01_起始页

Home > 00_起始页

midas Gen 2017

帮助文件

- General structure design system -

http://www.MidasUser.com

E-mail: BeiJing@MidasUser.com

MIDAS Information Technology China Co., Ltd.


01_新项目

Home > midas Gen 2017 > 01_文件 > 01_新项目

新项目

  • 功 能

创建新的项目

单击 保存，输入文件名并保存该文件。

  • 命 令

从主菜单选择文件 > 新项目...

在图标菜单中单击 新建

<快捷键>：[Ctrl]+N


02_打开项目

Home > midas Gen 2017 > 01_文件 > 02_打开项目

打开项目

  • 功 能

打开已有文件(文件名.mgb:MIDAS Gen Binary 二进制文件)该命令为标准的Windows命令。

注：mgt后缀的文件可以通过导入选项打开。

  • 命 令

从主菜单中选择文件 > 打开项目...

在图标菜单中单击 打开

快捷键：[Ctrl]+O

  • 用 法

选择打开项目后将弹出文件打开对话框，选择所需的文件，然后单击 。

文件打开对话框


03_关闭项目

Home > midas Gen 2017 > 01_文件 > 03_关闭项目

关闭项目

  • 功 能

关闭当前项目文件。

该命令为标准的Windows关闭命令。

如果工程数据经过修改, 关闭前就会弹出对话框，询问是否保存已作的修改。关闭当前项目文件后，程序会恢复默认的窗口。

  • 命 令

从主菜单中选择文件 > 关闭项目


04_项目信息

Home > midas Gen 2017 > 01_文件 > 04_项目信息

项目信息

  • 功 能

注册项目总信息(工程名称、用户名等)。

  • 命 令

从主菜单中选择文件 > 项目信息...

从树形菜单的菜单表单中选择环境设置 > 项目信息

  • 用 法

执行项目信息，在显示的对话框内注册项目相关信息。

在空白栏内填写相应的数据，然后单击 ，保存项目信息。

项目信息对话框

详细

点击该键将弹出所建立的模型的有关信息(如单元、节点数量、边界、荷载信息)。

项目的详细输入状况


05_保存

Home > midas Gen 2017 > 01_文件 > 05_保存

保存

  • 功 能

以项目文件形式保存当前工作。如果此前没有给项目文件赋名，提示同命令另存为...

  • 命 令

从主菜单中选择文件 > 保存

在图标菜单中单击 [image] 保存

快捷键： [Ctrl]+S


06_另存为

Home > midas Gen 2017 > 01_文件 > 06_另存为

另存为

  • 功 能

以另外一个文件名保存当前工作。

该功能为标准的Windows命令。

  • 命 令

从主菜单中选择文件 > 另存为...

  • 用 法

在弹出的 "另存为" 对话框中， 键入文件名及其目录，然后单击 。

另存为对话框


07_另存当前施工阶段为

Home > midas Gen 2017 > 01_文件 > 07_保存当前阶段为

另存当前施工阶段为

  • 功 能

在做施工阶段分析时，将在当前施工阶段定义的单元、边界以及荷载以另外一个文件名保存。

  • 命 令

从主菜单中选择文件 > 另存当前施工阶段为...

  • 用 法

在进入欲另存的施工阶段后点击"另存当前施工阶段为" 即弹出 "保存为" 对话框。键入文件名及其目录，然后单击 。

保存为对话框

提示:

1. 默认的文件名称为当前模型文件_施工阶段名称。

2. 另存的模型仅能自动保存该阶段的节点、单元、边界、荷载信息，不能自动保存该阶段的内力、截面特性值信息。所以当截面的特性发生变化时(如叠合截面)或需要考虑结构的初始几何刚度时，需要用户另存后进行编辑或修改。用户可在施工阶段分析后生成的.out文件中查看所需阶段的截面特性，在分析结果的内力表格中查找所需阶段的内力，将所得数据代入另存的模型中即可。


08_导入

Home > midas Gen 2017 > 01_文件 > 08_导入

导 入

  • 功 能

导入midas Gen文件MGB文件格式以外的文件。

  • 命 令

从主菜单中选择文件 > 导入 > midas Gen MGT 文件...

从主菜单中选择文件 > 导入 > AutoCAD DXF 文件...

从主菜单中选择文件 > 导入 > SAP2000(V6,V7) 文件...

从主菜单中选择文件 > 导入 > SAP2000(V8) 文件...

从主菜单中选择文件 > 导入 > STAAD2000 文件...

从主菜单中选择文件 > 导入 > STAAD2002 文件...

从主菜单中选择文件 > 导入 > MSC.Nastran 文件...

从主菜单中选择文件 > 导入 > Lusas DAT文件...

  • 用 法

midas Gen MGT 文件：导入midas Gen的文本格式文件MGT格式文件。

AUTOCAD DXF 文件：导入AUTOCAD DXF格式文件。

导入DXF文件对话框

提示:

在导入AutoCAD中建立的板单元时，注意检查导入的模型是否有重复节点或节点间距过小，避免分析时出现奇异。

SAP2000(V6，V7) 文件

将SAP2000数据文件(文件名.s2k)转换为MIDAS/Gen的MGT格式的文本文件后导入。此时文件名.s2k文件应为使用SAP2000的Export功能建立的文件。

将SAP2000文件转换为MIDAS/Gen数据文件时，存在以下局限性：

SAP2000 命令 | 细部命令 | 能否转换 | MIDAS/Gen的功能 | 限制
System | DOF | O | *结构类型 | -
 | LENGTH,FORCE | O | *单位体系 | -
 | CYC | O | - | 谐振稳态分析转换为静力分析
COORDINATE | - | O | - | -
JOINT | - | O | *节点 | 整体坐标系下数据均能转换，柱坐标系和球坐标系不能转换
LOCAL | ANG | O | *局部坐标系 | -
 | AXVEC,PLVEC | O | *局部坐标系 | -
RESTRAINT | - | O | *一般支撑 | -
CONSTRAINT(1) | - | O | *刚性连接 | -
WELD | - | X | - | -
PATTERN | - | O | - | -
SPRING | - | O | - | -
MASS | - | O | - | -
MATERIAL(2) | Isotropic | O | *材料 | -
 | Orthotropic | O | * 材料 | 只转换单轴方向
 | Anisotropic | O | * 材料 | 只转换单轴方向
FRAME SECTION(3) | Prismatic R,P,T,A,I,L,2L Shape Section | O | *截面 | -
 | Prismatic General Section | O | * 截面 | -
 | Prismatic Database Section | X | - | -
 | Nonprismatic Section | O | * 截面 | -
SHELL SECTION | - | O | *厚度 | -
NLPROP(4) | - | O | *弹性支撑 | -
 |  |  | *弹性连接
FRAME | GEN, DEL | O | *单元 | -
 | LOCAL, ANG, PLVEC | O | *单元 | -
 | IOFF, JOFF | O | *梁端刚域长度 | -
 | RIGID(5) | O | *梁端刚域长度 | 不能考虑1.0以外的数值，所以转换为1.0。
 | IREL, JREL | O | * 释放梁端约束 | -
SHELL | GEN, DEL | O | *单元 | -
 | ANG, PLVEC | X | - | -
PLANE | GEN, DEL | O | *单元 | -
 | 3、4节点单元 | O | *单元 | -
 | 9节点单元 | X | - | -
 | MATANG | X | - | -
ASOLID | GEN, DEL | O | *单元 | -
 | 3、4节点单元 | O | *单元 | -
 | 9节点单元 | X | - | -
 | MATANG, ARC | X | - | -
SOLID | GEN, DEL | O | *单元 | -
 | 6、8节点单元 | O | *单元 | -
 | MATANG | X | - | -
NLLINK(6) | 1节点单元 | O | *弹性支撑 | -
 | 2节点单元 | O | *弹性连接 | -
MATTEMP | - | O | - | -
REFTEMP | - | O | - | -
PRESTRESS | - | O | *预应力荷载 | -
荷载 | FORCE | O | *节点荷载 | -
 | RESTRAINT DISPLACEMENT | O | *支座强制位移 | -
 | SPRING DISPLACEMENT | O | *支座强制位移 | MIDAS中没有相应的命令，转换为相似的支座强制位移。
 | GRAVVITY(BEAM) | O | *梁单元荷载 | -
 | GRAVVITY(Shell) | O | *压力荷载 | -
 | GRAVVITY(Plane/Asolid/Solid) | X | - | -
 | CONCENTRATED SPAN | O | *梁单元荷载 | -
 | DISTRIBUTED SPAN | O | *梁单元荷载 | -
 | PRESTRESS | O | *预应力荷载 | -
 | UNIFORM | O | *压力荷载 | -
 | SURFACE PRESSURE | O | *压力荷载 | -
 | PORE PRESSURE | X | - | -
 | TEMPERATURE | O | *单元温度荷载 | -
 |  |  | *温度梯度荷载
 | ROTATE | X | - | -
PDFORCE | - | O | *几何刚度初始荷载 | -
PDELTA | - | O | *P-delta分析控制 | -
MODES | N, CUT, TOL | O | *特征值分析控制 | -
 | RITZ | O | *特征值分析控制 | -
 | SHIFT | X | - | -
 | NLLINK | X | - | -
FUNCTION | - | O | *反应谱函数 | 使用外部文件的函数文件应与*.s2k文件在同一文件夹内
 |  |  | *时程函数
SPEC | NAME, ANG, DAMP, F1, F2, DIRF, MODC(CQC, SRSS, ABS) | O | *反应谱函数 | -
 | MODC(GMC) | X | - | -
HISTORY | Linear Transient/Periodic Analysis | O | *时程荷载工况 | -
 | Nonlinear Transient Analysis | X | - | -
 | Acceleration Data | O | *地面加速度 | -
 | Load Data | O | *节点动力荷载 | -
LANE | - | O | *车道 | -
VEHICLE | DB Vehicle(7) | O | *车辆荷载 | -
 | User Define Vehicle | O | *车辆荷载 | 不能转换，任意转换为DB-24荷载并显示警告信息。
VEHICLE CLASS | - | O | *车辆荷载群 | -
BRIDGE RESPONSE | - | X | - | -
MOVING LOAD | NAME, RF, CLASS, LANE, LMIN, LMAX, SF | O | *移动荷载工况 | -
 | CALC | O | *移动荷载分析控制 | -
 | TOL, SET | X | - | -
COMBO | - | O | *荷载组合 | -

< 注释 >

1. CONSTRAINT

■ DIAPH、PLATE、ROD、BEAM Type的Constraint具有Auto Axis时，当前版本将Global Z轴作为Axis转换。

■ 在SAP中没有详细说明设定Master Node的方法。转换为MIDAS文件时，将Constraint的节点中距节点中心最近的节点作为Master Node。

■ 因为无法准确转换EQUAL和LOCAL，所以转换为MIDAS的Rigid Link，并输出警告信息。

2. MATERIAL

■ 在SAP中存在Weight Density和Mass Density。当用户在SAP中只输入了Mass Density时，转换时输出警告信息后将Mass Density转换为Weight Density (Weight Density = Mass Density * 重力加速度)

■ 用户在SAP中输入了Mass Density时，MIDAS自动将结构类型中的将结构的重量转换为质量设定为转换为X,Y,Z。

3. FRAME SECTION

■ 将SAP中的MPL(Mass Per Length)转换为相应单元的节点荷载。

■ 将SAP中的WPL(Weight Per Length)转换为相应单元的梁单元荷载，且将梁单元荷载包含在重力荷载工况中。

4. NLPROP

■ 当前版本中没有与SAP的NLLINK相应的单元。将NLLINK的NLPROP中的特性值取线性部分后转换为弹性连接(Elastic Link)。

■ 同时存在KE和K时，将KE转换为弹性连接(Elastic Link)的刚度。

■ 没有KE只有K时，将K转换为弹性连接(Elastic Link)的刚度。

KE和K均不存在时，将弹性连接(Elastic Link)的刚度设定为0。

5. RIGID

■ SAP中的RIGID命令使用方法为：首先设定Frame的Offset，然后设定Offset的Rigidity，即设定Factor。系数为1时表示Fully Rigid；0表示Fully Flexible。 当前版本的MIDAS中的梁端偏心设定只能反应Fully Rigid。

6. NLLINK

■ 因为MIDAS不能正确转换SAP的NLLINK，所以将1个节点的NLLINK转换为弹性支撑(Spring support)，2个节点的NLLINK转换为弹性连接(Elastic link)。

7. Load Data

§ 节点动力荷载是指作用于特定节点的荷载，就如在SAP 2000里分配的静力荷载。在静力荷载工况中有节点荷载时，荷载函数会分配到相应节点。如果在静力荷载工况中没有节点荷载，将不执行转换并生成一条警告信息。

8. DB Vehicle

■ 可以转换的数据库荷载 : COOPERE80, P5, P7, P9, P11, P13, AML

■ 不能转换的数据库荷载 : HL-93M, HL-93K, HL-93S, RL, HN-44, HSN-44, HN-44L, HSN-44L(临时转换为DB-24荷载后输出警告信息)。

SAP2000(V8) File

目标文件：由SAP2000(V8)的Export命令建立的*.s2k文件可以转化为Midas文件。

SAP2000命令 | 具体命令 | 能否转换 | MIDAS/Cen命令 | 说明
Joint | Summary - Joint Assignments | O | - |
 | Joint Coordinates | O | *NODE |
 | Joint Restraint Assignments | O | *CONSTRAINT |
 | Joint Local Axes Assignments 1 - Typical | O | *LOCALAXIS |
 | Joint Local Axes Assignments 2 - Advanced | O | *LOCALAXIS |
 | Joint Pattern Assignments(1) | O | - |
 | Joint Pattern Definitions(1) | O | - |
 | Joint Spring Assignments 1 - Uncoupled | O | *SPRING |
 | Joint Spring Assignments 2 - Coupled | O | *GSPRING *GSPRTYPE |
 | Joint Panel Zone Assignments | X | - 不适用 |
Frame | Summary - Frame Assignments | O |  |
 | Connectivity - Frame/Cable | O | *ELEMENT |
 | Frame Cable Assignments | X |  |
 | Frame Design Procedures | X |  |
 | Frame Insertion Point Assignments | O | *SECTION |
 | Frame Local Axes Assignments 1 - Typical | O | *ELEMENT |
 | Frame Local Axes Assignments 2 - Advanced | O | *ELEMENT |
 | Frame Material Temperatures | X | - 不适用 |
 | Frame NL Hinge Assignments | X |  |
 | Frame Offset Along Length Assignments(2) | O | *OFFSET |
 | Frame Output Station Assignments | X | - 不适用 |
 | Frame P-Delta Force Assignments | O | *INIFORCE |
 | Frame Prestress 1 - Patterns | O | *PRESTRESS |
 | Frame Prestress 2 - Load Multipliers | O | *PRESTRESS |
 | Frame Property Modifiers | O | *SECT-SCALE |
 | Frame Reference Temperatures | O | *ELTEMPER |
 | Frame Release Assignments 1 - General(3) | O | *FRAME-RLS |
 | Frame Release Assignments 2 - Partial Fixity(3) |  | *FRAME-RLS |
 | Frame Spring Assignments(4) |  | *SPRING |
 | Frame Auto Subdivision Assignments | X | - 不适用 |
 | Frame Tension And Compression Limits | X | - |
Area | Summary - Area Assignments | O |  |
 | Connectivity - Area(5) | O | *ELEMENT |
 | Area Auto Mesh Assignments | X | - 不适用 |
 | Area Local Axes Assignments 1 - Typical(6) | X | - Undefined |
 | Area Local Axes Assignments 2 - Advanced(6) | X | - Undefined |
 | Area Material Temperatures | X | - 不适用 |
 | Area Reference Temperatures | O | *ELTEMPER |
 | Area Spring Assignments(5) |  | *SPRING |
Solid | Summary - Solid Assignments | O | - |
 | Connectivity - Solid | O | *ELEMENT |
 | Solid Local Axes Assignments 1 - Typical(6) | X | - Undefined |
 | Solid Local Axes Assignments 2 - Advanced(6) | X | - Undefined |
 | Solid Material Temperatures | X | - 不适用 |
 | Solid Property Assignments | X | - 不适用 |
 | Solid Property Definitions | X | - 不适用 |
 | Solid Reference Temperatures | O | *ELTEMPER |
 | Solid Spring Assignments(4) | X | - Undefined |
 | Solid Auto Mesh Assignments | X | - 不适用 |
Link | Summary - Link Assignments | O | - |
 | Connectivity - Link | O | *ELASTICLINK, *NL-LINK |
 | Link Local Axes Assignments 1 - Typical | O | *ELASTICLINK, *NL-LINK |
 | Link Local Axes Assignments 2 - Advanced | O | *ELASTICLINK, *NL-LINK |
 | Link Property Definitions 01 - General | O | *NL-PROP |
 | Link Property Definitions 02 - Linear | O | *NL-PROP |
 | Link Property Definitions 03 - MultiLinear | X | - 不适用 |
 | Link Property Definitions 04 - Damper | O | *NL-PROP |
 | Link Property Definitions 05 - Gap | O | *NL-PROP |
 | Link Property Definitions 06 - Hook | O | *NL-PROP |
 | Link Property Definitions 07 - Rubber Isolator | O | *NL-PROP |
 | Link Property Definitions 08 - Sliding Isolator | O | *NL-PROP |
 | Link Property Definitions 09 -Plastic (Wen) | O | *NL-PROP |
 | Link Property Definitions 10 -Plastic (Kinematic) | X | - 不适用 |
 | Link Property Assignments | O | *NL-PROP |
 | Program Control | O | *UNIT |
MATERIAL | Material Properties 1 - General | O | *MATERIAL |
 | Material Properties 2 - Advanced |  | *MATERIAL | 各向异性的
 | Material Properties 3 - Design Steel | X | - |
 | Material Properties 4 - Design Concrete | X | - |
 | Material Properties 5 - Design Aluminum | X |  |
 | Material Properties 6 - Design ColdFormed | X |  |
SECTION | Frame Section Assignments | O | *SECTION |
 | Frame Section Properties 1 - General | O | *SECTION *SECT-SCALE |
 | Frame Section Properties 2 - Concrete Column | X |  |
 | Frame Section Properties 3 - Concrete Beam | X |  |
 | Frame Section Properties 4 - Auto Select | X |  |
 | Frame Section Properties 5 - Nonprismatic |  | *SECTION | 截面比例
Thickness | Area Section Properties | O | *THICKNESS |
 | Area Stiffness Modifiers | O | - 不适用 |
Static Load Case | Joint Loads - Force | O | *CONLOAD |
 | Joint Loads - Ground Displacement | O | *SPDISP |
 | Frame Loads - Distributed | O | *BEAMLOAD |
 | Frame Loads - Gravity(7) | O | *BEAMLOAD | 自动调整
 | Frame Loads - Point | O | *BEAMLOAD |
 | Frame Loads - Temperature(8) | O | *ELTEMPER *THERGRAD *NDTEMPER | 节点形式
 | Area Loads - Gravity(7) | O | *PRESSURE | 自动调整
 | Area Loads - Pore Pressure | X | - 不适用 |
 | Area Loads - Rotate | X | - 不适用 |
 | Area Loads - Surface Pressure | O | *PRESSURE |
 | Area Loads - Temperature(8) | O | *ELTEMPER,*THERGRAD |
 | Area Loads - Uniform To Frame | X | - Lack of data | - FLOADTYPE - FLOORLOAD
 | Area Loads - Uniform | O | *PRESSURE | 节点形式
 | Area Loads - Wind Pressure Coefficients | X | - Undefined |
 | Solid Loads - Gravity(7) | X | - Undefined | 自动调整
 | Solid Loads - Pore Pressure | X | - 不适用 |
 | Solid Loads - Surface Pressure | X | - Undefined |
 | Solid Loads - Temperature(8) | O | *ELTEMPER *THERGRAD |
 | Link Loads - Gravity(7) | X | - 不适用 |
 | Case - Static 1 - Load Assignments | O | *STLDCASE |
 | Load Case Definitions | O | *STLDCASE |
LOAD | Bridge Loads 1 - Lane Definitions | O | *LINELANE | - 两者 - 独立
 | Bridge Loads 2 - Standard Vehicles | O | *VEHICLE |
 | Bridge Loads 3 - General Vehicles 1 | O | *VEHICLE |
 | Bridge Loads 4 - General Vehicles 2 | O | *VEHICLE |
 | Bridge Loads 5 - Vehicle Classes | O | *VCLASS |
 | Bridge Loads 6 - Bridge Response | O | *VEHICLE |
 | Case - Moving Load 1 - Lane Assignments | O | *MVLDCASE |
 | Case - Moving Load 2 - Lanes Loaded | O | *MVLDCASE |
 | Case - Moving Load 3 - MultiLane Factors | O | *MVLDCASE |
 | Combination Definitions | O | *LOADCOMB |
Eigen Value Problem | Masses 1 - Mass Source | O | *LOADTOMASS |
 | Masses 2 - Assembled Joint Masses | X | - Generated after analysis |
 | Joint Added Mass Assignments | O | *NODALMASS |
 | Frame Added Mass Assignments(9) |  | *NODALMASS |
 | Area Added Mass Assignments(9) |  | *NODALMASS |
 | Case - Modal 1 - General | O | *EIGEN-CTRL |
 | Case - Modal 2 - Load Assignments - Eigen | X | - 不适用 |
 | Case - Modal 3 - Load Assignments - Ritz | O | *EIGEN-CTRL |
Response Spectrum Analysis | Function - Response Spectrum - BOCA96 | X | - 不适用 |
 | Function - Response Spectrum - EuroCode8 | O | *SFUNCTION |
 | Function - Response Spectrum - From File | X | - 不适用 |
 | Function - Response Spectrum - IBC2000 | O | *SFUNCTION |
 | Function - Response Spectrum - NBCC95 | O | *SFUNCTION |
 | Function - Response Spectrum - NEHRP97 | X | - 不适用 |
 | Function - Response Spectrum - NZS4203 | X | - 不适用 |
 | Function - Response Spectrum - UBC94 | O | *SFUNCTION |
 | Function - Response Spectrum - UBC97 | O | *SFUNCTION |
 | Function - Response Spectrum - User | O | *SFUNCTION |
 | Case - Response spectrum 1 - General(10) | O | *SPEC-CTRL *SPLDCASE |
 | Case - Response spectrum 2 - Load Assignments(10) | O | *SPLDCASE |
 | Case - Response spectrum 3 - Interpolated Damping | X | - 不适用 |
 | Case - Response spectrum 4 - Proportional Damping | X | - N/A |
 | Case - Response spectrum 5 - Damping Overrides | X | - N/A |
Analysis | Analysis Case Definitions | O | *ANAL-CTRL |
 | Active Degrees of Freedom | O | *STRUCTYPE |
 | Case - Static 2 - Nonlinear Load Application | X |  |
 | Case - Static 3 - Nonlinear Stage Information | X | - Lack of data | *STAGE
 | Case - Static 4 - Nonlinear Parameters | X | - Lack of data | *STAGE *NONL-CTRL
 | Case - Direct History 1 - General(11) | O | *THLDCASE |
 | Case - Direct History 2 - Load Assignments | O | *GROUND-ACC *DYN-SLOAD |
 | Case - Direct History 3 - Proportional Damping | O | *THLDCASE |
 | Case - Direct History 4 - Integration Parameters | X | - 不适用 |
 | Case - Direct History 5 - Nonlinear Parameters | O | *THLDCASE |
 | Case - Modal History 1 - General | O | *THLDCASE |
 | Case - Modal History 2 - Load Assignments | O | *GROUND-ACC *DYN-SLOAD |
 | Case - Modal History 3 - Interpolated Damping | X | - 不适用 |
 | Case - Modal History 4 - Proportional Damping | O | *THLDCASE |
 | Case - Modal History 5 - Damping Overrides | O | *THLDCASE |
 | Case - Modal History 6 - Nonlinear Parameters | O | *THLDCASE |
 | Case - Buckling 1 - General(12) | O | *BUCK-CTRL |
 | Case - Buckling 2 - Load Assignments | O | *BUCK-CTRL |
 | Case - Steady State 1 - General | X |  |
 | Case - Steady State 2 - Load Assignments | X |  |
Rigid Link | Joint Constraint Assignments(13) | O | *RIGIDLINK |
 | Constraint Definitions - Beam |  | *RIGIDLINK | - 自动轴
 | Constraint Definitions - Body | O | *RIGIDLINK |
 | Constraint Definitions - Diaphragm |  | *RIGIDLINK | - 自动轴
 | Constraint Definitions - Equal | O | *RIGIDLINK |
 | Constraint Definitions - Line | O | *RIGIDLINK |
 | Constraint Definitions - Local | X | - 不适用 |
 | Constraint Definitions - Plate |  | *RIGIDLINK | - 自动轴
 | Constraint Definitions - Rod |  | *RIGIDLINK | - 自动轴
 | Constraint Definitions - Weld | O | *RIGIDLINK |
Time History Functions | Function - Time History - Cosine | X | - 不适用 |
 | Function - Time History - From File | O | *TFUNCTION |
 | Function - Time History - Ramp | X | - 不适用 |
 | Function - Time History - Sawtooth | X | - 不适用 |
 | Function - Time History - Sine | X | - 不适用 |
 | Function - Time History - Triangular | X | - 不适用 |
 | Function - Time History - User | O | *TFUNCTION |
 | Function - Time History - User Periodic | X | - 不适用 |
COMBO | Groups 1 - Definitions | X |  |
Output | Groups 2 - Assignments | X | - Lack of data | *GROUP *BNDR-GROUP
END | Groups 3 - Masses and Weights | X |  |

注

1. 节点形式

☐ 目前，该形式用于单元温度荷载、温度梯度、面荷载。

2. 梁端刚域

No 刚度系数功能
注
转化为完全刚域。

3. 释放梁端约束

SAP通过输入部分约束刚度而MIDAS通过输入释放梁端约束模拟铰。
注
转化为完全固定。

4. 单元弹簧

框架弹簧分配：转化为节点弹簧。

面弹簧分配：转化为节点弹簧（只针对局部坐标轴的5、6面）。

实体弹簧分配：因为没有定义局部坐标轴，所以不转化。

5. 面单元

SAP2000(V8) |  |  | MIDAS/Gen |  | 说明
类型 | 子类型 |  | 单元 | 子类型
壳 | 壳 | 厚壳 | 平面应力(5-1) | 厚板 |
 |  | 薄壳 |  | 薄板 |
 | 膜 |  | 平面应力(5-2) |  |
 | 板 | 厚板 | 板 | 厚板 | 相同的单元特性
 |  | 薄板 |  | 薄板
平面单元 | 平面应力 |  | 板 | 平面应力 | 相同的单元特性
 | 平面应变 |  |  | 平面应变
轴对称 |  |  | 轴对称单元 |  | 相同的单元特性

5-1. 在SAP 2000中，壳单元综合了膜单元和板单元的特性在x、y、z方向既有平移自由度又有转动自由度（单元坐标系）。因为MIDAS/Gen中没有壳单元，所以将其转化为板单元。

5-2. 在SAP 2000中，膜单元具有两个面内平移自由度和一个垂直于平面的转动自由度。但是，膜单元在MIDAS中只能转化为只有两个面内平移自由度的平面应力单元。

6. 局部坐标轴

平面局部坐标轴：SAP - 默认：与整体坐标轴相同。

MIDAS - 默认: 根据节点顺序定义局部坐标轴。

 | SAP2000 (default:GLOBAL) | MIDAS/Gen
Ex(1) |  |
Ex(2) |  |

7. 重力荷载

☐ 框架：转化为梁单元荷载。(如果 self modifier > 0, 自重同样适用。)

☐ 平面: 转化为压力荷载。(因为没有定义局部坐标轴，只能转化全局坐标系的5、6平面。)

☐ 实体: 因为没有定义局部坐标轴，所以不能转化。

8. 温度荷载

☐ 框架温度荷载：如果节点形式存在，则转化节点温度荷载；如果是节点形式的平均，则转化为单元温度荷载。

☐ 框架温度梯度 ：Neglect Pattern if Joint Pattern exists.

☐ 平面温度荷载：如果节点形式存在，则转化为节点温度荷载；如果是节点形式的平均，则转化为单元温度荷载。

☐ 平面温度梯度：Neglect Pattern if Joint Pattern exists.

☐ 实体温度荷载：如果节点形式存在，则转化为节点温度荷载；如果是节点形式的平均，则转化为单元温度荷载。

9. 添加质量

☐ 框架添加质量 -> 转化为节点质量。

☐ 平面添加质量 -> 转化为节点质量。

10. 反应谱分析控制

☐ 在SAP中，每个反应谱分析荷载工况可以有多个分析控制，但是在MIDAS中，只能有一个分析控制，所以只有第一个分析控制被转换。

11. 时程荷载工况

☐ 在直接积分分析方法中，只有Newmark法的参数能够转换。

12 屈曲分析控制

☐ 在SAP中，每个荷载工况可以有多个屈曲分析控制，但是在MIDAS中，只能有一个分析控制，所以只有第一个分析控制被转换。

☐ 只有在SAP中，荷载类型为?荷载工况?时才会转换。

13. 刚性连接

☐ 主节点被分配给第一从节点。

☐ 对于膜和板单元，质量集中的节点（质量中心）作为主节点。

☐ 梁、膜、板和杆：在处理自动轴信息后，刚性连接不进行转换。

14. 综合

- 释放板端约束和释放梁端约束不能同时进行转换。

释放梁端约束的全局类型和单元类型不能同时进行转换。

- 框架自动划分

☐ 不转换

- 平面自动分网

☐ 不转换

STAAD2000/2002 文件

1. 需要转换的目标文件(*.std)必须是由STAAD程序打开和保存的文件。

2. 不支持缩写命令。(例如： SECTION => SEC 不支持)

3. 在当前版本中，转换仅限于静力分析。

STAAD 命令 | 具体命令 | 能否转换 | 限制条件 | MIDAS/Gen 命令
Unit | - | O | 转换为常用单位体系（牛顿、米） | *UNIT
Joint Coordinate | JOINT COORDINATE | O | - | *NODE
 | JOINT COORDINATE CYLINDRICAL Or CYLINDRICAL REVERSE | X | 待完善
 | REPEAT | O | -
 | REPEAT ALL | O | -
Member Incidence | MEMBER INCIDENCE | O | 如果壳和实体具有相同的ID，则将显示警告信息，重新分配ID，然后进行转换 | *ELEMENT (梁和桁架)
 | REPEAT | O
 | REPEAT ALL | O
Element Incidence (Shell) | ELEMENT INCIDENCE (SHELL) | O | 如果构件和实体具有相同的ID，则将显示警告信息，重新分配ID，然后进行转换 | *ELEMENT (板、平面应力)
 | REPEAT | O
 | REPEAT ALL | O
Element Incidence Solid | ELEMENT INCIDENCE SOLID | O | 如果构件和实体具有相同的ID，则将显示警告信息，重新分配ID，然后进行转换 | *ELEMENT (实体)
 | REPEAT | O
 | REPEAT ALL | O
Element Mesh Generation | - | X | - | -
Redefined of Joint and Member Numbers | - | X | - | -
Groups | GEOMETRY | O | 具有相应ID的节点和单元转化为MIDAS的组命令 | *GROUP
 | JOINT | O | -
 | MEMBER | O | -
 | ELEMENT | O | -
 | SOLID | O | -
Rotate of Structure Geometry | - | X | - | -
Inactive/Delete Specification | - | X | - | -
Start User Table | External File Name | X | 使用文件定义的用户截面表格不进行转换 | -
 | TYPE | O | - | *SECTION
 | NAME | O | -
 | PROPERTY | O | -
Member Properties | DB Section |  | 只有AISC码的数据库才能转换 | -
 | PRISMATIC | O | 如果截面特性(AX、AY、AZ、IX、IY和IZ)的值存在则转化为数值类型的截面特性。 梯形截面转化为矩形截面 | *SECTION
 | TAPERED | O | -
 | UPTABLE | O | 使用文件输入的用户表不能转换。
 | ASSIGN | X | 不能转换为在分析和设计完成后自动分配的命令。 在显示警告信息(assign #1)后，分配给相应单元任意ID。 | -
Element Properties | - | O | 只有f1能够转换。 如果存在f2～f4（单元其它节点的厚度）将显示警告信息。 | *THICKNESS
Define Material | E, G, POISSON, DENSITY, ALPHA | O | 只有在CONSTANT命令中使用的材料才能转化，转换后将分配任意的材料名称和ID。 | *MATERIAL
 | DAMPING,CDAMP | X | -
Constant | E, G, POISSON, DENSITY, ALPHA | O | 只有在CONSTANT命令中使用的材料才能转化，转换后将分配任意的材料名称和ID。混凝土、钢和铝材料转化为数值。 | *MATERIAL
 | CDAMP | X | - |
 | BETA, REF, REFJT | O | - |
Member Truss | - | O | - | *ELEMENT
Member Cable | - | O | - | *ELEMENT
Member Tension | - | O | - | *ELEMENT
Member Compression | - | O | - | *ELEMENT
Element Plane Stress(1) | - | O | 分配的单元类型为平面应力单元。 | *ELEMENT
Element Ignore (Inplane Rotation)(1) | - | O | - | *ELEMENT
Support | INCLINED | X | 待完善。 | -
 | FOOTING | X | - | -
 | ELASTIC MAT | X | - | -
 | FX, FY, FZ, MX, FY, MZ | O | - | *CONSTRAINT
 | KFX, KFY, KFZ, KMX, KMY, KMZ | O | - | *SPRING
Member Offsets | LOCAL | X | - | -
 | GLOBAL | O | 显示警告信息，并转化为DB24车辆荷载。 | *OFFSET
Member Release | Partial Moment Release | X | - | -
 | Release other than Partial Moment | O | - | *FRAME-RLS
Master / Slave | - | O | 如果在XRANGE, YRANGE和ZRANGE分配了从节点，不能转换。(待完善) | *RIGIDLINK
Loading | - | O | MIDAS需要为荷载工况命名。MIDAS默认为转化的荷载工况命名为DC荷载工况。 | *STLDCASE
Joint Load | - | O | - | *CONLOAD
Member Load | UNI or UMOM | O | f4值(从构件剪切中心到加载平面的垂直距离)不转化。 沿X、Y和Z轴(局部坐标轴)输入的荷载不转化全局坐标轴的荷载。 | *BEAMLOAD
 | CON or CMOM | O |  | *BEAMLOAD
 | LIN | O |  | *BEAMLOAD
 | TRAP | O |  | *BEAMLOAD
Element Load | PRESSURE | O | 只输入x1和y1的单元集中荷载不转化。 输入x1、y1、x2和y2的单元特定点的荷载不转化。 | *PRESSURE
 | TRAP | O | - | *PRESSURE
Area Load | - | X | - | -
Floor Load | - | X | - | -
Prestress Load | PRESTRESS | O | - | *PRESTRESS
 | POSTSTRESS
Fixed End Load | - | X | - | -
Support Displacement | - | O | - | *SPDISP
TEMPERAURE LOAD | - | X | - |
SELFWEIGHT | - | O | - | *SELFWEIGHT
SPECTRUM | - | X | 待完善。 |
TIME LOAD | - | X | 待完善。 |
REPEAT LOAD | - | X |  |
LOAD GENERATION | - | X |  |
UBC LOAD | - | X |  |
WIND LOAD | - | X |  |
CALCULATE NATURAL | - | X | 待完善。 |
MODAL | - | X | 待完善。 |
LOAD COMBINATION | Linear Combination | O | - | *LOADCOMB
 | SRSS | O | 如果荷载工况号为负号，SRSS和线性作合同时存在。在这种情况下，SRSS组合和线性组合分别形成新的荷载组合(LCBSRSS和LCBADD)。

注

1. 壳单元

STAAD2000/2002 |  | MIDAS/Gen |  | 说明
单元 | 类型 | 单元 | 类型
壳 | 默认 | Plate(1-1) | 薄板 |
 | 平面应力 | 平面应力 |  | 相同的单元特性。
 | 忽略面内旋转 | Plate | 厚板 | 相同的单元特性。

1-1. 在STAAD 2000中，壳单元既有沿单元坐标系x、y和z轴的平移自由度，又有绕单元坐标系x、y和z轴的转动自由度。MIDAS/Gen中没有相应的单元，所以用板单元代替。


09_导出

Home > midas Gen 2017 > 01_文件 > 09_导出

导 出

  • 功 能

使用midas Gen的文件格式MGB以外的格式保存当前项目。

  • 命 令

从主菜单中选择文件 > 导出 > midas Gen MGT 文件...

从主菜单中选择文件 > 导出 > MXT文件（for FEA/GTS）...

从主菜单中选择文件 > 导出 > AutoCAD DXF 文件...

从主菜单中选择文件 > 导出 > 由框架单元生成实体单元...

从主菜单中选择文件 > 导出 > 由框架单元生成板单元...

从主菜单中选择文件 > 导出 > midas Gen Designer MGF文件...

从主菜单中选择文件 > 导出 > IFC文件...

  • 用 法

midas Gen MGT 文件

以MIDAS/Gen的文本格式文件文件名.MGT保存当前模型数据。

MXT 文件(for FEA/GTS)

保存模型数据为MXT文件，Gen模型中包含节点、单元、截面特性、边界、荷载和分析控制数据等都可以导入到FEA和GTS中，用于细部分析，以及结构和下部土体的协同分析等。

注意：FEA中不支持截面数据，导入后为用户自定义截面。索单元导入后变为桁架单元。

AutoCAD DXF 文件

将模型数据保存为AutoCAD DXF格式文件。

把模型导出为DXF格式文件对话框

提示:

此命令仅能导出模型形状文件(模型尺寸真实)，如果要导出分析结果的DXF文件，可按下列步骤操作:

1. 文件>图形文件（.emf）。

2. 工具>转换EMF文件为DXF文件(包含文字时，模型尺寸按比例自动调整)。

由框架单元生成实体单元

将模型中框架单元转换为实体单元，同时导出钢束形状，以便在另一款高端有限元分析软件midas FEA中调用数据进行细部分析。

由框架单元生成实体单元

目标单元：选择单元用于导出。如果被选择的单元已经指定了变截面组，选择之前应先将其转换为变截面。

分割单元：输入单元分割数量。如果钢束形状有显著变化，建议增加分割数量。

钢束形状：与框架截面信息一同导入。

由框架单元生成板单元

利用框架截面信息，生成面几何文件，用于导入到FEA中进行详细分析。

由框架单元生成板单元

目标单元：选择单元用于导出；

其它框架单元：其它框架单元与框架单元在质心处连接，截面保存为数据类型。

强制位移：选择荷载工况或荷载组合，将其位移结果作为强制位移用于详细分析。只有分析结束后才能设置。

midas Gen Designer MGF文件

保存MGF文件，用于导入到Gen Designer中进行设计。

IFC文件

保存模型数据为IFC文件。

注意：IFC文件中仅包含几何数据，如截面数据，单元类型以及单元尺寸。不包含荷载，边界条件以及分析控制数据。

不支持联合截面。


10_数据交换

Home > midas Gen 2017 > 01_文件 > 10_数据交换

数据交换

  • 功 能

该命令用于将MIDAS/Gen中的模型数据和分析结果导入到MIDAS/SDS中，或反过来。MIDAS/SDS是一套专门用于楼板、筏基、桩基等结构的分析设计软件。在结构分析设计中，主体结构、楼板、基础一般都是分开进行的。所以在这种情况下，做完其中一种分析后，就需要将其分析后的数据导入到其他分析中，这个命令的功能就是为此设计的。它主要用于有平面板及非常规剪力墙的钢筋混凝土结构。

MIDAS/Gen 数据交换有以下功能：

  1. 提取MIDAS/Gen 框架结构的模型数据并转化为MIDAS/SDS模型数据。（MIDAS/Gen->MIDAS/SDS,模型数据)。程序自动计算框架中和楼板相连的梁，柱，斜撑和墙的等效刚度，并按照弹性支撑条件添加到楼板分析模型中。对于筏板基础的分析，墙单元会按照刚度等效原则转化成梁单元，弹性支承刚度并不自动生成。
  2. MIDAS/SDS板分析得到的反力数据会作为荷载数据自动导入到MIDAS/Gen中（MIDAS/SDS->MIDAS/Gen,荷载数据)。
  3. 由MIDAS/Gen 计算得到的支承反力将自动导入到MIDAS/SDS中作为荷载数据，进行筏板基础分析。（MIDAS/Gen->MIDAS/SDS,反力数据)。

为进行数据转换，需要在转换之前定义楼层数据。

框架模型中可以转化为楼板模型中的单元包括同一平面内的梁单元，与平面相连的梁单元，桁架单元，柱单元或斜撑单元。板单元及分析数据需要在MIDAS/SDS中进行定义。

如下为从MIDAS/Gen 框架模型转换到MIDAS/SDS 楼板模型时生成的数据。

MIDAS/Gen data | MIDAS/SDS data
单位体系数据 | 使用 MIDAS/ GEN单位体系
节点 | 在相应位置上自动生成节点
柱或支撑的轴向刚度 | 根据柱支承的相应位置自动生成点弹性支承。
柱或支撑的弯曲刚度 | 生成SRx & SRy数据.
墙单元轴向刚度 | 生成SDz数据以及墙支撑位置的梁单元。
墙单元弱轴向刚度 | 生成SR数据。
梁单元 | 生成相同材料和横截面的梁单元

注意：
1.对于墙单元、为连接墙端节点，程序会自动生成与墙单元刚度等效的梁单元。以保证竖向线弹簧（线弹性支承）的连续性，
2.MIDAS/SDS特点可参见MIDAS/SDS在线帮助文件。
MIDAS/SDS分析完成时，MIDAS/GEN中节点荷载数据会再次通过数据转换生成。

MIDAS/SDS楼板分析模型中的反力数据，转换为MIDAS/GEN中节点荷载（竖向集中荷载或弯矩）的方法如下：

表示柱或斜撑构件的节点弹性支承反力转换为MIDAS/GEN中的节点荷载（竖向集中荷载或弯矩）。

表示墙单元的线弹性支承反力转换为墙端节点反力。

MIDAS/GEN中的支座反力转换成MIDAS/SDS中集中荷载的方法如下：

MIDAS/Gen 数据 | MIDAS/SDS 数据
静力荷载工况 | 生成静力荷载工况，采用与MIDAS/Gen相同的静力荷载工况
荷载数据 | 自动转换为节点集中荷载 FZ: 整体坐标系Z轴方向荷载 Mx: 整体坐标系X轴方向弯矩 My: 整体坐标系Y轴方向弯矩

文件>数据转换>MIDAS/Gen—>MIDAS/SDS(模型+反力数据)
文件>数据转换>MIDAS/SDS—>MIDAS/Gen（荷载数据）

将MIDAS/Gen模型转化为MIDAS/SDS模型。可以生成MIDAS/SDS楼板模型或筏板基础分析模型。

MIDAS/Gen 模型转换到 MIDAS/SDS 模型的对话框

MIDAS/SDS文件名称( *.MST)
输入MIDAS/SDS 模型数据文件名称，会生成一个文本文件。
转换成楼板/筏板基础
选择转换成MIDAS/SDS楼板或筏板模型数据
选择需要转换到MIDAS/SDS的楼层
选择一个MIDAS/Gen模型中的楼层，转换为MIDAS/SDS 模型
如需生成筏板基础模型，选择最底层（base）楼板
抗弯刚度系数
输入单元的抗弯刚度系数 ，如生成筏板基础模型，无需输入。
注意:
如果已经通过数据转换生成楼板模型，柱和墙的弹性支承刚度会自动计算，方法如下：
轴向刚度
计算轴向刚度时，需考虑层高。

弹性模量
截面面积
楼层高度
抗弯刚度
计算抗弯刚度时考虑了楼板上、下层的层高

Where,
: 考虑相邻上、下层外竖向构件的刚度修正因子
上、下层构件的弹性模量
上、下层构件的抗弯惯性矩
上、下层层高
“ [image] ”代表单元的抗弯刚度，与结构总的楼层数、所考虑楼板的位置、连接条件等有关。对于一个多层建筑，一般需要用到如下表格数据。
对于斜撑，忽略其刚度的水平分量，仅考虑竖向分量。对墙单元，考虑弱轴方向的抗弯刚度。
计算得到的柱单元和斜撑单元的轴向和抗弯刚度将被转换成相应位置处的节点弹性支撑。对于墙单元，刚度按墙端之间的线弹性支承计算。

为了确保墙端点之间的连续性，会增加额外的梁单元。
程序计算的节点弹性支承的反力数据，通过数据转换自动转换为框架模型的节点集中荷载。线弹性支承的反力数据则转换为墙单元端部的等效集中荷载。

- | 屋顶 | 屋顶层-1 | 屋顶层-2 | 屋顶层-3 | 屋顶层-4 | 屋顶层-5 | 屋顶层-6 | 屋顶层-7 | 屋顶层-8 | 屋顶层-9 | 屋顶层-10
1层结构 | 4.0 | - | - | - | - | - | - | - | - | - | -
2层结构 | 4.7 | 7.0 | - | - | - | - | - | - | - | - | -
3层结构 | 4.3 | 13.0 | 4.4 | - | - | - | - | - | - | - | -
4层结构 | 4.4 | 10.8 | 5.7 | 4.9 | - | - | - | - | - | - | -
5层结构 | 4.4 | 11.3 | 5.3 | 6.7 | 4.7 | - | - | - | - | - | -
6层结构 | 4.4 | 11.2 | 5.4 | 6.1 | 6.4 | 4.8 | - | - | - | - | -
7层结构 | 4.4 | 11.2 | 5.4 | 6.3 | 5.9 | 6.5 | 4.8 | - | - | - | -
8层结构 | 4.4 | 11.2 | 5.4 | 6.2 | 6.0 | 5.9 | 6.5 | 4.8 | - | - | -
9层结构 | 4.4 | 11.2 | 5.4 | 6.2 | 6.0 | 6.1 | 5.9 | 6.5 | 4.8 | - | -
10层结构 | 4.4 | 11.2 | 5.4 | 6.2 | 6.0 | 6.0 | 6.0 | 5.9 | 6.5 | 4.8 | -
大于10层的结构 | 4.4 | 11.2 | 5.4 | 6.2 | 6.0 | 6.0 | ... | 6.0 | 5.9 | 6.5 | 4.8

柱、斜撑和墙单元的抗弯刚度因子
对于10层以上的结构，对于第二层到第四层，屋顶层-4到屋顶楼层，采用上表中数据，5层到屋顶层-5采用6.0.
* 假定
所有楼层层高均相同。
所有层柱子或墙的横截面面积都相同。
不考虑楼板厚度和柱帽。

MIDAS/Gen反力数据转换为MIDAS/SDS荷载对话框
注意
如果已经选择了转换为基础，从MIDAS/Gen框架模型分析后得到的反力转换成MIDAS/SDS模型的荷载数据。 MIDAS/GEN模型各荷载工况（包括反应谱荷载）的反力将自动转换为节点荷载。因而，荷载组合过程中删除的符号需要重新生成。
（参见“反应谱分析控制”）

把MIDAS /SDS反力转换成 MIDAS/GEN的节点载荷
由MIDAS/SDS楼板分析得到的反力结果转换成MIDAS/GEN框架模型的荷载数据。
MIDAS/SDS 文件名称(*.SA1, *.BN2)
输入MIDAS /SDS楼板分析模型的名称。
选择楼层节点
将MIDAS/SDS楼板分析的反力转换为MIDAS/GEN框架结构模型的荷载数据。选择要施加荷载的楼层，可以选择多个楼层。


11_合并数据文件

Home > midas Gen 2017 > 01_文件 > 11_合并数据文件

合并数据文件

  • 功 能

合并当前模型数据文件和其它模型数据文件。

提示：该功能在合并文件数据时不能合并荷载数据。

  • 命 令

从主菜单中选择文件 > 合并数据文件...

  • 输 入

合并数据文件对话框

数据文件名

输入要与当前文件组合的模型数据的文件名(文件名.mgb) ，单击 选择路径和文件名。

节点、单元、材料、截面、板厚

选择并指定要合并的模型数据的类型。如果材料、截面、厚度的编号重叠，将把合并进来的数据按当前数据编号最大值+1后自动重新编号。

建立组：将合并的模型数据定义为组(Group)

名称：组名称(如果不指定名称，程序将自动定义组名称为模型文件名)。

重新编号：

当前模型的节点和单元编号保持不变，将合并进来的数据按当前数据编号最大值+1后自动重新编号。

用下列功能修改编号：

节点起始号：

指定合并进来的模型数据的开始节点号,默认编号为当前模型中编号最大值+1。单击 修改选项，可以选择其它方式输入开始节点号。

单元起始号：

指定合并进来的模型数据的开始单元号,默认编号为当前模型中编号最大值+1。单击 修改选项，可以选择其它方式输入开始单元号。

原点和旋转角度：

按当前模型的整体坐标系指定合并进来的模型的位置。

原点

在当前模型的整体坐标系中输入准备合并进来的模型的原点位置坐标。

Rx:输入相对于当前整体坐标系X轴的旋转角度。

Ry:输入相对于y'轴的旋转角度，y'轴由前次Y轴随X轴旋转Rx得到。

Rz:输入相对于z"轴的旋转角度，z"轴由前两次Z轴随X轴和y'轴旋转Rx和Ry得到。

容许误差

合并重复节点：选择当前节点和合并进来的节点重叠时是否合并。单击 输入容许误差(合并容许误差)，以确定合并条件。

用交叉点分割单元：选择当前线单元和合并进来的线单元(桁架单元，梁单元)在交叉点处是否分割成线单元。单击 输入容许误差(判断相交时两条线之间的交叉公差)。


13_输出模型数据文本文件

Home > midas Gen 2017 > 01_文件 > 12_模型数据文本输出

输出模型数据文本文件

  • 功 能

输出模型的各种数据文本文件。

  • 命 令

从主菜单选择文件 > 输出模型数据文本文件

输出模型数据文本文件

模型数据文本文件

文件
选择输出文本保存的路径和文件名称。只要点击 [image] 即可。
输出选项
选择需要输出的数据
输出所有项目：输出所有数据
选择输出项目: 用户选择需要输出的数据
输入数据
注意
根据模型数据输出文件中的泊松比计算并显示剪切模量


14_打印

Home > midas Gen 2017 > 01_文件 > 13_打印

打 印

  • 功 能

打印各种格式的文本和图形(模型图，渲染图，图表等)

该命令为标准的Windows的打印命令。

  • 命 令

从主菜单中选择文件 > 打印...

在图标菜单中单击 [image] 打印...

快捷键：[Ctrl]+P

  • 用 法

选择并激活包含相应内容的窗口，然后执行打印命令。

打印对话框出现后，定义打印机，打印范围，打印份数等，然后按 [image] 。

打印命令的执行是按程序默认打印环境的设定进行的。建议在打印前用打印预览命令查看，修改和调整打印目标。

打印对话框


15_打印预览

Home > midas Gen 2017 > 01_文件 > 14_打印预览

打印预览

  • 功 能

预览要打印的图形文件或文本数据，查看、调整打印内容并执行打印。

  • 命 令

从主菜单中选择文件 > 打印预览...

在图标菜单中单击 [image] 打印预览...

  • 用 法

执行打印预览命令将显示打印状态。打印内容可以用对话框和鼠标随意重新安排位置。

打印预览窗口

/ [image] ：放大或缩小打印预览窗口。

：选择是否打印矩形轮廓线(开/关)。

水平对齐方式：

：水平中心对齐

：水平左端对齐

：水平右端对齐

垂直对齐方式：

：垂直中心对齐

：垂直顶端对齐

：垂直底端对齐

左侧页边距(mm)

上部页边距(mm)

宽度(mm)：打印区域的水平范围。

高度(mm)：打印区域的垂直范围。

固定比例：维持初始的垂直/水平显示长度比(开/关)。

对齐纸张：放大或缩小打印目标以适应纸张大小(开/关)。

用鼠标选择打印目标的图面布置位置和大小

将鼠标置于打印目标上，按住鼠标左键并拖动鼠标调整图的位置。

将鼠标置于图的四角之一或四边之一的中心，这时指针变为箭头( [image] 或 [image] )，按住鼠标左键并将鼠拖向箭头所指方向，就改变了图面在该方向的大小。

完成打印设置后，单击 [image] 弹出打印对话框。 指定打印机、打印范围、打印份数等，然后单击 [image] 。


16_设置打印机

Home > midas Gen 2017 > 01_文件 > 15_打印设置

设置打印机

  • 功 能

指定打印机和打印纸的型式。

该命令为标准的Windows的打印设置命令。

  • 命 令

从主菜单中选择 文件 > 设置打印机...

  • 用 法

出现打印设置对话框后，指定打印机和打印方向等，然后单击 保存设置。

打印设置对话框


17_生成图形文件

Home > midas Gen 2017 > 01_文件 > 16_图形文件

图形文件

  • 功 能

利用此功能可以将模型窗口的图形数据按以下5种格式的图形文件保存：

1.*.emf 2.*.bmp 3.*.jpg 4.*.dxf 5.*.dwg

  • 命 令

主菜单中选择文件 > 图形文件...

打开保存图形文件对话框，将图形数据保存为指定样式。

输入“文件名称”，选择需要保存的类型，点击“保存”按钮进行保存。

注：

emf 文件具有与缩放比例无关却能保持图像清晰度的优点。然而当图像文件变得复杂时，缩放需要花很长时间。打印emf文件时，建议在后处理中尽可能不使用梯度填充功能。

bmp是位图文件(Bitmap),在缩放图像的过程中，图像质量稍微会有些降低。不过，处理文件所需要的时间只与文件大小有关，而与其复杂程度无关。

jpg是清晰度高、压缩量大的图形文件。

dxf是Autocad软件的文件格式,可以在CAD中打开并编辑。

dwg是Autocad软件的文件格式,可以在CAD中打开并编辑。

因此，建议根据文件的用途采用适当的格式保存。


18_打印EMF文件

Home > midas Gen 2017 > 01_文件 > 17_打印图元文件

打印图形文件

  • 功 能

连续打印已保存的Windows Meta文件(文件名.EMF)。

  • 命 令

从主菜单中选择文件 > 打印EMF文件...

  • 用 法

输出EMF文件对话框

输出EMF文件对话框使用步骤

首先单击 [image] 添加要打印的图像文件，然后在 [image] 中确认打印选项，并单击 [image] 按顺序打印所有被选中的图像文件。

在Meta文件列表中选择相应文件，单击 [image] 或双击文件标中的文件名，相应的文件就显示在左边的预览窗口中。

注：需要同时打印大量图像文件(*.EMF)时，可采用打印EMF文件，其优点是按顺序打印的各个文件之间时没有间隙时间。可以用浏览器选择要打印的图像文件后，用鼠标将其拖入添加到打印列表中。


01_重画

Home > midas Gen 2017 > 02_视图 > 01_动态视图 > 01_重画

重 画

  • 功 能

刷新屏幕，清除所执行的命令痕迹。这些痕迹是由于Windows程序的特性而残留在屏幕上的。

  • 命 令

从主菜单中选择视图 > 重画

在图标菜单中单击 [image] 重画

快捷键：[F3]


02_初始画面

Home > midas Gen 2017 > 02_视图 > 01_动态视图 > 02_初始视图

初始视图

  • 功 能

将窗口恢复至初始状态，即第一次打开文件时的窗口状态。

  • 命 令

从主菜单中选择视图 > 初始视图

在图标菜单中单击 [image] 初始画面

快捷键： [Ctrl]+[F3]


07_前次视图状态

Home > midas Gen 2017 > 02_视图 > 01_动态视图 > 03_前次视图

前次视图状态

  • 功 能

将模型空间窗口恢复为执行视图处理(缩放，移动，视点，透视图等)前的状态。

  • 命 令

从主菜单中选择视图 > 前次视图状态

在图标菜单中单击 [image] 前次视图

快捷键：[Ctrl]+B


03_动态视图

Home > midas Gen 2017 > 02_视图 > 01_动态视图 > 04_动态

动态视图

  • 功 能

动态视图功能通过鼠标的移动来实现模型视图的伸缩、移动和旋转，如果将其与 [image] 渲染视图结合使用，用户可以漫游(漫游效果)或鸟瞰结构(鸟瞰效果)。

  • 命 令

从主菜单中选择视图 > 动态视图 > 缩放

从主菜单中选择视图 > 动态视图 > 移动

从主菜单中选择视图 > 动态视图 > 旋转

在图标菜单中单击 [image] 动态缩放

在图标菜单中单击 [image] 动态移动

在图标菜单中单击 [image] 动态旋转

  • 用 法

动态缩放

点击动态缩放命令后，按住鼠标左键，在工作窗口中向上或向右移动鼠标将放大模型。按住鼠标左键，在工作窗口中向下或向左移动鼠标将缩小模型。

<图1> 动态缩放

动态平移

按住鼠标左键移动鼠标，在同一方向上模型将以相同距离移动。

<图2> 动态移动

动态旋转

按住鼠标左键，向左或向右移动鼠标，模型分别绕GCS Z轴顺时针或逆时针旋转。

按住鼠标左键，向上或向下移动鼠标，模型分别绕水平方向顺时针或逆时针旋转。

<图3> 动态旋转


04_缩放

Home > midas Gen 2017 > 02_视图 > 01_动态视图 > 05_缩放

缩 放

  • 功 能

放大或缩小模型空间中的模型。

  • 命 令

从主菜单中选择视图 > 缩放 > 对齐

从主菜单中选择视图 > 缩放 > 窗口

从主菜单中选择视图 > 缩放 > 放大

从主菜单中选择视图 > 缩放 > 缩小

从主菜单中选择视图 > 缩放 > 自动对齐

在图标菜单中单击 [image] 对齐

快捷键： [Ctrl]+0

在图标菜单中单击 [image] 窗口缩放

在图标菜单中单击 [image] 放大

快捷键： [Ctrl]+ +

在图标菜单中单击 [image] 缩小

快捷键： [Ctrl]+ - 或者 [Ctrl]+[Insert]

在图标菜单中单击 [image] 自动对齐

  • 用 法

对齐

单击相关菜单或图标，放大或缩小当前处于激活状态的模型，使整个模型充满工作窗口。

窗口

单击鼠标左键，点取形成矩形的对角线的两端点，定义放大区域。

放大

单击相关菜单或图标，放大工作窗口的尺寸。每次放大50%。用 [image] 显示选项修改该比例。

缩小

单击相关菜单或图标，缩小工作窗口的尺寸。每次缩小50%。用 [image] 显示选项修改该比例。

自动对齐

单击相关菜单或图标转换至打开状态， [image] 自动对齐使整个模型在工作窗口总是充满显示。


05_移动

Home > midas Gen 2017 > 02_视图 > 01_动态视图 > 06_平动

移 动

  • 功 能

在工作窗口中上、下、左、右移动模型。

  • 命 令

从主菜单中选择视图 > 移动 > 向左

从主菜单中选择视图 > 移动 > 向右

从主菜单中选择视图 > 移动 > 向上

从主菜单中选择视图 > 移动 > 向下

在图标菜单中单击 [image] 向左移动，快捷键： [Ctrl]+

在图标菜单中单击 [image] 向右移动，快捷键： [Ctrl]+

在图标菜单中单击 [image] 向上移动，快捷键： [Ctrl]+

在图标菜单中单击 [image] 向下移动，快捷键： [Ctrl]+

  • 用 法

向左移动：单击相关菜单或图标，模型将向左移动一定距离。用 显示选项修改移动距离。

向右移动：单击相关菜单或图标，模型将向右移动一定距离。用 显示选项修改移动距离。

向上移动：单击相关菜单或图标，模型将向上移动一定距离。用 显示选项修改移动距离。

向下移动：单击相关菜单或图标，模型将向下移动一定距离。用 显示选项修改移动距离。


06_视点

Home > midas Gen 2017 > 02_视图 > 01_动态视图 > 07_视点

视 点

  • 功 能

选定观察模型的视点。

  • 命 令

从主菜单中选择视图 > 视点 > 标准

从主菜单中选择视图 > 视点 > 顶面(+Z)

从主菜单中选择视图 > 视点 > 底面(-Z)

从主菜单中选择视图 > 视点 > 左面(-X)

从主菜单中选择视图 > 视点 > 右面(+X)

从主菜单中选择视图 > 视点 > 正面(-Y)

从主菜单中选择视图 > 视点 > 背面(+Y)

从主菜单中选择视图 > 视点 > 视角

从主菜单中选择视图 > 视点 > 向左旋转

从主菜单中选择视图 > 视点 > 向右旋转

从主菜单中选择视图 > 视点 > 向上旋转

从主菜单中选择视图 > 视点 > 向下旋转

在图标菜单中单击 [image] 标准视图，快捷键： [Ctrl]+[Shift]+I

在图标菜单中单击 [image] 俯视，快捷键： [Ctrl]+[Shift]+T

在图标菜单中单击 [image] 仰视，快捷键： [Ctrl]+[Shift]+B

在图标菜单中单击 [image] 左侧，快捷键： [Ctrl]+[Shift]+L

在图标菜单中单击 [image] 右侧，快捷键： [Ctrl]+[Shift]+R

在图标菜单中单击 [image] 正面，快捷键： [Ctrl]+[Shift]+F

在图标菜单中单击 [image] 背面，快捷键： [Ctrl]+[Shift]+E

在图标菜单中单击 [image] 角度

在图标菜单中单击 [image] 向左旋转，快捷键： [Ctrl]+[Alt]+

在图标菜单中单击 [image] 向右旋转，快捷键： [Ctrl]+[Alt]+

在图标菜单中单击 [image] 向上旋转，快捷键： [Ctrl]+[Alt]+

在图标菜单中单击 [image] 向下旋转，快捷键： [Ctrl]+[Alt]+

  • 用 法

标准：单击相关菜单或图标，显示模型的等轴视图，视点坐标为(-0.483,-0.837,0.259)[整体坐标系(GCS)中]。

顶面：单击相关菜单或图标，显示从+Z方向观察的模型。

底面：单击相关菜单或图标，显示从-Z方向观察的模型。

左面：单击相关菜单或图标，显示从-X方向观察的模型。

右面：单击相关菜单或图标，显示从+X方向观察的模型。

正面：单击相关菜单或图标，显示从-Y方向观察的模型。

背面：单击相关菜单或图标，显示从+Y方向观察的模型。

视角：单击相关菜单或图标，打开下列对话框。

调整视角对话框

垂直移动右边滚动条将绕水平轴旋转各轴。水平移动下边滚动条将绕整体坐标系(GCS)Z轴旋转各轴。也可以在水平和垂直域内键入数值修改视点。或者，在对话框内用鼠标左键单击数字区，并将它拖至目标位置，从而修改视点。

向左旋转：单击相关菜单或图标，绕屏幕的垂直方向顺时针旋转模型，用 显示选项调整每次的旋转角度。

向右旋转：单击相关菜单或图标，绕屏幕的垂直方向逆时针旋转模型，用 显示选项调整每次的旋转角度。

向上旋转：单击相关菜单或图标，绕屏幕的水平方向向上旋转模型，用 显示选项调整每次的旋转角度。

向下旋转：单击相关菜单或图标，绕屏幕的水平方向向下旋转模型，用 显示选项调整每次的旋转角度。


08_命名的视图

Home > midas Gen 2017 > 02_视图 > 01_动态视图 > 08_命名视图

命名的视图

  • 功 能

选择已命名的视图，将方便选择某一视图。

可用于对复杂结构的重复多次查看视图。

  • 命 令

从主菜单中选择视图 > 命名的视图

在图标菜单中单击 [image] 命名的视图

  • 用 法

命名的视图对话框


11_消隐

Home > midas Gen 2017 > 02_视图 > 02_渲染视图 > 01_消隐

消 隐

  • 功 能

在屏幕上显示单元的厚度和截面形状并消除隐藏的线，将模型显示为如同真实结构一样。

  • 命 令

从主菜单中选择视图 > 消隐...

在图标菜单中单击 [image] 消隐...

快捷键：[Ctrl]+H

提示:

要显示面单元的厚度或梁单元上板件的厚度，应在显示选项对话框的绘图>消隐选项中勾选板单元的厚度或杆系的厚度。


09_收缩单元

Home > midas Gen 2017 > 02_视图 > 02_渲染视图 > 02_收缩单元

收缩单元

  • 功 能

将已建立的模型单元按一定比率缩小后重新显示在画面上。可用 [image] 显示选项调整收缩比率。

查看节点处单元的连接状态时，该项功能非常有用。

  • 命 令

从主菜单中选择视图 > 收缩单元

在图标菜单中单击 [image] 收缩

快捷键： [Ctrl]+K

下面图形为经收缩、消隐处理后的框剪模型。表现模型形状的一些系数以及是否显示墙的厚度等事项可以在 [image] 显示选项中设定。

经收缩、消隐处理后的模型视图


10_透视

Home > midas Gen 2017 > 02_视图 > 02_渲染视图 > 03_透视图

透 视

  • 功 能

显示模型的透视图。用 [image] 显示选项调整透视比例。

  • 命 令

从主菜单中选择视图 > 透视...

在图标菜单中单击 [image] 透视...

快捷键： [Ctrl]+J


12_渲染窗口

Home > midas Gen 2017 > 02_视图 > 02_渲染视图 > 04_渲染窗口

渲染窗口

  • 功 能

将单元根据属性(材料、截面、厚度)分类赋予不同的颜色，并经透明或半透明处理后赋以阴影效果，从而将实际形状呈现在模型或分析结果窗口。此外，在透视图中与漫游模式结合，呈现逼真的三维模拟。

进入渲染窗口后，工作窗口将转换为渲染窗口模式。再单击相应图标，返回建模窗口模式。

用 [image] 显示选项修改模型表现功能选项(缩放、移动、旋转、比例等)。

用 [image] 渲染选项修改灯光选项，以形成阴影效果。

渲染窗口中的视图处理命令包括缩放、移动和旋转，其用法与建模窗口模式中的命令相同。

注：在渲染窗口模式中，建模功能(模型数据的选择、增加、修改、删除等) 及与动画生成相关的功能不起作用。在渲染窗口模式中没有输出数值功能，其它如查看结果(反力，位移，构件内力，应力等)功能的使用与建模窗口模式中的操作相同。

  • 命 令

从主菜单中选择视图 > 渲染窗口...

在图标菜单中单击 [image] 渲染窗口...

快捷键： [F6]

经渲染处理后的模型


14_选择

Home > midas Gen 2017 > 02_视图 > 03_选择 > 01_选择

选 择

  • 功 能

在建模过程中，需要经常修改节点、单元和属性(边界条件、荷载等)，因此需要经常重复使用选择命令。

MIDAS/Gen提供了各种强大的选择和取消选择功能，简化并加快了建模过程。

另外，可以与激活功能同时使用，只显示需要的模型区域，从而为用户提供最优的建模环境。激活是指在建模窗口中选择性地显示模型的部分区域。

注：选择功能仅对被激活的节点和单元有效。

选择的节点和单元在屏幕上显示方式如下：

节点：节点的颜色将发生改变，用 [image] 显示选项中的颜色表修改被选择节点的显示颜色。

线单元：单元中心线的颜色将发生改变，用 [image] 显示选项中的颜色表修改被选择单元的显示颜色。

板单元：增加显示缩小了的单元形状，用 [image] 显示选项中的颜色表修改被选择单元的显示颜色。

实体单元：增加显示缩小了的单元形状，用 [image] 显示选项中的颜色表修改被选择单元的显示颜色。

  • 命 令

从主菜单中选择视图 > 选择 > 属性

从主菜单中选择视图 > 选择 > 单选

从主菜单中选择视图 > 选择 > 窗口

从主菜单中选择视图 > 选择 > 多边形

从主菜单中选择视图 > 选择 > 交叉线

从主菜单中选择视图 > 选择 > 平面

从主菜单中选择视图 > 选择 > 立体框

从主菜单中选择视图 > 选择 > 全选

在图标菜单中单击 [image] 选择属性-节点

在图标菜单中单击 [image] 选择属性-单元

在图标菜单中单击 [image] 单选

在图标菜单中单击 [image] 窗口选择

在图标菜单中单击 [image] 多边形选择

在图标菜单中单击 [image] 交叉线选择

在图标菜单中单击 [image] 平面选择

在图标菜单中单击 [image] 立体框选择

在图标菜单中单击 [image] 全选

  • 用 法

<图1> 选择属性对话框

属性选择( 或 选择属性节点/单元)

该项功能支持用属性(单元类型、材料特性、截面、边界条件等)选择节点或单元。

全选：选择全部节点或单元。

无：取消选择全部节点或单元。

反转：相互交换被选择与未被选择状态。

前次：调用前次选择。

节点：选择指定的节点。

单元：选择指定的单元。

节点和单元特性列表

单元类型：根据单元类型选择 (参见 "建立单元")

材料：根据材料特性选择 (参见 "材料")

截面：根据截面选择线单元 (参见 "截面")

厚度：根据厚度选择板单元 (参见 "厚度")

已命名的平面：根据平面名称选择 (参见 "已命名的平面")

结构组：根据结构组选择 (参见 "结构组")

边界组：根据边界组选择 (参见 "边界组")

荷载组：根据荷载组选择 (参见 "荷载组")

支承：根据支承条件选择 (参见 "支承")

梁端约束：根据梁端约束条件选择 (参见 "释放梁端部约束")

使用该功能时，在选择属性中选择相应属性，则对应于该属性的具体属性将显示在下面的子列表中，在子列表中选择具体属性值然后点击添加命令，则模型空间窗口中具有该属性的单元或节点将被自动选择。将多项选择项设置为开时，可以同时选择多项属性。

用以下按钮添加、删除、替换已选的实体。

添加：将具有相应属性的目标添加到相应列表中。

删除：从现有选择列表中删除选定的实体。

替换：在现有选择列表中用当前选定的实体内容替代已登记的内容。

交叉：只选择既从属于当前选择的属性，又满足已选择的属性的节点或单元。

单选

在模型空间窗口中将鼠标光标置于要选择的节点或单元附近，单击鼠标左键，逐个选择节点或单元。

重复指定选中的实体，即为撤消选择。为提高效率，可以将该功能与 [image] 节点捕捉或 [image] 单元捕捉同时使用。

按住鼠标左键并拖至目标方向，即可执行窗口选择功能。

<图2> 单选

窗口

在模型空间窗口中定义一个矩形选择窗口。

在工作窗口中用鼠标左键连续点击矩形的两个对角点，被矩形包围的实体将被选中。

在工作窗口中，首先点击左角，然后向右拖动鼠标选择，完全被矩形窗口包围的节点或单元将被选择。

在工作窗口中，首先点击右角，然后向左拖动鼠标选择，完全被矩形窗口包围的节点或单元以及与边界相交的单元将被选择。

<图3>从左上到右下框选

<图4>从右下到左上框选

多边形

在模型空间窗口中定义一个多边形边界选择实体。

在工作窗口中用鼠标左键连续点击角点，使定义的多边形包围被选择的实体。定义最后一点时，双击鼠标左键即可。

如果也要选择与边界相交的单元，按住[Ctrl]键的同时，用鼠标左键双击最后一个角点。

<图5> 多边形选择例子

交叉线

在工作窗口中用鼠标连续画出的任意线，与该线相交的单元均被选择。

画线时，将鼠标置于最初容易选择的位置，然后单击鼠标左键。连续画线时，在不同点处单击鼠标左键，结束时双击鼠标左键取最后一点。

<图6> 为了修改单元类型，使用交叉线选择腹杆的例子

平面选择

选择指定平面内包含的所有节点和单元。

下列对话框用于定义一个平面。

<图7> 平面选择对话框

3点

指定三点定义选择的平面。输入GCS坐标系中三点的坐标，或在工作窗口中连续点击三点定义平面。

XY平面

当选择的平面平行于GCS坐标系中X-Y 平面时，输入GCS坐标系中平面的Z坐标，或在工作窗口中单击平面上一点。

XZ平面

当选择的平面平行于GCS坐标系中X-Z 平面时，输入GCS坐标系中平面的Y坐标，或在工作窗口中单击平面上一点。

YZ平面

当选择的平面平行于GCS坐标系中Y-Z 平面时，输入GCS坐标系中平面的X坐标，或在工作窗口中单击平面上一点。

<图8> 三点选择平面的功能(即使不与GCS或UCS平行的平面也可用三点选择一个平面)

立体框选择

选择指定立方体内包含的每个节点和单元。

下列对话框用于定义一个立方体。

<图9> 立体框选择对话框

2点

输入两对角点的坐标，或在工作窗口中点击两对角点定义一个立方体。

XYZ极限

输入GCS坐标系中各坐标轴的范围(最大值和最小值)，定义立方体的边界。或者，在工作窗口中用鼠标单击相应的输入区，输入目标位置。

设定最大最小

点击上方设定最大最小，当前处于激活状态的结构的最大和最小坐标将被自动输入。用户可根据需要重新输入坐标。

<图10> 设定最大/最小值定义立体框

全选

选择所有节点和单元。

注
MIDAS支持过滤选择功能，允许用户根据单元布置的方向选择线型单元(桁架单元，梁单元等)。

<图11> 过滤选择对话框

从状态栏的过滤区中选择目标方向或平面，然后用图形选择功能(单选、窗口、多边形、交叉线、平面、立体框、全选)选择或解除选择目标。在选择的范围中，只有满足过滤条件的单元才能被选中。

注：板单元和实体单元不能被过滤。

上图中，即使用全部选择功能选择整个模型，因为已选定GCS坐标系的Z轴过滤，所以也只有平行于GCS坐标系的Z轴(UCS的z轴)的单元被选中。

过滤选项应用范围如下：

无 | 不使用过滤
x | 平行于GCS(UCS)x轴的线性单元
y | 平行于GCS(UCS)y轴的线性单元
z | 平行于GCS(UCS)z轴的线性单元
xy | 平行于GCS(UCS)x-y平面的线性单元
yz | 平行于GCS(UCS)y-z平面的线性单元
xz | 平行于GCS(UCS)x-z平面的线性单元

如果使用特定选择功能(选择属性-节点、选择属性-单元, 选择组、前次选择、新建实体选择)选择实体时，过滤不起作用。此时，只有首先指定实体，然后在状态栏中单击 [image] 过滤，才能选择符合过滤条件的单元。


15_解除选择

Home > midas Gen 2017 > 02_视图 > 03_选择 > 02_解除选择

解除选择

  • 功 能

解除选择的操作与选择正好相反，用法与选择相同。

用解除选择命令选择目标后，以不同颜色亮显的节点和单元将恢复最初的模型颜色。

  • 命 令

从主菜单中选择视图 > 解除选择 > 属性

从主菜单中选择视图 > 解除选择 > 窗口

从主菜单中选择视图 > 解除选择 > 多边形

从主菜单中选择视图 > 解除选择 > 交叉线

从主菜单中选择视图 > 解除选择 > 平面

从主菜单中选择视图 > 解除选择 > 立体框

从主菜单中选择视图 > 解除选择 > 全部解除

在图标菜单中单击 [image] 窗口解除选择

在图标菜单中单击 [image] 多边形解除选择

在图标菜单中单击 [image] 交叉线解除选择

在图标菜单中单击 [image] 平面解除选择

在图标菜单中单击 [image] 立体框解除选择

在图标菜单中单击 [image] 全部解除选择

注：

参见"选择"，了解各功能细节。


16_前次选择

Home > midas Gen 2017 > 02_视图 > 03_选择 > 03_选择前次

前次选择

  • 功 能

前次选择功能为调用最近的选择状态。

前次选择功能在对同一目标重复不同的命令时特别方便。

  • 命 令

从主菜单中选择视图 > 前次选择

在图标菜单中单击 [image] 前次选择

快捷键： [Ctrl]+Q


18_激活

Home > midas Gen 2017 > 02_视图 > 04_激活 > 01_激活

激 活

  • 功 能

激活功能可以在屏幕上只显示整个模型中指定的部分。

处理大型复杂结构时，在屏幕上只显示所选定的部分模型，是建模和查看分析结果的一条有效途径。

注：数据的输入和修改命令仅对激活的节点和单元有效。

当创建节点和单元时，如果选择了交叉分割和删除重复节点选项，这些命令即使对当前处于钝化状态的节点和单元同样有效。(参见"建立节点" 或 "建立单元")

  • 命 令

从主菜单中选择视图 > 激活 > 激活

从主菜单中选择视图 > 激活 > 钝化

从主菜单中选择视图 > 激活 > 逆激活

从主菜单中选择视图 > 激活 > 全部激活

从主菜单中选择视图 > 激活 > 按属性激活

从主菜单中选择视图 > 激活 > 前次激活状态

在图标菜单中单击 [image] 激活，快捷键：[F2]

在图标菜单中单击 [image] 钝化，快捷键：[Ctrl]+[F2]

在图标菜单中单击 [image] 逆激活

在图标菜单中单击 [image] 全部激活，快捷键：[Ctrl]+A

在图标菜单中单击 [image] 按属性激活，快捷键：[Ctrl]+D

在图标菜单中单击 [image] 前次激活状态

  • 用 法

激活：用选择功能选择要激活的目标，然后运行本命令仅显示(激活)被选中的目标。

钝化：选择要钝化的目标，然后用本功能从屏幕上消除(钝化)被选中的目标。

逆激活：逆转当前激活和钝化的目标。

全部激活：激活所有钝化的节点和单元。

按属性激活：激活用属性选择的节点和单元。

<图1> 按属性激活对话框

当前UCS平面：定义UCS后, 激活UCS坐标系中x-y平面内包括原点在内的所有节点和单元。(参见"用户坐标系")

已命名的平面：激活选定的已命名的平面内的所有节点和单元，可以多选。(参见"已命名的平面")

结构组：激活选定的结构组内的所有节点和单元，可以多选。(参见 "定义结构组")

边界组：激活选定的边界组内的所有节点和单元，可以多选。(参见 "定义边界组")

荷载组：激活选定的荷载组内的所有节点和单元，可以多选。(参见 "定义荷载组")

构件：激活选定构件包括的所有节点和单元，可以多选。

层：激活选定层包括的所有节点和单元，可以多选。

只适用于已激活的目标

仅用于部分模型处于激活状态，且按属性激活时。

选择为打开时，在上述特性列表中选择相应条件，则在当前激活状态中的节点和单元，满足指定激活条件的目标将被激活。

选择为关闭时, 忽略当前激活状态，在整个模型中满足指定激活条件的目标都被激活。

：仅激活具有当前选定属性的目标。

：按属性将新的目标增加到已选定的激活属性目标中。

：仅钝化具有当前选定属性的目标。

：激活整个模型。

前次激活状态：恢复模型最近的激活/钝化状态。

<图2> 激活/钝化功能

注：

图2为激活工业厂房模型部分结构的例子。


19_坐标系

Home > midas Gen 2017 > 02_视图 > 05_栅格/捕捉 > 01_UCS/GCS

坐标系

  • 功 能

UCS命令的功能是将当前应用的GCS坐标系转换到UCS坐标系。

GCS命令的功能是将当前应用的UCS坐标系转换到GCS坐标系。

  • 命 令

从主菜单中选择视图 > 坐标系 > 用户坐标系

从主菜单中选择视图 > 坐标系 > 全局坐标系

在图标菜单中单击 [image] 用户坐标系

在图标菜单中单击 [image] 全局坐标系

  • 用 法

首先应从模型 > 坐标系的下级菜单中指定一个UCS。如果未设定UCS，其坐标原点和坐标轴自动与GCS相符。请注意，点格栅和线格栅始终设置在用户坐标系UCS的x-y (或GCS的X-Y)平面内。

当屏幕上显示由 [image] 点格或 [image] 轴线定义的点格栅和线格栅时，随着UCS和GCS的转换，相应格栅也被移动至转换后的坐标系的x-y平面(或X-Y平面)内。

MIDAS/Gen使用如下坐标系：

  • 全局坐标系 (Global Coordinate System)

  • 单元坐标系 (Element Coordinate System)

  • 节点坐标系 (Node Local Coordinate System)

全局坐标系为按右手法则决定直角坐标系(Conventional Cartesian Coordinate System)并使用大写的"X、Y、Z"表示各轴。节点以及与节点相关的大部分数据、节点位移以及反力均按全局坐标系输出。

全局坐标系用户输入结构模型的几何位置，程序内部自动将X=0、Y=0、Z=0点定义为参考点(Reference Point)。MIDAS/Gen中将程序画面的竖向作为全局坐标系的Z轴，因此用户建模时将结构的竖向(重力加速度的反方向)设置为与全局坐标系的Z轴平行时会更方便一些。

单元坐标系为按右手法则决定的直角坐标系，使用小写的"x、y、z"表示各轴。

单元内力和应力等与单元有关的大部分数据的输入和输出按单元坐标系进行。

节点坐标系(Node Local Coordinate System)用于给节点施加任意方向的约束条件、弹性支撑边界或强制位移等边界条件时，或想计算并输出任意方向的反力时。节点坐标系为按右手法则决定的直角坐标系，使用小写的"x、y、z"表示各轴。

<图1> 全局坐标系和节点坐标


20_栅格

Home > midas Gen 2017 > 02_视图 > 05_栅格/捕捉 > 02_栅格

轴 网

  • 功 能

在屏幕中显示点格或轴线。

在模型空间窗口中，可以同时显示点格和轴线。点格和轴线的间距分别在 [image] 定义点格和 [image] 定义轴线中设置。如果使用 [image] 捕捉点或 [image] 捕捉轴线，鼠标的点击点自动捕捉到邻近的栅格上。

  • 命 令

从主菜单中选择视图 > 栅格 > 点格

从主菜单中选择视图 > 栅格 > 轴线

在图标菜单中单击 [image] 点格

在图标菜单中单击 [image] 轴线

  • 用 法

点格：在用户坐标系UCS的x-y平面中显示点格。

轴线：在用户坐标系UCS的x-y平面中显示轴线。

如果没有单独指定UCS，栅格自动设置在全局坐标系GCS的X-Y平面中。


21_捕捉

Home > midas Gen 2017 > 02_视图 > 05_栅格/捕捉 > 03_捕捉

捕 捉

  • 功 能

用鼠标光标创建单元或节点、或指定属性时，将鼠标挪到邻近的栅格、节点或单元附近，鼠标光标将自动对齐到相应位置。

  • 命 令

从主菜单中选择视图 > 捕捉 > 点

从主菜单中选择视图 > 捕捉 > 轴线

从主菜单中选择视图 > 捕捉 > 节点

从主菜单中选择视图 > 捕捉 > 单元

从主菜单中选择视图 > 捕捉 > 全部

从主菜单中选择视图 > 捕捉 > 关闭捕捉

在图标菜单中单击 [image] 捕捉点

在图标菜单中单击 [image] 捕捉轴线

在图标菜单中单击 [image] 捕捉节点

在图标菜单中单击 [image] 捕捉单元

在图标菜单中单击 [image] 捕捉全部

在图标菜单中单击 [image] 关闭捕捉

  • 用 法

捕捉点：将光标对齐最近的栅格点。用 定义点格设置点栅格。

捕捉轴线：将光标对齐邻近的栅格线交点。用 定义轴线设置线栅格。

捕捉节点：将光标对齐邻近的节点。

捕捉单元：将光标对齐邻近的单元的中心。

捕捉线单元时，用屏幕底部状态栏右边的捕捉点( [image])控制捕捉位置。例如，要捕捉单元的三等分点，单击 [image] 并输入1/3。

注：这项功能在已建立的主梁上的某一位置建立次梁时非常有用。

全部捕捉：设置以上所有捕捉功能有效。

关闭捕捉：关闭所有捕捉功能。

单击上列单个图标，可以开启或关闭某几个捕捉功能(开/关交替)。


22-显示

Home > midas Gen 2017 > 02_视图 > 06_显示 > 01_显示

显 示

  • 功 能

将输入的节点和单元编号、材料特性、截面类型、边界条件、荷载等信息显示在屏幕上。

  • 命 令

从主菜单中选择视图 > 显示...

在图标菜单中单击 [image] 显示

快捷键： [Ctrl]+E

  • 用 法

具体符号或数值的类型表示如下：

节点对话框

节点：在节点位置用圆点表示。

节点号：用阿拉伯数字表示节点号。

层名称：在模型中显示层名称。

节点局部坐标轴：在指定了节点坐标系的节点处显示节点局部坐标轴。

<图1>节点显示设置

单元对话框

单元号: 用阿拉伯数字表示单元号。

单元类型号: 显示单元类型编号。

单元类型名称: 显示单元类型名称。

墙类型: 显示墙单元类型名称。

墙号: 显示墙单元的墙号。

间隙: 显示间隙单元形状。

钩: 显示钩单元形状。

索: 显示索单元形状。

单元坐标轴: 显示单元坐标轴。

局部方向: 显示单元的方向(i >> j 节点，N1 >> N2 >> N3 >> N4)。

<图2>单元显示设置

特性对话框

材料号: 显示材料编号。

材料名称: 显示材料名称。

特性值号：显示截面特性的编号。

特性值名称：显示截面特性值的名称。

截面形状：显示线单元的截面形状。

变截面组：显示指定为变截面组的单元。

非弹性铰符号：显示非弹性铰的符号。

非弹性铰名称：显示非弹性铰的名称。

<图3>特性显示设置

边界对话框

全部：显示所有边界条件。

选择组：显示包含在选择的边界组里的边界条件。

：点击该按钮，选择边界组。

一般支承：以六边形显示支承条件(节点自由度的约束状态)。

各方向支承：以六位数显示支承条件(节点自由度的约束状态)。

节点弹性支承：以六边形显示加在节点上的弹性支承条件。

节点弹性支承（受拉/受压）：以六边形显示加在节点上的受拉/受压弹性支承条件。

节点弹性支承（多折线性）：以六边形显示加在节点上的多折线性弹性支承条件。

各方向点弹簧支承：以六位数显示加在节点上的弹性支承条件。

各方向点弹簧支承（抗拉/抗压）：以六位数显示加在节点上的抗拉/抗压弹性支承条件。

各方向点弹簧支承（多折线）：以六位数显示加在节点上的多折线性弹性支承条件。

面弹簧类型：显示面弹簧类型。

面弹簧（线性）：显示线性面弹簧类型。

面弹簧（抗拉/抗压）：显示抗拉/抗压面弹簧类型。

一般弹性支承：显示一般弹性支承条件。

弹性连接：显示两个节点之间的弹性连接状态。

弹性连接单元坐标轴：显示弹性连接单元的单元局部坐标轴。

弹性连接类型：显示弹性连接的类型。

弹性连接号：显示弹性连接的编号。

一般连接：显示两个节点之间的非线性连接状态。

一般连接号：显示非弹性连接号。

一般连接单元坐标轴：显示非线性连接单元的单元局部坐标轴。

一般连接类型：显示非弹性连接类型。

修改一般连接特性值：显示修改后的一般连接特性值。

释放梁端约束标志：显示释放的梁端约束的表示符号。

释放梁端约束数值：显示用数值表示的释放的梁端约束状态(0：约束，1：释放)。

梁端偏心：显示梁端偏心。

梁端部刚域：显示梁端部刚域(偏心)。

释放板端约束标志：显示释放的板端约束的表示符号。

释放板端约束数值：显示用数值表示的释放的板端约束状态(0：约束，1：释放)。

刚性连接：显示刚性连接状态(主节点/从属节点关系)。

线性约束：显示线性约束。

层刚性连接：显示楼层刚性连接状态(主节点/从属节点关系)。

解除刚性板连接：显示楼层中解除刚性连接的节点。

<图4>边界显示设置

综合对话框

质量

节点质量：显示节点质量的输入状态。

荷载转换为质量：显示由竖向荷载转换为质量的状态。

刚性楼板质量：显示刚性楼板质量的输入状态。

钢束形状名称：显示钢束的名称。

钢束形状控制点：显示为了布置钢束形状而输入的控制点。

几何刚度初始荷载：显示为构成几何刚度而输入的初始荷载的状态。

吊车道：显示输入吊车荷载的轨道。

吊车名称：显示输入吊车荷载名称。

水化热：显示为做水化热分析而输入的数据。

水化热值：显示与水化热分析有关的数值。

水化热函数名称：显示水化热函数名称。

水化热单元对流边界：显示输入的单元对流边界状态。

水化热固定温度：显示固定温度输入状态。

水化热热源：显示热源分配状态。

水化热管冷单元：显示输入的管冷单元。

<图5>综合显示设置

荷载对话框

荷载工况：选择要显示的荷载工况，并确认是否显示荷载值。

全部：显示全部荷载工况。

荷载值：选择是否显示荷载值。

(注：选择显示楼面荷载名称并选择该项时，在楼面荷载类型中定义的各荷载工况的荷载值将与楼面荷载类型的名称同时显示在屏幕上。)

选择荷载工况：选择将显示的荷载工况。

选择组：选择将显示的荷载组。 ：点击该按钮选择荷载组。

可以显示的荷载类型如下：

节点体力：显示节点集中体力。

节点荷载：显示节点集中荷载。

强制位移：显示输入的强制位移。

梁单元荷载：显示输入的梁单元荷载。

预应力荷载：显示输入的预应力荷载。

初拉力荷载：显示输入的初拉力荷载。

楼面荷载：显示输入的楼面荷载转换为梁单元荷载后的状态。

楼面荷载名称：显示输入的楼面荷载名称。

楼面荷载面积：以灰色交叉线显示已输入楼面荷载的区域。

装饰材料荷载：显示输入的装饰材料荷载。

压力荷载：显示输入的压力荷载。

平面荷载：显示输入的平面荷载。

平面荷载名称：显示输入的平面荷载名称。

节点温度：显示输入的节点温度。

单元温度：显示输入的单元温度。

温度梯度：显示输入的温度梯度。

梁截面温度：显示输入的梁截面温度。

钢束预应力：显示输入的钢束预应力。

风荷载：显示风荷载。

地震作用：显示地震作用。

节点动力荷载：显示节点动力荷载。

多支座激振：显示节点的多支座激振。

多支座激振函数名称：显示各个方向的多支座激振函数名称。

X-方向

Y-方向

Z-方向

<图6>荷载显示设置

视图对话框

UCS坐标轴：在原点显示UCS或GCS坐标轴。

视点：在屏幕右下角显示视点。

说明

可以将有关模型的一些说明显示在当前模型窗口的左上方位置。

字型：指定说明的字体、字形和大小等选项。

(注：在模型空间窗口上可以用鼠标拖动描述文本框放置到任意位置)

标签方向: 可以改变输出的一些名称、数值标签符号的显示方向(上面描述除外)。

<图7>视图显示设置

设计对话框

：打开 [image] 显示选项对话框。

：删除所有标签(节点标志除外)，初始化设定状态。

<图8>设计显示设置


02_显示选项

Home > midas Gen 2017 > 02_视图 > 06_显示 > 02_显示选项

显示选项

  • 功 能

显示选项用于修改在模型窗口中显示的图形、字符串或符号的表现形式。

显示选项中的设定值会注册到Windows的注册表中，因此即使结束或重新启动程序，这些值也将保持不变。

主要功能如下：

字体表单：指定字体、大小、颜色和形状等。

颜色表单：指定屏幕上节点、单元、各种属性(材料特性、截面、荷载、边界条件等)和分析结果的显示颜色。

打印颜色表单：指定打印输出时的节点、单元、各种属性和分析结果的打印颜色。

尺寸表单：指定各属性标签的显示尺寸大小以及与视图操作相关的有关功能的显示状态。

绘图表单：选择各种模型表现形式。

  • 命 令

从主菜单中选择视图 > 显示 > 显示选项...

在图标菜单中单击 [image] 显示选项

  • 用 法

<图1>显示选项对话框

字体

在左侧树形菜单中选择要修改表示形式的条目，在右侧设置表中指定字体、大小和颜色等。

  • 节点

节点号：节点编号。

节点输出值：节点位移、反力等数值。

节点局部坐标轴：表示节点局部坐标轴方向的文字。

  • 单元

号码/属性名称：单元编号、类型和名称，材料/截面/厚度的编号和名称。

单元输出值：单元内力、应力等数值。

设计标志：显示设计参数。

局部坐标轴：单元局部坐标轴。

等值线标注：等值线边界上的标注文字。

  • 荷载

荷载值：各种形式荷载的数值。

  • 边界条件

弹性，一般连接轴：表示弹性/非线性连接单元的单元局部坐标轴的文字。

尺寸：表示尺寸的文字。

信息条：在信息窗口显示的各种信息。

MGT命令窗口：在MGT命令窗口中表达的字符串。

打印：打印时使用的字体等。

节点

节点号：节点编号。

节点输出值：节点位移、反力等数值。

节点局部坐标轴：表示节点局部坐标轴方向的文字。

单元

号码/属性名称：单元编号、类型和名称，材料/截面/厚度的编号和名称。

单元输出值：单元内力、应力等数值。

设计标志：显示的设计参数。

局部坐标轴：单元局部坐标轴。

等值线标注：等值线边界上的标注文字。

荷载

荷载值：各种形式荷载的数值。

边界条件

弹性连接轴：表示弹性连接单元的单元局部坐标轴的文字。

水化热：与水化热分析相关的文字和数值。

尺寸：表示尺寸的文字。

字体：改变字体类型。

大小：改变字体大小。

文字颜色：改变字体颜色。

背景颜色：选择不透明选项后为字符串的背景颜色。

透明：将字符串背景设为透明，使标签与背景图像协调。

不透明：将字符串背景设为不透明，使标志亮显。

：改变字体、字形、大小、效果、颜色、语种等。

：对选择的项目使用midas Gen提供的默认值。

：对相应表单中的所有选择项目使用MIDAS/Gen提供的默认值。

颜色表单

在左侧树形菜单中选择要改变屏幕显示颜色的条目，然后在右侧设置表中指定显示颜色。

视图

上部背景：工作窗口的上部背景颜色。

下部背景：工作窗口的下部背景颜色。

点格：点栅格的颜色。

轴线：轴线的颜色。

光标：鼠标光标的颜色。

用户坐标系符号：用户坐标系UCS符号的颜色。

信息窗口

背景：信息窗口的背景颜色。

命令行：信息窗口命令行的颜色。

树形菜单

背景：树形菜单的背景颜色。

背景标题：树形菜单标题的颜色。

节点

标准：节点的颜色。

被选后：被选中的节点的颜色。

局部坐标系x轴：节点局部x轴的颜色。

局部坐标系y轴：节点局部y轴的颜色。

局部坐标系z轴：节点局部z轴的颜色。

钝化：被钝化的节点的颜色。

单元

单元可以用同一种颜色，也可以根据单元类型和使用材料特性着色。这种按类型分别着色的操作可通过绘图表单中的选择颜色来设定。

一般：指定全部单元为唯一的颜色。

线框架：在线框图中表示的单元颜色。

消隐：消隐处理后的表面的颜色。

消隐边界：消隐处理后的表面边界的颜色。

下列各种单元可以指定单独的颜色：

桁架单元

梁单元

平面应力单元

板单元

墙单元

平面应变单元

轴对称单元

实体单元

只受拉桁架单元

只受压桁架单元

注
当在绘图表单中的选择颜色中选择单元颜色时，以上不同单元类型的指定颜色方可应用到模型的颜色中。

符号：表示线单元横截面形状的颜色以及间隙，钩，索单元的颜色。

被选后：被选中的单元的颜色。

钝化：被钝化的单元的颜色。

变形前：当同时显示已变形的和未变形的模型形状时，未变形的模型形状的颜色。

单元坐标系x轴：单元坐标系x轴的颜色。

单元坐标系y轴：单元坐标系y轴的颜色。

单元坐标系z轴：单元坐标系z轴的颜色。

局部方向：显示建立单元时节点输入次序的颜色。

自由面/边：板单元或实体单元自由边或自由面的颜色。

铰特性值

非弹性铰-开：6个自由度中，表示设置了非弹性铰的自由度的符号颜色。

铰特性

非弹性铰-关：6个自由度中，表示没有设置非弹性铰的自由度的符号颜色。

非弹性铰-边：表示非弹性铰符号边的颜色。

质量

指定质量输入状态符号的颜色。

节点质量(开)：6个自由度中，表示输入了节点质量的自由度的符号颜色。

节点质量(关)：6个自由度中，表示没有输入节点质量的自由度的符号颜色。

节点质量符号轮廓：节点质量符号轮廓的颜色。

荷载变质量(开)：由荷载转变为节点质量的方向的颜色。

荷载变质量(关)：选择由荷载转变为节点质量的方向时，未被选中的方向的颜色。

荷载变质量符号轮廓：由荷载转变为节点质量的符号的轮廓的颜色。

刚性楼板质量(开)：6个自由度中，表示输入了刚性楼板质量的自由度的符号颜色。

刚性楼板质量(关)：6个自由度中，表示没有输入刚性楼板质量的自由度的符号颜色。

刚性楼板质量符号轮廓：刚性楼板质量符号轮廓的颜色。

层质量填充：层质量的颜色。

层质量轮廓：层质量轮廓的颜色。

荷载

根据荷载类型指定颜色。

节点体力填充：节点体力箭头的颜色。

节点体力边：节点体力轮廓的颜色。

节点荷载标志：节点荷载箭头的颜色。

节点荷载标志轮廓：节点荷载箭头轮廓的颜色。

强制位移(开)：6个自由度中，表示输入了强制位移的方向符号的颜色。

强制位移(关)：6个自由度中，表示未指定强制位移的方向符号的颜色。

强制位移符号轮廓：强制位移符号轮廓的颜色。

梁单元荷载标志：梁单元荷载箭头的颜色。

梁单元荷载标志轮廓：梁单元荷载箭头轮廓的颜色。

压力荷载标志：压力荷载箭头的颜色。

压力荷载标志轮廓：压力荷载箭头轮廓的颜色。

楼面荷载标志：楼板荷载箭头的颜色。

楼面荷载标志轮廓：楼板荷载箭头轮廓的颜色。

装饰材料荷载标志：装饰材料荷载箭头的颜色。

装饰材料荷载轮廓：装饰材料荷载箭头轮廓的颜色。

楼板荷载名称区域：楼板荷载作用范围的颜色。

楼板荷载名称轮廓：楼板荷载作用范围轮廓的颜色。

注
在楼板荷载名称区域中设定的颜色只有将绘图表单中的楼板荷载颜色选择颜色设定为全局颜色时方可显示在模型中。

平面荷载标志：平面荷载箭头的颜色。

平面荷载标志轮廓：平面荷载箭头轮廓的颜色。

平面荷载名称区域：平面荷载作用范围的颜色。

平面荷载标志轮廓：平面荷载作用范围轮廓的颜色。

预应力荷载标志：预应力荷载箭头的颜色。

预应力荷载标志轮廓：预应力荷载箭头轮廓的颜色。

初拉力标志：初拉力荷载箭头的颜色。

初始张拉标志轮廓：预拉荷载箭头轮廓的颜色。

节点温度荷载标志：节点温度荷载箭头的颜色。

节点温度荷载标志轮廓：节点温度荷载箭头轮廓的颜色。

单元温度荷载标志：单元温度荷载箭头的颜色。

单元温度荷载标志轮廓：单元温度荷载箭头轮廓的颜色。

温度梯度荷载：温度梯度荷载标志的颜色。

梁截面温度标志：梁截面温度标志的颜色。

风荷载标志：风荷载箭头的颜色。

风荷载标志轮廓：风荷载箭头轮廓的颜色。

地震荷载标志：地震作用箭头的颜色。

地震荷载标志轮廓：地震作用箭头轮廓的颜色。

节点动力荷载标志：时程分析时输入的节点动力荷载箭头的颜色。

节点动力荷载标志轮廓：时程分析时输入的节点动力荷载箭头轮廓的颜色。

多支座激振-开：6个自由度中，表示输入了多支座激振的方向符号的颜色。

多支座激振-关：6个自由度中，表示未输入多支座激振的方向符号的颜色。

多支座激振-边：多支座激振符号轮廓的颜色。

预应力钢束

指定钢束布置的颜色。

预应力钢束布置形状：显示钢束布置的线的颜色。

控制点：为了定义钢束布置形状而输入的控制点的颜色。

被选择的钢束布置形状：被选择的钢束布置形状的线的颜色。

尺寸

尺寸线：显示尺寸线的颜色。

边界条件

指定表示边界条件的符号的颜色。

约束(开)：6个自由度中，被约束的自由度的颜色。

约束(关)：6个自由度中，没有被约束的自由度的颜色。

约束标志轮廓：表示约束的符号轮廓的颜色。

支承方向边：各方向支承显示中支承符号边的颜色。

支承方向填充：各方向支承显示中支承符号的颜色。

弹性支撑(开)：6个弹性支承条件自由度中，输入了弹性支撑条件的符号的颜色。

弹性支撑(关)：6个弹性支承条件自由度中，未指定弹性支撑条件的符号的颜色。

弹性支撑标志轮廓：节点弹性支撑标志的轮廓的颜色。

非线性弹性支承打开：在一般弹性支撑中，在刚度矩阵的6个对角线成分中输入了支承刚度的标志的颜色。

非线性弹性支承关闭：在一般弹性支撑中，在刚度矩阵的6个对角线成分中未输入支承刚度的标志的颜色。

弹性支承面：弹性支承面标志符号的颜色。

节点多线性弹性支撑(开)：6个节点多线性弹性支承条件自由度中，输入了弹性支撑条件的符号的颜色。

节点多线性弹性支撑(关)：6个节点多线性弹性支承条件自由度中，未指定弹性支撑条件的符号的颜色。

节点多线性弹性支撑标志轮廓：节点多线性弹性支撑标志的轮廓的颜色。

点支承方向边：6个点支承条件自由度中，输入了点支承条件的符号边的颜色。

点支承方向填充：6个点支承条件自由度中，输入了点支承条件的符号的颜色。

点支承方向边（抗压/抗拉）：6个抗压/抗拉点支承条件自由度中，输入了点支承条件的符号边的颜色。

点支承方向填充（抗压/抗拉）：6个抗压/抗拉点支承条件自由度中，输入了点支承条件的符号的颜色。

点支承方向边（多折线）：6个多折线点支承条件自由度中，输入了点支承条件的符号边的颜色。

点支承方向填充（多折线）：6个多折线点支承条件自由度中，输入了点支承条件的符号的颜色。

面支承（框架）：面支承（框架）的符号颜色。

面支承（平面/线）：面支承（平面/线）的符号颜色。

面支承（平面/面）：面支承（平面/面）的符号颜色。

面支承（实体/面）：面支承（实体/面）的符号颜色。

一般弹性支承(开)：6个节点一般弹性支承条件自由度中，输入了弹性支承条件的符号的颜色。

一般弹性支承(关)：6个节点一般弹性支承条件自由度中，未指定弹性支承条件的符号的颜色。

一般弹性支承标志轮廓：一般弹性支承标志的轮廓的颜色。

梁端刚域：梁端刚域符号的颜色。

释放梁/板端约束标志：表示释放梁/板端约束的符号的颜色。

刚性连接：刚性连接(主节点和从属节点之间)符号的颜色。

线性约束：线性约束符号的颜色。

层刚性楼板：层刚性楼板符号的颜色。

车道：车道符号的颜色。

连续车道支座：连续车道支座符号的颜色。

车道面：车道面符号的颜色。

车道面中心线：车道面中心线的颜色。

主节点：在刚性楼层显示中主节点符号的颜色。

弹性连接：弹性连接单元的颜色。

弹性连接x轴：弹性连接单元的局部坐标系x轴的颜色。

弹性连接y轴：弹性连接单元的局部坐标系y轴的颜色。

弹性连接z轴：弹性连接单元的局部坐标系z轴的颜色。

一般连接：一般连接单元的颜色。

一般连接x轴：一般连接单元的局部坐标系x轴的颜色。

一般连接y轴：一般连接单元的局部坐标系y轴的颜色。

一般连接z轴：一般连接单元的局部坐标系z轴的颜色。

修改一般连接特性值：修改了的一般连接特性值的颜色。

水化热

指定与水化热有关的数据符号的颜色。

对流边界：表示对流边界的符号轮廓的颜色。

对流边界标志：对流边界的符号的颜色。

图例

指定显示有各种输出结果参照事项的图例的颜色。

绘图颜色：图例窗口中分割线的颜色。

文字颜色：图例窗口中文本的颜色。

分析结果

在显示分析结果的模型窗口中，指定下列各项的颜色：

板剖断线颜色：在查看板分析结果时，在显示形式中选择了剖断面时，在板单元上显示的剖断线的颜色。

板剖断面颜色：在查看板分析结果时，在显示形式中选择了剖断面时，在板单元上显示的剖断面的颜色。

梁单元/墙单元颜色：将梁/墙单元内力图按单一颜色表示时的颜色。

移动荷载轨迹节点荷载：使用移动荷载追踪器查出的节点集中荷载的符号(箭头)的颜色。

移动荷载轨迹分布荷载：使用移动荷载追踪器查出的分布荷载的符号(箭头)的颜色。

设计

构件：构件的颜色。

Pushover铰-开：6个自由度中，设定了Pushover铰的自由度的颜色。

Pushover铰-关：6个自由度中，未设定Pushover铰的自由度的颜色。

Pushover铰-边：Pushover铰符号边的颜色。

子区域布筋方向1：子区域布筋方向1的颜色。

子区域布筋方向2：子区域布筋方向2的颜色。

材料

该项只有在输入了材料特性时方在表单中显示。

按材料类型设定单元的颜色。

线框架：用线框架表示单元的颜色。

消隐：消隐面的颜色。

消隐轮廓：消隐面轮廓的颜色。

透明：调整被赋以颜色的单元的透明度。

注
1、当在绘图表单中的选择颜色中选择材料颜色时，在此项中指定的颜色才可显示到模型的颜色中。

2、截面、厚度、楼面荷载类型三项说明及应用条件同材料项。

选择值

颜色：改变颜色。

：指定用户定义的颜色。

基本选择

：将模型窗口背景设为黑色，其它部分使用MIDAS/Gen提供的默认颜色。

：将模型窗口背景设为白色，其它部分使用MIDAS/Gen提供的默认颜色。

：打开一个颜色文件：文件名.color，并将它作为当前颜色。

：将颜色文件保存为：文件名.color。

：选中的条目使用MIDAS/Gen提供的默认颜色。

：相关表单中所有被选中的条目均使用MIDAS/Gen提供的默认颜色。

打印颜色表单

在左侧树形菜单中选择要修改打印颜色的条目，然后在右侧设置表中指定打印颜色。

用法参见颜色表单。

尺寸表单

标志符号：控制符号和标志的大小。

缩放：控制放大或缩小的比例。

移动：控制移动距离。

旋转：控制旋转角度的比例。

收缩：控制单元收缩的比例。

透视：控制视点的位置。

绘图表单

在该项表单中将决定在颜色表单中指定的颜色的表现方法(基本颜色、单元颜色、材料颜色、截面颜色等)、消隐面的处理方法、显示厚度与否、被捕捉或被选择的目标的表现方式、打印时使用的颜色、节点和单元钝化时的表现方式、剪力和弯矩图的表现方式等。

单元颜色：指定在屏幕上显示单元时的颜色选择方法。

基本颜色：使用在颜色表单“单元”条目中的“一般”中定义的颜色。

单元颜色：使用在颜色表单“单元”条目中对不同单元类型(桁架、梁等)定义的颜色。

材料颜色：使用在颜色表单中“材料”条目中对不同材料定义的颜色。

截面颜色：使用在颜色表单中“截面”条目中对不同截面定义的颜色。

：随机采用单元、材料、截面/厚度项中定义的颜色。

：恢复使用随机颜色项前定义的颜色。

消隐选项(模型)

填充：对单元的消隐面使用在颜色表单中定义的颜色。

轮廓线：单元消隐时，只表示在颜色表单中定义的轮廓颜色，消隐面颜色取背景颜色。

外轮廓线+填充：给所有的消隐面和轮廓着色。

杆系的厚度：显示组成线单元截面的各成分的厚度(如工字钢腹板和翼缘的厚度)。

板单元厚度：显示板单元的厚度。

消隐选项(变形前)

线框架：显示变形形状时，将变形前的模型仅用线框架表示。

轮廓线：显示变形形状时，仅用单元轮廓表示变形前的模型。

杆系的厚度：显示变形的形状时，变形前的模型将显示组成线单元截面的各成分的厚度(如工字钢腹板和翼缘的厚度)。

板单元厚度：显示变形的形状时，变形前的模型将显示板单元的厚度。

线框选项

阴影处理实体和平面单元：勾选该项表示在线框图中以阴影形式显示实体和平面单元。

混色：选择是否混色。

系数：选择混色单元的透明比例系数。

捕捉/选择显示线：调整捕捉单元时单元局部坐标轴的显示线宽以及单元被选择时单元的线的宽度。

线框架模型线宽：用线框架图显示模型时，表示捕捉或选择的线的宽度。

隐藏线模型线宽：用消隐方式显示模型时，表示捕捉或选择的线的宽度。

显示单元坐标轴：指定是否显示被捕捉单元(或节点)的单元编号(或节点编号)以及被捕捉单元的单元局部坐标轴。

注
单元局部坐标轴按建立单元过程中输入节点的次序显示。

打印颜色选项

黑/白打印：以黑/白色打印。

彩色打印(视图)：使用在颜色表单中定义的颜色打印。

彩色打印(设定)：使用在打印颜色表单中定义的颜色打印。

被钝化的目标：指定被钝化的节点和单元的表示方法。

显示单元、节点：将被钝化的节点和单元按在颜色表单中“单元”条目中的钝化项中定义的颜色表示轮廓线。

考虑对齐缩放：对齐缩放时，考虑用轮廓表示的被钝化的节点和单元，即用轮廓表示的被钝化的节点和单元也将被对齐缩放。

梁/墙单元内力图：指定梁/墙单元的剪力/弯矩图的绘制方向。

反转弯矩图：颠倒弯矩图的绘制方向，使正值和负值颠倒。

反转剪力图：剪力图的绘制方向颠倒至单元局部坐标轴的反方向。

SRC中混凝土外轮廓线：指定SRC构件中混凝土部分的外轮廓线的宽度。

动态标签：输入模型数据时(如荷载、边界条件等)，即时显示所输入的数据的标志(如荷载箭头、边界符号等）的功能。

楼面荷载颜色：设定在颜色表单中“荷载”条目中的楼面荷载名称项中定义的颜色表现形式。

单元线宽：定义单元线宽度。

：选中的条目使用midas Gen提供的默认值。

：在当前表单中选中的所有条目使用midas Gen提供的默认值。

：所有显示选项均使用midas Gen提供的默认值。


01_新窗口

Home > midas Gen 2017 > 02_视图 > 07_窗口 > 01_新窗口

新窗口

  • 功 能

建立一个新的模型窗口。新建模型窗口按顺序排列。

由给定模型建立的若干模型窗口可以大大提高建模效率，可以根据需要分别控制模型视窗。

  • 命 令

从主菜单中选择窗口 > 新窗口

快捷键： [Ctrl]+[W]

相关功能：关闭窗口、关闭所有窗口、下一个窗口、前一个窗口、水平排序、竖直排序、阶梯式排序。


02_关闭窗口

Home > midas Gen 2017 > 02_视图 > 07_窗口 > 02_关闭

关闭窗口

  • 功 能

关闭当前窗口。但是，不适用于初始模型窗口。

  • 命 令

从主菜单中选择窗口 > 关闭窗口

相关功能：新窗口、关闭所有窗口


04_下一个窗口

Home > midas Gen 2017 > 02_视图 > 07_窗口 > 03_下一个

下一个窗口

  • 功 能

同时打开几个窗口时，激活当前处于活动状态窗口的下一个窗口。窗口编号顺序和建立窗口的顺序相同，被激活的窗口处于屏幕的前端。

  • 命 令

从主菜单中选择窗口 > 下一个窗口

相关功能：点击窗口标志选择窗口


05_前一个窗口

Home > midas Gen 2017 > 02_视图 > 07_窗口 > 04_前一个

前一个窗口

  • 功 能

同时打开几个窗口时，激活当前处于活动态窗口的上一个窗口。窗口编号顺序和建立窗口的顺序相同，被激活的窗口处于屏幕的前端。

  • 命 令

从主菜单中选择窗口 > 前一个窗口

相关功能：点击窗口标志选择窗口


06_水平排序

Home > midas Gen 2017 > 02_视图 > 08_窗口布置 > 01_水平

水平排序

  • 功 能

在屏幕上按照棋盘形排列所有打开的窗口，图标窗口除外。按水平方向的长度调节每个窗口的大小。

  • 命 令

从主菜单中选择窗口 > 水平排序

相关功能：竖直排序、阶梯式排序


07_垂直排序

Home > midas Gen 2017 > 02_视图 > 08_窗口布置 > 02_竖直

垂直排序

  • 功 能

在屏幕上按照棋盘形排列所有打开的窗口，图标窗口除外。按垂直方向的长度调节每个窗口的大小。

  • 命 令

从主菜单中选择窗口 > 竖直排序

相关功能：水平排序、阶梯式排序


08_阶梯式排序

Home > midas Gen 2017 > 02_视图 > 08_窗口布置 > 03_阶梯

阶梯式排序

  • 功 能

以纸牌平铺方式在屏幕上重新排列当前所有打开的窗口，图标窗口除外。把所有的窗口调整成同样大小，顺序堆叠。

  • 命 令

从主菜单中选择窗口 > 阶梯式排序

相关功能：垂直排序、水平排序


01_结构类型

Home > midas Gen 2017 > 03_结构 > 01_类型 > 01_结构类型

结构类型

  • 功 能

输入结构分析的类型及其基本数据(初始温度，结构质量，重力加速度等）。

  • 命 令

从主菜单中选择模型 > 结构类型

从树形菜单的菜单表单中选择环境设置 > 结构类型

  • 输 入

<图1>结构类型对话框

结构类型

确定进行三维分析还是二维分析。

3-D：三维结构分析。

X-Z平面：在全局坐标系X-Z平面内的二维分析。

Y-Z平面：在全局坐标系Y-Z平面内的二维分析。

X-Y平面：在全局坐标系X-Y平面内的二维分析。

约束RZ：约束绕全局坐标系Z轴转动的自由度的三维分析。

结构类型选项输入方法：

在midas Gen中用户未指定约束时，默认每个节点有六个自由度。当用户仅关心二维工作状况或约束特定自由度时的工作状况时，使用排除多余自由度的分析可以提高分析效率。

3-D

一般的三维结构分析，每个节点具有六个自由度。

X-Z平面

结构仅在全局坐标系的X-Z平面内发生位移和变形(自动约束Y方向的位移和绕X轴和Z轴的转动)

Y-Z平面

结构仅在全局坐标系的Y-Z平面内发生位移和变形(自动约束X方向的位移和绕Y轴和Z轴的转动)

X-Y平面

结构仅在全局坐标系的X-Y平面内发生位移和变形(自动约束Z方向的位移和绕X轴和Y轴的转动)

约束RZ

约束绕全局坐标系的竖轴(Z轴)转动(扭转)的特殊三维分析。这种分析可用于结构初步设计，以便分析各楼层的横向剪力分布。

质量控制参数

设定选项，决定是否将模型自重转换为动力分析时的质量及相应的质量类型。

集中质量：转换为集中质量。

单元质量直接分配到单元的各节点上。对于集中质量矩阵，一般仅考虑其对角项，非对角项为0。

考虑非对角线质量：如果勾选该项，则计算时考虑质量矩阵中的非对角线成分。分析精确度提高的同时，分析时间会增加。

考虑截面偏心时，在偏心位置将会生成一个节点。荷载、边界条件、质量等将会作用到偏心位置，而与单元相关的结构特性，如单元刚度，单元荷载以及自重转换为质量等将会作用到截面质心

勾选该项时，单元自重转换为质量将计算到及截面质心。节点质量、节点荷载等与单元无关，将计算到偏心节点上。

注1：非对角线质量在时程分析中可以考虑；

注2：如考虑非对角线质量，特征值分析仅支持兰佐斯方法；

注3：如考虑非对角线质量，则考虑梁单元的截面偏心。质量偏心仅对梁单元适用。

振型参与系数中考虑刚体旋转状态：

对于未考虑刚性楼板假定的结构，选择是否考虑变换矩阵。勾选该项时，对于未考虑刚性楼板假定的结构，也可以计算旋转分量的振型参与质量。

未考虑刚性楼板假定时，如果所有的节点均有质量时，即便不勾选该项，也按照实际情况计算。

勾选该项对于周期、振型及振型向量等无影响，仅对振型参与质量有影响。

一致质量：转换为分布质量。

计算一致质量时，将会用到刚度矩阵计算中用到的形函数。非对角线成分也将考虑。与集中质量不同，质量之间的耦合作用将被考虑。因而采用一致质量计算的结果将更准确，但同时也会增加计算时间。

只有在特征值分析控制的分析类型中选择了兰佐斯法时，才能使用一致质量。

将自重转换为质量：

转换到X、Y、Z：将自重转换为全局坐标系X、Y、Z方向的集中质量。

转换到X、Y：将自重转换为全局坐标系X、Y方向的集中质量。

转换到Z：将自重转换为全局坐标系Z方向的集中质量。

注:

1. 在 midas Gen中，可以将模型中的单元质量自动转换为动力分析或计算静力等效地震荷载所需的集中质量。

2. 如果选择转换到X、Y、Z，程序根据在模型 > 特性 > 材料... 中输入的比重自动计算出单元重量，然后自动将其转换为全局坐标系X、Y、Z方向的节点质量(等于重量/重力加速度)。

3. 如果选择转换到X、Y，则将计算得到的质量只转换到全局坐标系的X、Y方向。

4. 如果选择转换到Z，则将计算得到的质量只转换到全局坐标系的Z方向。

5. 在大多数建筑结构中，横向动力反应远比竖向动力反应重要。因此通常忽略质量的垂直分量。考虑到节约分析时间并减轻计算机内存容量的负担，选择"转换到X、Y"会更有效果。

6. 仅考虑垂直地震的影响或需要分析楼板上的机器振动或其它竖向振动时，用"转换到Z"可能更合适。此时如果选择"转换到X、Y、Z"，为了保证Z轴方向的振型参与度，在做特征值分析时需要计算相当多的振型。当由"节点质量" 或 "荷载转为质量"生成质量时，该概念同样适用。

7. 对线单元(桁架单元、只受拉单元、只受压单元、梁单元等)而言，程序将计算得到的单元质量等分给两端节点，并转化为节点质量。

8. 对平面单元(平面应力单元、板单元)和实体单元而言，程序将计算得到的单元质量等分给每个节点，并转化为节点质量。

9. 在模型 > 质量 > 将荷载转换成质量...中不能将单元的自重转换为质量。如果要做动力分析(包括地震动力分析)，将结构的自重转化为质量，必须在结构类型中设定相关条目。

重力加速度

按使用的单位体系输入重力加速度值。

   初始温度

输入温度应力分析所需的初始温度值。(参见荷载 > 系统温度 或 节点温度)。

在图形显示中，将梁顶标高与楼面(X-Y平面)标高对齐

在模型空间窗口显示单元时，使在全局坐标系X-Y平面内布置的线单元顶面与所在的楼面平面(柱节点位置)处于同一标高。

在图形显示中，将板顶标高与楼面(X-Y平面)标高对齐

在模型窗口中显示单元时，使在全局坐标系X-Y平面内布置的板单元顶面与所在的楼面平面(柱节点位置)处于同一标高。

注:
不选择排列选项时，图形将显示线单元和板单元的中心线与单元所在楼板平面对齐。选择此项时，程序内部计算梁柱的刚域位置将有所不同。


01_梁

Home > midas Gen 2017 > 03_结构 > 02_建模助手 > 基本结构 > 01_梁

梁

  • 功 能

使用梁建模助手可以实现在同一条直线上自动生成一系列水平梁单元。

注：这只是MIDAS中一种实现建梁的方法，常用的建梁方法主要有扩展，点选连接等。

  • 命 令

从主菜单中选择 模型 > 结构建模助手 > 梁

从树形菜单的菜单表单中选择几何模型 > 结构建模助手 > 梁

  • 输 入

<图1> 输入/编辑对话框

输入/编辑对话框

类型1:根据梁长生成梁单元，可同时生成不同长度的多个梁单元(Ex. 5.0, 3.0, 4.5, 3@5.0) 。

类型2:根据节点间距离及重复次数生成多个梁单元。

间距:一个或多个梁长。

距离:输入节点间的距离。

重复:输入重复的次数，按输入的距离重复形成多个单元。

:按输入的间距或节点距离和重复数量形成节点和单元。

:删除选定的节点。

:删除输入的全部节点。

自动生成边界条件:确认是否自动赋予每个节点以简支的边界条件，如不勾选也可在建完后定义。

显示单元号码:显示生成的梁的单元编号。

材料:输入使用的材料特性

单击 增加新的材料特性或修改现有的材料特性。

截面:输入使用的截面特性。

单击 增加新的截面或修改现有的截面。

<图2> 插入对话框

插入对话框

插入点:输入建立的梁的原点在全局坐标系(用户坐标系)下插入点的坐标。或者用鼠标在输入区内单击，并在工作窗口中点击插入点的位置，则程序将自动将该点的坐标显示在输入框内。

旋转:输入梁的布置方向，即输入梁绕全局坐标系的坐标轴X、Y、Z旋转的角度α、β、γ。

合并重复节点:决定是否合并现有模型和最新形成的梁的节点之间重叠的节点。

：设置合并节点的容许误差(公差)。

在交叉点分割单元:最新形成的梁与现有模型有交叉时，决定是否在交叉点处分割现有单元。

：设置单元交叉的容许误差(交叉公差)，即决定多大距离下可以看成两单元已交叉在一起。

显示号:显示创建的梁的节点编号。

原点:设置将建立的梁的原点，该点在建模助手窗口中显示为红色。


02_柱

Home > midas Gen 2017 > 03_结构 > 02_建模助手 > 基本结构 > 02_柱

柱

  • 功 能

用柱建模助手沿同一条直线自动生成一系列垂直的梁单元。

  • 命 令

从主菜单中选择模型 > 结构建模助手 > 柱

从树形菜单的菜单表单中选择几何 > 结构建模助手 > 柱

  • 输 入

<图1> 输入/编辑对话框

输入/编辑对话框

距离:输入节点间的距离。

重复:输入重复数量以形成多个单元。

:按输入的节点距离和重复数量形成节点和单元。

:删除选定的节点。

:删除输入的全部节点。

边界条件:选择底部节点的支承条件(铰支、固定或无) 。

显示单元号码:显示生成的柱的单元编号。

材料:输入使用的材料特性。

单击 增加新的材料特性或修改现有的材料特性。

截面:输入使用的截面特性。

单击 增加新的截面或修改现有的截面。

<图2> 插入对话框

插入对话框

插入点:输入建立的柱的原点在全局坐标系(用户坐标系)下插入点的坐标。或者用鼠标在输入区内单击，并在工作窗口中点击插入点的位置，则程序将自动将该点的坐标显示在输入框内。

显示号:显示创建的柱的节点编号。

原点:设置将建立的柱的原点，该点在建模助手窗口中显示为红色。

旋转:输入柱的布置方向，即输入柱绕全局坐标系的坐标轴X、Y、Z旋转的角度α、β、γ。

合并重复节点:决定是否合并现有模型和最新形成的柱之间重叠的节点。

：设置合并节点的容许误差(公差)。

在交叉点分割单元:最新形成的柱与现有模型有交叉时，决定是否在交叉点处分割现有单元。

：设置单元交叉的容许误差(交叉公差)，即决定多大距离下可以看成两单元已交叉在一起。


03_拱

Home > midas Gen 2017 > 03_结构 > 02_建模助手 > 基本结构 > 03_拱

拱

  • 功 能

用拱建模助手自动生成由一系列直线梁单元组成的拱结构

注：分析的精度取决于分割的数量，建议加大分割的数量。

  • 命 令

从主菜单中选择模型 > 结构建模助手 > 拱

从树形菜单的菜单表单中选择几何模型 > 结构建模助手 > 拱

快捷键： [Ctrl]+[Shift]+W

  • 输 入

<图1> 输入/编辑对话框

输入/编辑对话框

类型:选择拱的形状，建模(圆、等投影间距抛物线、等间距抛物线、等投影间距椭圆、等间距椭圆、等投影间距悬链线、等间距悬链线等)。

分割数量:输入拱的分割数量。

边界条件:选择拱两端点处的支承条件(铰支、固定或无)。

  1. 拱类型为圆弧时:

R：圆的半径

θ：圆心角

  1. 拱类型为椭圆形或抛物线时:

跨度(L)：输入拱的水平投影长度。

高度(H)：输入拱的高度。

  1. 拱类型为悬链线时:

跨度(L)：输入拱的水平投影长度。

高度(H)：输入拱的高度。

拱轴系数(m)：输入拱轴系数。

  1. 拱类型为二次或三次曲线时

跨度(L)：输入拱的水平投影长度。

f(x): 输入曲线的方程。

显示单元号:显示生成的拱的单元编号。

材料:输入使用的材料特性。

单击 增加新的材料特性或修改现有的材料特性。

截面:输入使用的截面。

单击 增加新的截面或修改现有的截面。

<图2> 插入对话框

插入对话框

插入点:输入建立的拱的原点在全局坐标系(用户坐标系)下插入点的坐标。或者用鼠标在输入区内单击，并在工作窗口中点击插入点的位置，则程序将自动将该点的坐标显示在输入框内。

旋转:输入拱的布置方向，即输入拱绕全局坐标系的坐标轴X、Y、Z旋转的角度α、β、γ。

合并重复节点:决定是否合并现有模型和最新形成的拱的节点之间重叠的节点。

：设置合并节点的容许误差(公差)。

在交叉点分割单元:最新形成的拱与现有模型有交叉时，决定是否在交叉点处分割现有单元。

：设置单元交叉的容许误差(交叉公差)，即决定多大距离下可以看成两单元已交叉在一起。

原点:设置将建立的拱的原点，该点在建模助手窗口中显示为红色。

显示号:显示创建的拱的节点编号。


04_框架

Home > midas Gen 2017 > 03_结构 > 02_建模助手 > 基本结构 > 04_框架

框 架

  • 功 能

使用框架建模助手在三维空间内自动生成由梁单元组成的二维平面框架。

  • 命 令

从主菜单中选择模型 > 结构建模助手 > 框架

从树形菜单的菜单表单中选择几何模型 > 结构建模助手 > 框架

快捷键： [Ctrl]+[Shift]+X

  • 输 入

<图1> 输入对话框

输入对话框

距离:输入节点间的距离。

重复:输入重复数量以在网格图形中形成多个等间距单元。

:按输入的节点距离和重复数量形成节点。

:删除选择的坐标方向的网格。

显示尺寸:在建模助手图形窗口中显示输入的尺寸。

<图2> 编辑对话框

编辑对话框

:用输入的节点生成基本框架单元。

:删除选定的单元，删除单元后其余单元自动重新编号。

显示单元号:显示生成的平面框架的单元编号。

Beta角:选择生成的单元的Beta角。

材料:输入使用的材料特性。

单击 增加新的材料特性或修改现有的材料特性。

截面:输入使用的截面特性。

单击 增加新的截面或修改现有的截面。

<图3> 插入对话框

插入对话框

插入点:输入建立的框架的原点在全局坐标系(用户坐标系)下插入点的坐标。或者用鼠标在输入区内单击，并在工作窗口中点击插入点的位置，则程序将自动将该点的坐标显示在输入框内。

旋转:输入框架的布置方向，即输入框架绕全局坐标系的坐标轴X、Y、Z旋转的角度Alpha、Beta、Gamma。

合并重复节点:决定是否合并现有模型和最新形成的框架的节点之间重叠的节点。

：设置合并节点的容许误差(公差)。

在交叉点分割单元:最新形成的框架与现有模型有交叉时，决定是否在交叉点处分割现有单元。

：设置单元交叉的容许误差(交叉公差)，即决定多大距离下可以看成两单元已交叉在一起。

显示号:显示创建的框架的节点编号。

原点:设置将建立的框架的原点，该点在建模助手窗口中显示为红色。


05_桁架

Home > midas Gen 2017 > 03_结构 > 02_建模助手 > 基本结构 > 05_桁架

桁 架

  • 功 能

用桁架建模助手自动生成由梁单元和桁架单元组成的桁架结构(上下弦-梁单元，竖杆和腹杆-桁架单元)。

  • 命 令

从主菜单中选择模型 > 结构建模助手 > 桁架

从树形菜单的菜单表单中选择几何模型 > 结构建模助手 > 桁架

快捷键： [Ctrl]+[Shift]+Y

  • 输 入

<图1> 输入对话框

输入对话框

类型:选择桁架类型和腹杆形式。

节间数量:输入桁架节间数量。

选项:选择桁架对称或不对称。

L:输入桁架半跨长度。

H1, H2:输入桁架端部和跨中高度。

D1, D2:输入下弦端部第一内节点和跨中节点与支撑节点高差。

显示尺寸:在建模助手窗口中显示输入的尺寸。

<图2> 编辑对话框

编辑对话框

插入:在端部或跨中增加竖杆。

合并连续的单元:不增加竖杆时，合并因分配给竖杆的节点分离的上弦和下弦。

显示单元号:显示生成的桁架的单元编号。

材料:输入使用的材料特性。

单击 增加新的材料特性或修改现有的材料特性。

截面:输入上弦、下弦、腹杆和竖杆的截面特性。

单击 增加新的截面或修改现有的截面。

所有构件使用相同材料：如勾选该项，则上弦、下弦、竖杆和腹板均使用相同的材料。

<图3> 插入对话框

插入对话框

插入点:输入建立的桁架的原点在全局坐标系(用户坐标系)下插入点的坐标。或者用鼠标在输入区内单击，并在工作窗口中点击插入点的位置，则程序将自动将该点的坐标显示在输入框内。

释放梁端约束

<图4> 释放梁端约束对话框

显示选项:在建模助手对话框中显示单元号、节点号、释放梁端约束符号。点击use中方框可确定释放梁端约束的节点。

旋转:输入桁架的布置方向，即输入桁架绕全局坐标系的坐标轴X、Y、Z旋转的角度α、β、γ。

合并重复节点:决定是否合并现有模型和最新形成的桁架的节点之间重叠的节点。

：设置合并节点的容许误差(公差)。

在交叉点分割单元:最新形成的桁架与现有模型有交叉时，决定是否在交叉点处分割现有单元。

：设置单元交叉的容许误差(交叉公差)，即决定多大距离下可以看成两单元已交叉在一起。

显示号:显示创建的桁架的节点编号。

原点:设置将建立的桁架的原点，该点在建模助手窗口中显示为红色。


06_板

Home > midas Gen 2017 > 03_结构 > 02_建模助手 > 基本结构 > 06_板

板

  • 功 能

用板建模助手自动生成由板单元组成的矩形、圆形或半圆形板结构。

  • 命 令

从主菜单中选择模型 > 结构建模助手 > 板

从树形菜单的菜单表单中选择几何模型 > 结构建模助手 > 板

快捷键： [Ctrl]+[Shift]+Z

  • 输 入

<图1> 输入对话框

输入表单

类型1:输入要形成的板的形状(矩形、圆形或半圆形)。

B:输入板结构的宽度。

H:输入板结构的高度。

R：输入板结构的半径(圆形或半圆形)。

显示尺寸：在建模助手窗口中显示输入的尺寸。

材料：输入使用的材料特性。

单击 增加新的材料特性或修改现有的材料特性。

厚度：输入使用的板的厚度。

单击 增加新的厚度或修改现有的厚度。

<图2> 编辑对话框

编辑表单

类型2：在要形成的板结构中选择孔的形状(无、矩形或圆形)。

分割单元尺寸：输入板单元的分割尺寸。

分割数量:输入板结构x和z方向的单元分割数量。

注：分割数量仅适用于无孔板。

尺寸:输入分割的板单元的最大尺寸(边长)。

m:输入矩形板结构宽度和高度方向上的分割数量(分别为m和n)。

n:圆形板结构时为圆弧方向和半径方向的分割数量。

Db, Dh:输入板结构中心和孔中心之间宽度和高度方向上的距离(分别为Db和Dh)。

b, h:输入矩形孔的宽度和高度。

r:输入圆形或半圆形孔的半径。

显示辅助尺寸:显示孔的位置和大小尺寸。

<图3> 插入对话框

插入对话框

插入点:输入建立的板的原点在全局坐标系(用户坐标系)下的插入点的坐标。或者用鼠标在输入区内单击，并在工作窗口中点击插入点的位置，则程序将自动将该点的坐标显示在输入框内。

旋转:输入板的布置方向，即输入板绕全局坐标系的坐标轴X、Y、Z旋转的角度α、β、γ。

合并重复节点:决定是否合并现有模型和最新形成的板的节点之间重叠的节点。

：设置合并节点的容许误差(公差)。

在交叉点分割单元:最新形成的板与现有模型有交叉时，决定是否在交叉点处分割现有单元。

：设置单元交叉的容许误差(交叉公差)，即决定多大距离下可以看成两单元已交叉在一起。

显示号:显示创建的板的节点编号。

原点:设置将建立的板的原点，该点在建模助手窗口中显示为红色。


07_壳

Home > midas Gen 2017 > 03_结构 > 02_建模助手 > 基本结构 > 07_壳

壳

  • 功 能

用壳建模助手自动生成由板单元组成的棱锥、棱锥台、圆台、圆柱、球形或半球形壳结构。

  • 命 令

从主菜单中选择模型 > 结构建模助手 > 壳

从树形菜单的菜单表单中选择几何模型 > 结构建模助手 > 壳

  • 输 入

<图1> 输入/编辑对话框

输入/编辑对话框

类型：选择壳结构的形状(棱锥台、圆台、球形或半球形)。

B1, B2, B3, B4：输入棱锥台壳结构的尺寸。

R1，R2： 输入圆柱形壳结构的上口半径(R1)和下口半径(R2)。

输入球形或半球形壳结构的半径(R1)。

H：输入矩形箱型壳结构或球形壳结构的高度。

分割数量：输入棱锥台壳结构的长(x轴)、宽(y轴)、高(z轴)方向的分割数量(m、n、l)。

圆台壳结构的圆弧方向和高度方向的分割数量(m、l)。

球壳结构的纬度和经度方向的分割数量(m、l)。

材料：输入使用的材料特性。

单击 增加新的材料特性或修改现有的材料特性。

厚度：输入使用的板的厚度。

单击 增加新的厚度或修改现有的厚度。

<图2> 插入对话框

插入对话框

插入点：输入建立的壳结构的原点在全局坐标系(用户坐标系)下的插入点的坐标。或者用鼠标在输入区内单击，并在工作窗口中点击插入点的位置，则程序将自动将该点的坐标显示在输入框内。

旋转：输入壳结构的布置方向，即输入壳结构绕全局坐标系的坐标轴X、Y、Z旋转的角度α、β、γ。

合并重复节点：决定是否合并现有模型和最新形成的壳结构的节点之间重叠的节点。

：设置合并节点的容许误差(公差)。

在交叉点分割单元：最新形成的壳结构与现有模型有交叉时，决定是否在交叉点处分割现有单元。

：设置单元交叉的容许误差(交叉公差)，即决定多大距离下可以看成两单元已交叉在一起。

显示号：显示创建的壳结构的节点编号。

原点：设置将建立的壳结构的原点，该点在建模助手窗口中显示为红色。


08_塔腿

Home > midas Gen 2017 > 03_结构 > 02_建模助手 > 08_塔腿

塔腿

  • 功 能

用塔腿建模助手自动生成塔脚，用于塔架结构的快速建模。

  • 命 令

从主菜单中选择模型 > 结构建模助手 > 塔腿

  • 输 入

<图1> 塔腿建模助手对话框

塔腿号

显示尺寸

在建模助手中显示塔腿尺寸。

W

塔腿的宽度

使用塔腿

勾选后输入塔腿的平面分割数量，上部宽度，下部宽度及塔腿高度。

选择类型

正面：选择塔腿正面形式

平面：选择塔腿平面形式

边界条件

铰接或不设置边界条件。

插入点

输入塔腿在模型视图中的插入位置。有两种输入方法：

（1）点击输入对话框后，在模型视图中选择合适的位置；

（2）直接用键盘输入节点坐标。

旋转

输入塔腿插入到模型视图时的旋转角度。

Alpha：绕整体坐标系X轴方向旋转角度；

Beta：绕整体坐标系Y轴方向旋转角度；

Gamma：绕整体坐标系Z轴方向旋转角度；

原点

指定节点，插入到指定位置（根据插入点中的定义）。

选择原点后，窗口中会以红色圆点显示。


09_塔身

Home > midas Gen 2017 > 03_结构 > 02_建模助手 > 09_塔身

塔身

  • 功 能

用塔身建模助手自动生成塔体，用于塔架结构的快速建模。

  • 命 令

从主菜单中选择模型 > 结构建模助手 > 塔身

  • 输 入

<图1> 塔身建模助手对话框

塔身号

塔身编号

W1：塔身下部宽度

W2：塔身上部宽度

添加

根据输入信息，在选择的部分后边增加新的部分；

编辑

根据输入信息修改所选的部分；

删除

将所选的部分删除；

定义类型

水平：选择水平类型；

竖直：选择竖直类型；

辅助构件行数：最多可以输入三行

插入点

输入塔身在模型视图中的插入位置。有两种输入方法：

（1）点击输入对话框后，在模型视图中选择合适的位置；

（2）直接用键盘输入节点坐标。

旋转

输入塔身插入到模型视图时的旋转角度。

Alpha：绕整体坐标系X轴方向旋转角度；

Beta：绕整体坐标系Y轴方向旋转角度；

Gamma：绕整体坐标系Z轴方向旋转角度；

除特别情况需要旋转外，一般无需处理。

原点

指定节点，插入到指定位置（根据插入点中的定义）。

选择原点后，窗口中会以红色圆点显示。

显示尺寸

在建模助手中显示塔身尺寸。

固定宽度

勾选时，部分上部宽度固定为W

W：该部分的宽度，未固定时程序自动计算，无需输入；

H：该部分的高度


10_塔臂

Home > midas Gen 2017 > 03_结构 > 02_建模助手 > 10_塔臂

塔臂

  • 功 能

用塔臂建模助手自动生成塔臂，用于塔架结构的快速建模。

  • 命 令

从主菜单中选择模型 > 结构建模助手 > 塔臂

  • 输 入

<图1> 塔臂建模助手对话框

塔臂号

塔臂编号

显示尺寸

在建模助手中显示塔臂尺寸。

使用塔臂

W1：塔臂下部宽度

W2：塔臂上部宽度

正面：选择正面类型

平面: 选择平面类型

使用左侧臂

平面分割数量：输入平面分割的数量

L：左侧塔臂水平长度

H：左侧塔臂竖向高度

D：只有当塔臂平面为梯形时才需要输入

内部：选择塔臂内部辅助构件的类型；

不生成左侧塔臂时，不勾选“使用左侧臂”

使用右侧臂

平面分割数量：输入平面分割的数量

L：右侧塔臂水平长度

H：右侧塔臂竖向高度

D：只有当塔臂平面为梯形时才需要输入

内部：选择塔臂内部辅助构件的类型；

不生成右侧塔臂时，不勾选“使用右侧臂”

插入点

输入塔臂在模型视图中的插入位置。有两种输入方法：

（1）点击输入对话框后，在模型视图中选择合适的位置；

（2）直接用键盘输入节点坐标。

旋转

输入塔臂插入到模型视图时的旋转角度。

Alpha：绕整体坐标系X轴方向旋转角度；

Beta：绕整体坐标系Y轴方向旋转角度；

Gamma：绕整体坐标系Z轴方向旋转角度；

除特别情况需要旋转外，一般无需处理。

原点

指定节点，插入到指定位置（根据插入点中的定义）。

选择原点后，窗口中会以红色圆点显示。


01_控制数据

Home > midas Gen 2017 > 03_结构 > 03_控制数据 > 01_控制数据

控制数据

  • 功 能

决定计算风荷载和地震作用时所需的地面高度，并决定在做特征值分析时是否考虑模型中地面以下的质量。(参见"风荷载"和 "静力地震荷载")

  • 命 令

从主菜单中选择模型 > 建筑物数据 > 控制数据...

从树形菜单的菜单表单中选择模型 > 建筑 > 控制数据...

  • 输 入

建筑控制数据对话框

使用地面高度:决定在计算风荷载和地震作用时是否使用地面标高。

地面标高:程序默认风荷载只作用在该坐标以上，用基底剪力法计算地震作用时，程序只计算该标高以上的等效重力荷载。

做特征值分析时，考虑地面以下的质量

注：当不选择该项时，特征值分析中的质量矩阵将排除地面以下的质量。

层剪力比

决定是否输出层剪力比。

考虑多塔：选择输出层剪力的方式。分析多塔模型时需勾选此项。

对弹性板考虑风荷载和静力地震作用

偏心率:选择计算层中心的方法

层中心(质量/荷载)：指定层中心计算方法，用来计算偏心率。

使用质量计算：使用质量分布来找到层中心。

使用轴力计算：使用静力荷载作用下的轴力来计算层中心， 可同时添加多个静力荷载工况。

使用剪力计算：使用整体坐标轴X、Y方向的静力地震作用下的剪力来计算层中心。

计算层刚度中心用荷载工况：指定计算层刚度中心用荷载工况，用来计算偏心率。

X-方向荷载工况：选择用于计算相对Y轴偏心的荷载工况。

Y-方向荷载工况：选择用于计算相对X轴偏心的荷载工况。

时程分析结果的层反应

层重心：用前面的层中心计算方法给出层位移/层速度/层加速度结果。

层平均：当没有设置刚性楼板或没有计算层中心时，可选择该项给出所有竖向构件的平均时程结果。


02_定义层数据

Home > midas Gen 2017 > 03_结构 > 03_控制数据 > 02_定义层数据

定义层数据

  • 功 能

层的位置由楼板在全局坐标系Z方向的坐标决定,所以建筑物的楼层平面必须与整体坐标系的X-Y平面平行。

层的用途如下:

    1. 用于定义墙构件号。

    2. 用于自动计算风荷载和计算地震作用，并将计算得到的横向荷载加载到各层。(参见"风荷载"和 "静力地震荷载")

    3. 在建筑各层自动考虑刚性楼板效应，并输入各层刚性楼板质量。(参见"刚性楼板质量")

    4. 用于输出层位移、层间位移、层间刚度比、剪重比、层偏心等。(参见"层间位移"、"层重量表格"、"层荷载表格")

  • 命 令

从主菜单中选择模型 > 建筑物数据 > 定义层数据...

从树形菜单的菜单表单中选择模型 > 建筑物数据 > 定义层数据...

快捷键 : [F10]

  • 输 入

用户既可以在电子表格中直接输入层数据，也可点击 [image] 自动生成。

层数据对话框

地面高度:地面的全局坐标系Z轴坐标，生成层时，该坐标以下的层被认为是地下室，并按 'B1', 'B2'...顺序命名。

直接在表格中输入层数据

MIDAS 软件中的表格工具提供了各种强大的内置功能,详细说明参见下列各项：

表格工具的使用

术语

掌握使用方法

基本说明(单元移动、选择、大小控制等)

数据处理(增加、删除、修改数据)

用剪贴板复制/粘贴数据

表格功能补充

表格排序

表格格式设定

自动适应列宽

图表打印

各表格类型的补充功能

节点/单元表格

结果表格

该对话框中提供与层相关的三个表格，各表格中内容如下:

层表单

名称: 层的名称

标高: 层标高

高度: 层高度

楼板刚性楼板: 决定是否将相应层楼板设置为刚性。

风表单

名称: 层名称

楼板宽度X-方向: 承受沿整体坐标系Y轴方向作用的风荷载的迎风面宽度

楼板宽度Y-方向: 承受沿整体坐标系X轴方向作用的风荷载的迎风面宽度

楼板中心Xc: 风荷载作用点在整体坐标系X轴方向的位置。

楼板中心Yc: 风荷载作用点在整体坐标系Y轴方向的位置。

地震表单

名称: 层名称

偏心X-方向:

计算等效静力地震荷载(基底剪力法)时，沿整体坐标系X轴方向的偶然偏心距离。

偏心Y-方向:

计算等效静力地震荷载(基底剪力法)时，沿整体坐标系Y轴方向的偶然偏心距离。

自动生成层数据的方法

: 点击该键，程序将根据输入的模型几何数据自动生成层数据。

注:
在Gen中是根据输入的节点Z坐标生成层数据的，既所有节点位置均被程序认定为层高位置。

当有些节点并不位于层高位置(位于层间位置)时，用户在右侧列表中选择相应层然后点击 [image] 将其从层列表中删除。

删除一些不必要的层时，程序自动将层名称递补。

层数据对话框

考虑偶然偏心:

决定计算地震作用时是否考虑偶然偏心的影响，并输入偶然偏心量。

注：此处偏心针对底部剪力法。

定义多塔

定义多塔对话框

塔名称：用户定义塔楼名称；

选择层：

起始层：选择该塔的起始楼层
包含：如果勾选，则包含该起始层，如果不勾选，则不包含该起始层；

终止层：选择该塔的终止楼层

包含：如果勾选，则包含该终止层，如果不勾选，则不包含该终止层；

定义楼层范围

勾选后，可以在视图窗口中通过多边形来指定塔楼范围，定义结束后，按“Enter”键结束定义。

添加：定义好塔楼数据后，点击“添加”按钮，即可完成塔楼的定义。

编辑：对已经定义好的塔楼数据进行修改。

删除：删除已经定义的塔楼数据。


03_复制层数据

Home > midas Gen 2017 > 03_结构 > 03_控制数据 > 03_复制层数据

复制层数据

  • 功 能

将已经建立的节点和单元复制生成建筑物数据。

  • 命 令

从主菜单中选择模型 > 建筑物数据 > 复制层数据...

从树形菜单的菜单表单中选择模型 > 建筑物数据 > 复制层数据...

快捷键: [Ctrl]+G

  • 输 入

节点起始号

决定新生成的节点起始号码，程序默认该号码为当前最大号码+1，当需要修改该项时可以点击 [image] ，重新设定起始号。

单元起始号

决定新生成的单元起始号码，程序默认该号码为当前最大号码+1，当需要修改该项时可以点击 [image] ，重新设定起始号。

生成建筑数据

复制次数: 复制层的次数(不包含当前层)

距离(全局Z): 沿全局坐标系Z轴的复制间距(层高)

注：输入负数时，表示向下复制。

材料号的增幅: 复制时自动生成的材料号的增幅。

柱截面号的增幅: 复制时自动生成的柱截面号的增幅。

梁截面号的增幅: 复制时自动生成的梁截面号的增幅。

支撑号的增幅: 复制时自动生成的支撑截面号的增幅。

墙厚度号的增幅: 复制时自动生成的墙厚度号的增幅。

操作

: 添加新的楼层复制参数。

: 修改选择的楼层复制参数

: 删除选择的楼层复制参数

注：当准备将各层的增分号设置成不同时，可以先输入复制的层高后点击 [image] ，然后在表格中输入增分量。

复制节点属性：

当作为复制对象的节点上输入有边界条件和荷载等属性时，可以将这些属性一同复制到新的节点上。当只想复制其中一部分属性时可点击 [image] 键，选择相应属性。

复制单元属性：

当作为复制对象的单元上输入有边界条件和荷载等属性时，可以将这些属性一同复制到新的单元上。当只想复制其中一部分属性时可点击 [image] 键，选择相应属性。

复制建筑的属性：

作为复制对象的单元上有刚性连接或分配楼板荷载等特性时，可将这些属性一同复制到其他楼层。只想复制其中一部分属性时可点击 [image] 键，选择相应属性。

:

输入新生成的节点和原有节点合并的条件，在输入的数据范围内的节点均将被合并。

注:自动生成层数据

    1. 首先建立标准层的单元。

    2. 输入各层层高，复制标准层。

在复制次数中输入'3', 距离中输入'3.5' +

在复制次数中输入'4', 距离中输入'4' +

则在复制表格中显示如下数据:

      3. 点击 [image] ，按层输入材料和截面号的增分量。可以赋予柱、梁、墙、支撑等构件以不同的增分量。

  4. 点击 [image] ，复制条件列表中的信息将变成如下状态。

  5. 选择复制对象以后，点击 [image] 将自动生成如下形式的建筑。

注：

当各层层高、材料、截面尺寸变化较大时，使用该功能能快速地建立模型。


04_自动生成墙号

Home > midas Gen 2017 > 03_结构 > 03_控制数据 > 04_自动生成墙号

自动生成墙号

  • 功 能

自动生成各层墙单元的墙号(Wall ID)。使用单元扩展功能将线单元扩展为墙单元时，程序可以自动修正墙构件号。

  • 命 令

从主菜单中选择模型 > 建筑物数据 > 自动生成墙号...

从树形菜单的菜单表单中选择模型 > 建筑物数据 > 自动生成墙号...

  • 输 入

自动生成墙号对话框

选择

层:选择需要自动生成墙号的层。

所有:对全楼自动生成墙号。


01_定义用户坐标系

Home > midas Gen 2017 > 03_结构 > 04_坐标系/平面 > 01_UCS

定义用户坐标系

  • 功 能

定义用户坐标系(UCS)。

绝大多数实际结构的平面和立面是比较复杂的，但即使多么复杂的平面和立面也都是由规则的几何体组成的。因此用户可以为各几何体分别建立坐标系，在各自的坐标系上分别建模。用户坐标系是快速建立复杂模型的有效手段。

在图标菜单中点击 [image] GCS或 [image] UCS，可以在用户坐标系(UCS)和全局坐标系(GCS)之间切换。

此外，将UCS x-y平面与栅格一起使用设定栅格线的栅格点可提供高效的建模环境。

  • 命 令

从主菜单中选择模型 > 用户坐标系统 > X-Y平面...

从主菜单中选择模型 > 用户坐标系统 > X-Z平面...

从主菜单中选择模型 > 用户坐标系统 > Y-Z平面...

从主菜单中选择模型 > 用户坐标系统 > 由三个点设定UCS...

从主菜单中选择模型 > 用户坐标系统 > 由三个角度设定UCS...

从主菜单中选择模型 > 用户坐标系统 > 已命名的平面...

从主菜单中选择模型 > 用户坐标系统 > 由当前的UCS设定UCS...

从主菜单中选择模型 > 用户坐标系统 > 已命名的UCS...

在树形菜单的菜单表单中选择几何模型 > 用户坐标系统 > X-Y平面

在树形菜单的菜单表单中选择几何模型 > 用户坐标系统 > X-Z平面

在树形菜单的菜单表单中选择几何模型 > 用户坐标系统 > Y-Z平面

在树形菜单的菜单表单中选择几何模型 > 用户坐标系统 > 由三个点设定UCS...

在树形菜单的菜单表单中选择几何模型 > 用户坐标系统 > 由三个角度设定UCS...

在树形菜单单菜单表单单中选择几何模型 > 用户坐标系统 > 已命名的平面

在树形菜单的菜单表单中选择几何模型 > 用户坐标系统 > 由当前的UCS设定UCS...

在树形菜单的菜单表单中选择几何模型 > 用户坐标系统 > 已命名的UCS

在图标菜单中单击 [image] X-Y

在图标菜单中单击 [image] X-Z

在图标菜单中单击 [image] Y-Z

在图标菜单中单击 [image] 由三个点设定UCS...

在图标菜单中单击 [image] 由三个角度设定UCS...

在图标菜单中单击 [image] 已命名的平面

在图标菜单中单击 [image] 由当前UCS定义UCS

  • 输 入

在对话框中选择相应表单并输入相应数据。

激活UCS平面

激活UCS平面，包括坐标原点。可以使用 [image] 全部激活功能激活模型的剩余部分。

修改视角

自动将视点调整到UCS的(+)z方向。

X-Y平面表单

将局部坐标系的x-y平面设置为平行于GCS(整体坐标系)X-Y平面。

原点：输入局部坐标系原点的GCS坐标。

注：
既可以输入坐标值，也可以用鼠标点击文本输入窗口后再点击模型窗口的相应位置即可。

旋转角度：局部坐标系的x-y平面绕GCS的Z轴旋转时，输入旋转角度(对Z轴用右手法则确定旋转角度的正负号)。

<图1>X-Y平面表单

X-Z平面表单

将局部坐标系的x-y平面设置为平行于GCS(整体坐标系)X-Z平面。

原点：输入局部坐标系原点的GCS坐标。

注：
既可以输入坐标值，也可以用鼠标点击文本输入窗口后再点击模型窗口的相应位置即可。

旋转角度

局部坐标系的x-y平面绕GCS的Y轴旋转时，输入旋转角度(对(-)Y轴用右手法则确定旋转角度的正负号)。

<图2>X-Z平面表单

Y-Z平面表单

将局部坐标系的x-y平面设置为平行于GCS(整体坐标系)Y-Z平面。

原点：输入局部坐标系原点的GCS坐标。

注：
既可以输入坐标值，也可以用鼠标点击文本输入窗口后再点击模型窗口的相应位置即可。

旋转角度：局部坐标系的x-y平面绕GCS的X轴旋转时，输入旋转角度(对X轴用右手法则确定旋转角度的正负号)。

<图3>Y-Z平面表单

三点表单

输入局部坐标系的原点以及局部坐标系x-y平面上的两点设置局部坐标系。

原点：输入局部坐标系原点的GCS坐标。

注：
既可以输入坐标值，也可以用鼠标点击文本输入窗口后再点击模型窗口的相应位置即可。

x轴上的一点：输入局部坐标系的x轴上的任意点，输入该点后即可定义局部坐标系的x轴。

xy平面上的一点：输入局部坐标系的xy平面上的任意点，输入该点后即可定义局部坐标系的x-y平面。

<图4>三点表单

三角表单

输入局部坐标系的原点以及三个角度来定义UCS。

原点：输入局部坐标系原点的GCS坐标。

注：
既可以输入坐标值，也可以用鼠标点击文本输入窗口后再点击模型窗口的相应位置即可。

1. 对于X轴：输入绕GCS的X轴的旋转角度。

2. 对于y'轴：输入绕经第一步旋转后生成的y'轴的旋转角度。

3. 对于z''轴：输入绕经第一步及第二步修改后生成的z''轴的旋转角度。

<图5>三角表单

(a) 绕GCS的X轴旋转AX度

(b) 绕新生成的y'轴旋转AY度(y'轴在步骤a中定义)

(c) 绕新生成的z"轴旋转AZ度(z"轴在步骤b中定义)

<图6>定义UCS(三点)

已命名的平面表单

选择用模型 > 命名平面定义的平面作为UCS的x-y平面。

<图7>已命名的平面对话框

由当前的UCS定义UCS表单

修改当前的UCS作为新的UCS。

<图8>用UCS定义UCS对话框

绕x轴旋转：绕当前局部坐标系x轴的旋转角度。

绕y轴旋转：绕当前局部坐标系y轴的旋转角度。

绕z轴旋转：绕当前局部坐标系z轴的旋转角度。

原点：输入新的UCS原点坐标(输入在当前UCS坐标系中的坐标)。

已命名的UCS表单

使用先前保存的UCS坐标。

<图8>已命名的UCS表单

用户坐标系名称：已保存的UCS名称

原点：选择的UCS的原点坐标(全局坐标系坐标)。

ux：选择的UCS的x轴方向的单位向量。

uy：选择的UCS的y轴方向的单位向量。

单击对话框底部的 [image] 将显示保存当前UCS名称对话框。

<图9>保存当前UCS名称表单


02_定义点格

Home > midas Gen 2017 > 03_结构 > 04_坐标系/平面 > 02_栅格

定义点格

  • 功 能

选定点格的间距和显示区域。

点格的显示是由初始参数的选择决定的，初始参数在工具 > 参数设置中使用环境中的视图内设置。

点格显示在UCS的x-y平面中。

点击视图 > 栅格中的点格命令可以显示或不显示栅格。

将该功能与 捕捉点格同时使用将提高建模的方便性。

  • 命 令

从主菜单中选择模型 > 栅格 > 定义点格...

从树形菜单的菜单表单中选择几何模型 > 栅格 > 点格

在图标菜单中单击 设置点栅格

  • 输 入

<图1> 定义点格对话框

轴网间距

dx、dy

输入用户坐标系x、y方向的点格间距。

dx=dy时，可以只输入dx。

注：

在此建立的栅格间距只能应用于当前工作状态，并可以随时更改栅格间距。在工具 > 参数设置 > 视图中设置的栅格间距将被设定为默认的栅格间距，每次打开新文件或已有文件时，将按默认的栅格间距工作。

模型区域

如果仅在特定范围内显示点格，需要输入栅格边界，并选中使用于轴网区域。

按Xmin, Ymin, Xmax和Ymax的顺序输入数据。

按以下示例输入：

  1. 只输入20时表示

Xmin = 0, Ymin = 0, Xmax =20, Ymax =20

  1. 输入20、 30时表示

Xmin = 0, Ymin = 0, Xmax = 20, Ymax = 30

  1. 输入10、15、 20、30时表示

Xmin = 10, Ymin = 15, Xmax = 20, Ymax = 30


04_命名的平面

Home > midas Gen 2017 > 03_结构 > 04_坐标系/平面 > 03_命名的平面

命名平面

  • 功 能

给指定的平面赋名。使用选择功能时，可以调用该平面，此时在该平面上的所有节点和单元均将被选择。在激活中使用已命名的平面进行选择也很方便。使用命名平面功能，可以帮助用户更方便快捷的观察及处理复杂的三维结构。

  • 命 令

从主菜单中选择模型 > 命名平面...

在树形菜单的菜单表单中选择模型 > 命名平面...

  • 输 入

新建或添加一个新的平面时，输入下列各项并单击 。

平面名称：指定平面的名称。

平面类型：选择定义平面的方法。

三点：选择要定义的平面上的三点。输入三点的GCS坐标，或者在模型窗口中连续点击三点。

X-Y平面：选定一个平行于GCS X-Y平面的平面。输入该平面在GCS中的Z轴坐标或在模型窗口中单击该平面上的一点。

X-Z平面：选定一个平行于GCS X-Z平面的平面。输入该平面在GCS中的Y轴坐标或在模型窗口中单击该平面上的一点。

Y-Z平面：选定一个平行于GCS Y-Z平面的平面。输入该平面在GCS中的X轴坐标或在模型窗口中单击该平面上的一点。

容许误差：决定节点、单元是否属于该平面的容许公差。该距离(公差)是到相应平面的垂直距离。

修改已命名的平面时：

从平面名称列表中选择相应平面并单击 [image] 。

删除已命名的平面时：

从平面名称列表中选择相应平面并单击 [image] 。

注:
当目标实体不在同一平面上时，使用 "组"功能更有效。


05_轴线

Home > midas Gen 2017 > 03_结构 > 04_坐标系/平面 > 04_轴线

尺寸

  • 功 能

导入dxf文件中的轴线，辅助建模。

  • 命 令

从主菜单中选择模型 > 尺寸...

在树形菜单的菜单表单中选择模型 > 尺寸...

  • 输 入

轴线名称：输入轴线名称。

DXF文件名称：点击 [image] 选择dxf文件，其文件名自动显示在此。

所有图层：显示该dxf文件中的所有图层。

选择的土层：选中的图层。

：将所有图层中选中的图层利用该按钮放到右侧选择的图层中。

：利用该按钮删除选择的图层中选中的图层。

调整系数：对原轴线的放大缩小比例系数。

原点：输入轴线原点在整体坐标系中的坐标。

旋转角：输入轴线绕整体坐标轴X/Y/Z的旋转角度。

选择的土层：选中的图层。

：添加新的轴线。

：修改选中轴线。

：删除选中轴线。

：关闭该对话框。


01_定义结构组

Home > midas Gen 2017 > 03_结构 > 05_组 > 01_结构

定义结构组

  • 功 能

将一些节点和单元组成一个结构组(Structure Group)，以便于建模、修改和输出，也可以编辑和删除已建立的结构组。对复杂的模型，当分析和设计中需要反复使用某些单元和节点时，可以将其定义为一个结构组，然后可以直接使用该结构组名称进行选择(选择属性)，或只激活该结构组(激 活属性)。该功能可以用于定义建筑物各施工阶段的结构,能将节点和单元赋予相应的结构组。

  • 命 令

从主菜单中选择模型 > 组 > 定义结构组...

在树形菜单的菜单表单中选择模型 > 组 > 定义结构组...

在树形菜单的组表单中利用结构组的关联菜单

快捷键: [Ctrl]+[F1]

  • 输 入

定义结构组名称对话框

名称:输入要建立的结构组的名称。

后缀:当需要同时建立多个结构组时，可以在结构组名称后面加上数字后缀。

:建立新的结构组名称。

:修改选中结构组的名称。

:删除选中结构组的名称。

:删除没有选中的结构组名称。

:关闭该对话框。

:按升序重新排列结构组名称。

:按降序重新排列结构组名称。

:选中一个或多个结构组名称向上移动。

:选中一个或多个结构组名称向下移动。

注：

可以在树形菜单的组表单中，点击右键，在弹出的关联菜单选择相应的命令操作。首先使用选择功能选择相应的节点和单元，然后用鼠标选择相应的结构组，将其拖放到模型窗口内，则选择的节点和单元将被分配到相应的结构组中。

例: 结构组1 [节点数=103 ；单元数=144]表示结构组1中的节点数和单元数。


02_定义边界组

Home > midas Gen 2017 > 03_结构 > 05_组 > 02_边界/荷载/钢束

定义边界组

  • 功 能

将单元和节点上的边界条件定义为一个边界组，或修改和删除已定义的边界组。

对复杂的模型，当分析和设计中需要反复使用某些边界条件时，可以将其定义为一个边界组，然后可以直接使用该边界组名称进行选择(选择属性)，或只激活该边界组(激活属性)。该功能可以用于定义桥梁各施工阶段的边界。

在生成边界组之前，需要先定义边界组的名称。然后在树形菜单的组表单中使用拖放功能将节点和单元赋予相应的边界组。

  • 命 令

从主菜单中选择模型 > 组 > 定义边界组...

在树形菜单的菜单表单中选择模型 > 组 > 定义边界组...

在树形菜单的组表单中利用边界组的关联菜单

  • 输 入

定义边界组名称对话框

名称:输入要建立的边界组的名称。

后缀:当需要同时建立多个边界组时，可以在边界组名称后面加上数字后缀。

:建立新的边界组名称。

:修改选中边界组的名称。

:删除选中边界组的名称。

:删除没有选中的边界组名称。

:关闭该对话框。

:按升序重新排列边界组名称。

:按降序重新排列边界组名称。

:选中一个或多个边界组名称向上移动。

:选中一个或多个边界组名称向下移动。

注1
可以在树形菜单的组表单中，点击右键，在弹出的关联菜单选择相应的命令操作。

首先使用选择功能选择相应的节点和单元，然后用鼠标选择相应的边界组，将其拖放到模型窗口内，则选择的节点和单元将被分配到相应的边界组中。

在组表单中，点击右键，在弹出的关联菜单选择分配或再分配时，将弹出选择边界类型对话框。选择相应的边界条件，点击 [image] ，则相应的边界条件将被赋予该边界组。

该功能主要用于使用一般功能赋予边界组内容时。使用建模助手时，各边界组内的边界条件内容均已被自动定义。

注2
使用边界组重复定义某一节点或单元的边界条件时，在分析过程中，将按阶段适用不同的边界条件。


05_修改边界组

Home > midas Gen 2017 > 03_结构 > 05_组 > 03_修改

修改边界组

  • 功 能

将定义为边界组的边界条件复制、移动到其它边界组，或者删除已定义的边界组。

该功能主要使用于施工阶段分析时，将已定义的边界组复制后，经修改生成新的边界组。

  • 命 令

从主菜单中选择模型 > 组 > 修改边界组...

在树形菜单的菜单表单中选择模型 > 组 > 修改边界组...

  • 输 入

选择

复制：将"原组"中的边界条件复制到新的边界组中。

移动：将"原组"中的边界条件移动到新的边界组中。

删除：将"原组"中的边界条件删除。

边界组

原组：将要复制、移动和删除的原边界组。

新组：将要建立、复制和移动的目标边界组。当选择删除时，该项将被钝化。

点击新组右面的 [image] ，将弹出定义边界组对话框，可以建立新的边界组。

边界条件列表：选择要复制、移动或删除的边界条件。


01_检查并删除重复输入的单元

Home > midas Gen 2017 > 03_结构 > 06_检查结构 > 01_检查重复单元

检查并删除重复输入的单元

  • 功 能

在数据输入过程中，如果在同一位置存在两个以上单元，检查并删除重叠的单元。

  • 命 令

从主菜单中选择模型 > 检查结构数据 > 检查并删除重复输入的单元...

快捷键：[F12]

  • 输 入

识别并删除重复单元。首先删除最新生成的单元(最大的单元编号)。


02_显示自由边

Home > midas Gen 2017 > 03_结构 > 06_检查结构 > 02_显示自由边/面

显示自由边

  • 功 能

显示平面或实体类型单元中与相邻单元不连接的边缘，即自由边。

用显示自由边检查平面单元中的建模错误。

  • 命 令

从主菜单中选择模型 > 检查结构数据 > 显示自由边...


04_检查单元坐标轴

Home > midas Gen 2017 > 03_结构 > 06_检查结构 > 03_检查单元局部坐标轴

检查单元局部坐标轴

  • 功 能

根据视图方向，板单元垂直于单元坐标系z轴的两个面将显示两种不同的颜色。用户可以使用该功能方便的查看板单元的单元坐标轴，而不必分别查看每个单元的单元坐标轴。

  • 命 令

从主菜单中选择模型 > 检查结构数据 > 检查单元局部坐标轴...

  • 输 入

正面颜色：单元坐标系+z方向面的颜色。

背面颜色：单元坐标系-z方向面的颜色。


01_建立节点

Home > midas Gen 2017 > 04_节点/单元 > 01_节点 > 01_建立节点

建立节点

  • 功 能

建立一个节点或同时复制该节点建立一组节点。

  • 命 令

从主菜单中选择 节点/单元 > 节点 > 建立节点...

从树形菜单的菜单表单中选择模型 > 节点 > 建立

快捷键： [Ctrl]+[Alt]+1

  • 输 入

单击建立节点右边的 [image] ，将显示节点表格。

节点起始号

输入新建节点的起始节点编号，该编号自动设置为当前最大节点号+1。要修改该项，单击 并选择一个选项指定目标编号。

<图1> 节点编号对话框

坐标(x,y,z):

用以下两种方法输入节点坐标：

1.直接键入UCS中的坐标x, y, z

单击坐标输入区，然后选择工作窗口中的目标位置，则选择的位置坐标将显示在输入区以及屏幕底部的状态条内。

2.使用点格(轴网)和捕捉栅格可以方便地建立节点。

复制:以等间距方式复制由上述步骤建立的节点。

复制次数：复制次数。

距离(dx,dy,dz)：在各坐标轴方向的复制间距。

注：可以直接在输入区内键入复制间距，也可以单击复制间距输入区后在工作窗口中用鼠标指定复制间距。

合并重复节点

如果新节点与现有节点位置重复，决定是否将重叠的节点合并为一个节点。必要时，单击 修改合并容许误差(公差)。

<图2> 合并的容许误差对话框

在交叉点分割单元

新近建立的节点处于现有的线单元(梁和桁架单元)上时，决定是否将现有线单元进行单元分割。必要时，单击 修改相交容许误差(公差)。


03_复制和移动

Home > midas Gen 2017 > 04_节点/单元 > 01_节点 > 02_移动复制

复制和移动

  • 功 能

以等间距或不等间距移动或复制节点。

  • 命 令

从主菜单中选择模型 > 节点 > 复制和移动...

从树形菜单的菜单表单中选择几何模型 > 节点 > 复制和移动

在图标菜单中单击 [image] 复制和移动节点

快捷键： [Ctrl]+[Alt]+3

  • 输 入

单击复制和移动节点右边的 [image] ，将显示节点表格。

节点起始号

输入新建节点的起始编号，该编号自动设置为当前最大节点号+1。要修改该项，单击 [image] 并选择一个选项指定目标编号。

<图1> 节点编号对话框

形式

复制：复制节点。

移动：移动节点。

复制和移动

等间距：等间距复制(或移动)节点。

dx, dy, dz：输入在三个坐标轴上的复制(或移动)距离。

注：要输入复制(或移动)距离，可直接键入每个距离，或用鼠标单击输入区后在工作窗口指定复制(或移动)距离。

复制次数：输入复制次数。

任意间距：以不等间距复制节点。

方向：选择复制(或移动)的方向。

x：在UCS的x轴上以不等间距复制节点。当选择为移动时，按输入的第一个间距移动节点。

y：在UCS的y轴上以不等间距复制节点。当选择为移动时，按输入的第一个间距移动节点。

z：在UCS的z轴上以不等间距复制节点。当选择为移动时，按输入的第一个间距移动节点。

任意方向：在任意方向上以不等间距复制节点。

间距：在指定方向上按需要次数输入不相等的复制间距。

(例如： 5, 3, 4.5, 3@5.0, 4 = 5, 3, 4.5, 5.0, 5.0, 5.0, 4)

方向向量：如果选择任意方向，则输入x, y, z方向上的方向向量分量。

合并重复节点：如果新节点与现有节点位置重复，决定是否将重叠的节点合并为一个节点。必要时，单击 [image] 修改合并容许误差(公差)。

<图2> 合并的容许误差对话框

复制节点属性：决定复制节点时是否一同复制被复制节点的属性(节点边界条件、节点集中荷载等)。单击 [image] 选择目标属性。

<图3> 复制节点属性对话框

在交叉点分割单元

新近建立的节点处于现有的线单元(梁和桁架单元)上时，决定是否将现有线单元单元分割。必要时，单击 [image] 修改相交容许误差(公差)。


07_分割节点间距

Home > midas Gen 2017 > 04_节点/单元 > 01_节点 > 03_分割

分割节点间距

  • 功 能

在两个节点间按相等或不相等的间距生成新的节点。

  • 命 令

从主菜单中选择模型 > 节点 > 分割...

从树形菜单的菜单表单中选择几何模型 > 节点 > 分割

在图标菜单中单击 [image] 分割

快捷键： [Ctrl]+[Alt]+7

  • 输 入

单击分割节点右边的 [image] ，将显示节点表格。

节点起始号

输入新建节点的节点起始编号，该编号自动设置为当前最大节点号+1。要修改该项，单击 [image] 并选择一个选项指定目标编号。

<图1> 节点编号对话框

分割

等间距：按等间距生成节点。

分割数量：分割数量 = 要生成的节点数 + 1

任意间距：

以不相等的间距生成节点，按所需分割数量输入不相等的间距。

(例如：5, 3, 4.5, 3@5.0, 4 = 5, 3, 4.5, 5.0, 5.0, 5.0, 4)

按距离比输入任意间距

距离比：按距离比生成距离不相等的节点。(例如： 0.4, 0.6, 0.9)

  分割的节点号

连续输入要分割的两个节点的节点编号，或者单击输入区后在工作窗口中选择相应的两个节点。

合并重复节点

如果新节点与现有节点位置重复，决定是否将重叠的节点合并为一个节点。必要时，单击 [image] 修改合并容许误差(公差)。

<图2> 合并的容许误差对话框

在交叉点分割单元

新近建立的节点处于现有的线单元(梁和桁架单元)上时，决定是否将现有线单元单元分割。必要时，单击 [image] 修改相交容许误差(公差)。


08_合并

Home > midas Gen 2017 > 04_节点/单元 > 01_节点 > 04_合并

合 并

  • 功 能

在给定范围内合并所有节点(>1)及其属性(节点荷载和节点边界条件)。

  • 命 令

从主菜单中选择模型 > 节点 > 合并...

从树形菜单的菜单表单中选择几何模型 > 节点 > 合并

在图标菜单中单击 [image] 合并节点

快捷键： [Ctrl]+[Alt]+8

  • 输 入

单击合并节点右边的 [image] ，将显示节点表格。

节点起始号

该命令不适用，处于钝化状态。

合并：选择合并节点的方法。

全部：选中全部节点。

选择：将使用选择功能选中的节点作为合并对象。

节点号：以特定范围内的节点为合并对象。

起始号：选定合并范围内起始节点编号。

结束号：选定合并范围内末尾节点编号。

合并范围：指定合并的范围，只有处于该距离范围内的节点才能合并，范围的中心为开始节点，合并后形成的新节点位置在开始节点的位置。

删除合并的节点:删除不再使用的被合并的节点。


02_删除

Home > midas Gen 2017 > 04_节点/单元 > 01_节点 > 05_删除

删除

  • 功 能

删除节点。

在程序中删除节点一般可以使用键盘中的Del键，这种删除方式可以删除自由节点和非自由节点，如果只想删除自由节点，可以在执行这个功能后的对话框中勾选只适用于自由节点，那么程序将只删除自由节点。

  • 命 令

从主菜单中选择模型 > 节点 > 删除...

从树形菜单的菜单表单中选择几何模型 > 节点 > 删除

在图标菜单中单击 删除节点

快捷键： [Ctrl]+[Alt]+2

在键盘上按[Delete]

  • 输 入

单击删除节点编号右边的 ，将显示节点表格。

节点起始号：该命令不适用(处于钝化状态)。

   类型：选择删除节点的方法。

鼠标点取节点号：单击节点号输入区，然后在工作窗口中用鼠标点击要删除的节点。不需点击 ，程序将立即删除这些节点。 也可以在节点号输入区内键入节点编号删除节点。

选择：使用选择功能选择要删除的节点，并需单击 或在键盘上按[Delete]键。

只适用于自由节点：选择该选项后，与单元有关联的节点和已被赋予属性(节点荷载、边界条件等)的节点将被保留。

注:

使用节点删除功能时，选择的命令的不同，其作用也就不同。使用键盘上的[Delete]键或图标菜单中的 时，必须首先用选择功能选定目标节点。在这种情况下，选定的节点和被赋予这些节点的属性(节点荷载、边界条件等)以及与节点关联的单元都将被删除。


04_旋转

Home > midas Gen 2017 > 04_节点/单元 > 01_节点 > 06_旋转

旋转

  • 功 能

绕特定轴旋转，移动或复制节点。

  • 命 令

从主菜单中选择模型 > 节点 > 旋转节点...

从树形菜单的菜单表单中选择几何模型 > 节点 > 旋转

在图标菜单中单击 [image] 旋转节点

快捷键： [Ctrl]+[Alt]+4

  • 输 入

单击旋转节点右边的 [image] ，将显示节点表单。

节点起始号

输入新建节点的节点起始编号，该编号自动设置为当前最大节点号+1。要修改该项，单击 [image] 并选择一个选项指定目标编号。

<图1> 节点编号对话框

形式

复制：复制节点。

移动：移动节点。

旋转

等角度：按等角度复制节点。

任意角度：按任意角度复制节点。

复制次数：输入复制次数。

旋转角度：复制时旋转的角度。

>0：按右手法则复制节点。

<0：按右手法则的相反方向复制节点。

间距(径向)/间距(旋转轴向)：以给定角度(螺线或螺旋线形状)旋转复制节点时，指定径向复制间距和旋转轴向复制间距。

旋转轴：选择旋转轴。

绕x轴：UCS x轴

绕y轴：UCS y轴

绕z轴：UCS z轴

绕两点定义的轴：将连接两点的直线定义为旋转轴。

第一点

选择绕x, y, z轴时，输入该轴上的任意点的坐标。

选择绕两点定义的轴时，输入第一点的坐标。

第二点

选择绕两点定义的轴时，输入第二点的坐标。

合并重复节点

如果新节点与现有节点位置重复，决定是否将重叠的节点合并为一个节点。必要时，单击 [image] 修改合并容许误差(公差)。

<图2> 合并的容许误差对话框

复制节点属性

决定复制节点时是否一同复制被复制节点的属性(节点边界条件、节点集中荷载等)。单击 [image] 选择目标属性。

<图3> 复制节点属性对话框

在交叉点分割单元

新近建立的节点处于现有的线单元(梁和桁架单元)上时，决定是否将现有线单元单元分割。必要时，单击 [image] 修改相交容许误差(公差)。


05_投影

Home > midas Gen 2017 > 04_节点/单元 > 01_节点 > 07_投影

投影

  • 功 能

通过在特定的线或面上投影，移动或复制节点。

  • 命 令

从主菜单中选择模型 > 节点 > 投影...

从树形菜单的菜单表单中选择几何模型 > 节点 > 投影

在图标菜单中单击 [image] 投影节点

快捷键： [Ctrl]+[Alt]+5

  • 输 入

单击投影节点右边的 [image] ，将显示节点表格。

节点起始号

输入新建节点的节点起始编号，该编号自动设置为当前最大节点号+1。要修改该项，单击并选择一个选项指定目标编号。

<图1> 节点编号对话框

   形式

复制：复制节点。

移动：移动节点。

投影类型：选择投影基准的几何形状。

投影基准的类型如下：

  1. 将节点投影到直线上

  2. 将节点投影到平面上

  3. 将节点投影到柱面上

  4. 将节点投影到圆锥面上

  5. 将节点投影到球面上

  6. 将节点投影到椭球面上

  7. 将节点投影到抛物线上

  8. 将节点投影到单元上

定义基准

输入必要的数据，定义投影基准如下：直接在键盘上键入全部数据，或者，单击相应输入区后在工作窗口中定义基准。

将节点投影到线上:

P1：位于基准线上的任意点的坐标。

P2：位于基准线上的任意点的坐标。

将节点投影到平面上:

P1：位于基准平面上的任意点的坐标。

P2：位于基准平面上的任意点的坐标。

P3：位于基准平面上的任意点的坐标。

将节点投影到柱面上:

P1：位于基准柱面中心轴上的任意点的坐标。

P2：位于基准柱面中心轴上的任意点的坐标。

半径R：基准柱面的半径。

将节点投影到圆锥面上:

P1：位于基准圆锥面中心轴上与圆锥顶面的交点坐标。

P2：位于基准圆锥面中心轴上与圆锥底面的交点坐标。

半径R1：点P1位置处基准圆锥顶面的半径。

半径R2：点P2位置处基准圆锥底面的半径。

将节点投影到球面上:

原点：基准球面中心的坐标。

半径R：基准球面的半径。

将节点投影到椭球面上:

P1：基准椭球底面中心的坐标。

P2：基准椭球顶点的坐标。

半径R：基准椭球底面圆的半径。

将节点投影到抛物线上:

P1：基准抛物线上任意点的坐标。

P2：基准抛物线上任意点的坐标。

P3：基准抛物线上任意点的坐标。

将节点投影到单元上:

单元编号：板单元编号(平面应力单元，板单元等)。

方向

选定已定义的投影基准线或面的投影方向。

法向：垂直于投影基准线或面的投影方向。

任意方向：在任意方向投影。输入在投影方向上的x, y, z矢量分量。

分割

在现有节点和投影后生成的节点之间沿投影方向以等间距或不等间距生成节点。

等间距：按相等的间距生成节点。

分割数量：等间距数量。

不等间距：按距离比定义的不相等的间距。

距离比：用距离比表示的沿总投影长度的分割位置。(例如： 0.4, 0.6, 0.9)

合并重复节点

如果新节点与现有节点位置重复，决定是否将重叠的节点合并为一个节点。必要时，单击 [image] 修改合并容许误差(公差)。

<图2> 合并的容许误差对话框

复制节点属性

决定复制节点时是否一同复制被复制节点的属性(节点边界条件、节点集中荷载等)。单击 [image] 选择目标属性。

<图3> 复制节点属性对话框

分割交叉杆系单元

如果节点投影的位置有单元存在，在相应的位置处分割单元。单击 [image] 设置交叉分割的容差。


06_镜像

Home > midas Gen 2017 > 04_节点/单元 > 01_节点 > 08_镜像

镜 像

  • 功 能

以特定对称面移动或复制节点。

  • 命 令

从主菜单中选择模型 > 节点 > 镜像...

从树形菜单的菜单表单中选择几何模型 > 节点 > 镜像

在图标菜单中单击 [image] 镜像节点。

快捷键： [Ctrl]+[Alt]+6

  • 输 入

单击镜像节点右边的 [image] ，将显示节点表单。

起始节点号

输入新建节点的节点起始编号，该编号自动设置为当前最大节点号+1。要修改该项，单击 [image] 并选择一个选项指定目标编号。

<图1> 节点编号对话框

形式

复制：复制节点。

移动：移动节点。

镜像平面

选定镜面位置。

y-z 平面：镜面平行于y-z平面。

x：镜面的x轴坐标。

x-y 平面：镜面平行于x-y平面。

z：镜面的z轴坐标。

z-x 平面：镜面平行于z-x平面。

y：镜面的y轴坐标。

由三点定义的面：镜面为一任意平面。

x1, y1, z1：定义镜面的第一点的x, y, z坐标。

x2, y2, z2：定义镜面的第二点的x, y, z坐标。

x3, y3, z3：定义镜面的第三点的x, y, z坐标。

可以用键盘直接键入三点坐标。或者单击相应的输入区后在工作窗口中选择三点。

合并重复节点

如果新节点与现有节点位置重复，决定是否将重叠节点合并为一个节点。必要时，单击 [image] 修改合并容许误差(公差)。

<图2> 合并的容许误差对话框

复制节点属性

决定复制节点时是否一同复制被复制节点的属性(节点边界条件、节点集中荷载等)。单击 [image] 选择目标属性。

<图3> 复制节点属性对话框

在交叉点分割单元

新近建立的节点处于现决定有的线单元(梁和桁架单元)上时，决定是否将现有线单元单元分割。必要时，单击 [image] 修改相交容许误差(公差)。


09_调整节点距离

Home > midas Gen 2017 > 04_节点/单元 > 01_节点 > 09_缩放

调整节点距离

  • 功 能

在各坐标轴方向以给定比例放大或缩小节点间的距离。

  • 命 令

从主菜单中选择模型 > 节点 > 调整节点距离...

从树形菜单的菜单表单中选择几何模型 > 节点 > 调整距离

在图标菜单中单击 [image] 缩放节点

  • 输 入

单击缩放节点右边的 [image] ，显示节点表格。

节点起始号

该命令不适用。

间距缩放系数:输入每个方向的间距缩放系数。

sfx：x方向间距缩放系数。

sfy：y方向间距缩放系数。

sfz：z方向间距缩放系数。

间距缩放参考点:指定放大或缩小间距的参考点。

UCS原点：UCS原点

GCS原点：GCS原点

平均：每个方向相应节点坐标的平均值。

中心：由各轴向具有最大和最小坐标的节点位置的平面围起的立方体的中心。

用户设定：由用户输入参考点的坐标。

选择类型

全部：适用于输入的所有节点。

用户选择：仅适用选定的截面。


10_紧凑节点号

Home > midas Gen 2017 > 04_节点/单元 > 01_节点 > 10_紧凑节点号

紧凑节点号

  • 功 能

确定不用的节点号，并重新指定连续的节点编号。

  • 命 令

从主菜单中选择模型 > 节点 > 紧凑节点编号...

从树形菜单的菜单表单中选择几何模型 > 节点 > 紧凑编号

在图标菜单中单击 [image] 紧凑节点编号

快捷键： [Ctrl]+[Alt]+9

  • 输 入

单击紧凑节点号右边的 [image] ，将显示节点表格。

节点起始号

该命令不适用，处于钝化状态。

选择范围:选定要压缩的节点编号范围。

全部：选定所有节点，按顺序递补空余号(未使用的号码)。

根据选择的号码：选定节点编号的特定范围，在此范围内有空余号(未使用的号)，将按顺序递补。

起始号：选定范围的起始节点编号。

结束号：选定范围的末尾节点编号。


11_重编节点号

Home > midas Gen 2017 > 04_节点/单元 > 01_节点 > 11_重编节点号

重编节点号

  • 功 能

按GCS方向的优先次序对现有节点(单元)重新编号。

  • 命 令

从主菜单中选择模型 > 节点 > 重编节点号...

从树形菜单的菜单表单中选择几何模型 > 节点 > 重新编号

在图标菜单中单击 [image] 重编节点号

  • 输 入

单击重新编号右边的 [image] ，显示节点表格。

节点起始号

该命令不适用。处于钝化状态。

重新编号的对象

节点：重编节点号。

单元：重编单元号。

节点和单元：重编节点和单元号。

选择

全部：选定所有对象。

根据选择：用户选择的对象。

新起始号

节点：新的节点起始号。

单元：新的单元起始号。

置新编号选项

排序坐标：选择排序时使用的坐标系。

直角坐标系：以直角坐标系作为排序坐标系。

圆柱坐标系：以圆柱坐标系作为排序坐标系。

排序：选择排序时各坐标轴的优先级。

当在排序坐标中选择直角坐标系时，新的节点(单元)编号考虑的坐标轴优先次序如下：

1ST：选定重新对节点(单元)编号时具有最高优先权的整体坐标轴。

2ND：选定具有第二优先权的轴。

3RD：选定剩下的轴。

注：可按整体坐标系负坐标轴方向对已有节点和单元重新编号。对于桩单元和框架单元，可按重力方向对节点和单元重新编号。

<图1> 按负坐标重编示例

当在排序坐标中选择圆柱坐标系时，将以圆柱坐标系作为排序坐标。

旋转轴：定义圆柱坐标系的Z轴。可以选择整体坐标系的X、Y、Z轴定义，也可以选择两点定义。

极坐标：定义圆柱坐标系的极坐标轴。可以选择整体坐标系的X、Y、Z轴定义，也可以选择两点定义。

1ST：选定重新对节点(单元)编号时具有最高优先权的圆柱坐标轴。

2ND：选定具有第二优先权的轴。

3RD：选定剩下的轴。


12_节点起始号

Home > midas Gen 2017 > 04_节点/单元 > 01_节点 > 12_节点起始号

节点起始号

  • 功 能

指定新近建立节点的编号方法。

  • 命 令

从主菜单中选择模型 > 节点 > 节点起始号...

从树形菜单的菜单表单中选择几何 > 节点 > 起始号

  • 输 入

编号方式选项

没有使用的最小号码:将没有使用的号码中的最小编号赋予新建节点。在现有节点中有中间空余号时，首先递补空余号，然后按使用的最大号码+1依次生成节点。

使用的最大号码+1:将当前使用的号码中的最大编号+1赋予新建节点。

用户定义号码:按用户定义的起始编号赋予新建节点。用户不能赋予新建节点以现有的节点号，但可以赋予空余号。

新建立的单元号码

当前面选择了"没有使用的最小号码"或"使用的最大号码+1"时，程序将自动指定相应号码；当前面选择了"用户定义号码"，则需用户输入新建节点的起始号。


13_节点表格

Home > midas Gen 2017 > 04_节点/单元 > 01_节点 > 13_节点表格

节点表格

  • 功 能

以电子表格形式输入或修改节点坐标数据。

MIDAS/Gen中的表格工具提供了各种强大的功能。详细说明参见以下各项：

表格工具的使用

术语

掌握使用方法

基本说明(单元移动、选择、大小控制等)

数据处理(增加、删除、修改数据)

用剪贴板复制/粘贴数据

表格功能补充

表格排序

表格格式设定

自动适应列宽

图表打印

各表格类型的补充功能

节点/单元表格

结果表格

  • 命 令

从主菜单中选择模型 > 节点 > 节点表格...

从树形菜单的表格表单中选择表格 > 结构表格 > 节点

快捷键： [Ctrl]+[Alt]+N

  • 输 入(参见"建立节点")

参考表格工具的使用方法输入或修改下列数据。

节点表格

节点：节点编号

X：GCS X坐标

Y：GCS Y坐标

Z：GCS Z坐标


01_建立

Home > midas Gen 2017 > 04_节点/单元 > 02_单元 > 01_建立

建 立

  • 功 能

建立单元。

  • 命 令

从主菜单中选择模型 > 单元 > 建立...

从树行菜单的菜单表单中选择几何模型 > 单元 > 建立

在图标菜单中单击 [image] 建立单元

快捷键： [Alt]+1

  • 输 入

单击建立单元右边的 [image] ，将显示单元表单。

节点起始号

输入新建单元的节点起始编号，该编号自动设置为当前最大节点号+1。要修改该项，单击 [image] 并选择一个选项指定目标编号。

<图1> 节点编号对话框

单元起始号

输入新建单元的单元起始编号。该编号自动设置为当前最大单元号+1。要修改该项，单击 [image] 并选择一个选项指定目标编号。

<图2> 单元编号对话框

单元类型

指定单元类型并输入相应数据。

桁架单元：桁架单元

只受拉/钩/索单元：只受拉单元。

若为只受拉桁架单元，补充输入最小容许压力，即只受拉桁架单元可以容许承受一定的压力荷载。

若为钩单元，补充输入钩的初始间距。

若为索单元，补充输入单元节点距离和索长之间的比值Lu/L，或者索的初拉力。

只受压/间隙单元：只受压单元。

若为只受压桁架单元，补充输入最小容许张力，即只受压桁架单元可以容许承受一定的张力荷载。

若为间隙单元，补充输入间隙的初始间距。

一般梁/变截面梁单元：梁单元

板：3节点或4节点板单元 。

厚板：厚板单元。

薄板：薄板单元。

平面应力单元：3节点或4节点平面应力单元。

平面应变单元：3节点或4节点二维平面应变单元。

轴对称单元：3节点或4节点二维轴对称单元。

实体单元：4节点、6节点或8节点三维实体单元。

墙单元：墙单元。

注1(桁架单元及只受拉、只受压单元)
桁架单元、只受拉单元以及只受压单元一般用于空间网架、索结构、支撑等只承受轴向力的构件和对接触面的模拟上。例如：桁架单元可以用于既承受压力也承受张力的空间网架、桁架上；只受拉单元可以用于可以忽略垂度的索上，也可以用于长细比比较大从而几乎不能承受压力的抗风斜支撑上；只受压单元可以用于结构间的接触面模拟上，也可以用于模拟只能受压力的地基边界条件；当有初始张力作用时，可以给桁架或只受拉单元施加初拉力。

桁架单元、只受拉单元以及只受压单元没有旋转方向的刚度，其两端节点没有旋转方向的自由度。没有旋转方向自由度的单元之间连接时，程序分析过程中将发生奇异现象(Singular Error)。当模型有这种非正常连接时，MIDAS/Gen在程序内部自动约束相应节点的旋转自由度，从而防止因分析时发生奇异而退出计算的情况发生。

桁架单元、只受拉单元以及只受压单元等没有旋转方向的刚度的单元与具有旋转方向刚度的单元(如梁单元)连接时，程序无需在内部做调整，也不会发生奇异现象。

图4显示了几种桁架单元连接注意事项。图1(a)结构受横向力时，将成为非稳定性结构。图1(b)和图1(c)虽然在Y-Z平面稳定，但在荷载作用平面X-Z平面内为非稳定性结构。用户在使用这些单元建模时，需注意。

另外，当只受拉单元(或只受压单元)受压力荷载(或受张力)时，单元可以退出工作。具体的操作参见分析 > 主控数据。

(a)在X-Z平面内X方向作用荷载时

(b)在Y-Z平面内X方向作用荷载时

(c)在Y-Z平面内X方向作用荷载时

<图4> 由桁架单元(只受拉或只受压单元)构成的典型非稳定性结构

注2(梁单元)

一般梁/变截面梁单元一般用于杆系构件或变截面(如楔形变截面)构件上，也可以作为连接自由度不同的两种单元的连接构件。

梁单元荷载类型有集中荷载、均布荷载、梯形荷载、三角形荷载、温度荷载、预应力荷载等。

MIDAS/Gen中的梁单元具有六个自由度，并默认计算剪切变形。当用户不想考虑剪切变形时，可将截面特性值的剪切面积设为零。

梁单元以铁摩辛柯的梁理论(垂直于中和轴的截面，在变形后保持平面形状，但不一定要继续垂直于中和轴)为基础，分析时考虑剪切变形。当截面尺寸与构件长度的比大于1/5时(深梁)，轴向的剪切变形的影响将显著增加，这种情况推荐用户使用板单元建模并划分较详细的网格。

梁单元截面特性值中的扭转刚度(torsional resistance)与截面的极惯性矩(polar moment of inertia)是不同的(圆形截面时，两个值相等)。扭转刚度一般由实验确定，当扭转变形较大时，应给予注意。

梁单元(或桁架单元)被理想化为线单元，截面的特性值均以中和轴为基准，因此程序不能自动考虑梁单元连接的刚域效果(梁柱节点)以及中和轴不同引起的效果。当需要考虑梁单元连接的刚域效果(梁柱节点)以及中和轴不同引起的效果时，需要利用梁端偏心功能或几何约束条件(在主菜单中选择模型>边界条件>刚域效果)。

当构件为变截面时，在截面中选择变截面表单输入。建立曲梁模型时，单元的划分应尽量细一些。

当梁单元端部为铰接或为滚动支座时，可使用释放梁端部约束功能，释放相应自由度方向的约束。当在一个节点释放多个杆件的端部约束时，注意可能会发生奇异现象。当不可避免地发生这种情况时，需要在相应自由度方向加一具有微小刚度的弹性连接单元或弹性约束。

注
多个梁单元在一点铰接时，为了避免发生奇异，其中一个梁单元不释放梁端约束，其它梁单元释放梁端约束。

<图5> 释放梁端约束例题

注
当节点自由度不同的单元连接在一点时，使用刚性梁单元会更有效地避免发生奇异。输入刚性梁单元时，可以将其刚度相对提高，一般可以比相连接的其它单元刚度高105～108倍。

如图3(d)中梁与墙体连接，墙体使用平面应力单元或板单元模拟，梁使用梁单元模拟时，因为平面应力单元(或板单元、实体单元)没有绕垂直于板单元方向的旋转自由度，所以即使将梁单元与平面应力单元连接起来，也不能传递给梁单元以绕垂直于板单元方向的弯矩，其结果相当于铰接。为了正确模拟连接，使用辅助的刚性梁。辅助刚性梁与现有梁单元的连接不必释放约束，将其与墙体的连接端释放所有旋转自由度和轴向约束。

注3(板单元)

厚板单元与薄板单元的差别为厚板单元考虑剪切变形。详细内容请参见分析与设计用户手册中的单元类型和主要考虑事项章节。

板单元可以使用于面内受拉压及面外受弯的压力容器、护壁、桥梁板等模型中。

在MIDAS/Gen中，板单元上可以施加任意方向的压力荷载。

板单元的形状有三角形和四边形两种。

MIDAS/Gen中的板单元的面外刚度有两种，既DKT、DKQ(Discrete Kirchhoff Element)和DKMT、DKMQ(Discrete Kirchhoff-Midlin Element)。DKT(三角形单元)和DKQ(四边形单元)是以薄板理论(Kirchhoff Plate Theory)为基础开发的；DKMT(三角形单元)和DKMQ(四边形单元)是以厚板理论(Mindlin-Reissner Plate Theory)为基础开发的。三角形板单元的面内刚度使用了LST(Linear Strain Triangle)理论，四边形板单元使用了等参数单元(Isoparametric Plane Stress Formulation with Incompatible Modes)理论。

输入板单元的厚度时，可以分别输入计算面内刚度(Inplane stiffness)和计算面外刚度(Out of Plane stiffness)所需的厚度。一般在计算自重和质量时，使用面内刚度厚度，但如果只输入了面外刚度厚度，则在计算自重和质量时使用面外刚度厚度。

板单元应尽量使用四边形单元。在建立曲面时，相邻板单元的夹角尽量不要超过10度。当需要输出比较精确的结果时，夹角尽量不要超过2～3度。在应力变化较大的位置，应尽量使用四边形单元细分。

<图6> 球面或圆柱面上使用的板单元

注4(平面应力单元)

平面应力单元可以使用于受拉或受压的膜单元或只能受平面方向荷载的结构上。

平面应力单元可以承受垂直于单元边界的荷载。

平面应力单元具有三角形和四边形单元，具有平面内抗拉、抗压和剪切强度。

一般来说，四边形单元的位移和应力结果比较准确。三角形单元的位移结果比较准确而应力结果的精确度不是很高。因此在需要较高精确度的位置，建模时应尽量使用四边形单元。在需要调整四边形单元大小的部位，可以使用三角形单元进行过渡。(参见图7)

平面应力单元没有旋转自由度。没有旋转自由度的不同单元之间相互连接时，在连接节点位置会发生奇异。此时在MIDAS/Gen中，程序内部会自动约束旋转自由度，从而避免了奇异的发生。

另外，当平面应力单元和具有旋转自由度的梁单元或板单元连接时，可以使用刚性连接(主节点、从属节点)或使用刚性辅助梁，从而保证旋转自由度的连续性。

恰当的单元形状与单元类型、几何形状、结构类型有关。一般尽量使单元形状比(Aspect Ratio)接近1。四边形单元尽量使角度接近90度。当不能满足上述条件时，也应该在应力变化较大的部位或需要精密分析的位置，尽量使用形状接近于正四边形的单元。

一般来说单元划分的越细，单元收敛性能越好。

<图7> 裂纹模型中使用的三角形/四边形单元

注5(平面应变单元)

平面应变单元一般使用于象大坝、隧道那样维持一定的截面而长度很长的结构模型中。平面应变单元不能和其它类型的单元混合使用。

平面应变单元可以承受垂直于单元边界的荷载。

因为平面应变单元只能发生平面内变形，所以只能用于线性静力分析，不存在平面外变形。由泊松比可以计算出平面外应力。

平面应变单元具有三角形和四边形单元，不仅具有平面内抗拉、抗压和剪切强度，而且具有平面外抗拉和抗压强度。

同平面应力单元一样，平面应变单元也应该尽量使用四边形单元，单元的形状比也应该尽量接近1.0。(参见平面应力单元)

注6(轴对称单元)

轴对称单元一般使用于形状、材料、荷载等沿一定的轴对称的结构中，如管道、压力容器、水箱、料仓等。轴对称单元不能和其它类型的单元混合使用。

平面应变单元可以承受垂直于单元边界的荷载。

同平面应力单元一样，平面应变单元也应该尽量使用四边形单元，单元的形状比也应该尽量接近1.0。(参见平面应力单元)

注7(实体单元)

实体单元一般用于实体结构中，实体单元的形状有楔形、三角棱柱体和六面体。

平面应变单元可以承受垂直于单元各面的荷载或沿着整体坐标系方向作用的荷载。

六面体单元(8节点)的位移和应力结果均比较准确；楔形(四节点)、三角棱柱体(六节点)的位移结果比较准确，应力结果的准确度相对于位移有所降低。因此在需要较高精确度的位置，建模时应尽量使用六面体单元。在需要调整六面体单元大小的部位，可以使用楔形或三角棱柱体单元进行过渡。实体单元没有旋转刚度，即在其节点位置没有旋转自由度。没有旋转自由度的不同单元之间相互连接时，在连接节点位置会发生奇异。此时在MIDAS/Gen中，程序内部会自动约束旋转自由度，从而避免了奇异的发生。另外，当实体单元和具有旋转自由度的梁单元或板单元连接时，可以使用刚性连接(主节点、从属节点)或使用刚性辅助梁，从而保证旋转自由度的连续性。

注8(索单元)

在静力分析时，索单元按等效桁架单元进行分析；在几何非线性分析时，索单元按弹性悬链线索单元进行分析。

材料:选择材料特性编号，或在已定义的材料特性数据中选择材料特性名称。

材料号：用键盘或鼠标输入编号。

名称：选择材料特性名称。

单击 [image] 可以增加、查询、修改或删除材料特性数据。也可以在建立了单元后，再定义单元的材料特性。

截面(或厚度):选择截面(厚度)编号，或在已定义的截面(厚度)数据中选择截面(厚度)名称。

截面号：用键盘或鼠标输入编号。

名称：选择截面(厚度)名称。

单击 [image] 可以增加、查询、修改、或删除截面(厚度)数据。也可以在建立了单元后，再定义单元的截面特性。

方向

当单元是线性单元(桁架，梁等)，指定β角、参考点坐标或参考向量定义构件的方向。

如果输入参考点坐标或参考向量，则在程序内部自动计算构件布置角度并将其作为β角输入。

在MIDAS软件中，为了便于用户理解和输入，引进了构件β角的概念。线单元的单元坐标系x轴的方向为从N1点(i点)指向N2点(j点)。

当线单元的单元坐标系x轴和整体坐标系的Z轴平行时，单元的β角为整体坐标系X轴和单元坐标系z轴的夹角。夹角的符号由绕单元坐标系x轴旋转的右手法则决定。当线单元的单元坐标系x轴和整体坐标系的Z轴不平行时，单元的β角为整体坐标系Z轴和单元坐标系x-z平面的夹角。

(a) 竖向构件(线单元的单元坐标系x轴和整体坐标系的Z轴平行时)

(b) 水平或倾斜构件(线单元的单元坐标系x轴和整体坐标系的Z轴不平行时)

<图8> β角的定义

节点连接

按显示在选择单元类型图中的顺序(N1, N2...)输入节点编号。

可以用以下两种方法输入节点号。

  1. 直接在节点连接中输入节点号。

  2. 单击节点连接输入区，其背景颜色将变为浅绿色，然后在模型窗口中连续指定目标节点输入单元。具有这种鼠标编辑功能的输入框在用户帮助手册中用图形 [image] 表示。鼠标指定点处无节点时将建立新的节点。使用点格(或轴网)和捕捉功能会更方便一些。

    打开直交选项时，从选定的第一点开始，鼠标光标只在平行于当前坐标轴(UCS或GCS)的方向上移动。

  3. 可以直接输入节点坐标或输入相对距离或输入单元长度和角度。

x,y,z：在输入区内输入单元的节点坐标，然后按键盘上的回车键或单击 [image] 。

dx, dy, dz：输入与参考点的相对距离并按键盘上的回车键或单击 [image] 。输入的方法既可以用逗号,也可以用空格，也可以使用符号@等。

例如：' dx, dy, dz'既可以表示为'0,20,10' ，也可表示为'@10, 20, 10'。

l,θ：l表示单元长度，θ表示单元方向对当前坐标系x轴的夹角。输入数据后，按键盘上的回车键或单击单元 [image] 。

如果数值串中包括字符'@' 或 '<'，无论选择哪种输入方式，程序都能识别l和θ。

例如：'l, theta'既可表示为'10, 15'，也可表示为 '@10<15'

注
程序最初将以当前坐标系原点为参考点，随后将最后建立的点为参考点。如果要确认参考点的位置，可以在数据输入区内输入'@0'并按键盘上的回车键。

交叉分割

如果选择交叉分割且现有节点在单元上时，则不管单元的类型，在现有节点位置处将单元分割。

如果选择交叉分割且建立的线单元与现有线单元相交，则在相交点位置处自动生成节点并将线单元分割。

如果选择建立交叉节点，即使在生成的板单元或实体单元中没有内部节点，也会在外部节点连线的交点处建立节点并随后建立板单元和实体单元。

<图9> 建立交叉节点应用举例


02_在曲线上建立直线单元

Home > midas Gen 2017 > 04_节点/单元 > 02_单元 > 02_在曲线上建立直线单元

建立曲线并分割成线单元

  • 功 能

在某平面上定义一条曲线并在曲线上建立直线单元。

  • 命 令

从主菜单中选择模型 > 单元 > 建立曲线并分割成线单元...

从树形菜单的菜单表单中选择几何模型 > 单元 > 在曲线上建立直线单元

在图标菜单中单击 [image] 建立曲线并分割成线单元

  • 输 入

单击在曲线上建立线单元右边的 [image] ，将显示单元表格。

节点起始号

输入与新单元同时生成的新节点的起始编号。该编号被默认为正在使用中的最大节点号+1。要修改该项，单击 [image] 并选择一个选项，指定目标编号。

单元起始号

输入新的单元起始编号。该编号被默认为正在使用中的最大单元号+1。要修改该项，单击 [image] 并选择一个选项，指定目标编号。

曲线类型

选择曲线形状和定义曲线的方法，在曲线上建立线单元。

三点弧:选定三个特定点定义一段弧。

弧中心+两点:选定两个特定点和弧的中心定义一段弧。

三点圆:选定三个特定点定义一个圆。

圆心+两点:选定两个特定点和圆心定义一个圆。

椭圆中心+两点:选定两个特定点和椭圆中心定义一个椭圆。

二次曲线-三点:选定三个特定点定义一条抛物线。

三次曲线-四点:选定四个特定点定义一条三次曲线。

单元类型

选定沿曲线生成的单元类型。

材料/截面/方向

选择材料和截面特性编号。或在已定义的材料和截面特性数据中选择名称。

材料号：用键盘或鼠标输入材料号。

名称：选择材料特性名称。

单击 [image] ，可以增加、查询、修改或删除材料特性数据。也可以在建立了单元后，再定义单元的材料特性。

截面号：用键盘或鼠标输入编号。

名称：选择截面名称。

单击 [image] ，增加、查询、修改或删除截面(厚度)数据。也可以在建立了单元后，再定义单元的截面特性。

方向：定义线单元的方向。

β角：输入线单元构件布置的β角。

定义曲线:定义一条曲线,在曲线上将建立线单元。

分割数量：将定义的曲线分割成直线段的数量。

定义各种曲线的方法如下：

三点弧:

曲线终点：选定定义弧终点的方法。

P3：弧上第三点。

角度：输入弧的角度。

P1：输入弧起点的坐标。

P2, P3：输入弧上另外两点的坐标。

弧的方向为沿P1、P2和P3的顺序方向。

弧中心+两点:

曲线终点：选定定义弧终点的方法。

P2：弧上终点。

角度：输入弧的角度。

C：输入弧中心的坐标。

P1：输入弧上第一点的坐标。

P2：输入弧上终点坐标。

弧的方向为沿P1到P2弧线的较短距离的方向。要在较长弧的方向形成弧，用角度控制方向。

注
如果P1、C和P2在一直线上，就不能形成弧。在这种情况下，可使用角度生成弧。

三点圆:

P1：输入圆起点的坐标。

P2, P3：输入圆上两点的坐标。

圆的方向为沿P1、P2和P3的顺序方向。

圆心+两点:

C：输入圆心的坐标。

P1：输入圆起点的坐标。

P2：指定圆所在平面上的任意一点。

椭圆中心+两点:

半椭圆：选择该项时将形成一个半椭圆。

C：输入椭圆中心的坐标。

P1：输入长轴上起点的坐标。

P2： 输入椭圆上任意一点的坐标。

二次曲线-三点:

等距离分割

曲线：将曲线分割成相等长度的直线单元。

投影线：将曲线分割成在UCS(GCS)的x轴上投影长度相等的直线单元。

P1：输入抛物线起点的坐标。

P2, P3：输入抛物线上任意两点的坐标。

三次曲线-四点:

P1：输入三次曲线起点的坐标。

P2, P3, P4：输入三次曲线上三点的坐标。

注
P1、P2和P3的顺序方向决定线单元的局部坐标方向。

交叉分割

节点：当现有节点位于将要生成的线单元上时，在现有节点位置处将单元分割。

单元：如果将要生成的线单元与现有线单元相交，则在相交点位置处自动生成节点并将线单元分割。


02_建立转换线单元

Home > midas Gen 2017 > 04_节点/单元 > 02_单元 > 03_建立转换线单元

建立转换直线单元

  • 功 能

将平面单元的边转换为直线单元。

  • 命 令

从主菜单中选择模型 > 单元 > 建立转换直线单元...

从树形菜单的菜单表单中选择模型 > 单元 > 建立转换直线单元

  • 输 入

单击在建立转换直线单元右边的 [image] ，将显示单元表格。

节点起始号

输入与新单元同时生成的新节点的起始编号。该编号被默认为正在使用中的最大节点号+1。要修改该项，单击 [image] 并选择一个选项，指定目标编号。

单元起始号

输入新的单元起始编号。该编号被默认为正在使用中的最大单元号+1。要修改该项，单击 [image] 并选择一个选项，指定目标编号。

单元类型

选择将要生成的线单元类型：桁架、梁。

材料/截面/方向

选择材料和截面特性编号。或在已定义的材料和截面特性数据中选择名称。

材料号：用键盘或鼠标输入材料号。

名称：选择材料特性名称。

单击 [image] ，可以增加、查询、修改或删除材料特性数据。也可以在建立了单元后，再定义单元的材料特性。

截面号：用键盘或鼠标输入编号。

名称：选择截面名称。

单击 [image] ，增加、查询、修改或删除截面(厚度)数据。也可以在建立了单元后，再定义单元的截面特性。

方向：定义线单元的方向。

β角：输入线单元构件布置的β角。

单元号:选择的平面单元号。

仅建立在表面区域:勾选此项，只在所选面域外围生成线单元。


02_在曲线上建立直线单元

Home > midas Gen 2017 > 04_节点/单元 > 02_单元 > 04_建立剪力墙洞口

剪力墙洞口

  • 功 能

对剪力墙单元进行开洞，并自动生成洞口上方连梁。

  • 命 令

从主菜单中选择节点/单元 > 单元 > 剪力墙洞口...

从树形菜单的菜单表单中选择模型 > 单元 > 剪力墙洞口

  • 输 入

节点起始号

输入与新单元同时生成的新节点的起始编号。该编号被默认为正在使用中的最大节点号+1。要修改该项，单击 [image] 并选择一个选项，指定目标编号。

单元起始号

输入新的单元起始编号。该编号被默认为正在使用中的最大单元号+1。要修改该项，单击 [image] 并选择一个选项，指定目标编号。

洞口类型

输入洞口尺寸、布置方向和距离等数据布置洞口。

方向：

i->j，j->i，居中：洞口布置参考方向。

注：i、j端分别指的是建立剪力墙单元时的点N1、N2的位置，i->j即为N1指向N2的方向，j->i即为N2指向N1的方向。

距离：

dx：洞口起始位置至墙端的水平距离（不输入则默认为0）。

dy：洞口底边至墙底的垂直距离（不输入则默认为0）。

洞口尺寸：

w：洞口宽度。

h：洞口高度。

分割框架单元：分割墙单元、的同时，分割与其相邻的梁单元。

合并重复节点：如果新节点与现有节点相符，将重叠节点合并为一个节点。必要时，单击 [image] ，修改合并容许误差(公差)。


04_移动和复制

Home > midas Gen 2017 > 04_节点/单元 > 02_单元 > 05_移动复制

复制和移动

  • 功 能

以等间距或不等间距移动或复制单元。

  • 命 令

从主菜单中选择模型 > 单元 > 移动和复制...

从树形菜单的菜单表单中选择几何模型 > 单元 > 移动和复制

在图标菜单中单击 [image] 移动和复制单元

快捷键： [Alt]+3

  • 输 入

<图1> 移动/复制单元对话框

单击移动/复制单元右边的 [image] ，将显示单元表格。

节点起始号

输入新建单元的节点起始编号，该编号自动设置为当前最大节点号+1。要修改该项，单击 [image] 并选择一个选项指定目标编号。

单元起始号

输入新建单元的起始编号。该编号自动设置为当前最大单元号+1。要修改该项，单击 [image] 并选择一个选项指定目标编号。

形式

复制：复制单元。

移动：移动单元。

移动和复制

节点号增幅

利用现有节点复制(或移动)单元时，可使用节点增量。

复制次数：复制次数。

等间距：等间距复制(或移动)单元。

dx, dy, dz

在每个轴上的复制(或移动)距离。

要输入复制(或移动)距离，可直接键入每个距离，或用鼠标单击输入区并在模型窗口中指定复制(或移动)距离。

复制次数：复制次数。

任意间距：以不等间距复制节点。

方向：指定复制方向。

x：在UCS x轴上以不等间距复制单元。

y：在UCS y轴上以不等间距复制单元。

z：在UCS z轴上以不等间距复制单元。

任意方向：在任意方向上以不等间距复制单元。

距离：在指定方向上按单元需要复制的次数输入不相等的间距
(例如： 5, 3, 4.5, 3@5.0, 4 = 5, 3, 4.5, 5.0, 5.0, 5.0, 4)

方向向量：如果选择任意方向，则输入x, y, z方向上方向向量的分量。

材料号增幅

复制单元时材料特性编号的增量。

：选中重复时，随着复制数量的重复，材料特性编号以给定的增量增加。

截面号增幅

复制单元时截面编号的增量。

：选中重复时，随着复制数量的重复，截面编号以给定的增量增加。

厚度号增幅

复制单元时厚度编号的增量。

：选中重复时，随着复制数量的重复，厚度编号以给定的增量增加。

交叉分割

仅适用于线单元。

如果选择交叉分割且现有节点在生成的线单元上，则在现有节点处分割单元。

如果选择交叉分割且生成的线单元与现有单元相交，则在交点处自动生成节点并分割单元。

复制节点属性

决定是否一同复制被复制节点的属性(节点边界条件、节点集中荷载)。当复制部分属性时，单击 [image] 选择需要复制的节点属性。

<图2> 复制节点属性对话框

复制单元属性

决定是否一同复制被复制单元的属性(单元边界条件、单元集中荷载)。当复制部分属性时，单击 [image] 选择需要复制的单元属性。

<图3> 复制单元属性对话框

指定合并公差，合并新近生成的节点和现有节点。


06_扩展

Home > midas Gen 2017 > 04_节点/单元 > 02_单元 > 06_扩展

扩 展

  • 功 能

通过扩展维数建立单元，即将节点扩展为线单元，线单元扩展为面单元及面单元扩展为实体单元。

扩展单元具有以下三种功能:

  1. 沿指定的路径由点形成线单元。

  2. 沿指定的路径由线单元形成面单元。

  3. 指定的路径由面单元形成实体单元。

  • 命 令

从主菜单中选择模型 > 单元 > 扩展...

从树形菜单的菜单表单中选择几何模型 > 单元 > 扩展

在图标菜单中单击 [image] 扩展单元

快捷键： [Alt]+5

  • 输 入

单击扩展单元右边的 [image] ，将显示单元表格。

节点起始号

输入新建单元的节点起始编号，该编号自动设置为当前最大节点号+1。要修改该项，单击 [image] 并选择一个选项指定目标编号。

单元起始号

输入新建单元的起始编号。该编号自动设置为当前最大节点号+1。要修改该项，单击 [image] 并选择一个选项指定目标编号。

扩展类型

选择将单元转换到更高层次单元的模式。

节点 [image] 线单元:

沿节点运动的线路径形成线单元。

线单元 [image] 平面单元:

沿线单元运动的面路径形成平面单元。

平面单元 [image] 实体单元:

沿平面单元运动的立体路径形成实体单元。

删除：完成扩展后，删除原来的单元。

移动：完成扩展后，将原来的单元移动到扩展形成的单元的最后位置。

反转I-J：如果在扩展类型中选择节点 [image] 线单元，扩展形成的线单元的局部坐标方向与生成方向相反。

单元属性

单元类型:指定将建立的单元的类型。

线单元：桁架单元、梁单元、只受拉单元、只受压单元等。

平面单元：板单元、平面应力单元、平面应变单元、轴对称单元等。

实体单元：实体单元。

当选择"桁架单元"或"梁单元"时

材料:选择材料特性编号，或在已定义的材料特性数据中选择材料特性名称。

单击 [image] 可以增加、查询、修改或删除材料特性数据。也可以在建立了单元后，再定义单元的材料特性。

截面:选择截面编号，或在已定义的截面数据中选择截面名称。

单击 [image] 可以增加、查询、修改、或删除截面数据。也可以在建立了单元后，再定义单元的截面特性。

β角:由点生成线单元时，指定线单元的β角。

当选择"只受拉单元"时

材料:选择材料特性编号，或在已定义的材料特性数据中选择材料特性名称。

单击 [image] 可以增加、查询、修改或删除材料特性数据。也可以在建立了单元后，再定义单元的材料特性。

截面:选择截面编号，或在已定义的截面数据中选择截面名称。

单击 [image] 可以增加、查询、修改、或删除截面数据。也可以在建立了单元后，再定义单元的截面特性。

β角:由点生成线单元时，指定线单元的β角。

桁架:选择桁架单元时，输入只受拉桁架单元的容许的最大压力。

钩:选择钩单元时，输入钩单元的间隙。

索:择索单元时，输入单元节点距离和索长之间的比值Lu/L，或者索的初拉力。

当选择"只受压单元"时

材料:选择材料特性编号，或在已定义的材料特性数据中选择材料特性名称。

单击 [image] 可以增加、查询、修改或删除材料特性数据。也可以在建立了单元后，再定义单元的材料特性。

截面:选择截面编号，或在已定义的截面数据中选择截面名称。

单击 [image] 可以增加、查询、修改、或删除截面数据。也可以在建立了单元后，再定义单元的截面特性。

β角:由点生成线单元时，指定线单元的β角。

桁架:选择桁架单元时，输入只受压桁架单元的容许的最大张力。

间隙单元:选择间隙单元时，输入间隙单元的间隙。

当选择"平面应力单元"时

材料:选择材料特性编号，或在已定义的材料特性数据中选择材料特性名称。

单击 [image] 可以增加、查询、修改或删除材料特性数据。也可以在建立了单元后，再定义单元的材料特性。

厚度:选择厚度编号，或在已定义的厚度数据中选择厚度名称。

单击 [image] 可以增加、查询、修改、或删除厚度数据。也可以在建立了单元后，再定义单元的截面特性。

当选择"板单元"时

材料:选择材料特性编号，或在已定义的材料特性数据中选择材料特性名称。

单击 [image] 可以增加、查询、修改或删除材料特性数据。也可以在建立了单元后，再定义单元的材料特性。

厚度:选择厚度编号，或在已定义的厚度数据中选择厚度名称。

单击 [image] 可以增加、查询、修改、或删除厚度数据。也可以在建立了单元后，再定义单元的截面特性。

类型:指定生成的板单元的类型，即是薄板还是厚板。

当选择"平面应变单元"或"轴对称单元"时

材料:选择材料特性编号，或在已定义的材料特性数据中选择材料特性名称。

单击 [image] 可以增加、查询、修改或删除材料特性数据。也可以在建立了单元后，再定义单元的材料特性。

生成形式

选择扩展的方式。

复制和移动

选择移动和复制，以等间距或不等间距复制现有的节点或单元，并扩展生成新的单元。

等间距：以等间距移动和复制。

dx, dy, dz：输入每个轴方向的移动和复制距离。

可以用键盘输入各个距离，或者单击输入区并用鼠标在模型窗口指定复制距离。

复制次数：输入复制次数。

任意间距：以不等间距移动和复制。

方向：指定移动和复制方向。

x：沿用户坐标系x轴方向以不等间距复制。

y：沿用户坐标系y轴方向以不等间距复制。

z：沿用户坐标系z轴方向以不等间距复制。

任意方向：在指定方向以不等间距复制。

间距：在指定方向按顺序输入复制距离。
(例如：5, 3, 4.5, 3@5.0, 4 = 5, 3, 4.5, 5.0, 5.0, 5.0, 4)

方向向量：仅用于选择任意方向时。输入x, y, z方向的各个方向向量分量。

局部方向：沿着局部坐标轴以不等间距移动和复制。仅适用于由线单元扩展成面单元的类型。

等间距：以等间距移动和复制。

复制次数：输入复制次数。

间距：输入复制间距。

任意间距：以不等间距移动和复制。

间距：在指定方向按顺序输入复制距离。
(例如：5, 3, 4.5, 3@5.0, 4 = 5, 3, 4.5, 5.0, 5.0, 5.0, 4)

方向：选择移动和复制局部坐标轴的方向，有+y、-y、+z、-z。因为是由线单元扩展成面单元，所以扩展方向没有x轴方向。

厚度方向：沿着面单元厚度方向移动和复制。仅适用于由面单元扩展成实体单元的类型。

等间距：以等间距移动和复制。

复制次数：输入复制次数。

厚度：输入复制间距。

任意间距：以不等间距移动和复制。

厚度：在指定方向按顺序输入复制距离。
(例如：5, 3, 4.5, 3@5.0, 4 = 5, 3, 4.5, 5.0, 5.0, 5.0, 4)

方向：选择移动和复制的方向，有+z、-z。因为是由面单元向厚度方向扩展成实体单元，所以扩展方向没有x轴和y轴方向。

旋转

选择旋转，以相等或不等角度旋转现有节点或单元，并扩展生成新的单元。

等角度：以等角度旋转复制。

复制次数：输入复制次数。

旋转角度：输入复制次数。

任意角度：以不等角度旋转复制。

角度：按顺序输入绕指定旋转轴方向的旋转复制角度。
(例如：20, 10, 3@30, 15 = 20, 10, 30, 30, 30, 15)

注:
>0：复制，按右手法则方向旋转。
<0：复制，按右手法则的反方向旋转。

间距(径向/旋转轴向)：

以给定角度(螺线或螺旋线形状)旋转复制节点时，指定径向距离和旋转轴方向复制距离。

旋转轴：选定旋转轴的选项区。

x轴：绕用户坐标系x轴。

y轴：绕用户坐标系y轴。

z轴：绕用户坐标系z轴。

由两点定义的轴：

将连接两点的直线定义为旋转轴(方向从第一点到第二点)。

第一点：输入旋转轴上第一点的坐标(x, y, z)。

第二点：输入旋转轴上第二点的坐标(x, y, z)。

投影

选择投影，向线和面上投影现有节点或单元，生成单元。

投影形式

选择投影的形式。

可供选择的投影形式下：

  1. 将节点投影到直线上

  2. 将节点投影到平面上

  3. 将节点投影到柱面上

  4. 将节点投影到圆锥面上

  5. 将节点投影到球面上

  6. 将节点投影到椭球面上

  7. 将节点投影到单元上

基准定义

输入必要的数据定义投影的基准。可直接在键盘上键入全部数据，或者单击相应输入区后，在工作窗口中定义用鼠标选择基准。

基准定义方法如下：

将节点投影到线上

P1：位于基准线上的点的坐标。

P2：位于基准线上的另外一点的坐标。

将节点投影到平面上

P1：位于基准面上的点的坐标。

P2：位于基准面上的另一点的坐标。

P3：位于基准面上的第三点的坐标。

将节点投影到柱面上

P1：位于基准圆柱面中心轴上的点的坐标。

P2：位于基准圆柱面中心轴上的另一点的坐标。

半径：基准柱面的半径。

将节点投影到圆锥面上

P1：位于基准圆锥面中心轴上的点的坐标。

P2：位于基准圆锥面中心轴上的另一点的坐标。

半径R1：点P1位置处基准圆锥面的半径。

半径R2：点P2位置处基准圆锥面的半径。

将节点投影到球面上

原点：基准球面中心的坐标。

半径：基准球面的半径。

将节点投影到椭球面上

P1：基准椭球底面中心的坐标。

P2：基准椭球顶点的坐标。

半径：基准椭球底面圆的半径。

将节点投影到单元上

单元号：平面单元编号(平面应力单元、板单元等)。

方向:选定向已定义的投影基准线或基准面的投影的方向。

法向：垂直于投影基准线或基准面的投影方向。

向量方向：在任意方向投影，输入在投影方向上的x, y, z矢量分量。

分割

在现有节点和投影节点之间沿投影方向以等间距或任意间距形成单元。

等分：相等的间距。

分割数量：等间距分割数量。

不等分：按距离比定义的不相等的间距。

距离比：用距离比表示的沿总投影长度的分割位置。(例如：0.4, 0.6, 0.9)

指定合并容许误差(公差)，合并新节点与现有节点。


08_分割

Home > midas Gen 2017 > 04_节点/单元 > 02_单元 > 07_分割

分 割

  • 功 能

分割选定单元并在分割点处建立节点。

  • 命 令

从主菜单中选择模型 > 单元 > 分割...

从树形菜单的菜单表单中选择几何模型 > 单元 > 分割

在图标菜单中单击 [image] 分割单元

快捷键： [Alt]+7

  • 输 入

单击分割单元右边的 [image] ，将显示单元表格。

节点起始号

输入新建单元的节点起始编号，该编号自动设置为当前最大节点号+1。要修改该项，单击 [image] 并选择一个选项指定目标编号。

单元起始号

输入新建单元的起始编号。该编号自动设置为当前最大节点号+1。要修改该项，单击 [image] 并选择一个选项指定目标编号。

分割

单元类型：指定单元类型。

线单元：线单元(桁架单元、梁单元等)。

实体单元：实体单元(三维实体单元)。

墙单元：墙单元。

其他平面单元：平面单元(板单元，平面应力单元等)。

等间距：以等间距分割单元。

线单元

x方向分割数量：单元坐标系x方向的分割数量。

其他平面单元

x方向分割数量：单元坐标系x方向的分割数量。

y方向分割数量：单元坐标系y方向的分割数量。

实体单元

x方向分割数量：单元坐标系x方向的分割数量。

y方向分割数量：单元坐标系y方向的分割数量。

z方向分割数量：单元坐标系z方向的分割数量。

任意间距：以不等间距分割。

线单元

x：输入沿单元坐标系x方向的各分割间距。

其他平面单元

x：输入沿单元坐标系x方向的各分割间距。

y：输入沿单元坐标系y方向的各分割间距。

实体单元

x：输入沿单元坐标系x方向的各分割间距。

y：输入沿单元坐标系y方向的各分割间距。

z：输入沿单元坐标系z方向的各分割间距。

任意距离比：用不同的距离比定义长度分割单元。

线单元

距离比x：按距离比输入沿单元坐标系x方向的各分割间距。

其他平面单元

距离比x：按距离比输入沿单元坐标系x方向的各分割间距。

距离比y：按距离比输入沿单元坐标系y方向的各分割间距。

实体单元

距离比x：按距离比输入沿单元坐标系x方向的各分割间距。

距离比y：按距离比输入沿单元坐标系y方向的各分割间距。

距离比z：按距离比输入沿单元坐标系z方向的各分割间距。

平行支撑

平行支撑主要适用于象输电塔桁架结构那样带有双支柱的结构。如果两个支柱之间用支撑连接，需要各支撑互相平行时，决定支柱上支撑点的位置计算起来比较繁琐。MIDAS软件提供平行斜支撑功能，按分割数量自动分割支柱单元，使分割点之间的连线互相平行。

分割数量

线单元(E1, E2)：选定用支撑连接的两个支柱。两个支柱必须是以某轴或某平面为基准对称的单元。

被节点分割

选择单元和节点。用节点把单元分成两个新的单元。

要分割的单元：要被分割的单元。

分割单元的节点：分割单元的节点。

注
分割单元的节点无需必须在要被分割的单元上。当分割单元的节点不在要被分割的单元上时，单元将被分割成与分割节点相连的两个单元。

被标准模式分割

按定义的模式分割平面单元。选择要分割的平面单元后，作为分割基准的基准边和基准点就会出现在模型窗口中以供参考。

用基准边分割平面单元

1.选择分割模式。

2.选择基准边(在图中以虚线表示)作为分割单元的依据。

用基准点分割平面单元

1. 选择分割模式。

2. 选择基准点(用红色的点表示)作为分割单元的依据。

用已定义的模式分割平面单元

1. 选择分割模式。

注
基准边和基准点限定模式的适用方向，但并不影响结构分析。

分割线单元

分割墙单元、板单元及实体单元的同时，分割与其相邻的梁单元。

合并重复节点

如果新节点与现有节点相符，将重叠的节点合并为一个节点。必要时，单击 [image] 修改合并容许误差(公差)。


09_合并

Home > midas Gen 2017 > 04_节点/单元 > 02_单元 > 08_合并

合 并

  • 功 能

将两个及以上的连续线单元合并为一个单元。

  • 命 令

从主菜单中选择模型 > 单元 > 合并...

从树形菜单的菜单表单中选择几何模型 > 单元 > 合并

在图标菜单中单击 [image] 合并单元

  • 输 入

单击合并单元右边的 [image] ，将显示单元表格。

节点起始号

该命令不适用。

单元起始号

该命令不适用。

合并

单元类型：选择要合并的单元的类型。

线单元：桁架单元、梁单元等。

平面单元：板单元、平面应力单元、平面应变单元等。

实体单元：各种实体单元等。

注：
当前版本中的'合并单元'功能只能用于线单元。

全部：合并模型中包含的所有线单元。

选择：只合并选中的单元。

强行合并：强行合并选择的单元。

容许误差：输入视为合并的最大角度。

单元：确定要合并的单元。

删除自由节点：消除所有无属性的节点及合并单元后与单元不关联的节点。

注1：
除强行合并之外，合并单元功能只能合并位于一条直线上的连续线单元。当需要合并与其它单元相交的两个连续直线单元时，需要使用强行合并功能。不能合并具有不同属性(材料特性、截面编号等)的单元。合并后荷载和边界条件保持不变(参见下图)，该功能提高了建模的效率。

注2：

该功能不能合并有两个及两个以上不同beta角的单元


10_交叉分割单元

Home > midas Gen 2017 > 04_节点/单元 > 02_单元 > 09_交叉分割

在交叉位置分割单元

  • 功 能

在先前输入的线单元(桁架，梁等)的交点处自动分割单元。

  • 命 令

从主菜单中选择模型 > 单元 > 在交叉位置分割单元...

从树形菜单的菜单表单中选择几何模型 > 单元 > 在交叉位置分割单元

在图标菜单中单击 [image] 在交叉位置分割单元

快捷键： [Alt]+8

  • 输 入

单击交叉分割单元右边的 [image] ，将显示单元表格。

节点起始号

输入新建单元的节点起始编号，该编号自动设置为当前最大节点号+1。要修改该项，单击 [image] 并选择一个选项指定目标编号。

单元起始号

输入新建单元的起始编号。该编号自动设置为当前最大节点号+1。要修改该项，单击 [image] 并选择一个选项指定目标编号。

交叉分割

容许误差：输入被视为交叉的最小距离。


03_删除

Home > midas Gen 2017 > 04_节点/单元 > 02_单元 > 10_删除

删 除

  • 功 能

删除单元。

注：使用单元删除功能时，选择的命令不同，其作用也不同。使用键盘上的[Delete]键或图标菜单中的 [image] 时，必须首先用选择功能选定目标单元。如果只选择单元而没有选择包括自由节点，即使删除单元后，节点仍保留。

  • 命 令

从主菜单中选择模型 > 单元 > 删除...

从树形菜单的菜单表单中选择几何模型 > 单元 > 删除

在图标菜单中单击 [image] 删除单元

快捷键： [Alt]+2

在键盘上按[Delete]

  • 输 入

单击删除单元右边的 [image] ，将显示单元表格。

节点起始号

该命令不适用。

单元起始号

该命令不适用。

类型

选择删除单元的方法。

点取：单击单元号输入区，然后在模型窗口中用鼠标点击要删除的单元。不需点击 [image] ，程序将立即删除这些单元。也可以在单元编号输入区内键入单元号删除单元。

选择：使用选择功能选择要删除的单元，单击 [image] 或在键盘上按[Delete]键。

包括自由节点：选择该选项后，无属性(节点荷载、边界条件等)的节点及与单元不关联的节点随单元一同被删除。


05_旋转

Home > midas Gen 2017 > 04_节点/单元 > 02_单元 > 11_旋转

旋 转

  • 功 能

绕特定轴旋转移动或旋转复制单元。

  • 命 令

从主菜单中选择模型 > 单元 > 旋转...

从树形菜单的菜单表单中选择几何模型 > 单元 > 旋转

在图标菜单中单击 [image] 旋转单元

快捷键： [Alt]+4

  • 输 入

<图1> 旋转单元对话框

单击旋转单元右边的 [image] ，将显示单元表格。

节点起始号

输入新建单元的节点起始编号，该编号自动设置为当前最大节点号+1。要修改该项，单击 [image] 并选择一个选项指定目标编号。

单元起始号

输入新建单元的起始编号。该编号自动设置为当前最大节点号+1。要修改该项，单击 [image] 并选择一个选项指定目标编号。

形式

复制：复制单元。

移动：移动单元。

旋转

等角度：以相同的角度增量旋转复制单元。

复制次数：复制次数。

旋转角度：现有单元旋转的角度。

>0：按右手法则旋转复制(或移动)节点。

<0：按右手法则的相反方向旋转复制(或移动)节点。

任意角度：以不同的角度增量旋转复制单元。

旋转角度：按顺序输入复制的旋转角度增量。例如: 20, 10, 3@30, 15 = 20, 10, 30, 30, 30, 15。

距离(径向)/距离(旋转轴向)

以给定角度(螺线或螺旋线形状)旋转复制节点时，指定径向复制距离和旋转轴方向复制距离。

旋转轴：选定旋转轴。

绕x轴：用户坐标系的x轴。

绕y轴：用户坐标系的y轴。

绕z轴：用户坐标系的z轴。

绕两点定义的轴：将连接两点的直线定义为旋转轴。

第一点

选择绕x、y、z轴时，输入轴上任意点的坐标。

选择绕两点定义的轴时，输入第一点的坐标。

第二点

选择绕两点定义的轴时，输入第二点的坐标。

材料号增幅

复制单元时材料特性编号的增量。

：选中重复时，随着复制数量的重复，材料特性编号以给定的增量增加。

截面号增幅

复制单元时截面编号的增量。

：选中重复时，随着复制数量的重复，截面编号以给定的增量增加。

厚度号增幅

复制单元时厚度编号的增量。

：选中重复时，随着复制数量的重复，厚度编号以给定的增量增加。

交叉分割

仅适用于线单元。

如果选择交叉分割且现有节点在生成的线单元上，则在现有节点处分割单元。

如果选择交叉分割且生成的线单元与现有单元相交，则在交点处自动生成节点并分割单元。

复制节点属性

决定是否一同复制被复制节点的属性(节点边界条件、节点集中荷载)。当复制部分属性时，单击 [image] 选择需要复制的节点属性。

<图2> 复制节点属性对话框

复制单元属性

决定是否一同复制被复制单元的属性(单元边界条件、单元集中荷载)。当复制部分属性时，单击 [image] 选择需要复制的单元属性。

<图3> 复制单元属性对话框

旋转β角

用旋转复制或移动单元时，决定被复制的单元属性中的β角是否随旋转轴改变。

指定合并公差，合并新近生成的节点和现有节点。

注
使用移动和复制节点可以同时移动节点和相关单元。


07_镜像

Home > midas Gen 2017 > 04_节点/单元 > 02_单元 > 12_镜像

镜 像

  • 功 能

以特定的镜面对称移动或复制单元。

  • 命 令

从主菜单中选择模型 > 单元 > 镜像...

从树形菜单的菜单表单中选择几何模型 > 单元 > 镜像

在图标菜单中单击 [image] 镜像单元

快捷键： [Alt]+6

  • 输 入

单击镜像单元右边的 [image] ，将显示单元表格。

节点起始号

输入新建单元的节点起始编号，该编号自动设置为当前最大节点号+1。要修改该项，单击 [image] 并选择一个选项指定目标编号。

单元起始号

输入新建单元的起始编号。该编号自动设置为当前最大节点号+1。要修改该项，单击 [image] 并选择一个选项指定目标编号。

形式

复制：复制单元。

移动：移动单元。

镜像平面：指定镜像平面。

y-z 平面：镜面平行于用户坐标系y-z平面。

x：镜面的x坐标

x-y 平面：镜面平行于用户坐标系x-y平面。

z：镜面的z坐标。

z-x 平面：镜面平行于用户坐标系z-x平面。

y：镜面的y坐标。

由三点定义的平面：镜面是一任意平面。

x1, y1, z1：定义镜面的第一点的x, y, z坐标

x2, y2, z2：定义镜面的第二点的x, y, z坐标

x3, y3, z3：定义镜面的第三点的x, y, z坐标

可以用键盘直接键入三点坐标，或者单击相应的输入区后在模型窗口中点击目标节点。

材料号的增幅：复制单元时材料特性编号的增量。

截面号的增幅：复制单元时截面编号的增量。

厚度号的增幅：复制单元时厚度编号的增量。

交叉分割：仅适用于线单元。

如果选择节点且现有节点在生成的线单元上，则在现有节点处分割单元。

如果选择单元且生成的线单元与现有单元相交，则在交点处自动生成节点并分割单元。

复制节点属性:决定是否复制被复制节点的属性(节点边界条件，节点集中荷载)。

单击 [image] 选择需要复制的节点属性。

复制单元属性:决定是否复制被复制单元的属性(单元边界条件，单元集中荷载)。

单击 [image] 选择需要复制的单元属性。

镜像β角:镜像复制或移动单元时，选择是否以反射面为对称面镜像β角。

反转单元坐标系

镜像复制或移动单元时，选择是否以反射面为对称面镜像UCS。

对线单元，β角保持不变，仅改变节点i, j(局部坐标轴方向)。

对平面单元，颠倒单元生成过程中的节点输入次序。

对实体单元，颠倒单元生成过程中的节点输入次序。

指定合并容许误差(公差)，合并新近生成的节点和现有节点。


12_紧凑单元号

Home > midas Gen 2017 > 04_节点/单元 > 02_单元 > 13_紧凑单元号

紧凑单元编号

  • 功 能

删除不用的单元号，并对全部或某些单元按整体坐标系的坐标方向的优先次序重新编号。

  • 命 令

从主菜单中选择模型 > 单元 > 紧凑单元号...

从树形菜单的菜单表单中选择几何模型 > 单元 > 紧凑单元号

在图标菜单中单击 [image] 紧凑单元号

快捷键： [Alt]+0

  • 输 入

单击紧凑单元编号右边的 [image] ，将显示单元表格。

节点起始号

该命令不适用。

单元起始号

该命令不适用。

选择范围

选定要按优先次序重新编号的单元编号范围。

全部：选定所有单元。

根据选择的号码：选定目标单元编号的特定范围。

起始号：选定范围的起始单元号。

结束号：选定范围的结束单元号。


13_重编单元号

Home > midas Gen 2017 > 04_节点/单元 > 02_单元 > 14_重编单元号

重编单元号

  • 功 能

按整体坐标系方向的优先次序对现有单元(节点)重新编号。

  • 命 令

从主菜单中选择模型 > 单元 > 重编单元号...。

从树形菜单的菜单表单中选择几何模型 > 单元 > 重新编号。

在图标菜单中单击 [image] 重编单元号。

  • 输 入

单击重新编号右边的 [image] ，显示单元表格。

节点起始号

该命令不适用。处于钝化状态。

重新编号的对象

节点：重编节点号。

单元：重编单元号。

节点和单元：重编节点和单元号。

选择

全部：选定所有对象。

根据选择：用户选择的对象。

新起始号

节点：新的节点起始号。

单元：新的单元起始号。

置新编号选项

排序坐标：选择排序时使用的坐标系。

直角坐标系：以直角坐标系作为排序坐标系。

圆柱坐标系：以圆柱坐标系作为排序坐标系。

排序：选择排序时各坐标轴的优先级。

当在排序坐标中选择直角坐标系时，新的节点(单元)编号考虑的坐标轴优先次序如下：

1ST：选定重新对节点(单元)编号时具有最高优先权的整体坐标轴。

2ND：选定具有第二优先权的轴。

3RD：选定剩下的轴。

注：可按整体坐标系负坐标轴方向对已有节点和单元重新编号。对于桩单元和框架单元，可按重力方向对节点和单元重新编号。

<图1> 按负坐标重编示例

当在排序坐标中选择圆柱坐标系时，将以圆柱坐标系作为排序坐标。

旋转轴：定义圆柱坐标系的Z轴。可以选择整体坐标系的X、Y、Z轴定义，也可以选择两点定义。

极坐标：定义圆柱坐标系的极坐标轴。可以选择整体坐标系的X、Y、Z轴定义，也可以选择两点定义。

1ST：选定重新对节点(单元)编号时具有最高优先权的圆柱坐标轴。

2ND：选定具有第二优先权的轴。

3RD：选定剩下的轴。


14_单元起始号

Home > midas Gen 2017 > 04_节点/单元 > 02_单元 > 15_单元起始号

单元起始号

  • 功 能

指定新近生成的单元的编号方法。

  • 命 令

从主菜单中选择模型 > 单元 > 单元起始号...

从树形菜单的菜单表单中选择几何模型 > 单元 > 起始号

  • 输 入

单元编号选项

没有使用的最小号码：

将没有使用的号码中的最小编号赋予新建单元。在现有单元中有中间空余号时，首先递补空余号，然后按使用的最大号码+1依次生成单元。

使用的最大号码+1：

将当前使用的号码中的最大编号+1赋予新建单元。

用户定义号码：

按用户定义的起始编号赋予新建单元。用户不能赋予新建单元以现有的单元号，但可以赋予空余号

新生成的单元起始号

当前面选择了"没有使用的最小号码"或"使用的最大号码+1"时，程序将自动指定相应号码；当前面选择了"用户定义号码"，则需用户输入新建单元的起始号。


11_修改单元参数

Home > midas Gen 2017 > 04_节点/单元 > 02_单元 > 16_修改参数

修改单元参数

  • 功 能

改变单元的属性(材料特性号、截面号、厚度号、β角等)。

  • 命 令

从主菜单中选择模型 > 单元 > 修改单元参数...

从树形菜单的菜单表单中选择几何模型 > 单元 > 修改单元参数

在图标菜单中单击 [image] 修改单元参数

快捷键： [Alt]+9

  • 输 入

单击修改单元参数右边的 [image] ，将显示单元表格。

节点起始号

该命令不适用。

单元起始号

该命令不适用。

参数类型

材料号：改变材料号。

截面号：改变截面号。

厚度号：改变厚度号。

墙号：改变墙号。

单元坐标轴方向：改变单元坐标轴方向。

单元类型：改变单元类型。

反转单元坐标轴：将单元局部坐标轴转换为相反方向。

统一单元坐标轴：修改单元的局部坐标轴，使其右手法则的旋转方向与参考单元一致。

形式

当在参数类型中选择了材料号时

分配：重新定义或复制相应属性，并将属性赋予选择的单元。

定义：输入修改后的材料号或材料名称。

复制：当选择新建属性数量等于选择的特性值数量时，在工作目录树中将生成相等于选择的特性值数量的新的特性值。当选择新建属性数量等于选择的单元数量时，在工作目录树中将生成相等于选择的单元数量的新的特性值。

修改：用已定义的材料号码增幅修改材料号。

号码增幅：输入材料号码增量。

当在参数类型中选择了截面号时

分配：重新定义或复制相应属性，并将属性赋予选择的单元。

定义：输入修改后的截面号或截面名称。

复制：当选择新建属性数量等于选择的特性值数量时，在工作目录树中将生成相等于选择的特性值数量的新的特性值。当选择新建属性数量等于选择的单元数量时，在工作目录树中将生成相等于选择的单元数量的新的特性值。

修改：用已定义的截面号码增幅修改材料号。

号码增幅：输入截面号码增量。

当在参数类型中选择了厚度号时

分配：重新定义或复制相应属性，并将属性赋予选择的单元。

定义：输入修改后的厚度号或厚度名称。

复制：当选择新建属性数量等于选择的特性值数量时，在工作目录树中将生成相等于选择的特性值数量的新的特性值。当选择新建属性数量等于选择的单元数量时，在工作目录树中将生成相等于选择的单元数量的新的特性值。

修改：用已定义的厚度号码增幅修改材料号。

号码增幅：输入厚度号码增量。

当在参数类型中选择了墙号时

分配：重新定义或复制相应属性，并将属性赋予选择的单元。

固定号：直接输入修改后的墙号。

自动编号：自动编号。

最后号+1：用当前模型中最大号+1重新编号。

修改：用已定义的墙号增幅修改材料号。

号码增幅：输入墙号增量。

当在参数类型中选择了单元坐标轴方向时

分配：重新定义或复制相应属性，并将属性赋予选择的单元。

Beta角：输入修改后的β角。

参考节点：输入新的参考节点坐标。

参考向量：输入新的参考向量。

修改：用已定义的β角增量修改构件的β角。

角度增量：输入β角增量。

当在参数类型中选择了单元类型时

当原类型为桁架单元，修改为只受拉单元时

容许压力：输入只受拉单元的最大容许压力。

当原类型为桁架单元，修改为钩单元时

初始间隙：输入钩单元的初始间隙。

当原类型为桁架单元，修改为索单元时，不需另外输入参数。

当原类型为桁架单元，修改为只受压单元时

容许张力：输入只受压单元的最大容许张力。

当原类型为桁架单元，修改为间隙单元时

初始间隙：输入间隙单元的初始间隙。

当原类型为桁架单元，修改为一般梁/变截面梁单元时，不需另外输入参数。

当原类型为只受拉/钩/索单元，修改为桁架单元时，不需另外输入参数。

当原类型为只受拉/钩/索单元，修改为只受拉单元时

容许压力：输入只受拉单元的最大容许压力。

当原类型为只受拉/钩/索单元，修改为钩单元时

初始间隙：输入钩单元的初始间隙。

当原类型为只受拉/钩/索单元，修改为索单元时，不需另外输入参数。

当原类型为只受拉/钩/索单元，修改为只受压单元时

容许张力：输入只受压单元的最大容许张力。

当原类型为只受拉/钩/索单元，修改为间隙单元时

初始间隙：输入间隙单元的初始间隙。

当原类型为只受拉/钩/索单元，修改为一般梁/变截面梁单元时，不需另外输入参数。

当原类型为只受压/间隙单元，修改为桁架单元时，不需另外输入参数。

当原类型为只受压/间隙单元，修改为只受拉单元时

容许压力：输入只受拉单元的最大容许压力。

当原类型为只受压/间隙单元，修改为钩单元时

初始间隙：输入钩单元的初始间隙。

当原类型为只受压/间隙单元，修改为索单元时，不需另外输入参数。

当原类型为只受压/间隙单元，修改为只受压单元时

容许张力：输入只受压单元的最大容许张力。

当原类型为只受压/间隙单元，修改为间隙单元时

初始间隙：输入间隙单元的初始间隙。

当原类型为只受压/间隙单元，修改为一般梁/变截面梁单元时，不需另外输入参数。

当原类型为一般梁/变截面梁单元，修改为桁架单元时，不需另外输入参数。

当原类型为一般梁/变截面梁单元，修改为只受拉单元时

容许压力: 输入只受拉单元的最大容许压力。

当原类型为一般梁/变截面梁单元，修改为钩单元时

初始间隙: 输入钩单元的初始间隙。

当原类型为一般梁/变截面梁单元，修改为索单元时，不需另外输入参数。

当原类型为一般梁/变截面梁单元，修改为只受压单元时

容许张力: 输入只受压单元的最大容许张力。

当原类型为一般梁/变截面梁单元，修改为间隙单元时

初始间隙: 输入间隙单元的初始间隙。

当原类型为板单元，修改为板单元时

类型: 修改板单元类型(厚板、薄板)。

当原类型为板单元，修改为平面应力单元时，不需另外输入参数。

当原类型为平面应力单元，修改为板单元时

类型: 定义板单元类型(厚板、薄板)。

当在参数类型中选择了反转单元坐标轴时

在单元类型中选择线单元时，将反转被选择的线单元的单元坐标轴。

在单元类型中选择平面单元时，将反转被选择的平面单元的单元坐标轴。

在单元类型中选择实体单元时，将反转被选择的实体单元的单元坐标轴。

在形式中选择反转单元属性时，在反转单元坐标轴的同时反转单元上输入的边界条件和荷载。

当在参数类型中选择了统一单元坐标轴时

参考单元：指定修改单元坐标轴时要参考的单元号。

对齐顺序：选择对齐单元局部坐标轴的优先次序，使选中单元的局部坐标轴方向尽量与参考单元的局部坐标轴一致。

注：
如果单元局部坐标轴不能与参考单元局部坐标系完全一致，尽可能使参考单元局部坐标系接近最高优先次序的坐标轴。


15_单元表格

Home > midas Gen 2017 > 04_节点/单元 > 02_单元 > 17_单元表格

单元表格

  • 功 能

在电子表格中输入或修改与单元相关的所有数据。

MIDAS/Gen中的表格工具提供了各种强大的功能，详细说明参见下列各项：

表格工具的使用

术语

掌握使用方法

基本说明(单元移动、选择、大小控制等)

数据处理(增加、删除、修改数据)

用剪贴板复制/粘贴数据

表格功能补充

表格排序

表格格式设定

自动适应列宽

图表打印

各表格类型的补充功能

节点/单元表格

结果表格

  • 命 令

从主菜单中选择模型 > 单元 > 单元表格...

从树形菜单的表格表单中选择表格 > 结构表格 > 单元

快捷键： [Ctrl]+[Alt]+N

  • 输 入 (参见" 建立单元 ")

参见表格工具的使用输入或修改下列数据：

单元表格

单元：单元编号。

类型：单元类型。

辅助类型：单元从属类型。

墙号：墙号。

材料：材料特性编号。

截面：截面特性编号。

β角：定义线单元截面方向的β角。

节点1，...，8：单元关联节点编号。

种类：初拉力类型。

初始间隙：钩或间隙单元的初始距离。

Lu：初拉力大小。

张力：索单元的初拉力值。

允许抗拉强度/抗压强度：允许抗拉强度/抗压强度。

使用极限值：是否使用极限值。

极限抗拉强度/抗压强度：极限抗拉强度/抗压强度。


定义有效梁

  • 功 能

1. 此功能用于定义有效梁。

2. 对于双向无梁的平板结构，用有效梁宽法进行分析/设计时，需要使用此功能来定义有效梁。

3. 布置了有效梁并选择了有效梁宽法进行分析/设计时，模型中的横向荷载由有效梁来承担，重力荷载由网格化板承担。

4. 布置了有效梁并选择了有限元法时，布置的有效梁将被忽略，仅由网格化板承担所有的横向荷载和重力荷载。

  • 命 令

从主菜单中选择模型 > 节点/单元 > 平板结构 > 定义有效梁

在图标菜单中单击 [image] 定义有效梁

  • 输 入

定义有效梁

添加/替换：添加新的有效梁或修改已定义的有效梁；

删除：删除已定义的有效梁。

添加/修改 有效梁

名称，说明：输入有效梁名称及相关说明；

i节点/宽度：从i节点处看j节点方向，ij节点连线为基准，左边/右边的宽度；

j节点/宽度：从j节点处看i节点方向，ij节点连线为基准，左边/右边的宽度；

支持输入左右宽度不同或 i、j 端宽度不同的有效梁。

点击右侧的 按钮，可以自动计算有效梁宽度。

自动计算的方法，程序提供Grossman和 Choi & Song两种。

1. Jzcob S. Grossman

1) 中跨

2) 边跨

KFP | 中柱 | 边柱 | 角柱
 | 1.0 | 0.8 | 0.6

Kd | Hs/800 | Hs/400 | Hs/200 | Hs/100
 | 1.1 | 1.0 | 0.8 | 0.5
楼板裂缝 (Ie/Ig) | 55% | 50% | 40% | 25%

2. Choi & Song

3) 中跨

刚性杆

柔性杆

4) 边跨

刚性杆

柔性杆

点击“计算”按钮即可按照当前定义的条件自动计算有效梁宽度，计算结果在按钮下方的框中显示；

点击“确认”按钮将自动计算结果更新到上一级对话框。计算的左右宽度值是相同的，左右宽度不同时在对话框中直接修改即可。

注意：有效梁的d是输入的板厚度减去保护层厚度Cc后的值。


建立有效梁

  • 功 能

1. 此功能用于布置有效梁。

2. 对于双向无梁的平板结构，用有效梁宽法进行分析/设计时，需要使用此功能来布置有效梁。

3. 布置了有效梁并选择了有效梁宽法时，模型中的横向荷载，由有效梁来承担，楼板刚度视为0；选择有限元法时，分析设计时忽略有效梁。

4. 分析方法在菜单 分析 > 分析控制 > 板分析控制 中选择。

  • 命 令

从主菜单中选择模型 > 节点/单元 > 平板结构 > 建立有效梁

在图标菜单中单击 [image] 建立有效梁

  • 输 入

有效梁名称：选择“定义有效梁”中已定义的有效梁；

材料号：选择有效梁材料；

节点连接：选择有效梁的两端节点，第一点为i节点，第二点位j节点；

交叉：设置建立的梁与现有节点或单元相交时是否分割；

节点：当现有节点位于将要生成的线单元上时，在现有节点位置处将单元分割。

单元：如果将要生成的线单元与现有线单元相交，则在相交点位置处自动生成节点并将线单元分割。


定义柱上板带2

Home > midas Gen 2017 > 04_节点/单元 > 03_平板结构 > 02_柱上板带 > 01_定义柱上板带

定义柱上板带

  • 功 能

此功能用于定义柱上板带。

  • 命 令

从主菜单中选择模型 > 节点/单元 > 平板结构 > 定义柱上板带

在图标菜单中单击 [image] 定义柱上板带

  • 输 入

定义板带

添加/替换：添加新的柱上板带或修改已定义的柱上板带；

删除：删除已定义的柱上板带。

添加/修改 板带

名称，说明：输入柱上板带的名称及相关说明；

i节点/宽度： 从i节点处看j节点方向，ij节点连线为基准，左边/右边的宽度；

j节点/宽度： 从j节点处看i节点方向，ij节点连线为基准，左边/右边的宽度；

支持输入左右宽度不同或 i、j 端宽度不同的柱上板带。


指定柱上板带1

Home > midas Gen 2017 > 04_节点/单元 > 03_平板结构 > 02_柱上板带 > 02_指定柱上板带

指定柱上板带

  • 功 能

此功能用于指定柱上板带。

  • 命 令

从主菜单中选择模型 > 节点/单元 > 平板结构 > 指定柱上板带

在图标菜单中单击 [image] 指定柱上板带

  • 输 入

柱上板带名称：选择“定义柱上板带”中已定义的柱上板带；

按节点指定： 指定两节点在两点间设置柱上板带； 对于未设置有效梁的楼板布置柱上板带时可使用此功能。

节点连接：选择柱上板带的两端节点；

按单元指定/选项：

添加/替换：布置新的柱上板带或替换已布置的柱上板带；选择模型视图中有效梁，点击“适用”按钮，在有效梁线上生成柱上板带。

删除：删除选择的柱上板带。

注意：柱上板带设计以板带最小厚度来进行计算，输入板托的宽度比板带要大（如果输入的比板带小，板带设计时，以端部的区域以最小厚度来进行设计）


定义托板1

Home > midas Gen 2017 > 04_节点/单元 > 03_平板结构 > 03_托板 > 01_定义托板

定义托板

  • 功 能

此功能用于定义托板。

  • 命 令

从主菜单中选择模型 > 节点/单元 > 平板结构 > 定义托板

在图标菜单中单击 [image] 定义托板

  • 输 入

定义托板

添加/替换：添加新的托板或修改已定义的托板；

删除：删除已定义的托板。

添加/修改 托板

名称，说明：输入托板的名称及相关说明；

形状

B1，B2：输入整体坐标系Y方向的尺寸（只能输入比0大的数值）

H1，H2：输入整体坐标系X方向的尺寸（只能输入比0大的数值）

厚度：输入托板厚度，注意此厚度包含楼板厚度；

角度：输入托板的角度。


指定托板

  • 功 能

此功能用于指定托板。

  • 命 令

从主菜单中选择模型 > 节点/单元 > 平板结构 > 指定托板

在图标菜单中单击 [image] 指定托板

  • 输 入

添加/替换：布置新的托板或替换已布置的托板；

删除：删除选择的托板。

托板名称：选择“定义托板”中已定义的托板。

注意： 托板或柱头连接是必须在网格化楼板范围内设置的。网格化楼板区域外设置的板托或柱头连接，在分析设计时将被忽略。

柱上板带设计以板带最小厚度来进行计算，输入板托的宽度比板带要大（如果输入的比板带小，板带设计时，以端部的区域以最小厚度来进行设计）


定义柱头连接

  • 功 能

此功能用于定义柱头连接。

  • 命 令

从主菜单中选择模型 > 节点/单元 > 平板结构 > 定义柱头连接

在图标菜单中单击 [image] 定义柱头连接

  • 输 入

定义托板

添加/替换：添加新的托板或修改已定义的柱头连接；

删除：删除已定义的柱头连接。

添加/修改 柱头连接

添加/修改：添加新的柱头连接或修改已定义的柱头连接；

删除：删除已定义的柱头连接。

名称，说明：输入柱头连接的名称及相关说明；

B1，B2：输入局部坐标系y方向的尺寸（只能输入比0大的数值）

H1，H2：输入局部坐标系y方向的尺寸（只能输入比0大的数值）

自动刚性连接：选择柱头连接区域是否作为刚域处理。选定时，柱头连接区域内其他构件的节点都设置为刚域。

此时，设置柱头连接时选择的柱上部节点为主节点，柱头连接定义区域内的其他节点为从节点。

刚性连接是指自由度DX, DY, DZ, RX, RY, RZ均被约束住。


指定柱头连接

  • 功 能

此功能用于指定柱头连接。

  • 命 令

从主菜单中选择模型 > 节点/单元 > 平板结构 > 指定柱头连接

在图标菜单中单击 [image] 指定柱头连接

  • 输 入

添加/替换：布置新的柱头连接或替换已布置的柱头连接；

删除：删除选择的柱头连接。

柱头连接名称：选择“定义柱头连接”中已定义的柱头连接；

注意：托板或柱头连接是必须在网格化楼板范围内设置的。网格化楼板区域外设置的板托或柱头连接，在分析设计时将被忽略。


02_自动网格平面区域

Home > midas Gen 2017 > 04_节点/单元 > 03_网格 > 01_自动网格

自动网格平面区域

  • 功 能

指定区域自动划分网格。

  • 命 令

从主菜单中选择模型 > 网格 > 自动网格平面区域...

在树形菜单的菜单表单中选择模型 > 网格 > 自动网格平面区域...

点击快捷图标

  • 输 入

网格划分器

方法：定义需划分网格的面域。有三种方式: 节点、线单元、平面单元。

节点：按选择顺序显示节点号，所有节点必须在同一个平面上。

线单元：按连接顺序显示单元号，所有单元必须在同一个平面上。

平面单元：按连接顺序显示单元号，所有单元不必在同一个平面上。

类型：四边形、四边形+三角形、三角形。

考虑内部区域划分：勾选该项时，如果面域内有内部区域，相应的内部区域也会生成网格。下图为勾选与否的区别示例：

考虑内部节点划分：勾选该项，划分网格时会考虑面域内的节点。

自动：自动识别面域内的节点。

用户：用户指定面域内的节点。

考虑内部线划分：勾选该项，划分网格时会考虑面域内的线单元。线单元可以取自线单元、面单元或实体单元。

自动：自动识别面域内的节点。

用户：用户指定面域内的节点。

考虑边界上耦合：勾选该项，会自动考虑相邻面域的单元耦合。

网格尺寸

长度：定义单元的边长。

分割：定义组成面域单元的分割份数。

特性

单元类型：共有板、平面应力单元、平面应变单元、轴对称单元四种类型。选择板或平面应力单元时，右面的按钮 [image] 亮显，可以定义单元子类型。

单元子类型（板）

单元子类型（平面应力单元）

材料：选择单元材料属性，点击右侧按钮 [image] 可打开定义材料对话框。 ?

厚度：选择单元厚度属性，点击右侧按钮 [image] 可打开定义厚度对话框。

区域

定义区域名称。点击右侧按钮 [image] 可打开定义区域对话框。

删除原线单元

勾选该项，生成网格后自动删除网格周边线单元。

分割原线单元

不勾选上一项时，该项起作用。 勾选该项时，根据网格尺寸自动划分网格周边线单元，分割后的单元仍然作用一个构件考虑。


01_映射网格四节点区域

Home > midas Gen 2017 > 04_节点/单元 > 03_网格 > 02_映射网格

映射网格4节点区域

  • 功 能

指定4节点区域，自动划分规则网格。

  • 命 令

从主菜单中选择模型 > 网格 > 映射网格4节点区域...

在树形菜单的菜单表单中选择模型 > 网格 > 映射网格4节点区域...

点击快捷图标

  • 输 入

角点

逆时针或顺时针连续选择4个角点形成四边形面域。选择方向决定了网格单元的法向。

参数

分割：每一个方向的分割份数。

斜率：定义最后单元与第一个单元的比率。

网格类型

三角形

四边形

特性

单元类型：共有板、平面应力单元、平面应变单元、轴对称单元四种类型。选择板或平面应力单元时，右面的按钮 [image] 亮显，可以定义单元子类型。

单元子类型（板）

单元子类型（平面应力单元）

材料：选择单元材料属性，点击右侧按钮 [image] 可打开定义材料对话框。

厚度：选择单元厚度属性，点击右侧按钮 [image] 可打开定义厚度对话框。

区域

定义区域名称。点击右侧按钮 [image] 可打开定义区域对话框。

删除原线单元

勾选该项，生成网格后自动删除网格周边线单元。

分割原线单元

不勾选上一项时，该项起作用。 勾选该项时，根据网格尺寸自动划分网格周边线单元，分割后的单元仍然作用一个构件考虑。


03_定义区域

Home > midas Gen 2017 > 04_节点/单元 > 03_网格 > 03_定义区域

定义区域

  • 功 能

自动划分网格功能划分单元时，可自动形成一个区域。 属于同一区域的单元必须具有相同的单元类型、材料特性和厚度属性。每个区域可分成若干个子域，划分网格前已分割的面域可自动形成一个子域。

一个区域可以包含不属于任何子域的单元， 完全属于子域的单元将不再属于该区域。

  • 命 令

从主菜单中选择模型 > 区域 > 定义区域...

在树形菜单的菜单表单中选择模型 > 区域 > 定义区域...

点击快捷图标

  • 输 入

新建或添加一个区域时，输入下列各项并单击 。

单元：区域名称。

单元类型：选择区域的单元类型，有板、平面应力单元、平面应变单元、轴对称单元四种。当选择板或平面应力单元时，右侧的 [image] 按钮亮显，可定义单元子类型。

材料：通过右侧下拉框选择区域的材料特性。可以点击 [image] 打开定义材料对话框。

厚度：通过右侧下拉框选择区域的厚度特性。可以点击 [image] 打开定义厚度对话框。

单元列表：显示直接属于该区域的单元号。

修改已命名的区域时：

选择相应区域，填写新参数后单击 [image] 。

删除已命名的区域时：

选择相应区域后单击 [image] 。


04_定义子区域

Home > midas Gen 2017 > 04_节点/单元 > 03_网格 > 04_定义子区域

定义子区域

  • 功 能

将同一个区域内设计结果相同的板单元，定义为子区域。

  • 命 令

从主菜单中选择节点/单元 > 网格 > 定义子区域

点击快捷图标

  • 输 入

区域

名称：显示子域所属区域名称。

单元类型：显示子域所属区域的单元类型。

子区域

名称：子域名称。

构件类型：显示子域的构件类型，有楼板、筏板、墙三种类型。水平向面域自动识别为楼板类型，竖向面域自动识别为墙类型。

布筋方向（逆时针为正）：依次输入子域钢筋主方向（方向一：与整体坐标X轴夹角）和钢筋次方向（方向二：与方向1夹角）。

使用模型中厚度：输入设计验算用厚度。可使用模型中定义厚度，也可输入新的厚度。

板/筏板主筋：设置板/筏板的基本构造配筋，当无基本构造配筋时，可不勾选。

非线性分析用钢筋材料：考虑板的非线性分析时需要勾选此项，在材料特性值中定义了范米塞斯的塑性材料，才能在此处的下拉框中进行选择。

说明：程序可以考虑板的材料非线性分析、板的Pushover分析以及板的弹塑性分析。当考虑板的非线性分析时，不仅需要将混凝土板定义为塑性材料，还需在此处将板的钢筋定义为钢材料的塑性材料。

单元列表：显示属于该子域的单元号。

修改已命名的子区域时：

选择相应子区域，填写新参数后单击 [image] 。

删除已命名的子区域时：

选择相应子区域后单击 [image] 。

区域和子域示例如下图：

子域可以单独进行选择和设计验算。楼板、筏板和竖向板设计时必须要定义子区域。

注意：属于子域内面单元的节点也属于该子域，当删除该子域时，若节点只属于子域内面单元，则节点也同时被删除；若节点同时属于除了面单元外的其他单元，则节点仍保留。


01_材料

Home > midas Gen 2017 > 05_特性 > 01_材料 > 01_材料特性值

材 料

  • 功 能

输入各向同性和正交各向异性材料的材料特性。

midas Gen可以分析各向同性和正交各向异性材料的结构，在进行各向异性材料非线性。

分析时，需要定义塑性材料模型。(参见"塑性材料")

  • 命 令

从主菜单中选择模型 > 材料和截面特性 > 材料...

从树形菜单的菜单表单中选择几何模型 > 特性值 > 材料

在图标菜单中单击 [image] 材料

  • 输 入

<图1> 材料和截面对话框

<图2> 材料数据对话框

新建或增加材料特性时

在材料和截面对话框中单击 [image] ，输入下列数据：

材料号：材料编号。

名称：材料名称。

类型：选择材料特性类型(混凝土、钢材、组合材料、用户定义等)。

注：
选择的材料仅用于分析，设计时可另外选择材料。

当选择'钢材'时

规范：在输入区内选择某个国家的材料标准。

无：用户直接定义材料特性。当需要编辑和修改从标准数据库得到的数据时，可选用?无?后激活标准数据输入框。

GB12（S）:中国国家标准，钢结构设计规范 GB50017-2013。包括Q235，Q345、Q390、Q420、Q345GJ、Q460。

GB03(S)：中国国家标准，钢结构设计规范 GB 50017-2003。包括Q235、Q345、Q390、Q420钢。

GB(S)：中国国家标准，钢结构设计规范 GBJ 17-88。包括3号钢、16Mn钢、16Mnq钢、15MnV钢、15MnVq钢。

JGJ(S)：中国行业标准，高层民用建筑钢结构技术规程 JGJ 99-98。包括Q235钢、Q295、Q345、Q390、Q420。

JTJ(S)：中国交通部标准，公路桥涵钢结构及木结构设计规范 JTJ 025-86。包括A3钢和16Mn钢。

ASTM(S)：美国材料试验协会标准

CSA(S):加拿大标准协会标准

BS(S)：英国标准

DIN(S)：德国工业标准

EN(S)：欧洲标准

JIS(S)：日本工业标准

KS(S)：韩国工业标准

KS-Civil(S)：韩国土木工程标准

IS(S):印度标准

CNS(S):台湾标准

数据库：选择在各标准规范中使用的钢材类型。

当选择?混凝土?时

规范：在输入区内选择某个国家材料标准。

无：用户直接定义材料特性。当需要编辑和修改从标准数据库得到的数据时，可选用?无?后激活标准数据输入框。

GB10(RC):中国国家标准，混凝土结构设计规范 GB50010-2010，包括C15~C80。

GB(RC)：中国国家标准，混凝土结构设计规范 GB 50010-2002。包括C15～C80。

GB-Civil(RC)：中国交通部部标准，公路钢筋混凝土及预应力混凝土桥涵设计规范 JTJ 023-85。包括C15～C80。

ASTM(RC)：美国材料试验协会

CSA(S):加拿大标准协会标准。(请参考有关规范)

BS(S)：英国标准。(请参考有关规范)

EN(S)：欧洲标准。(请参考有关规范)

JIS(S)：日本工业标准。(请参考有关规范)

KS(RC)：韩国工业标准。(请参考有关规范)

KS-Civil(RC)：韩国土木工程标准。(请参考有关规范)

IS(S):印度标准。(请参考有关规范)

CNS(S):台湾标准。

数据库：选择在各标准规范中使用的混凝土类型。

当选择'组合材料'时

与上述选择的类型'钢材'、'混凝土'情况类似，在钢及混凝土输入窗口内选择钢及混凝土的材料。

设计中将选用中国行业标准"型钢混凝土组合结构技术规程" JGJ 138-2001中的规定。组合材料中的混凝土材料使用GB 50010-2002中的材料，钢材应选用Q235和Q345。

当选择'用户定义'时

当材料类型不是'钢'，'砼'或'组合材料'，或用户希望直接定义材料特性时，选择该项。

材料类型：决定材料为各向同性还是各向异性。各向异性材料仅适用于用户定义的方式。

弹性模量

泊松比

用泊松比计算剪切模量如下：

剪切模量 = 弹性模量 / (2 x (1+泊松比))

注：
中国规范的剪切模量和泊松比：

混凝土结构设计规范 GB 50010-2010: 0.4 * 弹性模量，泊松比为0.2。

公路钢筋混凝土及预应力混凝土桥涵设计规范 JTJ 023-85: 0.43 * 弹性模量，泊松比为1/6。

钢结构设计规范 GB50017-2003: 79000 N/mm2，泊松比为0.3。

高层民用建筑钢结构技术规程 JGJ 99-98: 79000 N/mm2，泊松比为0.3。

公路桥涵钢结构及木结构设计规范 JTJ 025-86: 81000 N/mm2，泊松比为0.3。

线膨胀系数：线膨胀系数用于温度应力分析。

容重：容重用于计算自重和质量。中国规范的混凝土容重均使用了25kN/m2，钢材容重使用了7850kg/m3。

使用质量密度：定义质量密度。

注：
可以通过上面的功能单独定义质量密度。

塑性数据：输入塑性材料数据。

塑性材料名称：选择已经在塑性材料对话框中定义的塑性材料。

热特性值

比热

热传导率:用于热应力分析。

注：
MIDAS的设计功能不能设计自定义类型的构件。

阻尼比

定义材料阻尼比；

注1：进行反应谱分析和时程分析时，对混凝土和钢材采用不同的阻尼比。

反应谱分析：当选择应变能法时，可采用按照材料定义的阻尼比；

时程分析：当选择应变能法或单元质量和刚度因子时，可采用按照材料定义的阻尼比；

注2： 各种材料默认的阻尼比

-钢材：0.02（2%）

-混凝土/SRC:0.05 (5%)

-用户： 0.00（0%）

修改先前输入的材料特性数据

在材料和截面对话框中选择要修改的材料特性并单击 [image] ，修改相应的数据。

删除先前输入的材料特性数据

在材料和截面对话框中选择要删除的材料特性并单击 [image] 。

复制先前输入的材料特性数据

在材料和截面对话框中选择要复制的材料特性并单击 [image] 。

从现有*.MCB文件输入材料特性数据

单击 [image] ，选择包含材料特性数据的*.MCB文件或指定一个文件名，然后单击 [image] 。

<图3> 从其它项目中导入材料对话框

材料列表：显示包含在现有*.MGB文件中的材料特性数据。

选择列表

在材料列表中选择要输入的材料特性数据并移动到选择列表中。

注
如果选中*.MGB文件，所有包含在现有*.MGB文件中的材料特性数据均被移动到选择列表中。

编号类型

指定材料特性编号的输入方式。

原号码：输入数据并保持同样的材料特性编号。如果材料号已经存在于当前模型中，将被导入的材料号替换。

新号码：指定输入的材料特性数据的起始编号。

对已经输入的材料重新编号

在材料对话框里选择需要重新编号的材料特性号，单击 [image] 修改相关的数据。

<图4> 重新编材料号对话框

开始号：设定需要修改编号材料的起始号码。

增幅：输入材料特性编号的增量。

修改单元材料号：修改单元材料号。选择该选项，将修改先前定义的单元材料特性号。否则，重新编号材料的旧编号将出于未定义状态，用户新定义的材料号未分配给任何单元。


02_时间依存性材料(徐变/收缩)函数

Home > midas Gen 2017 > 05_特性 > 02_时间依存性材料 > 01_函数

时间依存性材料(徐变/温度收缩)函数

  • 功 能

由用户定义混凝土材料随时间的变化特性(徐变和收缩)函数。主要使用于考虑混凝土徐变和收缩的水化热分析和施工阶段分析。

  • 命 令

从主菜单中选择模型 > 材料和截面特性 > 时间依存性材料(徐变/收缩)函数...

从树形菜单的菜单表单中选择几何模型 > 特性值 > 时间依存性材料函数

  • 输 入

<图1> 时间依存性材料函数对话框

在图1对话框中点击 [image] ，输入下列数据。

如果要查看或编辑已定义的函数时，选择相应函数后点击 [image] ；删除已定义的函数时，选择相应函数后点击 [image] ；复制已定义的函数时，选择相应函数后点击 [image] 。

徐变对话框:定义混凝土随时间变化的徐变特性。

<图2> 添加/编辑/显示时间依存材料函数对话框（徐变）

函数名称:输入徐变函数名称。该函数名称将在添加/编辑时间依存材料(徐变和收缩)对话框中用户定义中被使用。

徐变数据形式:选择徐变数据形式。

徐变度：在不变的单位应力作用下的应变(不包含瞬时弹性应变)。

柔度函数：在不变的单位应力作用下的应变(包含瞬时弹性应变)。柔度系数 = 瞬时弹性应变 + 徐变度。

徐变系数：徐变与弹性应变的比 [image] 。

弹性模量:输入混凝土的弹性模量。

:

将经常使用的徐变系数存储为文件，当需要时导入使用。文件(fn.TDM)格式如下。

* Unit, cm, kgf | 选择使用的单位体系(选择项目)
*DATA | 以天、数值的数据形式输入(必填项目)
20, 0.9934 |
40, 1.2182 | -
60, 1.3705 | -
80, 1.4883 | -
100, 1.5854 | -
120, 1.6683 | -
140, 1.7408 | -
160, 1.8054 | -
180, 1.8636 | -
200, 1.9166 | -
220, 1.9653 | -
240, 2.0103 | -
260, 2.0252 | -

增减系数：输入增减系数。

图形选项：用于需要看对数刻度的图形时。

说明：输入对函数的说明。

收缩应变对话框:定义混凝土随时间变化的收缩应变。

<图3> 添加/编辑/显示时间依存材料函数对话框（收缩应变）

函数名称:输入徐变函数名称。该函数名称将在添加/编辑时间依存材料(徐变和收缩)对话框中用户定义中被使用。

将经常使用的收缩应变函数存储为文件，当需要时导入使用。文件(fn.TDM)格式与徐变的相同。

增减系数：输入增减系数。

图形选项：用于需要看对数刻度的图形时。


03_时间依存材料(徐变/收缩)

Home > midas Gen 2017 > 05_特性 > 02_时间依存性材料 > 02_徐变/收缩

时间依存性材料(徐变/温度收缩)

  • 功 能

定义混凝土材料的抗压强度和弹性模量随时间的变化特性(徐变和收缩)。

混凝土的材龄是从混凝土浇筑时开始计算的。因而各个单元在各施工阶段都有其抗压强度和弹性模量。

在施工阶段联合截面中，由于各部分混凝土材龄的不同，因而可以考虑各部分抗压强度和弹性模量的差异。

为了反映混凝土抗压强度和弹性模量的变化，在施工阶段分析控制中，应勾选“考虑抗压强度的变化”选项。

  • 命 令

从主菜单中选择模型 > 材料和截面特性 > 时间依存性材料(徐变/收缩)函数...

从树形菜单的菜单表单中选择几何模型 > 特性值 > 时间依存性材料函数

从树形菜单的特性值工具条中点击 [image] 时间依存材料(徐变/收缩)

  • 输 入

<图1> 时间依存材料(徐变/收缩)对话框

当需要定义时间依存材料数据时，点击 [image] ，输入下列数据。

如果要查看或编辑已定义的函数时，选择相应名称后点击 [image] ；删除已定义的数据时，选择相应名称后点击 [image] ；复制已定义的数据时，选择相应名称后点击 [image] 。

名称:

输入时间依存材料名称，该名称将用于和一般材料之间的连接。参见"时间依存材料的连接"。

设计标准:

选择相应国家的标准或选择用户定义。

选择China(JTG D62-2004)时

<图2> 添加/编辑时间依存材料(徐变/收缩)对话框

China(JTG D62-2004)

28天龄期混凝土立方体抗压强度标准值，即标号强度：28天抗压强度，该强度用于计算徐变系数,并按规范的强度与弹性模量的换算公式换算为徐变计算中使用的弹性模量。要注意的是计算弹性变形使用的弹性模量采用时间依存材料(抗压强度)命令中的弹性模量(输入强度发展函数时，按规范的要求由当时强度进行换算)，如果没有定义时间依存材料(抗压强度)，则按定义材料时的弹性模量计算弹性变形。

环境年平均相对湿度(40-99) : 输入相对湿度。

构件理论厚度 : 构件理论厚度，输入一个值后可在修改单元依存材料特性值中选择自动计算。

水泥种类系数(Bsc) : 不同水泥的系数

收缩开始时的混凝土龄期 : 浇筑混凝土后开始收缩时间。

: 以图标形式显示时间依存材料特性。

选择中国规范时

<图3> 添加/编辑时间依存材料(徐变/收缩)对话框

中国规范

中国规范中徐变和收缩的计算采用中国交通部标准，公路钢筋混凝土及预应力混凝土桥涵设计规范 JTJ 023-85 附录四中的规定。

28天材龄抗压强度：输入混凝土28天材龄的立方体抗压强度，即混凝土标号。

相对湿度：根据环境条件输入相对湿度。用于决定环境影响系数和标准厚度影响系数，计算流塑系数。

水中养生

相对湿度(40-90)

构件的理论厚度：输入构件的理论厚度( h=λ* 2A/u )。λ由相对湿度决定。

开始收缩时的混凝土材龄：浇筑后，混凝土开始发生收缩的时间。

点击 [image] ，可以显示出由程序按规范计算得到的徐变系数曲线和收缩应变曲线。

注:
中国桥梁规范中是依靠图表计算的收缩和徐变，MIDAS软件内部将规范中的图表分段模拟成公式后计算徐变和收缩。

用户使用时请将曲线和规范中的曲线对比验证后再使用。用户可以自行定义徐变和收缩曲线，也可以参照国外的一些规范中的规定。

可以在"修改单元依存材料特性"对话框中修改构件的理论厚度，也可以由程序自动计算各构件的理论厚度。自动计算功能在计算使用相同材料但截面大小不同的构件的理论厚度时特别有效。

选择CEB-FIP（1990）规范时

<图4> 添加/编辑时间依存材料(徐变/收缩)对话框

CEB-FIP（1990）

CEB-FIP是指欧洲混凝土委员会与国际预应力混凝土协会制定的标准。

混凝土抗压强度标准值（28天（fck））：输入混凝土28天材龄的立方体抗压强度，即混凝土标号。

外部环境的相对湿度(40-99)：根据环境条件输入相对湿度。

构件的理论厚度：输入构件的理论厚度( h=2*A/u )。

水泥类型：选择水泥类型。

开始收缩时的混凝土材龄：浇筑后，混凝土开始发生收缩的时间。

点击 [image] ，可以显示出由程序按规范计算得到的徐变系数曲线和收缩应变曲线。

选择CEB-FIP（1978）规范时

<图5> 添加/编辑时间依存材料(徐变/收缩)对话框

CEB-FIP（1990）

CEB-FIP是指欧洲混凝土委员会与国际预应力混凝土协会制定的标准。

混凝土抗压强度标准值（28天（fck））：输入混凝土28天材龄的立方体抗压强度，即混凝土标号。

外部环境的相对湿度(40，70，90，100)：根据环境条件输入相对湿度。

构件的理论厚度：输入构件的理论厚度( h=2*A/u )。

水泥类型：选择水泥类型。

开始收缩时的混凝土材龄：浇筑后，混凝土开始发生收缩的时间。

点击 [image] ，可以显示出由程序按规范计算得到的徐变系数曲线和收缩应变曲线。

选择ACI规范时

<图6> 添加/编辑时间依存材料(徐变/收缩)对话框

ACI

ACI是指美国混凝土协会的标准。

28天材龄抗压强度：输入混凝土28天材龄的立方体抗压强度，即混凝土标号。

相对湿度(40-99)：根据环境条件输入相对湿度。

体积-表面积比：输入构件的体积和表面积比。

开始收缩时的混凝土材龄：浇筑后，混凝土开始发生收缩的时间。

养生方法：早期养生方法。

湿润养生

蒸汽养生

材料特性值极限值：材料极限徐变系数和极限收缩应变。可以按规范输入一些参数由程序自动计算，也可由用户输入。

当在计算方法中选择规范定义时

坍落度：输入混凝土的坍落度。

细骨料含量

空隙率

水泥含量

当在计算方法中选择用户定义时

材料极限徐变系数(1.3～4.15)

材料极限收缩应变(415～1070)

选择PCA规范时

<图7> 添加/编辑时间依存材料(徐变/收缩)对话框

PCA

PCA是指美国波特兰水泥协会的标准。

28天材龄抗压强度：输入混凝土28天材龄的立方体抗压强度，即混凝土标号。

极限收缩应变(500～800)

极限徐变(3～5)

相对湿度(40-99)：根据环境条件输入相对湿度。

体积-表面积比：输入构件的体积和表面积比。

柱横截面配筋率

钢筋的弹性模量

选择ACI+PCA规范时

<图8> 添加/编辑时间依存材料(徐变/收缩)对话框

ACI+PCA

PCA是指美国波特兰水泥协会的标准。

28天材龄抗压强度：输入混凝土28天材龄的立方体抗压强度，即混凝土标号。

相对湿度(40-99)：根据环境条件输入相对湿度。

体积-表面积比：输入构件的体积和表面积比。

徐变

材料极限徐变

体积-表面积比：选择体积-表面积比的计算方法。

材龄系数(t:加载材龄)：选择材龄系数的计算方法。

收缩

材料极限收缩应变

体积-表面积比：选择体积-表面积比的计算方法。

收缩函数：选择计算收缩应变的方法。

钢筋混凝土效应-PCA

柱横截面配筋率

钢筋的弹性模量

选择日本规范时

<图9> 添加/编辑时间依存材料(徐变/收缩)对话框

日本规范

日本规范是指日本水泥协会的标准。

28天材龄抗压强度：输入混凝土28天材龄的立方体抗压强度，即混凝土标号。

E的计算方法：选择相应规范。

相对湿度

水中养生

相对湿度(40-90)：根据环境条件输入相对湿度。

构件的理论厚度：输入构件的理论厚度( h=2*A/u )。

水泥类型：选择水泥类型。

开始收缩时的混凝土材龄：浇筑后，混凝土开始发生收缩的时间。

点击 [image] ，可以显示出由程序按规范计算得到的徐变系数曲线和收缩应变曲线。

选择韩国规范时

<图10> 添加/编辑时间依存材料(徐变/收缩)对话框

韩国规范

混凝土抗压强度标准值（28天（fck））：输入混凝土28天材龄的立方体抗压强度，即混凝土标号。

外部环境的相对湿度(40-99)：根据环境条件输入相对湿度。

构件的理论厚度：输入构件的理论厚度( h=2*A/u )。

水泥类型：选择水泥类型。

开始收缩时的混凝土材龄：浇筑后，混凝土开始发生收缩的时间。

点击 [image] ，可以显示出由程序按规范计算得到的徐变系数曲线和收缩应变曲线。

选择INDIA(IRC:18-2000)时

<图11> 添加/编辑时间依存材料(徐变/收缩)对话框

INDIA(IRC:18-2000)

混凝土28天抗压强度：输入混凝土28天材龄的立方体抗压强度，即混凝土标号。

相对湿度(40-99)：根据环境条件输入相对湿度。

构件符号：输入构件的理论厚度( h=2*Ac/u )。

开始收缩时的混凝土材龄：浇筑后，混凝土开始发生收缩的时间。

点击 [image] ，可以显示出由程序按规范计算得到的徐变系数曲线和收缩应变曲线。

选择欧洲时

<图12> 添加/编辑时间依存材料(徐变/收缩)对话框

欧洲

混凝土28天抗压强度（fck）：输入混凝土28天材龄的立方体抗压强度，即混凝土标号。

相对湿度(40-99)：根据环境条件输入相对湿度。

构件理论厚度：输入构件的理论厚度( h=2*Ac/u )。

水泥类型：选择水泥类型。

规范类型：选择规范类型。

开始收缩时的混凝土材龄：浇筑后，混凝土开始发生收缩的时间。

点击 [image] ，可以显示出由程序按规范计算得到的徐变系数曲线和收缩应变曲线。

当选择AS 3600-2009

<图13> 添加/编辑时间依存材料(徐变/收缩)对话框

AS 3600-2009

28天龄期时混凝土抗压强度（fck）：输入混凝土28天材龄的立方体抗压强度，即混凝土标号。

暴露环境：干燥、内陆、温带内陆、热带或近海。

临界厚度：输入构件的理论厚度( h=2*Ag/u )。

注1：如果各单元的理论厚度不一致，则可以在“修改单元依存性材料特性”中进行修改。

注2：施工阶段联合截面中各部分的临界厚度，应在施工阶段联合截面中输入。

干缩应变：选择干缩应变值。

悉尼、布里斯班：800 x 10e-6;

墨尔本：900 x 10e-6;

其它：10000 x 10e-6;

混凝土开始收缩时的龄期：浇筑后，混凝土开始发生收缩的时间。

点击 [image] ，可以显示出由程序按规范计算得到的徐变系数曲线和收缩应变曲线。

当选择AS/RTA 5100.5-2011时

<图14> 添加/编辑时间依存材料(徐变/收缩)对话框

AS/RTA 5100.5-2011

28天龄期时混凝土抗压强度（fck）：输入混凝土28天材龄的立方体抗压强度，即混凝土标号。

暴露环境：干燥、内陆、温带内陆、热带或近海。

临界厚度：输入构件的理论厚度( h=2*Ag/u )。

注1：如果各单元的理论厚度不一致，则可以在“修改单元依存性材料特性”中进行修改。

注2：施工阶段联合截面中各部分的临界厚度，应在施工阶段联合截面中输入。

干缩应变：选择干缩应变值。

悉尼、布里斯班：800 x 10e-6;

墨尔本：900 x 10e-6;

其它：10000 x 10e-6;

混凝土开始收缩时的龄期：浇筑后，混凝土开始发生收缩的时间。

点击 [image] ，可以显示出由程序按规范计算得到的徐变系数曲线和收缩应变曲线。

当选择用户定义时

使用由用户定义的时间依存材料(徐变/收缩)函数。

<图15> 添加/编辑时间依存材料(徐变/收缩)对话框

用户定义

徐变函数

名称：选择用户定义的徐变函数。当需要添加和修改徐变函数时，可以点击右面的 [image] ，在"时间依存材料(徐变/收缩)函数"对话框中进行添加和修改。

加载时材龄：输入具有相应材料依存特性的构件被加载时的初始材龄。

:
考虑到构件被加载时的初始材龄后，将用户定义的徐变函数纪录在目录中。

:
编辑目录中的徐变函数的加载时的材龄。

:
删除目录中的徐变函数的加载时的材龄。

收缩应变函数
选择用户定义的收缩应变函数。当需要添加和修改收缩应变函数时，可以点击右面的 [image] ，在"时间依存材料(徐变/收缩)函数"对话框中进行添加和修改。


04_时间依存性材料(抗压强度)

Home > midas Gen 2017 > 05_特性 > 02_时间依存性材料 > 03_抗压强度

时间依存性材料(抗压强度)

  • 功 能

定义混凝土材料的抗压强度或弹性模量随时间变化的曲线。

  • 命 令

从主菜单中选择模型 > 材料和截面特性 > 时间依存性材料(抗压强度)...

从树形菜单的菜单表单中选择几何模型 > 特性值 > 时间依存性材料(抗压强度)

  • 输 入

<图1> 时间依存材料(抗压强度)对话框

点击 [image] ，可以定义混凝土弹性模量(抗压强度)随时间的变化。点击 [image] 可以编辑已定义的函数。点击 [image] 可以删除已定义的函数。复制已定义的数据时，选择相应名称后点击 [image] 。

<图2> 添加/编辑时间依存材料(抗压强度)对话框

名称:输入函数名称。

类型:选择是按有关规范计算抗压强度的变化还是使用用户定义的方式。

当在类型中选择了设计规范时

强度发展:在类型中选择设计规范，输入相应参数，定义抗压强度发展曲线，通过抗压强度计算弹性模量。

规范:选择有关规范。

选择了ACI时

混凝土28天抗压强度(S28)

混凝土抗压强度系数(a,b)：输入ACI抗压强度发展公式中的系数值。

选择了CEB-FIP时

混凝土平均抗压强度

水泥类型(s)：选择水泥种类。冒号后面的数字为a值。

RS：早强高强度水泥。

N, R：一般水泥或早强水泥。

SL：缓凝水泥。

选择了Ohzagi时

使用Ohzagi提议的公式定义混凝土强度发展。

混凝土28天抗压强度(S28)

水泥类型(a、b、c)：选择水泥种类。

RS：早强高强度水泥。

N, R：一般水泥或早强水泥。

SL：缓凝水泥。

Fly-ash：粉煤灰水泥。

选择了韩国标准时

混凝土91天抗压强度(S91)

混凝土抗压强度系数(a,b)：根据水泥类型决定a和b值。

水泥种类 | a | b
早强水泥 | 2.9 | 0.97
一般水泥 | 4.5 | 0.95
缓凝水泥 | 6.2 | 0.93

选择了Japan（Hydration）时

混凝土28天抗压强度(fck)

混凝土抗压强度系数(a、b、d)

水泥类型：选择水泥种类。

Normal portland cement

Moderate portland cement

High-early-strength Normal portland cement

抗拉强度

弹性模量

选择了Japan（Elastic）时

28天弹性模量(E28）

水泥类型：选择水泥种类。

普通类型

早强类型

选择了INDIA（IRC:18-2000）时

28天弹性模量(E28）

选择了欧洲时

混凝土28天标准抗压强度

水泥类型：选择水泥种类。

Class R：0.20

Class N：0.25

Class S：0.38

选择了CEB-FIP(1978)时

长期抗压强度(fck）

选择了AS3600-2009时

混凝土28天标准抗压强度

选择了AS/RTA 5100.5-2011时

混凝土28天标准抗压强度

当在类型中选择了用户定义时

输入时间和随时间变化的弹性模量。

。

系数:输入弹性模量的增减系数。

图形选项:决定图形的X轴和Y轴是否使用对数刻度。


06_修改单元依存材料特性

Home > midas Gen 2017 > 05_特性 > 02_时间依存性材料 > 04_修改特性

修改单元依存材料特性

  • 功 能

修改各单元的理论厚度值或者体积与面积比。当不同的单元使用了同一种时间依存材料，或使用了变截面单元时，需要分别计算各截面的理论厚度时，此功能特别方便。

  • 命 令

从主菜单中选择模型 > 材料和截面特性 > 修改单元依存材料特性

从树形菜单的菜单表单中选择几何模型 > 特性值 > 修改单元依存材料特性

在特性值工具条中点击 [image] 修改单元依存材料特性

  • 输 入

节点起始号

该命令不适用。

单元起始号

该命令不适用。

选项:

添加/替换：修改构件理论厚度。

删除：删除已经赋予给构件的理论厚度。

单元依存材料特性

当选择构件理论厚度时

输入：由用户在下面输入框中直接输入理论厚度值。

自动计算：由程序自动计算各构件的理论厚度。

规范：可供选择的国家规范有中国规范、CEB-FIP、日本规范、韩国规范。其它规范因为计算徐变和收缩时没有使用构件理论厚度，所以在此没有列出。

注:
在此修改理论厚度之后，在"时间依存材料(徐变/收缩)"中输入的理论厚度值将被替换。在此按中国桥梁规范计算的理论厚度为h0值。程序内部将根据前面定义的相对湿度自动计算λ值后计算真正的理论厚度值h。

当选择体积与表面积比时

输入：由用户在下面输入框中直接输入。

自动计算：目前不支持此功能。

v/s：用户输入体积与表面积比的数值。

规范：可供选择的国家规范有ACI、PCA、组合ACI与PCA。其它规范因为计算徐变和收缩时没有使用体积与表面积比，所以在此没有列出。


05_时间依存材料连接

Home > midas Gen 2017 > 05_特性 > 02_时间依存性材料 > 05_材料连接

时间依存性材料连接

  • 功 能

将在时间依存材料(徐变/收缩)中定义的材料特性赋予已定义的一般材料。该功能主要适用于水化热分析和施工阶段分析。

  • 命 令

从主菜单中选择模型 > 材料和截面特性 > 时间依存性材料连接

从树形菜单的菜单表单中选择几何模型 > 特性值 > 时间依存性连接

  • 输 入

时间依存材料类型:

选择已定义的时间依存材料特性函数名称。

选择指定的材料:

选择已定义的材料赋予时间依存材料特性。将选择的材料移动到右侧列表框内。

操作:

在时间依存材料类型中选择徐变和收缩、抗压强度发展函数，然后进行下列操作。

：

在选择的材料列表框中选择相应的材料，点击此键可以进行添加和编辑连接的内容。

：

在对话框下部已定义的连接列表框中选择相应的连接，点击此键，可以删除该项连接。


07_塑性材料

Home > midas Gen 2017 > 05_特性 > 03_塑性 > 01_塑性材料

塑性材料

  • 功 能

为材料非线性分析定义塑性材料模型。

塑性材料模型：

    • Tresca 和 Von Mises:

这两种模型适用于具有塑性不可压缩性的可锻金属材料。

    • Mohr-Coulomb 和 Drucker-Prager:

这两种模型适用于脆性材料，例如混凝土、岩石、土壤等，这些材料的特性是具有体积塑性应变。

    • 砌体

  • 命 令

从主菜单选择模型 > 材料和截面特性 > 塑性材料...

从树形菜单的菜单表单中选择几何模型 > 特性值 > 塑性材料...

  • 输 入

<图1> 塑性材料对话框

<图2> 添加/编辑塑性材料数据对话框

新建和增加材料时

在塑性材料对话框中单击 [image] ，输入下列数据：

名称: 塑性材料的名称。

模型: 塑性材料的模型:

1.Tresca 2.Von Mises 3.Mohr-Coulomb 4.Drucker-Prager 5.砌体

塑性数据

如果选择 Tresca 或者 Von Mises 模型，则输入初始单轴屈服应力。

如果 Mohr-Coulomb 或者 Drucker-Prager 模型，则输入初始内聚力和初始摩擦角。

初始内聚力

注：当输入0时，则屈服应力完全由剪应力决定。

初始摩擦角

硬化:当材料屈服时，硬化指随着塑性应变的变化，屈服面的变化。硬化分为以下三种类型：

  1. Isotropic: 等向硬化

  2. Kinematic: 随动硬化

  3. 组合: 以上两种硬化方式的组合

滞回系数：代表硬化的程度。

'1' 代表等向硬化
'0' 代表随动硬化
'0～1' 代表组合硬化

注：总的塑性增量可以采用等向硬化和随动硬化模型表达为下面公式：

M    代表滞回系数，取值在0和1之间。

硬化系数:材料屈服后的切线刚度。

如果选择砌体时：

<图3> 砌体

砖材料

<图4> 砖材料

竖向接缝材料

<图5> 竖向接缝材料

水平接缝材料

<图6> 水平接缝材料

砌筑方式

<图7> 砌筑方式


08_截面

Home > midas Gen 2017 > 05_特性 > 04_截面 > 01_截面特性值

截 面

  • 功 能

输入线单元(桁架、只受拉、只受压、索、间隙、钩、梁单元)的截面数据。

  • 命 令

从主菜单中选择模型 > 材料和截面特性 > 截面...

从树形菜单的菜单表单中选择几何模型 > 特性值 > 截面...

在图标菜单中单击 [image] 截面

  • 输 入

新建或增加截面时

在材料和截面对话框中单击 [image] ，输入下列数据：

<图1> 材料和截面对话框

<图2> 截面(数据库/用户)对话框

数据库/用户对话框

在对话框中用下面两种方法输入截面数据：

1. 从某个国家的标准截面数据库中选择截面。

2. 输入标准截面形状的主要尺寸。

截面号：输入截面编号(自动设定为最后的截面编号+1)。

名称：截面名称(如未指定则取默认的截面名称)。

截面形状列表：在列表中选择截面形状。

用户：输入标准截面形状的主要尺寸。

H, B1, ... ：参照对话框中的图形输入。

数据库：选择相应国家的标准截面数据库，共计21个数据库，例如：

GB-YB：中国国家标准和冶金部标准截面。

GB-YB(05)：中国国家标准和冶金部标准截面，2005。

AISC2K(US):美国钢结构协会，2000，(US单位：lb,in)

AISC2K(SI):美国钢结构协会，2000，(SI单位：kN,m)

AISC：美国钢结构协会。

CISC02(US)：加拿大钢结构协会，2002，(US单位：lb,in)

CISC02(SI)：加拿大钢结构协会，2002，(SI单位：kN,m)

BS：英国标准。

BS 4-93: 英国标准 BS 4-1:1993

DIN：德国工业标准。

UNI:意大利国家标准。

GOST:俄罗斯国家标准。

STO-SCHM:俄罗斯国家标准

JIS2K：日本工业标准，2000

JIS：日本工业标准。

KS：韩国工业标准。

PacificSI:本特利太平洋标准，（SI单位：kN,m）

IS:印度国家标准

IS808:印度国家标准

IS1161:印度国家标准

CNS91:台湾标准

截面：直接输入数据库中的截面名称或在截面列表中选择数据。直接输入截面名称时，必须与数据库中的截面名称一致。

注:
定义双角钢或双槽钢截面时，在列表中指定截面形状并选择用户自定义。然后从读取单一角钢(或槽钢)的数据?中选择单角钢(或槽钢)的数据及截面名称，或直接输入截面的主要尺寸。

考虑剪切变形：

选择是否考虑剪切变形，分析时该选项起作用，但对有效剪切面积无影响。

考虑翘曲效果（7自由度）：

选择是否考虑单元的翘曲自由度。该自由度主要用于结构的扭转验算。

偏心：指定截面线单元的位置，即在模型窗口中显示的线单元是以截面哪个位置为基准生成的。使用 [image] 消隐功能确认生成的截面形状。

单击 [image] 显示截面特性数据。截面特性数据可由用户输入的尺寸计算得到，或者从数据库中得到。

<图3> 截面(数值)对话框

数值对话框

用对话框直接输入截面数据。可用两种方法。

1. 输入标准截面形状的主要尺寸，通过修改截面尺寸自动计算截面特性。

2. 直接输入所有的截面特性数据。

截面号：输入截面编号(自动设定为最后的截面编号+1)。

名称：截面名称。

截面形状列表：选定要使用的截面形状。

焊接组合截面：选择焊接组合截面。

注:
该数据使用于钢构件的强度验算及材料表的汇总。

尺寸:

H, B1, ... ：参见对话框中图形输入数据。

即使没有指定截面尺寸，只要有刚度数据即可对结构进行分析。

截面特性值

单击 [image] ，使用输入的截面尺寸，计算和显示截面刚度。

面积：横截面面积。

Asy：单元局部坐标系y轴方向的有效抗剪面积(Effective Shear Area)。

Asz：单元局部坐标系z轴方向的有效抗剪面积(Effective Shear Area)。

Ixx：对单元局部坐标系x轴的扭转惯性距(Torsional Resistance)。

Iyy：对单元局部坐标系y轴的惯性距(Moment of Inertia)。

Izz：对单元局部坐标系z轴的惯性距(Moment of Inertia)。

Cyp：沿单元局部坐标系+y轴方向，单元截面中和轴到边缘纤维的距离。

Cym：沿单元局部坐标系-y轴方向，单元截面中和轴到边缘纤维的距离。

Czp：沿单元局部坐标系+z轴方向，单元截面中和轴到边缘纤维的距离。

Czm：沿单元局部坐标系-z轴方向，单元截面中和轴到边缘纤维的距离。

Qyb：沿单元局部坐标系z轴方向的剪切系数。

Qzb：沿单元局部坐标系y轴方向的剪切系数。

Peri:O ：截面外轮廓周长。

Peri:I ：箱型或管型截面的内轮廓周长。

注:
象H型钢那样没有内部轮廓的截面的Peri:1值为'0'。

Cent:y ：从截面最左侧到形心轴的距离。

Cent:z ：从截面最下端到形心轴的距离。

y1、z1：截面左上方最边缘点的y、z坐标。

y2、z2：截面右上方最边缘点的y、z坐标。

y3、z3：截面右下方最边缘点的y、z坐标。

y4、z4：截面左下方最边缘点的y、z坐标。

除面积和周长外，以上输入的所有截面特性数据仅使用于梁单元。

不指定有效抗剪面积时，程序将忽略剪切变形。Cyp, Cym, Czp和Czm仅用于计算弯曲应力。Qyb和Qzb用于计算剪应力。周长用于计算着色面积。

注 1
用户可以不输入截面尺寸(H, B1等)，直接输入刚度数据定义截面。

注 2
单元的刚性数据。

截面面积（Area:Cross Section Area）

工程中使用截面面积(Cross Section Area)来计算构件轴向刚度(Axial Stiffness)和截面上产生的轴向应力。

在MIDAS程序中计算截面面积时可以采用内部计算的方法和由数据库调入的方式，这两种方式均不能考虑节点部位由于构件之间的连接而造成的截面损失(如螺栓孔、铆钉孔）。所以在实际工程中，需要计算由于截面的损失对结构承载力的影响时，应该使用用户直接输入特性值的方式。

<图4> 截面面积计算例题

有效剪切面积(Asy、Asz : Effective Shear Area)

当截面沿单元坐标系的y轴或z轴方向上承受剪切荷载(Shear Force)时，可以利用有效剪切面积(Effective Shear Area)计算截面的抗剪刚度(Shear Stiffness)。如果没有输入有效剪切面积，意味着忽略该方向上的剪切变形。

如果采用内部计算的方法和由数据库调入的方式，MIDAS软件将自动计算截面的抗剪刚度。其计算方法见图2。

Asy ：沿单元坐标系y轴方向上的有效剪切面积。

Asz ：沿单元坐标系z轴方向上的有效剪切面积。

<图5> 各截面形状的有效剪切面积

抗扭刚度(Ixx: Torsional Resistance)

抗扭刚度就是抵抗扭矩的刚度，可用<公式1>表示。

<公式1>

Ixx ：抗扭刚度(Torsional Resistance)。

T ：扭矩(Torsional Moment Torque)。

θ ：扭转角度(Angle of Twist)。

由上式所示，抗扭刚度就是抵抗扭矩的刚度。它不同于为了计算扭矩作用下的截面剪应力所使用的极惯性矩(Polar Moment of Inertia)。但是当截面形状是圆形或厚板圆环时，其抗扭刚度与极惯性矩相同。

开口型截面(Open Section)和封闭型截面(Close Section)形态的抗扭刚度的计算方法不同；厚板截面和薄板截面的抗扭刚度计算方法也不相同。不存在适合于所有截面类型的计算抗扭刚度的一般公式。

计算开口型截面的抗扭刚度时，首先把截面划分成多个矩形截面，利用<公式2>计算每一个矩形截面的抗扭刚度，把每个矩形截面的抗扭刚度值取代数和就可以得到整个截面的抗扭刚度的近似值。

<公式2>

且 a≥b。

ixx ：划分后的小矩形截面的抗扭刚度。

2a ：划分后的小矩形截面的长边。

2b ：划分后的小矩形截面的短边。

对薄壁封闭型管(Tube)截面的抗扭刚度可按<公式3>计算(参照图3)。

<公式3>

A ：封闭管的截面面积。

dS ：截面任意位置上中和轴的微小长度

t ：截面任意位置的厚度。

象桥梁箱型截面那样的封闭型厚壁管型(Tube)截面的抗扭刚度可以利用抗扭刚度计算<公式1>和<公式3>组合计算。

<图6> 薄壁封闭型管截面的抗扭刚度

一些标准截面的抗扭刚度见<图7>～<图10>。

<图7> 实体截面的抗扭刚度

<图8> 薄壁封闭型截面的抗扭

<图9> 开口型厚壁截面的抗扭刚度

<图10> 开口型薄壁截面的抗扭刚度

当利用两个以上的型钢组合成一个截面时，在一个截面上可能同时存在封闭型和开口型，这种组合截面的抗扭刚度是各自抗扭刚度的代数和。

例如，由两个H型钢截面(Double H-Section)组合成<图11(a)>所示的截面，其中央形成封闭型而外部翼缘为开口型截面。

<a> 开口型和封闭型截面的组合截面的抗扭刚度

<b> 两个或两个以上封闭型截面的组合截面的抗扭刚度

<图11> 由两个或两个以上的型钢组合的截面的抗扭刚度

封闭型截面(阴影部分)的抗扭刚度

<公式4>

开口型截面(突出的翼缘部分)的抗扭刚度

<公式5>

全体截面的抗扭刚度

<公式6>

一个H型钢和2个平板(Flat Bar)组合形成<图11(b)>所示的截面形状时，截面的抗扭刚度可按以下方法计算。

当图中封闭型截面以外突出翼缘板部分的抗扭刚度比组合截面整体的抗扭刚度相比小得可以忽略不计时，可以只取图中H形型钢的翼缘和两平板(Flat Bar)组合成的外封闭截面(阴影部分)的抗扭刚度，使用<公式7>计算其大小。

<公式7>

当图中封闭型截面以外突出翼缘板部分的抗扭刚度比组合截面整体的抗扭刚度相比不能忽略时，可以计算突出翼缘板部分的抗扭刚度后与封闭型截面部分的抗扭刚度相加。

截面惯性矩(Iyy、Izz: Moment of Inertia)

利用截面惯性矩(Moment of Inertia)可以计算弯矩(Bending Moment)作用下的截面的抗弯刚度(Flexual Stiffness)。对截面的中和轴的截面惯性矩的大小可按下式计算。

对单元坐标系y轴的截面惯性矩

<公式1>

对单元坐标系z轴的截面惯性矩

<公式2>

<图12> 由两个或两个以上组成的截面惯性矩

截面惯性积(Iyz: Product Moment of Inertia)

利用截面惯性积(Product Moment of Inertia)计算非对称截面的应力特征。惯性积的大小可按下式计算。

<公式1>

如果截面形状对称于单元坐标系的y或z轴(例如H型、管型、槽型及T形截面)，则惯性积Iyz=0；如果截面形状不对称于单元坐标系的y或z轴(如Angle形截面)，则惯性积Iyz≠0。这时应该利用截面惯性积计算截面应力。

角型截面的截面惯性积的计算方法见<图13>。

<图13> 角型截面的惯性积

<图14> 非对称截面的弯矩应力图

所谓中和轴(Neutral Axis)就是在弯矩作用下截面上应力值为零点的连线，如<图14>所示。其中n轴为中和轴，m轴为垂直与n轴的轴。

因为弯矩作用下中和轴的应力为零，所以中和轴的方向可按下式计算。

<公式2>

弯矩作用下截面应力的计算公式可按下式计算。

<公式3>

如果是H型截面，由于Iyz=0，所以截面应力的计算公式可按下式计算。

<公式4>

在此，

Iyy：对单元坐标系y轴的截面惯性距。

Izz：对单元坐标系z轴的截面惯性距。

Iyz：截面惯性积。

y：从截面的中和轴沿着y轴方向到计算应力点的距离。

z：从截面的中和轴沿着z轴方向到计算应力点的距离。

My：绕单元坐标系的y轴作用的弯矩。

Mz：绕单元坐标系的z轴作用的弯矩。

可按下式计算沿单元坐标系y轴及z轴方向上作用的剪力产生的应力值。

<公式5>

<公式6>

截面面积矩(Qy、Qz: First Moment of Area)

可以利用截面面积矩(First Moment of Area)计算截面上任意点的剪切应力值。其大小可按下式计算。

<公式1>

<公式2>

如果截面对称于单元坐标系的y轴或z轴，则截面上任意点的剪切应力可按下式计算.

<公式3>

<公式4>

Vy: 沿单元坐标系的y轴方向作用的剪切力。

Vz: 沿单元坐标系的z轴方向作用的剪切力。

Iyy: 对单元坐标系y轴的截面惯性距。

Izz: 对单元坐标系z轴的截面惯性距。

by: 截面的剪应力计算点上沿垂直于单元坐标系的z轴方向的截面厚度。

bz: 截面的剪应力计算点上沿垂直于单元坐标系的y轴方向的截面厚度。

剪切系数（Qyb, Qzb : Shear Factor of Shear Stress due to Bending）

所谓剪切系数就是在剪应力的计算点上截面的面积距与该点的截面厚度之比，用于计算截面的的剪切应力。

<公式1>

，

，

<公式2>

<图15> 截面的剪应力计算图

组合截面的刚度

MIDAS/Gen作钢材-混凝土组合结构(SRC)受力分析时，假定钢材和混凝土紧密地连接在一起，并使用等效截面特性值(Equivalent Sectional Properties)进行计算和分析。

计算等效换算截面特性值时，钢材的弹性系数(Es)和混凝土的弹性系数(Ec)是利用型钢混凝土标准(SSRC79(Structural Stability Research Council，1979，USA))计算的。根据Eurocode 4规范，Ec取降低20%后的值。

等效换算截面面积

等效换算有效剪切截面面积

等效换算截面惯性矩

Ast1: 钢骨截面。

Acon: 混凝土截面。

Asst1: 钢骨有效剪切面积。

Ascon: 混凝土的有效剪切面积。

Ist1: 钢骨截面惯性距。

Icon: 混凝土截面惯性距。

REN: 钢骨与混凝土弹性系数之比(Es/Ec)。

<图16> 截面(组合截面)对话框

组合截面对话框

在对话框中输入钢-砼组合截面的截面特性。

截面号：截面编号(自动设定为最后的截面编号+1)。

名称：输入截面名称。

形状：选定要使用的截面形状。

混凝土数据：输入钢-砼组合截面中砼截面的外形尺寸。

钢材数据：输入钢骨截面数据。

用户：由用户输入标准截面形状的主要尺寸。

H, B1, ... ：参照对话框中图形尺寸输入。

数据库：选择相应国家的标准截面数据库。共包含14个数据库，例如：

GB-YB：中国国家标准和冶金部标准截面。

AISC：美国钢结构协会。

BS(S)：英国标准。

DIN(S)：德国工业标准。

JIS：日本工业标准。

KS：韩国工业标准。

截面：直接输入数据库中的截面名称或在截面列表中选择一个目标数据。直接输入截面名称时，必须与数据库中的截面名称一致。

材料：输入组成钢-砼组合截面的钢和砼的材料特性。

单击 [image] 选择材料数据库中的某一国家的钢材和砼的材料特性。

以下各项将由程序自动计算：

Es/Ec：钢与砼弹性模量之比。

Ds/Dc：钢材与砼重量(比重)之比。

Ps：钢材泊松比。

Pc：砼泊松比。

刚度比：换算刚度时，混凝土截面刚度的折减值。一般取0.8～1.0。

替换：计算组合截面刚度时指定以钢材为基准。

注:
在MIDAS中，计算钢-砼截面刚度时，将砼截面换算为等效钢材截面。

偏心：指定截面线单元的位置，即指定在模型窗口中显示的线单元是以截面哪个位置为基准生成的。使用 [image] 消隐功能确认生成的截面形状。

单击 [image] 显示组合截面的刚度数据。在刚度和周长对话框中，程序将砼截面刚度换算为等效钢材截面刚度。周长不变，仍然按实际外部轮廓尺寸计算。

<图17> 截面(型钢组合)对话框

型钢组合对话框

在对话框中，输入由两种标准截面组成的组合截面的截面特性。

截面号：截面编号(自动设定为最后的截面编号+1)。

名称：输入截面名称。

截面形状列表：选定要使用的截面形状。

用户：由用户输入标准截面形状的主要尺寸。

数据库：选择相应国家的标准截面数据库。共包含14个数据库，例如：

GB-YB：中国国家标准和冶金部标准截面。

AISC：美国钢结构协会。

BS(S)：英国标准。

DIN(S)：德国工业标准。

JIS：日本工业标准。

KS：韩国工业标准。

截面1、截面2：输入组成组合截面的各截面数据。

截面：直接输入数据库中的截面名称或在截面列表中选择一个目标数据。直接输入截面名称时，必须与数据库中的截面名称一致。

H, B, ... ：参照对话框中图形尺寸输入。

偏心：指定截面线单元的位置，即指定在模型窗口中显示的线单元是以截面哪个位置为基准生成的。使用 [image] 消隐功能确认生成的截面形状。

单击 [image] 显示组合截面特性数据。组合截面特性数据可由用户定义的尺寸计算得到；或者从数据库中得到。

<图18> 截面(变截面)对话框

变截面对话框

在对话框中，输入线单元两端的截面特性，定义变截面(非棱形截面/ 锥形截面)形状。(参见注解)

截面号：截面编号(自动设定为最后的截面编号+1)。

名称：输入截面名称。

截面形状列表：选定要使用的变截面形状。

数值：可以直接输入截面刚度数据。

分别输入i端和j端的截面尺寸并单击 [image] 。然后，用户可以修改自动计算得到的刚度数据。用户可以不输入截面尺寸而直接输入刚度数据。

用户：输入标准截面形状的主要尺寸。用户不能修改刚度值。

数据库：从某个国家的标准截面数据库中选择截面。共有14个截面库，例如：

GB-YB：中国国家标准和冶金部标准截面。

AISC：美国钢结构协会。

BS(S)：英国标准。

DIN(S)：德国工业标准。

JIS：日本工业标准。

KS：韩国工业标准。

截面-i、截面-j：直接输入对应于起点i端和终点j端的截面名称或在截面列表中选择截面来描述变截面。直接输入截面名称时，必须与数据库中的截面名称一致。

y轴变化：选择对单元局部坐标系y轴的惯性距，沿单元长度方向的变化规律。

z轴变化：选择对单元局部坐标系z轴的惯性距，沿单元长度方向的变化规律。

一次方程：沿单元局部坐标系x轴方向按线性变化。

二次方程：沿单元局部坐标系x轴方向按抛物线变化。

三次方程：沿单元局部坐标系x轴方向按三次曲线变化。

偏心：指定截面线单元的位置，即指定在模型窗口中显示的线单元是以截面哪个位置为基准生成的。使用 [image] 消隐功能确认生成的截面形状。

单击 [image] 同时显示i端和j端的截面特性值列表。

注:
一旦输入变截面构件两端的截面尺寸，即认为截面特性沿构件长度方向从i端(单元关联节点号为N1)到j端(单元关联节点号为N2)是变化的。程序默认为横截面积、有效抗剪面积和扭转惯性距沿单元局部坐标系x轴方向从i端到j端按线性变化，惯性距在截面改变方向上按线性、抛物线和三次曲线变化。

例如：下图中Iyy和Izz的变化表示如下：

矩形截面强轴和弱轴方向的惯性矩为(参见图19a)：

当宽度(B)是常数，高度(H)是变量时，则对强轴的惯性距由公式可以看出是按三次曲线变化的(面积是按线性变化的)，而对弱轴的惯性距由公式可以看出是线性变化。也就是说，此时应选择Iyy的变化 = '三次方程', Izz的变化 = '一次方程'。

工字型截面强轴和弱轴方向的惯性距为(参见图19b)：

当宽度(B)是常数，高度(H)是变量时，如果在上面的方程中忽略前两项，则对强轴的惯性距由公式可以看出是接近按抛物线变化。对弱轴的惯性距差不多是线性变化。因此，此时应选择Iyy的变化 = '二次方程', Izz的变化 = '一次方程'是可行的。相反，当高度(H)是常数而宽度(B)是变量时，如果在上面的方程中忽略前两项，则对强轴的惯性距差不多是线性变化。对弱轴的惯性距显示接近按抛物线变化。因此，此时应选择Iyy的变化 = '一次方程', Izz变化 = '二次方程'是可行的。

<图19> 变截面构件截面数据的输入

<图20> 截面(组合梁)对话框

组合梁对话框

在对话框中，将输入组合梁截面数据。

截面号：截面编号(自动设定为最后的截面编号+1)。

名称：输入截面名称。

截面类型

钢-箱型：箱型钢梁。

钢-工字形：工字形钢梁。

user：用户先前定义的截面。

钢筋混凝土板：参见左边的图形输入板的尺寸。

Bc：对于一个钢梁的有效翼缘宽度。

tc：钢筋混凝土板的厚度。

当选择"钢-箱型"时

Hw：钢梁腹板高度。

tw：钢梁腹板厚度。

B1：钢梁上翼缘宽度(选择箱型截面时，为箱型截面腹板中心间距)。

B2：钢梁下翼缘宽度(选择箱型截面时，为箱型截面腹板中心间距)。

Bf1：仅用于选择箱型截面时。为箱型截面腹板中心到上翼缘相邻端部距离。

Bf2：仅用于选择箱型截面时。为箱型截面腹板中心到下翼缘相邻端部距离。

tf1：钢梁上翼缘厚度。

tf2：钢梁下翼缘厚度。

N1：上翼缘的加劲板数量。

Hr1：上翼缘加劲板的高度。

tr1：上翼缘加劲板的厚度。

N2：下翼缘的加劲板数量。

Hr2：上翼缘加劲板的高度。

tr2：上翼缘加劲板的厚度。

当选择"钢-工字形"时

Hw：钢梁腹板高度。

tw：钢梁腹板厚度。

B1：钢梁上翼缘宽度。

B2：钢梁下翼缘宽度。

tf1：钢梁上翼缘厚度。

tf2：钢梁下翼缘厚度。

材料：

既可以由用户直接输入，也可以由用户点击 [image] 从数据库中选择。

Es/Ec：钢与砼弹性模量之比。

Ds/Dc：钢与砼重量(比重)之比。

偏心：

指定截面线单元的位置，即指定在模型窗口中显示的线单元是以截面哪个位置为基准生成的。使用 [image] 消隐功能确认生成的截面形状。

当选择"user"时

联合前(联合后)截面：

由用户在已定义的截面中选择联合前后的前面。该功能仅用于选择了?用户?定义时。

截面：在已定义的截面中选择联合前后的前面。

单击 [image] 显示截面特性值的列表。

修改先前输入的截面特性数据

在截面对话框列表中选择要修改的截面并单击 [image] 修改相应的数据。

删除先前输入的截面特性数据

在截面对话框列表中选择要删除的截面并单击 [image] 。

复制先前输入的截面特性数据

在截面对话框列表中选择要复制的截面并单击 [image] 。

从现有*.MCB文件中输入截面特性数据

单击 [image] 选择包含截面特性数据的*.MCB文件名，然后单击 [image] 。

截面列表

显示包含在现有*.MCB文件中的截面数据。

选择列表

在截面列表中选择要导入的截面数据移动到选择列表中。

注
如果选中*.MGB文件，程序将选择所有包含在现有*.MGB文件中的截面数据。如果有不需要的数据，可以将其从选择列表中移动到截面列表中。

编号类型

指定截面号的导入方式。

原号码

导入数据并保持同样的截面号，如果当前文件中已有该截面号，则当前截面号数据将被覆盖。

新号码

指定导入的截面号的起始新号码。

对已经输入的截面重新编号

在截面对话框里选择需要重新编号的截面特性号，单击 [image] 修改相关的数据。

<图21> 重新编截面号对话框

开始号：设定需要修改编号截面的起始号码。

增幅：输入截面特性编号的增量。

修改单元截面号：修改单元截面号。选择该选项，将修改先前定义的单元截面特性号。否则，重新编号截面的旧编号将出于未定义状态，用户新定义的截面号未分配给任何单元。


New Topic2

Home > midas Gen 2017 > 05_特性 > 04_截面 > 02_比例系数 > 01_截面刚度放大系数

截面刚度放大系数

  • 功 能

输入对线单元(桁架单元、只受拉单元、只受压单元、索单元、间隙单元、钩单元、梁单元）的截面特性的调整系数。可以对不同的构件赋予不同的调整系数。也可以用于调整剪力墙的连梁(只调整刚度，不调整截面面积)、现浇框架梁的刚度。

  • 命 令

从主菜单中选择特性 > 截面 > 比例系数 > 截面刚度放大系数 ...

  • 输 入

截面特性调整系数对话框

边界组名称

选择截面特性调整系数相应的边界组名称。为了在不同的施工阶段采用不同的边界条件/截面特性调整系数，使截面特性调整系数也能包含给边界组。在截面列表中选择相应截面，输入该截面的调整系数。

截面

在截面列表中选择相应截面，输入该截面的调整系数。

调整系数

输入截面各特性值的调整系数。

面积：截面面积。

Asy：单元坐标系y轴方向的抗剪有效面积(Effective Shear Area)。

Asz：单元坐标系z轴方向的抗剪有效面积(Effective Shear Area)。

Ixx：绕单元坐标系x轴的抗扭刚度(Torsional Resistance)。

Iyy：绕单元坐标系y轴的截面惯性矩(Moment of Inertia)。

Izz：绕单元坐标系z轴的截面惯性矩(Moment of Inertia)。

重量：计算重量使用的截面面积。


09_截面特性增减系数

Home > midas Gen 2017 > 05_特性 > 04_截面 > 02_比例系数 > 02_墙刚度放大系数

截面刚度放大系数

  • 功 能

输入对线单元(桁架单元、只受拉单元、只受压单元、索单元、间隙单元、钩单元、梁单元)的截面特性的调整系数。可以对不同的构件赋予不同的调整系数。也可以用于调整剪力墙的连梁(只调整刚度，不调整截面面积)、现浇框架梁的刚度。

  • 命 令

从主菜单中选择模型 > 材料和截面特性 > 截面特性值系数...

  • 输 入

截面特性调整系数对话框

边界组名称

选择截面特性调整系数相应的边界组名称。为了在不同的施工阶段采用不同的边界条件/截面特性调整系数，使截面特性调整系数也能包含给边界组。在截面列表中选择相应截面，输入该截面的调整系数。

截面

在截面列表中选择相应截面，输入该截面的调整系数。

调整系数

输入截面各特性值的调整系数。

面积：截面面积。

Asy：单元坐标系y轴方向的抗剪有效面积(Effective Shear Area)。

Asz：单元坐标系z轴方向的抗剪有效面积(Effective Shear Area)。

Ixx：绕单元坐标系x轴的抗扭刚度(Torsional Resistance)。

Iyy：绕单元坐标系y轴的截面惯性矩(Moment of Inertia)。

Izz：绕单元坐标系z轴的截面惯性矩(Moment of Inertia)。

重量：计算重量使用的截面面积。


10_变截面组

Home > midas Gen 2017 > 05_特性 > 04_截面 > 03_变截面组

变截面组

  • 功 能

将一些被定义为具有相同变截面(Tapered Section)特性的构件组成一个组，使其与单一的单元无关。原来单一构件的i端和j端变为变为变截面组的i端和j端。程序将自动计算内部各点的截面特性值。在截面对话框的?数值表单?中定义的变截面不能使用该功能。

  • 命 令

从主菜单中选择模型 > 材料和截面特性 > 变截面组...

从树形菜单的菜单表单中选择几何模型 > 特性值 > 变截面组

在图标菜单中单击 [image] 变截面组。

  • 输 入

节点起始号

该命令不适用。

单元起始号

该命令不适用。

变截面组:定义变截面组(Tapered Section Group)。

组名称：输入变截面组的名称。

单元列表：选择组成组的单元。

注:
使用选择功能选择单元时，单元号将自动显示到输入框中。选择的单元必须拥有相同的变截面特性值。

截面形状的变化:

决定沿单元坐标系各轴方向的截面的变化。

z轴(y轴)：沿单元坐标系z轴(y轴)方向的截面的变化。

线性：线性变化。

多项式：按右侧选择的数字做曲线变化。例如右侧数据为2，则按二次曲线变化。

注:
可选择的最大数字为2。可以选择2以下的小数，例如1.5等。

对称平面：
当截面形状按多项式变化时，曲线的切线与单元坐标系x轴平行的位置，一般可选择变截面组的j端。(参见左图)

从：选择基准点(变截面组的i端或j端)。

距离：从基准点到对称平面的x轴上的距离。

注:
要定义一个二次曲线，需要三个不在同一直线上的已知点。现在已知变截面组的i端和j端两个点的位置，对称平面位置就是二次曲线的第三点位置。

假设变截面组的截面形状变化沿构件长度方向对称，则在对称面上曲线的切线将与单元坐标系x轴平行，与截面垂直。

(a) 对称面在i端一侧时

(b) 对称面在j端一侧时

使用对称面(Symmeric Plane)的情形

操作:

点击 [image] ，将定义的变截面组添加到目录中。当需要修改已定义的变截面组时，在列表中选择相应变截面名称，输入修改内容后点击 [image] 。当需要删除已定义的变截面组时，在列表中选择相应变截面名称后点击 [image] 。

:

点击此键，程序将按变截面组中单元的个数，计算各点的截面特性值。用户可输入新生成的截面特性值号(截面号或厚度号)的开始截面号。

变截面组转换为变截面后，变截面组的信息将被自动删除。


11_厚度

Home > midas Gen 2017 > 05_特性 > 04_截面 > 04_厚度

厚 度

  • 功 能

输入平面单元(平面应力单元，板单元)的厚度数据。

  • 命 令

从主菜单中选择模型 > 材料和截面特性 > 厚度...。

从树形菜单的菜单表单中选择几何模型 > 特性值 > 厚度。

在图标菜单中单击 [image] 厚度。

  • 输 入

<图1> 厚度数据(数值)对话框

输入新的或增加厚度数据时

数值对话框

在特性对话框中单击 [image] 并输入下列各项：

厚度号：输入厚度编号(自动设定为最后的截面编号+1)。

面内和面外：平面内和平面外厚度相同时，厚度值在此输入。

面内：输入用于计算平面内方向刚度的厚度。

面外：输入用于计算平面外方向的刚度的厚度。

板对齐：输入沿单元坐标轴z轴方向的偏心值。

厚度比：输入偏心值和板厚的比值。

数值：直接输入偏心值。

加劲肋板对话框

<图2> 厚度数据(加劲肋板)对话框

厚度号：输入厚度编号(自动设定为最后的截面编号+1)。

输入：由用户直接输入肋板刚度数据。

计算重量用的厚度：输入计算重量时使用的等效厚度
(注意: 包括板单元)。

肋板位置：以板单元为基准，选择肋板的位置。

下部：布置在板单元下部。

上部：布置在板单元上部。

yz截面：输入沿单元坐标系x轴布置的肋板的数据。

xz截面：输入沿单元坐标系y轴布置的肋板的数据。

肋板形状列表：在列表中选择肋板的形状。

面内：输入用于计算平面内方向刚度的等效厚度(注意: 包括板单元和加劲肋)。

面外：输入用于计算平面外方向刚度的等效厚度(注意: 包括板单元和加劲肋)。

Hu、Hl：参照对话框左侧下端的图形输入尺寸。

用户：由用户直接输入计算肋板刚度使用的各尺寸数据。

板厚：输入板单元的厚度(注意: 不包括加劲肋)。

肋板位置：以板单元为基准，选择肋板的位置。

下部：布置在板单元下部。

上部：布置在板单元上部。

yz截面：输入沿单元坐标系x轴布置的肋板的数据。

xz截面：输入沿单元坐标系y轴布置的肋板的数据。

肋板：决定该方向是否设置肋板。

肋板形状列表：在列表中选择肋板的形状。

肋板间距：输入肋板的布置间距。

H1、Bl...：参照对话框左侧的图形输入尺寸。

单击 [image] ，将显示由用户输入的尺寸计算得到到截面特性数据。

数据库：在各国标准截面数据库中选择做为加劲肋的截面。

板厚：输入板单元的厚度(注意: 不包括板加劲肋)。

肋板位置：以板单元为基准，选择肋板的位置。

下部：布置在板单元下部。

上部：布置在板单元上部。

yz截面：输入沿单元坐标系x轴布置的肋板的数据。

xz截面：输入沿单元坐标系y轴布置的肋板的数据。

肋板：决定该方向是否设置肋板。

肋板形状列表：在列表中选择肋板的形状。

肋板间距：输入肋板的布置间距。

截面名称：选择标准截面。

单击 [image] ，将显示由用户输入的尺寸计算得到到截面特性数据。

钢板墙对话框

<图3>厚度数据(钢板墙对话框

厚度号：输入厚度编号；

混凝土厚度：输入混凝土厚度；

钢板厚度：输入钢板厚度；

注：

钢板墙分析时，按照下式计算的等效厚度计算刚度。

钢板混凝土剪力墙等效厚度：

d，dp: 混凝土及钢板厚度

Ep ，Ec: 混凝土及钢板弹性模量

修改先前输入的厚度数据

在厚度对话框中选择要修改的厚度并单击 [image] 修改相应的数据。

删除先前输入的厚度数据

在厚度对话框中选择要删除的厚度并单击 [image] 删除相应的数据。

复制先前输入的厚度数据

在厚度对话框中选择要复制的厚度并单击 [image] 复制相应的数据。

从现有*.MGB文件中输入厚度数据

单击 [image] 选择包含厚度数据的*.MGB文件，然后单击 [image] 。

厚度列表:显示包含在现有*.MGB文件中的厚度数据。

选择列表:在厚度列表中选择要导入的厚度数据移动到选择列表中。

注:
如果选中*.MGB文件，程序将选择所有包含在现有*.MGB文件中的厚度数据。如果有不需要的数据，可以将其从选择列表中移动到厚度列表中。

编号类型:指定厚度号的导入方式。

原号码:导入数据并保持同样的截面号，如果当前文件中已有该厚度号，则当前厚度号数据将被覆盖。

新号码:指定导入的厚度号的起始新号码。

对已经输入的厚度重新编号

在厚度对话框里选择需要重新编号的厚度特性号，单击 [image] 修改相关的数据。

<图4> 重新编厚度号对话框

开始号：设定需要修改编号厚度的起始号码。

增幅：输入厚度特性编号的增量。

修改单元厚度号：修改单元厚度号。选择该选项，将修改先前定义的单元厚度特性号。否则，重新编号厚度的旧编号将出于未定义状态，用户新定义的厚度号未分配给任何单元。


13_非弹性铰特性值

Home > midas Gen 2017 > 05_特性 > 05_塑性材料 > 01_非弹性铰 > 01_定义非弹性铰特性值

非弹性铰特性值

  • 功 能

添加、编辑或者删除非弹性铰特性值。

注：非弹性铰仅适用于非弹性时程分析功能。

  • 命 令

从主菜单中选择模型 > 材料和截面特性 > 非弹性铰特性值。

从树形菜单的菜单表单中选择模型 > 材料和截面特性 > 非弹性铰特性值。

  • 输 入

<图1> 定义非弹性铰的特性对话框

单击 [image] ，输入非弹性铰特性值。

当编辑前面定义的非弹性铰特性值时，选择特性值名称，单击 [image] ，修改输入数据。

当删除前面定义的非弹性铰特性值时，选择特性值名称，单击 [image] 。

：导入csv格式的非弹性铰特性值数据。CSV格式是日本程序DYNE2E的文件格式。

：导出csv格式的非弹性铰特性值数据。CSV格式是日本程序DYNE2E的文件格式。

：关闭对话框。

<图2> 添加/编辑非弹性铰特性对话框

名称

输入代表非弹性铰特性的名称。

说明

输入简要的说明。

屈服强度(面)计算方法

用户输入：用户直接输入非弹性铰的特性。

自动计算：根据选择的材料、截面、构件自动计算非弹性铰的特性。

铰类型

铰的类型分集中铰、分布铰、弹簧铰、桁架铰四种。

梁－柱

集中：梁－柱类型的集中铰通过转动和平移弹簧把结构的非弹性性能集中在单元的两端和中心。结构的其它位置假定为弹性。集中非弹性铰通过力矩与转角或者力与位移之间的关系定义。

分布：分布铰假定整个构件均为非弹性性能。分布非弹性铰通过在积分点处力矩与转角或者力与位移之间的关系定义。这需要计算构件的柔度矩阵。

弹簧

集中类型和分布类型的取决于材料和构件的非弹性特性，而对于边界条件的非线性连接则需要定义为弹簧类型的铰。在这里可以定义?边界条件/一般连接特性值?中非线性连接铰的各自由度的特性。各自由度的线性特性取决于输入的有效刚度，有效刚度在进行非弹性分析时会作为初始刚度来计算。弹簧的非弹性效应可定义为骨架曲线 (skeleton)，对于3个平移自由度和3个旋转自由度都可以定义非弹性特性。

桁架

对于构件的轴方向，构件中心处（center）布置弹簧（力－位移关系定义）。弹簧的非弹性滞回模型定义为骨架滞回模型。

定义

定义非弹性铰的滞回模型。

骨架: 是一种经验性的滞回模型，即假设3个平移自由度和3个旋转自由度的铰的特性各自作用而不互相影响，并对各自由度铰的特性分别定义的单轴(单向)铰滞回模型(uni-axial hinge hysteresis model)。

纤维: 纤维模型用来定义多轴铰的滞回模型，即将梁单元的截面分割成只发生轴向变形的纤维来进行分析的模型。纤维模型可通过各纤维的材料应力-应变关系和截面上的变形分布特性的假定，非常精确地反映截面的弯矩-曲率关系。

作用类型

无：不考虑轴力与弯矩的相互作用。

强度P-M: 在进行时程分析时，考虑轴力的影响来计算铰的弯曲屈服强度。这种方式对于两个方向弯矩间的相互作用是不考虑的，即对于每个时间增量(time step)评价铰的状态时，假定轴力和两个方向上的弯矩各自独立。

考虑轴力重新计算弯矩作用下的屈服强度时，荷载工况需满足下列3个条件：

1）需为几个连续分析的时程荷载工况中的第一个荷载工况；

2）需进行的是非线性静力分析；

3）需使用位移控制。

对象单元应为考虑P-M相互作用的非弹性铰的梁单元。此时的初始内力可以认为是时变静力荷载包含的所有静力荷载的线弹性分析结果的组合，组合系数使用的是定义时变静力荷载时所输入的系数。

强度P-M-M: 这种方式使用的是多轴铰的滞回模型，因此可适用于弹塑性时程分析。即使用塑性理论来反映轴力和两个方向上弯矩的相互作用，对于每个时间增量都共同考虑这三种作用的变化，从而来评价铰的状态。

注：对于集中铰和分布铰的Fy、Fz成分，不能考虑轴力和弯矩的相互作用。

材料

选择适用于非弹性铰的材料，根据选择材料的不同定义单元的屈服应力也不同。

类型：提供5种材料类型。

钢材：定义截面的最大弯曲应力达到屈服应力时为第一屈服点。全截面的弯曲应力达到屈服应力时做为第二屈服点。

钢筋混凝土：定义截面的最大弯曲应力达到了混凝土的开裂应力时为第一屈服点。混凝土的应力达到了极限强度或钢筋屈服时为第二屈服。

SRC(内填)：钢管混凝土形式，按钢骨混凝土截面的计算标准。

SRC(外围)：外围混凝土形式，按钢筋混凝土截面的计算标准。

用户定义：利用用户指定的材料特性来计算。

规范

选择设计规范。所选规范用于确定RC和SRC（内填）结构的混凝土极限强度系数（cracking strength coefficient）。ACI规范中极限强度系数为7.5 lb-in，AIJ规范中为1.8kgf-cm。

名称

选择非弹性铰的材料名称。

构件

类型：选择非弹性铰的构件类型，分为梁、柱、支撑三种构件。

单元位置：选择计算非弹性铰特性的参考位置。本选项仅适用于梁单元，I、M和J分别代表i端、中心和j端。非弹性铰的特性由钢筋混凝土梁三个位置的配筋情况决定。

截面

名称：选择非弹性铰的截面名称。

特性值

输入非弹性铰截面强度不同成分的特性值数据。

成分

选择需要输入截面强度的成分。可以输入一个轴向和两个弯距成分的数据。

铰位置（选择集中类型时被激活）

选择集中铰的位置。一般，受轴力单元选择单元中间，受弯单元选择I端、j端或者两端。

铰数量（选择分布类型时被激活）

输入积分点的数量，最多可输入到20个，根据输入的个数计算各个截面的力－位移或变形的关系。

滞回模型

选择滞回模型类型。

特性值

输入非弹性铰每一部分的特性值。

纤维名称

将分布铰定义为纤维形式时，选择纤维单元的名称。

滞回模型

随动强化型滞回模型（kinematic hardening）

随动强化滞回模型

初期加载时的效应点是在3条骨架曲线上移动的。卸载刚度与弹性刚度相同。随着荷载的增加强度有增加的趋势，这是考虑了金属材料的Bauschinger Effect(包辛格效应)。对于混凝土材料这样会过高的评价其吸收能量的能力，需要注意。这种滞回模型的特点要求屈服后刚度的折减率在正(+)、负(-)区域对称。

指向原点型滞回模型（Origin-oriented Type）

初期加载时的效应点是在3条不同斜率的骨架曲线上移动的。卸载时会向着圆心移动，到达另一方向（第三象限）的骨架曲线时会重新沿着骨架曲线移动。

指向顶点型滞回模型（Peak-oriented Type）

初期加载时的效应点是在3条骨架曲线上移动的。卸载时会向另一方向的最高位移点移动。另一侧如果还没有发生第一次屈服，则会向着第一次屈服点的位置移动。

克拉夫滞回模型（Clough Type）

初期加载时的效应点是在2条不同斜率的骨架曲线上移动的。卸载刚度按下式计算。由式可知，卸载刚度随着屈服后的变形进展而逐渐减小。

式中， [image] ：卸载刚度(unloading stiffness)

：弹性刚度(elastic stiffness)

：卸载开始时相应区域的屈服变形

：卸载开始时相应区域的最大变形

(对于还未发生屈服的区域取屈服时的变形)

：确定卸载刚度的一个参数（常数）

在卸载过程中，荷载符号发生变化的话，效应点会向着卸载方向区域的最大变形点的位置移动。如果该区域还未发生屈服，则会向着骨架曲线上的屈服点的位置移动。卸载过程中，在荷载符号还未发生变化的情况下重新加载的话，效应点会沿着卸载轨迹重新返回，继续加载到达骨架曲线时就会沿着骨架曲线移动。

刚度退化三折线型滞回模型（Degrading Trilinear Type）

无裂缝区域屈服前的初期卸载状态(微小变形)

无裂缝区域屈服前的初期卸载状态(大变形)和内环曲线

初期加载时的效应点是在3条骨架曲线上移动的。卸载时效应点将沿着两个不同的卸载刚度（斜率）所构成的轨迹向另一侧的最大变形点移动, 其卸载刚度取决于卸载点在骨架曲线上的位置和另一侧是否达到了一次屈服。

如果从骨架曲线的一次、二次屈服点之间开始卸载时，效应点会向着另一侧一次屈服点的位置移动（左图）。在这个过程中如果荷载符号发生变化，就会向着该区域骨架曲线的最大变形点移动。在该区域如果未发生屈服时则会向着第一个屈服点移动。在这个过程中如果与骨架曲线相遇，则将沿着骨架曲线移动。

若超过骨架曲线的二次屈服点后开始卸载的话，则效应点按右图所示移动。

两个卸载刚度按下式计算，最大变形越大卸载刚度减小的就越多。

式中，

K_R1 : 第1卸载刚度

K_R2 : 第2卸载刚度

K_0 : 弹性刚度

K_C : 卸载区域里的第一屈服刚度

K_1 : 卸载区域里原点和二次屈服点连线的斜率

b : 刚度折减率。卸载如果在骨架曲线上的一次屈服点和二次屈服点之间开始则取1.0

F_M+ , F_M- : 分别为正(+)、负(－)区域的最大荷载

D_M+ , D_M- : 分别为正(+)、负(－)区域的最大变形

武田三折线滞回模型(Takeda triLinear Type)

无裂缝区域屈服前卸载状态(微小变形) | 无裂缝区域屈服前卸载状态(大变形)
          • 初期加载时的效应点在3条骨架曲线上移动；
          • 当前的变形D首次超过D1或目前为止的最大变形时：

        1. 在3条骨架曲线上移动；

        2. 在骨架曲线上开始卸载时，向另一侧的一次屈服点的位置移动；

        3. 另一侧的最大变形处于弹性区域时，该弹性区域的范围最多到一次屈服点；

        4. 另一侧的最大变形超过D1时，该弹性区域的范围到恢复力为0的点为止，超过0点后则向着另一侧的最大变形点移动。在0点和最大变形点的直线上开始卸载时，卸载刚度使用与另一侧最大变形点开始卸载时的相同的刚度。

        • 当前的变形D首次超过D2或目前为止的最大变形时：

        1. 在3条骨架曲线上移动；

        2. 卸载时沿按下式所计算的刚度与卸载点所构成的直线上移动；

        ，

        式中， K_un2: 外环曲线的卸载刚度

        P1 : 卸载点另一侧区域的一次屈服荷载

        P2 : 卸载所属区域的二次屈服荷载

        D1: 卸载点另一侧区域的一次屈服变形

        D2: 卸载所属区域的二次屈服变形

        D_max: 卸载所属区域的最大变形

        β: 确定外环曲线的卸载刚度的常数

        3. 另一侧的最大变形不超过D1时，到P1为止保持K_un2的斜率。超过P1后则向着D2点移动。在向D2点移动的直线上开始卸载时，则沿着Kb的斜率卸载。恢复力超过0时则向着最大变形点，此时如果再开始卸载则按K_un2的斜率移动，恢复力又超过0时，向着另一侧的最大变形点移动。

        4. 卸载过程中荷载符号变化而重新加载时，如果还未到达骨架曲线就开始卸载，此时所形成的曲线都叫内环曲线(Inner Loop)。内环曲线的卸载刚度按下式计算。

        式中， K_RI : 内环曲线的卸载刚度

        K_un2 : 卸载开始点所属区域的外环曲线卸载刚度

        γ : 内环曲线的卸载刚度折减率

        5. 另一侧的最大变形超过D1时，斜率K_un2适用到恢复力为0的点，超过0时则向着最大变形点移动。在向着最大变形点移动的直线上卸载时，此时的D为内环曲线的最大变形点，并按着斜率K_un2移动，恢复力超过0时再向着最大变形点移动。

            • Takeda滞回模型适用于塑性铰为集中型和分布型的梁单元以及定义两节点间的非弹性连接的弹簧型连接。

武田四折线型滞回曲线(Takeda Tetra Linear Type)

      1. 武田四折线模型

        • 加载初期效应点在4折线型的骨架曲线上移动。
        • 当前的变形D没有超过D3时与Takeda滞回模型的原则相同。
        • 当前的变形D超过D3时沿着斜率K4移动，卸载时与Takeda滞回模型的原则相同。

        同样，四折线型Takeda滞回模型适用于塑性铰为集中型和分布型的梁单元以及定义两节点间的非弹性连接的弹簧型连接。

修正的武田滞回模型(Modified Takeda Type)

          • 加载初期效应点在3折线型的骨架曲线上移动。
          • 前变形D首次超过D2或者超过到目前为止的最大变形时，效应点在3折线型骨架曲线上移动。若此时开始卸载，到恢复力为0的点为止，沿着斜率为K_un2的直线移动，恢复力超过0后则向着另一侧的最大变形点移动。

        式中，

        K_un2 : 外环曲线的卸载刚度

        K_0 : 弹性刚度

        D1 : 卸载区域的一次屈服变形

        D_max : 卸载区域的最大变形

        β : 决定外环曲线卸载刚度的常数

        • 从恢复力为0的点向最大变形点移动过程中的直线上开始卸载时，其原则也是一样。即，到恢复力为0的点为止，沿着斜率为K_un2的直线移动，恢复力超过0后则向着另一侧的最大变形点移动。

        改进型Takeda滞回模型适用于塑性铰为集中型和分布型的梁单元以及定义两节点间的非弹性连接的弹簧型连接。

修正的武田四折线滞回模型(Modified Takeda Tetra Linear Type)

        • 修正的武田四折线滞回模型

        • 加载初期效应点在4折线型的骨架曲线上移动。
        • 当前的变形D没有超过D3时与改进型Takeda滞回模型的原则相同。
        • 当前的变形D超过D3时沿着斜率K4移动，卸载时与改进型Takeda滞回模型的原则相同。

        改进型四折线Takeda滞回模型适用于塑性铰为集中型和分布型的梁单元以及定义两节点间的非弹性连接的弹簧型连接。

标准双折线型滞回模型 (Normal Bilinear Type)

      1. +

        标准双折线滞回模型

        加载初期的效应点是在一双折线(Bi Linear)骨架曲线上移动的。卸载刚度与弹性刚度相同。一般双折线型滞回模型适用于塑性铰为集中型和分布型的梁单元以及定义两节点间的非弹性连接的弹簧型连接。

弹性双折线型滞回模型 (Elastic Bilinear Type)

      1. 弹性双折线滞回模型

        不论加载还是卸载都是沿着双折线(Bi Linear)移动，并不形成环形曲线。 该滞回模型可适用于塑性铰为集中型和分布型的梁单元以及定义两节点间的非弹性连接的弹簧型连接。

弹性三折线型滞回模型 (Elastic Trilinear Type)

      1. 弹性三折线滞回模型

        不论加载还是卸载都是沿着三折线(Tri Linear)骨架曲线移动，并不形成环形曲线。该滞回模型可适用于塑性铰为集中型和分布型的梁单元以及定义两节点间的非弹性连接的弹簧型连接。

弹性四折线型滞回模型 (Elastic Tetralinear Type)

      1. 弹性四折线滞回模型

        不论加载还是卸载都是沿着四折线(Tetra Linear)骨架曲线移动，并不形成环形曲线。 该滞回模型可适用于塑性铰为集中型和分布型的梁单元以及定义两节点间的非弹性连接的弹簧型连接。

滑移双折线模型（Slip Bilinear Type）

滑移三折线模型（Slip Triilinear Type）

<图3> 铰特性值对话框

滑移双折线/只受拉模型（SLIP Bilinear/Tension）

可用于定义只受拉单元的双折线型非弹性铰特性值。

<图4>只受拉单元双折线型铰特性值对话框

滑移双折线/只受压模型（SLIP Bilinear/Compression）

可用于定义只受压单元的双折线型非弹性铰特性值。

<图5>受压单元双折线型铰特性值对话框

滑移三折线/只受拉模型（SLIP Trilinear/Tension）

可用于定义只受拉单元的三折线型非弹性铰特性值。

<图6>只受拉单元三折线型铰特性值对话框

滑移三折线/只受压模型（SLIP Trilinear/Compression）

可用于定义只受压单元的三折线型非弹性铰特性值。

<图7>只受压单元三折线型铰特性值对话框

LRB隔震装置双折线型

可用于定义只受压单元的三折线型非弹性铰特性值。

<图8> 双折线型LRB滞回模型

Qd50:屈服特性值

Kp50: 屈服强度

H: 层厚

ALF: 屈服刚度比(1/6.5)

Rmin: 应变值，用于计算初始刚度

KE50: 初始刚度（LRB装置变形50%时的刚度）

LRB隔震双折线型滞回模型仅能应用于弹簧类型的一般连接。

LRB隔震装置三折线型

<图9>三折线型LRB滞回模型

H:层厚度

面积： 接触面积

R_min: 初始剪切应变(默认值为 0.01)

SW: 支座型号

1: HDR-G12 (默认)
2: HDR-G10
3: LRB-G12
4: LRB-G10
5: RB-G12
6: RB-G10
7: HDR-G8
8: HDR-S-G12

LRB隔震装置三折线型滞回模型仅能用于弹簧型一般连接。

高阻尼橡胶隔震装置

<图10>高阻尼橡胶隔震支座滞回模型

H: 层厚

面积：接触面积

R_min: 初始剪切应变(默认值为 0.01)

SW: 支座型号

1: KL301 (默认)
2: KL401
3: KL302
4: KL501
5: UHD-G6
6: HD-G8
7: TOYO
8: G=8 kgf/cm2
9: G=10 kgf/cm2
10: G=12 kgf/cm2

Gs: 剪切模量系数 (默认值 : 1.0)

Hs:等效阻尼系数 (默认值 : 1.0)

Us: 屈服承载力特性值系数 (默认值 : 1.0)

高阻尼橡胶隔震支座滞回模型仅能用于弹簧类型的一般连接。


14_分配非弹性铰

Home > midas Gen 2017 > 05_特性 > 05_塑性材料 > 01_非弹性铰 > 02_分配非弹性铰

分配非弹性铰

  • 功 能

给单元添加或者删除非弹性铰特性值。

  • 命 令

从主菜单中选择模型 > 材料和截面特性 > 非弹性铰

从树形菜单的菜单表单中选择几何模型 > 特性值 > 非弹性铰

  • 输 入

选项：

添加/替换: 在选定单元上添加或者替换先前定义的非弹性铰特性。

删除: 删除选定单元上先前定义的非弹性铰特性。

单元类型：

选择分配非弹性铰的单元类型。目前，只有桁架和梁单元可以分配非弹性铰特性。

非弹性铰特性值：选择要分配的非弹性铰特性值。

材料：显示输入的非弹性铰的材料类型。

构件类型：显示输入的非弹性铰的构件类型。

单元位置：如果材料类型为钢筋混凝土，并且构件类型为梁，则显示单元上加强信息的位置。

截面：显示输入的非弹性铰的截面。

所有满足上述四项的构件将在模型窗口中显示。


15_组阻尼比

Home > midas Gen 2017 > 05_特性 > 05_塑性材料 > 02_组阻尼 > 01_组阻尼比-单元质量和刚度因子

组阻尼：单元质量和刚度因子

  • 功 能

组阻尼比用于对不同的结构组和边界组赋予不同的阻尼比。

  • 命 令

从主菜单中选择模型 > 材料和截面特性 > 组阻尼比：单元质量和刚度因子...

从树形菜单的表格表单中选择模型 > 材料和截面特性 > 组阻尼比：单元质量和刚度因子...

  • 输 入

  • <图1> 组阻尼比：单元质量和刚度因子输入对话框

未指定的节点、单元和边界

对于未指定阻尼比的组或材料中包含的节点、单元和边界应用该默认值

阻尼类型

确认阻尼矩阵是否与质量和刚度成正比。

直接计算：直接输入相应的比例因子；

由计算得振型阻尼比：根据“因子计算”中输入的振型阻尼比，由程序自动计算比例因子。

因子计算

根据比例型阻尼的类型，可以定义一到两个振型阻尼比。如果仅与质量或刚度成正比，只需定义一个振型阻尼比。如果与质量和刚度都成正比，则需定义两个振型阻尼比。

频率（Hz）:输入振型频率，用于计算比例因子；

周期（秒）：输入周期，用于计算比例因子；

阻尼比：输入与频率和周期相对应的阻尼比

指定的节点、单元和边界

根据材料或组定义阻尼比；

类型：

材料：按材料输入阻尼比。阻尼比将会根据材料数据中的定义应用到相应的单元。

结构组：按结构组来输入阻尼比

边界组：按边界组来输入阻尼比

材料或组的组名称：下拉菜单选择要输入的组

1. 材料：选择材料数据名称；

2. 选择组名称：组在模型->组->结构组或边界组

因子计算

根据比例型阻尼的类型，可以定义一到两个振型阻尼比。如果仅与质量或刚度成正比，只需定义一个振型阻尼比。如果与质量和刚度都成正比，则需定义两个振型阻尼比。

直接定义：直接输入相应的比例因子；

由计算得振型阻尼比：根据“因子计算”中输入的振型阻尼比，由程序自动计算比例因子。

频率（Hz）:输入振型频率，用于计算比例因子；

周期（秒）：输入周期，用于计算比例因子；

设置默认数据：对于未指定的单元和边界，设置默认的周期和频率

阻尼比

定义阻尼比

使用材料数据：利用材料数据中定义的阻尼比

直接定义：直接输入各个材料的阻尼比，当材料或组的名称中选择“所有材料数据”时，该选项钝化。

重复定义时阻尼比优选项

<图2>重复定义时组阻尼比优选项

在材料数据和结构组中优选

当材料数据和结构组的阻尼比被指定到同一个单元时，选择优先级别。

材料数据：优选材料数据中的阻尼比用于分析；

结构组：优选结构组中定义的阻尼比用于分析；

在结构组中优选

小阻尼比：应用小阻尼比；

大阻尼比：应用大阻尼比；


15_组阻尼比

Home > midas Gen 2017 > 05_特性 > 05_塑性材料 > 02_组阻尼 > 02_组阻尼比-应变能因子

组阻尼：应变能因子

  • 功 能

时程分析时，对不同的结构组和边界组赋予不同的阻尼比。

  • 命 令

从主菜单中选择模型 > 材料和截面特性 > 组阻尼比：应变能因子...

从树形菜单的表格表单中选择模型 > 材料和截面特性 > 组阻尼比：应变能因子...

  • 输 入

    <图1> 组阻尼比输入对话框

未指定阻尼的单元和边界的阻尼比

对于未指定阻尼比的单元和边界，应用该阻尼比。

指定单元和边界的阻尼比

根据材料或组（结构组和边界组），输入阻尼比。

类型：

材料：按材料输入阻尼比。阻尼比将会根据材料数据中的定义应用到相应的单元。

结构组：按结构组来输入阻尼比

边界组：按边界组来输入阻尼比

材料或组的组名称：下拉菜单选择要输入的组

1. 材料：选择材料数据名称；

2. 选择组名称：组在模型->组->结构组或边界组

注：可以通过选择“所有材料数据”定义整体阻尼比；

-选择“所有材料数据”（默认）

-点击“定义”：根据材料数据中定义的阻尼比定义整体阻尼比；

使用材料数据：利用材料数据中定义的阻尼比

直接定义：直接输入各个材料的阻尼比，当材料或组的名称中选择“所有材料数据”时，该选项钝化。

只有在其他对话框中选择应变能因子时才计算上述内容

勾选时，只有当时程荷载工况中阻尼比计算方法选择“应变能因子”时才计算振型阻尼比。

不勾选时，无论选择何种阻尼比计算方法，都计算振型阻尼比，并在“结果->组阻尼比计算的各振型阻尼比”中输出。

重复定义时阻尼比优选项

<图2> 重复定义时组阻尼比优选项

在材料数据和结构组中优选

当材料数据和结构组的阻尼比被指定到同一个单元时，选择优先级别。

材料数据：优选材料数据中的阻尼比用于分析；

结构组：优选结构组中定义的阻尼比用于分析；

在结构组中优选

小阻尼比：应用小阻尼比；

大阻尼比：应用大阻尼比；


16_纤维材料特征值

Home > midas Gen 2017 > 05_特性 > 05_塑性材料 > 03_弹塑性材料 > 01_弹塑性材料特性

弹塑性材料特性

  • 功 能

为进行纤维单元的非弹性时程分析，定义钢筋和混凝土的应力－应变关系。

  • 命 令

从主菜单中选择模型 > 材料和截面特性 > 弹塑性材料特性

从树形菜单的菜单表单中选择模型 > 材料和截面特性 > 纤维材料特性值

  • 输 入

梁截面分割成多块以后，给每个分割块赋予相应的应力－应变关系。

定义纤维材料特性值对话框

：添加纤维材料特性值。

：修改已输入的纤维材料特性值。

：删除已输入的纤维材料特性值。

名称：纤维材料特性名称

材料类型：选择滞后模型的材料。

滞后模型：纤维模型可采用的滞后模型钢筋有4种，混凝土有5种。

骨架曲线：根据不同模型的滞后模型曲线图，输入曲线参数。

混凝土

Kent & Park 模型

用Modified Kent & Park 混凝土模型，可以考虑横向约束钢筋的约束效果。

f'c : 混凝土抗压强度

K : 约束引起抗压强度增加的系数

ε_cu : 压缩破碎时的应变

ε_c0 : 产生最大抗压强度时的应变

Z : 压缩屈服以后，表示软化区段的系数

日本混凝土标准规范模型

日本混凝土标准规范[抗震性能对照调查篇，23页]的滞后模型。反映了超过最大应力点的软化区段和残留塑性变形、卸载再加载时的刚度下降效果。

fc' : 混凝土最大抗压强度

ε'峰值 : 达到最大抗压强度时的应变

日本公路标准模型

日本公路标准，V抗震设计篇[钢筋混凝土，161页]的模型。

选择类型I时

选择类型II时

地震类型 I：极限应变和最大抗压强度时的应变值相等，所以不考虑下降段。

地震类型 II：极限应变根据规范来估算，考虑下降段。

Ec：弹性模量

σ_ck：混凝土设计强度

σ_sy：横向约束钢筋（如横向拉构筋、横向箍筋等）的屈服点

α,β：截面保证系数

注

圆形截面 α=1.0, β=1.0

梯形截面、空心圆形截面、空心梯形截面α=0.2, β=0.4

A_h：一根横向约束钢筋截面积

s：横向约束钢筋间距

d：横向约束钢筋的有效区域内，被箍筋或中间箍筋分割的内核混凝土中最大边长。

σ_bt：混凝土抗拉强度

σ_cc：被横向约束钢筋约束的混凝土强度

名古屋高速公路社团模型

σ_ck：混凝土抗压强度

ε_cc：混凝土达到最大抗压强度时的应变

K：抗压强度增大系数

ε_cu：混凝土极限压应变

ε_t0：混凝土达到最大抗拉强度时的应变

ε_t1：混凝土受拉破坏时的应变

ε_tu：混凝土极限拉应变

三折线混凝土模型

受拉区和受压区均能定义的模型，受压区取三折线滞后模型。三折线滞后模型有应力－应变关系输入方法和应力－刚度折减率输入方法两种。

应力－应变关系

应力－刚度折减率

σ_c1 : 混凝土第一受压屈服强度

σ_c2 : 混凝土第二受压屈服强度

σ_c3 : 混凝土第二受压屈服以后的强度(估算K3时必要)

ε : 混凝土产生最大抗拉强度时的应变

ε_t1 : 混凝土受拉破坏发生时的应变

ε_tu : 混凝土极限拉应变

ε_c1 : 混凝土第一受压屈服应变

ε_c2 : 混凝土第二受压屈服应变

ε_c3 : 混凝土第二受压屈服以后的应变(估算K3时必要)

ε_cu : 混凝土第三受压屈服应变

K1 : 混凝土初始强度

K2/K1 : 混凝土第一屈服后的强度与初始强度之比

K3/K1 : 混凝土第二屈服后的强度与初始强度之比

ε_cu : 混凝土第三受压屈服应变

注

用“σ - ε”输入方式输入完ε_c1～ε_c3后，再选择“σ - α”输入方式，会自动计算K1, K2/K1, K3/K1的值。相反也可会自动计算。

混凝土结构设计规范（GB50010-02）

fc*：混凝土的单轴抗压强度。

εc：与fc*对应的混凝土峰值压应变。

ft*：混凝土的单轴抗拉强度。

εt：与ft*对应的混凝土峰值拉应变。

Mander模型

钢材

Menegotto-Pinto 模型

Filippou等修改的Menegotto and Pinto钢材模型。

f_y : 钢筋屈服强度

E : 钢筋初始刚度

b : 屈服后钢筋的刚度和初始刚度之比

R0, a1, a2 : 屈服后钢筋的应力－应变曲线参数

双折线模型

一般对称的双折线钢筋模型。

f_y : 钢筋屈服强度

E1 : 钢筋初始刚度

E2/E1: 屈服后钢筋的刚度和初始刚度之比

非对称双折线模型

对一般双折线模型深化的一个模型，可以任意定义钢筋屈服后的刚度，可考虑钢筋的屈曲和拉断。

σ_y : 受拉侧的屈服强度

σ_cy : 受压侧屈服强度

ε1 : 钢筋受压失稳时的应变

ε2 : 受拉屈服后，钢筋拉断发生时应变

E1 : 钢筋的初始刚度

E2 : 受拉屈服后钢筋的刚度

E3 : 加载时，钢筋屈服以后刚度

E4 : 受压屈服后钢筋的刚度(输入负值时可考虑下降段)

E5 : 发生受压屈服的失稳以后的刚度

三折线钢材模型

三折线滞后模型，有应力－应变的坐标值输入的方法和应力－刚度折减率的输入方法。

应力－应变

应力－刚度折减率

σ2y : 受拉侧的第二屈服强度

σ3y : 受拉侧的第二屈服以后的强度(估算K3时必要)

σ'1y : 受压侧第一屈服强度

σ'2y : 受压侧第二屈服强度

σ'3y : 受压侧第二屈服以后的强度(计算K5时必要)

ε1y : 受拉侧第一屈服应变

ε2y : 受拉侧第二屈服应变

ε3y : 受拉侧第二屈服以后的应变(估算K3时必要)

ε'1y : 受压侧第一屈服应变

ε'2y : 受压侧第二屈服应变

ε'3y : 受压侧第二屈服以后的应变(估算K5时必要)

K : 钢筋初始刚度

K2/K1 : 受拉第一屈服后钢筋刚度与初始刚度之比

K3/K1 : 受拉第二屈服后钢筋刚度与初始刚度之比

K4/K1 : 受压第一屈服后钢筋刚度与初始刚度之比

K5/K1 : 受压第二屈服后钢筋刚度与初始刚度之比

注

用“σ - ε”输入方式输入完ε_c1～ε_c3后，再选择“σ - α”输入方式，会自动计算K1, K2/K1, K3/K1的值。相反也会自动计算。


17_纤维截面分割

Home > midas Gen 2017 > 05_特性 > 05_塑性材料 > 03_弹塑性材料 > 02_截面纤维分割

纤维截面分割

  • 功 能

为了利用纤维单元来进行非线性分析，首先把截面分割成多个块，给每个块输入具有不同非线性特性的混凝土或钢筋等的材料特性。如钢筋混凝土的截面可以分别输入钢筋以外保护层混凝土、钢筋以内核心混凝土、钢筋三个不同的非线性特性的材料特性。

  • 命 令

从主菜单中选择模型 > 材料和截面特性 > 纤维截面分割...

从树形菜单的菜单表单中选择模型 > 材料和截面特性 > 纤维截面分割

  • 输 入

定义纤维模型的截面分割特性。

名称：纤维截面名称。

截面：要分割为纤维截面的一般截面的名称。

：新添加纤维截面。

：修改或编辑已输入的纤维截面数据。

：删除已输入的纤维截面。

纤维截面分割对话框

名称

输入纤维截面名称。

截面名称

选择要分割的一般截面名称。

：导入已定义的截面形状。

：删除导入的截面形状。

：导入截面已定义的钢筋数据。

：删除导入的钢筋数据。

：定义纤维截面时，如果想定义新的截面，可以点击此按钮直接定义。

纤维材料特性值

不同类型的非线性混凝土和钢筋的材料特性最多可定义6种，然后分配给各个纤维块。

：各种类型的材料特性可定义不同颜色来显示。材料颜色可任意定义。

生成纤维

截面分割成多个块后，分配非线性材料特性。

导入保护层厚度: 导入已有保护层厚度的一般截面的原有保护层厚度。

从边界偏心距离: 给一般截面指定保护层厚度，首先选择基准多边形，然后输入保护层厚度生成新的多边形。

：生成新截面边缘时，选择任意两点来自动计算距离。可以输入已选两点距离的多倍距离。

确认：一般截面是多个点和边缘线形成的多边形。选择其中要分割为纤维单元的部分，在定义了保护层时，也可作为一个对象来处理。

清除：取消已选择的部分。

确认 : 选择分割部分的区域面。此时只激活区域面形成的多边形包含的部分。能够进行分割的部分用阴影来显示。

清除 : 取消被选的区域。

类型分割：对被选区域用矩形形式或圆形形式来分割。

矩形：

Ny = 输入截面y方向要分割的块数。

Nz = 输入截面z方向要分割的块数。

圆形：中心点 (y,z) = 圆形形式分割时，输入圆心坐标。

:两点中心作为圆形形式分割的圆心坐标。选择任意两点，圆心坐标自动取用两点中心坐标。

Nt = 输入圆周方向分割的块数。

Nr = 输入圆心向外方向分割的块数。

材料号：分配被分割部分的材料特性。

修改已分割的纤维单元。

合并：把分割的多个块合并为一个块。

删除：删除已分割的块。

撤销、重做：撤销上一步编辑的工作或重做。

生成钢筋

在截面输入钢筋数据。钢筋的定义有点、线、圆弧三种方法。所输入的钢筋数据按钢筋的名称和数量、总面积分别列入表内。

类型：点

单根单根输入钢筋数据。

材料号：选择纤维材料特性值种类。

中心点(y,z)：输入钢筋位置。可直接输入数值，也可以在左侧截面窗口上点击鼠标输入。

面积：输入单根钢筋的面积。普通钢筋的面积可直接在DB里面选择，也可以用户直接输入钢筋面积（User）。

类型：线

钢筋布置在一条直线上时，可采用线的类型来定义。

材料号：选择纤维材料特性值种类。

开始点(y,z)：输入钢筋列的开始点的位置。直接输入数值或在左侧图形敞口上点击鼠标输入。

结束点(y,z)：输入钢筋列的结束点位置。直接输入数值或在左侧图形敞口上点击鼠标输入。

钢筋数：一列布置的钢筋根数。

面积：输入单根钢筋的面积。普通钢筋的面积可直接在DB里面选择，也可以用户直接输入钢筋面积（User）。

类型：圆弧

钢筋布置在圆弧线上时，可采用圆弧类型来定义。

材料号：选择纤维材料特性值种类。

开始点(y,z)：输入圆弧线布置钢筋的圆弧起点。直接输入数值或在左侧图形敞口上点击鼠标输入。

弧中心(y,z)：输入圆弧的中心点位置。此时，开始点必须位于弧中心的右侧，才能正确的布置钢筋。直接输入数值或在左侧图形敞口上点击鼠标输入。

圆心角：输入圆弧的圆心角。圆形布置的圆心角为360度。

钢筋数：圆弧布置钢筋的数量。

面积：输入单根钢筋的面积。普通钢筋的面积可直接在DB里面选择，也可以用户直接输入钢筋面积（User）。


18_材料表格

Home > midas Gen 2017 > 05_特性 > 06_特性表格 > 01_材料

材料表格

  • 功 能

以电子表格形式输入或修改单元的材料特性。

MIDAS软件中的表格工具提供了各种强大的内置功能。详细说明参见下列各项：

表格工具的使用

术语

掌握使用方法

基本说明(单元移动、选择、大小控制等)

数据处理(增加、删除、修改数据)

用剪贴板复制/粘贴数据

表格功能补充

表格排序

表格格式设定

自动适应列宽

图表打印

各表格类型的补充功能

节点/单元表格

结果表格

  • 命 令

从主菜单中选择模型 > 材料和截面特性 > 材料表格...

从树形菜单的表格表单中选择表格 > 结构表格 > 特性值 > 材料

快捷键： [Ctrl]+[Alt]+L

  • 输 入(参见" 材料 ")

参考表格工具的使用输入或修改下列数据：

号：材料编号。

名称：材料名称。

类型：材料类型。

规范：使用的标准材料规范。

标准材料名称：具体的标准材料名称。

热量单位：选择热量单位。

使用质量密度

弹性模量

泊松比

热膨胀系数

容重：单位体积重量。

注：
输入钢-混凝土材料(SRC)时，混凝土(RC)数据保存在规范2和标准材料名称2内。

质量密度

规范2、标准材料名称2.....质量密度2：同上。

塑性材料：选择塑性材料特性。

比热

热传导率

材料类型：选择各向同性或者正交异性材料。

当选择正交异性材料时，输入以下数据：

剪切模量_xy：材料xy平面内的剪切模量。

弹性模量_y：材料y方向的弹性模量。

线膨胀系数_y：材料y方向的线膨胀系数。

剪切模量_xz：材料xz平面内的剪切模量。

泊松比_xz：材料xz平面内的泊松比。

弹性模量_z：材料z方向的弹性模量。

线膨胀系数_z：材料z方向的线膨胀系数。

剪切模量_yz：材料yz平面内的剪切模量。

泊松比_yz：材料yz平面内的泊松比。


19_截面表格

Home > midas Gen 2017 > 05_特性 > 06_特性表格 > 02_截面

截面表格

  • 功 能

以电子表格形式输入或修改性单元的截面特性。

MIDAS软件中的表格工具提供了各种强大的内置功能。详细说明参见下列各项：

表格工具的使用

术语

掌握使用方法

基本说明(单元移动、选择、大小控制等)

数据处理(增加、删除、修改数据)

用剪贴板复制/粘贴数据

表格功能补充

表格排序

表格格式设定

自动适应列宽

图表打印

各表格类型的补充功能

节点/单元表格

结果表格

  • 命 令

从主菜单中选择模型 > 材料和截面特性 > 截面表格...

从树形菜单的表格表单中选择表格 > 结构表格 > 特性值 > 截面

快捷键： [Ctrl]+[Alt]+S

  • 输 入(参见" 截面 ")

参考表格工具的使用输入或修改下列数据：

总表

不管截面是如何定义的，总表描述已定义的所有截面特性。表格工具功能在这里不适用，要修改或增加截面数据，使用按截面数据定义的方法分类的各分表格。

号：截面编号。

类型：截面类型。

形状：截面形状符号。例如H型、2L型等。

名称：截面名称。

面积：横截面面积。

Asy：单元局部坐标系y轴方向抵抗剪力的有效抗剪面积。

Asz：单元局部坐标系z轴方向抵抗剪力的有效抗剪面积。

Ixx：绕单元局部坐标系x轴的扭转惯性距。

Iyy：绕单元局部坐标系y轴的惯性距。

Izz：绕单元局部坐标系z轴的惯性距。

Cyp：沿单元局部坐标系+y轴方向，单元截面中和轴到边缘纤维的距离。

Cym：沿单元局部坐标系-y轴方向，单元截面中和轴到边缘纤维的距离。

Czp：沿单元局部坐标系+z轴方向，单元截面中和轴到边缘纤维的距离。

Czm：沿单元局部坐标系-z轴方向，单元截面中和轴到边缘纤维的距离。

Qyb：沿单元局部坐标系z轴方向的剪切系数。

Qzb：沿单元局部坐标系y轴方向的剪切系数。

周长(外)：截面外轮廓周长。

周长(内)：箱型或管型截面的内轮廓周长。

数据库/用户

号：截面编号。

名称：截面名称。

形状：截面形状符号。例如H型、2L型等。

数据库：使用的标准规范数据库名称。

截面：数据库中截面名称。

偏心：相邻单元截面的对齐位置。

焊接组合：有时显示为型钢。

尺寸1～尺寸6：钢截面的主要尺寸。

面积：横截面面积。

Asy：单元局部坐标系y轴方向抵抗剪力的有效抗剪面积。

Asz：单元局部坐标系z轴方向抵抗剪力的有效抗剪面积。

Ixx：绕单元局部坐标系x轴的扭转惯性距。

Iyy：绕单元局部坐标系y轴的惯性距。

Izz：绕单元局部坐标系z轴的惯性距。

Cyp：沿单元局部坐标系+y轴方向，单元截面中和轴到边缘纤维的距离。

Cym：沿单元局部坐标系-y轴方向，单元截面中和轴到边缘纤维的距离。

Czp：沿单元局部坐标系+z轴方向，单元截面中和轴到边缘纤维的距离。

Czm：沿单元局部坐标系-z轴方向，单元截面中和轴到边缘纤维的距离。

Qyb：沿单元局部坐标系z轴方向的剪切系数。

Qzb：沿单元局部坐标系y轴方向的剪切系数。

周长(外)：截面外轮廓周长。

周长(内)：箱型或管型截面的内轮廓周长。

数值

号：截面编号

形状：截面形状符号。例如H型、2L型等。

名称：截面名称。

偏心：相邻单元截面的对齐位置。

焊接组合：有时显示为型钢。

尺寸1～尺寸6：钢截面的主要尺寸。

面积：横截面面积。

Asy：单元局部坐标系y轴方向抵抗剪力的有效抗剪面积。

Asz：单元局部坐标系z轴方向抵抗剪力的有效抗剪面积。

Ixx：绕单元局部坐标系x轴的扭转惯性距。

Iyy：绕单元局部坐标系y轴的惯性距。

Izz：绕单元局部坐标系z轴的惯性距。

Cyp：沿单元局部坐标系+y轴方向，单元截面中和轴到边缘纤维的距离。

Cym：沿单元局部坐标系-y轴方向，单元截面中和轴到边缘纤维的距离。

Czp：沿单元局部坐标系+z轴方向，单元截面中和轴到边缘纤维的距离。

Czm：沿单元局部坐标系-z轴方向，单元截面中和轴到边缘纤维的距离。

Qyb：沿单元局部坐标系z轴方向的剪切系数。

Qzb：沿单元局部坐标系y轴方向的剪切系数。

周长(外)：截面外轮廓周长。

周长(内)：箱型或管型截面的内轮廓周长。

组合截面

号：截面编号。

形状：截面形状符号。

RBO：矩形砼-钢箱形-空心

RBC：矩形砼-钢箱形-实心

RPO：矩形砼-钢管形-空心

RPC：矩形砼-钢管形-实心

CBO：圆形砼-钢箱形-空心

CBC：圆形砼-钢箱形-实心

CPO：圆形砼-钢管形-空心

CPC：圆形砼-钢管形-实心

EBC：钢箱形-砼

EPC：钢管形-砼

RIB：矩形砼-工字钢

CIB：圆形砼-工字钢

名称：截面名称。

钢材数据库：使用的标准规范数据库名称。

钢材名称：标准钢材截面名称。

钢材名称2：另外一种组合钢材截面名称。

钢材组合：有时显示为钢材型钢。

钢材尺寸1～尺寸8：钢截面的主要尺寸。

混凝土尺寸1～尺寸2：砼截面的主要尺寸。

材料弹性模量：钢材与混凝土弹性模量之比(Es/Ec)。

材料容重：钢与砼容重之比(Ds/Dc)。

材料Ps：钢泊松比

材料Pc：砼泊松比

材料刚度系数：换算刚度时，混凝土截面刚度的折减值。

材料等效替换：计算组合截面刚度时指定以钢材为基准。

注：
MIDAS计算钢骨砼截面刚度时，将砼截面换算为等效钢材截面。

面积：横截面面积。

Asy：单元局部坐标系y轴方向抵抗剪力的有效抗剪面积。

Asz：单元局部坐标系z轴方向抵抗剪力的有效抗剪面积。

Ixx：绕单元局部坐标系x轴的扭转惯性距。

Iyy：绕单元局部坐标系y轴的惯性距。

Izz：绕单元局部坐标系z轴的惯性距。

Cyp：沿单元局部坐标系+y轴方向，单元截面中和轴到边缘纤维的距离。

Cym：沿单元局部坐标系-y轴方向，单元截面中和轴到边缘纤维的距离。

Czp：沿单元局部坐标系+z轴方向，单元截面中和轴到边缘纤维的距离。

Czm：沿单元局部坐标系-z轴方向，单元截面中和轴到边缘纤维的距离。

Qyb：沿单元局部坐标系z轴方向的剪切系数。

Qzb：沿单元局部坐标系y轴方向的剪切系数。

周长(外)：截面外轮廓周长。

周长(内)：箱型或管型截面的内轮廓周长。

型钢组合

号：截面编号。

形状：截面形状符号。

名称：截面名称。

数据库：使用的标准规范数据库名称。

截面1名称：组成型钢组合截面的截面1名称。

截面1尺寸1～尺寸5：截面1的主要尺寸。

截面2名称：组成型钢组合截面的截面2名称。

截面2尺寸1～尺寸4：截面2的主要尺寸。

面积：横截面面积。

Asy：单元局部坐标系y轴方向抵抗剪力的有效抗剪面积。

Asz：单元局部坐标系z轴方向抵抗剪力的有效抗剪面积。

Ixx：绕单元局部坐标系x轴的扭转惯性距。

Iyy：绕单元局部坐标系y轴的惯性距。

Izz：绕单元局部坐标系z轴的惯性距。

Cyp：沿单元局部坐标系+y轴方向，单元截面中和轴到边缘纤维的距离。

Cym：沿单元局部坐标系-y轴方向，单元截面中和轴到边缘纤维的距离。

Czp：沿单元局部坐标系+z轴方向，单元截面中和轴到边缘纤维的距离。

Czm：沿单元局部坐标系-z轴方向，单元截面中和轴到边缘纤维的距离。

Qyb：沿单元局部坐标系z轴方向的剪切系数。

Qzb：沿单元局部坐标系y轴方向的剪切系数。

周长(外)：截面外轮廓周长。

周长(内)：箱型或管型截面的内轮廓周长。

变截面

号：截面编号。

形状：截面形状符号。

名称：截面名称。

数据库：使用的标准规范数据库名称。

截面i名称：i端截面名称。

截面i尺寸1～尺寸6：i端截面的主要尺寸。

截面j名称：j端截面名称。

截面j尺寸1～尺寸6：j端截面的主要尺寸。

Iyy的变化：绕单元局部坐标系y轴的惯性距的变化规律。

Izz的变化：绕单元局部坐标系z轴的惯性距的变化规律。

面积：横截面面积。

Asy：单元局部坐标系y轴方向抵抗剪力的有效抗剪面积。

Asz：单元局部坐标系z轴方向抵抗剪力的有效抗剪面积。

Ixx：绕单元局部坐标系x轴的扭转惯性距。

Iyy：绕单元局部坐标系y轴的惯性距。

Izz：绕单元局部坐标系z轴的惯性距。

Cyp：沿单元局部坐标系+y轴方向，单元截面中和轴到边缘纤维的距离。

Cym：沿单元局部坐标系-y轴方向，单元截面中和轴到边缘纤维的距离。

Czp：沿单元局部坐标系+z轴方向，单元截面中和轴到边缘纤维的距离。

Czm：沿单元局部坐标系-z轴方向，单元截面中和轴到边缘纤维的距离。

Qyb：沿单元局部坐标系z轴方向的剪切系数。

Qzb：沿单元局部坐标系y轴方向的剪切系数。

周长(外)：截面外轮廓周长。

周长(内)：箱型或管型截面的内轮廓周长。


20_厚度表格

Home > midas Gen 2017 > 05_特性 > 06_特性表格 > 03_厚度

厚度表格

  • 功 能

以电子表格形式输入或修改性单元的厚度特性。

MIDAS软件中的表格工具提供了各种强大的内置功能。详细说明参见下列各项：

表格工具的使用

术语

掌握使用方法

基本说明(单元移动、选择、大小控制等)

数据处理(增加、删除、修改数据)

用剪贴板复制/粘贴数据

表格功能补充

表格排序

表格格式设定

自动适应列宽

图表打印

各表格类型的补充功能

节点/单元表格

结果表格

  • 命 令

从主菜单中选择模型 > 材料和截面特性 > 厚度表格...

从树形菜单的表格表单中选择表格 > 结构表格 > 特性值 > 厚度

快捷键：[Ctrl]+[Alt]+T

  • 输 入(参见"厚度")

参考表格工具的使用输入或修改下列数据：

号：厚度编号

类型：是否设置加劲肋。

面内＝面外：是或者否。

厚度-面内：面内厚度值。

厚度-面外：面外厚度值。

偏心：是否偏心。

偏心类型

偏心率

偏心值


21_修改单元依存材料特性表格

Home > midas Gen 2017 > 05_特性 > 06_特性表格 > 04_修改时间依存材料特性

修改单元依存材料特性表格

  • 功 能

以电子表格形式输入或修改构件的理论厚度数据。

MIDAS软件中的表格工具提供了各种强大的内置功能。详细说明参见下列各项：

表格工具的使用

术语

掌握使用方法

基本说明(单元移动、选择、大小控制等)

数据处理(增加、删除、修改数据)

用剪贴板复制/粘贴数据

表格功能补充

表格排序

表格格式设定

自动适应列宽

图表打印

各表格类型的补充功能

节点/单元表格

结果表格

  • 命 令

从主菜单中选择模型 > 材料和截面特性 > 修改单元依存材料特性表格...

从树形菜单的表格表单中选择表格 > 结构表格 > 特性值 > 修改单元依存材料特性

  • 输 入(参见"修改单元依存材料特性")。

参考表格工具的使用输入或修改下列数据：

单元：单元号。

类型：构件理论厚度或者体积-面积比。

h：构件的理论厚度数值。

V/S:构件体积-面积比的数值。


23_非弹性铰表格

Home > midas Gen 2017 > 05_特性 > 06_特性表格 > 05_非弹性铰

非弹性铰表格

  • 功 能

在电子表格中输入或者修改单元非弹性铰特性值

MIDAS软件中的表格工具提供了各种强大的内置功能。详细说明参见下列各项：

表格工具的使用

术语

掌握使用方法

基本说明(单元移动、选择、大小控制等)

数据处理(增加、删除、修改数据)

用剪贴板复制/粘贴数据

表格功能补充

表格排序

表格格式设定

自动适应列宽

图表打印

各表格类型的补充功能

节点/单元表格

结果表格

  • 命 令

从主菜单中选择模型 > 材料和截面特性 > 非弹性铰特性值表格...

从树形菜单的表格表单中选择表格 > 结构表格 > 特性值 > 非弹性铰

  • 输 入

参考非弹性铰特性值在以下表格中输入或修改数据：

单元：单元号

非弹性铰特性值：相应单元的非弹性铰特性值


22_墙刚度系数表格

Home > midas Gen 2017 > 05_特性 > 06_特性表格 > 06_墙刚度放大系数表格

墙刚度系数表格

  • 功 能

    （参见墙刚度系数）

    Gen的表格工具提供各种强大的内置功能。详细说明参见下列各项：

    表格工具的使用

    术语

    掌握使用方法

    基本说明(单元移动、选择、大小控制等)

    数据处理(增加、删除、修改数据)

    用剪贴板复制/粘贴数据

    表格功能补充

    表格排序

    表格格式设定

    自动适应列宽

    图表打印

    各表格类型的补充功能

    节点/单元表格

    结果表格

  • 命 令

从主菜单中选择模型> 材料和截面特性> 墙刚度系数表格...

从树形菜单的表格表单中选择表格 > 结构表格>特性值>墙刚度系数

  • 输 入

参考表格工具的使用查看如下表格：

单元：单元号 剪力：剪切刚度

墙号：墙号 弯矩：抗弯刚度


01_一般支承

Home > midas Gen 2017 > 06_边界 > 01_一般支承

一般支承

  • 功 能

约束选定节点的自由度，或者替换或删除先前定义的支承条件。

  • 命 令

从主菜单中选择模型 > 边界条件 > 一般支承...

从树形菜单的菜单表单中选择几何模型 > 边界条件 > 一般支承

  • 输 入

单击一般支承右边的 [image] ，将显示一般支承表格。

边界组名称

选择定义的边界将要所属的边界组。当不需要指定组时，选择"默认值"。当需要添加和编辑边界组时，可以点击右面的 [image] ，将弹出"定义边界组"对话框。

选择

添加：对选定的节点赋予或添加新的约束。

替换：替换先前定义的在选定节点上的约束。

删除：删除先前定义的在选定节点上的约束。

支承条件类型(局部方向)

选择要约束的节点的自由度分量。定义了节点局部坐标系时，自由度的方向为局部坐标系，否则为整体坐标系方向。

D-ALL：全部平移自由度。

Dx：整体坐标系X轴方向(或节点局部坐标x轴方向)的平移自由度。

Dy：整体坐标系Y轴方向(或节点局部坐标y轴方向)的平移自由度。

Dz：整体坐标系Z轴方向(或节点局部坐标z轴方向)的平移自由度。

R-ALL：全部旋转自由度。

Rx：绕整体坐标系X轴方向(或节点局部坐标x轴方向)的旋转自由度。

Ry：绕整体坐标系Y轴方向(或节点局部坐标y轴方向)的旋转自由度。

Rz：绕整体坐标系Z轴方向(或节点局部坐标z轴方向)的旋转自由度。

Rw：翘曲自由度


02_节点弹性支承

Home > midas Gen 2017 > 06_边界 > 02_弹性支承 > 01_节点弹性支承

节点弹性支承

  • 功 能

在GCS或节点局部坐标系的各个方向输入选定节点的弹性刚度，也可以替换或删除先前已定义的弹性支承刚度。

  • 命 令

从主菜单中选择模型 > 边界条件 > 节点弹性支承...

从树形菜单的菜单表单中选择几何模型 > 边界条件 > 节点弹性支承

  • 输 入

单击节点弹性支承右边的 [image] ，将显示节点弹性支承表格。

边界组名称

选择定义的边界将要所属的边界组。当不需要指定组时，选择"默认值"。当需要添加和编辑边界组时，可以点击右面的 [image] ，将弹出"定义边界组"对话框。

选择

添加：对选定的节点增加新的弹性支承刚度。

替换：替换先前定义的选定节点的弹性支承刚度。

删除：删除先前定义的选定节点的弹性支承刚度。

节点弹性支承(局部方向)

线性：输入弹性支承刚度。定义了节点局部坐标系时，支承自由度的方向为局部坐标系，否则为整体坐标系方向。

SDx：整体坐标系X轴方向(或已定义的节点局部坐标系x方向)的弹性支承刚度。

SDy：整体坐标系Y轴方向(或已定义的节点局部坐标系y方向)的弹性支承刚度。

SDz：整体坐标系Z轴方向(或已定义的节点局部坐标系z方向)的弹性支承刚度。

SRx：绕整体坐标系X轴方向(或已定义的节点局部坐标x轴方向)的转动弹性刚度。

SRy：绕整体坐标系Y轴方向(或已定义的节点局部坐标y轴方向)的转动弹性刚度。

SRz：绕整体坐标系Z轴方向(或已定义的节点局部坐标z轴方向)的转动弹性刚度。

固定：可勾选SDx,SDy,SDz,SRx,SRy,SRz中任意一项或几项。选择后，程序将该方向的刚度自动设置为一较大值。

SDx,SDy,SDz的默认值为10e14, SRx,SRy,SRz的默认值为10e16。

只受压/只受拉：输入只受压/只受拉弹性支承刚度。

刚度：单元坐标系x轴方向的只受拉/只受压弹性支承刚度。

方向：以节点坐标系为基准，设置弹性支承的方向。

多折线形：定义多折线性弹性支承刚度。

多折线类型：对称、非对称。

a--f：输入多点的非线性弹性刚度坐标值。超出范围部分的刚度保持最后一个刚度的斜率。

方向：以节点坐标系为基准，设置弹性支承的方向。


05_面弹性支承

Home > midas Gen 2017 > 06_边界 > 02_弹性支承 > 02_面弹性支承

面弹性支承

  • 功 能

输入平面或实体单元单位支承面上的弹簧刚度形成弹性支承。并可同时形成弹性连接的单元。

该功能主要用于在基础或地下结构分析中考虑地基的弹性支承条件。

  • 命 令

从主菜单中选择模型 > 边界条件 > 面弹性支承...

从树形菜单的菜单表单中选择几何模型 > 边界条件 > 面弹性支承

  • 输 入

单击面弹性支承右边的 [image] ，将显示面弹性支承表单。

注：
在面弹性支承中输入的数据将转换为节点弹性支承或弹性连接数据后保存。

边界组名称

选择定义的边界将要所属的边界组。当不需要指定组时，选择"默认值"。当需要添加和编辑边界组时，可以点击右面的 [image] ，将弹出"定义边界组"对话框。

面弹性支承

转换为：选择形成的刚度(单位面积)数据类型。

  1. 节点弹性支承

  2. 弹性连接

  3. 分布弹性支承

勾选转换为节点弹性支承时

单元类型：

指定要生成节点弹性支承或弹性连接单元的对象单元类型。

  1. 杆系：在梁单元节点上形成节点弹性支承或弹性连接单元

  2. 平面：在平面单元节点上形成节点弹性支承或弹性连接单元

  3. 实体(面)：在实体单元指定平面，形成节点弹性支承或弹性连接单元

  4. 实体(节点)：在实体单元指定节点，形成节点弹性支承或弹性连接单元

    选择节点弹性支承时

    弹性支承类型：线性、只受压、只受拉。

    选择线性时

    基床系数：输入节点局部坐标轴方向的弹性支承刚度。如果没有定义局部坐标轴，按整体坐标轴方向处理。

    Kx：沿节点局部坐标系x轴方向(或整体坐标系X轴方向)单位面积的刚度。

    Ky：沿节点局部坐标系y轴方向(或整体坐标系Y轴方向)单位面积的刚度。

    Ky：沿节点局部坐标系z轴方向(或整体坐标系Z轴方向)单位面积的刚度。

    选择只受压/只受拉时

    方向：输入节点弹性支承的方向。

    地基弹性模量：输入前一项指定方向的弹性支承刚度。

    选择弹性连接时

    方向：弹性连接单元的方向。

    法向(+)：表面法向(+)(与节点相关的周围各面的平均法线方向)。

    法向(-)：表面法向(-)(与节点相关的周围各面的平均法线方向)。

    注：
    平面单元的法线方向根据节点输入次序按右手法则确定。对实体单元，法向定义为远离单元表面的方向。

    UCS-x(+)：UCS +x方向(或GCS +X方向)。

    UCS-x(-)：UCS -x方向(或GCS -X方向)。

    UCS-y(+)：UCS +y方向(或GCS +Y方向)。

    UCS-y(-)：UCS -y方向(或GCS -Y方向)。

    UCS-z(+)：UCS +z方向(或GCS +Z方向)。

    UCS-z(-)：UCS -z方向(或GCS -Z方向)。

    基床系数：地基刚度。

    弹性连接长度：弹性连接单元的长度,该数据对分析结果没有影响，只是在分析中定义一个内部矢量。

    只受拉，只受压：选中选项指定弹性连接为只受拉或只受压单元。

    选择分布弹性支承时

    单元截面：

    指定要生成分布弹性支承的对象单元类型。

    杆系：沿梁长生产分布弹性支承

    截面：节点/单元

    局部轴：y/z

    宽度：计算单位长度弹性支承刚度时所考虑的梁单元宽度

    类型：线性、只受压、只受拉

    基床系数：地基刚度

    平面（面）：在面单元的面上生成分布弹性支承

    平面（边）：在面单元的边上生成分布弹性支承

    实体（面）：在实体单元的面上生成分布弹性支承


03_定义一般弹性支承类型

Home > midas Gen 2017 > 06_边界 > 02_弹性支承 > 03_一般弹性支承 > 01_定义一般弹性支承类型

定义一般弹性支承类型

  • 功 能

定义任意节点一般弹性支承刚度值。

  • 命 令

从主菜单中选择模型 > 边界条件 > 定义一般弹性支承类型...

从树形菜单的菜单表单中选择几何模型 > 边界条件 > 定义一般弹性支承类型

  • 输 入

定义一般弹性支承类型对话框

名称：输入节点一般弹性支承名称。

输入方法：

刚度矩阵：默认勾选

质量矩阵: 勾选后输入质量矩阵.

阻尼矩阵: 勾选后输入阻尼矩阵

耦合的弹性刚度：

输入节点一般弹性支承刚度。定义了节点局部坐标系时，自由度的方向为局部坐标系方向，否则为整体坐标系方向。

SDx-SDx：整体坐标系X轴方向(或已定义的节点局部坐标系x方向)的弹性支承刚度。

SDx-SDy：整体坐标系X轴方向和Y轴方向(或已定义的节点局部坐标系x方向和y方向)的相关弹性支承刚度。

SRz-SRz：绕整体坐标系z方向的转动弹性刚度(或已定义的节点局部坐标系z方向)的转动弹性支承刚度。

注：
一般弹性支承通常用于反映桩的支承刚度，结构分析时可以考虑与各个自由度有关的桩支承刚度。

在典型的建筑结构中，分析模型不包括桩基础。而是假定在基础底面或桩帽处存在弹性边界。下面的通用刚度给出了桩单元的实际刚度。对斜桩，用节点局部坐标轴计算斜向的刚度。

一般弹性支承的刚度组成

注：

弹性模量：E

截面惯性矩： Iy, Iz

横截面面积： A

长度： L(未考虑剪切变形)。


04_一般弹性支承

Home > midas Gen 2017 > 06_边界 > 02_弹性支承 > 03_一般弹性支承 > 02_一般弹性支承

一般弹性支承

  • 功 能

分配定义的一般弹性支撑类型，或输入节点通用刚度矩阵(6×6)。其中包括选定的节点在整体坐标系或节点局部坐标系内各自由度之间相关的刚度，也可以替换或删除先前定义的弹性支承刚度。

注：分配一般弹性支承前首先定义节点一般弹性支承刚度。

  • 命 令

从主菜单中选择模型 > 边界条件 > 一般弹性支承...

从树形菜单的菜单表单中选择几何模型 > 边界条件 > 一般弹性支承

  • 输 入

单击一般弹性支承右边的 [image] ，将显示一般弹性支承表格。

边界组名称

选择定义的边界将要所属的边界组。当不需要指定组时，选择"默认值"。当需要添加和编辑边界组时，可以点击右面的 [image] ，将弹出"定义边界组"对话框。

选择

添加/替换：输入或替换选定节点的新的一般弹性支承刚度。

删除：删除先前输入的选定节点的一般弹性支承刚度。

一般弹性支承

一般弹性支承类型：从先前定义的一般弹性支承刚度中选择要输入的节点一般弹性支承刚度。(参见"定义一般弹性支承类型")

单击右边的 [image] 显示一般弹性支承类型对话框。

SDx：整体坐标系X轴方向(或已定义的节点局部坐标系x方向)的弹性支承刚度。

SDy：整体坐标系Y轴方向(或已定义的节点局部坐标系y方向)的弹性支承刚度。

SDz：整体坐标系Z轴方向(或已定义的节点局部坐标系z方向)的弹性支承刚度。

SRx：绕整体坐标系X轴方向(或已定义的节点局部坐标x轴方向)的转动弹性刚度。

SRy：绕整体坐标系Y轴方向(或已定义的节点局部坐标y轴方向)的转动弹性刚度。

SRz：绕整体坐标系Z轴方向(或已定义的节点局部坐标z轴方向)的转动弹性刚度。

注： 在一般弹性支承类型对话框中，上述6个弹性支承刚度值只表示6 x 6阶刚度矩阵中的6个对角线刚度值。实际分配给节点的刚度值为6 x 6阶刚度。

质量：是否考虑一般弹性支承的质量矩阵；

阻尼：是否考虑一般弹性支承的阻尼矩阵；

注：如需考虑一般弹性支承的质量矩阵和阻尼矩阵，则需要在“模型->边界条件->定义一般弹性支承类型”中进行定义。


06_桩弹性支承

Home > midas Gen 2017 > 06_边界 > 02_弹性支承 > 04_桩弹性支承

桩弹簧支承

  • 功 能

生成桩周土弹簧，桩周横向土弹簧用对称的非线性弹簧模拟，桩侧土弹簧用线性弹簧模拟。程序将自动计算土弹簧刚度，可以在节点弹性支承表格中查看。

  • 命 令

从主菜单中选择模型 > 边界条件 > 桩弹簧支承

从树形菜单的菜单表单中选择模型 > 边界条件 > 桩弹簧支承

  • 输 入

边界组名称

选择定义的边界将要所属的边界组。当不需要指定组时，选择"默认值"。当需要添加和编辑边界组时，可以点击右面的 [image] ，将弹出"定义边界组"对话框。

桩弹性支承数据

土壤类型：指定土壤类型。砂、软土、硬土，不同土的刚度计算方法不一样。

地面标高：地面Z坐标。

桩直径

土单位重量（r）

静止土压力（KO）：静止土压力系数

地基反力系数（Kh）：地基反力系数

选择砂时

内摩擦角（Phi）：土的内摩察角

初始土模量（Kl）：根据相对密度计算的系数，用于计算桩周横向土弹簧的刚度，参见如下K值计算。

选择软土或硬土时

三轴试验最大应力点1/2应变值（e50）

无排水粘聚力（cu）

桩周横向非线性土弹簧刚度

某一特定深度处的横向图抗力与横向位移Y之间的关系如左图所示。

Pk, Pm, Pu, Yk, Ym 和Yu的值根据具体深度确定。（如，桩弹簧所在位置）
Pu的计算方法根据土类型的不同而变化。Pk, Pm, Yk, Ym 和 Yu的值根据Pu计算。
计算方法分为两种主要情况-砂和粘土。 软土和硬土的J值不同。

砂土Pu值计算：

Xt值表示下列两式中Pu值相等时的深度。

这里， Pu：单位长度土极限抗力； Ф’：砂土内摩察角

A：经验调整系数； &alpha;=Ф’/2

X：埋深； ?=45°+&alpha;

D：桩径；&gamma;：土容重

K0：静止土压力系数；

Ka：动土压力系数tan?^2

砂土Pu值计算：

Xt值表示下列两式中Pu值相等时的深度。

这里， Pu：单位长度土极限抗力；&gamma;：土容重

su：不排水抗剪强度； J:经验常数，软土为0.5，硬土为0.25.

cu:不排水粘聚力 X：埋深；

D：桩径；Xr：6D/[&sigma;v/su+J]

k及m计算

这里，A,B：经验调整系数

n=[Pm(Yu-Ym)]/[Ym(Pu-Pm)]

k1:与相对密度有关的系数；

相对密度 k1(MN/m2/m)
松散
5.43
中等
16.29
密实
33.93

弹簧刚度计算

弹簧刚度由单位面积刚度与计算面积相乘得到。

桩周竖向线性土弹簧刚度

这里， Ф’：内摩察角

X：埋深；

D：桩径；&gamma;：土容重

K0：静止土压力系数；

桩周土线弹性竖向弹簧的方向应垂直于地面（GC S- 'z方向）。即便桩不垂直于地面，桩上节点的z方向（节点局部坐标轴）应与整体坐标系的Z方向一致。


06_弹性连接

Home > midas Gen 2017 > 06_边界 > 03_连接 > 01_弹性连接

弹性连接

  • 功 能

形成或删除弹性连接。由用户定义弹性连接及其弹性连接的两个节点。

  • 命 令

从主菜单中选择模型 > 边界条件 > 弹性连接...

从树形菜单的菜单表单中选择几何模型 > 边界条件 > 弹性连接

  • 输 入

单击弹性连接右边的 [image] ，将显示弹性连接表格。

边界组名称

选择定义的边界将要所属的边界组。当不需要指定组时，选择"默认值"。当需要添加和编辑边界组时，可以点击右面的 [image] ，将弹出"定义边界组"对话框。

选项

添加：输入或替换弹性连接。

删除：删除先前输入的弹性连接。

弹性连接数据

类型：指定弹性连接类型。

一般：一般弹性连接(6个自由度)。

刚性：刚性连接单元。

仅受拉：只受拉弹性连接。

仅受压：只受压弹性连接。

多折线：多折线形弹性连接。

注：
当指定弹性连接为仅受拉或仅受压类型时，只能使用单元的轴向刚度。弹性连接与只受拉/压单元相同，遵循主控数据中定义的迭代法。

选择一般/刚性/仅受拉/仅受压时

SDx：单元局部坐标系x轴方向的刚度。

SDy：单元局部坐标系y轴方向的刚度。

SDz：单元局部坐标系z轴方向的刚度。

SRx：绕单元局部坐标系x轴的转动刚度。

SRy：绕单元局部坐标系y轴的转动刚度。

SRz：绕单元局部坐标系z轴的转动刚度。

选择多折线时

曲线形状：对称/非对称c

曲线控制点数：3-5

方向：弹性连接方向

剪切弹簧位置

输入剪切型弹性支承在弹性连接单元的位置。该项主要为了考虑弹性支承两端因剪力传递的弯矩。当弹性连接两端作用有弯矩和剪力时，弯矩通过弹性连接的旋转刚度传递，剪力引起的弯矩通过定义的剪切型弹性支承位置通过计算后进行传递。

SDy：输入局部坐标系y轴方向的剪切型弹性支承的位置(按到端点I的距离比输入)。

SDz：输入局部坐标系z轴方向的剪切型弹性支承的位置(按到端点I的距离比输入)。

Beta角：输入弹性连接单元的角度。

两点：输入弹性连接单元的两个节点号。

复制弹性连接：复制指定的弹性连接条件。

当选择节点增量时，输入复制次数和节点号增量。

当选择距离时，选择复制方向轴，指定间距。


12_刚性连接

Home > midas Gen 2017 > 06_边界 > 03_连接 > 02_刚性连接

刚性连接

  • 功 能

强制某些节点(从属节点)的自由度从属于某节点(主节点)。

包括从属节点的刚度分量在内的从属节点的所有属性(节点荷载或节点质量)均将转换为主节点的等效分量。

  • 命 令

从主菜单中选择模型 > 边界条件 > 刚性连接...

从树形菜单的菜单表单中选择模型 > 边界条件 > 刚性连接

  • 输 入

单击刚性连接右边的 [image] ，将显示刚性连接表格。

边界组名称

选择定义的边界将要所属的边界组。当不需要指定组时，选择"默认值"。当需要添加和编辑边界组时，可以点击右面的 [image] ，将弹出"定义边界组"对话框。

选项

添加：指定选定的节点为从属节点，或修改已定义的刚性连接

删除：删除选定节点的刚性连接条件

主节点

主节点号：输入主节点编号。用键盘直接键入主节点编号，或单击输入区并点击相应节点

注意从属节点用选择确定(鼠标选择的方法

从刚性连接中解除从属节点：当选择删除时会激活该选项

刚性连接的自由度

指定从属节点从属于主节点的自由度

DX：整体坐标系X轴方向的平移自由度

DY：整体坐标系Y轴方向的平移自由度

DZ：整体坐标系Z轴方向的平移自由度

RX：绕整体坐标系X轴的旋转自由度

RY：绕整体坐标系Y轴的旋转自由度

RZ：绕整体坐标系Z轴的旋转自由度

类型

下列按钮简化上述各数据输入：

：刚体连接。

：整体坐标系X-Y平面内刚性平面连接。

：整体坐标系Y-Z平面内刚性平面连接。

：整体坐标系X-Z平面内刚性平面连接。

复制刚性连接

复制在刚性连接的自由度中已定义的刚性连接条件。

方向：指定要复制的轴的方向。

间距：指定要复制的距离。


07_一般连接特性值

Home > midas Gen 2017 > 06_边界 > 03_连接 > 03_一般连接 > 01_一般连接特性

一般连接特性值

  • 功 能

建立、修改或删除一般连接的特性值。

非线性连接单元只有在做边界非线性动力分析时才体现其动力非线性特性，当做线性和非线性静力分析或线性动力分析时，非线性连接单元将作为等效连接单元参与计算。

  • 命 令

从主菜单中选择模型 > 边界条件 > 一般连接特性值...

从树形菜单的菜单表单中选择几何模型 > 边界条件 > 一般连接特性值

  • 输 入

当需要建立非线性连接的特性值时，点击 [image] 。

当需要编辑非线性连接的特性值时，可以先在目录列表中选择相应的非线性连接特性，然后点击 [image] 。

当需要删除非线性连接的特性值时，可以先在目录列表中选择相应的非线性连接特性，然后点击 [image] 。

<图1> 定义非线性连接特性值对话框

<图2> 添加/编辑非线性连接特性值对话框

名称

输入非线性连接特性值的名称。

作用类型

单元：分析过程中不断更新刚度矩阵以反映一般连接的最新非线性特性。

内力：变换基于非线性特性计算得到的单元内力为外力来间接地反映非线性特性。

特性值类型

选择非线性连接特性的类型。

选择单元时，提供弹簧、线性阻尼器、弹簧和线性阻尼器三种非线性连接单元，并可赋予非弹性铰特性值；选择内力时，提供的非线性连接特性的类型有粘弹性消能器(Viscoelastic Damper)、间隙(Gap)、钩(Hook)、滞后系统(Hysteretic System)、铅芯橡胶支承隔震装置(Lead Rubber Bearing Isolator)、摩擦摆隔震装置(Friction Pendulum System Isolator)等六种类型的非线性连接单元。

说明

简单输入对非线性连接特性的描述。

自重：该重量将等分给两个节点，并按静力荷载计算或换算为节点质量。

总重量：输入非线性连接单元的总重量。

集中重量系数：根据输入的集中重量系数，将总重量分配到单元端部节点。

使用质量：用户直接输入一般连接单元添加的质量。

总质量：输入非线性连接单元的总质量。

集中质量系数：根据输入的集中质量系数，将总质量分配到单元端部节点。

线性特性值

选择约束非线性连接单元的六个方向自由度，并输入相应弹性支承的有效支承刚度。

如果没有输入非线性弹性支承的特性值，有效支承刚度将作为线性弹性支承的刚度参与工作。

如果输入了非线性弹性支承的特性值，分两种情况: 一种是做线性或非线性静力分析时，有效支承刚度将按等效的线性弹性支承支承的刚度参与工作；另一种是做动力非线性分析时，有效支承刚度在运算中仅作为假想刚度出现，该假想刚度用于在运算过程中防止结构做刚体运动。

动力非线性分析时，有效支承刚度值过大会引起发散，所以必须输入恰当的值(一般取非线性弹性支承的刚度值即可)。

DOF：选择约束非线性弹性连接单元的自由度。

Dx、Dy、Dz：单元坐标系x、y、z方向的平移自由度。

Rx、Ry、Rz：单元坐标系x、y、z方向的旋转自由度。

刚度：输入有效支承刚度。

阻尼：输入有效阻尼。

耦合：输入6x6 相互耦合的刚度矩阵和阻尼矩阵。

非线性特性值

选择约束非线性连接单元的六个方向自由度，并输入相应非线性连接特性值的有关参数。只有在线性弹性支承值中选择了相应的自由度，才可以在非线性弹性支承值中输入相应自由度方向的非线性连接特性值的参数。

DOF：选择相应自由度，将自动弹出相应的非线性特性值对话框。

非线性特性值：点击，将弹出相应的非线性特性值对话框。

剪切弹性支承位置

只有在线性弹性支承值中选择了Dy或Dz时，才可以选择该项。选择该项后，输入剪切弹性支承距支承I端点的距离比。Dy和Dz分别表示沿单元坐标系y轴和z轴方向的剪切弹性。

输入剪切弹性支承位置后，支承两端的弯矩将因剪切的影响发生变化。两节点的弯矩差=剪力×剪切距离。当不选择该项时，两节点的弯矩相同。

各种类型的非线性连接的特性值参数

在MIDAS软件中提供了六种单元类型的非线性连接。各种非线性连接的特性值参数说明如下：

粘弹性消能器

<图3> 粘弹性消能器??Maxwell模型

粘弹性消能器(Viscoelastic Damper)在六个自由度上由线性弹簧和(非)线性阻尼器并联后与线性弹簧串联而成。MIDAS/Gen提供3中粘弹性消能器模型。

1. Maxwell模型

如下图所示，线性弹簧与阻尼器串联的模型，适用于流动粘弹性装置。

Maxwell模型的力－变形关系式如下：

消能器阻尼(Cd)：输入消能器的阻尼。

参考速度（VO)：一般取1.0。

注：

一般厂家提供的消能器阻尼（Cd）的单位为(力/速度），使用此功能时，首先建议把程序的单位体系转换为厂家提供的消能器阻尼（Cd）的单位后，输入消能器阻尼（Cd）值，参考速度（VO）输入1.0。

阻尼指数(s)：决定粘弹性消能器的非线性特性的常数(粘弹性阻尼力作用方向与位移速度的方向相反，并为速度绝对值的s方成正比。)

注：

非线性阻尼指数一般可取0.35～1.0。

连接弹簧刚度(kb)：将消能器与结构连接起来的弹簧的刚度，其值可以由用户直接输入。当选择"刚接"时，程序将忽视连接弹簧的刚度。

<图4> 粘弹性消能器??Kelvin(voigt)模型

2. Kelvin(voigt)模型

如下图所示，线性弹簧与阻尼器并联的模型，适用于固体粘弹性装置。

Kelvin(voigt)模型的力－变形关系式如下，式中右侧每项的值都是已知值，所以可直接解方程求出作用在消能器上的力。

消能器刚度（kd)：输入消能器刚度。

消能器阻尼(Cd)：输入消能器的阻尼。

参考速度（VO)：一般取1.0。

注：

一般厂家提供的消能器阻尼（Cd）的单位为(力/速度），使用此功能时，首先建议把程序的单位体系转换为厂家提供的消能器阻尼（Cd）的单位后，输入消能器阻尼（Cd）值，参考速度（VO）输入1.0。

阻尼指数(s)：决定粘弹性消能器的非线性特性的常数(粘弹性阻尼力作用方向与位移速度的方向相反，并为速度绝对值的s方成正比。)

注：

非线性阻尼指数一般可取0.35～1.0。

<图5> 粘弹性消能器??Kelvin(voigt)模型

3. 阻尼支撑组合类型（Maxwell+Kelvin)

消能器刚度（kd)：输入消能器刚度。

消能器阻尼(Cd)：输入消能器的阻尼。

参考速度（VO)：一般取1.0。

注：

一般厂家提供的消能器阻尼（Cd）的单位为(力/速度），使用此功能时，首先建议把程序的单位体系转换为厂家提供的消能器阻尼（Cd）的单位后，输入消能器阻尼（Cd）值，参考速度（VO）输入1.0。

阻尼指数(s)：

决定粘弹性消能器的非线性特性的常数(粘弹性阻尼力作用方向与位移速度的方向相反，并为速度绝对值的s方成正比。)

注：

非线性阻尼指数一般可取0.35～1.0。

连接弹簧刚度(kb)：将消能器与结构连接起来的弹簧的刚度，其值可以由用户直接输入。当选择"刚接"时，程序将忽视连接弹簧的刚度。

<图6> 阻尼支撑组合类型（Maxwell+Kelvin)

间隙

<图7> 间隙---非线性弹性支承特性值对话框

当间隙单元两个节点的缩小的相对位移(在六个自由度上各自的相对位移)超过了间隙单元内部的初始间隙时，该方向的刚度将开始发生作用。另外，还可以输入与间隙单元并联的附加线性粘性阻尼器的有效阻尼(图中未显示)。

弹性刚度(k)：间隙单元的弹性刚度。

初始间隙(o)：间隙单元的初始间隙。

钩

<图8> 钩---非线性弹性支承特性值对话框

当钩单元两个节点的缩小的相对位移(在六个自由度上各自的相对位移)超过了钩单元内部的初始间隙时，该方向的刚度将开始发生作用。另外，还可以输入与钩单元并联的附加线性粘性阻尼器的有效阻尼(图中未显示)。

弹性刚度(k)：钩单元的弹性刚度。

初始间隙(o)：钩单元的初始间隙。

滞后系统

<图9> 滞后系统---非线性弹性支承特性值对话框

滞后系统(Hysteretic System)由在六个自由度上分别具有单向塑性(Uniaxial Plasticity)的弹簧组成。另外，还可以输入与滞后系统并联的附加线性粘性阻尼器的有效阻尼(图中未显示)。

弹性刚度(k)：弹簧屈服前的初期刚度。

屈服强度(Fy)：弹簧的屈服强度。

屈服后刚度与弹性刚度之比(r)：屈服后的切线刚度与初期弹性刚度之比。

屈服指数(s)：决定屈服位置曲线形状的参数。(该值越大，曲线越接近二直线模型。)

滞后循环参数(α)：决定恢复力曲线形状的参数。

滞后循环参数(β)：决定恢复力曲线形状的参数。

铅芯橡胶支承隔震装置

铅芯橡胶支承隔震装置(Lead Rubber Bearing Isolator)中的两个剪切弹性支承具有二轴塑性(Biaxial Plasticity)相关特性，其余四个自由度具有线性弹性特性。另外，还可以输入与滞后系统并联的附加线性粘性阻尼器的有效阻尼(图中未显示)。

剪切弹性支承的参数如下:

<图10> 铅芯橡胶支承隔震装置-剪切弹性支承对话框

弹性刚度(k)：弹簧屈服前的初期刚度。

屈服强度(Fy)：弹簧的屈服强度。

屈服后刚度与弹性刚度之比(r)：屈服后的切线刚度与初期弹性刚度之比。

屈服指数(s)：决定屈服位置曲线形状的参数。(该值越大，曲线越接近二直线模型。)

滞后循环参数(α)：决定恢复力曲线形状的参数。

滞后循环参数(β)：决定恢复力曲线形状的参数。

轴向和三个旋转方向的弹性支承的参数如下:

<图11> 铅芯橡胶支承隔震装置-轴向或旋转弹性支承对话框

弹性刚度(k)：弹性支承刚度。

摩擦摆隔震装置

摩擦摆隔震装置(Friction Pendulum System Isolator)中的两个剪切弹性支承具有二轴塑性(Biaxial Plasticity)相关特性，轴向初始间隙为零的间隙弹性支承，其余三个旋转自由度具有线性弹性特性。另外，还可以输入与滞后系统并联的附加线性粘性阻尼器的有效阻尼(图中未显示)。

摩擦摆隔震装置得轴向弹性支承的参数如下:

<图12> 摩擦摆隔震装置-间隙型轴向弹性支承对话框

弹性刚度(k)：轴向弹性刚度。

初始间隙(o)：轴向初始间隙(值为零，不能修改)。

剪切弹性支承的参数如下:

<图13> 摩擦摆隔震装置-剪切弹性支承对话框

滑动前刚度(k)：发生滑动前的初期刚度。

位移速度慢时的摩擦系数(μs)：位移速度慢时，摩擦面的摩擦系数。

位移速度快时的摩擦系数(μf)：位移速度快时，摩擦面的摩擦系数。

摩擦系数变化参数(s)：与位移速度对应的决定摩擦系数变化的参数。

摩擦面曲率半径(R)：摩擦面的曲率半径。

滞后循环参数(α)：决定恢复力曲线形状的参数。

滞后循环参数(β)：决定恢复力曲线形状的参数。

三个旋转方向的弹性支承的参数如下:

<图14> 摩擦摆隔震装置-旋转弹性支承对话框

弹性刚度(k)：弹性支承刚度。


08_一般连接

Home > midas Gen 2017 > 06_边界 > 03_连接 > 03_一般连接 > 02_一般连接

一般连接

  • 功 能

添加或删除非线性连接。由用户定义非线性连接及其非线性连接的两个节点。

  • 命 令

从主菜单中选择模型 > 边界条件 > 一般连接...

从树形菜单的菜单表单中选择几何模型 > 边界条件 > 一般连接

  • 输 入

单击非线性连接右边的 [image] ，将显示非线性连接表格。

边界组名称

选择定义的非线性连接将要所属的边界组。当不需要指定组时，选择"默认值"。当需要添加和编辑边界组时，可以点击右面的 [image] ，将弹出"定义边界组"对话框。

选项

添加：输入或替换非线性连接。

删除：删除已定义的非线性连接。

一般连接数据

一般连接特性值名称：选择非线性连接的特性。当需要建立或编辑非线性连接的特性值时，可以点击右面的 [image] ，将弹出非线性连接特性值对话框。

一般连接特性值类型：显示选择的非线性连接的连接类型。

非弹性铰特性值

名称：选择非弹性铰特性。

参考坐标系

单元：单元坐标系。

整体：整体坐标系。

输入方法：Beta角/参考点/参考向量

输入一般连接单元的角度

两点：输入弹性连接单元的两个节点号

复制一般连接：复制指定的非线性连接

当选择节点增幅时，输入复制次数和节点增幅。

当选择距离时，选择复制轴方向，输入复制间距。


03_修改一般连接特性

Home > midas Gen 2017 > 06_边界 > 03_连接 > 03_一般连接 > 03_修改一般连接特性

修改一般连接特性值

  • 功 能

该功能主要为了在不同荷载工况或不同分析类型下使用不同的边界条件，需要结合分析 > 分配边界转换给荷载工况/分析一起使用。该功能不能在施工阶段分析中使用。

  • 命 令

从主菜单中选择边界 > 一般连接 > 修改一般连接特性值...

从树形菜单的菜单表单中选择模型 > 边界条件 > 修改一般连接特性值

  • 输 入

单击非线性连接右边的 [image] ，将显示非线性连接表格。

边界组名称

选择该边界将要所属的边界组。当不需要指定组时，选择"默认值"。当需要添加和编辑边界组时，可以点击右面的 [image] ，将弹出"定义边界组"对话框。

选项

添加/替换：输入或替换边界。

删除：删除已定义的边界。

两个节点：输入一般连接单元的两个节点号

一般连接号：输入一般连接号

一般连接特性：选择新的一般连接特性

名称：一般连接名称。

类型：一般连接类型。


09_释放梁端约束

Home > midas Gen 2017 > 06_边界 > 04_释放/偏心 > 01_释放梁端约束

释放梁端部约束

  • 功 能

输入梁两端的梁端释放条件(铰接，滑动，滚动，节点和部分固定)，或替换或删除先前输入的梁端释放条件。

  • 命 令

从主菜单中选择模型 > 边界条件 > 释放梁端部约束...

从树菜单的表格表中选择模型 > 边界条件 > 释放梁端部约束

  • 输 入

单击释放梁端约束右边的 [image] ，将显示释放梁端约束表格。

边界组名称

选择定义的边界将要所属的边界组。当不需要指定组时，选择"默认值"。当需要添加和编辑边界组时，可以点击右面的 [image] ，将弹出"定义边界组"对话框。

选择

添加/替换：释放或替换选定的梁单元的端部约束条件。

删除：删除选定的梁单元的端部约束条件。

选择类型和释放比率

决定选定节点在单元局部坐标系中各自由度方向的约束条件。

选择某个方向自由度时，表示将释放该自由度方向上的约束。在后面的输入框中可以输入释放后残留的约束能力(按百分比输入）。例如左图中，i节点(N1端节点)弯矩My系数为0.3，表示My抗弯刚度30%有效。右侧j节点(N2端节点)弯矩My系数为0，表示My抗弯刚度为0，即成为铰支。

Fx：释放单元局部坐标系x轴方向的约束，可按需要输入部分约束比率。

Fy：释放单元局部坐标系y轴方向的约束，可按需要输入部分约束比率。

Fz：释放单元局部坐标系z轴方向的约束，可按需要输入部分约束比率。

Mx：在相应端释放绕单元局部坐标系x轴方向的扭矩，可按需要输入部分约束比率。

My：在相应端释放绕单元局部坐标系y轴方向的弯距，可按需要输入部分约束比率。

Mz：在相应端释放绕单元局部坐标系z轴方向的弯距，可按需要输入部分约束比率。

W：在相应端释放翘曲扭矩，可按需要输入部分约束的比率。

下列按钮简化了上述各数据的输入：

：在梁两端释放绕单元局部坐标系y轴和z轴方向的抗弯约束。

：在梁I端释放绕单元局部坐标系y轴和z轴方向的弯曲刚度。

：在梁J端释放绕单元局部坐标系y轴和z轴方向的弯曲刚度。

：将梁两端的所有释放条件恢复为固定条件。


10_梁端刚域长度

Home > midas Gen 2017 > 06_边界 > 04_释放/偏心 > 02_梁端刚域

设定梁端部刚域

  • 功 能

定义GCS或梁单元局部坐标系下梁两端的刚域长度或考虑节点偏心。

该功能主要适用于梁单元(梁、柱)间的偏心设定。当梁单元间倾斜相交，用户要考虑节点刚域效果时，需使用该功能进行设定。在主菜单中的模型>边界条件>刚域效果只能考虑梁柱直交时的效果。

  • 命 令

从主菜单中选择模型 > 边界条件 > 设定梁端部刚域...

从树形菜单的菜单表单中选择模型 > 边界条件 > 设定梁端部刚域...

  • 输 入

单击梁端刚域右边的 [image] ，将显示梁端刚域表格。

边界组名称

选择定义的边界将要所属的边界组。当不需要指定组时，选择"默认值"。当需要添加和编辑边界组时，可以点击右面的 [image] ，将弹出"定义边界组"对话框。

选择

添加/替换：输入或替换选定的梁单元的梁端刚域长度和节点偏心。

删除：删除先前输入的选定的梁端刚域长度和节点偏心。

梁端部刚域长度

类型

整体坐标系：按整体坐标系方向输入刚域长度。

单元坐标系：按单元局部坐标系x方向输入刚域长度。

类型 = "整体坐标系"时

输入在整体坐标系中的梁端刚域长度，用节点N1(或N2)到刚域点N1'(或N2')的矢量表示

RGDXi：N1端梁端刚域长度矢量在GCS X方向的分量

RGDYi：N1端梁端刚域长度矢量在GCS Y方向的分量

RGDZi：N1端梁端刚域长度矢量在GCS Z方向的分量

RGDXj：N2端梁端刚域长度矢量在GCS X方向的分量

RGDYj：N2端梁端刚域长度矢量在GCS Y方向的分量

RGDZj：N2端梁端刚域长度矢量在GCS Z方向的分量

注:
输入刚域长度后，所有与单元有关的数据(单元局部坐标系，单元长度，单元刚度)均将按照刚域条件由程序内部做相应调整。RGDXi～RGDZj可输入负值

类型 = "单元坐标系"时

输入在单元局部坐标系X方向的梁端刚域长度。

RGDi：N1端在单元局部坐标系(+)X方向的梁端刚域长度。

RGDj：N2端在单元局部坐标系(-)X方向的梁端刚域长度。

RGDi和RGDj必须输入正值。程序将根据RGDi和RGDj的长度，自动调整梁单元长度。

单元长度：L = L0 - (RGDi + RGDj)

其中，L0：梁单元的原始长度(节点N1和N2之间的距离)。


11_释放板端约束

Home > midas Gen 2017 > 06_边界 > 04_释放/偏心 > 03_释放板端约束

释放板端部约束

  • 功 能

输入板单元节点连接条件(铰接，刚性连接)，也可以替换或删除先前输入的边缘释放条件。

  • 命 令

从主菜单中选择模型 > 边界条件 > 释放板端部约束...

从树形菜单的菜单表单中选择模型 > 边界条件 > 释放板端约束

  • 输 入

单击释放板端约束右边的 [image] ，将显示释放板端约束表格。

边界组名称

选择定义的边界将要所属的边界组。当不需要指定组时，选择"默认值"。当需要添加和编辑边界组时，可以点击右面的 [image] ，将弹出"定义边界组"对话框。

选择

添加/替换：输入或替换板单元节点约束释放条件。

删除：删除先前输入的板单元节点约束释放条件。

解除端部约束

选择板单元相应节点的释放约束条件，选择表示释放该约束

Fx：释放单元局部坐标系x轴方向的相应节点的轴向约束

Fy：释放单元局部坐标系y轴方向的相应节点的轴向约束

Fz：释放单元局部坐标系z轴方向的相应节点的轴向约束

Mx：释放绕单元局部坐标系x轴方向的相应节点的弯曲约束

My：释放绕单元局部坐标系y轴方向的相应节点的弯曲约束

下列按钮将简化上述各数据输入：

：释放所有节点的所有方向的约束，随后可固定个别分量。

：约束所有节点的所有方向的自由度。


12_刚性连接

Home > midas Gen 2017 > 06_边界 > 05_其它 > 01_线性约束

线性约束

  • 功 能

强制某些节点(从属节点)的位移从属于某节点(自由节点)的位移。

：约束节点m在M方向的平动位移。

：自由节点i在I方向的平动位移。

：约束节点m在M方向的转动位移。

：自由节点i在I方向的转动位移。

：方程中的参数。

由于公式（1）和公式（2）允许限制任何节点的任何自由度，因而其应用范围比较广泛。约束方程用于整体坐标系中自由度。

图1所示为实体单元与板单元之间的连接。由于实体单元没有旋转自由度，因而无法约束与其相连的板单元的旋转特性。如果连接部分的旋转自由度通过公式（3）进行约束，板单元将沿垂直于连接部分的方向变形。

图1 约束方程应用示例

需要清楚约束方程与刚性连接之间的区别。刚性连接是多个节点从属于一个节点的运动。而约束方程是使一个节点从属于多个独立节点的运动。

  • 命 令

从主菜单中选择模型 > 边界条件 > 线性约束...

从树形菜单的菜单表单中选择模型 > 边界条件 > 线性约束

  • 输 入

边界组名称

选择定义的边界将要所属的边界组。当不需要指定组时，选择"默认值"。当需要添加和编辑边界组时，可以点击右面的 [image] ，将弹出"定义边界组"对话框。

选项

添加/替换：定义或修改已有的线性约束关系。

删除：删除选定的线性约束条件。

类型

显式：

-选择某个节点及单个自由度（不允许多选）。

-选择自由点及单个自由度（不允许多选），输入系数后即可建立线性约束关系。

加权位移：

-选择某个节点

-选择同时适用于约束点和自由点的自由度（允许多选）

-选择自由点，定义对应的权重系数后即可建立线性约束关系。

S是所有权重系数之和，不考虑平动位移和转动位移的耦合性。

当选择显式时：

约束点/DOF

点：约束节点号。

DOF：选定约束节点的自由度。

自由点/DOF

点：自由节点号。

DOF：选定自由节点的自由度。

系数：各自由点位移之间的关联参数。

注1：当平动自由度与旋转自由度互相约束时，系数会随单位长度变化而自动改变；

注2：一般来讲，指定的自由度都沿整体坐标轴方向。但如果对要限制的节点定义了节点局部坐标系，则自由度为局部坐标轴方向。

当选择加权位移时

约束点/DOF

点：约束节点号。

DOF：选定约束节点的自由度。

自由点/重量

节点：自由节点号。

重量：决定各自由度位移之间关系的权重系数。

注：一般来讲，指定的自由度都沿整体坐标轴方向。但如果对要限制的节点定义了节点局部坐标系，则自由度为局部坐标轴方向。

例题：如何限制两个节点的平动位移，两个节点连线不沿整体坐标轴方向。

约束条件 u1=u2

方法1：使用节点的局部坐标轴
如果一个节点局部坐标轴预分配到某个节点上，与全局坐标系呈30?角的节点，系数成为1。

DX1=DX2： 约束方程

方法2：手动分配系数
如果未分配节点局部轴，用户必须根据两个节点的位置来计算系数。在这里，对x2,系数等于cos30/ cos30，对y2,等于sin30/ con30，对y1,系数等于 sin30/cos30。

这里，DX1：约束节点1的X向平移位移

DX2：独立节点2的X向平移位移
DY1：独立节点1的Y向平移位移
DY2：独立节点2的Y向平移位移


14_刚域效果

Home > midas Gen 2017 > 06_边界 > 05_其它 > 02_刚域效果

刚域效果

  • 功 能

自动考虑杆系结构中柱构件和梁构件(与柱连接的水平单元)连接节点区的刚域效应，刚域效应反映在梁单元中，平行于整体坐标系Z轴的梁单元将被视为柱构件，整体坐标系X-Y平面内的梁单元将被视为梁构件。

  • 命 令

从主菜单中选择模型 > 边界条件 > 刚域效果...

从树形菜单的菜单表单中选择模型> 边界条件 > 刚域效果

  • 输 入

<图1> 刚域效果对话框

考虑刚域效果，计算刚域长度

基于构件尺寸的长度，自动计算刚域长度。

修正系数：修正刚域长度(系数不大于1)。

输出位置：单元内力的输出位置。

刚域：在节点区边缘输出单元内力。

修正后刚域：在经修正系数调整后的位置处输出单元内力。

不考虑

不考虑刚域效果。

注:
当选择"输出位置=修正后刚域"时, 自重、分布荷载的大小及构件内力的输出位置取决于经修正系数调整后的距离。另外，如果选择"输出位置=刚域"时，自重、分布荷载的大小及构件内力的输出位置取原节点区边缘(对梁，为柱面；对柱，为梁的上下翼缘)。

在刚域效应中，在修正系数=1.0的情况下，"输出位置=修正后刚域"与"输出位置=刚域"的情况是同样的条件。修正系数=0的情况下，"输出位置=修正后刚域"与根本不考虑刚域效应的条件是相同的。

因为结构分析时考虑刚域效应，将发生下列变化，用户使用该功能时，需格外小心。

  • 单元刚度计算

单元两端节点的距离用于计算轴向刚度和抗扭刚度。反映修正系数的距离(L1 = L - ZF*(Ri + Rj ))用于计算剪切刚度和弯曲刚度，与指定的输出位置无关。其中，L为单元两端节点的距离，ZF为修正系数，Ri和Rj为刚域长度。

  • 分布荷载计算

如果选择"输出位置=刚域"，在修正后刚域位置和节点之间的截面上的分布荷载只作为相应节点上的剪力。其余截面上的分布荷载将换算为剪力和弯矩。

当"输出位置=修正后刚域位置"时，使用经修正系数调整后的位置计算。

  • 自重计算长度

不管是否使用刚域效应，柱构件的自重考虑两端节点之间的长度。对梁构件，当"输出位置=刚域"时，用除节点区外的净距离(L1=L-(Ri + Rj ))计算自重。当"输出位置=修正后刚域位置"时，使用经修正系数折减后的刚域长度(L1=L-ZF*(Ri + Rj ))。此外，分析中将已定义的自重转换为剪力和弯矩的方法类似于上述分布荷载。

  • 构件内力的输出位置

如果选择"输出位置=刚域"，将输出节点区之间净长度的四分点处的梁柱构件内力。

如果选择"输出位置=修正后刚域位置"，将输出基于修正系数调整后的构件长度四分点处的梁构件内力。

在修正系数=1.0的情况下，"输出位置=刚域"与"输出位置=修正后刚域位置"的输出位置相同。

设计功能中将使用这些位置输出的内力。

  • 考虑梁端释放条件时的刚域

在梁端释放点处不考虑刚域效应(参见"释放梁端约束")。

  • 使用刚域效应时，考虑各种构件刚域的方法

用下列方法考虑各种构件类型的梁端刚域：

1. 柱构件

柱构件长度为楼板到楼板的高度。

在MIDAS中，假定梁构件的上翼缘与楼层平面一致。柱构件柱端刚域只需要在上节点处考虑(参见"结构类型")。

柱端刚域长度由与柱构件连接的梁构件的方向和高度决定。柱端刚域要分别计算局部坐标系y轴和z轴方向的长度。

当梁构件在几个方向上与柱构件连接时，可以用以下方法计算各个方向的刚域长度(图1)：

RCy = BD·cos2θ

RCz = BD·sin2θ

RCy：单元局部坐标系y轴方向的柱端刚域长度。

RCz：单元局部坐标系z轴方向的柱端刚域长度。

BD：与柱构件连接的梁构件的高度。

θ：梁构件与柱构件局部坐标系z轴方向形成的角度。

柱构件各方向的柱端刚域长度由各梁构件决定的刚域长度的最大值确定。

<图2> 柱构件端部刚域长度计算

2. 梁构件

梁构件端部刚域长度根据梁两端的柱构件的宽度和高度确定。计算方法如下。

梁端部刚域长度方程(参见图2):

Depth：柱构件在单元局部坐标系z轴方向的截面尺寸。

Width：柱构件在单元局部坐标系y轴方向的截面尺寸。

θ：梁构件和柱构件单元局部坐标系z轴方向的夹角。

<图3> 梁构件端部刚域长度计算


15_节点局部坐标系

Home > midas Gen 2017 > 06_边界 > 05_其它 > 03_节点局部坐标轴

节点局部坐标系

  • 功 能

输入或修改指定节点的节点局部坐标系。采用节点局部坐标系可以在指定的节点输入边界条件或形成输出反力。

  • 命 令

从主菜单中选择模型 > 边界条件 > 节点局部坐标系...

从树形菜单的菜单表单中选择几何模型 > 边界条件 > 节点局部坐标轴

  • 输 入

单击节点局部坐标轴右边的 [image] ，将显示节点局部坐标轴表格。

选择

添加/替换：输入或替换选定节点的局部坐标系。

删除：删除先前输入的选定节点的局部坐标系。

定义局部坐标轴

输入方法：选择指定节点局部坐标系的方法。

角度：指定定义节点局部坐标系的三个旋转角度。

绕x轴：对GCS X轴的旋转角度。

绕y"轴：对绕GCS X轴旋转所得的y'轴的旋转角度。

绕z""轴：对绕GCS X轴及y'轴旋转所得的z"轴的旋转角度。

3点：指定定义节点局部坐标系的三个节点坐标。

P0：节点局部坐标系原点的坐标。

P1：节点局部坐标系x轴上任意一点的坐标。

P2：由P1平行于节点局部坐标系y轴移动得的节点的坐标。

向量：指定定义节点局部坐标系的两个矢量。

V1：以节点局部坐标系原点为起点的x轴方向的矢量。

V2：以节点局部坐标系原点为起点到上述3点法P2点的矢量。

注:
节点局部坐标轴的应用功能如下：

"一般支承"

"节点弹性支承"

"一般弹性支承"

"面弹簧支承"(假设转换为点弹性支撑)

"支座沉降"

"反力"中的"反力和弯矩"


16_定义约束标签方向

Home > midas Gen 2017 > 06_边界 > 05_其它 > 04_定义标签方向

定义约束标签方向

  • 功 能

定义约束标签方向。

  • 命 令

从主菜单中选择模型 > 边界条件 > 定义约束标签方向...

从树形菜单的菜单表单中选择模型 > 边界条件 > 定义约束标志方向

  • 输 入

单击定义约束标志方向右边的 [image] ，将显示定义约束标志方向的表格。

选项

添加/替换：输入或替换约束标志方向。

删除：删除先前输入的约束标志方向。

方向

窗口中选择相应节点，选定局部坐标方向及正负后点击适用即可。


13_解除刚膜连接

Home > midas Gen 2017 > 06_边界 > 05_其它 > 05_解除刚膜连接

解除刚膜连接

  • 功 能

    将一些节点从使用层功能自动生成的刚性楼板中释放出来。该功能一般用于局部楼板为弹性时。

  • 命 令

    从主菜单中选择 模型 > 边界条件 > 解除刚膜连接...

    从树形菜单的菜单表单中选择 几何模型 > 边界条件 > 释放刚性板连接

  • 输 入

选择将要解除刚性连接的节点 ，在选项中

选择"添加"(或"删除")，将其添加到列表

中(或从列表中删除)

选择:选择是添加还是删除有关节点的信息

号: 序列号

节点号: 选择的节点号


16_各施工阶段刚性楼板组

Home > midas Gen 2017 > 06_边界 > 05_其它 > 06_层刚性楼板假定组

各施工阶段刚性楼板组

  • 功 能

高层建筑施工阶段分析时，将使用层功能定义的刚性楼板信息定义为边界条件组。边界条件组名称应事先在定义边界条件组命令中定义。 当使用建筑结构施工阶段建模助手建立了施工阶段模型时，将自动生成边界条件组并赋予各楼层。各边界条件组将在各施工阶段恒荷载(楼板自重)发生作用时被激活(Activation)。

  • 命 令

从主菜单中选择模型 > 边界条件 > 各施工阶段刚性楼板组...

从树形菜单的菜单表单中选择模型 > 边界条件 > 各施工阶段层刚性楼板组

  • 输 入

定义层数据: 层名称

组: 含有相应层的刚性楼板信息的边界条件组名称

注:
使用建筑结构施工阶段建模助手自动生成的层边界条件组的名称被自动赋予为 "#DP-层名称"。


17_一般支承表格

Home > midas Gen 2017 > 06_边界 > 06_表格 > 01_边界表格 > 01_支承

一般支承表格

  • 功 能

以电子表格形式输入或修改一般支承节点的约束数据。

MIDAS软件中的表格工具提供了各种强大的内置功能。详细说明参见下列各项：

表格工具的使用

术语

掌握使用方法

基本说明(单元移动、选择、大小控制等)

数据处理(增加、删除、修改数据)

用剪贴板复制/粘贴数据

表格功能补充

表格排序

表格格式设定

自动适应列宽

图表打印

各表格类型的补充功能

节点/单元表格

结果表格

  • 命 令

从主菜单中选择模型 > 边界条件 > 一般支承表格...

从树形菜单的表格表单中选择结构表格 > 边界条件 > 一般支承

快捷键： [Ctrl]+[Shift]+P

  • 输 入 (参见"一般支承")

参考表格工具的使用输入或修改下列数据：

节点：节点编号

Dx：整体坐标系X轴方向(或节点局部坐标x轴方向)的平移自由度。

Dy：整体坐标系Y轴方向(或节点局部坐标y轴方向)的平移自由度。

Dz：整体坐标系Z轴方向(或节点局部坐标z轴方向)的平移自由度。

Rx：绕整体坐标系X轴方向(或节点局部坐标x轴方向)的旋转自由度。

Ry：绕整体坐标系Y轴方向(或节点局部坐标y轴方向)的旋转自由度。

Rz：绕整体坐标系Z轴方向(或节点局部坐标z轴方向)的旋转自由度。

Rw：单元的翘曲自由度

自由度受约束时为"1"，自由度自由时为"0"。

组：支承所属的边界组。没有选择边界组时，为"默认"。


18_节点弹性支承表格

Home > midas Gen 2017 > 06_边界 > 06_表格 > 01_边界表格 > 02_点弹簧支承

节点弹性支承表格

  • 功 能

在电子表格中输入或修改GCS的各个方向的节点弹性支承刚度。

MIDAS软件中的表格工具提供了各种强大的内置功能。详细说明参见下列各项：

表格工具的使用

术语

掌握使用方法

基本说明(单元移动、选择、大小控制等)

数据处理(增加、删除、修改数据)

用剪贴板复制/粘贴数据

表格功能补充

表格排序

表格格式设定

自动适应列宽

图表打印

各表格类型的补充功能

节点/单元表格

结果表格

  • 命 令

从主菜单中选择模型 > 边界条件 > 节点弹性支承表格...。

从树形菜单的表格表单中选择结构表格 > 边界条件 > 节点弹性支承。

  • 输 入 (参见"节点弹性支承")

参考表格工具的使用并输入或修改下列数据：

节点：节点编号。

类型：节点弹性支承类型，有一次方程、只受压、只受拉、多线性四种。

SDx：整体坐标系X轴方向(或已定义的节点局部坐标系x方向)的弹性支承刚度。

SDy：整体坐标系Y轴方向(或已定义的节点局部坐标系y方向)的弹性支承刚度。

SDz：整体坐标系Z轴方向(或已定义的节点局部坐标系z方向)的弹性支承刚度。

SRx：绕整体坐标系X轴(或已定义的节点局部坐标系x方向)的转动弹性支承刚度。

SRy：绕整体坐标系Y轴(或已定义的节点局部坐标系y方向)的转动弹性支承刚度。

SRz：绕整体坐标系Z轴(或已定义的节点局部坐标系z方向)的转动弹性支承刚度。

刚度：只受压/只受拉类型的弹性支承刚度。

KX、KY、KZ：沿整体坐标系X、Y、Z轴（或节点局部坐标系x轴、y轴、z轴）方向的基床系数。

模型>边界 > 面弹性支承中设定为面弹性支承 > 转换为节点弹性支承 > 节点弹性支承时，显示面弹性支承中设置的基床系数。

方向：节点弹性支承的方向。

X/Y/Z：向量的三个坐标值。

多线性类型：对称/不对称。

ax-fx：各个点的横坐标。

ay-fy：各个点的纵坐标。

组：支承所属的边界组。没有选择边界组时，为"默认"。


19_一般弹性支承表格

Home > midas Gen 2017 > 06_边界 > 06_表格 > 01_边界表格 > 03_一般弹性支承

一般弹性支承表格

  • 功 能

以电子表格形式输入或修改一般弹性支承数据。

MIDAS软件中的表格工具提供了各种强大的内置功能。详细说明参见下列各项：

表格工具的使用

术语

掌握使用方法

基本说明(单元移动、选择、大小控制等)

数据处理(增加、删除、修改数据)

用剪贴板复制/粘贴数据

表格功能补充

表格排序

表格格式设定

自动适应列宽

图表打印

各表格类型的补充功能

节点/单元表格

结果表格

  • 命 令

从主菜单中选择模型 > 边界条件 > 一般弹性支承表格...

从树形菜单的表格表单中选择结构表格 > 边界条件 > 一般弹性支承

  • 输 入 (参见"一般弹性支承")

参考表格工具的使用输入或修改下列数据：

节点：节点编号。

类型：定义的一般弹性支承类型名称。

SDx：整体坐标系X轴方向(或已定义的节点局部坐标系x方向)的弹性支承刚度。

SDy：整体坐标系Y轴方向(或已定义的节点局部坐标系y方向)的弹性支承刚度。

SDz：整体坐标系Z轴方向(或已定义的节点局部坐标系z方向)的弹性支承刚度。

SRx：绕整体坐标系X轴(或已定义的节点局部坐标系x方向)的转动弹性支承刚度。

SRy：绕整体坐标系Y轴(或已定义的节点局部坐标系y方向)的转动弹性支承刚度。

SRz：绕整体坐标系Z轴(或已定义的节点局部坐标系z方向)的转动弹性支承刚度。

质量：是否考虑一般弹性支承的质量。

阻尼：是否考虑一般弹性支承的阻尼。

组：该弹性支承所属的边界组。如果没有选择边界组，将显示"默认"。


19_面弹性支承表格

Home > midas Gen 2017 > 06_边界 > 06_表格 > 01_边界表格 > 04_面弹簧

面弹簧支承表格

  • 功 能

以电子表格形式输入或修改面弹簧支承数据。

MIDAS软件中的表格工具提供了各种强大的内置功能。详细说明参见下列各项：

表格工具的使用

术语

掌握使用方法

基本说明(单元移动、选择、大小控制等)

数据处理(增加、删除、修改数据)

用剪贴板复制/粘贴数据

表格功能补充

表格排序

表格格式设定

自动适应列宽

图表打印

各表格类型的补充功能

节点/单元表格

结果表格

  • 命 令

从主菜单中选择模型 > 边界条件 > 面弹簧支承表格...

从树形菜单的表格表单中选择结构表格 > 边界条件 > 面弹簧

  • 输 入 (参见"面弹性支承")

参考表格工具的使用输入或修改下列数据：

单元：单元号。

类型：单元类型。

分布类型：面弹性支承分布类型，有框架、平面（面）、平面（线）、实体（面）四种。

局部坐标轴：选择框架分布类型时的局部坐标轴。

面：选择平面（面）或实体（面）分布类型时的面号。

边：选择平面（线）分布类型时的边号。

宽度：转换为节点弹性支承时杆系单元用于计算支承刚度的宽度。。

弹簧类型：线性、只受拉、只受压。

基床系数和：总基床系数值。

组：该面弹簧支承所属的边界组。如果没有选择边界组，将显示"默认"。


20_弹性连接表格

Home > midas Gen 2017 > 06_边界 > 06_表格 > 01_边界表格 > 05_弹性连接

弹性连接表格

  • 功 能

在电子数据格式表中输入或修改弹性连接。

MIDAS软件中的表格工具提供了各种强大的内置功能。详细说明参见下列各项：

表格工具的使用

术语

掌握使用方法

基本说明(单元移动、选择、大小控制等)

数据处理(增加、删除、修改数据)

用剪贴板复制/粘贴数据

表格功能补充

表格排序

表格格式设定

自动适应列宽

图表打印

各表格类型的补充功能

节点/单元表格

结果表格

  • 命 令

从主菜单中选择模型 > 边界条件 > 弹性连接表格...

从树形菜单的表格表单中选择结构表格 > 边界条件 > 弹性连接

  • 输 入 (参见"弹性连接")

号：弹性连接的顺序号。

节点1：弹性连接单元的起始节点编号。

节点2：弹性连接单元的终端节点编号。

类型：弹性连接单元的类型。

角度：弹性连接的方向角(β角)。

SDx：整体坐标系X轴方向(或已定义的节点局部坐标系x方向)的弹性支承刚度。

SDy：整体坐标系Y轴方向(或已定义的节点局部坐标系y方向)的弹性支承刚度。

SDz：整体坐标系Z轴方向(或已定义的节点局部坐标系z方向)的弹性支承刚度。

SRx：绕整体坐标系X轴(或已定义的节点局部坐标系x方向)的转动弹性支承刚度。

SRy：绕整体坐标系Y轴(或已定义的节点局部坐标系y方向)的转动弹性支承刚度。

SRz：绕整体坐标系Z轴(或已定义的节点局部坐标系z方向)的转动弹性支承刚度。

剪力弹性支承位置：当为剪切型弹性支承时，该输入框将被选择。

距离比SDy：输入剪切型弹性支承在整体坐标系Y轴(或已定义的节点局部坐标系y方向)上的位置。

距离比SDz：输入剪切型弹性支承在整体坐标系Z轴(或已定义的节点局部坐标系z方向)上的位置。

组：该边界条件所属的边界组。如果没有选择边界组，将显示"默认"。

号：弹性连接的顺序号。

节点1：弹性连接单元的起始节点编号。

节点2：弹性连接单元的终端节点编号。

角度：弹性连接的方向角(β角)。

类型：弹性连接单元的类型,对称和不对称。

方向：弹性连接的方向。

Num：多折线上的点数。

D1：第一个点的横坐标值。

F1：第一个点的纵坐标值（力）。

R1：第一个点的纵坐标值（力矩）。

其他各点说明同第一个点。

剪力弹性支承位置：当为剪切型弹性支承时，该输入框将被选择。

距离比：输入剪切型弹性支承的位置。

组：该边界条件所属的边界组。如果没有选择边界组，将显示"默认"。


21_非线性连接表格

Home > midas Gen 2017 > 06_边界 > 06_表格 > 01_边界表格 > 06_一般连接

一般连接表格

  • 功 能

在电子表格中输入或修改非线性连接(Nonlinear Link)数据。

MIDAS软件中的表格工具提供了各种强大的内置功能。详细说明参见下列各项：

表格工具的使用

术语

掌握使用方法

基本说明(单元移动、选择、大小控制等)

数据处理(增加、删除、修改数据)

用剪贴板复制/粘贴数据

表格功能补充

表格排序

表格格式设定

自动适应列宽

图表打印

各表格类型的补充功能

节点/单元表格

结果表格

  • 命 令

从主菜单中选择模型 > 边界条件 > 一般连接表格...

从树形菜单的表格表单中选择结构表格 > 边界条件 > 一般连接

  • 输 入 (参见"一般连接")

参考表格工具的使用输入或修改下列数据：

号：序号。

节点1：一般连接单元的开始节点号。

节点2：一般连接单元的结束节点号。

一般特性值：一般连接单元的特性值名称。

非弹性铰特性值：若使用显示为非弹性铰特性值。

类型：一般连接作用类型。

Beta角：按单元坐标系输入时一般连接单元的方向。

方法：按整体坐标系输入的方法。

Angle-x：按角度方法输入时绕整体坐标轴X的旋转角度。

Angle-y'：绕上一项旋转后的整体坐标轴Y轴的旋转角度。

Angle-z''：绕上两项旋转后的整体坐标轴Z轴的旋转角度。

P1-X/P1-Y/P1-Z：按三点方式输入时第一个点的X、Y、Z坐标。

P2-X/P2-Y/P2-Z：按三点方式输入时第二个点的X、Y、Z坐标。

P3-X/P3-Y/P3-Z：按三点方式输入时第三个点的X、Y、Z坐标。

V1-X/V1-Y/V1-Z：按向量方式输入时第一个点的X、Y、Z坐标。

V2-X/V2-Y/V2-Z：按向量方式输入时第二个点的X、Y、Z坐标。

组：该边界条件所属的边界组。如果没有选择边界组，将显示"默认"。


07

Home > midas Gen 2017 > 06_边界 > 06_表格 > 01_边界表格 > 07_修改一般连接特性值

修改一般连接特性值表格

  • 功 能

在电子数据格式表中输入或修改弹性连接。

MIDAS软件中的表格工具提供了各种强大的内置功能。详细说明参见下列各项：

表格工具的使用

术语

掌握使用方法

基本说明(单元移动、选择、大小控制等)

数据处理(增加、删除、修改数据)

用剪贴板复制/粘贴数据

表格功能补充

表格排序

表格格式设定

自动适应列宽

图表打印

各表格类型的补充功能

节点/单元表格

结果表格

  • 命 令

从主菜单中选择边界 > 表格 > 边界表格 > 修改一般连接特性值...

从树形菜单的表格表单中选择结构表格 > 边界条件 > 修改一般连接特性值

  • 输 入 (参见"修改一般连接特性值")

MO：序号。

节点1：一般连接单元的起始节点编号。

节点2：一般连接单元的终端节点编号。

前一般连接特性值：修改前使用的一般连接特性值类型。

修改一般连接特性值：修改后使用的一般连接特性值类型。

组：该边界条件所属的边界组。如果没有选择边界组，将显示"默认"。


22_梁释放端部约束表格

Home > midas Gen 2017 > 06_边界 > 06_表格 > 01_边界表格 > 08_梁端约束释放

释放梁端部约束表格

  • 功 能

在电子表格中输入或修改释放梁端约束数据。

MIDAS软件中的表格工具提供了各种强大的内置功能。详细说明参见下列各项：

表格工具的使用

术语

掌握使用方法

基本说明(单元移动、选择、大小控制等)

数据处理(增加、删除、修改数据)

用剪贴板复制/粘贴数据

表格功能补充

表格排序

表格格式设定

自动适应列宽

图表打印

各表格类型的补充功能

节点/单元表格

结果表格

  • 命 令

从主菜单中选择模型 > 边界条件 > 梁释放端部约束表格...

从树形菜单的表格表单中选择结构表格 > 边界条件 > 释放梁端约束

快捷键： [Ctrl]+[Shift]+D

  • 输 入 (参见" 释放梁端约束 ")

参考表格工具的使用输入或修改下列数据：

单元：梁单元编号。

类型：约束释放方式，有相对值和数值两种。

Flag-i：梁单元i端(N1)的约束释放条件。

Fx：当释放或部分约束单元坐标系x轴方向的刚度时，输入1。

Fy：当释放或部分约束单元坐标系y轴方向的刚度时，输入1。

Fz：当释放或部分约束单元坐标系z轴方向的刚度时，输入1。

Mx：当释放或部分约束绕单元坐标系x轴方向的扭转刚度时，输入1。

My：当释放或部分约束绕单元坐标系y轴方向的弯曲刚度时，输入1。

Mz：当释放或部分约束绕单元坐标系z轴方向的弯曲刚度时，输入1。

W：当释放或部分释放翘曲刚度时，输入1。

Fxi：按需要输入i端轴向刚度的约束比率。

Fyi：按需要输入i端单元坐标系y轴方向剪切刚度的约束比率。

Fzi：按需要输入i端单元坐标系z轴方向剪切刚度的约束比率。

Mxi：按需要输入i端绕单元坐标系x轴方向的扭转刚度的约束比率。

Myi：按需要输入i端绕单元坐标系y轴方向的弯曲刚度的约束比率。

Mzi：按需要输入i端绕单元坐标系z轴方向的弯曲刚度的约束比率。

Wi:按需要输入i端的翘曲刚度的约束比率。

标志-j：梁单元j端(N2)约束释放条件。

Fx：当释放或部分约束单元坐标系x轴方向的刚度时，输入1。

Fy：当释放或部分约束单元坐标系y轴方向的刚度时，输入1。

Fz：当释放或部分约束单元坐标系z轴方向的刚度时，输入1。

Mx：当释放或部分约束绕单元坐标系x轴方向的扭转刚度时，输入1。

My：当释放或部分约束绕单元坐标系y轴方向的弯曲刚度时，输入1。

Mz：当释放或部分约束绕单元坐标系z轴方向的弯曲刚度时，输入1。

W: 当释放或部分释放翘曲刚度时，输入1.

Fxj：按需要输入j端轴向刚度的约束比率。

Fyj：按需要输入j端单元坐标系y轴方向剪切刚度的约束比率。

Fzj：按需要输入j端单元坐标系z轴方向剪切刚度的约束比率。

Mxj：按需要输入j端绕单元坐标系x轴方向的扭转刚度的约束比率。

Myj：按需要输入j端绕单元坐标系y轴方向的弯曲刚度的约束比率。

Mzj：按需要输入j端绕单元坐标系z轴方向的弯曲刚度的约束比率。

Wj：按需要输入j端的翘曲刚度的约束比率。

组：该边界条件所属的边界组。如果没有选择边界组，将显示"默认"。


23_梁端部刚域表格

Home > midas Gen 2017 > 06_边界 > 06_表格 > 01_边界表格 > 09_梁端刚域

梁端部刚域表格

  • 功 能

在电子数据格式表中输入或修改GCS或梁单元局部坐标系下梁端刚域数据或节点偏心数据。

MIDAS软件中的表格工具提供了各种强大的内置功能。详细说明参见下列各项：

表格工具的使用

术语

掌握使用方法

基本说明(单元移动、选择、大小控制等)

数据处理(增加、删除、修改数据)

用剪贴板复制/粘贴数据

表格功能补充

表格排序

表格格式设定

自动适应列宽

图表打印

各表格类型的补充功能

节点/单元表格

结果表格

  • 命 令

从主菜单中选择模型 > 边界条件 > 梁端部刚域表格...

从树形菜单的表格表单中选择结构表格 > 边界条件 > 梁端刚域

  • 输 入 (参见"梁端刚域")

参考表格工具的使用输入或修改下列数据：

单元：单元编号。

类型：定义坐标系类型(整体坐标系或单元坐标系)。

  • 当选择类型= "整体坐标系"时

RGDXi：N1端梁端刚域长度在整体坐标系X轴方向的矢量分量。

RGDYi：N1端梁端刚域长度在整体坐标系Y轴方向的矢量分量。

RGDZi：N1端梁端刚域长度在整体坐标系Z轴方向的矢量分量。

RGDXj：N2端梁端刚域长度在整体坐标系X轴方向的矢量分量。

RGDYj：N2端梁端刚域长度在整体坐标系Y轴方向的矢量分量。

RGDZj：N2端梁端刚域长度在整体坐标系Z轴方向的矢量分量。

  • 当选择类型= "单元坐标系"时

RGDXi：N1端在单元坐标系(+)X方向的梁端刚域长度。

RGDXj：N2端在单元坐标系(-)X方向的梁端刚域长度。

组：该边界条件所属的边界组。如果没有选择边界组，将显示"默认"。


24_板释放端部约束表格

Home > midas Gen 2017 > 06_边界 > 06_表格 > 01_边界表格 > 10_板端约束释放

释放板端部约束表格

  • 功 能

在电子表格中输入或修改释放板端约束的数据。

MIDAS软件中的表格工具提供了各种强大的内置功能。详细说明参见下列各项：

表格工具的使用

术语

掌握使用方法

基本说明(单元移动、选择、大小控制等)

数据处理(增加、删除、修改数据)

用剪贴板复制/粘贴数据

表格功能补充

表格排序

表格格式设定

自动适应列宽

图表打印

各表格类型的补充功能

节点/单元表格

结果表格

  • 命 令

从主菜单中选择模型 > 边界条件 > 板释放端部约束表格...

从树形菜单的表格表单中选择结构表格 > 边界条件 > 释放板端约束

  • 输 入 (参见 "释放板单元约束")

参考表格工具的使用输入或修改下列数据：

单元：单元编号。

N1：释放节点N1的约束条件。1表示释放该方向的约束。

Fx：释放节点N1沿单元坐标系x轴方向的平移约束。

Fy：释放节点N1沿单元坐标系y轴方向的平移约束。

Fz：释放节点N1沿单元坐标系z轴方向的平移约束。

Mx：释放节点N1绕单元坐标系x轴方向的旋转约束。

My：释放节点N1绕单元坐标系y轴方向的旋转约束。

N2～N4：释放节点N2～N4的约束条件。详细说明与节点N1类似。

组：该边界条件所属的边界组。如果没有选择边界组，将显示"默认"。


25_刚性连接表格

Home > midas Gen 2017 > 06_边界 > 06_表格 > 01_边界表格 > 11_刚性连接

刚性连接表格

  • 功 能

在电子表格中输入或修改从属节点与主节点的约束关系。

MIDAS软件中的表格工具提供了各种强大的内置功能。详细说明参见下列各

表格工具的使用

术语

掌握使用方法

基本说明(单元移动、选择、大小控制等)

数据处理(增加、删除、修改数据)

用剪贴板复制/粘贴数据

表格功能补充

表格排序

表格格式设定

自动适应列宽

图表打印

各表格类型的补充功能

节点/单元表格

结果表格

  • 命 令

从主菜单中选择模型 > 边界条件 > 刚性连接表格...

从树形菜单的表格表单中选择结构表格 > 边界条件 > 刚性连接

快捷键： [Ctrl]+[Shift]+R

  • 输 入 (参见"刚性连接")

参考表格工具的使用输入或修改下列数据：

主节点：主节点编号。

类型：标记要约束于主节点的从属节点的自由度。

DX：整体坐标系X轴方向的平移自由度。

DY：整体坐标系Y轴方向的平移自由度。

DZ：整体坐标系Z轴方向的平移自由度。

RX：绕整体坐标系X轴的旋转自由度。

RY：绕整体坐标系Y轴的旋转自由度。

RZ：绕整体坐标系Z轴的旋转自由度。

从属节点列表：从属节点编号列表。

组：该边界条件所属的边界组。如果没有选择边界组，将显示"默认"。


26_节点局部坐标系表格

Home > midas Gen 2017 > 06_边界 > 06_表格 > 01_边界表格 > 12_节点局部坐标系

节点局部坐标轴表格

  • 功 能

在电子表格中输入或修改指定节点的节点局部坐标系。

MIDAS软件中的表格工具提供了各种强大的内置功能。详细说明参见下列各项：

表格工具的使用

术语

掌握使用方法

基本说明(单元移动、选择、大小控制等)

数据处理(增加、删除、修改数据)

用剪贴板复制/粘贴数据

表格功能补充

表格排序

表格格式设定

自动适应列宽

图表打印

各表格类型的补充功能

节点/单元表格

结果表格

  • 命 令

从主菜单中选择模型 > 边界条件 > 节点局部坐标轴表格...

从树形菜单的表格表单中选择结构表格 > 边界条件 > 节点局部坐标轴

  • 输 入 (参见"节点局部坐标轴")

参考表格工具的使用输入或修改下列数据：

节点：节点编号。

方法：定义节点局部坐标系的方法。

用角度方法时:

角度-X：绕GCS X轴的旋转角度。

角度-Y：对绕GCS X轴旋转所得的y'轴的旋转角度。

角度-Z：对绕GCS X轴及y'轴旋转所得的z"轴的旋转角度。

用3点方法时:

P0-X, P0-Y, P0-Z：原点P0在整体坐标系下的坐标。

P1-X, P1-Y, P1-Z：点P1在整体坐标系下的坐标。

P2-X, P2-Y, P2-Z：点P2在整体坐标系下的坐标。

用向量方法时:

V1-X：矢量V1在GCS X方向的分量。

V1-Y：矢量V1在GCS Y方向的分量。

V1-Z：矢量V1在GCS Z方向的分量。

V2-X：矢量V2在GCS X方向的分量。

V2-Y：矢量V2在GCS Y方向的分量。

V2-Z：矢量V2在GCS Z方向的分量。


01_静力荷载工况

Home > midas Gen 2017 > 07_荷载 > 01_静力荷载 > 01_建立荷载工况 > 01_静力荷载工况

静力荷载工况

  • 功 能

定义静力荷载工况，修改或删除已定义的荷载工况。

使用该功能可以完成静力分析下所需的各种静力荷载工况的定义，在"荷载组合"中可相互组合这些分析结果。

也可以用该功能生成P-Δ效应或屈曲分析中的几何刚度矩阵中必需的荷载工况。

在MIDAS程序中做静力分析的步骤如下：

  1. 在荷载>静力荷载工况中建立静力荷载工况名称。

  2. 使用荷载菜单中的各种静力荷载输入功能输入荷载。

  3. 当结构模型中有几何非线性单元时，需要在荷载>由荷载组合建立荷载工况中将实现建立的荷载组合生成荷载工况，然后在分析>主控数据中输入收敛条件。

  4. 在分析过程中需要考虑P-Δ效应时，需要在分析>P-Delta分析控制数据 中输入收敛条件和计算几何刚度所需的荷载工况和荷载系数。

  5. 点击分析>运行分析菜单或点击 [image] 运行分析图标。

  6. 分析过程和结束的信息将显示在下面的信息窗口中。

  7. 分析成功结束之后，可以使用荷载工况和荷载组合在结果菜单中查看各种分析结果。

注：分析过程中产生的信息自动保存在"文件名.out"文件之中。

  • 命 令

从主菜单中选择荷载 > 静力荷载工况...

在树形菜单的菜单表单中选择静力荷载 > 静力荷载工况

快捷键：[F9]

在指定静力荷载的各种功能的对话框中，单击荷载工况名称区右边的 [image] ，定义或修改静力荷载工况名称和类型。

  • 输 入

静力荷载工况对话框

定义或增加新的静力荷载工况时

输入以下各项并单击 [image] 。

名称：输入静力荷载工况名称。

类型：从静力荷载工况类型列表中选择荷载类型(参见注)
在荷载组合命令中将根据各国设计规范中的规定，使用列表自动生成荷载组合。因为自动生成荷载组合的依据为静力荷载的类型，所以当用户使用自动生成的荷载组合时，需要在此正确选择荷载工况类型。
遇到不常用的荷载类型，可在表中输入用户定义的荷载。自动生成荷载组合时不考虑用户自定义的荷载工况类型，需要用户手动调整荷载组合。

说明：输入对荷载工况的简要描述。

修改先前已定义的荷载工况时

在已定义的荷载工况列表中选择相应的荷载工况，做相应修改后单击 [image] 。

删除先前已定义的荷载工况时

在已定义的荷载工况列表中选择相应的荷载工况，然后单击 [image] 。

注：

荷载工况类型如下：注意下面列出的荷载工况的名称及符号可能与各国规范中给定的名称与符号不同，有的类型可能又重复，请选择相应规范的准确名称。

请参照建筑荷载规范(GB 50009-2001)以及下列荷载工况选择荷载类型。在下列荷载工况中未注明规范出处的，均为国外相应规范中的荷载。

用户定义的荷载(USER)

恒荷载(D)

活荷载(L)

屋面活荷载(LR)

风荷载(W)

地震作用(E)

竖向地震作用（EVT)

雪荷载（S)

雨荷载（R)

冰压力（IP)

地面压力（EP)

地下水压力（WP）

水平土压力（EH）

竖向土压力（EV）

流体压力（FP)

流水压力（SF)

浮力（B)

徐变（CR)

收缩（SH)

温度荷载（T)

预应力（PS)

施工阶段荷载（CS)

爆炸荷载（EX）

注

该荷载类型只在施工阶段分析中会被使用。对于完成施工阶段分析后的模型，该荷载不会发生作用，不论是否被激活。

施工荷载（ER）

汽车冲击力（IL）

活荷载引起的纵向内力（BK)

与车辆活荷载同时作用的风荷载（WL)

离心力（CF)

冲击力（CO)

加劲肋收缩（RS）


02_由荷载组合建立荷载工况

Home > midas Gen 2017 > 07_荷载 > 01_静力荷载 > 01_建立荷载工况 > 02_使用荷载组合

由荷载组合建立荷载工况

  • 功 能

将荷载组合中的各荷载工况的组合建立为新的荷载工况。

对非线性单元(如索、只受拉或只受压单元)由于其非线性特性，单纯将各荷载工况的分析结果进行线性组合(荷载组合)是错误的，此时应该使用该功能将荷载组合(如1.2D+1.4L)定义为一个荷载工况作用于结构上，方能得到正确的分析结果。

  • 命 令

从主菜单中选择荷载 > 由荷载组合建立荷载工况...

从树形菜单中选择静力荷载 > 由荷载组合建立荷载工况...

  • 输 入

用荷载组合建立荷载工况对话框

选择荷载工况和荷载组合

荷载组合

选择将被赋名为新的荷载工况的现有的荷载组合。此前未定义荷载组合时，单击荷载组合右边的 [image] 定义。

新建荷载工况

选择将要建立的代表荷载组合的荷载工况。该荷载工况可以是新建立的，也可以是已建立的。

在新建荷载工况中删除原荷载工况荷载

当使用已经建立的荷载工况时(该荷载工况不能包含在选择的荷载组合中)，选择该项将删除原荷载工况的荷载。未选该项时，新建立的荷载工况中将包含原荷载工况荷载。

选择新建荷载工况中包含的荷载类型

将选择的荷载组合建立成新的荷载工况时，选择荷载组合中将转换到荷载工况的荷载类型。

注：如果结构中存在非线性单元（只受拉/只受压单元，间隙，钩，索等），将各单工况的结果进行简单的线性叠加是不正确的。这种情况下，采用由荷载组合建立 荷载工况非常有用，包括平面荷载和楼面荷载。


03_自重

Home > midas Gen 2017 > 07_荷载 > 01_静力荷载 > 02_结构荷载/质量 > 01_自重

自重

  • 功 能

输入单元自重，也可以修改或删除已输入的单元自重。

MIDAS用单元的体积和密度自动计算模型的自重。在静力分析中，求得的自重可使用于整体坐标系的X、Y、Z轴方向。

此外，在动力分析或静力等效地震荷载计算中需要将自重转换为质量时，可在"结构类型"中选择转换的方向。

计算各种单元类型自重的方法如下：

  • 桁架、只受拉、只受压和梁单元

桁架、只受拉、只受压或梁单元的自重等于在"截面"和"材料"输入的横截面面积和比重乘以单元长度。

对定义为SRC截面(钢和混凝土组合截面)的梁单元, 其自重为分别求得的混凝土和钢的重量的和(参见"截面"中的SRC表单)。

对定义为变截面(参见"截面"中的变截面表单)的梁单元，假设自重从一端到另一端是线性变化的。

使用"刚域效应"定义刚性节点区域时，柱构件的自重用两节点间的长度计算。梁构件(与柱连接的水平构件)的自重用两节点间的长度减去两端的偏移距离计算。

使用"梁端刚域"功能且单元为均匀截面时，按整个梁长计算，不考虑偏移。

使用"梁端刚域"功能且单元为变截面时，刚域部分按重量均布分配，其余部分假设自重从一刚域端到另一刚域端是线性变化。

  • 平面应力、板、墙、平面应变和轴对称单元

平面应力、板、墙、平面应变和轴对称单元的自重按集中荷载作用在连接节点处。该荷载等于单元面积、厚度和比重的乘积，并按各节点的面积比分配给各节点。

平面应力、板和墙单元的厚度为在"厚度"中中输入的平面内厚度。平面应变和轴对称单元分别使用单位宽度(1.0)和单位角度(1.0弧度)。

  • 实体单元

实体单元的自重按集中荷载作用在连接节点处，该荷载等于单元体积和比重的乘积，并按各节点的体积比分配给各节点。

  • 命 令

从主菜单中选择荷载 > 自重...

在树形菜单的菜单表单中选择静力荷载 > 自重

  • 输 入

荷载工况名称

输入荷载工况名称。单击右边的 [image] 可以建立、修改或删除荷载工况。

荷载组名称

选择自重将要所属的荷载组。当不需要指定组时，选择"默认值"。当需要添加和编辑荷载组时，可以点击右面的 [image] ，将弹出"定义荷载组"对话框。

输入或增加新的自重时

输入以下各项并单击 [image] ：

自重系数

X：GCS X方向自重系数。

Y：GCS Y方向自重系数。

Z：GCS Z方向自重系数。

注1：如果输入的平面内和平面外厚度不一样，平面内厚度用于计算自重。但是，当平面内厚度为0时，使用平面外厚度
注2：对于加肋板，程序取yz和xz截面平面内厚度的较大值。但是当平面内厚度为0时，取平面外厚度的较大值。

修改先前输入的自重时

在对话框底部的自重列表中选择相应的荷载工况，修改相应数据后单击 [image] 。

删除先前输入的自重时

在对话框底部的自重列表中选择相应的荷载工况并单击 [image] 。


05_节点荷载

Home > midas Gen 2017 > 07_荷载 > 01_静力荷载 > 02_结构荷载/质量 > 02_节点荷载

节点荷载

  • 功 能

输入节点集中荷载(集中力或力矩)，修改或删除已输入的集中荷载。

  • 命 令

从主菜单中选择荷载 > 节点荷载...

在树形菜单的菜单表单中选择静力荷载 > 节点荷载

  • 输 入

荷载工况名称

输入荷载工况名称。单击右边的 [image] 可以建立、修改或删除荷载工况。

荷载组名称

选择节点荷载将要所属的荷载组。当不需要指定组时，选择"默认值"。当需要添加和编辑荷载组时，可以点击右面的 [image] ，将弹出"定义荷载组"对话框。

选择

添加：输入新的或附加的节点荷载。

替换：替换先前输入的节点荷载。

删除：删除先前输入的节点荷载。

节点荷载

以整体坐标系为基准输入节点集中荷载。

FX：集中荷载在整体坐标系X轴方向的分量。

FY：集中荷载在整体坐标系Y轴方向的分量。

FZ：集中荷载在整体坐标系Z轴方向的分量。

MX：绕整体坐标系X轴的节点力矩分量。

MY：绕整体坐标系Y轴的节点力矩分量。

MZ：绕整体坐标系Z轴的节点力矩分量。


06_支座强制位移

Home > midas Gen 2017 > 07_荷载 > 01_静力荷载 > 02_结构荷载/质量 > 03_强制位移

支座强制位移

  • 功 能

输入节点指定(强制)位移，修改或删除已输入的节点指定(强制)位移。

  • 命 令

从主菜单中选择荷载 > 支座强制位移...

在树形菜单的菜单表单中选择静力荷载 > 节点强制位移

  • 输 入

荷载工况名称

输入荷载工况名称。单击右边的 [image] 可以建立、修改或删除荷载工况。

荷载组名称

选择强制位移将要所属的荷载组。当不需要指定组时，选择"默认值"。当需要添加和编辑荷载组时，可以点击右面的 [image] ，将弹出"定义荷载组"对话框。

选择

添加：输入新的或附加的节点强制位移。

替换：替换先前输入的节点强制位移。

删除：删除先前输入的节点强制位移。

位移

以整体坐标系为基准输入强制位移。已为指定节点建立节点局部坐标系时，节点数据以节点局部坐标系为基准输入。

Dx：强制位移在整体坐标系或节点局部坐标系x方向的分量。

Dy：强制位移在整体坐标系或节点局部坐标系y方向的分量。

Dz：强制位移在整体坐标系或节点局部坐标系z方向的分量。

Rx：绕整体坐标系或节点局部坐标系x轴的强制旋转角度分量。

Ry：绕整体坐标系或节点局部坐标系y轴的强制旋转角度分量。

Rz：绕整体坐标系或节点局部坐标系z轴的强制旋转角度分量。

注1：
在MIDAS中将强制位移作为一种荷载工况考虑。因此强制位移可与其它荷载工况进行组合。

模型中有强制位移参与荷载组合时要注意下列事项:

如果对某节点赋予强制位移，相应的节点自由度自动被约束。

被赋予强制位移的节点的特征类似于支座。即在同一个荷载组合中，如果包含了节点的强制位移，则其它荷载工况也将按发生了强制位移处理。

注2：

如果强制位移被指定给了某个施工阶段，支座强制位移的荷载工况被分配到CS：恒荷载或CS：吊装。但强制位移并不是应用到CS：恒荷载或CS：安装，而是应用到CS：合计。例如，如果在前一阶段，节点位移如下表所示，用户输入+0.1作为强制位移，则为了得到最终的位移0.1（荷载+徐变+收缩+钢束），将用到0.5的节点强制位移。

恒载 | -0.1
徐变 | -0.1
收缩 | -0.1
预应力钢束 | -0.1


04_节点体力

Home > midas Gen 2017 > 07_荷载 > 01_静力荷载 > 02_结构荷载/质量 > 04_节点体力

节点体力

  • 功 能

将赋予在节点上的节点质量、荷载转换成质量、结构质量转换成任意方向的节点荷载。可任意定义体力系数（质量×g×系数）。在进行Pushover分析时，根据质量分配荷载的情况使用此功能。

  • 命 令

从主菜单中选择荷载 > 节点体力...

在树形菜单的菜单表单中选择静力荷载 > 节点体力

  • 输 入

荷载工况名称

输入荷载工况名称。单击右边的 [image] 可以建立、修改或删除荷载工况。

用于节点体力的节点

使用结构组：选择包含用于节点体力的节点的结构组。若要添加或修改结构组点击 [image] 按钮即可。

节点列表：直接输入要赋予节点体力的节点号或用选择功能来输入。

质量转换

选择转换类型。

节点质量：节点质量

荷载转换成质量：荷载转换的质量

结构质量：结构自身质量

节点体力系数

X：整体坐标系X方向的体力系数

Y：整体坐标系Y方向的体力系数

Z：整体坐标系Z方向的体力系数

操作

如果要修改已定义的节点体力，选择要修改的荷载工况点击 [image] 即可。如果要删除已定义的节点体力，选择相应荷载工况后点击 [image] 即可。


01_节点质量

Home > midas Gen 2017 > 07_荷载 > 01_静力荷载 > 02_结构荷载/质量 > 05_节点质量 > 01_节点质量

节点质量

  • 功 能

输入节点质量数据(平动集中质量、转动质量惯性矩)，也可以修改或删除先前输入的节点质量。

  • 命 令

从主菜单中选择模型 > 质量 > 节点质量...

在树形菜单的菜单表单中选定模型 > 质量 > 节点质量...

  • 输 入

单击节点质量右边的 [image] ，将显示节点质量表单。

选择

添加：输入或增加新的节点质量数据。

替换：替换先前输入的节点质量数据。

删除：删除选定节点上先前输入的节点质量数据。

节点质量

按整体坐标系输入质量数据。

mX：整体坐标系X轴方向的平动集中质量。

mY：整体坐标系Y轴方向的平动集中质量。

mZ：整体坐标系Z轴方向的平动集中质量。

rmX：绕整体坐标系X轴的转动质量惯性矩。

rmY：绕整体坐标系Y轴的转动质量惯性矩。

rmZ：绕整体坐标系Z轴的转动质量惯性矩。

注:
各质量分量计算如下:

  • 集中质量分量 =

  • 转动质量惯性矩 =

其中，r 是质量中心到相应质量分量中心的距离。集中质量的单位等于重量除以重力加速度，转动质量惯性矩的单位等于质量乘以长度的平方。在米-千克-秒(MKS)制或英制单位系统中，必须用重量除以重力加速度后输入质量数据。用模型 > 结构类型定义重力加速度。国际标准(SI)单位系统中，质量的单位是千克[kg]或吨[ton]，力的单位为牛顿[N]或千牛[kN]。

质量数据计算方法


02_刚性楼板质量

Home > midas Gen 2017 > 07_荷载 > 01_静力荷载 > 02_结构荷载/质量 > 05_节点质量 > 02_层刚性楼板质量

刚性楼板质量

  • 功 能

输入各层的质量数据，输入层质量的方法有下面两种：

    1. 由用户直接输入层质量、回转质量惯性矩、质量中心坐标

    2. 由程序自动计算层质量、回转质量惯性矩、质量中心坐标

当层的平面由很多分离的单体(如多塔结构)组成时，可分别计算各单体的层质量。输入的层质量数据用于计算地震作用所需的等效重量以及动力分析所需的质量矩阵。刚性楼板质量数据功能一般与模型 > 建筑物数据 > 层， 控制数据等功能联合使用。当使用该功能时，应将模型的Z轴设置为重力方向的反方向，并将各层楼板设置为"考虑刚性楼板"。生成的层质量数据作用在各层质量中心上，且只能考虑沿全局坐标系X和Y方向的成份以及绕Z的回转质量惯性矩。

  • 命 令

从主菜单中选择模型 > 质量 > 刚性楼板质量...

从树形菜单的菜单表单中选择模型 > 质量 > 刚性楼板质量...

  • 输 入

质量类型

选择质量的类型:

  1. 节点质量

  2. 线质量

  3. 圆弧质量

  4. 扇形面质量

  5. 三角面质量

  6. 四角面质量

开始层/顶层

选择要输入的层。

刚性楼板质量

  • 节点质量：

Mp : 沿全局坐标系X、Y方向的节点平动质量(Translational Mass)

Mr : 绕全局坐标系Z方向旋转的回转质量惯性矩(Rotational Mass Moment of Inertia)

Xc, Yc : 节点质量中心全局坐标系坐标

  • 线质量：

Ml : 单位长度上的质量(Mass/Length)

D1 : 直线长度

Xc, Yc : 直线中心全局坐标系坐标

  • 圆弧质量：

Ml : 单位长度上的质量(Mass/Length)

Xc, Yc : 圆弧中心全局坐标系坐标

D1 : 圆弧角度(Degree)

D2 : 圆弧半径

D3 : 圆弧质量中心与全局坐标系X轴的夹角(Degree)

  • 扇形面质量：

Ma : 单位面积上的质量(Mass/Area)

Xc, Yc : 扇面中心全局坐标系坐标

D1 : 扇面角度(Degree)

D2 : 扇面半径

D3 : 扇面厚度

D4 : 扇面质量中心与全局坐标系X轴的夹角(Degree)

  • 三角面质量：

Ma : 单位面积上的质量(Mass/Area)

X1, Y1 : 三角形第一个顶点的全局坐标系坐标

X2, Y2 : 三角形第二个顶点的全局坐标系坐标

X3, Y3 : 三角形第三个顶点的全局坐标系坐标

  • 四角面质量：

Ma : 单位面积上的质量(Mass/Area)

Xc, Yc : 四角形中心的全局坐标系坐标

D1 : 四角形一边的长度

D2 : 四角形另一边的长度


03_将荷载转化成质量

Home > midas Gen 2017 > 07_荷载 > 01_静力荷载 > 02_结构荷载/质量 > 05_节点质量 > 03_荷载转化为质量

将荷载转换成质量

  • 功 能

将输入的荷载(作用于整体坐标系-Z方向)的垂直分量转换为质量并作为集中质量数据。

该功能主要用于计算地震分析时所需的重力荷载代表值。

  • 命 令

从主菜单中选择模型 > 质量 > 将荷载转换成质量...

在树形菜单的菜单表单中选定模型 > 质量 > 将荷载转化成质量...

  • 输 入

质量方向：指定转换得到的质量的应用方向。

注：
考虑地震影响时，因为横向作用占支配地位，通常可以忽略垂直质量分量。因此通常选择X和Y为质量方向。

转换的荷载种类

选择要转换的荷载类型。可转换的荷载类型包括节点荷载、梁单元荷载、板单元荷载和压力荷载(流体压力)。

重力加速度：输入重力加速度，用于将荷载转换为质量。

荷载工况/组合值系数

荷载工况：选择要转换的荷载工况。

组合值系数: 输入荷载转为质量时所用的组合值系数。

：

删除所有荷载转换的质量数据。


01_风荷载

Home > midas Gen 2017 > 07_荷载 > 01_静力荷载 > 03_横向荷载 > 01_风荷载

风荷载

  • 功 能

自动生成风荷载功能一般适用于各层均有刚性楼板作用的结构上，其输入步骤如下。

1.建立结构模型结构模型的整体坐标系+Z轴的方向必须与重力方向相反。

2.在建筑物数据 > 控制数据中输入地面的整体坐标系+Z轴坐标。

程序默认地面以下的结构模型为地下室，在计算风荷载时不考虑地面以下部分。当不输入该项时，程序默认模型最低点为地面。

3.在层命令中指定层，并指定要考虑刚性楼板效应的层。另外还要输入各层的受风面宽度和风荷载作用位置。

此时点击，将自动生成层以及风荷载加载面和加载位置信息。当立面上有开洞时，用户需要对受压面做相应调整。

处于刚性楼板平面内的节点，其节点间的X、Y方向的位移自由度和节点间绕Z轴的旋转自由度将被约束。

用户可以通过解除刚性楼板连接命令，释放节点间的这种约束。

4.在输入风荷载的对话框中选择相应的国家规范，输入必要的参数。在Gen中内藏的风荷载规范如下：

China (GS50009-2012) : 中国建筑结构荷载规范(新规范)

China (GS50009-2001) : 中国建筑结构荷载规范

NBC(1995) : 加拿大，National Building Code of Canada

IBC 2000(ASCE7-98) : 美国，International Building Code 2000

UBC (1997) : 美国，UBC 97

ANSI (1982) : 美国，ANSI

Eurocode-1 (2005) : 欧洲，Basis of Design and Actions on Structures

Eurocode-1 (1992) : 欧洲，Basis of Design and Actions on Structures

BS6399 (1997) : 英国，British Standard 6399 Loading for buildings

Japan (Arch, 2000) : 日本，建筑物荷载指针同解说

Japan (1987) : 日本，建筑物荷载指针同解说

Korean (Arch, 2000) : 韩国，建筑物荷载规准同解说

Korean (Arch, 1992) : 韩国，建筑物的结构基准规则

Taiwan (2002): 台湾建筑规范

输入完风荷载参数之后，与自动生成的层数据相结合，程序将自动生成各层的风荷载。自动生成的风荷载可点击 [image] 查看生成的风荷载形状。

  • 命令

从主菜单中选择荷载 > 横向荷载 > 风荷载...

在树形菜单的菜单表单中选择 静力荷载 > 风荷载

  • 输 入

在风荷载定义对话框中点击 [image] ，将会出现如下对话框。

添加/编辑风荷载工况对话框

荷载工况名称

选择风荷载工况名称，点击可以添加和修改风荷载工况名称。

风荷载规范

选择风荷载设计规范。

说明

输入对工况的说明。

风荷载参数

输入计算风荷载的一些参数。
China (GB50009-2012)

地面粗糙度: 分A、B、C、D四类

基本风压(Wo): 不得小于0.3kN/m2。

地形修正系数(η): 对于山区的建筑物，应输入风压高度变化系数的地形修正系数。

阻尼比：对于混凝土结构，一般取0.05，对于钢结构应根据其高度确定阻尼比。

结构振型系数：

查表法：根据《建筑结构荷载规范》（GB50009-2012）附录表G.0.3计算振型系数；

公式法：根据《建筑结构荷载规范》（GB50009-2012）8.4.7条文说明中公式计算振型系数。

说明：附录表G.0.3适用于剪力墙和框架均起主要作用的框剪结构或框筒结构。8.4.7条文说明中公式适用于剪力墙工作为主的结构。

体形系数:

迎风面体形系数：X向及Y向默认值均为0.8。

背风面体型系数：X向及Y向默认值均为-0.5。

说明：对于高度超过45m的矩形截面高层建筑，背风面体形系数与结构的深宽比有关。

因而结构沿X向及Y向的背风面体形系数将会不同。

考虑分段体型系数：可对不同的楼层输入不同的体型系数。

考虑挡风系数：主要用于桁架结构风荷载的计算。

挡风系数一般取为桁架杆件的净投影面积与桁架轮廓面积的比值。

具体可参见《建筑结构荷载规范》表8.3.1第33项。

基本周期: 由用户输入或者由程序计算结构沿整体坐标系X轴方向和Y轴方向的基本自振周期。

H : 建筑物的高度。

Bx : 整体坐标系X轴方向风荷载的迎风面宽度。

By : 整体坐标系Y轴方向风荷载的迎风面宽度。

n : 建筑物的层数。

注:

建筑物的高度、X和Y轴方向的宽度、建筑层数均由程序自动计算。

公式1为一般混凝土结构的基本自振周期的简化计算公式。

公式2为高层钢筋混凝土框架和框架结构的基本自振周期的简化计算公式。

公式3为高层混凝土剪力墙结构的基本自振周期的简化计算公式。

公式4为高层钢结构基本自振周期的简化计算公式。

考虑顺风向风振影响：

如勾选该项目，则程序按照《建筑结构荷载规范》公式8.4.3计算风振系数。

如果不勾选该项目，则取风振系数=1.0。

考虑横风风振和扭转风振：

考虑横风向风振：

矩形截面结构：

需要输入削角或凹角的修正比例b/B, b为削角或凹角的尺寸，B为结构的迎风面宽度

如果无削角或凹角，此处应输入为0.

程序根据该输入数值，按照规范公示H.2.5计算角沿修正系数Cm.

圆形截面结构：

此处应输入结构沿整体坐标系X向和Y向的第二阶平动周期。

考虑扭转风振：

此处需输入第一阶扭转周期。

风振舒适度验算

风压：风振舒适度计算用基本风压；

阻尼比：结构的阻尼比；

程序按照《建筑结构荷载规范》附录J公式，分别计算顺风向及横风向风振加速度，用于舒适度验算。

风荷载方向系数

风荷载在各方向的增减系数。
X-轴方向: 整体坐标系X轴方向风荷载系数。
Y-轴方向: 整体坐标系Y轴方向风荷载系数。
注：这两个系数决定风荷载的作用方向和大小。

当风荷载只作用于X轴方向时，X轴方向系数输入为"1"，Y轴方向系数输入为"0"。

当风荷载只作用于Y轴方向时，X轴方向系数输入为"0"，Y轴方向系数输入为"1"。

当风荷载沿45度方向作用于结构时，X轴方向系数输入为"0.707"，Y轴方向系数输入为"0.707"。

附加风荷载

输入一些自动计算中未能考虑的附加风荷载，或者根据风洞试验的数据输入风荷载。

按照风洞试验数据输入风荷载时，应将风荷载基本风压输入为0.
点击 [image] 可以通过下边窗口进行操作。

风荷载形状

点击 [image] ，可以用表格和图形查看风荷载分布形状。

风荷载的计算

方向组成: 选择要查看的风荷载作用方向。该选项只用于查看各方向风荷载的形状，并不决定风荷载实际作用方向和大小。

"X和Y轴方向"并无特别的意义，只是为了在右图中比较两个方向风荷载的差异。

"SRSS"表示两个方向的SRSS组合结果。

输出项目: 选择图形将显示的内容。

层荷载: 各层的风荷载。

层剪力: 由风荷载引起的各层剪力。

倾覆弯矩: 由风荷载引起的倾覆弯矩。

: 将风荷载按文本格式输出。


01_速度压

Home > midas Gen 2017 > 07_荷载 > 01_静力荷载 > 03_横向荷载 > 02_风压 > 01_速度压

速度压

  • 功 能

定义速度压，用于计算面风压、梁单元风压和节点风压。

  • 命令

从主菜单中选择荷载 > 横向荷载 > 风压 > 速度压...

在树形菜单中选择 静力荷载 > 风压 > 速度压

  • 输 入

速度压

添加：添加一个速度压；

添加/编辑速度压

速度压名称：输入速度压名称

风荷载规范：输入用于计算速度压的风荷载规范，目前支持China(GB50009-2012),China(GB50009-2012),KBC(2009)

风荷载参数：

粗糙度类别：输入建筑物所在区域的地面粗糙度类别。

基本风压：选择建筑物所在城市的基本风压；

地形系数：对于山区建筑物，考虑地形条件的修正系数

编辑：对于已经定义的速度压进行编辑；

删除：删除已经定义的速度压；


02_风压函数

Home > midas Gen 2017 > 07_荷载 > 01_静力荷载 > 03_横向荷载 > 02_风压 > 02_风压函数

速度压

  • 功 能

定义速度压，用于计算面风压、梁单元风压和节点风压。

  • 命令

从主菜单中选择荷载 > 横向荷载 > 风压 > 速度压...

在树形菜单中选择 静力荷载 > 风压 > 速度压

  • 输 入

风压函数

添加：添加一个风压函数；

添加/编辑风压函数

函数名称：输入函数名称

坐标系：可在右侧坐标系下拉列表中选择直角坐标系或圆柱坐标系

公式：输入风压函数

点击右侧“ [image] ”按钮，打开函数输入助手，辅助进行输入。

描述：可对风压函数做以简单描述

表格显示选项：

固定坐标轴：对于直角坐标系和圆柱坐标系，可以选择固定三个坐标中的两个坐标。

起始、终止和增量：输入固定坐标以外的坐标的起始值、终止值和增量；

固定坐标：输入两个固定坐标轴的数值；

计算：计算所有点的风压值，可以在下方表格中进行查看。


03_面风压

Home > midas Gen 2017 > 07_荷载 > 01_静力荷载 > 03_横向荷载 > 02_风压 > 03_面风压

面风压

  • 功 能

对于封闭型空间结构，程序自动计算各作用面上的风荷载，并将其转化为作用在周端节点上的节点荷载。

  • 命令

从主菜单中选择荷载 > 横向荷载 > 风压 > 面风压...

在树形菜单中选择 静力荷载 > 风压 > 面风压

  • 输 入

面风压

荷载工况名称：选择之前定义的静力荷载工况名称，如果未定义，可点击 [image] ，重新进行定义。

方向：可以选择X-Y或Normal，分别定义水平方向的风荷载以及与加载面垂直方向的风荷载。

角度：如果方向中选择X-Y，则该项可输入。代表与整体坐标系X轴所成的角度。

内部节点：当方向选择Normal时，根据内部节点确定风压方向。风压方向为从所选面指向该内部节点的方向。

放大系数：输入风荷载的放大系数

风荷载规范：可以选择China(GB50009-2012),China(GB50009-2012),KBC(2009)。

速度压名称：选择定义的速度压；

结构振型系数：

查表法：根据《建筑结构荷载规范》（GB50009-2012）附录表G.0.3计算振型系数；

公式法：根据《建筑结构荷载规范》（GB50009-2012）8.4.7条文说明中公式计算振型系数。

说明：附录表G.0.3适用于剪力墙和框架均起主要作用的框剪结构或框筒结构。8.4.7条文说明中公式适用于剪力墙工作为主的结构。

阻尼比：输入结构的阻尼比

顺风向基本周期: 由用户输入或者由程序计算结构沿顺风向的基本自振周期。

横风向基本周期: 由用户输入或者由程序计算结构沿横风向的基本自振周期。

H : 建筑物的高度。

Bx : 整体坐标系X轴方向风荷载的迎风面宽度。

By : 整体坐标系Y轴方向风荷载的迎风面宽度。

n : 建筑物的层数。

注:

建筑物的高度、X和Y轴方向的宽度、建筑层数均由程序自动计算。

公式1为一般混凝土结构的基本自振周期的简化计算公式。

公式2为高层钢筋混凝土框架和框架结构的基本自振周期的简化计算公式。

公式3为高层混凝土剪力墙结构的基本自振周期的简化计算公式。

公式4为高层钢结构基本自振周期的简化计算公式。

体型系数：输入该区域的体型系数

考虑顺风向振动：

如勾选该项目，则程序按照《建筑结构荷载规范》公式8.4.3计算风振系数。

如果不勾选该项目，则取风振系数=1.0。

考虑横风风振和扭转风振：

考虑横风向风振：

矩形截面结构：

需要输入削角或凹角的修正比例b/B, b为削角或凹角的尺寸，B为结构的迎风面宽度

如果无削角或凹角，此处应输入为0.

程序根据该输入数值，按照规范公示H.2.5计算角沿修正系数Cm.

圆形截面结构：

此处应输入结构沿整体坐标系X向和Y向的第二阶平动周期。

考虑扭转风振：

此处需输入第一阶扭转周期。

选择

选择组或选择单元施加风压。

选择组时，在加载面组中选择之前定义的组。

选择单元时，在模型视图中选择相应的单元，构成封闭区域。


04_梁单元风压

Home > midas Gen 2017 > 07_荷载 > 01_静力荷载 > 03_横向荷载 > 02_风压 > 04_梁单元风压

梁单元风压

  • 功 能

对于开放型空间结构，程序自动计算各梁单元上的风荷载。

  • 命令

从主菜单中选择荷载 > 横向荷载 > 风压 > 梁单元风压...

在树形菜单中选择 静力荷载 > 风压 > 梁单元风压

  • 输 入

梁单元风压

荷载工况名称：选择之前定义的静力荷载工况名称，如果未定义，可点击 [image] ，重新进行定义。

方向：可以选择X-Y或Normal，分别定义水平方向的风荷载以及与加载面垂直方向的风荷载。

角度：如果方向中选择X-Y，则该项可输入。代表与整体坐标系X轴所成的角度。

放大系数：输入风荷载的放大系数

风荷载规范：可以选择China(GB50009-2012),China(GB50009-2012),KBC(2009)。

速度压名称：选择定义的速度压；

振型系数：

查表法：根据《建筑结构荷载规范》（GB50009-2012）附录表G.0.3计算振型系数；

公式法：根据《建筑结构荷载规范》（GB50009-2012）8.4.7条文说明中公式计算振型系数。

说明：附录表G.0.3适用于剪力墙和框架均起主要作用的框剪结构或框筒结构。8.4.7条文说明中公式适用于剪力墙工作为主的结构。

阻尼比：输入结构的阻尼比

基本周期: 由用户输入或者由程序计算结构沿整体坐标系顺风向和横风向的基本自振周期。

H : 建筑物的高度。

Bx : 整体坐标系X轴方向风荷载的迎风面宽度。

By : 整体坐标系Y轴方向风荷载的迎风面宽度。

n : 建筑物的层数。

注:

建筑物的高度、X和Y轴方向的宽度、建筑层数均由程序自动计算。

公式1为一般混凝土结构的基本自振周期的简化计算公式。

公式2为高层钢筋混凝土框架和框架结构的基本自振周期的简化计算公式。

公式3为高层混凝土剪力墙结构的基本自振周期的简化计算公式。

公式4为高层钢结构基本自振周期的简化计算公式。

体型系数：输入该区域的体型系数

考虑顺风向振动：

如勾选该项目，则程序按照《建筑结构荷载规范》公式8.4.3计算风振系数。

如果不勾选该项目，则取风振系数=1.0。

考虑横风风振和扭转风振：

考虑横风向风振：

矩形截面结构：

需要输入削角或凹角的修正比例b/B, b为削角或凹角的尺寸，B为结构的迎风面宽度

如果无削角或凹角，此处应输入为0.

程序根据该输入数值，按照规范公示H.2.5计算角沿修正系数Cm.

圆形截面结构：

此处应输入结构沿整体坐标系X向和Y向的第二阶平动周期。

考虑扭转风振：

此处需输入第一阶扭转周期。


05_节点风压

Home > midas Gen 2017 > 07_荷载 > 01_静力荷载 > 03_横向荷载 > 02_风压 > 05_节点风压

节点风压

  • 功 能

对于未参与建模的设备或其他附属结构，程序自动计算其上面的风荷载，并将其转化为主体结构上的节点荷载。

  • 命令

从主菜单中选择荷载 > 横向荷载 > 风压 > 节点风压...

在树形菜单中选择 静力荷载 > 风压 > 节点风压

  • 输 入

节点风压

荷载工况名称：选择之前定义的静力荷载工况名称，如果未定义，可点击 [image] ，重新进行定义。

方向：可以选择X-Y或Normal，分别定义水平方向的风荷载以及与加载面垂直方向的风荷载。

角度：如果方向中选择X-Y，则该项可输入。代表与整体坐标系X轴所成的角度。

放大系数：输入风荷载的放大系数

风荷载规范：可以选择China(GB50009-2012),China(GB50009-2012),KBC(2009)。

速度压名称：选择定义的速度压；

结构振型系数：

查表法：根据《建筑结构荷载规范》（GB50009-2012）附录表G.0.3计算振型系数；

公式法：根据《建筑结构荷载规范》（GB50009-2012）8.4.7条文说明中公式计算振型系数。

说明：附录表G.0.3适用于剪力墙和框架均起主要作用的框剪结构或框筒结构。8.4.7条文说明中公式适用于剪力墙工作为主的结构。

阻尼比：输入结构的阻尼比

基本周期: 由用户输入或者由程序计算结构沿顺风向和横风向的基本自振周期。

H : 建筑物的高度。

Bx : 整体坐标系X轴方向风荷载的迎风面宽度。

By : 整体坐标系Y轴方向风荷载的迎风面宽度。

n : 建筑物的层数。

注:

建筑物的高度、X和Y轴方向的宽度、建筑层数均由程序自动计算。

公式1为一般混凝土结构的基本自振周期的简化计算公式。

公式2为高层钢筋混凝土框架和框架结构的基本自振周期的简化计算公式。

公式3为高层混凝土剪力墙结构的基本自振周期的简化计算公式。

公式4为高层钢结构基本自振周期的简化计算公式。

体型系数：输入该区域的体型系数

考虑顺风向风振：

如勾选该项目，则程序按照《建筑结构荷载规范》公式8.4.3计算风振系数。

如果不勾选该项目，则取风振系数=1.0。

考虑横风风振和扭转风振：

考虑横风向风振：

矩形截面结构：

需要输入削角或凹角的修正比例b/B, b为削角或凹角的尺寸，B为结构的迎风面宽度

如果无削角或凹角，此处应输入为0.

程序根据该输入数值，按照规范公示H.2.5计算角沿修正系数Cm.

圆形截面结构：

此处应输入结构沿整体坐标系X向和Y向的第二阶平动周期。

考虑扭转风振：

此处需输入第一阶扭转周期。

上部结构作用点

选择未建模部分与结构的接触点。

迎风面面积：

输入为建模部分迎风面的面积；

集中荷载作用点：

将未建模部分的风荷载考虑为集中荷载，该集中荷载在未建模部分的作用点。

点击 [image] ，可以选择未建模部分的形状，可以选择棱柱、圆柱、球形及半球形。

程序自动将该形状的形心作为集中荷载作用点，用户也可以直接输入集中荷载作用点的坐标。


06_函数风压

Home > midas Gen 2017 > 07_荷载 > 01_静力荷载 > 03_横向荷载 > 02_风压 > 06_函数风压

函数风压

  • 功 能

利用之前定义的风压函数，对结构施加风荷载。

  • 命令

从主菜单中选择荷载 > 横向荷载 > 风压 > 函数风压...

在树形菜单中选择 静力荷载 > 风压 > 函数风压

  • 输 入

函数风压

荷载工况名称：选择之前定义的静力荷载工况名称，如果未定义，可点击 [image] ，重新进行定义。

方向：可以选择X-Y或Normal，分别定义水平方向的风荷载以及与加载面垂直方向的风荷载。

角度：如果方向中选择X-Y，则该项可输入。代表与整体坐标系X轴所成的角度。

内部节点：当方向选择Normal时，根据内部节点确定风压方向。风压方向为从所选面指向该内部节点的方向。

放大系数：输入风荷载的放大系数

函数名称：选择之前定义的风压函数，如未定义，可点击 [image] ，重新进行定义。

选择

选择组或选择单元施加风压。

选择组时，在加载面组中选择之前定义的组。

选择单元时，在模型视图中选择相应的单元，构成封闭区域。


02_静力地震荷载

Home > midas Gen 2017 > 07_荷载 > 01_静力荷载 > 03_横向荷载 > 03_地震荷载

静力地震荷载

  • 功 能

使用该功能计算地震作用的方法又称为基底剪力法。该功能一般适用于各层均有刚性楼板作用的结构上，其输入步骤如下。

1.建立结构模型

结构模型的整体坐标系+Z轴的方向必须与重力方向相反。

2.将模型中单元的自重转换为质量，用于计算总重力荷载代表值。在结构类型中的将结构的自重转换为质量中选择质量成分的方向，然后输入重力加速度值。

将模型的自重转换为层质量数据的步骤如下:

首先计算各构件的自重，然后将构件的自重等分给节点，当节点处于层高位置时，直接将其转换成层质量数据。当节点处于层间时，则将节点质量等分到上下两层。

3.在建筑物数据 > 控制数据对话框中输入地面的整体坐标系Z轴坐标。

静力地震作用计算中不考虑地面标高以下的质量数据。当不输入地面标高时，程序默认模型最下端为地面。

4.在层对话框中指定具有刚性楼板的层，输入偶然偏心量。然后点击，生成计算地震作用所需的层数据。

处于刚性楼板平面内的节点，其节点间的X、Y方向的位移自由度和节点间绕Z轴的旋转自由度将被约束。

用户可以通过解除刚性楼板连接命令，释放节点间的这种约束。

5.利用节点质量功能、刚性楼板质量功能、将荷载转换为质量功能输入没有包含在模型自重中的质量。此时可将部分活荷载转换为重力荷载代表值。

6.在输入静力地震作用对话框中选择相应的国家规范，输入必要的参数。在Gen中内藏的计算静力地震作用的规范如下：

China (GB50011-2001) : 中国，建筑抗震设计规范

IBC2000(ASCE7-98) : 美国，International Building Code 2000

UBC (1997) : 美国，UBC 97

UBC (1991) : 美国，UBC 91

ATC 3-06 (1982) : 美国，ATC 3-06 Provision

NBC(1995) : 加拿大，National Building Code of Canada

Eurocode-8 (2004) : 欧洲，结构物耐震设计规范

Eurocode-8 (1996) : 欧洲，结构物耐震设计规范

Japan (Arch. 1994) : 日本，建筑物荷载指针及同解说

KBC（2009）：韩国建筑规范

KBC（2005）：韩国建筑规范

Korean (Arch. 2000) : 韩国，建筑物的结构基准等规定

Korean (Arch. 1992) : 韩国，建筑物的结构基准等规定

IS1893（2002）：印度规范

Taiwan（2011）：建筑结构抗震规范

Taiwan（2006）：建筑结构抗震规范

Taiwan（1999）：建筑结构抗震规范

输入完地震作用参数之后，与自动生成的层数据相结合，程序将自动生成各层的地震。

自动生成的地震作用可点击 [image] 查看生成的地震作用形状。

  • 命令

从主菜单中选择荷载 > 横向荷载 > 静力地震荷载...

在树形菜单的菜单表单中选择 静力荷载 > 静力地震荷载

--------------------------------------------------------------------------------

  • 输 入

在静力地震荷载对话框中点击 [image] ，将弹出下列地震作用参数对话框。

添加/编辑地震作用设计标准值对话框

荷载工况名称

选择地震作用工况名称，点击 [image] 可以添加和修改地震作用工况名称。

地震作用设计标准

在各国设计标准中选择所需的设计标准。

说明

输入对地震作用的简单说明。

地震作用参数

输入计算地震作用所需的参数。

China (GB50011-2001)

设计地震分组: 设计地震分组共分为一、二、三组。

地震设防烈度: 分为6度(0.05g)、7度(0.10g)、7度(0.15g)、8度(0.20g)、8度(0.30g)、9度(0.40g),( )内数字为设计基本地震加速度。

场地类别: 根据土层等效剪切波速和场地覆盖层厚度，建筑的场地类别分为I、II、III、IV四类。

结构类型: 该项用于计算顶部附加地震作用，分为多层钢筋混凝土和钢结构房屋、多层内框架砖房、其他三种。

注

当结构类型为高层钢结构时，遵循高层民用建筑钢结构技术规程中的规定计算顶部附加地震作用。

阻尼比: 高层钢筋混凝土结构的阻尼比一般取0.05，高层建筑钢结构的阻尼比一般取0.02。

多遇地震: 多遇地震烈度对应于50年设计基准期内超越概率为63%的地震烈度。

罕遇地震烈度: 罕遇地震烈度对应于50年设计基准期内超越概率为2～3%的地震烈度。

多层砌体房屋、底部框架和多层内框架砖房: 选择该项时水平地震影响系数宜取最大值。

结构参数

China (GB50011-2001)

结构基本自振周期: 用于计算水平地震影响系数。

计算周期: 计算结构基本自振周期。

H : 建筑物的高度。

Bx : 计算整体坐标系X轴方向的地震时使用的建筑宽度。

By : 计算整体坐标系Y轴方向的地震时使用的建筑宽度。

n : 建筑物的层数。

地震作用方向系数

地震作用在各方向的增减系数。

全局坐标系X轴方向系数: 整体坐标系X轴方向的地震作用增减系数。
全局坐标系Y轴方向系数: 整体坐标系Y轴方向的地震作用增减系数。
注：这两个系数决定地震作用的方向和大小。

当地震只作用于X轴方向时，全局坐标系X轴方向系数输入为"1"，全局坐标系Y轴方向系数输入为"0"。

当地震只作用于Y轴方向时，全局坐标系X轴方向系数输入为"0"，全局坐标系Y轴方向系数输入为"1"。

当考虑地震按450方向作用于结构时，全局坐标系X轴方向系数输入为"0.707"，全局坐标系Y轴方向系数输入为"0.707"。

偶然偏心的方向

选择偶然偏心的的方向。

添加地震荷载

添加一些自动计算时没有考虑到的附加地震荷载。

点击 [image] 选择需要附加地震荷载的层和荷载大小。

地震作用形状

点击 [image]: 可以用表格和图形查看地震作用的分布形状。

地震作用的计算

方向组成: 选择要查看的地震作用方向。该选项只用于查看各方向地震作用的形状，并不决定地震实际作用方向和大小。"X和Y轴方向"并无特别的意义，只是为了在右图中比较两个方向地震作用的差异。"SRSS"表示两个方向的SRSS组合结果。

输出项目: 选择图形将显示的内容。

层荷载: 各层的地震作用。

层剪力: 由地震作用引起的各层剪力。

倾覆弯矩: 由地震作用引起的倾覆弯矩。

: 将地震作用按文本格式输出。

注

请参照建筑抗震规范输入有关参数


07_梁单元荷载

Home > midas Gen 2017 > 07_荷载 > 01_静力荷载 > 04_梁荷载 > 01_单元

梁单元荷载

  • 功 能

输入作用在梁单元上的荷载，如均布荷载、集中荷载等，也可以修改或删除已输入的梁单元荷载。

  • 命 令

从主菜单中选择荷载 > 梁单元荷载...

在树形菜单的菜单表单中选择静力荷载 > 梁单元荷载(单元)

  • 输 入

荷载工况名称

输入荷载工况名称。单击右边的 [image] 可以建立、修改或删除荷载工况。

荷载组名称

选择梁单元荷载将要所属的荷载组。当不需要指定组时，选择"默认值"。当需要添加和编辑荷载组时，可以点击右面的 [image] ，将弹出"定义荷载组"对话框。

选择

添加：输入新的或附加的梁单元荷载。

替换：替换已输入的梁单元荷载。

删除：删除已输入的梁单元荷载。

荷载类型

输入梁单元荷载的荷载类型。荷载类型如下：

集中荷载：跨中某点处的集中荷载。

集中弯矩/扭矩：跨中某点处的集中弯矩/扭矩。

均布荷载：均匀分布的荷载。

均布弯矩/扭矩：均匀分布的弯矩/扭矩。

梯形荷载：沿梁长度方向线性变化的梯形荷载。

梯形弯矩/扭矩：沿梁长长度方向线性变化的梯形弯矩/扭矩。

偏心

通过指定偏心距离，可以很方便的设置偏心荷载。 如下图所示，通过输入偏心距离和荷载，程序自动把它转换为等效弯矩。

这个功能可以方便的指定一个偏心梁荷载，如风荷载。
方向：输入偏心方向
距离：输入偏心距离
I-End：I端的偏心距离
J-End：J端的偏心距离

偏心梁荷载

方向

设定梁单元荷载的作用方向。荷载方向如下：

局部坐标系x：梁单元荷载作用在单元局部坐标系x轴方向上。

局部坐标系y：梁单元荷载作用在单元局部坐标系y轴方向上。

局部坐标系z：梁单元荷载作用在单元局部坐标系z轴方向上。

整体坐标系X：梁单元荷载作用在整体坐标系X轴方向上。

整体坐标系Y：梁单元荷载作用在整体坐标系Y轴方向上。

整体坐标系Z：梁单元荷载作用在整体坐标系Z轴方向上。

当荷载方向与上述6个方向不一致时，正确考虑正负号后输入每个方向上的荷载分量。

投影

决定梁单元荷载是沿整个梁长作用还是沿与荷载作用方向垂直的梁的投影长度作用。该功能仅用于荷载类型为'均布荷载'或'梯形荷载'且荷载方向是在'整体坐标系'下时。

是：梁单元荷载沿与荷载作用方向垂直的梁的投影长度作用。

否：梁单元荷载沿整个梁长作用。

数值

决定是以梁长的相对比例输入梁单元荷载的加载位置，还是以实际长度输入。

相对值：梁长的相对比例。

绝对值：实际长度。

参考荷载类型选择区下面的图，输入相应荷载类型的加载位置和大小。


08_连续梁单元荷载

Home > midas Gen 2017 > 07_荷载 > 01_静力荷载 > 04_梁荷载 > 02_连续

连续梁单元荷载

  • 功 能

几个梁单元在连续连接在一起时(直线或曲线)，选择连续线的两端点并输入连续梁荷载。也可以根据需要修改或删除已输入的荷载。

  • 命 令

从主菜单中选择荷载 > 连续梁单元荷载...

在树形菜单的菜单表单中选择静力荷载 > 梁单元荷载(连续)

  • 输 入

荷载工况名称

输入荷载工况名称。单击右边的 [image] 可以建立、修改或删除荷载工况。

荷载组名称

选择连续梁单元荷载将要所属的荷载组。当不需要指定组时，选择"默认值"。当需要添加和编辑荷载组时，可以点击右面的 [image] ，将弹出"定义荷载组"对话框。

选择

添加：输入新的或附加的连续梁单元荷载。

替换：替换已输入的连续梁单元荷载。

删除：删除已输入的连续梁单元荷载。

荷载类型

输入梁单元荷载的荷载类型。荷载类型如下：

集中荷载：跨中某点处的集中荷载。

集中弯矩/扭矩：跨中某点处的集中弯矩/扭矩。

均布荷载：均匀分布的荷载。

均布弯矩/扭矩：均匀分布的弯矩/扭矩。

梯形荷载：沿梁长度方向线性变化的梯形荷载。

梯形弯矩/扭矩：沿梁长长度方向线性变化的梯形弯矩/扭矩。

曲线荷载 : 沿梁长度方向按曲线(2次函数或0.5次函数)变化的分布荷载。

均布压力：考虑梁截面高度，定义沿梁长度方向均布的压力荷载。

梯形压力：考虑梁截面高度，定义沿梁长度方向线性变化的压力荷载。

注：

曲线荷载是将单元按3等分之后加载，一个单元如果很长，其荷载形式就会接近直线，故单元分割的越细，其荷载形式就会越接近于曲线。

荷载作用的单元

指定荷载作用单元的方法。

两点间直线：加载在指定的两点间的直线上。

选择的单元：加载在选择的单元上。

注释
加载的单元必须与加载方向在同一平面。加载单元可以是曲线。

偏心

通过指定偏心距离，可以很方便的设置偏心荷载。 如下图所示，通过输入偏心距离和荷载，程序自动把它转换为等效弯矩。

这个功能可以方便的指定一个偏心梁荷载，如风荷载。
方向：输入偏心方向
距离：输入偏心距离
I-End：I端的偏心距离
J-End：J端的偏心距离

偏心梁荷载

方向

设定连续梁荷载的作用方向。荷载方向如下：

局部坐标系x：梁荷载作用在单元局部坐标系x轴方向上。

局部坐标系y：梁荷载作用在单元局部坐标系y轴方向上。

局部坐标系z：梁荷载作用在单元局部坐标系z轴方向上。

整体坐标系X：梁荷载作用在整体坐标系X轴方向上。

整体坐标系Y：梁荷载作用在整体坐标系Y轴方向上。

整体坐标系Z：梁荷载作用在整体坐标系Z轴方向上。

当荷载方向与上述6个方向不一致时，正确考虑正负号后输入每个方向上的荷载分量。

投影

决定梁荷载是沿整个梁长作用还是沿与荷载作用方向垂直的梁的投影长度作用。该功能仅用于荷载类型为'均布荷载'或'梯形荷载'且荷载方向是在'整体坐标系'下时。

是：梁荷载沿与荷载作用方向垂直的梁的投影长度作用。

否：梁荷载沿整个梁长作用。

数值

决定是以梁长的相对比例输入梁荷载的加载位置，还是以实际长度输入。

相对值：梁长的相对比例。

绝对值：实际长度。

参考荷载类型选择区下面的图，输入相应荷载类型的加载位置和大小。

加载区间(两点)

输入连续梁两端的节点编号。这两个节点编号可以在工作窗口中利用节点捕捉功能用鼠标设定。

复制荷载

选择复制荷载，可以将荷载复制到具有相同长度的其它连续梁上。

方向：设定复制方向。

x：用户坐标系x轴方向。

y：用户坐标系y轴方向。

z：用户坐标系z轴方向。

距离：复制距离。

当需要连续复制荷载时，按需要次数输入复制距离(间距)。例如：5.0, 3.0, 4.5, 3@5.0。


09_标准梁单元荷载

Home > midas Gen 2017 > 07_荷载 > 01_静力荷载 > 04_梁荷载 > 03_标准

标准梁单元荷载

  • 功 能

输入由楼面荷载传递的标准梁荷载，也可以修改或删除已输入的荷载。

在二维框架分析中，使用该功能可以简便地输入由楼面传来的荷载。

  • 命 令

从主菜单中选择荷载 > 标准梁单元荷载...

在树形菜单的菜单表单中选择静力荷载 > 梁单元荷载(标准)

  • 输 入

荷载工况名称

输入荷载工况名称。单击右边的 [image] 可以建立、修改或删除荷载工况。

荷载组名称

选择梁单元荷载将要所属的荷载组。当不需要指定组时，选择"默认值"。当需要添加和编辑荷载组时，可以点击右面的 [image] ，将弹出"定义荷载组"对话框。

选择

添加：输入新的或附加的标准梁单元荷载。

替换：替换先前输入的标准梁单元荷载。

删除：删除先前输入的标准梁单元荷载。

荷载类型

输入梁荷载的荷载类型。 荷载类型如下：

：均布荷载

：三角形荷载分布(1)

：梯形荷载分布

：三角形荷载分布(2)+集中荷载(1)

：三角形荷载分布(3)+集中荷载(2)

：三角形荷载分布(4)+集中荷载(3)

楼面均布荷载P，加载高度B

P：输入楼面单位面积荷载。当梁上为墙体荷载时，也可以输入墙体截面均布荷载。

B：输入楼面荷载加载高度。单向板时，为板跨(或净跨)一半；双向板(无次梁)时，按40度角计算的荷载高度(参见上图)；双向板(有次梁)时，可输入次梁跨度的一半。三角形荷载的位置和高度由程序自动计算。

次梁单位长度重量w：输入次梁线长度重量，计算时可以包含次梁重量。

方向

设定标准梁单元荷载的作用方向。荷载方向如下：

局部坐标系x：梁荷载作用在单元局部坐标系x轴方向上。

局部坐标系y：梁荷载作用在单元局部坐标系y轴方向上。

局部坐标系z：梁荷载作用在单元局部坐标系z轴方向上。

整体坐标系X：梁荷载作用在整体坐标系X轴方向上。

整体坐标系Y：梁荷载作用在整体坐标系Y轴方向上。

整体坐标系Z：梁荷载作用在整体坐标系Z轴方向上。

取消：单击取消删除输入的数值或选择另一种荷载类型。

投影

决定梁荷载是沿整个梁长作用还是沿与荷载作用方向垂直的梁的投影长度作用。

是：梁荷载沿与荷载作用方向垂直的梁的投影长度作用。

否：梁荷载沿整个梁长作用。

增减系数

增加或减小作用荷载的比例因子。


13_压力荷载

Home > midas Gen 2017 > 07_荷载 > 01_静力荷载 > 05_压力荷载 > 01_压力荷载

压力荷载

  • 功 能

将压力荷载作用在板、平面应力、平面应变、轴对称或实体单元的边缘或表面，也可以修改或删除先前输入的压力荷载。

压力荷载可以按均匀分布或线性分布输入，程序将自动其转换为等效节点力。

板单元和平面应变单元的压力荷载可以以整体坐标系或单元局部坐标系为基准输入，也可以按指定方向输入。当作用在面上时，荷载方向与给定坐标系的某一轴一致；当作用在边上时，荷载方向垂直于边(平面内方向)。荷载作用方向由外向边为正(+)，反之为负(-)。作用在边上的荷载按线荷载输入。

作用在平面应变和轴对称单元的压力荷载方向垂直与单元的边缘(平面内方向)。荷载作用方向由外向边为正(+)，反之为负(-)。作用在边上的荷载按线荷载输入。

实体单元的压力荷载方向垂直于表面。荷载作用由外指向单元表面时为正方向(+)，反之为负(-)。

(a) 压力荷载垂直作用于板、平面应力、平面应变、轴对称单元的边缘

(b) 压力荷载垂直作用于板单元的表面

(c) 压力荷载垂直作用于实体单元的表面

<图1> 作用于各种单元上的压力荷载

  • 命 令

从主菜单中选择荷载 > 压力荷载...

在树形菜单的菜单表单中选择静力荷载 > 压力荷载

  • 输 入

荷载工况名称

输入荷载工况名称。单击右边的 [image] ，可以建立、修改或删除荷载工况。

荷载组名称

选择压力荷载将要所属的荷载组。当不需要指定组时，选择"默认值"。当需要添加和编辑荷载组时，可以点击右面的 [image] ，将弹出"定义荷载组"对话框。

选项

添加：输入新的或添加压力荷载。

替换：替换先前输入的压力荷载。

删除：删除先前输入的压力荷载。

单元类型

选择承受压力荷载的单元类型。参考下面的图确认加载方向和受载边。

单元上的压力荷载

板/平面应力单元(面)

压力面

选择受压面，仅适用于单元选择方式。在此只有#1面。

方向

局部x：压力荷载作用在单元局部坐标系x轴方向上。

局部y：压力荷载作用在单元局部坐标系y轴方向上。

局部z：压力荷载作用在单元局部坐标系z轴方向上。

全局X：压力荷载作用在整体坐标系X轴方向上。

全局Y：压力荷载作用在整体坐标系Y轴方向上。

全局Z：压力荷载作用在整体坐标系Z轴方向上。

向量：压力荷载作用在指定方向上。

板/平面应力单元(边)

选择：选择指定压力荷载作用边的方法。

节点：通过选择单元的两个节点选择边。

单元：直接选择单元的边(参照图中提示选择)。

压力边

选择受压边，仅适用于单元选择方式。可供选择的边有#1～#4边。

方向

法向：压力荷载与单元的边垂直。

局部x：压力荷载作用在单元局部坐标系x轴方向上。

局部y：压力荷载作用在单元局部坐标系y轴方向上。

局部z：压力荷载作用在单元局部坐标系z轴方向上。

全局X：压力荷载作用在整体坐标系X轴方向上。

全局Y：压力荷载作用在整体坐标系Y轴方向上。

全局Z：压力荷载作用在整体坐标系Z轴方向上。

向量：压力荷载作用在指定方向上。

实体单元(面)

选择：选择指定压力荷载作用面的方法。

节点：通过选择单元的节点选择面。

单元：直接选择单元的面(参照图中提示选择)。

压力面

选择受压面，仅适用于单元选择方式。可供选择的边有#1～#6面。

方向

法向：压力荷载与单元的边垂直。

局部x：压力荷载作用在单元局部坐标系x轴方向上。

局部y：压力荷载作用在单元局部坐标系y轴方向上。

局部z：压力荷载作用在单元局部坐标系z轴方向上。

全局X：压力荷载作用在整体坐标系X轴方向上。

全局Y：压力荷载作用在整体坐标系Y轴方向上。

全局Z：压力荷载作用在整体坐标系Z轴方向上。

向量：压力荷载作用在指定方向上。

平面应变单元(边)和轴对称单元

压力边

选择受压边，仅适用于单元选择方式。可供选择的边有#1～#4边。

方向

法向：压力荷载与单元的边垂直。

局部x：压力荷载作用在单元局部坐标系x轴方向上。

局部y：压力荷载作用在单元局部坐标系y轴方向上。

向量：压力荷载作用在指定方向上。

投影

当压力荷载在?全局X、Y或Z?方向作用于板或实体单元上时，选择是否将荷载投影到与荷载方向垂直的平面上。

是：投影到与荷载方向垂直的平面上。

否：压力荷载沿整个表面作用。

荷载

选择荷载是均布或线性变化。输入压力荷载值。

均布：当荷载均匀分布时。

线性变化：当荷载线性变化时。

P1、P2、P3、P4：表面或边缘的压力荷载值。


14_流体压力荷载

Home > midas Gen 2017 > 07_荷载 > 01_静力荷载 > 05_压力荷载 > 02_流体压力荷载

流体压力荷载

  • 功 能

在板、平面应力、平面应变及实体单元的边缘或表面作用流体压力荷载。

流体压力荷载将转换为节点处的流体压力荷载。节点压力等于流体表面到节点的竖向距离乘以流体比重。

板单元连接节点处由流体势能产生的压力荷载

  • 命 令

从主菜单中选择荷载 > 流体压力荷载...

在树形菜单的菜单表单中选择静力荷载 > 流体压力荷载

  • 输 入

荷载工况名称

输入荷载工况名称。单击右边的 [image] ，可以建立、修改或删除荷载工况。

荷载组名称

选择流体压力荷载将要所属的荷载组。当不需要指定组时，选择"默认值"。当需要添加和编辑荷载组时，可以点击右面的 [image] ，将弹出"定义荷载组"对话框。

选项

添加：输入新的或添加流体压力荷载。

替换：替换先前输入的流体压力荷载。

删除：删除先前输入的流体压力荷载。

荷载类型

指定随流体的位置而变化的压力荷载的加载形式，分为以下两种类型。

线性荷载：将随流体的位置而变化的压力荷载按直线形式加载。

曲线荷载：将随流体的位置而变化的压力荷载按曲线形式（2次曲线或0.5次曲线）加载。

注：

曲线荷载是将单元按3等分之后加载，一个单元如果很长，其荷载形式就会接近直线，故单元分割的越细，其荷载形式就会越接近于曲线。

单元类型

选择承受流体压力荷载的单元类型。参考下面的图，确认加载方向及受载边。

板单元

加载方向

法向：流体压力荷载与单元的边垂直。

局部坐标系x：流体压力荷载作用在整体坐标系x轴方向上。

局部坐标系y：流体压力荷载作用在整体坐标系y轴方向上。

局部坐标系z：流体压力荷载作用在整体坐标系z轴方向上。

整体坐标系X：流体压力荷载作用在整体坐标系X轴方向上。

整体坐标系Y：流体压力荷载作用在整体坐标系Y轴方向上。

整体坐标系Z：流体压力荷载作用在整体坐标系Z轴方向上。

平面应变单元和轴对称单元

选择：选择指定压力荷载作用边的方法。

节点：通过选择单元的节点选择边。

单元：直接选择单元(参照图中提示选择)。

压力边：参照图形选择加载边。

实体单元

选择：选择指定压力荷载作用面的方法。

节点：通过选择单元的节点选择面。

单元：直接选择单元的面(参照图中提示选择)。

压力面：参考图选择加载面的编号

加载方向

法向：压力荷载作用于实体单元表面的法线方向上。

整体坐标系X：压力荷载作用在整体坐标系X轴方向上。

整体坐标系Y：压力荷载作用在整体坐标系Y轴方向上。

整体坐标系Z：压力荷载作用在整体坐标系Z轴方向上。

投影

当压力荷载在法向、整体坐标系X、Y或Z方向作用于实体单元上时，选择是否将荷载投影到与荷载方向垂直的平面上。

是：投影到与荷载方向垂直的平面上。

否：压力荷载沿整个表面作用。

流体荷载

流体压力荷载应用条件如下：

流体荷载 = P0 + g(H - h)

其中，P0为均布压力，g为流体比重，H-h为单元节点距流体水平面的距离。

荷载变化方向：决定流体荷载大小的变化方向。

整体坐标系(-X)
整体坐标系(-Y)
整体坐标系(-Z)

起始位置：开始产生流体荷载压力的基准面(用鼠标或键盘输入)。

均布压力荷载(P0)：作用在流体表面的压力。(参照图形输入)。

流体容重(g)：流体的容重。

注：

使用流体压力荷载定义土的侧压力的方法如下。?单元类型?使用板单元，板单元需进行适当地划分。

?方向?指定为荷载作用的方向。?荷载变化方向?一般设定为重力的作用方向（整体坐标系-Z）。

?均布压力荷载(Po)?中输入上部长期荷载作用引起的土压力大小，这里也需考虑土压力系数。?流体容重(g)?需考虑土压力系数，而且还需要考虑地下水的影响。

1) 不考虑地下水位的影响时（只考虑土）

土：g = 土压力系数×土的容重

2) 考虑地下水位的影响时（对土和水要分别输入）

土：g = 土压力系数×地下水位以下土的容重

水：g = 水的容重

(对于水，参考高度(H)需指定为地下水位的位置)

曲线荷载类型的流体荷载

荷载

曲线流体压力荷载输入方法如下：

?荷载变化方向?以及?参考高度?的输入方法与线性流体压力荷载相同。

选择曲线函数形式。

a, b, c：曲线函数的各系数。


15_定义平面荷载类型

Home > midas Gen 2017 > 07_荷载 > 01_静力荷载 > 05_压力荷载 > 03_分配面荷载 > 01_定义平面荷载类型

定义平面荷载类型

  • 功 能

定义平面荷载的形式和大小。

平面荷载将通过分配平面荷载功能分配给结构。

使用平面荷载功能可以输入作用在板单元和实体单元上任意位置的荷载。在建模过程中，不必在荷载作用点位置建立节点和网格，减少了工作量和建模的繁琐。输入的荷载根据板单元和实体单元的刚度转换为节点荷载。

  • 命 令

从主菜单中选择荷载 > 定义平面荷载类型...

在树形菜单的菜单表单中选择静力荷载 > 定义平面荷载类型

  • 输 入

定义平面荷载类型对话框

当需要新建或添加平面荷载时，点击 [image] ；当需要修改已定义的平面荷载时，在列表中选择相应荷载，做相应修改后点击 [image] ；当需要删除已建立的平面荷载时，点击 [image] 。

平面荷载类型和说明

名称：输入荷载名称。在分配平面荷载功能中将选择在此定义的平面荷载名称。

说明：输入对荷载的简要说明。

平面荷载

定义荷载的加载位置、加载方式和荷载大小。

荷载类型

荷载类型有集中荷载、线荷载和面荷载。

集中荷载

x, y：荷载作用点的平面坐标系坐标。

注
平面坐标系是在分配平面荷载命令中定义的。参见分配平面荷载。

荷载：集中荷载的大小。

弯矩：集中弯矩的大小。

线荷载

均布：当为均布线荷载时，选择该项。

类型：选择线荷载的类型。

x1, y1：线荷载的起点坐标(平面坐标系坐标)。

x2, y2：线荷载的结束点坐标(平面坐标系坐标)。

荷载：各位置的线荷载的大小。

面荷载

均布：当为均布面荷载时，选择该项。

点：选择决定面荷载加载区域的点数。可供选择的有三点和四点。

x1, y1：面荷载加载区域的第一个加载角点的坐标(平面坐标系坐标)。

x2, y2：面荷载加载区域的第二个加载角点的坐标(平面坐标系坐标)。

x3, y3：面荷载加载区域的第三个加载角点的坐标(平面坐标系坐标)。

x4, y4：选择了四点时，面荷载加载区域的最后一个加载角点的坐标(平面坐标系坐标)。

荷载：各加载角点处的面荷载的大小。

注1
一定要按顺时针或逆时针方向指定各角点。

注2
可以将平面坐标系方向设定成与整体坐标系相同，也可以将用户坐标系设定成与用户坐标系相同。此时可以使用鼠标编辑功能和点格功能，简便地输入加载位置。

复制到x轴方向

将定义的平面荷载沿平面坐标系x轴方向复制，输入复制间距。

复制到y轴方向

将定义的平面荷载沿平面坐标系y轴方向复制，输入复制间距。


16_分配平面荷载

Home > midas Gen 2017 > 07_荷载 > 01_静力荷载 > 05_压力荷载 > 03_分配面荷载 > 02_分配平面荷载

分配平面荷载

  • 功 能

可用于定义平面或实体单元上指定位置处的平面荷载
平面荷载的功能是由将用户定义的荷载类型加载到板单元或实体单元上。当指定特定荷载到各种位置时该功能非常有用，如设备荷载。在定义平面荷载类型里定义好荷载类型和大小，选择指定的加载位置。
压力荷载分配到整个单元上。另一方面，不论单元是否分割，用户都能随意定义平面荷载，如下图所示。

  • 命 令

从主菜单中选择荷载 > 分配平面荷载...

在树形菜单的菜单表单中选择静力荷载 > 分配平面荷载

  • 输 入

荷载工况名称

输入荷载工况名称。单击右边的 [image] 可以建立、修改或删除荷载工况。

荷载组名称

选择平面荷载将要所属的荷载组。当不需要指定组时，选择"默认值"。当需要添加和编辑荷载组时，可以点击右面的 [image] ，将弹出"定义荷载组"对话框。

平面荷载类型

荷载类型：选择在定义平面荷载类型中定义的荷载类型。需要添加和编辑平面荷载类型时，点击右侧的 [image] 。

单元类型：选择要加载平面荷载的单元类型，可供选择的有板单元和实体单元。

加载平面：定义加载平面坐标系。

第一点(原点)：平面坐标系的原点的整体坐标系坐标。

第二点(在x轴)：平面坐标系x轴上的任意点的整体坐标系坐标。

第三点(在x-y平面上)：平面坐标系x-y平面上任意点的坐标。

误差：决定平面坐标系坐标的容许误差(公差)。

自动设置

：选择已定义的用户坐标系作为平面坐标系。

：选择已命名的平面作为平面坐标系。

注
命名平面的方法不同，定义用户坐标系的方法也不一样。

用3点命名平面时：第一点为原点，第二点为x轴。

用X-Y平面命名平面时：X, Y坐标为'0'的点为原点，x, y轴同整体坐标轴。

用X-Z平面命名平面时：X, Z坐标为'0'的点为原点，整体坐标系X轴为x轴，整体坐标系Z轴为y轴。

用Y-Z平面命名平面时：Y, Z坐标为'0'的点为原点，整体坐标系Y轴为x轴，整体坐标系Z轴为y轴。

选择单元

选择要加载的单元。

加载平面上的单元：给加载平面坐标系上的单元加载。

组：给选择的结构组中的单元的加载投影面加载。

组名称：选择结构组。

加载面：如果是给实体单元加载，选择实体单元的加载面。

注
当选择给组加载时，组中各方向的单元及面都将被加载，加载面为与加载方向垂直的投影面。

荷载方向和投影

加载方向

法向(加载平面)：垂直于加载平面。

法向(单元)：垂直于单元的面。

整体坐标系X：沿整体坐标系X轴方向加载。

整体坐标系Y：沿整体坐标系Y轴方向加载。

整体坐标系Z：沿整体坐标系Z轴方向加载。

投影

决定加载平面荷载时是否按投影面积。

否：加载面积使用单元面积。

荷载方向：投影到平面荷载类型中加载方向上的面积。

加载平面：垂直于平面荷载类型中加载方向上的面积。

图1 平面荷载的加载位置和大小

加载方向：法向(加载平面)。

投影：否。

加载方向：法向(单元)。

投影：荷载方向。

加载方向：法向(加载平面)。

投影：加载平面。

加载方向：法向(单元)。

投影：加载平面

加载方向：整体坐标系Z。

投影：荷载方向。

图2. 荷载方向和投影

说明

输入对荷载的简单说明。

用节点定义加载区域

在"选择单元"中选择了加载平面上的单元时，选择平面荷载的加载区域。

按顺时针或逆时针输入决定加载区域的各角点节点号。

选择了加载区域之后，在平面荷载类型中定义的荷载中，只有包含在加载区域内的荷载才能被加载。

如果不指定加载区域，则在平面荷载类型中定义的荷载被全部加载。

使用鼠标编辑功能输入角点号时，最后一定要回到开始角点，才能完成输入。

复制平面荷载

将输入的荷载复制到其他平面或结构组中。

方向：复制的方向。

x：整体坐标系(或局部坐标系)x轴方向。

y：整体坐标系(或局部坐标系)y轴方向。

z：整体坐标系(或局部坐标系)z轴方向。

距离：复制的距离。重复复制时，可按复制次数输入间距。


01_几何刚度初始荷载

Home > midas Gen 2017 > 07_荷载 > 01_静力荷载 > 06_初始荷载/其它 > 01_初始荷载 > 01_大位移 > 01_几何刚度初始荷载

几何刚度初始荷载

  • 功 能

输入计算几何刚度所需的初始荷载(轴力)。仅用于大位移分析。

程序会根据输入的初始荷载计算出平衡外力(反力)，并生成初始平衡状态(有内力、反力、无位移)。在此初始平衡状态下做结构的分析。

  • 命 令

从主菜单中选择荷载 > 初始荷载 > 大位移> 几何刚度初始荷载...

在树形菜单的菜单表单中选择静力荷载 >大位移> 几何刚度初始荷载

  • 输 入

选项

添加/替换：在选定的构件中输入新的或替换现有的初始荷载。

删除：删除选定的构件中的初始荷载。

初始荷载

输入几何刚度计算所需的初始荷载。

方向：选择初始荷载(轴力)的方向。

轴向：将输入的内力作为单元轴力。

整体坐标系X：将力作用于整体坐标系X轴方向，程序将自动计算沿单元轴向的荷载。

整体坐标系Y：将力作用于整体坐标系Y轴方向，程序将自动计算沿单元轴向的荷载。

整体坐标系Z：将力作用于整体坐标系Z轴方向，程序将自动计算沿单元轴向的荷载。


01_初始荷载控制数据

Home > midas Gen 2017 > 07_荷载 > 01_静力荷载 > 06_初始荷载/其它 > 01_初始荷载 > 02_小位移 > 01_初始荷载控制数据

初始荷载控制数据

  • 功 能

用于小位移分析。

将输入的初始荷载作为一个独立的荷载工况结果保存，或计算外部荷载引起的结构各单元产生的节点力和单元内力。

在定义时程分析荷载工况时，在分析类型中选择?非线性?、在分析方法中选择静力法时，如果要考虑自重引起的结构内力作为初始状态，可勾选初始单元内力（表格）选项，并在初始单元内力中输入相应数据。初始单元内力可通过初始荷载控制数据中的初始内力组合选项自动生成。

计算得出的节点力和单元内力可以在结果 > 分析结果表格> 平衡单元节点内力和 结果 > 分析结果表格 > 初始单元内力里查看。

这里的节点力等于各个节点的位移乘以结构刚度的乘积，内力等于节点力加上固端内力的值。

初始内力组合与给单元添加初始单元荷载不能同时勾选使用。

  • 命 令

从主菜单中选择荷载 > 初始荷载 > 小位移 > 初始荷载控制数据...

在树形菜单的菜单表单中选择静力荷载 > 初始内力（小位移） > 初始荷载控制数据

  • 输 入

初始荷载控制数据对话框

给单元添加初始荷载

勾选该项，则将“荷载->初始荷载->初始单元内力”中定义的荷载添加到指定的工况中

荷载工况：选择并输入荷载工况，以便保存结果。

初始内力组合

荷载工况：将某一工况的内力作为初始内力。

系数：输入增减系数。

考虑初始轴力对几何刚度的影响

计算几何刚度时，考虑初始轴力的影响。


02_初始单元内力

Home > midas Gen 2017 > 07_荷载 > 01_静力荷载 > 06_初始荷载/其它 > 01_初始荷载 > 02_小位移 > 02_初始单元内力

初始单元内力

  • 功 能

输入使用平衡内力控制系数计算得出的外部荷载作用下结构各单元产生的构件内力。在荷载 > 初始荷载 > 小位移 > 初始荷载控制数据里选择要计算的荷载工况后运行分析，根据选择的荷载工况计算出来的内力，可以在结果 > 分析结果表格 > 初始单元内力 里查看。

把结果复制到初始单元内力里，然后进行特征值分析可以得出考虑几何刚度的特征值分析结果。进行时程分析时，设定初始荷载时选择(时程荷载工况对话框里面的加载顺序选择初始单元内力(Table)，则利用此表的初始荷载进行时程分析。

  • 命 令

从主菜单中选择荷载 > 初始荷载 > 小位移 > 初始单元内力...

在树形菜单的菜单表单中选择静力荷载 > 小位移 > 初始单元内力

  • 输 入

轴力-i：i端产生的轴力

剪力(y)-i：i端产生的单元坐标系y轴方向的剪力

剪力(z)-i：i端产生的单元坐标系z轴方向的剪力

扭矩-i：i端产生的扭矩

弯矩(y)-i：i端产生的单元坐标系绕y轴方向的弯矩

弯矩(z)-i：i端产生的单元坐标系绕z轴方向的弯矩

轴力-j：j端产生的轴力

剪力(y)-j：j端产生的单元坐标系y轴方向的剪力

剪力(z)-j：j端产生的单元坐标系z轴方向的剪力

扭矩-j：j端产生的扭矩

弯矩(y)-j：j端产生的单元坐标系绕y轴方向的弯矩

弯矩(z)-j：j端产生的单元坐标系绕z轴方向的弯矩


10_定义楼面荷载类型

Home > midas Gen 2017 > 07_荷载 > 01_静力荷载 > 06_初始荷载/其它 > 02_分配楼面荷载 > 01_定义楼面荷载类型

定义楼面荷载类型

  • 功 能

定义楼面荷载工况及相应的楼面荷载。

此处定义的楼面荷载由分配楼面荷载命令施加到结构上。

尽管诸如恒载、活载、屋面荷载和雪荷载等楼面荷载的荷载形式和大小不同，但它们的加载区域可能相同。为避免重复输入并加快荷载数据的输入过程，MIDAS将楼面荷载的定义和分配分开来进行。

  • 命 令

从主菜单中选择荷载 > 定义楼面荷载类型...

  • 输 入

定义楼面荷载对话框

定义或增加新的楼面荷载工况

输入下列各项并单击 [image] ：

楼面荷载

名称：输入楼面荷载名称。
用分配楼面荷载命令分配作用在结构上的楼面荷载时，名称将用于选择楼面荷载类型。通常可按建筑用途指定名称(如办公室、屋顶等)。

说明：输入对荷载形式的简短描述。

楼面荷载大小和所属荷载工况

指定荷载工况并输入相应的楼面荷载值。

荷载工况：选择所属的荷载工况。该荷载工况信息中包含荷载类型，将用于自动生成荷载组合中。因此应正确选择荷载工况。

楼面荷载：输入单位面积上的楼面荷载值。荷载的符号规则参见"分配楼面荷载"中的图3。

注
用户可以将荷载规范中的各种楼面活荷载事先做成数据库，单击右侧的 [image] ，在数据库中选择相应荷载。参见工具>参数设置中的荷载。

建筑结构荷载规范(GB50009-2001)均布活荷载标准值数据库

次梁的重量：对未参与建模的次梁，选择是否包括该次梁的自重(参见"分配楼面荷载"中的注)

修改先前定义的楼面荷载类型

在对话框底部的列表中选择相应的楼面荷载名称，做相应修改后单击 [image] 。

删除先前定义的楼面荷载类型

在对话框底部的列表中选择相应的楼面荷载名称后单击 [image] 。


11_分配楼面荷载

Home > midas Gen 2017 > 07_荷载 > 01_静力荷载 > 06_初始荷载/其它 > 02_分配楼面荷载 > 02_分配楼面荷载

分配楼面荷载

  • 功 能

在闭合的平面多边形内输入楼面荷载。楼面荷载将被转换为梁上线荷载或集中荷载。

将楼面荷载转换为梁上或墙上荷载是一件非常繁琐的工作。MIDAS程序提供了单向板、双向板、多边形(按长度分配)、多边形(按面积分配)等四种导荷载的方式。如果用户需要对异形板做比较精确的荷载转换(如考虑梁、板间的变形协调)，可以另外建立异形板的模型，或使用MIDAS/SDS做比较精确的楼板分析。

楼面荷载的加载区域由闭合的多边形组成，加载区域必须在一平面内，但不一定必须平行于整体坐标系的坐标轴。

  • 命 令

从主菜单中选择荷载 > 分配楼面荷载...

在树形菜单的菜单表单中选择 静力荷载 > 分配楼面荷载

  • 输 入

荷载组名称

选择楼面荷载将要所属的荷载组。当不需要指定组时，选择"默认值"。当需要添加和编辑荷载组时，可以点击右面的 [image] ，将弹出"定义荷载组"对话框。

楼面荷载类型

楼面荷载：选择由定义楼面荷载类型定义的楼面荷载。必要时，单击右边的 [image] ，添加、修改或删除现有的楼面荷载类型。

分配模式：选择荷载的分配方式。

单向：按单向板分配。

双向：按双向板分配。

多边形-面积：按多边形重心与各边组成的三角形的面积与总面积的比分配。

多边形-长度：按多边形各边长与总周长的比分配。

不考虑内部单元的面积：分配荷载时不分配到内部单元上。

允许凹多边形楼面荷载输入：该项用于施加荷载到内角大于180度的凹多边形时。选择双向板导荷时，可以选择该项。

载荷角度(A1)：定义荷载分布方向的角度。

荷载角度仅适用于荷载单向分布时。载荷角度是加载区域的第一节点和第二节点的连线与荷载分布方向的加角。角度的符号遵循右手法则，右手的旋转方向为定义加载区域的角点顺序。(参见图2、3)

假想次梁

楼板荷载的荷载传递路径一般为楼板->次梁->主梁->柱>基础。传递的大小由楼板、梁、柱的刚度(变形协调)决定。

支承在主梁上的次梁一般可以看做铰支在主梁上(负筋按构造配筋)，仅仅作为传递楼面荷载的中间构件，对结构整体的刚度影响不是很大。因此，通常在分析模型中可以不考虑次梁。

当在分析中不考虑次梁影响时，为了正确反映荷载的传递，在MIDAS软件中引进了假想次梁的概念。

由假想次梁、梁和墙形成的次加载区域的形状必须是三角形或四边形。

次梁数量：在次加载区域内的次梁构件数量(参见注和图4、5)。

次梁角度(A2)：次梁构件的布置角度(参见图4、5)。

次梁线荷载：次梁单位长度上的荷载，包括自重和次梁上的砌体重量。

荷载方向和投影

选择楼面荷载的作用方向和投影选项。

输入加载区域时，同时自动确定了加载区域的局部坐标系，即从第一点到第二点的方向为平面的局部坐标系x轴。旋转方向按选择的节点次序。按右手法则和旋转方向决定局部坐标系的z轴方向。在第一角点处垂直于x和z轴的方向为y轴方向。(参见图3)

局部坐标系x：楼面荷载作用在楼板局部坐标系的x轴方向(参见图3)。

局部坐标系y：楼面荷载作用在楼板局部坐标系的y轴方向(参见图3)。

局部坐标系z：楼面荷载作用在楼板局部坐标系的z轴方向(参见图3)。

整体坐标系X：楼面荷载作用在整体坐标系的X轴方向。

整体坐标系Y：楼面荷载作用在整体坐标系的Y轴方向。

整体坐标系Z：楼面荷载作用在整体坐标系的Z轴方向。

<图1> 楼面荷载转换为作用在梁单元上的分布荷载(无次梁时)

<图2> 单向分布时荷载角度(A1)的概念

<图3> 角点方向的顺序和楼板局部坐标系之间的关系

<图4> 次梁数量和次梁角度(A2)的定义

<图5> 次梁角度(A2)的概念(次梁数量=2)

投影

当楼面荷载方向与整体坐标系X、Y或Z一致时，选择是否投影楼面荷载。

是：楼面荷载作用在与荷载作用方向垂直的投影面上。

否：楼面荷载沿整个面作用。

说明

输入对荷载的简要描述。

指定加载区域的节点

按已选定的转动方向依次选择定义加载区域的角点。用户可以直接输入节点编号，也可以用鼠标编辑功能点击输入区后，在模型窗口中选择节点。楼板局部坐标系和荷载正负号由角点的选择次序决定。(参见图3)

注

分配楼面荷载时报错常见原因

1.分配的范围内有重复节点。

2.分配的范围内有重复单元。

3.分配的范围内有单元没有被节点分割。

4.分配的范围不是闭合面。

如<图6>中所示可以连续输入角点。不需要选择非角点，如<图6>中的N9和N11。

加载区域的边界线可以有凹点。但所有的节点必须在同一平面上。区域内的梁单元(或墙单元)围成的区域必须保持三角形或四边形区域。

在模型窗口中用鼠标连续选择角点，并再次确认第一节点，完成围区。

<图6> 定义承受楼面荷载的加载区域的角点

复制楼面荷载

将输入的楼面荷载复制到其它具有相同形状(尺寸)的楼板上。

方向：指定复制方向。

x：用户坐标系x轴方向。

y：用户坐标系y轴方向。

z：用户坐标系z轴方向。

距离：按需要复制楼面荷载的次数输入相应距离。

注

利用次梁概念，将楼面荷载转换为作用在梁或墙单元上的分布荷载和集中荷载的方法如下：

  1. 由角点定义的楼面荷载加载区域如图7(a)所示。在边界内设置梁或墙单元，形成三角形或四边形的围区，从而组成子加载区域，如图7(b)所示。

  2. 定义次梁数量后，进一步分为如图7(c)所示的子加载区域(图7(c)中次梁数量 = 1)。

  3. 按双向分配，作用在梁(或墙)单元及次梁上的分布荷载如图7(d)所示。作用在次梁上的分布荷载转换为节点反力(假定两端铰接)。

  4. 由次梁传来的反力和作用在梁(或墙)单元上的分布荷载最后作用在梁(或墙)单元上，如图7(e)所示。

  5. 当假想次梁与楼板局部坐标x轴形成角度"A2"(如图4(a)所示)，由两条通过最远角点且平行于次梁的投影线确定假象线的长度，以"次梁数量+1"个等间距分割假想线，假想线围成的区域即为子加载区域。由次梁和现有梁(或墙)单元围成的加载区域的形状只能是三角形或四边形。图4(b)介绍了违背基本形状要求的错误的五边形(阴影区域)加载区域。

<图7> 楼面荷载转换为作用在梁单元上(或墙单元顶面)的分布荷载

转换为梁单元荷载

当不选择该项时，程序内部将保存有楼板荷载的信息，在现有的平面内添加梁或墙单元时，程序自动将楼面荷载重新分布。当选择该项时，程序内部将删除楼面荷载信息，在现有的平面内添加梁或墙单元时，楼面荷载不能重新分布，即新增加的单元上不承受楼面上传来的荷载。

注
当需要改变楼面荷载大小时，仅需修改楼面荷载类型的值，程序自动将修改后的楼面荷载作用到模型上。然而如果已选择转换为梁荷载类型，则修改楼面荷载类型的值将不起作用。此时必须直接修改作用到梁单元上的荷载。

使用楼面荷载功能的其他注意事项

  • 楼面荷载作用在由梁或墙单元区分的三角形或四边形区域上。使用次梁时，要求形状必须保持闭合且围成的区域也应是三角形或四边形。

  • 梁单元重叠时，不能使用楼面荷载。此时，用"删除单元"或"检查并删除重复单元"删除重复的数量。


12_装饰材料荷载

Home > midas Gen 2017 > 07_荷载 > 01_静力荷载 > 06_初始荷载/其它 > 03_装饰材料荷载

装饰材料荷载

  • 功 能

输入并计算装饰荷载，也可以修改和删除已定义的装饰材料荷载。

  • 命 令

从主菜单中选择荷载 > 装饰材料荷载...

在树形菜单的菜单表单中选择静力荷载 > 装饰材料荷载

  • 输 入

荷载工况名称

输入荷载工况名称。单击右边的 [image] ，可以建立、修改或删除荷载工况。

荷载组名称

选择装饰材料荷载将要所属的荷载组。当不需要指定组时，选择"默认值"。当需要添加和编辑荷载组时，可以点击右面的 [image] ，将弹出"定义荷载组"对话框。

选项

添加：输入新的或添加装饰材料荷载。

替换：替换先前输入的装饰材料荷载。

删除：删除先前输入的装饰材料荷载。

装饰方式

有包裹(顺周长)、填充(沿最外延尺寸围成长方形或圆形，并填充内部空隙)、围绕(沿最外延尺寸围成长方形或圆形，不填充)，参照图形输入。

装饰范围

参照图形选择装饰的范围。"半"表示该面只装修一半。

装饰特性值

d：装饰材料的厚度。

比重：装饰材料的比重。

方向: 装饰材料的作用方向(整体坐标系X、Y、Z)。

系数: 装饰材料的作用方向及增减系数。


04_加载面

Home > midas Gen 2017 > 07_荷载 > 01_静力荷载 > 06_初始荷载/其它 > 04_加载面

加载面

  • 功 能

定义输入风压荷载的加载面。将具有相同风荷载的受力特性的板单元和梁单元定义为同一加载面，在主菜单 荷载 > 静力荷载 > 横向荷载 > 风压 中，通过直接选择加载面来定义面风压或梁单元风压。

  • 命 令

从主菜单中选择荷载 > 静力荷载 > 初始荷载/其它 > 加载面

在树形菜单的菜单表单中选择静力荷载 > 加载面

  • 输 入

加载面组名称

定义各加载面的名称。单击右边的 [image] ，可以按照一定的编号规律定义加载面名称。

选项

添加：输入新的或添加加载面。

替换：替换先前输入的加载面。

删除：删除先前输入的加载面。

单元类型

框架：加载面由梁单元组成，只能在模型中选择梁单元进行添加；

板：加载面由板单元组成，只能在模型中选择板进行添加。

选择单元定义加载面

输入定义加载面的单元号，当在模型中选择单元时，单元号自动读入到该文本框中。


01_反应谱函数

Home > midas Gen 2017 > 07_荷载 > 02_地震作用 > 01_反应谱数据 > 01_反应谱函数

反应谱函数

  • 功 能

输入反应谱分析所需的反应谱数据
反应谱分析通过特征值分析得到自振周期来计算各振型反应。因而必须定义反应谱函数，其中包含了特征值分析中得到的基本周期的范围。

特征值分析得到的基本周期的范围

  • 命 令

从主菜单中选择荷载 > 反应谱数据 > 反应谱函数...

在树形菜单的菜单表单中选择反应谱分析数据 > 反应谱函数

  • 输 入

<图1> 反应谱函数对话框

输入新的或附加的反应谱数据时

单击 [image] 。

修改先前输入的反应谱数据时

从对话框的反应谱数据列表中选择相应的谱数据并单击 [image] 。

删除先前输入的反应谱数据时

从对话框的反应谱数据列表中选择相应的谱数据并单击 [image] 。

单击 [image] 或 [image] ，在相应的输入区内输入相应的数据。

<图2> 添加/编辑/显示地震影响系数曲线对话框

函数名称

输入反应谱函数名称。该名称用于定义"反应谱荷载工况"。

反应谱数据

确认要输入的反应谱数据类型。

无量纲加速度：加速度反应谱除以重力加速度得到的频谱。

加速度：加速度反应谱。

速度：速度反应谱。

位移：位移反应谱。

注

变更上述的反应谱数据的形式时，已输入的数据并不会根据单位自动更改。

放大

放大系数:输入反应谱数据的调整系数(一般为放大)。

最大值：反应谱数据的最大值可根据用户在这里输入的值来调整。

重力加速度

输入重力加速度。该数据将被用于将无量纲加速度和等效质量转换为荷载。

阻尼比

输入结构的阻尼比，也可以在设计反应谱中直接输入(有的设计反应谱中有阻尼比输入选项)。

反应谱分析时有三处可输入阻尼比:

a. 设计反应谱中直接输入(例如建筑抗震设计反应谱)

b. 在本对话框中输入

c. 在反应谱分析工况中输入

程序最终使用的阻尼比优先顺序为c，b，a。

图形选项

决定图形是否使用对数刻度。

说明

输入对反应谱的简要说明(不能超过80个字节)。

在MIDAS中支持下列4种反应谱数据输入方法：

  1. 将频繁使用的反应谱荷载工况保存为文件，然后在其他工程中调用。

  2. 从数据库中调用反应谱数据。

  3. 用地震荷载生成器输入。

  4. 用户直接输入反应谱数据。

将频繁使用的反应谱荷载工况保存为文件，然后调用的方法

点击 [image] ，调用先前生成的反应谱数据。数据以?.sgs? 或?.spd?扩展名保存，文件格式如下：

文件名.sgs的文件格式

*SGSw | 说明文件为"地震数据生成器"数据格式的注释文。
*TITLE, ATC 3-06 Design Spectrum | 总注释1
*TITLE, Soil = 1.0 Aa = 1.00 Av =1.00 RMF = 1.00 | 总注释2
*X-AXIS，Period Tn(sec) | 描述水平轴
*YAXIS，Absolute Acceleration(g) | 描述垂直轴
*UNIT&TYPE,GRAV, ACCEL | 描述使用单位(g)和数据类型(加速度)
*FLAGS, 0, 0 | -
*DATA | -
1.00000E-006, 2.50000+000 | X: 周期，Y: 反应谱数据
4.00000E-002, 2.50000E+000 | -
8.00000E-002, 2.50000E+000 | -
1.20000E-001, 2.50000E+000 | -
: | -

文件名.spd的文件格式-用户输入的数据格式

** 注释，可在任意处输入 | 选项
*UNIT，M - MM, CM, M, INCH, FEET, GRAV 可以输入的单位 | -
*TYPE，ACCEL - ACCEL, VELO, DISP 可以输入的内容 | -
*DATA | 必须输入
X1, Y1 (X: 周期，Y: 反应谱数据) | -
X2, Y2 | -
X3, Y3 | -
: | -

文件名.thd 的文件格式-用户输入的数据格式

** 注释，可在任意处输入 | 说明
*UNIT，LENGTH,FORCE | 用于描述长度和力 长度可用单位：MM,CM,M,INCH(IN),FEET(FT) 力可用单位：KG,KGF,TON,N,KN,LBF,KIP
*TYPE | 用于描述类型 可以输入的类型：ACCEL（加速度）,VELO（速度）,DISP（位移）
*DATA | 数据开始之前定义
X-DATA, Y-DATA | X: 周期，Y: 反应谱数据

从MIDAS数据库中调用反应谱数据

点击 [image] ，从数据库中调用相应国家的反应谱数据，并输入相关内容。

MIDAS程序数据库中包括的各国设计反应谱如下：

China(GB50011-2010)：建筑抗震设计规范，中国国家标准。

<图3> 建筑抗震设计规范

<图4> 按《建筑抗震设计规范》生成的反应谱图形

注
用户也可以对数据做相应验算。

ChinaShanghai(DGJ08-9-2003)：上海地区反应谱函数

IBC2012: 美国，国际建筑规范 2012

IBC2009: 美国，国际建筑规范 2009

IBC2000: 美国，国际建筑规范 2000

IBC2000(ASCE7-98)：美国，国际建筑规范 2000。

UBC(1997)：美国，UBC 97标准。

UBC 88-94：美国，UBC 88-94标准。

NBC(1995)：加拿大，National Building Code of Canada (1995)。

EUROCODE-8(2004) ：欧洲，结构抗震设计标准。

EUROCODE-8(1996) Design：欧洲，结构抗震设计标准。

EUROCODE-8(1996) Elastic：欧洲，结构抗震设计标准。

IS1893 (2002): 印度标准

Taiwan (2006):台湾抗震规范

Taiwan (1999) Horizontal: 台湾抗震规范

Taiwan (1999) Vertical: 台湾抗震规范

TaiwanBrg (89) Horizontal: 台湾抗震规范

TaiwanBrg (89) Vertical: 台湾抗震规范

Japan (Arch, 2000):日本建筑荷载规范

Korean (KBC 2005):韩国建筑规范

Korea (Arch, 2000): 韩国建筑结构荷载规范

Korea (Arch, 1992): 韩国建筑结构规范

Korea (Bridge):韩国公路桥规范

China (GB50011-2001):建筑抗震设计规范

在添加/编辑/显示地震反应谱影响系数对话框中的输入区内直接输入反应谱数据

用户在对话框左边的输入区内直接输入周期和反应谱数据。

在反应谱分析中，与结构自振周期对应的反应谱数据是靠线性内插得到的。因此在曲率变化较大处，应该以比较小的时间间隔提供函数值，反应谱函数的周期范围应包括所有的结构自振周期。


02_反应谱荷载工况

Home > midas Gen 2017 > 07_荷载 > 02_地震作用 > 01_反应谱数据 > 02_反应谱

反应谱荷载工况

  • 功 能

反应谱分析需时需要输入荷载工况、反应谱函数和荷载方向
midas Gen中反应谱分析的过程如下：

  1. 在主菜单“模型>质量”中输入质量数据
  2. 在特征值分析控制里输入模态数等特征值分析必要的数据
  3. 在反应谱函数里定义谱数据
  4. 在反应谱荷载工况里设定相关选项
  5. 点击 [image] 或通过主菜单“分析->运行分析”执行分析
  6. 分析完成后，后处理状态下，通过结果菜单查看各荷载工况和荷载组合的分析结果

  • 命 令

从主菜单中选择荷载 > 反应谱分析数据 > 反应谱荷载工况...

在树形菜单的菜单表单中选择 反应谱分析数据 > 反应谱荷载工况

  • 输 入

反应谱荷载工况

荷载工况名称

输入反应谱荷载工况的名称，该名称将用于荷载组合(参见"荷载组合")。

方向

X-Y：反应谱荷载作用于结构的水平方向(平行于整体坐标系的X-Y平面)。

Z：整体坐标系的Z方向。

自动搜索角度

自动搜索最不利地震作用方向。

最不利方向：最不利地震作用方向

正交方向：最不利地震作用方向+90度

注：“最不利方向”“正交方向”必须在定义在相同的反应谱函数里。例如，如果定义“RX”荷载工况作为“最不利方向”，RY荷载工况必须定义为“正交方向”。运行完反应谱分析，结构地震作用角度将自动的输入到“地震作用角度”中。

地震作用角度

当地震激发方向平行于X-Y平面，地震角度为与X轴的夹角(度)，角度的正负号以Z轴为基准，按右手法则确定。地震作用方向在整体坐标系的X轴上时角度为0。

系数

地震作用方向上反应谱荷载数据的放大系数。该系数只放大选择的地震作用方向上的地震作用，在反应谱函数中的放大系数将放大任意方向的地震作用。两个放大系数将相乘。

注

工程中需要做竖向反应谱分析的话，可以通过修改系数来调整该方向地震作用。

周期折减系数

特征值分析求得的周期的折减系数。

注

这个系数适用于反应谱分析中特征值分析求得的所有自振周期。如果分析时考虑非结构单元的刚度贡献作用，希望折减计算周期，此功能特别有效。

模态组合控制

振型组合控制对话框

振型组合类型

设定振型组合的方法。

SRSS：Square Root of Sum of the Squares(平方和开平方法)。

CQC：Complete Quadratic Combination(完全平方组合法)。

ABS：ABsolute Sum(绝对总和法)。

线性：按照线性进行组合。

考虑振型的正负号

给振型组合结果添加正负号，使最终结果(比如各节点的弯矩符号，各节点间的相对位置)具有连贯性。

沿着主振型方向

主振型是指在该方向质量参与度最高的振型。在每个方向，按主振型的符号(+, -)给各组合结果(节点位置)添加正负号。

沿着绝对值最大的振型方向

按所有振型结果中绝对值最大的振型的符号(+, -)添加正负号。

选择振型形状

可以针对不同的振型选择是否用于计算及修改振型参与系数。

谱函数

选择事先定义的设计频谱函数。相同设计标准的谱函数，阻尼不同时的谱函数也会变化很大。对于一个结构具有不同阻尼比时，用此功能来输入不同的谱函数。

适用阻尼计算方法

阻尼比计算方法: 定义结构的阻尼特性。

根据阻尼比修改反应谱: 选择了一个反应谱的情况，利用修正公式及阻尼比修正反应谱。

注1：选择多个反应谱的情况，根据内插法来计算反应谱，不使用保证公式。此时的阻尼系数不能超出反应谱阻尼系数的上下限。

注2：振型组合时，如果选择CQC（Complete Quadratic Combinaton）方法，则不需要使用保证公式也能计算各个模态的阻尼系数。组合方法在反应谱分析控制里面可以设定。

阻尼比计算方法

  • 振型

直接输入各个模态的阻尼比。

直接输入振型阻尼：

直接定义各模态的阻尼比

所有振型的阻尼比：

除了用户直接输入的各模态外，其它模态使用的阻尼比。适用于下面表格里定义的模态阻尼比之外所有模态。输入的阻尼比与定义反应谱函数时的阻尼比不同时，以此处输入的阻尼比为基准在多个谱函数之间内插来计算。

各模态的阻尼比：

用户直接在表格上面输入各个模态的阻尼比。

振型：模态号

阻尼比：各模态的阻尼比

  • 质量和刚度因子

利用用户定义的2个振型的动力特性和阻尼比，计算与质量和刚度矩阵成正比的阻尼比矩阵。可用此阻尼比矩阵计算其它振型的阻尼比，进行反应谱的分析。

质量和刚度因子：计算质量比例型阻尼和刚度比例型阻尼。

阻尼类型：选择阻尼比矩阵比例于质量还是刚度。

直接输入：在阻尼类型中选择的项目上输入比例系数。

从模态计算：根据用户输入的阻尼比计算比例系数自动输入。

计算因子：根据在阻尼类型中选择的项目输入相应数据。

频率：输入定义阻尼比需要的模型频率，该值将用于计算比例系数。

周期：输入定义阻尼比需要的模型周期，该值将用于计算比例系数。

阻尼比：输入相应频率或周期的阻尼比。

:点击按钮，激活阻尼比计算器对话框，可以直接输入质量、刚度系数计算和显示指定频率或周期下模型的阻尼比。当阻尼和质量、刚度成比例时，可以选择由振型阻尼定义两种振型，计算阻尼比。该功能使用户可以方便的计算剩余振型的阻尼比大小。

      • 应变能因子

根据用户在?组阻尼比?(材料和截面特性)中指定的阻尼比计算各模态的阻尼比，并用其调整反应谱函数再进行反应谱分析。

利用组阻尼比中定义的各构件或边界的阻尼的话，大部分结构的阻尼矩阵会是一种非典型的阻尼，故无法分离各模态。所以为了在进行动力分析时反映各单元不同的阻尼特性，使用变形能量的概念来计算各模态的阻尼比。

谱数据内插

选择反应谱荷载数据的内插方法。

线形: 反应谱荷载数据线形内插

对数 : 反应谱荷载数据对数内插

说明

输入对地震荷载工况的简要描述。

操作

输入以上各项后点击 [image] 。

修改已输入的反应谱荷载工况：在对话框的目录中选择反应谱分析荷载工况后点击 [image] 。

删除已输入的反应谱荷载工况：在对话框的目录中选择反应谱分析荷载工况后 [image] 。

做反应谱分析除了需要输入上述数据之外，还必须输入下列附加数据：

点击 [image] ，输入特征值分析控制数据。

点击 [image] ，输入反应谱函数。


01_时程荷载工况

Home > midas Gen 2017 > 07_荷载 > 02_地震作用 > 02_时程分析数据 > 01_荷载工况

时程荷载工况

  • 功 能

定义时程分析的条件和必需的控制数据。

MIDAS做时程分析的步骤如下：

  1. 利用模型>质量菜单中各种输入质量的命令建立模型的质量数据。

  2. 在分析>特征值分析控制对话框中输入特征值分析所需的各种控制数据。

  3. 在荷载>时程分析数据>时程荷载函数中输入时程荷载函数名称和时程荷载数据。

  4. 在荷载>时程分析数据>时程荷载工况中输入荷载工况名称、时程分析和输出所需的数据、阻尼比等数据。

  5. 当时间荷载函数用于输入节点动力荷载时，在荷载>时程分析数据>节点动力荷载中输入荷载工况名称、荷载函数名称、作用方向、到达时间等数据。

  6. 当时间荷载函数用于输入地面加速度荷载时，在荷载>时程分析数据>地面加速度中输入荷载工况名称、各方向荷载函数名称后点击操作命令。

  7. 当时间荷载函数用于将静力荷载转换为时变静力荷载时，在荷载>时程分析数据>时变静力荷载中输入荷载工况名称、荷载函数名称、作用方向、到达时间等数据。

  8. 点击分析>运行结构分析或点击图标菜单 [image] ，运行结构分析。

  9. 结构分析结束之后，利用"结果"菜单中各种后处理功能查看分析结果，或将其与其他静力荷载分析结果组合起来。

  10. 所有的分析结果都提供分析控制时间内的最大值和最小值。当需要查看各时间步骤的结果，可利用结果>时程分析结果命令，输出时程分析的文本或图形结果。

  • 命 令

从主菜单中选择荷载 > 时程分析数据 > 时程荷载工况...

在树形菜单的菜单表单中选择时程分析 > 时程荷载工况

  • 输 入

输入新的或另外的时程分析荷载工况

单击 [image] 。

修改先前输入的时程分析荷载工况

从对话框底部时程分析荷载工况列表中选择某一荷载工况，然后单击 [image] 并修改数据记录。

删除先前输入的时程分析荷载工况

从对话框底部时程分析荷载工况列表中选择某一荷载工况，然后单击 [image] 。

<图1> 时程荷载工况对话框

一般

  • 名称：输入时程分析荷载工况的名称。该名称用于"荷载组合"。

  • 说明：输入简要描述。

  • 分析类型

线性：进行线性时程动力分析。

非线性：进行非线性时程动力分析。

  • 分析方法

振型叠加法：结构的位移用相互正交位移向量的线性组合的形态求解的方法。

直接积分法：时间渐进的形式进行积分求动力方程的方法。

静力法：静力分析法，能够与分析类型的非线性分析组合进行Pushover分析。

  • 时程类型

瞬态：不重复加载时程荷载函数的时程分析。

周期：重复加载时程荷载函数的时程分析。本选项仅适用于分析类型为线性，并且分析方法为振型叠加法的情况。

注
当选择了线性周期时，时程荷载函数将被反复加载，反复加载的周期为前面定义的"结束时间"。

加载了线性周期时程荷载函数的结构，其反应也应该显示周期性。即在分析结果中，结束时间的反应应该与开始时间的反应相同。因此在线性周期分析中只由找到反应相同点，才能正确分析周期性的反应。

具有阻尼衰减特性的结构，随时间的推移，其初始状态的影响力将逐渐消失，达到稳定状态时，只显示周期荷载的反应。所以当多次重复加载进行分析时，其最终结果将接近稳定状态的反应，但其分析时间将成倍增长。一般来说，阻尼比越小结构衰减的速度就越慢，初始状态的影响时间也就越长，即达到稳定状态的时间也就越长。

如果选择了"线性周期"，首先假定初始反应值为零。然后先做一个周期的线性瞬态分析。调整开始时间的初始值，使其与结束时间相同。然后重新运行分析，与线性瞬态分析相加求出周期性反应。使用该方法可以缩短计算时间。

  • 分析时间

时程分析的总的时间长度[秒]。

  • 分析时间步长

时程分析的时间增量(步长)，该增量对分析结果的精度有较大的影响。按照经验时间增量一般可以取时程加载函数周期或结构振动的最小自振周期的1/10秒。

  • 步长（选择非线性静力法分析时被激活）

输入施加荷载增量间隔。例如增量步骤数为100，施加的荷载为100ton，进行非线性静力分析时的荷载步长为1ton。

  • 输出时间步长(步骤数)

输出时程分析结果的时间步骤数。将以(输出步骤数 x 时间增量)的间隔生成结果。

加载顺序

  • 接续前次

选择当前输入时程荷载工况的前次进行的时程荷载工况名称。此时选择的荷载工况，只能选择分析类型和分析方法相同的荷载工况。

把前次荷载工况的位移、速度、加速度、内力、铰的状态、非线性连接单元等作为这次荷载工况的初始条件进行分析。但是荷载必须要勾选保持最后加载步骤的荷载不变才能把前次的荷载持续到本次荷载工况。

荷载工况 : 选择前次进行的荷载工况。不仅可以选时程荷载工况（TH），而且还可考虑静力荷载工况（ST）、施工阶段荷载工况（CS）。没有必要把静力荷载工况（自重）转换为时程荷载工况，可直接选择静力荷载工况来考虑自重。

初始单元内力（表格） ：考虑前次荷载工况的构件平衡内力。输入前次荷载工况时选择荷载工况，只能限制在同一种结构体系的荷载，反之如果选择平衡构件内力，就像地震分析时的边界条件变化的结构体系一样，可以以平衡力的形式输入前次荷载工况。

静力荷载工况(ST)、时程荷载工况(CS)、平衡构件内力的前次荷载工况不适用于纤维单元的结构，且前次荷载工况的内力应在弹性范围内，如超过弹性范围，计算结果可能是不正确的。

  • 累加位移/数度/加速度结果：累计前次荷载工况的位移、速度、加速度输出结果，不会对分析有影响。只适用于时程荷载工况。

  • 保持最终步骤荷载不变：维持前次荷载工况的最终步骤荷载。只适用于时程荷载(TH)。

阻尼

  • 振型阻尼

用户直接定义各振型的阻尼比，根据各振型的阻尼比计算各振型的响应。只适用于振形叠加法和直接积分法。

直接输入振型阻尼：定义各个振型的阻尼比

所有振型的阻尼比：除了用户直接输入阻尼比的模态，其他模态使用的阻尼比。除下面“各振形的阻尼比”输入栏里指定了阻尼比的模态之外均适用。

各振型的阻尼比: 用户直接输入各振型的阻尼比。

振型 : 振型号

阻尼比 : 各振型阻尼比

  • 质量和刚度因子

输入质量矩阵和刚度矩阵的系数。

阻尼类型：选择质量因子还是刚度因子。

直接输入：输入在阻尼类型中选择项目的比例系数。

从模型阻尼中计算：根据用户定义的阻尼比计算比例系数并自动输入。

因子计算：根据在阻尼类型中选择的项目输入相应数据。

频率：输入定义阻尼比需要的频率，该值将用于计算比例系数。

周期：输入定义阻尼比需要的周期，该值将用于计算比例系数。

阻尼比：输入相应频率或周期的阻尼比。

：点击按钮，激活阻尼比计算器对话框，可以直接输入质量、刚度系数计算和显示指定频率或周期下模型的阻尼比。当阻尼和质量、刚度成比例时，可以选择由振型阻尼定义两种振型，计算阻尼比。该功能使用户可以方便的计算剩余振型的阻尼比大小。

<图2> 阻尼比对话框

  • 应变能因子

根据在组阻尼中指定的各个结构组及边界组的阻尼比，自动计算各个模态的阻尼比，用这些计算得出的阻尼比作为阻尼矩阵。所以选择应变能因子时，没有必要输入各个结构组和边界组的阻尼比。应变能比例只适用于振型叠加法和直接积分法的分析。

  • 单元质量和刚度因子

利用在组阻尼中定义的各个结构组及边界组的阻尼比，计算Rayleigh阻尼比。单元质量和刚度因子可对特定的构件以及边界部位输入阻尼比，所以对结构中有阻尼比不同的材料或设置减隔振装置的情况也适用。不同的单元定义成不同的结构组，输入各自的阻尼比。在进行振型叠加法时，根据组阻尼比进行分析以后查看各个模态的阻尼比。

注：

选择直接模型和应变能比例时，因阻尼的特性可能会产生较大的不平衡的内力。所以推荐进行收敛计算。

静力加载控制[选择非线性静力分析时被激活]

非线性静力分析时的控制方法有以下两种方法：

荷载控制法：在每个阶段增加荷载增量直至达到最终荷载。

位移控制法：在每个阶段增加位移增量直至达到目标位移时分析结束的。

  • 荷载控制法

系数：非线性静力分析中使用的荷载修正系数

  • 位移控制法

整体控制：任何一个节点的位移达到了最大位移时分析终止。

最大位移: 输入最大位移

主节点控制：用户指定的主节点的位移达到了最大位移时分析终止。

主节点：输入主节点号

位移方向：选择主节点最大位移的控制方向

最大位移：输入最大位移值

注：

在连续进行非线性静力分析时，非线性分析的控制方法和使用顺序会对分析结果有影响，所以使用时要注意。

1. 荷载控制 --> 位移控制

2. 荷载控制 --> 位移控制 --> 位移控制

3. 位移控制 --> 荷载控制

4. 荷载控制 --> 荷载控制

通过第一、二步骤的分析可以得到正确的分析结果，但通过第三、四的步骤的分析结果可能有错误的结果。

时间积分参数

Newmark法：Newmark法是用于数值积分动力方程的直接积分法的一种。需要输入Gama和Beta两个相关参数。有三种方法输入上述两个参数。由于加速度常量法分析结果稳定，因此推荐使用该方法输入。

加速度常量：假定结构的加速度在每个时间步骤中未发生改变，相应的Gama＝1/2、Beta＝1/4自动输入。基于上述假定，时间步的大小不会影响解的稳定性。

线性变化加速度：假定结构的计算度在每个时间步骤中线性变化，相应的Gama＝1/2、Beta＝1/6自动输入。基于上述假定，当时间增量值大于0.551倍的结构最小周期时，分析结果会变得不稳定。

用户输入：用户直接输入Gamma和Beta值。

非线性分析控制参数

在"分析类型"中选择了"非线性"，则输入非线性分析必要的参数。

分析方法选择“振型叠加法”或“直接积分法”时

迭代参数

容许不收敛：使用Newton Raphson计算方法进行收敛计算时，计算至最大迭代次数以后没有收敛时，输出信息后停止计算。允许不收敛时，不满足收敛条件也可以继续计算。在进行动力非线性分析时，因非线性的效果刚度变化较大，此时选择允许不收敛后计算出来的结果可能是完全没有收敛的结果，所以推荐把时间间隔调小一点再进行计算。

最小步长：输入每个时间步的子步的最小值。在使用Newton Raphson计算方法进行收敛计算时，计算至最大迭代次数也没有收敛的情况，自动调整时间间隔直至满足收敛条件。最小步长指细分时间间隔时的最小间隔。

最大迭代次数：输入每个子步的迭代次数。如果在"分析方法"中选择了"振型叠加法"，则使用E. L. Wilson的快速非线性法计算；如果在"分析方法"中选择了"直接积分法"，则使用Newton Raphson的计算方法。推荐数值不小于10，如果使用很大的值可能会收敛在不正确的结果。

收敛标准：进行迭代计算时收敛标准可分为位移标准、内力标准、能量标准等3种。可选择其中一个标准或多个标准来判断是否收敛。进行振型叠加法时可选择位移标准和内力标准，进行直接积分法时3种标准都可以选择。

注
为完成时程分析，在特征值分析控制中必须输入下列数据：特征值数量、要考虑的自振频率的范围、特征值计算的最大重复次数、子空间大小、收敛公差和刚体运动的移频。

边界非线性分析: 选择分析方法，决定了边界非线性分析的精度和收敛性。

Runge Kutta方法: 采用泰勒序列扩展时间增量以求解微分方程。

Fehlberg方法 (不收敛的子步长控制)

Cash-Karp Method (自适应步长控制)

分析方法选择“静力法”时

最大子步骤数：子步骤数的最大值

最大迭代次数：输入每个子步的迭代次数。如果在"分析方法"中选择了"振型叠加法"，则使用E. L. Wilson的快速非线性法计算；如果在"分析方法"中选择了"直接积分法"，则使用Newton Raphson的计算方法。推荐数值不小于10，如果使用很大的值可能会收敛在不正确的结果。

收敛标准：进行迭代计算时收敛标准可分为位移标准、内力标准、能量标准等3种。可选择其中一个标准或多个标准来判断是否收敛。进行振型叠加法时可选择位移标准和内力标准，进行直接积分法时3种标准都可以选择。


02_时程荷载函数

Home > midas Gen 2017 > 07_荷载 > 02_地震作用 > 02_时程分析数据 > 02_时程函数

时程荷载函数

  • 功 能

指定时程分析时的时程加载函数。

  • 命 令

从主菜单中选择荷载 > 时程分析数据 > 时程荷载函数...

在树形菜单的菜单表单中选择时程分析 > 时程荷载函数

  • 输 入

时程荷载函数对话框

输入新的或其他时程荷载函数

当时程荷载是随机振动荷载时，单击 [image] 。当时程荷载是谐振动(正弦曲线)时，单击 [image] 。

修改先前输入的时程荷载函数

在对话框的列表中选择一个时程荷载函数并单击 [image] 。

删除先前输入的时程荷载函数

在对话框的列表中选择一个时程荷载函数并单击 [image] 。

单击 [image] ，添加时程荷载函数。

添加/编辑/显示时程函数对话框

函数名称

输入时程荷载函数的名字。该函数名使用在"节点动力荷载"和"地面加速度"中。MIDAS的时程荷载数据库提供地震波数据。

时间函数数据类型

指定要输入的数据类型。

无量纲加速度：将加速度时程函数数据除以重力加速度得到的数据。

加速度：加速度时程数据。

力：外力时程数据。

弯矩：弯矩时程数据。

无量纲：无量纲数据。

注
力或弯矩时程荷载函数用于输入"节点动力荷载"，指定无量纲加速度或加速度时程函数用于输入"地面加速度"，无量纲时程函数用于输入"时变静力荷载"。

放大系数

输入时程函数的调整系数(一般为放大)。

用户输入时程荷载数据后，如果修改时程荷载数据类型，此时只能改变数据的单位，数据本身不会改变到修正单位后的数据。使用放大系数，时程数据所有的值都修改了。
例如，当用户在无量纲加速度中输入0.1g，随后将荷载类型修改为加速度，数值大小将保持不变，0.1m/s2，为了把0.1g换到m/s2为单位，需要输入比例系数9.8，因为0.1g=0.98 m/s2

最大值

输入峰值加速度值。

重力加速度

输入重力加速度。该数据将被用于将无量纲加速度转换为荷载。

图形选项

决定图形是否使用对数刻度。

说明

输入对反应谱的简要说明(不能超过80个字节)。

在MIDAS/Gen中支持下列3种数据输入方法：

    1. 将频繁使用的时程荷载函数保存为文件，然后在其他工程中调用。

    2. 从数据库中调用时程函数数据。

    3. 用户直接输入时程函数数据。

将频繁使用的时程荷载函数保存为文件，然后调用的方法

点击 [image] ，调用先前生成的时程函数数据文件。数据以?.sgs?或?.thd?扩展名保存，文件格式如下：

"文件名.sgs" 的文件格式

*SGS | 说明文件为"地震数据生成器"数据格式的注释文。
*TITLE, Elcentro 1940, N-S Component | -
*X-AXIS, Second | -
*Y-AXIS, Normalized Acceleration | -
*UNIT&TYPE, GRAV, ACCEL | -
*FLAGS, 0, 0 | -
*DATA | -
1.00000E-010, 3.50102E-001 | -
5.00000E-002, 3.82861E-001 | -
1.00000E-001, 5.08226E-001 | -
1.50000E-001, 5.17459E-001 | -
: | -

"文件名.spd" 文件格式(用户输入)

选项 | ** 注释，可在任意处输入
- | *UNIT, M , N - Length: MM, CM, M, INCH, FEET, GRAV allowed
- | Load: KG, TON, KN, LBF, KIP
- | *TYPE, ACCEL - ACCEL, FORCE, MOMENT allowed
必须输入 | *Data
- | X1, Y1 (x: Time, X: Time Function)
- | X2, Y2
- | X3, Y3
- | :

"文件名.spd"的文件的输入实例：

从数据库中调用时程荷载函数

点击 [image] ，从数据库中调用相应国家的地震记录数据，并输入相关内容。目前数据库中有32个地震加速度记录。

生成地震加速度记录对话框

点击 [image] ，根据行人的重量、步行速度和时间间隔自动生成时程荷载；

生成步行荷载对话框

可用的步行荷载如下：

■ 行走1步（Baumann）

Baumann K. Bachmann H.提出的基于一个行人一步的时程荷载函数，可以考虑步行者的重量和步行速度。

■ 连续行走（IABSE）
Baumann的步行荷载被IABSE（国际桥梁和结构工程协会）、 AIPC（Association Internationale des Ponts et Charpentes）和IVBH（Internationale Vereinigung fur Bruckenbau Hochbau）进一步细化。

注：IABSE的时程荷载假定步行者在同一位置处连续行走。这不适用于“行走”。频率范围在2.0~2.4，重复数大于2时，结果可能比较可靠。

■ 不连续行走（AIJ）

假定步行荷载有0.3kgf/s的冲击能，超过0.04s.

单位：kgf

■ 跑动（AIJ）

跑动荷载函数和步行荷载类似，除了1.8kgf/s的冲击能。

单位：kgf

■ 跑动（Allen&Rainer）

注：一般认为，步行频率范围为1.5~2.5Hz
根据楼板的固有频率，工程师必须慎重使用引起最大响应的步行频率。

在添加/编辑/显示时程函数对话框中的输入区内直接输入时程荷载函数数据

在对话框左边的输入区内，由用户直接输入时间和时程函数的值。

单击 [image] ，输入相应数据。

添加/编辑/显示时程函数对话框

函数名称

输入时程荷载函数的名称。该名称用于"节点动力荷载"和 "地面加速度"中，它是所用的时程荷载函数的数据输入特征。

时间函数数据类型

无量纲加速度：将加速度时程函数数据除以重力加速度得到的数据。

加速度：加速度时程数据。

力：外力时程数据。

弯矩：弯矩时程数据。

无量纲：无量纲数据。

注
力或弯矩时程荷载函数用于输入"节点动力荷载"，指定无量纲加速度或加速度时程函数用于输入"地面加速度"，无量纲时程函数用于输入"时变静力荷载"。

系数

输入时程函数的调整系数(一般为放大)。

重力加速度

输入重力加速度。该数据将被用于将无量纲加速度转换为荷载。

图形选项

决定图形是否使用对数刻度。

输入谐振函数的参数

A, C 为常量，f为激振频率，D为阻尼系数，PA为相位角。

当输入完必需的参数后单击 [image] ，则在右边显示函数的图形，单击 [image] 保存时程荷载函数。

说明

输入对反应谱的简要说明(不能超过80个字节)。


03_地面加速度

Home > midas Gen 2017 > 07_荷载 > 02_地震作用 > 02_时程分析数据 > 03_地面

地面加速度

  • 功 能

以地面加速度方式输入时程荷载函数。

  • 命 令

从主菜单中选择荷载 > 时程分析数据 > 地面加速度...

在树形菜单的菜单表单中选择时程分析 > 地面加速度

  • 输 入

时程分析荷载工况名称

选择在"时程荷载工况"中定义的时程分析荷载工况。如果此前未定义荷载工况，单击 [image] 定义相应的工况。

X-方向时程分析函数

输入整体坐标系X方向的地面加速度。

函数名称：从列表中选择要使用的地面加速度。

系数：地面加速度的调整系数。

到达时间：地面加速度开始作用于结构上的时间。

注
在"到达时间"之前的时间，地面加速度的数据为零，对结构不发生作用。定义到达时间的目的是反映几个时程荷载作用在同一结构上，且各荷载发生作用的时间不同时的结构反应。

Y-方向时程分析函数函数

输入整体坐标系Y方向的地面加速度。

函数名称：从列表中选择要使用的地面加速度。

系数：地面加速度的调整系数。

到达时间：地面加速度开始作用于结构上的时间。

Z-方向时程分析函数

输入整体坐标系Z方向的地面加速度。

函数名称：从列表中选择要使用的地面加速度。

系数：地面加速度的调整系数。

到达时间：地面加速度开始作用于结构上的时间。

水平地面加速度的角度

水平地面加速度作用方向与整体坐标系X轴的夹角。

输入上述各项后单击 [image] ，则与地面加速度相关的时程分析荷载工况作用数据将被添加到列表中。

要修改列表中的时程分析荷载工况作用数据，修改各项数据后并单击 [image] 。

要删除列表中的时程分析荷载工况作用数据，在表中选择工况后单击 [image] 。


05_节点动力荷载

Home > midas Gen 2017 > 07_荷载 > 02_地震作用 > 02_时程分析数据 > 04_动力

节点动力荷载

  • 功 能

将时程荷载函数应用到指定的节点上。

  • 命 令

从主菜单中选择荷载 > 时程分析数据 > 节点动力荷载...

在树形菜单的菜单表单中选择时程分析 > 节点动力荷载

  • 输 入

时程分析荷载工况名称

选择在"时程荷载工况"中定义的时程分析荷载工况。如果此前未定义荷载工况，单击 [image] 定义相应的工况。

选项

添加：在指定节点处添加动力时程荷载函数。

替换：替换先前输入的动力时程荷载函数。

删除：删除先前输入的动力时程荷载函数。

函数和方向

选择已定义的节点动力荷载函数名称，加载方向和到达时间。

函数名称：选择在"时程荷载函数"中定义的某一时程荷载函数。

荷载类型：选定的时程荷载函数的类型。自动显示在"时程荷载函数"中定义的时程荷载函数的类型。

方向：选择时程荷载函数的加载方向。

X：整体坐标系X轴方向。

Y：整体坐标系Y轴方向。

Z：整体坐标系Z轴方向。

到达时间：时程荷载函数开始发生作用的时间。

系数：时程荷载函数的调整系数。

定义上述各项后，选择要加载的节点并单击 [image] 将时程荷载函数应用到节点上。用"显示"检查输入的数据。


04_时变静力荷载

Home > midas Gen 2017 > 07_荷载 > 02_地震作用 > 02_时程分析数据 > 05_时变静力荷载

时变静力荷载

  • 功 能

将已经定义的静力荷载乘上时间函数，将其转换为动力荷载，时间函数应该在“时程荷载函数”里定义。
该功能用于进行地震荷载作用下的时程分析时考虑自重的影响。
首先，为自重定义时间荷载函数，并为其指定时程荷载工况。然后，为地震作用定义一个时程荷载工况，选择已定义的自重时程荷载工况作为“接续加载”荷载工况，然后运行分析。这能保证执行地震分析时考虑自重；自重首先作用到结构上，地震作用时自重作用的效应会始终存在。

  • 命 令

从主菜单中选择荷载 > 时程分析数据 > 时变静力荷载...

在树形菜单的菜单表单中选择时程分析 > 时变静力荷载

  • 输 入

时程分析荷载工况名称

选择在"时程荷载工况"中定义的时程荷载工况。当没有事先定义时程荷载工况时，可点击右侧的 [image] ，建立时程荷载工况。

静力荷载工况

选择将按动力荷载考虑的静力荷载。

时程分析函数

选择将与静力荷载相乘，将静力荷载转换为动力荷载的时程分析函数。

函数的值为无量纲形式。函数一般定义为倾斜上升阶段和水平阶段(静力荷载值)两个直线段。

函数名称：选择在时程分析函数中定义的时间分析函数。

到达时间：时间分析函数开始作用的时间。

系数：时程分析函数的调整系数。

操作

：将时变静力荷载添加到目录中。则该荷载将在分析中被使用。

：修改已经建立的时变静力荷载。

：删除已经建立的时变静力荷载。


06_多支座激振

Home > midas Gen 2017 > 07_荷载 > 02_地震作用 > 02_时程分析数据 > 06_多点

多支座激振

  • 功 能

在各支承处输入不同的时程荷载函数。

  • 命 令

从主菜单中选择荷载 > 时程分析数据 > 多支座激振...

在树形菜单的菜单表单中选择时程分析 > 多支座激振

  • 输 入

时程分析荷载工况名称

选择在"时程荷载工况"中定义的时程分析荷载工况。如果此前未定义荷载工况，单击 [image] 定义相应的工况。

选项

添加/替换：在指定支承处添加或替换时程荷载函数。

删除：删除先前在指定支承处输入的时程荷载函数。

X-方向时程分析函数

输入整体坐标系X方向的地面加速度。

函数名称：从列表中选择要使用的地面加速度。

系数：地面加速度的调整系数。

到达时间：地面加速度开始作用于结构上的时间。

注
在"到达时间"之前的时间，地面加速度的数据为零，对结构不发生作用。定义到达时间的目的是反映几个时程荷载作用在同一结构上，且各荷载发生作用的时间不同时的结构反应。

Y-方向时程分析函数函数

输入整体坐标系Y方向的地面加速度。

函数名称：从列表中选择要使用的地面加速度。

系数：地面加速度的调整系数。

到达时间：地面加速度开始作用于结构上的时间。

Z-方向时程分析函数

输入整体坐标系Z方向的地面加速度。

函数名称：从列表中选择要使用的地面加速度。

系数：地面加速度的调整系数。

到达时间：地面加速度开始作用于结构上的时间。

水平地面加速度的角度

水平地面加速度作用方向与整体坐标系X轴的夹角。

定义上述各项后，选择要加载的支承并单击 [image] 将时程荷载函数应用到支承上。用"显示"检查输入的数据。


07_时程结果函数

Home > midas Gen 2017 > 07_荷载 > 02_地震作用 > 02_时程分析数据 > 07_定义

时程结果函数

  • 功 能

决定时程结果的类型和定义输出结果图形函数和步骤函数。图形结果函数也可以在后处理的时程分析图形中定义或编辑。

  • 命 令

从主菜单中选择荷载 > 时程分析数据 > 时程结果函数...

在树形菜单的菜单表单中选择时程分析 > 时程结果函数

  • 输 入

定义函数

图形函数：定义图形结果函数。

步骤函数：定义特定步骤的函数。

函数列表

列出已定义的图形（步骤）函数名称。

图形函数

1. 层 位移/速度/加速度

定义层 位移、速度、加速度的图形函数。

名称：输入层 位移/速度/加速度的输出图形函数的名称。

层号：输入要输出结果的层号。

结果类型：选择输出结果的类型。

位移、速度、加速度

控制点：选择位移（速度、加速度）的基准参考点。

地面：为了输出相对于地面产生的反映而选择此项。适用于输出相对位移和相对速度。

添加地面运动：输出包含地面发生的反映的结构物的绝对的反映。适用于输出绝对加速度的结果。

层间位移：输出层间位移的时程分析结果。

组成：输入位移方向成分。

位移方向可选则DX、DY、DZ、RX、RY、RZ。

时程荷载工况：选择要输出时程分析图形的荷载工况。

2. 位移/速度/加速度

定义位移、速度、加速度的图形函数。

名称：输入位移/速度/加速度的输出图形函数的名称。

节点号：输入要输出结果的节点号。

结果类型：选择输出结果的类型。

位移、速度、加速度

参考点：选择位移（速度、加速度）的基准参考点。

地面：为了输出相对于地面产生的反映而选择此项。适用于输出相对位移和相对速度。

添加地面运动：输出包含地面发生的反映的结构物的绝对的反映。适用于输出绝对加速度的结果。

其他点：以输入的节点位基准，计算要输出节点的相对反映时使用。

成分：输入位移方向成分。

位移方向可选则DX、DY、DZ、RX、RY、RZ。

时程荷载工况：选择要输出时程分析图形的荷载工况。

包括振型数：在时程分析中选择了振型叠加法时可选择振型数。可用全部模态计算反应，也可选择一个模态用于计算。

3. 桁架单元内力/应力

定义桁架单元内力/应力的图形函数。

名称：输入桁架单元内力/应力的输出图形函数的名称。

单元号：输入要输出结果的单元号。

结果类型：选择输出结果的类型。

内力、应力

点：选择输出结果的位置。

可选择I-节点和J-节点。

时程荷载工况：选择要输出时程分析图形的荷载工况。

包括振型数：在时程分析中选择了振型叠加法时可选择振型数。可用全部模态计算反应，也可选择一个模态用于计算。

4. 梁单元内力/应力

定义梁单元内力/应力的图形函数。

名称：输入梁单元内力/应力的输出图形函数的名称。

单元号：输入要输出结果的单元号。

结果类型：选择输出结果的类型。

内力、应力

点：选择输出结果的位置。

可选择I-节点和J-节点。

成分

结果类型为内力时：可选择轴力、剪力-y、剪力-z、扭矩、弯矩-y、弯矩-z等内力成分。

结果类型为应力时：可选择轴力、剪应力-y、剪应力-z、弯曲应力(+y)、弯曲应力(-y)、弯曲应力(+z)、弯曲应力(-z)等应力成分。

时程荷载工况：选择要输出时程分析图形的荷载工况。

包括振型数：在时程分析中选择了振型叠加法时可选择振型数。可用全部模态计算反应，也可选择一个模态用于计算。

5. 平面应力单元内力/应力

定义平面应力单元内力/应力的图形函数。

名称：输入平面应力单元内力/应力的输出图形函数的名称。

单元号：输入要输出结果的单元号。

结果类型：选择输出结果的类型。

内力、应力

点：选择输出结果的位置。

结果类型为内力时：可选择I-节点、J-节点K-节点、L-节点。

结果类型为应力时：可选择中心、I-节点、J-节点、K-节点、L-节点。

成分

结果类型为内力时：可选择Fx、Fy内力成分。

结果类型为应力时：可选择Sig-xx、Sig-yy、Sig-xy等应力成分。

时程荷载工况：选择要输出时程分析图形的荷载工况。

包括振型数：在时程分析中选择了振型叠加法时可选择振型数。可用全部模态计算反应，也可选择一个模态用于计算。

6. 平面应变单元内力/应力

定义平面应变单元内力/应力的图形函数。

名称：输入平面应变单元内力/应力的输出图形函数的名称。

单元号：输入要输出结果的单元号。

结果类型：选择输出结果的类型。

内力、应力

点：选择输出结果的位置。

结果类型为内力时：可选择I-节点、J-节点K-节点、L-节点。

结果类型为应力时：可选择中心、I-节点、J-节点、K-节点、L-节点。

成分

结果类型为内力时：可选择Fx、Fy、Fz内力成分。

结果类型为应力时：可选择Sig-xx、Sig-yy、Sig-zz、Sig-xy等应力成分。

时程荷载工况：选择要输出时程分析图形的荷载工况。

包括振型数：在时程分析中选择了振型叠加法时可选择振型数。可用全部模态计算反应，也可选择一个模态用于计算。

7. 板单元内力/应力

定义板单元内力/应力的图形函数。

名称：输入板单元内力/应力的输出图形函数的名称。

单元号：输入要输出结果的单元号。

结果类型：选择输出结果的类型。

内力、应力、单位力（单位长度的内力）

点：选择输出结果的位置。

结果类型为内力时：可选择I-节点、J-节点、K-节点、L-节点。

结果类型为应力时：可选择中心、I-节点、J-节点K-节点、L-节点。

结果类型为单位力时：可选择中心、I-节点、J-节点K-节点、L-节点。

成分

结果类型为内力时：可选择Fx、Fy、Fz、Mx、My、Mz内力成分。

结果类型为应力时：可选择Sig-xx(Top)、 Sig-yy(Top)、Sig-xy(Top)、Sig-xx(Bottom)、Sig-yy(Bottom)、Sig-xy(Bottom)等应力成分。

结果类型为单位力时：Fxx、Fyy、Fxy、Mxx、Myy、Mxy、Vxx、Vyy的单位长度内力成分。

时程荷载工况：选择要输出时程分析图形的荷载工况。

包括振型数：在时程分析中选择了振型叠加法时可选择振型数。可用全部模态计算反应，也可选择一个模态用于计算。

8. 实体单元内力/应力

定义实体单元内力/应力的图形函数。

名称：输入实体单元内力/应力的输出图形函数的名称。

单元号：输入要输出结果的单元号。

结果类型：选择输出结果的类型。

内力、应力

点：选择输出结果的位置。

结果类型为内力时：可选择I-节点、J-节点、K-节点、L-节点、M-节点、O-节点、N-节点、P-节点。

结果类型为应力时：可选择中心、I-节点、J-节点、K-节点、L-节点、M-节点、O-节点、N-节点、P-节点。

成分

结果类型为内力时：可选择Fx、Fy、Fz内力成分。

结果类型为应力时：可选择Sig-xx、 Sig-yy、Sig-zz、Sig-xy、Sig-yz、Sig-xz等应力成分。

时程荷载工况：选择要输出时程分析图形的荷载工况。

包括振型数：在时程分析中选择了振型叠加法时可选择振型数。可用全部模态计算反应，也可选择一个模态用于计算。

9. 一般连接变形/内力

定义一般连接变形/内力的图形函数。

名称：输入一般连接单元的输出图形函数的名称。

一般连接号：输入要输出结果的一般连接单元号。

类型：

变形、I-节点内力、J-节点内力

成分

类型为变形：Dx、Dy、Dz、Rx、Ry、Rz变形成分。

类型为I、J-节点内力时：Fx、Fy、Fz、Mx、My、Mz内力成分。

时程荷载工况：选择要输出时程分析图形的荷载工况。

10. 非弹性铰变形/内力

定义非弹性铰变形/内力的图形函数。

名称：输入非弹性铰单元的输出图形函数的名称。

单元类型：

梁、一般连接

单元号：输入要输出结果的单元号。

结果类型：

变形、内力

成分

类型为变形：Dx、Dy、Dz、Rx、Ry、Rz变形成分。

类型为I、J-节点内力时：轴力、剪力-y、剪力-z、扭矩、弯矩-y、弯矩-z内力成分。

时程荷载工况：选择要输出时程分析图形的荷载工况。

11. 荷载增量时程

名称：输入荷载增量时程函数的名称。

时程荷载工况：选择要输出时程分析图形的荷载工况。

步骤函数

根据用户定义的条件查看对时间步骤、位移（速度、加速度）、内力的静力分析结果和时程分析结果。

1. 时间步骤

查看用户定义的时间或加载步骤的结构反映。

名称：输入时间步骤函数的名称。

时程荷载工况：选择要输出时程分析图形的荷载工况。

时间步骤：选择要输出结果的时间或加载步骤。

2. 位移/速度/加速度

查看位移/速度/加速度的结构反映。

名称：输入函数的名称。

节点号：输入要输出结果的节点号。

结果类型

位移、速度、加速度

成分

选择输出结果节点的成分。可选择 DX、DY、 DZ、RX、RY、RZ。

值

Min、Max、AbsMax（绝对最大值）

时程荷载工况：选择要输出的荷载工况。

3. 桁架单元内力/应力

查看特定桁架单元的最大（最小、绝对值）内力、应力。

名称：输入函数的名称。

单元号：输入要输出结果的桁架单元号。

结果类型

内力、应力

点

选择输出结果位置。

值

Min、Max、AbsMax（绝对最大值）

时程荷载工况：选择要输出的荷载工况。

4. 梁单元内力/应力

查看特定梁单元的最大（最小、绝对值）内力、应力。

名称：输入函数的名称。

单元号：输入要输出结果的梁单元号。

结果类型

内力、应力

点

选择输出结果位置。

成分

结果类型为内力时：可选择轴力、剪力-y、剪力-z、扭矩、弯矩-y、弯矩-z内力成分。

结果类型为应力时：轴力、剪应力-y、剪应力-z、弯曲应力(+y)、弯曲应力(-y)、弯曲应力(+z)、弯曲应力(-z)、组合1、2、3、4。

值

Min、Max、AbsMax（绝对最大值）

时程荷载工况：选择要输出的荷载工况。

5. 指定的DOF

输出时程结果中选择的内力成分显示最大（最小、绝对值）时的自由度。

名称：输入函数的名称。

点

选择输出结果位置。

成分

可选择Fx、Fy、Fz、Mx、My、Mz

值

Min、Max、AbsMax（绝对最大值）

时程荷载工况：选择要输出的荷载工况。

6. 一般连接内力

输出一般连接单元时程结果中选择的内力成分的最大值（最小、绝对值）。

名称：输入函数的名称。

一般连接号

选择输出结果的一般连接单元号。

成分

可选择轴力、剪力-y、剪力-z、扭矩、弯矩-y、弯矩-z内力成分。

值

Min、Max、AbsMax（绝对最大值）

时程荷载工况：选择要输出的荷载工况。


08_定义动画时间

Home > midas Gen 2017 > 07_荷载 > 02_地震作用 > 02_时程分析数据 > 08_定义动画时间

定义动画时间

  • 功 能

定义时程分析结果的动画时间。

  • 命 令

从主菜单中选择荷载 > 地震作用 > 时程分析数据 > 定义动画时间

在树形菜单的菜单表单中选择时程分析数据 > 定义动画时间

  • 输 入

时程分析荷载工况名称

选择在"时程荷载工况"中定义的时程分析荷载工况。如果此前未定义荷载工况，单击 [image] 定义相应的工况。

开始时间： 定义时程动画开始的时程荷载对应的时间；

结束时间： 定义时程动画结束的时程荷载对应的时间；

增幅：定义时程动画的时间增幅。

操作

添加：添加定义的时程动画；

编辑：编辑定义的时程动画；

删除：删除定义的时程动画。


01_系统温度

Home > midas Gen 2017 > 07_荷载 > 04_温度/预应力 > 01_温度荷载 > 01_系统温度

系统温度

  • 功 能

当整个结构温度从初始(参考)温度变化至指定温度时，为了做热应力分析，输入最终温度(或称系统温度)。也可修改或删除先前输入的最终温度。

MIDAS中对所有单元都能进行温度变化分析。温度变化产生热应变，并导致构件中产生内力。

其中，α是在"材料"中输入的线性热膨胀系数。T1是初始温度(参见"结构类型")，T2是结构的最终温度。既可以赋予整个结构相同的最终温度，也可以赋予结构的不同部分以不同的最终温度(参见"节点温度")。

  • 命 令

从主菜单中选择荷载 > 温度荷载 > 系统温度...

在树形菜单的菜单表单中选择静力荷载 > 温度荷载 > 系统温度

  • 输 入

荷载工况名称

输入荷载工况名称。单击右边的 [image] 输入另外的荷载工况，修改或删除现有的荷载工况。

荷载组名称

选择系统温度荷载将要所属的荷载组。当不需要指定组时，选择"默认值"。当需要添加和编辑荷载组时，可以点击右面的 [image] ，将弹出"定义荷载组"对话框。

温度

初始温度：输入整个结构的初始温度。

最终温度：输入最终温度。

注：

初始温度可在 模型 > 结构类型 菜单中修改。

输入新的或添加最终温度

输入相应项目后单击 [image] 。

修改先前输入的最终温度

从对话框底部最终温度列表中选择相应的荷载工况，修改上方的输入区并单击 [image] 。

删除先前输入的最终温度

从对话框底部最终温度列表中选择相应的荷载工况并单击 [image] 。


02_节点温度

Home > midas Gen 2017 > 07_荷载 > 04_温度/预应力 > 01_温度荷载 > 02_节点温度

节点温度

  • 功 能

输入热应力分析时所需的节点温度，也可以修改或删除先前输入的节点温度。(参见"系统温度")

  • 命 令

从主菜单中选择荷载 > 温度荷载 > 节点温度...

在树形菜单的菜单表单中选择静力荷载 > 温度荷载 > 节点温度

  • 输 入

荷载工况名称

输入荷载工况名称。单击右边的 [image] 输入另外的荷载工况，修改或删除现有的荷载工况。

荷载组名称

选择节点温度荷载将要所属的荷载组。当不需要指定组时，选择"默认值"。当需要添加和编辑荷载组时，可以点击右面的 [image] ，将弹出"定义荷载组"对话框。

选择

添加：输入新的或添加节点温度。

替换：替换先前输入的节点温度。

删除：删除先前输入的节点温度。

温度

输入节点温度。

初始温度：输入整个结构的初始温度。

最终温度：输入节点上温升或温降温度。

注：

初始温度可在 模型 > 结构类型 菜单中修改。


03_单元温度荷载

Home > midas Gen 2017 > 07_荷载 > 04_温度/预应力 > 01_温度荷载 > 03_单元温度

单元温度荷载

  • 功 能

输入热应力分析时所需的单元温度，也可以修改或删除先前输入的单元温度。(参见"系统温度")

  • 命 令

从主菜单中选择荷载 > 温度荷载 > 单元温度...

在树形菜单的菜单表单中选择静力荷载 > 温度荷载 > 单元温度

  • 输 入

荷载工况名称

输入荷载工况名称。单击右边的 [image] 输入另外的荷载工况，修改或删除现有的荷载工况。

荷载组名称

选择单元温度荷载将要所属的荷载组。当不需要指定组时，选择"默认值"。当需要添加和编辑荷载组时，可以点击右面的 [image] ，将弹出"定义荷载组"对话框。

选择

添加：输入新的或添加单元温度荷载。

替换：替换先前输入的单元温度荷载。

删除：删除先前输入的单元温度荷载。

温度

输入单元温度。

初始温度

最终温度

注
温度荷载是按最终温度和初始温度的差计算的。


04_温度梯度荷载

Home > midas Gen 2017 > 07_荷载 > 04_温度/预应力 > 01_温度荷载 > 04_温度梯度

温度梯度荷载

  • 功 能

输入梁或板单元顶面和底面的温度差，也可以修改或删除先前输入的温度差。

温度梯度分析适用于具有弯曲刚度的单元，如梁和板单元。对梁单元，需要输入沿单元局部坐标系y轴和z轴方向距截面边缘的距离和温度差；对板单元，温度梯度可用板上下面的温度差和板厚表示。温度梯度产生的等效弯矩如下：

  • 梁单元

  • 板单元

其中，α是线性热膨胀系数，E是弹性模量，I是绕梁单元相应中和轴的惯性矩，ΔT是单元两边缘(最外面)间的温度差，h是单元截面两边缘间的距离，t是板厚，v是泊松比。

提示: ΔT输入为10度，代表上翼缘为5度，下翼缘为-5度，而非上翼缘为10度，下翼缘为0度。

如果上翼缘为10度，下翼缘为0度时，应在系统温度中输入整体升温5度，然后在温度梯度中输入10度。

当需要给板单元施加沿厚度方向折线形温度变化（类似梁截面温度荷载）时，可将折线温度等效为温度梯度荷载+单元温度荷载。等效方法为将折线温度等效到板单元厚度中心上的弯矩和轴力，然后再等效为温度梯度荷载+单元温度荷载。

  • 命 令

从主菜单中选择荷载 > 温度荷载 > 温度梯度荷载...

在树形菜单的菜单表单中选择静力荷载 > 温度荷载 > 温度梯度荷载

  • 输 入

荷载工况名称

输入荷载工况名称。单击右边的 [image] 输入另外的荷载工况，修改或删除现有的荷载工况。

荷载组名称

选择温度梯度荷载将要所属的荷载组。当不需要指定组时，选择"默认值"。当需要添加和编辑荷载组时，可以点击右面的 [image] ，将弹出"定义荷载组"对话框。

选择

添加：输入新的或添加温度梯度荷载。

替换：替换先前输入的温度梯度荷载。

删除：删除先前输入的温度梯度荷载。

单元类型及温度梯度

选择要指定温度梯度的单元类型。并参考图输入相应的数据。

梁

T2z-T1z：单元局部坐标系z轴方向两最外面之间的温度差。

使用截面的Hz：单元局部坐标系z轴方向两最外边缘之间的距离。

Hz：单元局部坐标系z轴方向两最外边缘之间的距离，也可以由用户做相应调整。

T2y-T1y：单元局部坐标系y轴方向两最外边缘之间的温度差。

Hy：单元局部坐标系y轴方向两最外边缘之间的距离，也可以由用户做相应调整。

板

T2z-T1z：单元局部坐标系z轴方向两表面面之间的温度差。

Hz：板单元的厚度，也可以由用户做相应调整。


05_梁截面温度荷载

Home > midas Gen 2017 > 07_荷载 > 04_温度/预应力 > 01_温度荷载 > 05_梁截面温度

梁截面温度荷载

  • 功 能

截面内部的温度分布为非均匀分布时可以利用梁截面温度功能输入温度荷载。MIDAS中不仅可以沿截面高度分段输入温度，而且可以输入沿截面横向的温度变化。

与温度梯度的功能相比，温度梯度适用于上、下缘温度差在截面内呈线性分布的情况。但是对于如下图所示的钢混叠合梁桥、预应力混凝土箱型梁桥等，通常截面内的温度并非线性分布，因此需要沿高度输入不同的温度， 而且对于用梁单元模拟的组合截面需输入考虑材料特性（弹性模量、热膨胀系数）差异的温度荷载。故像截面内温度非均匀分布或者组合截面时，利用梁截面温度的功能可以更真实的模拟截面内实际的温度分布情况。

提示：MIDAS程序中的温度计算中考虑了温度自应力。

a)实际的温度分布 b)简化的温度分布

  • 命 令

从主菜单中选择荷载 > 温度荷载 > 梁截面温度荷载...

在树形菜单的菜单表单中选择静力荷载 > 温度荷载 > 梁截面温度荷载

  • 输 入

荷载工况名称

输入荷载工况名称。单击右边的 [image] 输入另外的荷载工况，修改或删除现有的荷载工况。

荷载组名称

选择梁截面温度荷载将要所属的荷载组。当不需要指定组时，选择"默认值"。当需要添加和编辑荷载组时，可以点击右面的 [image] ，将弹出"定义荷载组"对话框。

选项

添加：输入新的或添加梁截面温度荷载。

替换：替换先前输入的梁截面温度荷载。

删除：删除先前输入的梁截面温度荷载。

方向

局部-y：单元坐标系y轴方向的温度差。

局部-z：单元坐标系z轴方向的温度差。

参考位置

H1、H2值输入的参考位置。

中心：以截面中心为参考位置。

+边(顶)：以截面顶端为参考位置。

-边(底)：以截面底端为参考位置。

截面温度

初始温度

表示初始温度。

注：

初始温度可在 模型 > 结构类型 菜单中修改。

材料特性

输入梁截面的材料特性值。

单元：直接使用梁单元的材料特性值。

用户定义：由用户重新定义单元的材料特性。

弹性模量

线膨胀系数

B：具有温度差的宽度，可以不等于截面宽度。

H1, H2：从梁截面的形心到温度变化点的距离。

T1, T2：H1, H2处的温度。

点击 [image] ，将数据添加到目录列表中。需要修改时，在目录中选择相应的项，经修改后点击 [image] 。删除数据时，在目录中选择相应的项点击 [image] 。

注

作用在构件上的温度荷载为线性时，构件内部不会产生自应力，但温度荷载为非线形时，构件内部会产生自应力。这种内部自应力在没有外部边界条件时也会产生，所以构件内部会形成应力差。


01_梁单元预应力荷载

Home > midas Gen 2017 > 07_荷载 > 04_温度/预应力 > 02_预应力 > 01_梁单元预应力荷载

梁预应力荷载

  • 功 能

输入梁上的预应力荷载，也可以修改或删除先前输入的荷载。

定义梁中预应力荷载的图示如下:

力在索道的整个长度上是相同的(考虑预应力钢束的各种预应力损失时，应该使用"预应力钢束的预应力荷载")。

计算预应力荷载作用效应时，提供下列两种模式的分析。

  1. "后张法"，主要考虑张拉过程中构件的反应(现场张拉)，张拉产生的剪力将传递到邻近的单元。

  2. "先张法"，主要考虑张拉后构件的反应(工厂制作)，因张拉产生的剪力不再传递到邻近的单元。

(a) 承受预应力荷载的梁构件

(b) 预应力荷载产生的作用在梁单元上的等效荷载

梁单元中预应力荷载的概念

  • 命 令

从主菜单中选择荷载 > 预应力荷载 > 梁单元预应力荷载...

在树形菜单的菜单表单中选择静力荷载 > 预应力荷载 > 梁单元预应力荷载

  • 输 入

荷载工况名称

输入荷载工况名称。单击右边的 [image] 输入另外的荷载工况，修改或删除现有的荷载工况。

荷载组名称

选择梁单元预应力荷载将要所属的荷载组。当不需要指定组时，选择"默认值"。当需要添加和编辑荷载组时，可以点击右面的 [image] ，将弹出"定义荷载组"对话框。

选择

添加：输入新的或添加梁单元预应力荷载。

替换：替换先前输入的梁单元预应力荷载。

删除：删除先前输入的梁单元预应力荷载。

张拉方法

选择分析张拉前后的状态。

后张法：考虑张拉过程中构件的状态(现场张拉)。

先张法：考虑张拉后构件的状态(工厂预制)。

荷载

参考张拉方法选择区下面的图形，输入预应力钢筋的形状和预拉力值。

张力：预拉力(只能输入正值)。

Di：预应力钢筋在梁单元起点沿单元局部坐标系z方向的偏心量。

Dm：预应力钢筋在梁单元中心沿单元局部坐标系z方向的偏心量。

Dj：预应力钢筋在梁单元终点沿单元局部坐标系z方向的偏心量。

选择单元的方法

选择受预应力荷载的单元的方法。

选择单元：对选择的单元分别加预拉力。

两点：选择两点，两点间的单元将被看成一个单元施加预应力。


02_初拉力荷载

Home > midas Gen 2017 > 07_荷载 > 04_温度/预应力 > 02_预应力 > 02_初拉力

初拉力荷载

  • 功 能

输入桁架单元，只受拉单元(钩、索)或只受压单元(间隙)中的预拉荷载，也可以修改后删除先前输入的荷载。

当运行材料非线性分析时，不能应用该荷载。

  • 命 令

从主菜单中选择荷载 > 预应力荷载 > 初拉力...

在树形菜单的菜单表单中选择静力荷载 > 预应力荷载 > 初拉力荷载

  • 输 入

荷载工况名称

输入荷载工况名称。单击右边的 [image] 输入另外的荷载工况，修改或删除现有的荷载工况。

荷载组名称

选择初拉力荷载将要所属的荷载组。当不需要指定组时，选择"默认值"。当需要添加和编辑荷载组时，可以点击右面的 [image] ，将弹出"定义荷载组"对话框。

选择

添加：输入新的或添加梁单元预应力荷载。

替换：替换先前输入的梁单元预应力荷载。

删除：删除先前输入的梁单元预应力荷载。

初拉力

输入正的(拉力)或负的(压力)预拉荷载。

注：如果索单元中为指定初拉力荷载，MIDAS/GEN会根据构件的容重和索的几何参数计算初始应力。


03_初拉力体外类型荷载工况

Home > midas Gen 2017 > 07_荷载 > 04_温度/预应力 > 02_预应力 > 03_体外类型荷载工况

初拉力体外类型荷载工况

  • 功 能

输入桁架单元的体外类型的预拉荷载。以前在一般静力分析时只能输入体内类型的预拉荷载，但是使用此功能在一般静力分析时也可以输入体外类型的预拉荷载。

不能够与P-Delta分析同时进行分析。

  • 命 令

从主菜单中选择荷载 > 预应力荷载 > 初拉力体外类型荷载工况

在树形菜单的菜单表单中选择荷载 > 预应力荷载 > 初拉力体外类型荷载工况

  • 输 入

在已经输入初拉力荷载的荷载工况中选择荷载工况点击 [image] 按钮，定义为体外类型荷载工况。

删除已输入的数据点击 [image] 。

初拉力体外类型荷载工况对话框


04_预应力钢束特性值

Home > midas Gen 2017 > 07_荷载 > 04_温度/预应力 > 02_预应力 > 04_钢束特性

预应力钢束特性值

  • 功 能

定义钢束的特性值和钢束的张拉方法。

  • 命 令

从主菜单中选择荷载 > 预应力荷载 > 预应力钢束特性值...

在树形菜单的菜单表单中选择静力荷载 > 预应力荷载 > 预应力钢束特性值

  • 输 入

<图1> 预应力钢束特性值对话框

新建或添加预应力钢束特性值时

点击 [image] ，输入预应力钢束特性值数据。

<图2>添加/编辑钢束特性值

预应力钢束的名称

输入钢束的名称。

预应力钢束的类型

选择预应力钢束的类型。

内部(先张)：在混凝土浇注前张拉钢束，通过混凝土和钢束的摩擦力传递预应力的方式。

内部(后张)：混凝土凝固后张拉并锚固钢束来给混凝土施加预应力的方式。

外部：体外束。

注： 当钢束为体外束时，在 [image] 显示功能中选择显示钢束时，钢束形状将显示为直线。

材料

选择钢束的材料，需要添加和编辑钢束的材料特性时，可以点击右侧的 [image] 。

钢束总面积

可以直接输入钢束的总面积，也可以点击右侧的 [image] ，选择钢绞线的公称直径和组成钢束的钢绞线股数。

导管直径：当钢束类型为内部（后张）时，输入预埋管孔道直径。

钢筋松弛系数

计算松弛的方法可以选择JTG04规范、Magura计算式、CEB-FIP、TB05、INDIA及欧洲规范的规定。若不想考虑松弛的影响，可以去掉左侧勾选项。

选择Magura计算式

选择计算松弛系数时所需的参数C值(10或45)。松弛系数10和45分别用于一般钢束和低松弛钢束。

其计算式如下：

其中，

其中， [image] 为初始应力；

为加载后，时刻t的应力；

为屈服应力(0.1% Offset Yield Stress)；

C为 松弛系数，一般钢材取值为10，低松弛钢材取值45。

选择CEB-FIP

输入松弛引起的最终损失率。松弛引起的预应力损失量计算如下：

其中， [image] ：初始应力

：松弛引起的最终损失率

：各步骤结束时的松弛进展度

随时间变化的松弛进展度的计算方法如下：

其中，t。＝张拉预应力时的时间

t ＝查看松弛引起损失的时间

注:普通松弛选择10，低松弛(low-relaxation steel)选择45。当不考虑松弛的影响时，可不勾选左侧选项。该系数主要用于计算随时间发展的预应力松弛的影响，当时间取无限大时，为松弛的最终预应力损失值。

选择JTG-04

在定义材料时使用JTG04规范的材料，在钢筋松弛系数力选择JTG04，预应力钢筋抗拉强度标准值根据规范自动输入。

如果定义材料时没有采用JTG04的材料，用户可直接输入预应力钢筋抗拉标准值。

定义材料时选择Steelbar540～930时，超张拉项不起作用。

注：钢筋松弛系数：I级松弛（普通松弛）选择1.0，II级松弛（低松弛）选择0.3。

选择TB05

如果定义材料数据时选择了TB05，定义钢束松弛系数时也选择TB05，则钢束的抗拉强度标准值（fpk）与钢束松弛系数将自动根据TB05规范取用。

如果用户未在材料数据中选择TB05规范，则用户需要直接输入钢束的抗拉强度标准值。

选择INDIA（IRC18-2000）

1000天的松弛损失如下：

松弛损失与时间关系如下：

极限强度：预应力钢筋的强度标准值。

屈服强度：预应力钢筋的屈服强度。

预应力钢筋与管道壁的摩擦系数

选择规范中提供的系数，注意建筑结构规范"混凝土结构设计规范"与桥规的取值不同。

管道每米局部偏差对摩擦的影响系数

选择规范中提供的系数，注意建筑结构规范"混凝土结构设计规范"与桥规的取值不同。

锚具变形、钢筋回缩和接缝压缩值

参考各规范输入。

开始点：钢束开始点内缩值。

结束点：钢束结束点内缩值。

粘结类型

粘结：注浆以后，用考虑钢束面积的换算截面来计算截面特性值。

无粘结：张拉完钢筋后，用不考虑管道面积的混凝土截面来计算截面特性值。

需要修改钢束特性值时

在钢束特性值列表框中选择相应钢束，点击 [image] 进行修改。

需要删除钢束特性值数据时

在钢束特性值列表框中选择相应钢束之后，点击 [image] 。


05_预应力钢束的形状

Home > midas Gen 2017 > 07_荷载 > 04_温度/预应力 > 02_预应力 > 05_钢束形状

预应力钢束的形状

  • 功 能

定义钢束在单元各截面上的布置位置。

注 1

利用钢束布置形状功能布置钢束时，可以复制钢束、旋转钢束，还可以考虑纵坡布置钢束。

注 2

为了有效有效提高编辑修改钢束形状，可以在工作树型菜单的钢束布置形状部分直接修改其钢束特征值。

  • 命 令

从主菜单中选择荷载 > 预应力荷载 > 预应力钢束的形状...

在树形菜单的菜单表单中选择静力荷载 > 预应力荷载 > 钢束的布置形状

  • 输 入

<图1> 钢束布置对话框

注1
选择钢束形状列表中的任意一个，图形中将显示该钢束的布置。

当需要添加新的钢束布置时，点击 [image] ；当需要编辑某个钢束布置形状时，点击 [image] ；当需要修改钢束的特性值时，点击 [image] ；当需要删除某个钢束的布置时，点击 [image] 。

注2

如果需要修改多个钢束特性值。该功能可以用于集中修改，比单独修改会更方便。

修改钢束特性值对话框

复制

复制已经建立的钢束布置。

前缀：复制生成的钢束布置形状名称的前缀。

后缀：复制生成的钢束布置形状名称的后缀。

距离：输入复制生成的钢束在X、Y、Z方向移动的距离。

点击 [image] ，生成复制的钢束。

移动

移动已经建立的钢束布置。

距离：输入钢束在X、Y、Z方向移动的距离。

点击 [image] ，移动选定的钢束。

<图2> 添加/编辑钢束布置对话框

钢束名称

名称为英文时，长度不能超过20个字母(包括空格)；名称为中文时，长度不能超过10个汉字(包括空格)。

钢束特性值

选择钢束的特性值名称。当需要新建、修改和删除钢束特性值时点击 [image] 。

分配给单元

输入将分配钢束的单元号。可以使用鼠标编辑功能。

输入类型

2-D：在二维平面内按照平弯和竖弯分别输入钢束的形状。

3-D：在三维空间中输入钢束的形状。

曲线类型

选择定义钢束形状的方法，MIDAS程序提供样条法和圆弧法。

样条：定义钢束布置的各控制点(最高、最低和反弯点)，程序自动生成连接各点的曲线，生成的方法为使样条在各位置的曲率半径为最小。

圆弧：定义钢束布置的各控制点(最高、最低和反弯点)，在各点给出钢束曲线的半径。圆弧与两端的直线相切。

钢束直线长度

在钢束两端，设置直线段。

开始点：始点处直线段。

结束点：终点处直线段。

无应力场长度

输入钢束的无应力场长度。无应力场是指在钢束的锚固端或构件端部 ，钢束引起的压应力没有传递到构件上、下端的情况。无应力场长度用户可以直接输入或根据公式自动计算输入。自动输入的方法根据钢束特性值分为2类（Post-tension，Pre-tension）。按中国规范计算时，可不输入该项。

用户定义长度：用户直接输入无应力场长度。

开始：开始点的无应力场长度

结束： 结束点的无应力场长度

自动计算(0.5x(H+Bf/n)：后张法的情况按下面公式自动计算无应力场长度。

L=0.5x(H+Bf/n)

H：截面高度，Bf：翼缘板宽度，n：腹板数(1室腹板数为2)

自动计算65x钢束直径：先张法的情况按下面公式自动计算无应力场长度。

L=65x钢束直径

形状

以钢束的始点为原点，输入钢束各控制点在假想坐标系-钢束坐标系内的坐标。最少要输入两点的坐标。

假想坐标系(钢束坐标系)中将钢束的纵向布置方向设置为x轴，z轴设置同整体坐标系的z轴。

选择样条时

x, y, z：钢束各控制点在钢束坐标系的坐标。

固定：固定钢束的切线角度。

Ry：选择固定后方能输入。在钢束坐标系x-z平面中与x轴的角度。

Rz：选择固定后方能输入。在钢束坐标系x-y平面中与x轴的角度。

注
例如，在钢束坐标系的点(x=10，y=2)处的切线角度固定为Ry=30和Rz=-30。钢束在定义了切线角度的节点处角度被固定外，整个曲线是按最小曲率拟合的。

选择圆弧时

x, y, z：钢束各控制点在钢束坐标系的坐标。

半径：输入各控制点处的圆弧半径。

<图3> 控制点半径示意图

对称点

对于自身对称的钢束，可以自动生成对称部分的数据。

开始：以开始点作为对称点。

结束：以结束点作为对称点。

点击 [image] ，自动生成对称部分的数据。

钢束形状

输入钢束坐标系x轴的形状。

直线：钢束坐标系x轴为直线。

曲线：钢束坐标系x轴为曲线，主要应用于弯桥。

单元：以单元x轴形状作为钢束坐标系x轴形状。

当选择直线时：

形状插入点

输入钢束始点(钢束坐标系原点)在整体坐标系中的坐标。

x轴方向

指定钢束坐标系x轴的形状。

X：x轴平行于整体坐标系X轴。

Y：x轴平行于整体坐标系Y轴。

向量：输入x轴在整体坐标系内的向量方向。

绕x轴旋转角度

实际布置钢束时，将钢束绕钢束坐标系x轴旋转布置。主要应用于倾斜腹板中的钢束布置。

投影：

将钢束布置投影到绕x轴旋转后得到的平面上。未选该项时，钢束坐标将按旋转计得到。

绕整体坐标轴旋转

将布置好的钢束绕整体坐标系的Y轴和Z轴旋转。该功能主要用于桥梁在纵向有坡度时钢束的布置。

当选择曲线时：

形状插入点

输入钢束始点(钢束坐标系原点)在整体坐标系中的坐标。

圆中心(X, Y)

输入x轴的圆心在整体坐标系的坐标。

偏心

输入钢束真实布置位置，即沿着半径中心与插入点的连线方向，钢束真实布置位置与插入点的偏心距离。

注
当钢束坐标系x轴形状为曲线时，钢束将布置在以半径中心和插入点间距为半径的圆弧上。当输入了偏心时，钢束将按距离圆弧以偏心距离的位置上布置钢束。在弯桥中，各腹板束一般为同心圆。此时在布置了一个腹板束后，使用复制功能并修改偏心距离，即可快速布置其他腹板束。

方向

顺时针：按顺时针方向布置钢束。

逆时针：按逆时针方向布置钢束。

绕x轴旋转角度

实际布置钢束时，将钢束绕钢束坐标系x轴旋转布置。主要应用于倾斜腹板中的钢束布置。

投影：

将钢束布置投影到绕x轴旋转后得到的平面上。未选该项时，钢束坐标将按旋转计得到。

绕整体坐标轴旋转

将布置好的钢束绕整体坐标系的Y轴和Z轴旋转。该功能主要用于桥梁在纵向有坡度时钢束的布置。

当选择单元时：

形状插入点

输入钢束始点(钢束坐标系原点)在整体坐标系中的坐标。

I-端：指定单元的I端作为参考插入点。

J-端：指定单元的J端作为参考插入点。

单元：输入单元号。

x轴方向

指定钢束坐标系x轴的形状。

I->J：钢束的x轴方向定义为从单元I端到J端的方向。

J->I：钢束的x轴方向定义为从单元J端到I端的方向。

单元：默认与形状插入点中的单元号相同。

绕x轴旋转角度

实际布置钢束时，将钢束绕钢束坐标系x轴旋转布置。主要应用于倾斜腹板中的钢束布置。

投影：

将钢束布置投影到绕x轴旋转后得到的平面上。未选该项时，钢束坐标将按旋转计得到。

偏心

输入钢束在单元坐标系中的偏心，即确定钢束的真实布置位置。

y：钢束形状在单元坐标系y轴方向的偏移距离。

z：钢束形状在单元坐标系z轴方向的偏移距离。

注1
当钢束坐标系x轴形状为曲线时，钢束将布置在以半径中心和插入点间距为半径的圆弧上。当输入了偏心时，钢束将按距离圆弧以偏心距离的位置上布置钢束。在弯桥中，各腹板束一般为同心圆。此时在布置了一个腹板束后，使用复制功能并修改偏心距离，即可快速布置其他腹板束。

注2
钢束只能布置在梁单元上，分配了钢束的梁单元可以是不连续的。在 [image] 显示对话框的综合表单中选择显示钢束的布置形状，可以在模型窗口中随时查看钢束的布置。体外束显示为直线。


06_钢束预应力荷载

Home > midas Gen 2017 > 07_荷载 > 04_温度/预应力 > 02_预应力 > 06_钢束预应力

钢束预应力荷载

  • 功 能

定义给钢束施加的预应力。

  • 命 令

从主菜单中选择荷载 > 预应力荷载 > 钢束预应力荷载...

在树形菜单的菜单表单中选择静力荷载 > 预应力荷载 > 钢束的预应力荷载

  • 输 入

荷载工况名称

输入荷载工况名称。单击右边的 [image] 可以建立、修改或删除荷载工况。

荷载组名称

选择钢束预应力荷载将要所属的荷载组。当不需要指定组时，选择"默认值"。当需要添加和编辑荷载组时，可以点击右面的 [image] ，将弹出"定义荷载组"对话框。

选择加载的预应力钢束

在左侧钢束列表中选择将要加载的预应力钢束，点击 [image] 。在右侧选择的钢束列表中去除钢束时，选择后点击 [image] 。

张拉力

输入钢束的张拉力并选择张拉顺序，可以分别输入两端的张拉力。

应力：输入张拉应力。

内力：以力的单位输入张拉力。

先张拉：选择张拉的顺序。

开始点：钢束开始点处的张拉力。当选择先张拉"开始点"时，必须输入大于0的数据。当选择先张拉"结束点"时，如果此处输入0表示钢束张拉形式为一端张拉(结束点)，如果此处输入大于0的数据表示两端张拉。

结束点：钢束结束点处的张拉力。当选择先张拉"结束点"时，必须输入大于0的数据。当选择先张拉"开始点"时，如果此处输入0表示钢束张拉形式为一端张拉(结束点)，如果此处输入大于0的数据表示两端张拉。

注
选择张拉顺序和张拉方法的原因是为了计算钢束沿钢束全长的摩擦损失量。当梁的跨度较小且钢束形状为直线时，可选择一端张拉；当梁的跨度较大且钢束形状为曲线(如抛物线)，则应该选择两端张拉。

注浆: 每n个施工阶段

定义张拉钢束后注浆的时间。灌浆时间决定使用包括钢束的换算截面时间。

点击 [image] 将定义的钢束预应力荷载添加到目录中。当需要编辑已定义的数据时，在列表中选择相应预应力荷载，作相应修改后点击 [image] 。删除数据时，在列表中选择相应预应力荷载后点击 [image] 。


01_建筑结构施工阶段建模助手

Home > midas Gen 2017 > 07_荷载 > 05_施工阶段 > 01_施工阶段建模助手

建筑结构施工阶段建模助手

  • 功能

在做建筑物的施工阶段分析时，定义结构体系的变化、荷载条件的变化和变化时间。首先点击，自动生成最基本的施工阶段，然后根据需要再编辑局部施工阶段。

该建模助手可用于建筑施工时，定义各施工阶段单元生成和荷载施加的时间。可以反映混凝土的时间依存特性（混凝土强度，徐变和收缩）。首先点击 [image] 来生成最基本的施工阶段，然后根据需要进行编辑，会很便捷。
如果对于施工阶段建模助手中定义的施工阶段，需要进一步细化（如荷载作用在不同的时间或几何形状（单元组）的变化），可在定义施工阶段中进行。

  • 命令

从主菜单中选择荷载 > 施工阶段分析数据 > 建筑结构施工阶段建模助手...

在树形菜单的菜单表单中选择施工阶段分析数据 > 建筑结构施工阶段建模助手...

  • 输入

施工阶段建模助手对话框

施工阶段恒载工况

选择施工阶段荷载工况(包括楼板自重等)。需要建立或编辑荷载工况时，可以点击 [image] 弹出静力荷载工况对话框。

施工持续时间: 施工阶段持续时间。

构件初始材龄: 构件的初始材龄。

注：
构件的初始材龄是指从浇筑混凝土到拆模后混凝土开始参与结构工作所经历的时间。在Gen的施工阶段分析中，各施工阶段的开始时间不是指浇筑混凝土的时间，而是指该混凝土构件开始参与结构工作(参与整刚)的时间。即，混凝土的施工持续时间中不包括从浇筑到拆模的这段时间，这段时间将反映于构件的初始材龄中，从而被用于计算混凝土材料的时间依存特性。

点击 [image] 时

施工顺序列表

定义施工楼层，以及施工荷载开始发生作用的时间。

步骤

输入施工阶段编号。联合截面施工时，结构中构既有钢构件又有混凝土构件时，对于同一层可以定义不同的施工时间。

模型类型

选择定义层单元构件(生成单元)的方法。

材料类型:之前定义的材料类型。

材料名称:之前定义的材料名称。

模型材料

选择增加的层的单元材料类型或材料名称。

模型层(To)

选择在该施工阶段施工的层。如果在同一个施工阶段要施工多个楼层，选择该阶段的最高楼层。

开始层：

选择施工阶段恒载所要施加的楼层。开始层表示相应施工阶段中的最低楼层。

结束层：

选择施工阶段恒载所要施加的最高楼层。

阶段持续时间：

施工阶段持续的时间，单位为天。所有的阶段的持续时间相同，如需修改，需要在定义施工阶段中修改。

构件材龄：

所有阶段的材龄相同，如需修改，需要在定义施工阶段中修改。

注

当指定高度为3m为一个施工阶段时，需要在层(To)中选择"2F"，此时该施工阶段模型包括二层楼板和一层柱子。

即，当在层(To)中指定层为施工阶段时，则该施工阶段包括该层楼板。如果第一个施工阶段到6m，则应选择"3F"。

注：在Gen中，默认为层荷载作用的瞬间自动生成刚性楼板。用户可在各施工阶段刚性楼板组中将刚性楼板激活。

点击 [image] 时

施工顺序列表

定义施工阶段施工进程，以及施工荷载开始发生作用的时间。

步骤

输入是阶段号。当结构既有钢构件又有混凝土构件时，可以在同一施工阶段中反复输入各层的单元。

恒荷载时程

选择相应施工阶段中施工恒荷载作用时机。

各步骤模型的选择

选择各施工阶段准备施工的层。

类型

选择定义层单元构件(生成单元)的方法。

材料类型: 以材料类型指定构件。

材料名称: 以材料名称指定构件。

材料

选择增加的层的具体的单元材料类型或材料名称。

层 (To)

选择在该施工阶段施工的层。

附加恒荷载

指定各施工阶段附加荷载(装饰、砌体隔墙)的作用时间。

荷载工况 n

选择施工阶段分析中除固定荷载之外的荷载。

开始日期: 附加荷载开始作用的时间。

层: 附加荷载作用的层(当作用于多个层上时，填最上层)

删除施工阶段建模助手数据。

自动生成施工阶段数据。

自动生成施工阶段数据对话框

施工阶段

输入施工阶段信息。

荷载工况: 施工阶段荷载工况。

层增幅: 每个施工阶段施工的层数。

持续时间: 施工阶段持续时间。

构件材龄: 构件的初始材龄。

附加恒荷载工况 n

输入附加恒荷载加载信息。

荷载工况: 附加荷载工况名称。

层增幅: 附加恒荷载在同一施工阶段中加载的层数。

开始日期: 该施工阶段开始后，该附加荷载开始加载的时间。

时间增幅: 附加荷载作用于下一层的时间距离。


02_定义施工阶段

Home > midas Gen 2017 > 07_荷载 > 05_施工阶段 > 02_定义施工阶段

定义施工阶段

  • 功 能

当进行高层建筑结构设计时，柱子和竖向构件的收缩变形会对分析结果有很大的影响。该功能可用于定义必要的施工阶段，以便在高层结构分析中考虑结构布置变化，弹性柱收缩变形和时间依存柱（收缩和徐变）收缩变形。
每个施工阶段需要定义激活（或钝化）的单元、边界和荷载组。每个阶段中包括独立的单元组和边界组和荷载组，形成一个临时的独立结构。在施工阶段建模助手中不好定义的阶段信息现在可以通过该功能来添加和编辑。“建筑施工阶段建模助手”功能可用于生成施工阶段。

  • 命 令

从主菜单中选择荷载 > 施工阶段分析数据 > 定义施工阶段...

在树形菜单的菜单表单中选择施工阶段分析数据 > 定义施工阶段

在图标菜单中点击定义施工阶段。

  • 输 入

<图1> 施工阶段对话框

添加新的施工阶段，添加的施工阶段的位置在最后。

插入到在目录中选择的施工阶段之前。

插入到在目录中选择的施工阶段之后。

同时生成多个施工阶段。

在目录中选择相应施工阶段，编辑或显示该施工阶段。

在目录中选择相应施工阶段，删除该施工阶段。

关闭定义施工阶段对话框。

定义新的施工阶段时

根据添加的位置不同，可以选择点击 [image] 、 [image] 、 [image] 。

<图2> 设定施工阶段对话框

施工阶段

阶段：添加施工阶段时，该输入栏钝化。编辑施工阶段时，可通过下拉列表选择相应的施工阶段。

名称：施工阶段名称。

持续时间：施工持续时间。

保存结果

选择保存结果的方法。

施工阶段：按施工阶段保存结果。

施工步骤：按施工步骤保存结果。

显示当前施工阶段可以使用的节点号、单元号、边界组和荷载组等信息。

<图3> 当前施工阶段信息对话框

添加子步骤

在一个施工阶段内划分子步骤。同一施工阶段内的结构模型和边界条件相同，但加载的时期和荷载可以发生变化，此时可以将一个施工阶段划分成几个子步骤。

时间

输入在一个施工阶段的持续时间内每个子步骤的持续时间。该时间将使用于对话框左下部的荷载表单内的激活和钝化时间列表中。也可以在"自动生成"中输入子步骤数，将施工阶段的持续时间自动划分成几个子步骤。当重复输入时间时，重复时间将被覆盖。输入的时间均为连续累积时间。

输入子步骤的持续时间，将其添加到目录中。

在目录中选择相应子步骤进行修改。

在目录中选择相应子步骤，将其删除。

删除建立的所有子步骤，初始化目录。

自动生成

可以同时生成多个子步骤。在"步骤数"中输入将要划分的子步骤数点击 [image] ，将按步骤数以及均等对数间隔划分施工阶段的持续时间。

单元表单

通过将已经定义的结构组激活或钝化，定义相应施工阶段的结构模型。

组列表

已经定义的结构组将显示在目录中，当需要添加或编辑结构组时，点击右侧的 [image] ，弹出"定义结构组"对话框。

激活

在组列表中选择相应结构组后点击 [image] ，将其添加到激活的组列表中。在激活的组列表中，选择相应组后点击 [image] 和 [image] ，可以修改相应组的材龄或删除该结构组。

材龄
添加或修改结构组的材龄。该材龄为该结构组的初始材龄，即在该施工阶段开始时，结构组已经具备的材龄。程序将按输入的材龄计算徐变和收缩。施工阶段开始时才浇筑的混凝土的材龄为0。一般输入从浇筑混凝土后到拆模直到该单元开始发生作用(拆除了脚手架)的时间。

钝化

在组列表中选择相应结构组后点击 [image] ，将其添加到钝化的组列表中。在钝化的组列表中，可以决定结构组被钝化后，其负担的内力如何分配给相邻单元(一般输入100%)。在被钝化的组列表中分配选择相应组后点击 [image] 和 [image] ，可以修改相应组的材龄或删除该结构组。

重新分配单元内力
指定结构组被钝化后，其负担的内力分配给相邻单元的比率。

注
前一施工阶段设定的结构组、边界组、荷载组，如果在本施工阶段中没有进行相应的钝化处理，则在本施工阶段中同样适用。

边界表单

将已经定义的边界组激活或钝化，定义各施工阶段的边界。

组列表

已经定义的边界组将显示在目录中，当需要添加或编辑边界组时，点击右侧的 [image] ，弹出"定义边界组"对话框。

激活

在组列表中选择相应边界组后点击 [image] ，将其添加到激活的组列表中。在激活的组列表中，选择相应组后点击 [image] 和 [image] ，可以修改相应组的边界支承的位置或在激活列表中删除该边界组。

一般支承/弹性支承位置

指定一般支承或弹性支承的位置。

变形前：结构变形前的支承位置。

变形后：结构变形后的支承位置。

钝化

在组列表中选择相应边界组后点击 [image] ，将其添加到钝化的组列表中。在钝化的组列表中选择相应组后点击 [image] ，可以删除该边界组。

注
施工阶段开始时，边界组或被激活或被钝化。

荷载表单

将已经定义的荷载组激活或钝化，定义各施工阶段以及各施工阶段内各子步骤作用的荷载。

组列表

已经定义的荷载组将显示在目录中，当需要添加或编辑荷载组时，点击右侧的 [image] ，弹出"定义荷载组"对话框。

激活

决定激活时间后，在组列表中选择相应荷载组后点击 [image] ，将其添加到激活的组列表中。在激活的组列表中，选择相应组后点击 [image] 和 [image] ，可以修改相应组的激活时间或在激活列表中删除该荷载组。

激活时间
择相应施工阶段(或子步骤)开始后荷载组开始作用的时间。可以选择施工阶段的"开始"时间，也可以选择"结束"时间。当有添加的子步骤时，可以选择各子步骤的时间。

钝化

在组列表中选择相应荷载组后点击 [image] ，将其添加到钝化的组列表中。在钝化的组列表中，可以决定荷载组被钝化的时间。在被钝化的组列表中分配选择相应组后点击 [image] 和 [image] ，可以修改相应荷载组的钝化时间或删除该荷载组。

注
各施工阶段中只能做静力分析。如果想在某施工阶段做移动荷载分析、时程分析、反应谱分析时，可以将该施工阶段定义为"最终"施工阶段。

当需要同时定义多个施工阶段时

在定义施工阶段对话框中点击 [image] 。当需要编辑和显示某施工阶段时，点击 [image] 。

<图4> 同时定义多个施工阶段对话框

施工阶段

名称：输入施工阶段名称。

后缀：输入阶段名称后面的后缀号。

例如) 在名称中输入'CS', 后缀中输入'1 to 4'，则生成从'CS1'到'CS4'的四个施工阶段。

持续时间：各施工阶段的持续时间。

添加子步骤

在一个施工阶段内划分子步骤。同一施工阶段内的结构模型和边界条件相同，但加载的时期和荷载可以发生变化，此时可以将一个施工阶段划分成几个子步骤。

时间

输入在一个施工阶段的持续时间内每个子步骤的持续时间。该时间将使用于对话框左下部的荷载表单内的激活和钝化时间列表中。也可以在"自动生成"中输入子步骤数，将施工阶段的持续时间自动划分成几个子步骤。当重复输入时间时，重复时间将被覆盖。输入的时间均为连续累积时间。

输入子步骤的持续时间，将其添加到目录中。

在目录中选择相应子步骤进行修改。

在目录中选择相应子步骤，将其删除。

删除建立的所有子步骤，初始化目录。

自动生成

可以同时生成多个子步骤。在"步骤数"中输入将要划分的子步骤数点击 [image] ，将按步骤数以及均等对数间隔划分施工阶段的持续时间。

保存结果

选择保存施工阶段数据的方法。

施工阶段
按施工阶段保存结果。

施工步骤
按施工的子步骤保存结果。

点击 [image] 或 [image] ，将定义的多个施工阶段添加到施工阶段目录中。


04_施工阶段联合截面

Home > midas Gen 2017 > 07_荷载 > 05_施工阶段 > 03_施工阶段联合截面

施工阶段联合截面

  • 功 能

通过激活、钝化联合截面相应施工阶段的截面定义每一个施工阶段的分析模型。

  • 命 令

从主菜单中选择荷载 > 施工阶段分析数据 > 施工阶段联合截面...

  • 输 入

  • 新建或添加施工阶段联合截面时

点击 [image] ，将弹出"添加/编辑施工阶段联合截面"对话框，添加新的施工阶段联合截面数据。

激活施工阶段：从列表中选择单元被激活的施工阶段，即构件最初生成的施工阶段。

截面：在已经定义的截面中，选择要进行联合截面施工的截面名称。选择截面后，与该截面相对应的单元号会自动显示在?单元列表?中。该截面，其作用除为了在此定义联合截面施工阶段外，还有两个作用：一是为了在模型窗口?消隐?时显示形状，二是为了确定联合后截面的形心位置。如果联合截面的形状不规则，无法在数据库中定义，可以使用?数值?的方法定义截面后，在截面特性的Center:y、Center:z项中输入正确的形心位置即可。

联合形式：标准、用户

在"截面"栏选择联合截面表单定义截面或组合截面表单定义截面，则显示为"标准"，此时的截面刚度采用数据库数据，如要调整可以在下面?施工顺序?表格的刚度里面修改。

在"截面"栏选择其它表单定义截面，则显示为"用户"，此时截面刚度需用户直接输入。所以该截面的截面特性值不参与分析与计算，只起模型窗口?消隐?时的显示形状作用。

截面类型：显示截面的类型。

截面形状：显示截面的形状。

单元列表：与在"截面"中所选择的截面相对应的单元号会自动显示在此。

施工顺序：定义各位置号相应的单元特性值(分析用)和各截面相对位置(形心)。

位置：显示位置编号

材料类型：

单元：按单元进行选择。已经定义的单元的材料特性将被使用。

材料：按材料进行选择。所选的材料特性将用于分析。不使用已经定义过的材料特性。

注：组合截面可以采用SRC材料。如果选择了SRC组合材料截面，而材料类型中选择了单元，将使用SRC材料中的钢材特性。

材料：

选择材料。如果在材料类型中选择材料，则用户可以定义这种截面的材料。

叠合阶段：指定各位置的构件产生的施工阶段。

材龄：当施工阶段联合截面激活时，输入各位置的材龄。一般施工阶段中输入的材龄将不考虑，而该处输入的材龄将被激活并用于分析。

h:输入构件各位置的尺寸，h=2*Ac/u（Ac:截面面积；u：周长）

■“h”值的要求

h数值必须大于0。如果h等于0，除了下面的情况外，分析都不能进行。

1. 当所选截面的单元不在激活的施工阶段；

2. 当I型钢截面或箱型钢截面被指定为位置1；

3. 当材料类型中选择“材料”，并且材料被指定为钢材时；

4. 当材料类型中选择“单元”，并且所有的在单元列表里定义的单元都是钢材。

■打开一个旧版本的模型生成数据

当材料类型指定为“单元”时，除了下列情况外，h值要输入0。

1. 在“修改单元依存材料特性”的对话框里，对所有在单元列表里的单元，h值输入了相同的值；

2. 当单元列表里的所有单元被指定了相同的时间依存材料特性；

当材料类型被指定为“材料”

1. 将使用所选材料的材料特性和与时间依存性材料特性中定义的h值

2. 当使用所选材料的材料特性和与时间依存性特性中的体积面积比时，h将被指定为0

注：

1. 联合截面和PSC截面类型时，h值自动计算，并且用户可以修改

2. 计算整体周长u时，不考虑封闭部分的影响系数

3. 对于联合截面，依据桥梁的总宽度计算板面积和周长，不是分割成多段。

刚度：输入各位置截面的特性值。当联合形式为"标准"时，各位置的截面特性值程序会自动输入；否则由用户直接输入。

刚度系数：对刚度的调整系数。

注：

程序会根据各位置的刚度特性值以及材龄，计算联合后截面的特性值。但对于抗扭刚度和有效剪切面积，由于计算方法与截面的具体形状相关，故这里只是将各位置的抗扭刚度和有效剪切面积进行算术叠加。用户可另行计算联合后截面的抗扭刚度和有效剪切面接后，用这里的刚度调整系数来调整。

叠合刚度：在相应阶段已经联合的截面的刚度。

注：

大略的查看联合截面的截面特性，可以检查最终联合截面的误差。在使用了刚度系数的情况下，更容易的查看截面特性。

  • 需要修改施工阶段联合截面时

点击 [image] ，修改输入的施工阶段联合截面数据。

  • 需要删除施工阶段联合截面时

点击 [image] ，删除输入施工阶段联合截面数据。

刚度系数： 定义各位置截面特性的比例系数

面积：

Asy：局部坐标轴y方向的有效剪切面积
Asz：局部坐标轴z方向的有效剪切面积
Ixx：对单元局部坐标系x轴的扭转惯性距
Iyy：对单元局部坐标系y轴的惯性距
Izz：对单元局部坐标系z轴的惯性距

重量：

刚度： 修改各部分的截面特性值

Asy：单元局部坐标系y轴方向的有效抗剪面积
Asz：单元局部坐标系z轴方向的有效抗剪面积
Ixx：对单元局部坐标系x轴的扭转惯性距
Iyy：对单元局部坐标系y轴的惯性距
Izz：对单元局部坐标系z轴的惯性距
Cyp：沿单元局部坐标系y轴正方向，单元截面中和轴到边缘纤维的距离。
Cym：沿单元局部坐标系y轴负方向，单元截面中和轴到边缘纤维的距离。
Czp：沿单元局部坐标系z轴正方向，单元截面中和轴到边缘纤维的距离。
Czm：沿单元局部坐标系z轴负方向，单元截面中和轴到边缘纤维的距离。
Qyb：沿单元局部坐标系z轴方向的剪切系数。
Qzb：沿单元局部坐标系y轴方向的剪切系数


01_施工阶段时程荷载

Home > midas Gen 2017 > 07_荷载 > 05_施工阶段 > 04_施工阶段荷载 > 01_施工阶段时程荷载

施工阶段时程荷载

  • 功 能

为了考虑相邻构件的材龄差异，并反映到材料的时间依存特性(徐变、收缩、强度的变化等)，给构件施加时间荷载。

  • 命 令

从主菜单中选择荷载 > 施工阶段 > 施工阶段荷载 > 施工阶段时程荷载...

在树形菜单的菜单表单中选择静力荷载 > 施工阶段时间荷载

  • 输 入

荷载工况名称

输入荷载工况名称。单击右边的 [image] 可以建立、修改或删除荷载工况。

荷载组名称

选择施工阶段时间荷载将要所属的荷载组。当不需要指定组时，选择"默认值"。当需要添加和编辑荷载组时，可以点击右面的 [image] ，将弹出"定义荷载组"对话框。

选择

添加：输入新的或附加的施工阶段时间荷载。

替换：替换先前输入的施工阶段时间荷载。

删除：删除先前输入的施工阶段时间荷载。

时间荷载：按天数输入时间荷载。


02_施工阶段徐变系数

Home > midas Gen 2017 > 07_荷载 > 05_施工阶段 > 04_施工阶段荷载 > 02_施工阶段徐变系数

施工阶段徐变系数

  • 功 能

将徐变系数作为荷载直接分配给单元。输入的徐变系数优先于在徐变函数定义中定义的徐变系数。

在施工阶段分析控制中可以指定用哪个徐变系数做施工阶段分析。

  • 命 令

从主菜单中选择荷载 > 施工阶段 > 施工阶段荷载 > 施工阶段徐变系数...

在树形菜单的菜单表单中选择静力荷载 > 施工阶段时间荷载

  • 输 入

荷载工况名称

输入荷载工况名称。单击右边的 [image] 可以建立、修改或删除荷载工况。

荷载组名称

选择施工阶段徐变系数将要所属的荷载组。当不需要指定组时，选择"默认值"。当需要添加和编辑荷载组时，可以点击右面的 [image] ，将弹出"定义荷载组"对话框。

选择

添加：输入新的或附加的施工阶段徐变系数。

替换：替换先前输入的施工阶段徐变系数。

删除：删除先前输入的施工阶段徐变系数。

徐变系数

输入徐变系数。


03_选择显示的施工阶段

Home > midas Gen 2017 > 07_荷载 > 05_施工阶段 > 05_显示阶段

选择显示的施工阶段

  • 功 能

选择在窗口中显示的施工阶段。

  • 命 令

从主菜单中选择荷载 > 施工阶段分析数据 > 选择显示施工阶段...

在树形菜单的菜单表单中选择施工阶段分析数据 > 选择显示的施工阶段

在图标菜单中点击 [image] 选择施工阶段。

  • 输 入

<图1> 选择显示施工阶段对话框

选择相应施工阶段后点击 [image] 或 [image] 。

注1
施工阶段工具条中列有各施工阶段。在后处理模式中多出了"最小/最大"和"最终"两个施工阶段。"最小/最大"是输出各施工阶段的最小和最大值。"最终"除了输出施工阶段荷载分析结果，还输出其它荷载工况的静力和动力分析结果。

如果想要用于施工阶段分析的荷载类型没有定义为“施工阶段荷载”，在“最终阶段”中仅生成一般分析结果。
注2：利用工具菜单中的阶段页可以更方便的实现该功能。


01_节点体力

  • 功 能

以电子表格形式输入或修改节点处的节点体力。

MIDAS/Gen中的表格工具提供了各种强大的功能。详细说明参见以下各项：

表格工具的使用

术语

掌握使用方法

基本说明(单元移动、选择、大小控制等)

数据处理(增加、删除、修改数据)

用剪贴板复制/粘贴数据

表格功能补充

表格排序

表格格式设定

自动适应列宽

图表打印

各表格类型的补充功能

节点/单元表格

结果表格

  • 命 令

从主菜单中选择荷载 > 荷载表格 > 节点体力...

从树形菜单的表格表单中选择结构表格 > 静力荷载 > 节点体力

  • 输 入(参照"节点荷载")：

参考表格工具的使用输入或修改下列数据

荷载工况：选择荷载工况。

节点：节点编号。

FX：质量转换为X方向的节点体力值。

FY：质量转换为Y方向的节点体力值。

FZ：质量转换为Z方向的节点体力值。


02_节点质量

Home > midas Gen 2017 > 07_荷载 > 06_荷载表格 > 01_静力荷载 > 02_节点质量

节点质量

  • 功 能

在电子表格中输入或修改节点质量数据(集中平动质量、转动质量惯性矩) 。

MIDAS软件中的表格工具提供了各种强大的内置功能。详细说明参见下列各项：

表格工具的使用

术语

掌握使用方法

基本说明(单元移动、选择、大小控制等)

数据处理(增加、删除、修改数据)

用剪贴板复制/粘贴数据

表格功能补充

表格排序

表格格式设定

自动适应列宽

图表打印

各表格类型的补充功能

节点/单元表格

结果表格

  • 命 令

从主菜单中选择荷载 > 荷载表格 > 静力荷载 > 节点质量...

在树形菜单的表格表单中选定结构表格 > 质量 > 节点质量...

快捷键： [Ctrl]+[Alt]+U

  • 输 入 (参见"节点质量")

参考表格工具的使用输入下列数据：

节点：节点编号

mX：整体坐标系X轴方向的平动集中质量

mY：整体坐标系Y轴方向的平动集中质量

mZ：整体坐标系Z轴方向的平动集中质量

rmX：绕整体坐标系X轴的转动质量惯性矩

rmY：绕整体坐标系Y轴的转动质量惯性矩

rmZ：绕整体坐标系Z轴的转动质量惯性矩


02_节点荷载

Home > midas Gen 2017 > 07_荷载 > 06_荷载表格 > 01_静力荷载 > 03_节点荷载

节点荷载

  • 功 能

以电子表格形式输入或修改节点处的集中力和弯矩。

MIDAS/Gen中的表格工具提供了各种强大的功能。详细说明参见以下各项：

表格工具的使用

术语

掌握使用方法

基本说明(单元移动、选择、大小控制等)

数据处理(增加、删除、修改数据)

用剪贴板复制/粘贴数据

表格功能补充

表格排序

表格格式设定

自动适应列宽

图表打印

各表格类型的补充功能

节点/单元表格

结果表格

  • 命 令

从主菜单中选择荷载 > 荷载表格 > 节点荷载...

从树形菜单的表格表单中选择结构表格 > 静力荷载 > 节点荷载

快捷键：[Ctrl]+[Shift]+N

  • 输 入(参照"节点荷载")

参考表格工具的使用输入或修改下列数据：

节点：节点编号。

荷载工况：选择荷载工况。

FX：整体坐标系X轴方向的集中荷载分量。

FY：整体坐标系Y轴方向的集中荷载分量。

FZ：整体坐标系Z轴方向的集中荷载分量。

MX：绕整体坐标系X轴的弯矩分量。

MY：绕整体坐标系Y轴的弯矩分量。

MZ：绕整体坐标系Z轴的弯矩分量。

组：该节点荷载所属的荷载组。


03_强制位移

Home > midas Gen 2017 > 07_荷载 > 06_荷载表格 > 01_静力荷载 > 04_强制位移

强制位移

  • 功 能

以电子表格形式输入或修改支座的强制位移。

MIDAS/Gen中的表格工具提供了各种强大的功能。详细说明参见以下各项：

表格工具的使用

术语

掌握使用方法

基本说明(单元移动、选择、大小控制等)

数据处理(增加、删除、修改数据)

用剪贴板复制/粘贴数据

表格功能补充

表格排序

表格格式设定

自动适应列宽

图表打印

各表格类型的补充功能

节点/单元表格

结果表格

  • 命 令

从主菜单中选择荷载 > 荷载表格 > 强制位移...

从树形菜单的表格表单中选择结构表格 > 静力荷载 > 强制位移

  • 输 入(参照"强制位移")

参考表格工具的使用输入或修改下列数据：

节点：节点编号。

荷载工况：选择荷载工况。

约束标记：在节点坐标系(或整体坐标系)中选择强制位移的自由度分量。"1"为有强制位移，"0"为无强制位移。

Dx：在节点坐标系(或整体坐标系)x轴方向的强制位移。

Dy：在节点坐标系(或整体坐标系)y轴方向的强制位移。

Dz：在节点坐标系(或整体坐标系)z轴方向的强制位移。

Rx：绕节点坐标系(或整体坐标系)x轴的强制旋转位移(弧度)。

Ry：绕节点坐标系(或整体坐标系)y轴的强制旋转位移(弧度)。

Rz：绕节点坐标系(或整体坐标系)z轴的强制旋转位移(弧度)。

组：该强制位移荷载所属的荷载组。


04_梁单元荷载

Home > midas Gen 2017 > 07_荷载 > 06_荷载表格 > 01_静力荷载 > 05_梁单元荷载

梁单元荷载

  • 功 能

以电子表格形式输入或修改梁单元荷载。

MIDAS/Gen中的表格工具提供了各种强大的功能。详细说明参见以下各项：

表格工具的使用

术语

掌握使用方法

基本说明(单元移动、选择、大小控制等)

数据处理(增加、删除、修改数据)

用剪贴板复制/粘贴数据

表格功能补充

表格排序

表格格式设定

自动适应列宽

图表打印

各表格类型的补充功能

节点/单元表格

结果表格

  • 命 令

从主菜单中选择荷载 > 荷载表格 > 梁单元荷载...

从树形菜单的表格表单中选择结构表格 > 静力荷载 > 梁单元荷载

快捷键： [Ctrl]+[Shift]+M

  • 输 入(参照"梁单元荷载")

参考表格工具的使用输入或修改下列数据：

单元：单元编号

梁单元荷载类型：梁单元荷载类型有单元、连续、标准以及楼面荷载(转换为梁单元荷载)，在表格形式中不能修改类型。(参见梁单元荷载(单元)、梁单元荷载(连续)、梁单元荷载(标准)、分配楼面荷载)。

荷载工况：显示梁单元荷载所属的荷载工况。

荷载类型：显示梁单元荷载的形式(集中荷载、集中弯矩、分布荷载、分布弯矩)。

偏心: 显示是否设置偏心

偏心方向: 显示偏心的方向

使用J: 如果J端节点使用偏心时显示

距离-I(m): I端的偏心距离

距离-J(m): J端的偏心距离

附加H：I端是否考虑附加高度，只有当荷载类型选择压力或均布压力时才激活。

J端附加：J端是否考虑附加高度，只有当荷载类型选择压力或均布压力时才激活。

I端附加高度：I端附加高度

J端附加高度：J端附加高度

方向：选择梁荷载的加载方向(局部坐标系X、Y、Z和整体坐标系X、Y、Z)。

投影：选择是否投影梁单元荷载。

D1～D4：加载位置。

P1～P4：加载位置D1～D4处的荷载值。

单位：梁单元荷载的单位(自动显示)。

Dx：在指定方向上输入的楼面荷载产生的梁单元荷载在整体坐标系X轴方向的分量(自动显示)。

Dy：在指定方向上输入的楼面荷载产生的梁单元荷载在整体坐标系Y轴方向的分量(自动显示)。

Dz：在指定方向上输入的楼面荷载产生的梁单元荷载在整体坐标系Z轴方向的分量(自动显示)。

注
分配楼面荷载时，如果选择了将其转换为梁单元荷载(参见分配楼面荷载)，则在本表格中将显示转换的梁单元荷载。如果没有选择转换，则在本表格中不显示。当按局部坐标系方向输入楼面荷载时，本表格中的数据为转换成整体坐标系方向后的荷载。

组：该梁单元荷载所属的荷载组。


05_楼面荷载类型

Home > midas Gen 2017 > 07_荷载 > 06_荷载表格 > 01_静力荷载 > 06_楼面荷载类型

楼面荷载类型

  • 功 能

以电子表格形式输入或修改楼面荷载类型。

MIDAS/Gen中的表格工具提供了各种强大的功能。详细说明参见以下各项：

表格工具的使用

术语

掌握使用方法

基本说明(单元移动、选择、大小控制等)

数据处理(增加、删除、修改数据)

用剪贴板复制/粘贴数据

表格功能补充

表格排序

表格格式设定

自动适应列宽

图表打印

各表格类型的补充功能

节点/单元表格

结果表格

  • 命 令

从主菜单中选择荷载 > 荷载表格 > 楼面荷载类型...

从树形菜单的表格表单中选择结构表格 > 静力荷载 > 楼面荷载类型

  • 输 入(参照"定义楼面荷载类型)

参考表格工具的使用输入或修改下列数据：

名称：定义的楼面荷载名称。

描述：输入对楼面荷载的简要描述。

荷载工况：选择荷载工况。

荷载：对应工况荷载值。

Sub：是否考虑次梁的重量。

注：勾选为考虑。


06_楼面荷载表格

Home > midas Gen 2017 > 07_荷载 > 06_荷载表格 > 01_静力荷载 > 07_楼面荷载

楼面荷载表格

  • 功 能

以电子表格形式输入或修改楼面荷载。

MIDAS/Gen中的表格工具提供了各种强大的功能。详细说明参见以下各项：

表格工具的使用

术语

掌握使用方法

基本说明(单元移动、选择、大小控制等)

数据处理(增加、删除、修改数据)

用剪贴板复制/粘贴数据

表格功能补充

表格排序

表格格式设定

自动适应列宽

图表打印

各表格类型的补充功能

节点/单元表格

结果表格

  • 命 令

从主菜单中选择荷载> 荷载表格 > 楼面荷载...

从树形菜单的表格表单中选择结构表格 > 静力荷载 > 楼面荷载

快捷键： [Ctrl]+[Shift]+O

  • 输 入 (参见定义楼面荷载类型、分配楼面荷载)

参考表格工具的使用输入或修改下列数据：

楼面荷载类型：由定义楼面荷载类型定义的楼面荷载。

分配模式：荷载分配模式(单向、双向、面积比、长度比分配)。

加载角度：由连接定义加载区域的第一节点到第二节点的连线与荷载方向形成的角度。

次梁数量：次梁数量。

次梁角度：由连接定义加载区域的第一节点到第二节点的连线方向形成的角度。

次梁线荷载：次梁上单位长度的荷载(包括自重)。

荷载方向：楼面荷载的加载方向(楼面局部坐标系或整体坐标系)。

投影：选择是否投影楼面荷载。

加载范围节点：定义承担楼面荷载的闭合区域的节点编号。

说明：输入简要描述。

不考虑内部单元：是否考虑内部单元

允许凹多边形类型： 是否支持凹多边形

组：该楼面荷载所属的荷载组。


07_装饰材料荷载

Home > midas Gen 2017 > 07_荷载 > 06_荷载表格 > 01_静力荷载 > 08_装饰材料荷载

装饰材料荷载

  • 功 能

以电子表格形式输入或修改装饰材料荷载。

MIDAS/Gen中的表格工具提供了各种强大的功能。详细说明参见以下各项：

表格工具的使用

术语

掌握使用方法

基本说明(单元移动、选择、大小控制等)

数据处理(增加、删除、修改数据)

用剪贴板复制/粘贴数据

表格功能补充

表格排序

表格格式设定

自动适应列宽

图表打印

各表格类型的补充功能

节点/单元表格

结果表格

  • 命 令

从主菜单中选择荷载 > 荷载表格 > 装饰材料荷载...

从树形菜单的表格表单中选择结构表格 > 静力荷载 > 装饰材料荷载

  • 输 入(参照"装饰材料荷载")

参考表格工具的使用输入或修改下列数据：

单元：加载装饰材料的单元号。

荷载工况：荷载工况名称。

装饰方式：装饰方式包括包裹、填充、围绕三种方式。

面1～面1：选择各装饰表面装饰的范围(无、一半、全部)。

厚度：装饰材料的厚度。

容重：装饰材料的容重。

方向：装饰材料荷载的作用方向(局部坐标系或整体坐标系)。

系数：装饰材料的作用方向系数。

组：装饰材料荷载所属的荷载组。


08_压力荷载

Home > midas Gen 2017 > 07_荷载 > 06_荷载表格 > 01_静力荷载 > 09_压力荷载

压力荷载

  • 功 能

以电子表格形式输入或修改板、平面应力、平面应变、轴对称或实体单元边缘或表面的压力荷载。

MIDAS/Gen中的表格工具提供了各种强大的功能。详细说明参见以下各项：

表格工具的使用

术语

掌握使用方法

基本说明(单元移动、选择、大小控制等)

数据处理(增加、删除、修改数据)

用剪贴板复制/粘贴数据

表格功能补充

表格排序

表格格式设定

自动适应列宽

图表打印

各表格类型的补充功能

节点/单元表格

结果表格

  • 命 令

从主菜单中选择荷载 > 荷载表格 > 压力荷载...

从树形菜单的表格表单中选择结构表格 > 静力荷载 > 压力荷载

  • 输 入(参照"压力荷载")

参考表格工具的使用输入或修改下列数据

单元：压力荷载作用的单元号。

荷载工况：与压力荷载有关的荷载工况名称。

荷载类型：压力荷载(由程序自动输入)。

荷载形式：面荷载、线荷载。

边/面：压力荷载作用的边或表面号。

方向：压力荷载作用的方向。

VX、VY、VZ：当压力荷载作用方向选择为"向量"时，为向量的三个坐标方向。

投影：选择是否投影压力荷载。

PU：均布面荷载的大小。

P1～P4：指定线性变化的面荷载时，在连接节点N1～N4处压力荷载的大小。

EPU：均布线荷载压力荷载的大小。

EP1、EP2：指定线性变化的线荷载时，在连接节点N1～N2处压力荷载的大小。

组：压力荷载所属的荷载组。


09_平面荷载

Home > midas Gen 2017 > 07_荷载 > 06_荷载表格 > 01_静力荷载 > 10_平面荷载

平面荷载

  • 功 能

以电子表格形式输入或修改板或实体单元表面的平面荷载。

MIDAS/Gen中的表格工具提供了各种强大的功能。详细说明参见以下各项：

表格工具的使用

术语

掌握使用方法

基本说明(单元移动、选择、大小控制等)

数据处理(增加、删除、修改数据)

用剪贴板复制/粘贴数据

表格功能补充

表格排序

表格格式设定

自动适应列宽

图表打印

各表格类型的补充功能

节点/单元表格

结果表格

  • 命 令

从主菜单中选择荷载 > 荷载表格 > 平面荷载...

从树形菜单的表格表单中选择结构表格 > 静力荷载 > 平面荷载

  • 输 入(参照"平面荷载")

参考表格工具的使用输入或修改下列数据：

荷载工况：与平面荷载有关的荷载工况名称。

荷载类型：平面荷载(由程序自动输入)。

单元类型：平面荷载加载的单元类型(板单元或实体单元)。

1st(X、Y、Z)：定义荷载作用平面的第一点的坐标。

2nd(X、Y、Z)：定义荷载作用平面的第二点的坐标。

3rd(X、Y、Z)：定义荷载作用平面的第三点的坐标。

误差：定义的平面与加载平面的公差。

选择单元：选择加载平面或组。

结构组：当在"选择单元"中选择了"组"时，在此选择具体的结构组。

面：当在"单元类型"中选择了"实体单元"时，在此选择荷载作用的面。

方向：选择加载方向。

投影：选择是否投影平面荷载。

输入加载范围节点：选择是否输入加载范围节点。

加载范围节点：均布压力荷载的大小。

说明：输入对荷载的简单描述。

组：平面荷载所属的荷载组。


10_节点温度荷载

Home > midas Gen 2017 > 07_荷载 > 06_荷载表格 > 02_温度荷载 > 01_节点温度

节点温度荷载

  • 功 能

以电子表格形式输入或修改指定节点处的节点温度。

MIDAS/Gen中的表格工具提供了各种强大的功能。详细说明参见以下各项：

表格工具的使用

术语

掌握使用方法

基本说明(单元移动、选择、大小控制等)

数据处理(增加、删除、修改数据)

用剪贴板复制/粘贴数据

表格功能补充

表格排序

表格格式设定

自动适应列宽

图表打印

各表格类型的补充功能

节点/单元表格

结果表格

  • 命 令

从主菜单中选择荷载 > 荷载表格 > 节点温度荷载...

从树形菜单的表格表单中选择结构表格 > 静力荷载 > 节点温度荷载

  • 输 入(参照"节点温度荷载")

参考表格工具的使用输入或修改下列数据：

节点：加载了节点温度荷载的节点号。

荷载工况：节点温度荷载所属的荷载工况。

温度：节点最终温度。

组：节点温度荷载所属的荷载组。


11_单元温度荷载

Home > midas Gen 2017 > 07_荷载 > 06_荷载表格 > 02_温度荷载 > 02_单元温度

单元温度荷载

  • 功 能

以电子表格形式输入或修改指定单元的温度。

MIDAS/Gen中的表格工具提供了各种强大的功能。详细说明参见以下各项：

表格工具的使用

术语

掌握使用方法

基本说明(单元移动、选择、大小控制等)

数据处理(增加、删除、修改数据)

用剪贴板复制/粘贴数据

表格功能补充

表格排序

表格格式设定

自动适应列宽

图表打印

各表格类型的补充功能

节点/单元表格

结果表格

  • 命 令

从主菜单中选择荷载 > 荷载表格 > 单元温度荷载...

从树形菜单的表格表单中选择结构表格 > 静力荷载 > 单元温度荷载

  • 输 入(参照"单元温度荷载")

参考表格工具的使用输入或修改下列数据：

单元：加载了单元温度荷载的单元号。

荷载工况：单元温度荷载所属的荷载工况。

温度：单元最终温度。

组：单元温度荷载所属的荷载组。


12_温度梯度荷载

Home > midas Gen 2017 > 07_荷载 > 06_荷载表格 > 02_温度荷载 > 03_温度梯度

温度梯度荷载

  • 功 能

以电子表格形式输入或修改梁单元或板单元顶面和底面的温度差。

MIDAS/Gen中的表格工具提供了各种强大的功能。详细说明参见以下各项：

表格工具的使用

术语

掌握使用方法

基本说明(单元移动、选择、大小控制等)

数据处理(增加、删除、修改数据)

用剪贴板复制/粘贴数据

表格功能补充

表格排序

表格格式设定

自动适应列宽

图表打印

各表格类型的补充功能

节点/单元表格

结果表格

  • 命 令

从主菜单中选择荷载 > 荷载表格 > 温度梯度荷载...

从树形菜单的表格表单中选择结构表格 > 静力荷载 > 温度梯度荷载

  • 输 入(参照"温度梯度荷载")

参考表格工具的使用输入或修改下列数据：

单元：温度梯度荷载作用的单元号。

荷载工况：温度梯度荷载所属的荷载工况名称。

类型：单元类型(梁或板单元)。

Tz：单元局部坐标系z方向单元两边缘纤维间的温度差。

使用截面Hz：选项，当选择"是"时，使用板单元厚度或梁单元截面尺寸表示单元局部坐标系z方向两边缘纤维间的距离。

Hz：单元局部坐标系z方向用户指定的两边缘纤维间的距离，仅适用于选择"使用截面 Hz"为"否"时。

Ty：单元局部坐标系y方向单元两边缘纤维间的温度差。

使用截面Hy：选项，当选择"是"时，使用板单元厚度或梁单元截面尺寸表示单元局部坐标系y方向两边缘纤维间的距离。

Hy：单元局部坐标系y方向用户指定的两边缘纤维间的距离，仅适用于选择"使用截面 Hy"为"否"时。

组：温度梯度荷载所属的荷载组。


13_梁截面温度

Home > midas Gen 2017 > 07_荷载 > 06_荷载表格 > 02_温度荷载 > 04_梁截面温度

梁截面温度

  • 功 能

以电子表格形式输入或修改梁截面内温度的变化。

MIDAS/Gen中的表格工具提供了各种强大的功能。详细说明参见以下各项：

表格工具的使用

术语

掌握使用方法

基本说明(单元移动、选择、大小控制等)

数据处理(增加、删除、修改数据)

用剪贴板复制/粘贴数据

表格功能补充

表格排序

表格格式设定

自动适应列宽

图表打印

各表格类型的补充功能

节点/单元表格

结果表格

  • 命 令

从主菜单中选择荷载 > 荷载表格 > 梁截面温度...

从树形菜单的表格表单中选择结构表格 > 静力荷载 > 梁截面温度

  • 输 入(参照"梁截面温度荷载")

参考表格工具的使用输入或修改下列数据：

单元：梁截面温度荷载作用的单元号。

荷载工况：梁截面温度荷载所属的荷载工况名称。

方向：梁截面温度荷载作用的方向。

参考位置：选择中心、+边(顶)、-边(底)。

1st～5th材料：梁截面的材料特性。

1st～5th弹性：材料的弹性模量。

1st～5th线膨胀系数：材料的线膨胀系数。

1st～5th B：具有温度差的宽度。

1st～5th H1：从梁截面的形心到温度变化点的距离。

1st～5th T1：H1处的温度。

1st～5th H2：从梁截面的形心到温度变化点的距离。

1st～5th T2：H2处的温度。

组：梁截面温度荷载所属的荷载组。


14_预应力荷载

Home > midas Gen 2017 > 07_荷载 > 06_荷载表格 > 03_预应力荷载 > 01_预应力荷载

预应力荷载

  • 功 能

以电子表格形式输入或修改梁单元的预应力荷载。

MIDAS/Gen中的表格工具提供了各种强大的功能。详细说明参见以下各项：

表格工具的使用

术语

掌握使用方法

基本说明(单元移动、选择、大小控制等)

数据处理(增加、删除、修改数据)

用剪贴板复制/粘贴数据

表格功能补充

表格排序

表格格式设定

自动适应列宽

图表打印

各表格类型的补充功能

节点/单元表格

结果表格

  • 命 令

从主菜单中选择荷载 > 荷载表格 > 预应力荷载...

从树形菜单的表格表单中选择结构表格 > 静力荷载 > 预应力荷载

  • 输 入(参照"预应力荷载")

参考表格工具的使用输入或修改下列数据：

单元：预应力荷载作用的单元号。

荷载工况：预应力荷载所属的荷载工况。

张拉力：张拉力，输入正值。

距离i：单元起始节点(i端)处，沿单元局部坐标系z轴方向上索的垂距。

距离m：单元中央节点处，沿单元局部坐标系z轴方向上索的垂距。

距离j：单元结束节点(j端)处，沿单元局部坐标系z轴方向上索的垂距。

组：预应力荷载所属的荷载组。


15_初拉力荷载

Home > midas Gen 2017 > 07_荷载 > 06_荷载表格 > 03_预应力荷载 > 02_初拉力荷载

初拉力荷载

  • 功 能

以电子表格形式输入或修改桁架、索及只受拉单元的初拉力荷载。

MIDAS/Gen中的表格工具提供了各种强大的功能。详细说明参见以下各项：

表格工具的使用

术语

掌握使用方法

基本说明(单元移动、选择、大小控制等)

数据处理(增加、删除、修改数据)

用剪贴板复制/粘贴数据

表格功能补充

表格排序

表格格式设定

自动适应列宽

图表打印

各表格类型的补充功能

节点/单元表格

结果表格

  • 命 令

从主菜单中选择荷载 > 荷载表格 > 初拉力荷载...

从树形菜单的表格表单中选择结构表格 > 静力荷载 > 初拉力荷载

  • 输 入(参照"初拉力荷载")

参考表格工具的使用输入或修改下列数据：

单元：初拉力荷载作用的单元号。

荷载工况：初拉力荷载所属的荷载工况。

张拉力：初拉力荷载大小，总为正值。

组：初拉力荷载所属的荷载组。


16_钢束预应力荷载

Home > midas Gen 2017 > 07_荷载 > 06_荷载表格 > 03_预应力荷载 > 03_钢束预应力荷载

钢束预应力荷载

  • 功 能

以电子表格形式输入或修改钢束的预应力荷载数据。

MIDAS/Gen中的表格工具提供了各种强大的功能。详细说明参见以下各项：

表格工具的使用

术语

掌握使用方法

基本说明(单元移动、选择、大小控制等)

数据处理(增加、删除、修改数据)

用剪贴板复制/粘贴数据

表格功能补充

表格排序

表格格式设定

自动适应列宽

图表打印

各表格类型的补充功能

节点/单元表格

结果表格

  • 命 令

从主菜单中选择荷载 > 荷载表格 > 钢束预应力荷载...

从树形菜单的表格表单中选择结构表格 > 静力荷载 > 钢束预应力荷载

  • 输 入(参照"钢束预应力荷载")

参考表格工具的使用输入或修改下列数据：

钢束名称：钢束布置形状的名称。

荷载工况：钢束预应力的荷载工况名称。

张力类型：张力控制或应力控制。

张拉位置：首先张拉的位置(开始点或结束点)。

开始点-应力：按应力控制张拉时，开始点的张拉应力。

结束点-应力：按应力控制张拉时，结束点的张拉应力。

开始点-拉力：按拉力控制张拉时，开始点的张拉应力。

结束点-拉力：按拉力控制张拉时，结束点的张拉应力。

注浆：给预留管道注浆的时间(每n个施工阶段)。

荷载组：该钢束预应力荷载所属的荷载组。


17_节点动力荷载

Home > midas Gen 2017 > 07_荷载 > 06_荷载表格 > 04_时程分析 > 01_节点动力荷载

节点动力荷载

  • 功 能

以电子表格形式输入或修改节点的动力荷载数据。

MIDAS/Gen中的表格工具提供了各种强大的功能。详细说明参见以下各项：
表格工具的使用

术语

掌握使用方法

基本说明(单元移动、选择、大小控制等)

数据处理(增加、删除、修改数据)

用剪贴板复制/粘贴数据

表格功能补充

表格排序

表格格式设定

自动适应列宽

图表打印

各表格类型的补充功能

节点/单元表格

结果表格

  • 命 令

从主菜单中选择荷载 > 荷载表格 > 节点动力荷载...

从树形菜单的表格表单中选择结构表格 > 静力荷载 > 节点动力荷载

  • 输 入(参照"节点动力荷载")

参考表格工具的使用输入或修改下列数据：

节点：节点动力荷载作用的节点号。

荷载工况：节点动力荷载所属的荷载工况。

荷载类型：时程荷载函数类型(力或弯矩)。

时程函数：时程荷载函数的名称。

加载方向：时程荷载函数的加载方向。

到达时间：时程荷载的到达时间。

系数：时程加载函数的调整系数。


21_多支座激振

Home > midas Gen 2017 > 07_荷载 > 06_荷载表格 > 04_时程分析 > 02_多支座激振

多支座激振

  • 功 能

以电子表格形式输入或修改多支座激振的时程分析荷载数据。

MIDAS/Gen中的表格工具提供了各种强大的功能。详细说明参见以下各项：

表格工具的使用

术语

掌握使用方法

基本说明(单元移动、选择、大小控制等)

数据处理(增加、删除、修改数据)

用剪贴板复制/粘贴数据

表格功能补充

表格排序

表格格式设定

自动适应列宽

图表打印

各表格类型的补充功能

节点/单元表格

结果表格

  • 命 令

从主菜单中选择荷载 > 荷载表格 > 多支座激振...

从树形菜单的表格表单中选择结构表格 > 静力荷载 > 多支座激振

  • 输 入(参照"多支座激振")

参考表格工具的使用输入或修改下列数据：

节点：时程分析荷载作用的支承节点号。

荷载工况：多支座支承时程分析荷载所属的荷载工况。

函数_X：整体坐标系X方向时程荷载函数。

系数_X：函数_X的调整系数。

到达时间_X：函数_X开始作用于结构上的时间。

函数_Y：整体坐标系Y方向时程荷载函数。

系数_Y：函数_Y的调整系数。

到达时间_Y：函数_Y开始作用于结构上的时间。

函数_Z：整体坐标系Z方向时程荷载函数。

系数_Z：函数_Z的调整系数。

到达时间_Z：函数_Z开始作用于结构上的时间。

地面加速度角：水平地面加速度作用方向与整体坐标系X轴的夹角。


18_施工阶段时间荷载

Home > midas Gen 2017 > 07_荷载 > 06_荷载表格 > 05_施工阶段 > 01_施工阶段时间荷载

施工阶段时间荷载

  • 功 能

以电子表格形式输入或修改单元的材龄。

MIDAS/Gen中的表格工具提供了各种强大的功能。详细说明参见以下各项：

表格工具的使用

术语

掌握使用方法

基本说明(单元移动、选择、大小控制等)

数据处理(增加、删除、修改数据)

用剪贴板复制/粘贴数据

表格功能补充

表格排序

表格格式设定

自动适应列宽

图表打印

各表格类型的补充功能

节点/单元表格

结果表格

  • 命 令

从主菜单中选择荷载 > 荷载表格 > 施工阶段时间荷载...

从树形菜单的表格表单中选择结构表格 > 施工阶段时间荷载

  • 输 入(参照"施工阶段时间荷载")

参考表格工具的使用输入或修改下列数据：

单元：将要添加材龄的单元号。

天：单元的材龄。

组：该施工阶段时间荷载所属的荷载组。


19_施工阶段徐变系数

Home > midas Gen 2017 > 07_荷载 > 06_荷载表格 > 05_施工阶段 > 02_施工阶段徐变系数

施工阶段徐变系数

  • 功 能

以电子表格形式输入或修改徐变系数。

MIDAS/Gen中的表格工具提供了各种强大的功能。详细说明参见以下各项：

表格工具的使用

术语

掌握使用方法

基本说明(单元移动、选择、大小控制等)

数据处理(增加、删除、修改数据)

用剪贴板复制/粘贴数据

表格功能补充

表格排序

表格格式设定

自动适应列宽

图表打印

各表格类型的补充功能

节点/单元表格

结果表格

  • 命 令

从主菜单中选择荷载 > 荷载表格 > 施工阶段徐变系数...

从树形菜单的表格表单中选择结构表格 > 施工阶段徐变系数

  • 输 入(参照"施工阶段徐变系数")

参考表格工具的使用输入或修改下列数据：

单元：添加了徐变系数的单元号。仅显示在"施工阶段徐变系数"中定义的徐变系数。

徐变系数：徐变系数。

组：该徐变系数所属的荷载组。


22_单元对流边界

Home > midas Gen 2017 > 07_荷载 > 06_荷载表格 > 06_水化热 > 01_单元对流边界

单元对流边界

  • 功 能

以电子表格形式输入或修改实体单元做水化热分析时的对流边界。

MIDAS/Gen中的表格工具提供了各种强大的功能。详细说明参见以下各项：

表格工具的使用

术语

掌握使用方法

基本说明(单元移动、选择、大小控制等)

数据处理(增加、删除、修改数据)

用剪贴板复制/粘贴数据

表格功能补充

表格排序

表格格式设定

自动适应列宽

图表打印

各表格类型的补充功能

节点/单元表格

结果表格

  • 命 令

从主菜单中选择荷载 > 荷载表格 > 单元对流边界...

从树形菜单的表格表单中选择结构表格 > 水化热 > 单元对流边界

  • 输 入(参照"单元对流边界")

参考表格工具的使用输入或修改下列数据：

单元：实体单元号。

对流系数函数：定义的对流系数函数。

环境温度函数：定义的环境温度函数。

对流边界：作为对流边界的实体单元的表面号。

组：该单元对流边界所属的荷载组。


23_固定温度

Home > midas Gen 2017 > 07_荷载 > 06_荷载表格 > 06_水化热 > 02_固定温度

固定温度

  • 功 能

以电子表格形式输入和修改结构的固定温度。固定温度仅适用于节点。

MIDAS/Gen中的表格工具提供了各种强大的功能。详细说明参见以下各项：

表格工具的使用

术语

掌握使用方法

基本说明(单元移动、选择、大小控制等)

数据处理(增加、删除、修改数据)

用剪贴板复制/粘贴数据

表格功能补充

表格排序

表格格式设定

自动适应列宽

图表打印

各表格类型的补充功能

节点/单元表格

结果表格

  • 命 令

从主菜单中选择荷载 > 荷载表格 > 固定温度...

从树形菜单的表格表单中选择结构表格 > 水化热 > 固定温度

  • 输 入(参照"固定温度")

参考表格工具的使用输入或修改下列数据：

节点：实体单元的节点。

温度：固定温度。

组：该固定温度所属的荷载组。


24_分配热源

Home > midas Gen 2017 > 07_荷载 > 06_荷载表格 > 06_水化热 > 03_分配热源

分配热源

  • 功 能

以电子表格形式输入或修改热源函数。

MIDAS/Gen中的表格工具提供了各种强大的功能。详细说明参见以下各项：

表格工具的使用

术语

掌握使用方法

基本说明(单元移动、选择、大小控制等)

数据处理(增加、删除、修改数据)

用剪贴板复制/粘贴数据

表格功能补充

表格排序

表格格式设定

自动适应列宽

图表打印

各表格类型的补充功能

节点/单元表格

结果表格

  • 命 令

从主菜单中选择荷载 > 荷载表格 > 分配热源...

从树形菜单的表格表单中选择结构表格 > 水化热 > 分配热源

  • 输 入(参照"分配热源")

参考表格工具的使用输入或修改下列数据：

单元：分配了热源函数的实体单元号。

热源函数：热源函数名称。


20_几何刚度初始荷载

Home > midas Gen 2017 > 07_荷载 > 06_荷载表格 > 07_几何刚度初始荷载

几何刚度初始荷载

  • 功 能

在电子数据格式表中，输入指定单元的初始内力。

MIDAS/Gen中的表格工具提供了各种强大的功能。详细说明参见以下各项：
表格工具的使用

术语

掌握使用方法

基本说明(单元移动、选择、大小控制等)

数据处理(增加、删除、修改数据)

用剪贴板复制/粘贴数据

表格功能补充

表格排序

表格格式设定

自动适应列宽

图表打印

各表格类型的补充功能

节点/单元表格

结果表格

  • 命 令

从主菜单中选择荷载 > 荷载表格 > 几何刚度初始荷载...

从树形菜单的表格表单中选择结构表格 > 几何刚度初始荷载

  • 输 入(参照"几何刚度初始荷载")

参考表格工具的使用输入或修改下列数据：

单元：初始荷载作用的单元号。

荷载方向：初始荷载的作用方向。

轴向：单元坐标系轴向。

整体坐标系X轴：整体坐标系X轴方向的初始荷载。

整体坐标系Y轴：整体坐标系Y轴方向的初始荷载。

整体坐标系Z轴：整体坐标系Z轴方向的初始荷载。

初始荷载：初始荷载的大小。


01_吊车荷载

Home > midas Gen 2017 > 07_荷载 > 07_吊车荷载 > 吊车荷载数据 > 01_定义

定义吊车荷载数据

  • 功 能

输入吊车分析所需的数据。

  • 命 令

从主菜单中选择荷载 > 吊车荷载分析数据> 定义吊车荷载

在树形菜单的菜单表单中选择吊车荷载分析数据 > 定义吊车荷载

  • 输 入

定义吊车荷载

吊车名称

输入吊车荷载工况的名称，该名称将用于荷载组合(参见"荷载组合")。

最大轴荷载（Max P）

输入作用于牛腿柱上的最大轴荷载

最小轴荷载（Min P）

输入作用于牛腿柱上的最小轴荷载

纵向刹车荷载

输入沿柱列纵向吊车大车刹车荷载值

横向刹车荷载

输入沿跨度横向吊车小车刹车荷载值

左偏心/右偏心（ECC-H）

输入轴荷载作用点与柱节点水平偏心值

竖向偏心（ECC-V）

输入轴荷载作用点与柱节点竖向偏心值

用节点建立吊车车道

选择点取——在模型窗口中直接点取节点建立吊车车道

选择输入——直接输入节点编号建立吊车车道

宽度

输入跨度方向距离。

注：选择一个方向吊车荷载的节点之后，输入吊车荷载的宽度就可以实现自动输入吊车车道布置

吊车荷载组合

输入吊车数量，当多个吊车存在时生成自动组合。

注：吊车数量最多输入2，即在多个吊车布置区间内自动选择两个定义区间进行不利荷载组合计算。

例如：如下图所示，有两个吊车荷载组合的时候，程序在内部生成如下组合进行分析.CL1-CL2, CL1-CL3, CL1-CL4, CL2-CL3,CL2-CL4, CL3-CL4, CL1, CL2, CL3, CL4


01_环境温度函数

Home > midas Gen 2017 > 07_荷载 > 08_水化热 > 01_对流边界 > 01_环境温度函数

环境温度函数

  • 功 能

环境温度函数，又称外界介质温度函数，在土木工程中一般输入大气温度函数。

该函数将用于计算热流密度(q=hc(T-Ta)，hc:放热系数，又称对流系数；Ta:环境温度；T:混凝土温度)。

  • 命 令

从主菜单中选择荷载 > 水化热分析数据 > 环境温度函数...

在树形菜单的菜单表单中选择水化热分析数据 > 环境温度函数

  • 输 入

<图1> 定义环境温度函数对话框

：建立新的环境温度函数。

：编辑已建立的环境温度函数。

：删除已建立的环境温度函数。

：关闭对话框。

点击 [image] ，建立或添加新的环境温度函数。

函数名称：输入环境温度函数名称。

函数类型：选择环境温度的函数类型。

常量：环境温度保持不变。

正弦函数：环境温度按正弦曲线变化。

用户：用户直接定义环境温度的变化。

当选择函数类型为常量时

<图2> 添加/编辑环境温度(常量)对话框

温度：输入不变的环境温度。

当选择函数类型为正弦函数时

<图3> 添加/编辑环境温度(正弦曲线)对话框

T ：温度变化幅度。

to ：浇筑后的迟延时间(天)。

To ：平均温度。

当选择函数类型为用户定义时

<图4> 添加/编辑环境温度(用户)对话框

在左侧表格中输入时间和温度数据。注意第一个时间不能取0，当第一个时间想取0时，应输入一个比较小的数值，如0.0001。

放大系数

输入温度的增减系数，仅适用于用户定义的情况。

图形选项

决定图形的X、Y轴是否采用对数刻度。


02_对流系数函数

Home > midas Gen 2017 > 07_荷载 > 08_水化热 > 01_对流边界 > 02_对流系数函数

对流系数函数

  • 功 能

输入对流边界面的对流系数的变化函数。对流边界面是指混凝土表面、施工缝表面。

对流系数又称放热系数，用于计算热流密度(q=hc(T-Ta)，hc:放热系数，又称对流系数；Ta:环境温度；T:混凝土温度)。

  • 命 令

从主菜单中选择荷载 > 水化热分析数据 > 对流系数函数...

在树形菜单的菜单表单中选择水化热分析数据 > 对流系数函数

  • 输 入

<图1> 对流系数函数对话框

：建立新的对流系数函数。

：编辑已建立的对流系数函数。

：删除已建立的对流系数函数。

：关闭对话框。

点击 [image] ，建立或添加新的对流系数函数。

函数名称：输入对流系数函数名称。

函数类型：选择对流系数的函数类型。

常数：对流系数保持不变。

用户：用户直接定义对流系数的变化函数。

当选择函数类型为常数时

<图2> 添加/编辑对流系数函数对话框

对流系数：输入不变的对流系数。

当选择函数类型为用户定义时

<图3> 添加/编辑对流系数函数对话框

在左侧表格中输入时间和对流系数数据。注意第一个时间不能取0，当第一个时间想取0时，应输入一个比较小的数值，如0.0001。

放大系数

输入对流系数的增减系数，仅适用于用户定义的情况。

图形选项

决定图形的X、Y轴是否采用对数刻度。


03_单元对流边界

Home > midas Gen 2017 > 07_荷载 > 08_水化热 > 01_对流边界 > 03_单元对流边界

单元对流边界

  • 功 能

定义结构表面的单元对流边界。水化热分析适用于实体单元。

  • 命 令

从主菜单中选择荷载 > 水化热分析数据 > 单元对流边界...

在树形菜单的菜单表单中选择水化热分析数据 > 单元对流边界

  • 输 入

边界组名称

选择定义的对流边界将要所属的边界组。当不需要指定组时，选择"默认值"。当需要添加和编辑边界组时，可以点击右面的 [image] ，将弹出"定义边界组"对话框。

选择

添加/替换：添加或替换对流边界。

删除：删除先前输入的对流边界。

对流边界

选择对流边界上使用的对流系数函数和环境温度函数。

对流系数函数

环境温度函数

选择

选择实体单元的对流边界面。

表面号：选择表面号，适用与选择的单元的表面。

根据选择的节点：由用户选择的点组成的表面。


04_固定温度

Home > midas Gen 2017 > 07_荷载 > 08_水化热 > 02_固定温度

固定温度

  • 功 能

输入结构的固定温度条件。具有固定温度的位置，其温度不随时间发生变化。一般赋予结构与地面的接触面。

  • 命 令

从主菜单中选择荷载 > 水化热分析数据 > 固定温度...

在树形菜单的菜单表单中选择水化热分析数据 > 固定温度

  • 输 入

边界组名称

将固定温度分配给边界组。当不需要指定组时，选择"默认值"。当需要添加和编辑边界组时，可以点击右面的 [image] ，将弹出"定义边界组"对话框。

选择

添加：添加固定温度。

替换：替换固定温度。

删除：删除先前输入的固定温度。

温度

输入固定温度。


05_热源函数

Home > midas Gen 2017 > 07_荷载 > 08_水化热 > 03_分配热源 > 01_热源函数

热源函数

  • 功 能

热源函数又称热源强度函数，用来表现水化过程发热状态的函数。

  • 命 令

从主菜单中选择荷载 > 水化热分析数据 > 热源函数...

在树形菜单的菜单表单中选择水化热分析数据 > 热源函数

  • 输 入

<图1> 热源函数对话框

：建立新的热源函数。

：编辑已建立的热源函数。

：删除已建立的热源函数。

：关闭对话框。

点击 [image] ，建立或添加新的热源函数。

函数名称：热源函数名称。

函数类型：热源函数类型。

常量：热源强度(每小时、每立方米体积混凝土发热量)不变。

设计标准：按经验公式计算热源强度，一般给出绝热温升变化函数，程序内部将其转换为热源强度函数。

用户：由用户定义热源强度函数。

选择常量时

<图2> 定义热源函数（常量）对话框

热源：输入热源强度常量。

选择设计标准时

<图3> 定义热源函数（设计标准）对话框

最大绝热温升(K)

常数(a)

使用混凝土数据：输入混凝土的数据，自动计算最大绝热温升和导温系数。

水泥类型：水泥的类型

浇筑温度：浇筑混凝土时温度

单位体积水泥用量：单位体积水泥用量

选择用户定义时

用户可直接定义热源函数。可以输入热源和温度两种形式的热源函数。

<图4> 定义热源函数（设计标准）对话框

在左侧表格中输入时间和热源数据。注意第一个时间不能取0，当第一个时间想取0时，应输入一个比较小的数值，如0.0001。

放大系数

输入热源的增减系数，仅适用于用户定义的情况。

图形选项

决定图形的X、Y轴是否采用对数刻度。


06_分配热源

Home > midas Gen 2017 > 07_荷载 > 08_水化热 > 03_分配热源 > 02_分配热源

分配热源函数

  • 功 能

将定义的热源强度函数分配给单元。

  • 命 令

从主菜单中选择荷载 > 水化热分析数据 > 分配热源函数...

在树形菜单的菜单表单中选择水化热分析数据 > 分配热源函数

  • 输 入

选项

添加/替换：添加或替换对流边界。

删除：删除先前输入的对流边界。

热源

选择热源强度函数。


07_管冷

Home > midas Gen 2017 > 07_荷载 > 08_水化热 > 04_管冷

管冷

  • 功 能

为了降低混凝土的温度，在混凝土内设置冷却管。

  • 命 令

从主菜单中选择荷载 > 水化热分析数据 > 管冷...

在树形菜单的菜单表单中选择水化热分析数据 > 管冷

  • 输 入

<图1> 管冷对话框

：建立或添加管冷单元。

：编辑已经建立的管冷数据。

：删除已经建立的管冷数据。

：关闭对话框。

点击 [image] 时

名称

输入管冷单元组的名称。

冷却水

比热：水的比热。

比重：水的比重。

流入温度：水在入口处的温度。

单位时间流量：单位时间水的流量。

流入时间

输入管冷时间。

开始：开始时间。

结束：结束时间。

冷却管

直径：输入冷却管直径。

对流系数：输入对流系数。

选择

按冷却水流动的路径输入设置冷却管的节点位置。

2点：连接两点，中间节点将被自动选择，先选择的节点为流入节点。

点取：使用鼠标点击选取节点。

节点号：用户直接输入节点号，然后点击"添加"键。点击"插入"键，可插入中间节点。也可"删除"相应节点。


08_定义水化热施工阶段

Home > midas Gen 2017 > 07_荷载 > 08_水化热 > 05_定义水化热施工阶段

定义水化热分析施工阶段

  • 功 能

定义水化热分析各施工阶段的结构组、荷载组和边界组。

  • 命 令

从主菜单中选择荷载 > 水化热分析数据 > 定义水化热施工阶段...

在树形菜单的菜单表单中选择水化热分析数据 > 定义水化热分析施工阶段

  • 输 入

<图1> 定义水化热分析施工阶段对话框

定义施工阶段。

在目录中选择施工阶段，新建的施工阶段将插入到该施工阶段之前。

在目录中选择施工阶段，新建的施工阶段将插入到该施工阶段之后。

编辑或显示已定义的施工阶段。

删除已定义的施工阶段。

关闭对话框。

当需要新建施工阶段时

根据新建的施工阶段的顺序，可以选择点击 [image] 、 [image] 、 [image] ，将弹出如下对话框。

<图2> 添加水化热分析施工阶段对话框

施工阶段

名称：输入施工阶段的名称。

将显示当前施工阶段的节点号、单元号和边界组。

<图3> 当前施工阶段信息对话框

步骤

时间(小时)
输入该施工阶段各步骤的时间。也可以在"自动生成"中输入。当重复输入时间时，重复时间将被覆盖。输入的时间均为连续累积时间。

自动生成
可以同时生成多个步骤，各步骤的时间为累计时间，各步骤间隔的是按均等对数间隔划分的。

时间：要划分的时间。

步骤数：要划分的步骤数。

将按时间(小时)输入的时间添加到步骤目录中。

在步骤列表中选择相应步骤，做相应修改。

在步骤列表中选择相应步骤后将其删除。

清除步骤列表中的所有步骤。

单元表单

定义在该施工阶段中使用的结构组。

组列表

目录中将显示已经定义的结构组列表。当需要新建或添加结构组时，点击右侧的 [image] ，将弹出"定义结构组"对话框。

激活

在组列表中选择将要激活的组后，点击 [image] ，将其添加激活的组列表中。也可在激活的组列表中选择相应的组后，点击 [image] 将其删除。

边界表单

定义在该施工阶段中使用的边界组。

组列表

目录中将显示已经定义的边界组列表。当需要新建或添加边界组时，点击右侧的 [image] ，将弹出"定义边界组"对话框。

激活

在组列表中选择将要激活的组后，点击 [image] ，将其添加激活的组列表中。也可在激活的组列表中选择相应的组后，点击 [image] 将其删除。

钝化

在组列表中选择将要钝化的组后，点击 [image] ，将其添加激活的组列表中。也可在钝化的组列表中选择相应的组后，点击 [image] 将其删除。

注
边界组的激活和钝化均发生在该施工阶段的开始时间；

水化热施工阶段分析中考虑的静力荷载工况的荷载类型必须是施工阶段荷载。

边界表单

通过激活或钝化荷载组，用户可以为相应的施工阶段指定静荷载。

组列表
目录中将显示所有已定义的荷载组列表。当需要新建或添加荷载组时，点击右侧的 [image] ，将弹出"定义边界组"对话框。

激活
在荷载组列表里选择相应的荷载组，点击 [image] ，将其激活。点击 [image] ，将选中的荷载组从激活的组列表中删除

激活时间
输入在相应的施工阶段中荷载组激活的时间

钝化
在组列表中选择相应的荷载组组后，点击 [image] ，将其钝化。点击 [image] ，将选中的荷载组从钝化的组列表中删除

钝化时间
输入在相应的施工阶段中荷载组钝化的时间


09_选择显示施工阶段

Home > midas Gen 2017 > 07_荷载 > 08_水化热 > 06_显示阶段

选择显示施工阶段

  • 功 能

选择相应施工阶段，将其显示在画面上。

  • 命 令

从主菜单中选择荷载 > 水化热分析数据 > 选择显示施工阶段...。

在树形菜单的菜单表单中选择水化热分析数据 > 选择显示的施工阶段。

也可以在施工阶段工具条选择相应施工阶段。

  • 输 入

<图1> 选择显示施工阶段对话框

选择相应施工阶段后点击 [image] 或 [image] 。


01_主控数据

Home > midas Gen 2017 > 08_分析 > 01_主控 > 01_主控数据

主控数据

  • 功 能

输入单元的自由度约束条件和非线性单元的分析条件。

  • 命 令

从主菜单中选择分析 > 主控数据...

  • 输 入

主控数据对话框

约束桁架/平面应力/实体单元的旋转自由度

使用无旋转自由度的单元时，自动约束其转动自由度。默认为选择。

约束板的旋转自由度

约束板单元绕垂直于板平面轴向的旋转自由度。默认为选择。

仅受拉/仅受压单元(弹性连接)

输入与非线性单元或非线性连接迭代分析相关的数据。

迭代次数（荷载工况）：输入最大迭代次数。

收敛误差：输入收敛公差。

在应力计算中考虑截面刚度调整系数

在应力计算时考虑在截面特性调整系数中调整后的截面特性值。默认为不勾选。

转换从属节点反力为主节点反力

转换从属节点反力为主节点反力。默认为选择。


02_P-Delta分析控制

Home > midas Gen 2017 > 08_分析 > 02_分析控制 > 01_P-Delta

P-Delta分析控制

  • 功 能

输入结构进行P-Delta效应分析时的荷载工况和收敛控制条件。

P-delta分析对话框中选择的荷载构成的几何刚度适用于所有的荷载工况。

  • 命 令

从主菜单中选择分析 > P-Delta分析控制...

  • 输 入

控制参数

迭代次数

输入P-Delta分析时的迭代次数。

收敛误差

输入收敛公差。

P-Delta分析荷载组合

选择P-Delta效应分析时用于构成几何刚度的荷载(组合)。输入荷载工况及相应的组合系数。

一般选择作用在结构上的恒载(自重、恒载等)。

输入新的或另外的荷载工况

输入荷载工况及系数，然后单击 [image] 。

修改先前输入的荷载工况的系数

选择荷载工况，修改系数并单击 [image] 。

删除先前输入的荷载工况

在对话框底部的荷载工况列表中选择要删除的荷载工况并单击 [image] 。

P-Delta分析和屈曲分析不能同时使用。P-Delta效应分析仅限于桁架单元、梁单元(包括变截面梁单元)和墙单元。

要删除所有输入的数据，单击 [image] 。点击此键时，程序将不做P-delta分析。


03_屈曲分析控制

Home > midas Gen 2017 > 08_分析 > 02_分析控制 > 02_屈曲

屈曲分析控制

  • 功 能

输入结构屈曲分析的荷载工况及相关数据。屈曲分析采用子空间迭代法。

MIDAS/Gen做屈曲分析的步骤如下:

  1. 结构做屈曲分析时需要构成几何刚度。为了构成几何刚度，需要静力分析的内力结果。所以，应该建立屈曲分析所需的荷载工况。

  2. 在分析>屈曲分析控制中输入屈曲模态的数量和分析的收敛条件。

  3. 运行分析>运行分析或点击图标菜单 [image] 运行分析。

  4. 结构分析结束之后，可以在结果>屈曲模态或结果>分析结果表格>屈曲模态中查看各模态和临界荷载系数。

  5. 输入自重（不变）和附加荷载（可变）后进行屈曲分析。分析结果输出的特征值就是屈曲荷载系数，屈曲荷载系数乘以附加荷载（可变）加上自重等于屈曲荷载值。

  6. 做考虑几何非线性的屈曲分析可使用非线性分析功能中的位移控制法。

  • 命 令

从主菜单中选择分析 > 屈曲分析控制...

  • 输 入

屈曲模态

模态数：输入需要计算的屈曲模态数量。

仅考虑正值：只输出荷载方向的特征值。

搜索：只输出此处定义范围内的特征值。

从：最小屈服荷载系数。

到：最大屈服荷载系数。

检查斯图姆序列：勾选该项可检查任何丢失的屈服荷载系数，若存在，会在信息窗口给出报错提示。

框架几何刚度选项

仅考虑轴力：形成框架几何刚度矩阵时，仅考虑轴力。

屈曲分析荷载组合

输入屈曲分析时的荷载工况(组合)和组合系数。

荷载类型

可变：考虑增减的荷载（活载等）。

不变：不考虑增减的荷载（自重、恒载等）。

输入新的或另外的荷载工况

输入新的或另外的荷载工况和组合系数并单击 [image] 。

修改先前输入的荷载工况和系数。

选择荷载工况，修改组合系数并单击 [image] 。

删除先前输入的荷载工况

在对话框底部荷载工况列表中选择要删除的荷载工况并单击 [image] 。

屈曲分析不能与P-Delta分析或特征值分析同时进行。屈曲分析仅限于桁架单元、梁单元(包括变截面梁单元)和板单元。

要删除所有输入的数据，单击 [image] 。点击此键时，程序将不做屈曲分析。


04_特征值分析控制

Home > midas Gen 2017 > 08_分析 > 02_分析控制 > 03_特征值

特征值分析控制

  • 功 能

输入特征值分析的控制数据。

MIDAS/Gen做特征值分析的步骤如下：

  1. 在模型>结构类型中将结构自重转换成质量，在模型>质量菜单中将其他荷载转换为质量数据，也可直接输入节点质量建立模型的质量矩阵。

  2. 在分析>特征值分析控制中输入特征值数量和各种分析控制数据。

  3. 运行分析>运行分析或点击图标菜单 [image] 运行分析。

  4. 结构分析结束之后，可以在结果>周期与振型或结果>分析结果表格>周期与振型中查看各振型形状和特征值(自振周期和自振频率)。

注
在模型>质量>将荷载转换成质量中可以将输入的外部荷载转换为质量数据。该功能可以用来计算地震作用时的重力荷载代表值。

  • 命 令

从主菜单中选择分析 > 特征值分析控制...

  • 输 入

分析类型

选择特征值分析的方法。可供选择的方法有特征值向量的子空间迭代法和Lanczos法，以及多重Rith向量法(MR法)。

当选择了子空间迭代法时

<图1> 特征值分析控制(子空间迭代法)对话框

振型数量

输入要计算的特征值(自振周期)的数量，当输入的数量多于结构固有周期的数量时，程序自动按最大固有周期数量运行分析。

频率范围

设定要计算的结构自振频率的最小值和最大值。

下限：频率范围的最小值。

上限：频率范围的最大值。

如果求得的自振频率超出设定的频率上限时，不再计算另外的频率。在随后的分析中，只使用小于频率上限的值。程序内定的频率范围为0～1600Hz。

该项为不可更改项。

特征值控制参数

迭代次数：最大迭代次数。

子空间大小：默认值为"0"，表示由程序自动划分子空间。

收敛误差：迭代计算时的收敛条件。

使用子空间迭代方法进行特征值分析时，当求得的相对频率 [image] 小于收敛误差时，迭代将终止。

如果经过最大迭代次数的计算后，相对自振频率仍不在收敛公差范围内时，不再计算另外的频率。用先前求得的自振频率进行其后的分析。

特征值分析和屈曲分析不能同时进行。

在做动力分析(如时程分析或反应谱分析)时，必须先进行特征值分析。

反应谱分析中将使用特征值分析中得到的特征周期。因此在输入反应谱数据时，必须包括结构自振周期的预计范围。

要删除所有输入的数据，单击 [image] 。

当选择了Lanczos时

<图2> 特征值分析控制(Lanczos)对话框

Strum序列检测

勾选可检测可能丢失的特征值，一般用于希望获得所有低阶振型的情况。

其他参数可参照子空间迭代法的输入。

当选择了多重Ritz向量法时

<图3> 特征值分析控制(多重Ritz向量法)对话框

初始荷载向量(Ritz向量)

为了计算Ritz向量，需要输入初始荷载向量。选择荷载工况生成初始荷载向量，程序将首先按初始荷载向量的方向和大小计算特征值。Ritz向量法具有计算收敛快，计算结果比较准确的特点。

当使用了一般连接单元时，可以考虑沿着一般连接单元变形方向作用的荷载向量。

荷载工况：可供选择的初始荷载工况包括静力荷载和地面加速度荷载。

初始向量数量：各初始荷载工况包含的初始向量数量。

：将选择的荷载工况和向量数量添加到目录列表中。

：在目录列表中选择相应荷载工况，修改荷载工况和初始向量数量。

：在目录列表中选择相应荷载工况，删除该荷载工况。

当选择了"考虑一般连接的荷载向量"时

一般连接的初始荷载工况数量：

当模型中有一般连接单元时，该项自动选择为一般连接的单元数量。如果没有一般连接单元，则该项为"0"。该项为不可更改项。

各一般连接的初始向量数量：

各一般连接的初始荷载工况包含的初始向量数量。如果没有一般连接单元，该项的数值将不发生作用。

初始荷载工况总数：等于初始荷载工况数量+一般连接的初始荷载工况数量。

Ritz向量总数：等于所有初始向量总数(包括一般连接的初始荷载向量)。

要删除所有输入的数据，单击 [image] 。点击此键时，程序将不做特征值分析。


05_水化热分析控制

Home > midas Gen 2017 > 08_分析 > 02_分析控制 > 04_水化热

水化热分析控制

  • 功 能

输入水化热分析控制数据。

在MIDAS中做水化热分析的步骤如下：

  1. 在模型 > 材料和截面特性 > 时间依存性材料(徐变/温度收缩)和模型 > 材料和截面特性 > 时间依存性材料(抗压强度)中输入材料的时间依存特性值，然后在模型 > 材料和截面特性 > 时间依存性材料连接中将时间依存材料特性与定义的一般材料连接起来。

  2. 在荷载 > 水化热分析数据中输入水化热分析必要的数据(环境温度函数、对流系数函数、定义及分配热源、定义对流边界和施工阶段)。

  3. 在分析 > 水化热分析控制中输入积分系数和初始温度，并决定应力输出位置以及是否考虑徐变和收缩。

  4. 点击分析> 运行分析或点击图标菜单 [image] 运行分析。

  5. 结构分析结束之后，可以利用结果中的各种后处理功能查看分析结果。

  • 命 令

从主菜单中选择分析 > 水化热分析控制...

  • 输 入

水化热分析控制对话框

最终施工阶段

决定哪个施工阶段为最终施工阶段。只有在最终施工阶段，才能与其他荷载工况(如地震、风荷载等)进行组合。

最后施工阶段

定义的施工阶段中，排在最后的施工阶段。

其它阶段

在已经定义的施工阶段中选择某个施工阶段作为最终施工阶段。

积分系数(时间离散系数)

输入热传导分析所需的时间离散系数(Temporal discretization Factor, [image] )。

= 0 ： 前向差分。

= 1/2 ： Crank-Nicolson法。

= 2/3 ： Galerkin法。

= 1 ： 后向差分。

初始温度

输入热传导分析所需的结构初始温度。整个结构为发生水化反应之前的温度状态。最终的结构温度等于水化热导致的温度上升和初始温度之和。在定义水化热施工阶段定义的初始温度优先于在此定义的初始温度。如果没有在定义水化热施工阶段里输入初始温度，则使用在此输入的初始温度进行计算。

单元应力输出位置

选择单元应力输出位置。

单元中心：将单元中心的应力作为单元应力输出。

高斯点：将高斯点应力作为节点应力输出。

节点：将高斯点应力转换为节点应力。

徐变和收缩

决定是否考虑徐变和收缩。

类型

选择分析时要考虑的类型。

徐变计算方法

徐变的计算方法有一般方法和有效系数法两种方法。选择一般时，按时间依存材料（徐变/收缩）里定义的曲线来计算。有效系数法为修正弹性模量来考虑徐变的一种近似计算方法。

选择一般时：

收敛条件

进行考虑徐变的分析时，输入结束迭代计算的收敛条件。

迭代次数 : 最大迭代次数

收敛误差 : 收敛误差

选择有效系数时：

0天至n1天的弹性模量折减系数为ph1，n2天以后的弹性模量折减系数为phi2。n1至n2之间的折减系数线性内插计算。

注

有效系数法定义的徐变数据，在打开新文件时被自动删除，所以重新打开模型时要重新定义。

使用等效材龄和温度

进行水化热分析时，选择是否使用等效材龄和温度。

考虑自重

考虑自重时选择此项。重力方向的自重输入"－1"。

要删除所有输入的数据，单击 [image] 。点击此键时，程序将不做水化热分析。


06_非线性分析控制

Home > midas Gen 2017 > 08_分析 > 02_分析控制 > 05_非线性

非线性分析控制

  • 功 能

选择非线性分析计算方法和收敛控制条件。

在MIDAS程序中，做静力分析、施工阶段分析和时程分析时，均可以考虑大位移。

在MIDAS/Gen中做非线性分析的步骤如下：

  1. 在荷载 > 非线性分析数据 > 非线性分析加载顺序中输入荷载的加载顺序,也可以不输入该项。

  2. 在分析 > 非线性分析控制中选择计算方法和收敛控制条件。

  3. 运行分析>运行分析或点击图标菜单 [image] 运行分析 。

  4. 结构分析结束之后，可以利用结果中的各种后处理功能查看分析结果。

  • 命 令

从主菜单中选择分析 > 非线性分析控制...

  • 输 入

非线性类型

选择非线性分析类型。

几何非线性：几何大位移非线性分析。

材料非线性：材料塑性静力分析。

注1

如下情况不能运行几何非线性分析或材料非线性分析。

但，释放梁端部约束和释放板端部约束在下述情况不能运行材料非线性分析。

1. 使用荷载>非线性分析数据>非线性分析加载顺序功能的情况。

2. 使用分析>施工阶段分析控制对话框中考虑非线性分析>累计步骤的分析选项时。

注2

板单元的静力非线性分析中可同时考虑几何非线性和材料非线性，但平面应变单元或实体单元的情况不能同时考虑几何非线性和材料非线性。

计算方法

选择非线性分析的计算方法。

当选择Newton-Raphson法时

<图1> 非线性分析控制(Newton-Raphson法)对话框

加载步骤数量：将荷载逐步加载。

子步骤内迭代次数：每个加载步骤内的反复计算次数。

当选择弧长法时

<图2> 非线性分析控制(弧长法)对话框

加载步骤数量:将荷载逐步加载。

子步骤内迭代次数:每个加载步骤内的反复计算次数。

初始荷载比单位弧长(%):单位弧长的初始荷载比。

最大控制位移：当某节点的位移超过最大控制位移时，程序停止运算。

当选择位移控制法时

<图3> 非线性分析控制(位移控制法)对话框

位移步骤数量:指定将总位移分解为子步的数量，程序将逐步加载位移。

子步骤内迭代次数:每个位移子步内的最大反复计算次数。

主节点:位移控制的参考点。

方向：位移控制的方向。

最大控制位移：当某节点的位移超过最大控制位移时，程序停止运算。

收敛条件

选择收敛的控制条件。

能量控制

输入能量(力*位移)标准的收敛控制误差。

位移控制

输入位移标准的收敛控制误差。

荷载控制

输入荷载标准的收敛控制误差。

注
为了能反映各自由度方向的收敛，一般使用下面的收敛控制方法。以位移控制为例，当某分析阶段的位移为[D1]，所有阶段的累积位移为[D2]时，计算 [image] ，当该值小于或等于收敛控制误差时，表示在该阶段收敛。

非线性分析荷载工况

上述定义的计算方法将独立的应用于每个荷载工况。如果所有的荷载工况都采用一种计算方法，则不需要定义此对话框。

当点击 [image] 时，出现如下对话框：

<图4> 添加/编辑非线性分析荷载工况对话框

Newton-Raphson/弧长法/位移控制法控制数据

由计算方法确定。

步骤：荷载步骤的编号。

子步骤系数或主节点位移：每一子步骤的荷载系数或主节点位移。

子步骤系数或主节点位移可以用户定义，也可以点击 [image] 或 [image] 自动生成。

要删除所有输入的数据，单击 [image] 。点击此键时，程序将不做非线性分析。


07_施工阶段分析控制

Home > midas Gen 2017 > 08_分析 > 02_分析控制 > 06_施工阶段

施工阶段分析控制

  • 功 能

输入施工阶段分析的各种控制数据。

MIDAS/Gen中施工阶段分析可以考虑的事项如下:

  • 时间依存材料特性

  1. 材龄不同的混凝土构件的徐变。

  2. 材龄不同的混凝土构件的收缩应变。

  3. 混凝土抗压强度随时间的变化。

  4. 钢束预应力的各种损失。

  • 施工阶段的定义

  1. 结构模型的变化(结构组的激活和钝化)。

  2. 荷载条件的变化(荷载组的激活和钝化)。

  3. 边界条件的变化(边界组的激活和钝化)。

在MIDAS/Gen中做考虑材料时间依存特性的施工阶段分析的步骤如下:

  1. 建立结构整体模型(包括材料、截面、荷载、边界)。

  2. 在模型 > 材料和截面特性 > 时间依存性材料(徐变/收缩)和模型 > 材料和截面特性 > 时间依存 性 材料(抗压强度)中输入材料的时间依存特性值，然后在模型 > 材料和截面特性 > 时间依存 性 材料的连接中将时间依存材料特性与定义的一般材料连接起来。

  3. 定义各施工阶段的结构组、荷载组、边界组。

  4. 按实际施工顺序和工定义施工阶段(利用定义的结构组、荷载组、边界组)。

  5. 在分析 > 施工阶段分析控制中选择施工阶段分析中要考虑的时间依存特性，并输入计算徐变所需的迭代次数以及其他的一些选项。

  6. 点击分析>运行分析或点击图标菜单 [image] 运行分析。

  7. 结构分析结束之后，可以利用结果中的各种后处理功能查看分析结果。

  • 命 令

从主菜单中选择分析 > 施工阶段分析控制...。

  • 输 入

施工阶段分析控制对话框

最终施工阶段

决定哪个施工阶段为最终施工阶段。只有在最终施工阶段，才能与其他荷载工况(如地震、风荷载等)进行组合。

最后施工阶段

定义的施工阶段中，排在最后的施工阶段。

其它施工阶段

在已经定义的施工阶段中选择某施工阶段。

分析选项

考虑非线性分析

独立步骤：在各个施工阶段形成独立模型来进行分析。独立模型的几何非线性分析和考虑时间依存特性的分析不能同时进行。此时，除了非线性分析控制选项之外的其它选项不能设定。

累计步骤：累加各个施工阶段的结果来进行非线性分析。进行累加模型的几何非线性分析时，可以考虑时间依存特性的效果和索初拉力类型。

考虑时间依存效果(累加模型)

考虑材料的徐变和收缩、抗压强度的变化。

当选择了"考虑时间依存效果"时

徐变和收缩
考虑徐变和收缩中的任何一项时，选择此项。

类型
选择是要只考虑徐变(或收缩)，还是同时考虑徐变和收缩。

当选择"徐变"时

徐变分析时的收敛控制

迭代次数：最大反复计算次数。达到最大迭代次数时，程序停止运算。

收敛误差：满足收敛误差时，程序停止运算。

使用用户定义的徐变系数
使用用户在施工阶段徐变系数中定义的徐变系数。

徐变分析加载时间步骤数
该加载步骤与施工阶段的步骤数无关，仅是将徐变系数曲线划分为一些步骤。

注
该步骤数仅用于内部徐变计算上，程序不提供各步骤分析结果的输出。

自动分割时间
当某施工阶段的持续时间过长时，程序自动将其划分为一些施工步骤。

钢束预应力损失(徐变和收缩)
决定是否考虑徐变、收缩引起的钢束预应力损失，摩擦损失、锚固端和钢筋内缩损失、预应力钢筋松弛损失是在"钢束特性值"内决定。

抗压强度的变化
通过抗压强度的变化曲线，可以得到弹性模量的变化。抗压强度的变化可以在"时间依存材料(抗压强度)"中定义。

钢束预应力损失(弹性收缩)
决定是否考虑因混凝土弹性收缩引起的钢束预应力损失。

当选择了"考虑非线性分析"时

当选择了在施工阶段分析中考虑非线性分析时，应输入下列数据。

各加载阶段最大迭代次数
最大反复计算次数。达到最大迭代次数时，程序停止运算。

收敛条件

选择收敛的控制条件。

能量控制

输入能量(力*位移)标准的收敛控制误差。

位移控制

输入位移标准的收敛控制误差。

荷载控制

输入荷载标准的收敛控制误差。

注
为了能反映各自由度方向的收敛，一般使用下面的收敛控制方法。以位移控制为例，当某分析阶段的位移为{D1}，所有阶段的累积位移为{D2}时，计算 [image] ，当该值小于或等于收敛控制误差时，表示在该阶段收敛。

索初拉力控制

体内力

将索的初拉力视为内力。因为索的内力大小与索两端连接构件的刚度有关，所以由于变形，索的内力将发生变化。

体外力

将索的初拉力视为外力。索的外力被视为作用在与索两端连接的构件上。因此索的初拉力大小不发生变化。

添加：将初拉力添加到索上。

替换：以新加到索上的初拉力替换原来的初拉力。

注1

索与钢束为不同的构件。

注2

在预应力荷载中给索单元加初拉力后做施工阶段分析时，如果选体内力程序中将以一定的变形量的方式加载到单元中，犹如给单元加一温度荷载一样。索内最终张力与索两端的锚固条件有关。当索两端完全锚固时，索内张力为所加初拉力；当索两端完全自由时，索内张力为零(可以类比加温度荷载时的自由伸缩)。

在预应力荷载中给索单元加初拉力后做施工阶段分析时，如果选体外力程序中将做为荷载加载在索两端。当该阶段只有该索力作用时，索的张力不变；当该阶段有其他荷载作用或下一阶段有其他荷载作用时，索力会有相应变化。

斜拉桥的施工阶段分析，一般选体外力。悬索桥的分析与悬索桥的类型(自锚式、地锚式)以及施工工序有很大关系，用户应根据工序和经验选择相关选项。

联合截面

输出各位置的分析结果:

选择是否计算输出联合截面各组成截面的应力和内力。不选时，则只计算输出整个联合截面的应力和内力。

从施工阶段分析结果的恒荷载中分离出荷载工况（施工荷载）

一般在施工阶段分析中，恒荷载是所有荷载中最主要的部分。除了徐变、收缩和预应力松弛，所有的荷载工况结果都累加到CS：恒荷载中。在此，可以选择特定的荷载工况从恒荷载中分离出来，相应的结果保存在CS：活荷载中。

荷载工况:

选择从恒荷载中分离出来的荷载工况。

要删除所有输入的数据，单击 [image] 。点击此键时，程序将不做施工阶段分析。


08_分配边界转换给荷载工况/分析

Home > midas Gen 2017 > 08_分析 > 02_分析控制 > 07_分配边界换工况

分配边界转换给荷载工况/分析

  • 功 能

在一个模型里，不同的荷载工况条件采用不同的边界条件。

不同荷载工况可输入不同边界条件，所以不同边界条件的静力分析和动力分析，也可在一个模型里面进行分析。

  • 命 令

从主菜单中选择分析 > 分配边界转换给荷载工况/分析...

  • 输 入

分配边界转换给荷载工况/分析 对话框

数据选择：

显示随荷载工况能够变化的边界条件的类型。

边界组组合

边界组列表：只显示左侧数据选择里面勾选的边界类型对应的边界组。如果不选择下面的过滤边界组选项，则显示所有边界组名称。

名称：定义边界组组合名称。在左侧的边界组里面选好边界组，然后点击 [image] 按钮，被选边界组生成一个边界组组合。按此方法生成几个边界组组合以后，分配给相应的荷载工况，进行不同荷载工况不同边界条件的分析。

荷载工况 & 分析：显示静力荷载工况和分析类型。点击 [image] 按钮，展开表格显示用户定义的静力荷载工况名称。

边界组组合：选择要使用在左侧荷载工况或分析类型上的边界组组合名称。进行施工阶段分析时，选择?没有修改?，则使用最终施工阶段的边界条件。

不约束与强制位移相关的自由度/边界组组合沉降：进行强制位移或支座沉降分析时，约束相应节点的自由度进行内部支点处理，然后赋予强制位移。如果选择此项，内部约束自由度只包含在强制位移/支座沉降相应的边界组组合里。不选择此项，所有荷载工况都包含内部约束自由度。

：删除分配边界转换给荷载工况/分析数据。


08_板分析控制

Home > midas Gen 2017 > 08_分析 > 02_分析控制 > 08_板分析控制

板分析控制

  • 功 能

设置模型中板单元的分析方法。

  • 命 令

从主菜单中选择 分析 > 分析控制 > 板分析控制

  • 输 入

板分析控制 对话框

板的分析方法可选择“有效梁宽法”或者“有限元法”两种。

“有限元法”是板的通用的分析方法，“有效梁宽法”有别于“有限元法”，其相关介绍如下：

1. 有效梁宽法也是一种有限元分析方法，但假定横向荷载全部由有效梁（一般布置在柱上）的区域的板来承担；

2. 由于传统的设计工程经验，均认为板结构由等代的框架承担荷载，而完全忽略跨中部分板对水平荷载承担的贡献，这是一种普遍被认可的分配模式。

对于无梁楼盖体系，竖向荷载均按照有限元法（FEM）进行分析，其荷载由板承担。

注：当选择“有效梁宽法（EBWM）”时，仅横向荷载按照该方法进行分析，且其荷载由有效梁承担。


10_运行分析

Home > midas Gen 2017 > 08_分析 > 03_运行 > 01_运行分析

运行分析

  • 功 能

运行结构分析。

  • 命 令

从主菜单中选择分析 > 运行分析...

在图标菜单中单击 [image] 运行分析

快捷键： F5


09_分析选项

Home > midas Gen 2017 > 08_分析 > 03_运行 > 02_分析选项

分析选项

  • 功 能

指定静力分析方法和分析时使用的内存大小。

  • 命 令

从主菜单中选择分析 > 分析选项...

  • 输 入

分析选项图

分析求解器

选择要执行的静力分析方法。选择适当的分析方法会提高分析的效率。

Skyline

结构分析程序中普遍采用的求解器。该求解器可以使用于任何分析方法、任何大小的模型，并与系统设置无关。

Multi Frontal Sparse Gaussian

是一种高性能的求解器(MFSG)，适用于大型模型及使用了板单元或实体单元的模型中。

多处理器

在Multi Frontal Sparse Gaussian solver时，选择一个以上的处理器可以提高分析的速度。如2个处理器时，分析时间可减少30～40％。

分析所需内存

仅利用系统内存的一部分进行分析时，才需输入该项。

选择自动，则程序将确定计算机的内存状态后使用恰当的内存进行分析。


11_批处理

Home > midas Gen 2017 > 08_分析 > 03_运行 > 03_批量分析

批处理

  • 功 能

对几个结构模型连续执行结构分析。

  • 命 令

从主菜单中选择分析 > 批处理...

  • 输 入

批处理对话框

文件名称：分析模型的名称。

路径：分析模型文件所在的路径。

：添加分析模型。

：从先前输入的批量分析列表中删除分析模型。

：清除先前输入的批量分析列表。

：执行批量分析。

：中断批量分析。


12_导入分析结果

Home > midas Gen 2017 > 08_分析 > 03_运行 > 04_导入分析结果

导入分析结果

  • 功 能

其它结构分析程序的分析结果可以用此功能导入MIDAS/Gen后,用MIDAS/Gen的后处理功能进行校核。

1.把准备好的MGT格式的模型数据文件从文件>导入>MIDAS/GenMGT文件。

2.点击 [image] 保存为'fn.mgb'。

3.然后把准备好的以'fn.sar'保存的分析结果文件导入.这时候文件的扩展名不必一定是'sar'.只要格式是相同的,文本文件也能导入。

  • 命 令

主菜单选择>分析>导入分析结果

  • 输 入

对话框

怎样生成fn.sar文件

1.* : 命令

2. ** : 描述

3. UNITSYS,定义单位,这个命令应该放在所有命令的最前面

4. ENDDATA,这个命令应该放在所有命令的最后面

5. 其它命令可以随便放置和位置无关

6.这些命令及输入的数据应该用(,)或分割线分开

7.单元的内力结果数据应该按单元坐标系输入

8.平面应变单元和轴对称单元不能和其它类型单元同时输入


01_荷载组合

Home > midas Gen 2017 > 09_结果 > 01_荷载组合

荷载组合

  • 功 能

输入荷载组合。既可以由用户输入荷载组合，也可以选择相应规范，自动生成荷载组合。

MIDAS/Gen支持下列四个荷载组合输入表单。

    • 一般：所有的荷载组合。也可以根据结构形式在"钢结构设计"、"混凝土设计"、"SRC设计"中分别输入荷载组合。

    • 钢结构设计：根据钢结构设计规范输入荷载组合。midas Gen 中提供的中国钢结构设计规范为：钢结构设计规范（GB50017-03）

    • 混凝土设计：根据混凝土结构设计规范输入荷载组合。midas Gen中提供的中国混凝土结构设计规范为《混凝土结构设计规范》(GB50010-2010)。

    • SRC设计：根据钢-砼组合结构(SRC)设计规范输入荷载组合。midas Gen中提供的中国SRC结构设计规范为"型钢混凝土组合结构技术规程"(JGJ 138-2001)，钢管混凝土结构设计与施工规程(CECS28:90)。

  • 命 令

从主菜单中选择结果 > 荷载组合

从树形菜单中选择分析结果 > 荷载组合

快捷键： [Ctrl]+[F9]

  • 用 法

<图1> 荷载组合对话框

参考表格工具的使用，建立荷载组合。

一般荷载组合与设计荷载组合的主要区别是：一般荷载组合中有包络组合，设计荷载组合中无包络组合；一般荷载组合主要用于查看计算分析的结果,设计荷载组合主要用于构件的设计。

几个符合的解释：

gLCB：一般荷载组合。

sLCB：钢结构设计荷载组合。

cLCB：混凝土设计荷载组合。

rLCB：SRC设计荷载组合。

ST:静力工况。

CS:施工阶段荷载工况。

当定义了某一地震作用工况EX后，分析是考虑了偶然偏心，分析后荷载组合中有EX(RS)和EX(ES)，括号中的RS及ES分别表示：

（RS）：无偏心地震作用工况。

（ES）：偶然偏心地震作用工况。

注：看层间位移及层间位移角时，应该选择无偏心地震作用工况，即EX(RS)。看层间位移比，即最大层间位移与平均层间位移比时，应该选择偶然偏心与无偏心地震作用工况组合的结果，即EX(RS)±EX(ES)。

输入新的或添加其他荷载组合

用以下4 种方法输入荷载组合：

1. 用户直接输入荷载组合

号： 按荷载组合的输入次序自动编号。

名称：输入荷载组合的名称。

激活：决定在后处理模式中是否使用该荷载组合。

激活: 在后处理模式中可以查看该荷载组合的结果。仅适用于"一般"表单中。

钝化: 在后处理模式中不能查看该荷载组合的结果。

类型：指定分析结果的组合类型

相加：各荷载工况的分析结果的线性相加。

L1 + L2 + ... + M1 + M2 + ... + S1 + S2 + ...+ (R1 + R2 + ...) + T + LCB1 + LCB2 + ... + ENV1 + ENV2 + ...

包络：各荷载工况的分析结果中的最大值、最小值以及绝对值的最大值结果。

ENV_STR为承载力极限状态的包络，ENV_SER为正常使用极限状态的包络。

CBmax : Max(L1, L2, ..., M1, M2, ..., S1, S2, ...,R1, R2, ..., T, LCB1, LCB2, ..., ENV1, ENV2, ...)

CBmin: Min(L1, L2, ..., M1, M2, ..., S1, S2, ...,R1, R2, ..., T, LCB1, LCB2, ..., ENV1, ENV2, ...)

CBall: Max(|L1|, |L2|, ..., |M1|, |M2|, ..., |S1|, |S2|, ..., |R1|, |R2|, ..., |T|, |LCB1|, |LCB2|, ..., |ENV1|, |ENV2|, ...)

ABS：反应谱分析中各方向地震荷载工况分析结果的绝对值之和与其他荷载工况分析结果线性相加。

L1+ L2 + ... + M1 + M2 + ... + S1 + S2 + ...+ (|R1| + |R2| + ...) + T + LCB1 + LCB2 + ... + ENV1 + ENV2 + ...

SRSS：反应谱分析中各方向地震荷载工况分析结果的平方和的1/2次方值与其他荷载工况分析结果线性相加。

L1 + L2 + ... + M1 + M2 + ... + S1 + S2 +...+(R12 + R22 +...)1/2 + T + LCB1 + LCB2 + ... + ENV1 + ENV2 + ...

其中，

L：各荷载工况的分析结果(已经乘以荷载安全系数的结果)。

M：移动荷载工况的分析结果(已经乘以荷载安全系数的结果)。

S：支座沉降荷载工况的分析结果(已经乘以荷载安全系数的结果)。

R：反应谱荷载工况的动力分析结果(已经乘以荷载安全系数的结果)。

T：时程分析工况的动力分析结果(已经乘以荷载安全系数的结果)。

LCB：将荷载组合转换为荷载工况后的分析结果(已经乘以荷载安全系数的结果)。

ENV：将按包络类型组合的荷载组合转换为荷载工况后的分析结果(已经乘以荷载安全系数的结果)。

描述：对荷载组合的简要描述。

按需要输入荷载工况及荷载安全系数(荷载分项系数)。

荷载工况：从荷载工况列表中选择荷载工况。

系数：输入相应荷载工况的荷载安全系数(荷载分项系数)。

注:当分析建筑结构时，根据"建筑结构荷载规范"，活荷载的组合具有荷载分项系数、组合值系数、频遇值系数、准永久值系数。目前按规范自动生成的荷载组合只能考虑荷载分项系数，用户应根据需要将"荷载分项系数"乘以其他系数进行相应调整。

2. 选择内置的设计标准自动生成荷载组合

在荷载组合对话框底部单击 [image] 。将显示如下对话框。

<图2> 自动生成荷载组合对话框

在显示的荷载组合自动生成对话框中选择下列各项:

选择

添加：在先前已定义的荷载组合中添加新的荷载组合。

替换：用生成的荷载组合替换先前已定义的荷载组合

添加包络：自动生成荷载组合包络，仅适用于"一般"的组合情况。

选择规范

钢结构:钢结构设计规范。

混凝土：混凝土结构设计规范。

SRC：型钢混凝土组合结构设计规范。

设计规范：选择相应的设计规范生成荷载组合(参见不同规范的设计荷载组合中的注)。

反应谱荷载工况增大系数

增大系数:需要增大的反应谱荷载工况及增大系数。

考虑竖向地震荷载作为主地震荷载：

同时计算水平与竖向地震荷载时，考虑将竖向地震荷载作为主地震荷载，则将竖向地震荷载工况的组合值系数设为1.3，而水平地震荷载工况的组合值系数设为0.5。

施工阶段荷载工况

ST:静力工况。

CS:施工阶段荷载工况。

ST+CS:静力工况和施工阶段荷载工况。

考虑正交结果

设置双向地震作用

100：30规定:日本规范中的规定，当设计选用中国规范时，该项显示为灰色，不能使用。

SRSS法：平方和开平方根法。

点击?设置双向地震荷载工况?，弹出以下对话框。

正交荷载组：

双向地震作用荷载工况

荷载工况1：需要考虑的第一种荷载工况。

荷载工况2：需要考虑的第二种荷载工况。

附加荷载组合

特殊地震荷载:其它需要考虑的地震作用。

竖向地震力：考虑竖向地震力。

考虑施工阶段分析

考虑预应力荷载工况的损失

张拉阶段：设置在张拉阶段的系数。

使用荷载阶段：设置在使用荷载阶段的系数。

单击?确认?后，基于用户的定义，程序按照设计规范自动生成荷载组合。

3. 在电子表格中输入或修改荷载组合

在荷载组合对话框中单击 [image] ，将数据转换到电子表格中，按行排列荷载工况。输入或修改相应的系数、增加或修改荷载工况。

<图3> 荷载组合(电子表格形式)对话框

4. 输入荷载组合文件(文件名.lcb)生成荷载组合

在荷载组合对话框中单击 [image] ，显示输入荷载组合文件的对话框。选择包含已输入荷载组合的文件。

*.LCB文件格式如下:

荷载组合号，组合方式，荷载工况1，荷载安全系数1，...，荷载工况n，荷载安全系数n。

例：

1, , 1, 1.0, 2, 1.0

2, , 1, 1.4, 2, 1.7

组合方式："0"或不输入时，为"添加"；"1"为包络；"2"为ABS；"3"为SRSS。

修改先前定义的荷载组合

在荷载组合列表中选择要修改的荷载组合并修改。

复制先前定义的荷载组合

在荷载组合列表中选择要复制的荷载组合并单击 [image] 。

删除先前定义的荷载组合

在荷载组合列表中选择要删除的荷载组合并单击Delete键。

复制到->： 把"一般"中的荷载组合复制到"钢结构设计"、"混凝土设计" 或者"SRC设计"的荷载组合中。

注：1、使用复制到命令的时候，如果复制不成功，将荷载组合列表采用如图3所示的?电子表格形式?即可。

2、只能把"一般"中的荷载组合复制到"钢结构设计"、"混凝土设计" 或者"SRC设计"的荷载组合中，而不能把"设计"中的荷载组合复制到"一般"荷载组合。

文件名称：生成的荷载组合所存储的目录和文件名称。

另存为：选择荷载组合文件存储的目录和文件名。

生成荷载组合文本文件：点击该键将弹出荷载组合的文本文件。

注:如果不将施工阶段中的荷载定义为"施工阶段荷载"，则在最终施工阶段中仅将该荷载按一般荷载处理。

施工荷载(ER)

累积施工应力(EL)

加劲肋收缩(RS)

屋面活荷载(LR)

雪荷载(S)

雨荷载(R)


01_反力

Home > midas Gen 2017 > 09_结果 > 02_结果 > 01_反力 > 01_反力

反力

  • 功 能

用数值及箭头大小显示支座反力。

  • 命 令

从主菜单中选择结果 > 反力 > 反力

在树形菜单的菜单表单中选择分析结果 > 反力

在图标菜单中单击 [image] 反力

  • 输 入

荷载工况/荷载组合

选择荷载工况、荷载组合或包络荷载工况。

单击右边的 [image] 输入新的或修改现有的荷载工况。(参见?荷载工况 /荷载组合?)

步骤：选择输出的步骤。可以选择非线性分析的荷载步骤、施工阶段分析的各步骤、水化热分析的各步骤。

指定显示形式如下：

反力

选择输出的反力分量。反力分量程序默认按整体坐标系提供。当已为节点定义节点局部坐标系时，可按节点局部坐标系方向输出结果。

FX：整体坐标系X轴方向或节点局部坐标系x方向的反力分量。

FY：整体坐标系Y轴方向或节点局部坐标系y方向的反力分量。

FZ：整体坐标系Z轴方向或节点局部坐标系z方向的反力分量。

FXYZ：

MX：绕整体坐标系X轴或节点局部坐标系x轴的弯矩反力分量。

MY：绕整体坐标系Y轴或节点局部坐标系y轴的弯矩反力分量。

MZ：绕整体坐标系Z轴或节点局部坐标系z轴的弯矩反力分量。

MXYZ：

局部坐标系(如果已定义)：按节点局部坐标系定义节点时，支座反力按节点局部坐标系方向输出。

显示类型

数值： 显示位移分量的数值。数字的字型和颜色可在 [image] 显示选项中控制。

点击?数值?右侧的 [image] ，弹出如下对话框。

小数点以下位数：指定小数形式的数值的精确度。

指数型：数值按指数形式显示。

最大和最小值：显示最小值和最大值。

最大绝对值：显示绝对值的最大值。

最大值：仅显示最大值。

最小值：仅显示最小值。

显示范围(%)：当某需要显示的值与选定的最大值或最小值的差在规定的范围以内时，在屏幕上显示该值。

显示角度：数值的显示方向。

注：默认的小数点可在?参数设置?中输入。当显示方向为0时，在节点或单元右侧，水平显示数值。角度的正方向为逆时针方向，正确选择显示方向，能更清晰地看到数值。

图例：在工作窗口的右边或左边显示与分析结果有关的各种图例。

点击?图例?右侧的 [image] ，弹出?设定图例?对话框。

图例的位置：选择图例在模型空间的位置。

图例数值类型：选择图例中的数值类型和小数点位数。

批量输出结果( 、 )

选择荷载工况、荷载组合以及各施工阶段的步骤，然后选择输出的内容。连续定义输出的内容后，将其保存为图形文件。

点击 [image] ，定义批量输出信息。

在定义输出信息名称时，应事先在前面的荷载工况/荷载组合中选择相应的荷载工况和荷载组合。

选择的荷载工况和荷载组合、施工阶段步骤都将保存在该信息中。

当输出的图形要包含图例时，应该在设置批量输出信息之前选择显示图例。

点击 [image] ，选择批量输出内容。

批量输出对话框

保存的菜单信息：列有在?设置批量输出信息?对话框中定义的输出信息。在列表中选择某信息后，点击 [image] ，可以删除该信息。

阶段：选择将输出的施工阶段。选择该项时，下面的列表中将显示各施工阶段(不显示每个阶段内的子步骤)。

PostCS荷载：选择将输出的最终施工阶段的荷载组合。选择该项时，下面的列表中将显示最终施工阶段的荷载组合。

注：当没有定义施工阶段时，下面的列表中将列出各荷载工况。

使用保存的结果：选择此项时，在上面列表中选择的荷载工况将不起作用，程序将输出保存在保存的菜单信息中的荷载工况和荷载组合信息。

阶段荷载工况/荷载组合：当定义了施工阶段时，下面的列表中将显示各施工阶段的荷载工况和荷载组合。没有定义施工阶段时，下面的列表为空白。

步骤选项

保存的步骤：选择此项时，将输出保存在保存的菜单信息中的施工阶段(在左侧列表中选择的施工阶段)的子步骤信息。

所有步骤：选择此项时，将输出在左侧列表中选择的施工阶段的所有子步骤信息。

输出选项：选择将要输出的文件的格式(BMP或EMF文件)。

输出路径：指定输出的文件保存地址的目录。

文件前缀：指定要生成的图形文件名称的前缀。文件名称的后缀则根据输出选项决定(*.bmp或*.emf)。

自动描述：在生成的图形左上端显示输出的信息内容、施工阶段、子步骤、荷载工况和荷载组合等信息。

点击 [image] ，将按设定的内容输出图形文件。点击 [image] ，可以将输出的设定内容保存成二进制文件(*.bog)。点击 [image] 可以导入该文件，按同样的格式输出其他内容的文件。


02_查看反力

Home > midas Gen 2017 > 09_结果 > 02_结果 > 01_反力 > 02_查看反力

查看反力

  • 功 能

查看特定节点处的反力值。

  • 命 令

从主菜单中选择结果 > 反力 > 查看反力

在树形菜单的菜单表单中选择分析结果 > 反力 > 查看反力

在图标菜单中单击 [image] 查看反力和弯矩

  • 用 法

荷载工况/荷载组合

选择荷载工况、荷载组合。

单击右边的 [image] 输入新的或修改现有的荷载工况。(参见荷载工况 /荷载组合)

步骤：选择输出的步骤。可以选择非线性分析的荷载步骤、施工阶段分析的各步骤、水化热分析的各步骤。

选择节点

输入要查看反力的节点号。

节点号：输入支座的节点编号。或单击输入区，然后在模型窗口中选择支座节点。

注：输入节点编号后，在信息窗口中将显示下列各项：

节点编号：支座节点编号。

FX：整体坐标系X轴方向的反力分量。

FY：整体坐标系Y轴方向的反力分量。

FZ：整体坐标系Z轴方向的反力分量。

FXYZ：

MX：绕整体坐标系X轴的弯矩反力分量。

MY：绕整体坐标系Y轴的弯矩反力分量。

MZ：绕整体坐标系Z轴的弯矩反力分量。

Fx：节点局部坐标系x轴方向的反力分量(已定义节点局部坐标系时)。

Fy：节点局部坐标系y轴方向的反力分量(已定义节点局部坐标系时)。

Fz：节点局部坐标系z轴方向的反力分量(已定义节点局部坐标系时)。

Fxyz： (已定义节点局部坐标系时)。

Mx：绕节点局部坐标系x轴的弯矩反力分量(已定义节点局部坐标系时)。

My：绕节点局部坐标系y轴的弯矩反力分量(已定义节点局部坐标系时)。

Mz：绕节点局部坐标系z轴的弯矩反力分量(已定义节点局部坐标系时)。


03_土压力

Home > midas Gen 2017 > 09_结果 > 02_结果 > 01_反力 > 03_土压力

土压力

  • 功 能

查看地基梁、筏板及挡土墙上的土压力等值线。

  • 命 令

从主菜单中选择结果 > 反力 > 土压力

在树形菜单的菜单表单中选择分析结果 > 反力 > 土压力

  • 用 法

荷载工况/荷载组合

选择荷载工况、荷载组合。

单击右边的 [image] 输入新的或修改现有的荷载工况。(参见荷载工况 /荷载组合)

步骤：选择输出的步骤。可以选择非线性分析的荷载步骤、施工阶段分析的各步骤、水化热分析的各步骤。

成分

选择需要显示的成分。

PX：沿整体坐标系X轴方向的土压力；

PY：沿整体坐标系Y轴方向的土压力；

PZ：沿整体坐标系Z轴方向的土压力；

局部（如已定义）：如果相应节点已经定义节点局部坐标系，土压力按照节点局部坐标系输出。

注1：只有在梁单元、板单元和实体单元上利用“模型->边界条件->面弹性支承”，定义了节点弹性支承或分布弹性支承时，才显示土压力。利用“模型->边界条件->节点弹性支承”定义的节点弹性支承并不适用。

注2：土压力计算时，用节点反力除以节点周围的有效面积；

显示类型

指定显示形式如下：

等值线： 用等值线显示模型位移。

点击等值线右侧的 [image] ，弹出如下对话框。

范围：定义等值线的范围。

调整范围：指定等值线的颜色分布范围。使用该功能可为特定的区域赋以特定的颜色。点击该键，将显示如下对话框。

等值线值：列表中将显示各颜色等级代表的等值线值。颜色等级的数量为下面选择的颜色数量。

颜色数量：输入要包含在等值线中的颜色的数量(在6、12、18、24种颜色中选择)。

颜色：指定或控制等值线的颜色。

颜色表：输入颜色的变化顺序。

V->R->G->B：青紫色->红->绿->蓝。

R->G->B：红->绿->蓝。

R->B->G：红->蓝->绿。

Gray Scaled：渐变灰色。

调整颜色表：调整颜色变化的顺序。在此设定颜色的变化后，颜色表中的顺序将不起作用。

反转等值线图：反转等值线中颜色变化的次序。

等值线：指定等值线的边界线颜色。该项设定仅在右侧选择?画等值线?或?单色线?时才有效。

单元边界：指定单元的边界颜色。

等值线选项：选择表示等值线的方法。

填充涂色

颜色按梯度扩散：颜色渐变(模糊边界)。

画等值线：在等值线中显示彩色边界。

只显示等值线：仅用彩色等值线表现等值线图。

单色线：仅用单色线表现等值线图。

标注等值线注释：显示表示等值线范围和边界的注释。

标注间距：注释的标注间距。

快速显示等值线(用于较大的板或实体单元模型)：板或实体单元的模型较大时，使用简化的等值线，以减少显示等值线需要的时间。

扩展：表现板单元或实体单元的等值线图时，将单元局部坐标系的z轴方向为分析结果的正方向，生成三维等值线图。

注：该选项不能在变形形状中使用。也不能与消隐命令同时使用。当需要同时显示顶板束和底板束地内力(应力)时，也不能使用该选项。

放大系数：将沿单元局部坐标系的z轴方向表现的分析结果放大显示。

变形： 显示模型变形后的形状。点击?变形?右侧的 [image] ，弹出如下对话框。

变形图的比例：放大或缩小变形的显示比例。

变形的表现方式：选择显示变形的方式。

节点位移：只显示节点位移的变形形状。

实际变形：显示详细的变形形状，包括沿两端节点之间任意截面的变形以及梁单元的节点变形。在施工阶段分析中，为了加快速度及节省时间，只提供节点位移。

实际位移(关闭自动调整)：按实际比例显示图变形。选择该项则输入的变形图的比例将不起作用。

相对位移：将最小位移设置为0，其他节点显示相对位移。

数值： 显示位移分量的数值。数字的字型和颜色可在 显示选项中控制。

点击?数值?右侧的 [image] ，弹出如下对话框。

小数点以下位数：指定小数形式的数值的精确度。

指数型：数值按指数形式显示。

最大和最小值：显示最小值和最大值。

最大绝对值：显示绝对值的最大值。

最大值：仅显示最大值。

最小值：仅显示最小值。

显示范围(%)：当某需要显示的值与选定的最大值或最小值的差在规定的范围以内时，在屏幕上显示该值。

显示角度：数值的显示方向。

注：默认的小数点可在?参数设置?中输入。当显示方向为0时，在节点或单元右侧，水平显示数值。角度的正方向为逆时针方向，正确选择显示方向，能更清晰地看到数值。

图例：在工作窗口的右边或左边显示与分析结果有关的各种图例。

点击?图例?右侧的 [image] ，弹出?设定图例?对话框。

图例的位置：选择图例在模型空间的位置。

图例数值类型：选择图例中的数值类型和小数点位数。

动画：动态显示变形过程。单击“动画”按钮，然后单击工作窗口底部动画控制板右边的记录。

点击动画右侧的 [image] ，弹出如下对话框。

动画模式：选择表现分析结果的动画类型。

动画显示(颜色变化)等值线：选择该项，则随着变形量的改变，变形等值线的颜色也将发生变化。

重复半个周期：按半个周期重复放映动画，即从0到最大值。一般用于表现结构的一般变形。

重复整个周期：按整个周期重复放映动画，即从0到最大值，再到0。一般用于表现结构的振动变形和屈曲变形。

制作AVI选项：输入制作AVI动画的各控制数据。

颜色：选择动画的分辨率大小。可供选择的有256色(8位)、增强色(16位)、真彩色(24位)。

：选择压缩动画文件的程序。

半周期帧数(3～300)：模拟半周期的帧数。

每秒帧数：每秒帧数。

施工阶段选项：做施工阶段分析时，选择制作成动画的施工阶段。

施工阶段：选择该项时，在下面选择将制作成动画的施工阶段范围。

当前阶段内子步骤：选择该项时，表示将当前施工阶段各子步骤制作成动画。

变形前： 将模型的变形前形状和变形后的形状重叠显示。

模型变形前形状的显示类型可在 显示选项中控制。

镜像：通过反射面将1/2或1/4模型的分析结果展开成整个模型的结果。

点击?镜像?右侧的 [image] ，弹出如左图的对话框。

1/2模型的镜像：通过对称面将1/2模型的分析结果展开成整个模型的结果。

1/4模型的镜像：通过对称面将1/4模型的分析结果展开成整个模型的结果。

对称面：指定一个整体坐标系平面为对称面。


01_位移形状

Home > midas Gen 2017 > 09_结果 > 02_结果 > 02_变形 > 01_位移形状

位移形状

  • 功 能

查看模型变形后的形状。

  • 命 令

从主菜单中选择结果 > 变形 > 位移形状

在树形菜单的菜单表单中选择分析结果 > 变形 > 位移形状

在图标菜单中单击 [image] 位移形状

  • 输 入

荷载工况/荷载组合

选择荷载工况或荷载组合。

单击右边的 [image] 输入新的或修改现有的荷载工况。(参见荷载工况 /荷载组合)

步骤：选择输出的步骤。可以选择非线性分析的荷载步骤、施工阶段分析的各步骤、水化热分析的各步骤。

位移：显示模型的最大变形形状。(进行时程分析后激活)。

速度：显示模型的最大节点速度。(进行时程分析后激活)。速度值的显示与位移值的显示极其相似。

加速度：显示模型的最大节点加速度。(进行时程分析后激活)。加速度值的显示与位移值的显示极其相似。

绝对加速度：显示模型的最大节点绝对加速度。(进行时程分析后激活)。绝对加速度值的显示与位移值的显示极其相似。

注1：加速度和绝对加速度的区别

加速度＝绝对加速度+观测者加速度

从上面公式可以看出，加速度和绝对加速度的区别依赖于观测者加速度的存在。

注2：上述各项仅在执行时程分析之后激活。

成分

在下列各项中选择变形分量：

DX：整体坐标系X轴方向的位移分量。

DY：整体坐标系Y轴方向的位移分量。

DZ：整体坐标系Z轴方向的位移分量。

DXY =

DYZ =

DXZ =

DXYZ =

显示类型

指定显示形式如下：

变形： 显示模型变形后的形状。点击变形右侧的 [image] ，弹出如下对话框。

变形图的比例：放大或缩小变形的显示比例。

变形的表现方式：选择显示变形的方式。

节点位移：只显示节点位移的变形形状。

实际变形：显示详细的变形形状，包括沿两端节点之间任意截面的变形以及梁单元的节点变形。在施工阶段分析中，为了加快速度及节省时间，只提供节点位移。

实际位移(关闭自动调整)：按实际比例显示图变形。选择该项则输入的变形图的比例将不起作用。

相对位移：将最小位移设置为0，其他节点显示相对位移。

变形前： 将模型的变形前形状和变形后的形状重叠显示。

模型变形前形状的显示类型可在 [image] 显示选项中控制。

数值： 显示位移分量的数值。数字的字型和颜色可在 [image] 显示选项中控制。

点击数值右侧的 [image] ，弹出如下对话框。

小数点以下位数：指定小数形式的数值的精确度。

指数型：数值按指数形式显示。

最大和最小值：显示最小值和最大值。

最大绝对值：显示绝对值的最大值。

最大值：仅显示最大值。

最小值：仅显示最小值。

显示范围(%)：当某需要显示的值与选定的最大值或最小值的差在规定的范围以内时，在屏幕上显示该值。

显示角度：数值的显示方向。

注：默认的小数点可在参数设置中输入。当显示方向为0时，在节点或单元右侧，水平显示数值。角度的正方向为逆时针方向，正确选择显示方向，能更清晰地看到数值。

图例：在工作窗口的右边或左边显示与分析结果有关的各种图例。

点击图例右侧的 [image] ，弹出设定图例对话框。

图例的位置：选择图例在模型空间的位置。

图例数值类型：选择图例中的数值类型和小数点位数。

动画：动态显示变形过程。单击 [image] ，然后单击工作窗口底部动画控制板右边的 [image] 记录。

点击动画右侧的 [image] ，弹出如下对话框。

动画模式：选择表现分析结果的动画类型。

动画显示(颜色变化)等值线：选择该项，则随着变形量的改变，变形等值线的颜色也将发生变化。

重复半个周期：按半个周期重复放映动画，即从0到最大值。一般用于表现结构的一般变形。

重复整个周期：按整个周期重复放映动画，即从0到最大值，再到0。一般用于表现结构的振动变形和屈曲变形。

制作AVI选项：输入制作AVI动画的各控制数据。

颜色：选择动画的分辨率大小。可供选择的有256色(8位)、增强色(16位)、真彩色(24位)。

：选择压缩动画文件的程序。

半周期帧数(3～300)：模拟半周期的帧数。

每秒帧数：每秒帧数。

施工阶段选项：做施工阶段分析时，选择制作成动画的施工阶段。

施工阶段：选择该项时，在下面选择将制作成动画的施工阶段范围。

当前阶段内子步骤：选择该项时，表示将当前施工阶段各子步骤制作成动画。

镜像：通过反射面将1/2或1/4模型的分析结果展开成整个模型的结果。

点击镜像右侧的 [image] ，弹出如左图的对话框。

1/2模型的镜像：通过对称面将1/2模型的分析结果展开成整个模型的结果。

1/4模型的镜像：通过对称面将1/4模型的分析结果展开成整个模型的结果。

对称面：指定一个整体坐标系平面为对称面。

当前步骤位移：显示当前步骤内发生的位移。

批量输出结果( [image] 、 [image])

选择荷载工况、荷载组合以及各施工阶段的步骤，然后选择输出的内容。连续定义输出的内容后，将其保存为图形文件。

点击 [image] ，定义批量输出信息。

在定义输出信息名称时，应事先在前面的荷载工况/荷载组合中选择相应的荷载工况和荷载组合。

选择的荷载工况和荷载组合、施工阶段步骤都将保存在该信息中。

当输出的图形要包含图例时，应该在设置批量输出信息之前选择显示图例。

点击 [image] ，选择批量输出内容。

批量输出对话框

保存的菜单信息：列有在设置批量输出信息对话框中定义的输出信息。在列表中选择某信息后，点击 [image] ，可以删除该信息。

阶段：选择将输出的施工阶段。选择该项时，下面的列表中将显示各施工阶段(不显示每个阶段内的子步骤)。

PostCS荷载：选择将输出的最终施工阶段的荷载组合。选择该项时，下面的列表中将显示最终施工阶段的荷载组合。

注：当没有定义施工阶段时，下面的列表中将列出各荷载工况。

使用保存的结果：选择此项时，在上面列表中选择的荷载工况将不起作用，程序将输出保存在保存的菜单信息中的荷载工况和荷载组合信息。

阶段荷载工况/荷载组合：当定义了施工阶段时，下面的列表中将显示各施工阶段的荷载工况和荷载组合。没有定义施工阶段时，下面的列表为空白。

步骤选项

保存的步骤：选择此项时，将输出保存在保存的菜单信息中的施工阶段(在左侧列表中选择的施工阶段)的子步骤信息。

所有步骤：选择此项时，将输出在左侧列表中选择的施工阶段的所有子步骤信息。

输出选项：选择将要输出的文件的格式(BMP或EMF文件)。

输出路径：指定输出的文件保存地址的目录。

文件前缀：指定要生成的图形文件名称的前缀。文件名称的后缀则根据输出选项决定(*.bmp或*.emf)。

自动描述：在生成的图形左上端显示输出的信息内容、施工阶段、子步骤、荷载工况和荷载组合等信息。

点击 [image] ，将按设定的内容输出图形文件。点击 [image] ，可以将输出的设定内容保存成二进制文件(*.bog)。点击 [image] 可以导入该文件，按同样的格式输出其他内容的文件。


02_位移等值线

Home > midas Gen 2017 > 09_结果 > 02_结果 > 02_变形 > 02_位移等值线

位移等值线

  • 功 能

用位移等值线查看模型的位移。

  • 命 令

从主菜单中选择结果 > 变形 > 位移等值线

在树形菜单的菜单表单中选择分析结果 > 变形 > 位移等值线

在图标菜单中单击 [image] 位移等值线

  • 用 法

荷载工况/荷载组合

选择荷载工况或荷载组合。

单击右边的 [image] ，输入新的或修改现有的荷载工况。(参见"荷载工况 /荷载组合")

步骤：选择输出的步骤。可以选择非线性分析的荷载步骤、施工阶段分析的各步骤、水化热分析的各步骤。

位移：显示模型的最大变形形状。(进行时程分析后激活)。

速度：显示模型的最大节点速度。(进行时程分析后激活)。速度值的显示与位移值的显示极其相似。

加速度：显示模型的最大节点加速度。(进行时程分析后激活)。加速度值的显示与位移值的显示极其相似。

绝对加速度：显示模型的最大节点绝对加速度。(进行时程分析后激活)。绝对加速度值的显示与位移值的显示极其相似。

注1：加速度和绝对加速度的区别

加速度＝绝对加速度+观测者加速度

从上面公式可以看出，加速度和绝对加速度的区别依赖于观测者加速度的存在。

注2：上述各项仅在执行时程分析之后激活。

成分

在下列各项中选择位移分量：

DX：整体坐标系X轴方向的位移分量。

DY：整体坐标系Y轴方向的位移分量。

DZ：整体坐标系Z轴方向的位移分量。

RX：绕整体坐标系X轴的转动分量。

RY：绕整体坐标系Y轴的转动分量。

RZ：绕整体坐标系Z轴的转动分量。

DXY =

DYZ =

DXZ =

DXYZ =

显示类型

指定显示形式如下：

等值线： 用等值线显示模型位移。

点击等值线右侧的 [image] ，弹出如下对话框。

范围：定义等值线的范围。

：指定等值线的颜色分布范围。使用该功能可为特定的区域赋以特定的颜色。点击该键，将显示如下对话框。

等值线值：列表中将显示各颜色等级代表的等值线值。颜色等级的数量为下面选择的颜色数量。

颜色数量：输入要包含在等值线中的颜色的数量(在6、12、18、24种颜色中选择)。

颜色：指定或控制等值线的颜色。

颜色表：输入颜色的变化顺序。

V->R->G->B：青紫色->红->绿->蓝。

R->G->B：红->绿->蓝。

R->B->G：红->蓝->绿。

Gray Scaled：渐变灰色。

：调整颜色变化的顺序。在此设定颜色的变化后，颜色表中的顺序将不起作用。

反转等值线图：反转等值线中颜色变化的次序。

等值线：指定等值线的边界线颜色。该项设定仅在右侧选择画等值线或单色线时才有效。

单元边界：指定单元的边界颜色。

等值线选项：选择表示等值线的方法。

填充涂色

颜色按梯度扩散：颜色渐变(模糊边界)。

画等值线：在等值线中显示彩色边界。

只显示等值线：仅用彩色等值线表现等值线图。

单色线：仅用单色线表现等值线图。

标注等值线注释：显示表示等值线范围和边界的注释。

标注间距：注释的标注间距。

快速显示等值线(用于较大的板或实体单元模型)：板或实体单元的模型较大时，使用简化的等值线，以减少显示等值线需要的时间。

扩展：表现板单元或实体单元的等值线图时，将单元局部坐标系的z轴方向为分析结果的正方向，生成三维等值线图。

注：该选项不能在变形形状中使用。也不能与消隐命令同时使用。当需要同时显示顶板束和底板束地内力(应力)时，也不能使用该选项。

放大系数：将沿单元局部坐标系的z轴方向表现的分析结果放大显示。

变形： 显示模型变形后的形状。点击?变形?右侧的 [image] ，弹出如下对话框。

变形图的比例：放大或缩小变形的显示比例。

变形的表现方式：选择显示变形的方式。

节点位移：只显示节点位移的变形形状。

实际变形：显示详细的变形形状，包括沿两端节点之间任意截面的变形以及梁单元的节点变形。在施工阶段分析中，为了加快速度及节省时间，只提供节点位移。

实际位移(关闭自动调整)：按实际比例显示图变形。选择该项则输入的变形图的比例将不起作用。

相对位移：将最小位移设置为?0?，其他节点显示相对位移。

数值： 显示位移分量的数值。数字的字型和颜色可在 [image] 显示选项中控制。

点击数值右侧的 [image] ，弹出如下对话框。

小数点以下位数：指定小数形式的数值的精确度。

指数型：数值按指数形式显示。

最大和最小值：显示最小值和最大值。

最大绝对值：显示绝对值的最大值。

最大值：仅显示最大值。

最小值：仅显示最小值。

显示范围(%)：当某需要显示的值与选定的最大值或最小值的差在规定的范围以内时，在屏幕上显示该值。

显示角度：数值的显示方向。

注：默认的小数点可在参数设置中输入。当显示方向为0时，在节点或单元右侧，水平显示数值。角度的正方向为逆时针方向，正确选择显示方向，能更清晰地看到数值。

图例：在工作窗口的右边或左边显示与分析结果有关的各种图例。

点击图例右侧的 [image] ，弹出设定图例对话框。

图例的位置：选择图例在模型空间的位置。

图例数值类型：选择图例中的数值类型和小数点位数。

动画：动态显示变形过程。单击 [image] ，然后单击工作窗口底部动画控制板右边的 [image] 记录。

点击动画右侧的 [image] ，弹出如下对话框。

动画模式：选择表现分析结果的动画类型。

动画显示(颜色变化)等值线：选择该项，则随着变形量的改变，变形等值线的颜色也将发生变化。

重复半个周期：按半个周期重复放映动画，即从0到最大值。一般用于表现结构的一般变形。

重复整个周期：按整个周期重复放映动画，即从0到最大值，再到0。一般用于表现结构的振动变形和屈曲变形。

制作AVI选项：输入制作AVI动画的各控制数据。

颜色：选择动画的分辨率大小。可供选择的有256色(8位)、增强色(16位)、真彩色(24位)。

：选择压缩动画文件的程序。

半周期帧数(3～300)：模拟半周期的帧数。

每秒帧数：每秒帧数。

施工阶段选项：做施工阶段分析时，选择制作成动画的施工阶段。

施工阶段：选择该项时，在下面选择将制作成动画的施工阶段范围。

当前阶段内子步骤：选择该项时，表示将当前施工阶段各子步骤制作成动画。

变形前： 将模型的变形前形状和变形后的形状重叠显示。

模型变形前形状的显示类型可在 [image] 显示选项中控制。

镜像：通过反射面将1/2或1/4模型的分析结果展开成整个模型的结果。

点击镜像右侧的 [image] ，弹出如左图的对话框。

1/2模型的镜像：通过对称面将1/2模型的分析结果展开成整个模型的结果。

1/4模型的镜像：通过对称面将1/4模型的分析结果展开成整个模型的结果。

对称面：指定一个整体坐标系平面为对称面。

剖断面 ：剖断线或剖断面上板单元的位移。

点击剖断面右侧的

设定剖断方式

剖断线：沿剖断线生成位移(或内力、应力)图形。

剖断面：生成沿与剖断面相交的面的位移(或内力、应力)图形。

选择剖断线时

已定义的剖断线

已定义的剖断线列表。

：在已定义的剖断线列表中添加新的剖断线。

：在已定义的剖断线列表中删除已定义的剖断线。

：修改已定义的剖断线。

定义剖断线

定义一条剖断线。

名称：剖断线的名称。

Pnt1：剖断线的起点。

Pnt2：剖断线的终点。

选项

指定显示结果的平面和颜色，在该平面上生成图形。

法向：在板单元的法线方向生成图形。

平面内：在板单元的平面内方向显示图形

放大系数：指定输出结果显示的比例。

反转：反转图形显示的方向。

数值：在切断面图内显示结果数值。

仅输出最大/最小值：仅输出最大最小值。

图形：按图形形式显示剖断线上的分析结果。点击右侧 [image] ，设定剖断线图形文件的显示方式并定义图形横轴。

设定剖断线图形对话框

图形显示方式：选择是将各切割线(或切割面)图分别布置在不同表单内，还是布置在一张图内。

图形横轴：定义图形横轴。可以按距离始点Pnt1的距离，也可以按整体坐标系X、或Y、或Z轴的顺序显示结果。

当选择该项后，在前面的位移等值线表单中点击适用键时，将以图形文件的方式显示结果。

以图形形式显示的剖断面图

选择剖断面时

已定义的平面

在已定义的平面中选择某一平面或用户坐标系的x-y、x-z和y-z平面。

定义剖断面

板单元的法线方向：假设剖断面平行于板单元的局部坐标系z轴。

已定义的平面：按照已定义的平面。

对折板连续输出结果：对不同平面上的板单元，用连续线连续显示各板单元的分析结果。

反转：反转图形显示的方向。

数值：在切断面图内显示结果数值。

仅输出最大/最小值：仅输出最大最小值。

当前步骤位移：显示当前步骤内发生的位移。

批量输出结果( 、 )

选择荷载工况、荷载组合以及各施工阶段的步骤，然后选择输出的内容。连续定义输出的内容后，将其保存为图形文件。

点击 [image] ，定义批量输出信息。

在定义输出信息名称时，应事先在前面的?荷载工况/荷载组合?中选择相应的荷载工况和荷载组合。

选择的荷载工况和荷载组合、施工阶段步骤都将保存在该信息中。

当输出的图形要包含图例时，应该在设置批量输出信息之前选择显示图例。

点击 [image] ，选择批量输出内容。

批量输出对话框

保存的菜单信息：列有在设置批量输出信息对话框中定义的输出信息。在列表中选择某信息后，点击 [image] ，可以删除该信息。

阶段：选择将输出的施工阶段。选择该项时，下面的列表中将显示各施工阶段(不显示每个阶段内的子步骤)。

PostCS荷载：选择将输出的最终施工阶段的荷载组合。选择该项时，下面的列表中将显示最终施工阶段的荷载组合。

注：当没有定义施工阶段时，下面的列表中将列出各荷载工况。

使用保存的结果：选择此项时，在上面列表中选择的荷载工况将不起作用，程序将输出保存在保存的菜单信息中的荷载工况和荷载组合信息。

阶段荷载工况/荷载组合：当定义了施工阶段时，下面的列表中将显示各施工阶段的荷载工况和荷载组合。没有定义施工阶段时，下面的列表为空白。

步骤选项

保存的步骤：选择此项时，将输出保存在保存的菜单信息中的施工阶段(在左侧列表中选择的施工阶段)的子步骤信息。

所有步骤：选择此项时，将输出在左侧列表中选择的施工阶段的所有子步骤信息。

输出选项：选择将要输出的文件的格式(BMP或EMF文件)。

输出路径：指定输出的文件保存地址的目录。

文件前缀：指定要生成的图形文件名称的前缀。文件名称的后缀则根据输出选项决定(*.bmp或*.emf)。

自动描述：在生成的图形左上端显示输出的信息内容、施工阶段、子步骤、荷载工况和荷载组合等信息。

点击 [image] ，将按设定的内容输出图形文件。点击 [image] ，可以将输出的设定内容保存成二进制文件(*.bog)。点击 [image] 可以导入该文件，按同样的格式输出其他内容的文件。


03_查看位移

Home > midas Gen 2017 > 09_结果 > 02_结果 > 02_变形 > 03_查看位移

查看位移

  • 功 能

检查特定节点处的位移值。

  • 命 令

从主菜单中选择结果 > 变形 > 查看位移

在树形菜单的菜单表单中选择分析结果 > 变形 > 查看位移

在图标菜单中单击 [image] 查看位移

  • 用 法

荷载工况/荷载组合

选择荷载工况或荷载组合。

单击右边的 [image] ，输入新的或修改现有的荷载工况。(参见"荷载工况 /荷载组合")

步骤：选择输出的步骤。可以选择非线性分析的荷载步骤、施工阶段分析的各步骤、水化热分析的各步骤。

点取节点

节点号：输入要查看位移的节点编号。或单击输入区，然后在模型窗口中选择节点。

当前步骤位移：显示当前步骤内发生的位移。

注：输入节点编号后，在信息窗口中显示下列各项：

节点号

DX：整体坐标系X轴方向的位移分量。

DY：整体坐标系Y轴方向的位移分量。

DZ：整体坐标系Z轴方向的位移分量。

DXYZ：

RX：绕整体坐标系X轴的转动分量。

RY：绕整体坐标系Y轴的转动分量。

RZ：绕整体坐标系Y轴的转动分量。


01_桁架单元内力

Home > midas Gen 2017 > 09_结果 > 02_结果 > 03_内力 > 01_桁架内力

桁架单元内力

  • 功 能

用等值线查看桁架单元、只受拉单元、索单元、钩单元、只受压单元、间隙单元的轴力。

  • 命 令

从主菜单中选择结果 > 内力 > 桁架单元内力

在树形菜单的菜单表单中选择分析结果 > 内力 > 桁架单元内力

在图标菜单中单击 [image] 桁架单元内力

  • 输 入

荷载工况/荷载组合

选择荷载工况或荷载组合。

单击右边的 [image] 输入新的或修改现有的荷载工况。(参见"荷载工况 /荷载组合")

步骤：选择输出的步骤。可以选择非线性分析的荷载步骤、施工阶段分析的各步骤、水化热分析的各步骤。

选择内力

选择输出的内力形式。

全部：显示所有桁架单元的内力。

受拉：只显示只受拉构件的内力。

受压：只显示只受压构件的内力。

显示类型

指定显示形式如下：

等值线： 用等值线显示模型位移。

点击等值线右侧的 [image] ，弹出如下对话框。

范围：定义等值线的范围。

：指定等值线的颜色分布范围。使用该功能可为特定的区域赋以特定的颜色。点击该键，将显示如下对话框。

等值线值：列表中将显示各颜色等级代表的等值线值。颜色等级的数量为下面选择的颜色数量。

颜色数量：输入要包含在等值线中的颜色的数量(在6、12、18、24种颜色中选择)。

颜色：指定或控制等值线的颜色。

颜色表：输入颜色的变化顺序。

V->R->G->B：青紫色->红->绿->蓝。

R->G->B：红->绿->蓝。

R->B->G：红->蓝->绿。

Gray Scaled：渐变灰色。

：调整颜色变化的顺序。在此设定颜色的变化后，颜色表中的顺序将不起作用。

反转等值线图：反转等值线中颜色变化的次序。

等值线：指定等值线的边界线颜色。该项设定仅在右侧选择画等值线或单色线时才有效。

单元边界：指定单元的边界颜色。

等值线选项：选择表示等值线的方法。

填充涂色

颜色按梯度扩散：颜色渐变(模糊边界)。

画等值线：在等值线中显示彩色边界。

只显示等值线：仅用彩色等值线表现等值线图。

单色线：仅用单色线表现等值线图。

标注等值线注释：显示表示等值线范围和边界的注释。

标注间距：注释的标注间距。

快速显示等值线(用于较大的板或实体单元模型)：板或实体单元的模型较大时，使用简化的等值线，以减少显示等值线需要的时间。

扩展：表现板单元或实体单元的等值线图时，将单元局部坐标系的z轴方向为分析结果的正方向，生成三维等值线图。

注：该选项不能在变形形状中使用。也不能与消隐命令同时使用。当需要同时显示顶板束和底板束地内力(应力)时，也不能使用该选项。

放大系数：将沿单元局部坐标系的z轴方向表现的分析结果放大显示。

变形： 显示模型变形后的形状。点击?变形?右侧的 [image] ，弹出如下对话框。

变形图的比例：放大或缩小变形的显示比例。

变形的表现方式：选择显示变形的方式。

节点位移：只显示节点位移的变形形状。

实际变形：显示详细的变形形状，包括沿两端节点之间任意截面的变形以及梁单元的节点变形。在施工阶段分析中，为了加快速度及节省时间，只提供节点位移。

实际位移(关闭自动调整)：按实际比例显示图变形。选择该项则输入的变形图的比例将不起作用。

相对位移：将最小位移设置为0，其他节点显示相对位移。

数值： 显示位移分量的数值。数字的字型和颜色可在 [image] 显示选项中控制。

点击数值右侧的 [image] ，弹出如下对话框。

小数点以下位数：指定小数形式的数值的精确度。

指数型：数值按指数形式显示。

最大和最小值：显示最小值和最大值。

最大绝对值：显示绝对值的最大值。

最大值：仅显示最大值。

最小值：仅显示最小值。

显示范围(%)：当某需要显示的值与选定的最大值或最小值的差在规定的范围以内时，在屏幕上显示该值。

显示角度：数值的显示方向。

注：默认的小数点可在参数设置中输入。当显示方向为0时，在节点或单元右侧，水平显示数值。角度的正方向为逆时针方向，正确选择显示方向，能更清晰地看到数值。

图例：在工作窗口的右边或左边显示与分析结果有关的各种图例。

点击图例右侧的 [image] ，弹出设定图例对话框。

图例的位置：选择图例在模型空间的位置。

图例数值类型：选择图例中的数值类型和小数点位数。

动画：动态显示变形过程。单击 [image] ，然后单击工作窗口底部动画控制板右边的 [image] 记录。

点击动画右侧的 [image] ，弹出如下对话框。

动画模式：选择表现分析结果的动画类型。

动画显示(颜色变化)等值线：选择该项，则随着变形量的改变，变形等值线的颜色也将发生变化。

重复半个周期：按半个周期重复放映动画，即从0到最大值。一般用于表现结构的一般变形。

重复整个周期：按整个周期重复放映动画，即从0到最大值，再到0。一般用于表现结构的振动变形和屈曲变形。

制作AVI选项：输入制作AVI动画的各控制数据。

颜色：选择动画的分辨率大小。可供选择的有?256色(8位)、增强色(16位)、真彩色(24位)。

：选择压缩动画文件的程序。

半周期帧数(3～300)：模拟半周期的帧数。

每秒帧数：每秒帧数。

施工阶段选项：做施工阶段分析时，选择制作成动画的施工阶段。

施工阶段：选择该项时，在下面选择将制作成动画的施工阶段范围。

当前阶段内子步骤：选择该项时，表示将当前施工阶段各子步骤制作成动画。

变形前： 将模型的变形前形状和变形后的形状重叠显示。

模型变形前形状的显示类型可在 [image] 显示选项中控制。

镜像：通过反射面将1/2或1/4模型的分析结果展开成整个模型的结果。

点击镜像右侧的 [image] ，弹出如左图的对话框。

1/2模型的镜像：通过对称面将1/2模型的分析结果展开成整个模型的结果。

1/4模型的镜像：通过对称面将1/4模型的分析结果展开成整个模型的结果。

对称面：指定一个整体坐标系平面为对称面。

数值的输出位置

指定输出桁架单元内力值的截面的位置。仅在选择输出数值时，该项才会被激活。

i：显示桁架单元起始节点(N1)处的内力值。

j：显示桁架单元结束节点(N2)处的内力值。

最大值：将桁架单元的四等分点中最大轴力值，作为桁架单元中心的轴力输出。

全部：同时显示起始节点i、结束节点j以及最大轴力。

桁架单元局部坐标系中内力(或应力)正负号的约定

批量输出结果( 、 )

选择荷载工况、荷载组合以及各施工阶段的步骤，然后选择输出的内容。连续定义输出的内容后，将其保存为图形文件。

点击 [image] ，定义批量输出信息。

在定义输出信息名称时，应事先在前面的?荷载工况/荷载组合?中选择相应的荷载工况和荷载组合。

选择的荷载工况和荷载组合、施工阶段步骤都将保存在该信息中。

当输出的图形要包含图例时，应该在设置批量输出信息之前选择显示图例。

点击 [image] ，选择批量输出内容。

批量输出对话框

保存的菜单信息：列有在设置批量输出信息对话框中定义的输出信息。在列表中选择某信息后，点击 [image] ，可以删除该信息。

阶段：选择将输出的施工阶段。选择该项时，下面的列表中将显示各施工阶段(不显示每个阶段内的子步骤)。

PostCS荷载：选择将输出的最终施工阶段的荷载组合。选择该项时，下面的列表中将显示最终施工阶段的荷载组合。

注：当没有定义施工阶段时，下面的列表中将列出各荷载工况。

使用保存的结果：选择此项时，在上面列表中选择的荷载工况将不起作用，程序将输出保存在保存的菜单信息中的荷载工况和荷载组合信息。

阶段荷载工况/荷载组合：当定义了施工阶段时，下面的列表中将显示各施工阶段的荷载工况和荷载组合。没有定义施工阶段时，下面的列表为空白。

步骤选项

保存的步骤：选择此项时，将输出保存在保存的菜单信息中的施工阶段(在左侧列表中选择的施工阶段)的子步骤信息。

所有步骤：选择此项时，将输出在左侧列表中选择的施工阶段的所有子步骤信息。

输出选项：选择将要输出的文件的格式(BMP或EMF文件)。

输出路径：指定输出的文件保存地址的目录。

文件前缀：指定要生成的图形文件名称的前缀。文件名称的后缀则根据输出选项决定(*.bmp或*.emf)。

自动描述：在生成的图形左上端显示输出的信息内容、施工阶段、子步骤、荷载工况和荷载组合等信息。

点击 [image] ，将按设定的内容输出图形文件。点击 [image] ，可以将输出的设定内容保存成二进制文件(*.bog)。点击 [image] 可以导入该文件，按同样的格式输出其他内容的文件。


02_梁单元内力

Home > midas Gen 2017 > 09_结果 > 02_结果 > 03_内力 > 02_梁单元内力

梁单元内力

  • 功 能

用等值线查看梁单元的内力。

  • 命 令

从主菜单中选择结果 > 内力 > 梁单元内力

在树形菜单的菜单表单中选择分析结果 > 内力 > 梁单元内力

在图标菜单中单击 [image] 梁单元内力

  • 输 入

荷载工况/荷载组合

选择荷载工况或荷载组合。

单击右边的 [image] 输入新的或修改现有的荷载工况。(参见"荷载工况 /荷载组合")

步骤：选择输出的步骤。可以选择非线性分析的荷载步骤、施工阶段分析的各步骤、水化热分析的各步骤。

内力

在下列各项中选择输出的内力分量。

Fx：单元局部坐标系x轴方向的轴力。

Fy：单元局部坐标系y轴方向的剪力。

Fz：单元局部坐标系z轴方向的剪力。

Mx：绕单元局部坐标系x轴方向的扭矩。

My：绕单元局部坐标系y轴方向的弯矩。

Mz：绕单元局部坐标系z轴方向的弯矩。

注：

勾选内力Fx时同时勾选查看桁架内力，可同时显示梁单元和桁架单元的轴力。

显示类型

指定显示形式如下：

等值线： 用等值线显示模型位移。

点击等值线右侧的 [image] ，弹出如下对话框。

范围：定义等值线的范围。

：指定等值线的颜色分布范围。使用该功能可为特定的区域赋以特定的颜色。点击该键，将显示如下对话框。

等值线值：列表中将显示各颜色等级代表的等值线值。颜色等级的数量为下面选择的颜色数量。

颜色数量：输入要包含在等值线中的颜色的数量(在6、12、18、24种颜色中选择)。

颜色：指定或控制等值线的颜色。

颜色表：输入颜色的变化顺序。

V->R->G->B：青紫色->红->绿->蓝。

R->G->B：红->绿->蓝。

R->B->G：红->蓝->绿。

Gray Scaled：渐变灰色。

：调整颜色变化的顺序。在此设定颜色的变化后，颜色表中的顺序将不起作用。

反转等值线图：反转等值线中颜色变化的次序。

等值线：指定等值线的边界线颜色。该项设定仅在右侧选择?画等值线?或?单色线?时才有效。

单元边界：指定单元的边界颜色。

等值线选项：选择表示等值线的方法。

填充涂色

颜色按梯度扩散：颜色渐变(模糊边界)。

画等值线：在等值线中显示彩色边界。

只显示等值线：仅用彩色等值线表现等值线图。

单色线：仅用单色线表现等值线图。

标注等值线注释：显示表示等值线范围和边界的注释。

标注间距：注释的标注间距。

快速显示等值线(用于较大的板或实体单元模型)：板或实体单元的模型较大时，使用简化的等值线，以减少显示等值线需要的时间。

扩展：表现板单元或实体单元的等值线图时，将单元局部坐标系的z轴方向为分析结果的正方向，生成三维等值线图。

注：该选项不能在变形形状中使用。也不能与消隐命令同时使用。当需要同时显示顶板束和底板束地内力(应力)时，也不能使用该选项。

放大系数：将沿单元局部坐标系的z轴方向表现的分析结果放大显示。

变形： 显示模型变形后的形状。点击变形右侧的 [image] ，弹出如下对话框。

变形图的比例：放大或缩小变形的显示比例。

变形的表现方式：选择显示变形的方式。

节点位移：只显示节点位移的变形形状。

实际变形：显示详细的变形形状，包括沿两端节点之间任意截面的变形以及梁单元的节点变形。在施工阶段分析中，为了加快速度及节省时间，只提供节点位移。

实际位移(关闭自动调整)：按实际比例显示图变形。选择该项则输入的变形图的比例将不起作用。

相对位移：将最小位移设置为0，其他节点显示相对位移。

数值： 显示位移分量的数值。数字的字型和颜色可在 [image] 显示选项中控制。

点击数值右侧的 [image] ，弹出如下对话框。

小数点以下位数：指定小数形式的数值的精确度。

指数型：数值按指数形式显示。

最大和最小值：显示最小值和最大值。

最大绝对值：显示绝对值的最大值。

最大值：仅显示最大值。

最小值：仅显示最小值。

显示范围(%)：当某需要显示的值与选定的最大值或最小值的差在规定的范围以内时，在屏幕上显示该值。

显示角度：数值的显示方向。

注：默认的小数点可在?参数设置?中输入。当显示方向为0时，在节点或单元右侧，水平显示数值。角度的正方向为逆时针方向，正确选择显示方向，能更清晰地看到数值。

图例：在工作窗口的右边或左边显示与分析结果有关的各种图例。

点击图例右侧的 [image] ，弹出?设定图例?对话框。

图例的位置：选择图例在模型空间的位置。

图例数值类型：选择图例中的数值类型和小数点位数。

动画：动态显示变形过程。单击 [image] ，然后单击工作窗口底部动画控制板右边的 [image] 记录。

点击动画右侧的 [image] ，弹出如下对话框。

动画模式：选择表现分析结果的动画类型。

动画显示(颜色变化)等值线：选择该项，则随着变形量的改变，变形等值线的颜色也将发生变化。

重复半个周期：按半个周期重复放映动画，即从0到最大值。一般用于表现结构的一般变形。

重复整个周期：按整个周期重复放映动画，即从0到最大值，再到0。一般用于表现结构的振动变形和屈曲变形。

制作AVI选项：输入制作AVI动画的各控制数据。

颜色：选择动画的分辨率大小。可供选择的有256色(8位)、增强色(16位)、真彩色(24位)。

：选择压缩动画文件的程序。

半周期帧数(3～300)：模拟半周期的帧数。

每秒帧数：每秒帧数。

施工阶段选项：做施工阶段分析时，选择制作成动画的施工阶段。

施工阶段：选择该项时，在下面选择将制作成动画的施工阶段范围。

当前阶段内子步骤：选择该项时，表示将当前施工阶段各子步骤制作成动画。

变形前： 将模型的变形前形状和变形后的形状重叠显示。

模型变形前形状的显示类型可在 [image] 显示选项中控制。

镜像：通过反射面将1/2或1/4模型的分析结果展开成整个模型的结果。

点击?镜像?右侧的 [image] ，弹出如左图的对话框。

1/2模型的镜像：通过对称面将1/2模型的分析结果展开成整个模型的结果。

1/4模型的镜像：通过对称面将1/4模型的分析结果展开成整个模型的结果。

对称面：指定一个整体坐标系平面为对称面。

输出位置

指定梁单元内力值的输出位置。仅在选择输出?数值?时，该项才会被激活。

I：显示梁单元起始节点(N1)处的内力值。

中心：显示梁单元跨中处的内力值。

J：显示梁单元结束节点(N2)处的内力值。

绝对最大：将梁单元的四等分点中绝对最大内力值，作为梁单元中心的内力输出。

Min/Max：将梁单元的四等分点中最小和最大内力值，作为梁单元中心的内力输出。

全部：同时显示起始节点i、结束节点j以及中心点的内力。

按构件：按照构件显示。需首先在“设计->一般设计参数->指定构件”中指定构件后使用。

梁单元局部坐标系中内力(或应力)正负号的约定

注：对于梁单元局部坐标系中内力(或应力)正负号的约定，程序中的约定是和材料力学教材里面的约定是一致的。对于过程中常用的My及Mz的方向，和单元坐标轴x、y、z的方向有关，可以这样简单理解：对My，因为是使得整个杆件在xz平面内发生弯曲，当My使得杆件在z轴的负向受拉时，My的值为正。对Mz，因为是使得整个杆件在xy平面内发生弯曲，当Mz使得杆件在y轴的负向受拉时，Mz的值为正。

可以参考下图，图中两个单元的单元坐标轴中x、y轴方向相反，z轴的方向相同，外力产生的弯矩在两个单元中连续。

弯矩My图

弯矩Mz图

批量输出结果( 、 )

选择荷载工况、荷载组合以及各施工阶段的步骤，然后选择输出的内容。连续定义输出的内容后，将其保存为图形文件。

点击 [image] ，定义批量输出信息。

在定义?输出信息名称?时，应事先在前面的?荷载工况/荷载组合?中选择相应的荷载工况和荷载组合。

选择的荷载工况和荷载组合、施工阶段步骤都将保存在该信息中。

当输出的图形要包含?图例?时，应该在设置批量输出信息之前选择显示?图例?。

点击 [image] ，选择批量输出内容。

批量输出对话框

保存的菜单信息：列有在?设置批量输出信息?对话框中定义的输出信息。在列表中选择某信息后，点击 [image] ，可以删除该信息。

阶段：选择将输出的施工阶段。选择该项时，下面的列表中将显示各施工阶段(不显示每个阶段内的子步骤)。

PostCS荷载：选择将输出的最终施工阶段的荷载组合。选择该项时，下面的列表中将显示最终施工阶段的荷载组合。

注：当没有定义施工阶段时，下面的列表中将列出各荷载工况。

使用保存的结果：选择此项时，在上面列表中选择的荷载工况将不起作用，程序将输出保存在?保存的菜单信息?中的荷载工况和荷载组合信息。

阶段荷载工况/荷载组合：当定义了施工阶段时，下面的列表中将显示各施工阶段的荷载工况和荷载组合。没有定义施工阶段时，下面的列表为空白。

步骤选项

保存的步骤：选择此项时，将输出保存在?保存的菜单信息?中的施工阶段(在左侧列表中选择的施工阶段)的子步骤信息。

所有步骤：选择此项时，将输出在左侧列表中选择的施工阶段的所有子步骤信息。

输出选项：选择将要输出的文件的格式(BMP或EMF文件)。

输出路径：指定输出的文件保存地址的目录。

文件前缀：指定要生成的图形文件名称的前缀。文件名称的后缀则根据?输出选项?决定(*.bmp或*.emf)。

自动描述：在生成的图形左上端显示输出的信息内容、施工阶段、子步骤、荷载工况和荷载组合等信息。

点击 [image] ，将按设定的内容输出图形文件。点击 [image] ，可以将输出的设定内容保存成二进制文件(*.bog)。点击 [image] 可以导入该文件，按同样的格式输出其他内容的文件。


03_梁单元内力图

Home > midas Gen 2017 > 09_结果 > 02_结果 > 03_内力 > 03_梁单元内力图

梁单元内力图

  • 功 能

查看梁单元的轴力图(AFD)、弯矩图(BMD)和剪力图(SFD)。

  • 命 令

从主菜单中选择结果 > 内力 > 梁单元内力图

在树形菜单的菜单表单中选择分析结果 > 内力 > 梁单元内力图

在图标菜单中单击 [image] 梁单元内力图

  • 输 入

荷载工况/荷载组合

选择荷载工况或荷载组合。

单击右边的 [image] 输入新的或修改现有的荷载工况。(参见荷载工况 /荷载组合)

步骤：选择输出的步骤。可以选择非线性分析的荷载步骤、施工阶段分析的各步骤、水化热分析的各步骤。

内力

在下列各项中选择输出的内力分量。

Fx：单元局部坐标系x轴方向的轴力。

Fy：单元局部坐标系y轴方向的剪力。

Fz：单元局部坐标系z轴方向的剪力。

Fy、Fz：同时输出单元局部坐标系y、z轴方向的剪力。

Mx：绕单元局部坐标系x轴方向的扭矩。

My：绕单元局部坐标系y轴方向的弯矩。

Mz：绕单元局部坐标系z轴方向的弯矩。

Myz：同时输出绕单元局部坐标系y、z轴方向的弯矩。

注：

勾选内力Fx时同时勾选查看桁架内力，可同时显示梁单元和桁架单元的轴力。

勾选仅桁架单元内力，只显示桁架单元的轴力。

显示选项

精确解：提供沿包括两端节点在内的梁单元全长的的梁内力图(参见梁单元细部分析)。该项不适用于施工阶段分析和非线性分析。

5点：提供梁长的四等分点及两端节点处的内力，节点和四等分点之间的内力用直线内插。

不涂色：仅显示梁内力图的外轮廓。

线涂色：在节点和四等分点处用彩色线表现内力图。

实体涂色：内力图用彩色涂面。

系数：输入内力图的显示比例。

显示类型

指定显示形式如下：

等值线： 用等值线显示模型位移。

点击等值线右侧的 [image] ，弹出如下对话框。

范围：定义等值线的范围。

：指定等值线的颜色分布范围。使用该功能可为特定的区域赋以特定的颜色。点击该键，将显示如下对话框。

等值线值：列表中将显示各颜色等级代表的等值线值。颜色等级的数量为下面选择的颜色数量。

颜色数量：输入要包含在等值线中的颜色的数量(在6、12、18、24种颜色中选择)。

颜色：指定或控制等值线的颜色。

颜色表：输入颜色的变化顺序。

V->R->G->B：青紫色->红->绿->蓝。

R->G->B：红->绿->蓝。

R->B->G：红->蓝->绿。

Gray Scaled：渐变灰色。

：调整颜色变化的顺序。在此设定颜色的变化后，颜色表中的顺序将不起作用。

反转等值线图：反转等值线中颜色变化的次序。

等值线：指定等值线的边界线颜色。该项设定仅在右侧选择画等值线或单色线时才有效。

单元边界：指定单元的边界颜色。

等值线选项：选择表示等值线的方法。

填充涂色

颜色按梯度扩散：颜色渐变(模糊边界)。

画等值线：在等值线中显示彩色边界。

只显示等值线：仅用彩色等值线表现等值线图。

单色线：仅用单色线表现等值线图。

标注等值线注释：显示表示等值线范围和边界的注释。

标注间距：注释的标注间距。

快速显示等值线(用于较大的板或实体单元模型)：板或实体单元的模型较大时，使用简化的等值线，以减少显示等值线需要的时间。

扩展：表现板单元或实体单元的等值线图时，将单元局部坐标系的z轴方向为分析结果的正方向，生成三维等值线图。

注：该选项不能在变形形状中使用。也不能与消隐命令同时使用。当需要同时显示顶板束和底板束地内力(应力)时，也不能使用该选项。

放大系数：将沿单元局部坐标系的z轴方向表现的分析结果放大显示。

变形： 显示模型变形后的形状。点击变形右侧的 [image] ，弹出如下对话框。

变形图的比例：放大或缩小变形的显示比例。

变形的表现方式：选择显示变形的方式。

节点位移：只显示节点位移的变形形状。

实际变形：显示详细的变形形状，包括沿两端节点之间任意截面的变形以及梁单元的节点变形。在施工阶段分析中，为了加快速度及节省时间，只提供节点位移。

实际位移(关闭自动调整)：按实际比例显示图变形。选择该项则输入的变形图的比例将不起作用。

相对位移：将最小位移设置为0，其他节点显示相对位移。

数值： 显示位移分量的数值。数字的字型和颜色可在 [image] 显示选项中控制。

点击数值右侧的 [image] ，弹出如下对话框。

小数点以下位数：指定小数形式的数值的精确度。

指数型：数值按指数形式显示。

最大和最小值：显示最小值和最大值。

最大绝对值：显示绝对值的最大值。

最大值：仅显示最大值。

最小值：仅显示最小值。

显示范围(%)：当某需要显示的值与选定的最大值或最小值的差在规定的范围以内时，在屏幕上显示该值。

显示角度：数值的显示方向。

注：默认的小数点可在参数设置中输入。当显示方向为0时，在节点或单元右侧，水平显示数值。角度的正方向为逆时针方向，正确选择显示方向，能更清晰地看到数值。

图例：在工作窗口的右边或左边显示与分析结果有关的各种图例。

点击图例右侧的 [image] ，弹出设定图例对话框。

图例的位置：选择图例在模型空间的位置。

图例数值类型：选择图例中的数值类型和小数点位数。

动画：动态显示变形过程。单击 [image] ，然后单击工作窗口底部动画控制板右边的 [image] 记录。

点击动画右侧的 [image] ，弹出如下对话框。

动画模式：选择表现分析结果的动画类型。

动画显示(颜色变化)等值线：选择该项，则随着变形量的改变，变形等值线的颜色也将发生变化。

重复半个周期：按半个周期重复放映动画，即从0到最大值。一般用于表现结构的一般变形。

重复整个周期：按整个周期重复放映动画，即从?0?到最大值，再到?0?。一般用于表现结构的振动变形和屈曲变形。

制作AVI选项：输入制作AVI动画的各控制数据。

颜色：选择动画的分辨率大小。可供选择的有256色(8位)、增强色(16位)、真彩色(24位)。

：选择压缩动画文件的程序。

半周期帧数(3～300)：模拟半周期的帧数。

每秒帧数：每秒帧数。

施工阶段选项：做施工阶段分析时，选择制作成动画的施工阶段。

施工阶段：选择该项时，在下面选择将制作成动画的施工阶段范围。

当前阶段内子步骤：选择该项时，表示将当前施工阶段各子步骤制作成动画。

变形前： 将模型的变形前形状和变形后的形状重叠显示。

模型变形前形状的显示类型可在 [image] 显示选项中控制。

镜像：通过反射面将1/2或1/4模型的分析结果展开成整个模型的结果。

点击?镜像?右侧的 [image] ，弹出如左图的对话框。

1/2模型的镜像：通过对称面将1/2模型的分析结果展开成整个模型的结果。

1/4模型的镜像：通过对称面将1/4模型的分析结果展开成整个模型的结果。

对称面：指定一个整体坐标系平面为对称面。

快速查看

可以快速查看用户选择的单元的内力结果。

点击右侧的 [image] 按钮，弹出如下对话框，输入需要查看的单元号或者直接在窗口中点取需要查看的单元，可以查看该单元的相应结果。

输出位置

指定梁单元内力值的输出位置。仅在选择输出"数值"时，该项才会被激活。

i：显示梁单元起始节点(N1)处的内力值。

中心：显示梁单元跨中处的内力值。

j：显示梁单元结束节点(N2)处的内力值。

绝对最大：将梁单元的四等分点中绝对最大内力值，作为梁单元中心的内力输出。

Min/Max：将梁单元的四等分点中最小和最大内力值，作为梁单元中心的内力输出。

全部：同时显示起始节点i、结束节点j以及中心点的内力。

按构件：按照构件显示。需首先在“设计->一般设计参数->指定构件”中指定构件后使用。

梁单元局部坐标系中内力(或应力)正负号的约定

注：对于梁单元局部坐标系中内力(或应力)正负号的约定，程序中的约定是和材料力学教材里面的约定是一致的。对于过程中常用的My及Mz的方向，和单元坐标轴x、y、z的方向有关，可以这样简单理解：对My，因为是使得整个杆件在xz平面内发生弯曲，当My使得杆件在z轴的负向受拉时，My的值为正。对Mz，因为是使得整个杆件在xy平面内发生弯曲，当Mz使得杆件在y轴的负向受拉时，Mz的值为正。

可以参考下图，图中两个单元的单元坐标轴中x、y轴方向相反，z轴的方向相同，外力产生的弯矩在两个单元中连续。

弯矩My图

弯矩Mz图

批量输出结果( [image] 、 [image])

选择荷载工况、荷载组合以及各施工阶段的步骤，然后选择输出的内容。连续定义输出的内容后，将其保存为图形文件。

点击 [image] ，定义批量输出信息。

在定义输出信息名称时，应事先在前面的荷载工况/荷载组合中选择相应的荷载工况和荷载组合。

选择的荷载工况和荷载组合、施工阶段步骤都将保存在该信息中。

当输出的图形要包含图例时，应该在设置批量输出信息之前选择显示图例。

点击 [image] ，选择批量输出内容。

批量输出对话框

保存的菜单信息：列有在设置批量输出信息对话框中定义的输出信息。在列表中选择某信息后，点击 [image] ，可以删除该信息。

阶段：选择将输出的施工阶段。选择该项时，下面的列表中将显示各施工阶段(不显示每个阶段内的子步骤)。

PostCS荷载：选择将输出的最终施工阶段的荷载组合。选择该项时，下面的列表中将显示最终施工阶段的荷载组合。

注：当没有定义施工阶段时，下面的列表中将列出各荷载工况。

使用保存的结果：选择此项时，在上面列表中选择的荷载工况将不起作用，程序将输出保存在保存的菜单信息中的荷载工况和荷载组合信息。

阶段荷载工况/荷载组合：当定义了施工阶段时，下面的列表中将显示各施工阶段的荷载工况和荷载组合。没有定义施工阶段时，下面的列表为空白。

步骤选项

保存的步骤：选择此项时，将输出保存在保存的菜单信息中的施工阶段(在左侧列表中选择的施工阶段)的子步骤信息。

所有步骤：选择此项时，将输出在左侧列表中选择的施工阶段的所有子步骤信息。

输出选项：选择将要输出的文件的格式(BMP或EMF文件)。

输出路径：指定输出的文件保存地址的目录。

文件前缀：指定要生成的图形文件名称的前缀。文件名称的后缀则根据输出选项决定(*.bmp或*.emf)。

自动描述：在生成的图形左上端显示输出的信息内容、施工阶段、子步骤、荷载工况和荷载组合等信息。

点击 [image] ，将按设定的内容输出图形文件。点击 [image] ，可以将输出的设定内容保存成二进制文件(*.bog)。点击 [image] 可以导入该文件，按同样的格式输出其他内容的文件。


04_板单元内力

Home > midas Gen 2017 > 09_结果 > 02_结果 > 03_内力 > 04_板单元内力

板单元内力

  • 功 能

用等值线或矢量查看板单元在单位宽度上的内力分布。

  • 命 令

从主菜单中选择结果 > 内力 > 板单元内力

在树形菜单的菜单表单中选择分析结果 > 内力 > 板单元内力

在图标菜单中单击 [image] 板单元内力

  • 输 入

荷载工况/荷载组合

选择荷载工况或荷载组合。单击右边的 [image] 输入新的或修改现有的荷载工况。(参见"荷载工况/荷载组合")

步骤：选择输出的步骤。可以选择非线性分析的荷载步骤、施工阶段分析的各步骤、水化热分析的各步骤。

内力选项

单元坐标系：输出沿各板单元局部坐标系方向的单位宽度的内力分布。

用户：选择用户坐标系，程序将输出用户坐标系方向的各单元的单位宽度的内力。未定义用户坐标系时，默认使用整体坐标系。

内力输出方式

单元：分别输出各单元的节点内力(单位宽度的内力)。

节点平均值：使用"绕节点平均法"计算各节点的内力和应力值。即取各单元在共享节点的平均值。

取被激活单元的节点平均值：仅输出当前被激活的单元的节点平均值。

各种内力输出方式的使用条件

单元：

1、选择没有限制。

2、节点的不同单元在共享节点的内力值和应力值有可能不同，这是由有限元分析的特征决定的。因此对预测内力变化较大的位置，应细分单元。

节点平均值：

1、选择有限制。各板单元的单元坐标系方向相差较大时(单元划分不规则、折形板等)，不能使用?单元?坐标系。

2、在同一平面时(包括同一平面内单元划分不规则时)，推荐使用用户坐标系。

取被激活单元的节点平均值：

1、选择有限制。各板单元的单元坐标系方向相差较大时(单元划分不规则、折形板等)，不能使用?单元?坐标系。

2、些板单元在同一平面时，可以使用用户坐标系，然后选择这些板激活。

注:当需要计算某单元在指定方向的合力时，可以使用?局部方向内力的合力?。

内力

在下列各项中选择输出的内力分量：

注:Fij：i-力作用平面。

j-力作用方向。

(+)符号约定：力作用平面的法线方向与某单元坐标轴方向一致，且力作用方向j与单元坐标轴方向一致时为正(+)；力作用平面的法线方向与某单元坐标轴方向相反，且力作用方向j与单元坐标轴方向相反时为正(+)。

Mij：i-力作用平面。

j-与弯矩旋转方向平行的轴。

(+)符号约定：当i≠j时，按右手法则，大拇指方向与力作用平面的法线方向一致为正(+)；当i=j时，弯矩作用时板的正面(法线方向作用面)受压时为正(+)。

Vii：i-力作用平面。

(+)符号约定：力作用平面的法线方向与单元坐标轴方向一致，且力作用方向与单元坐标系z轴方向一致时为正(+)。

(a) 内力(单位板宽)输出位置

(b) 轴力和剪力(单位板宽)

(c) 弯矩和扭矩(单位板宽)

<图1> 板单元的内力作用位置及符号约定

Fxx：作用在与局部坐标系或用户坐标系x轴垂直平面内，单元局部坐标系或用户坐标系x轴方向上单位宽度轴力。

Fyy：作用在与局部坐标系或用户坐标系y轴垂直平面内，单元局部坐标系或用户坐标系y轴方向上单位宽度轴力。

Fxy：单元局部坐标系或用户坐标系的x-y平面内(平面内受剪)单位宽度剪力(Fxy=Fyx)。

Fmax：单位宽度最大主轴力。

Fmin：单位宽度最小主轴力。

FMax：单位宽度绝对值最大的轴力。

Mxx：作用在与局部坐标系或用户坐标系x轴垂直平面内，绕y轴旋转的单位宽度弯矩(绕局部坐标系y轴的平面外弯矩)。(有时候可以这样理解：在单元坐标系或者用户坐标系xy平面内，使板单元绕y轴旋转的弯矩。）

Myy：作用在与局部坐标系或用户坐标系y轴垂直平面内，绕x轴旋转的单位宽度弯矩(绕局部坐标系x轴的平面外弯矩)。(有时候可以这样理解：在单元坐标系或者用户坐标系xy平面内，使板单元绕x轴旋转的弯矩。）

Mxy：作用在与局部坐标系或用户坐标系x轴垂直平面内，绕x轴旋转的单位宽度扭矩(Mxy=Myx)。

Mmax：单位宽度的最大主弯矩。

Mmin：单位宽度的最大小弯矩。

MMax：单位宽度的绝对值最大的弯矩(Mmax和Mmin中的较大值)。

Vxx：作用在与局部坐标系或用户坐标系x轴垂直平面内，沿单元局部坐标系或用户坐标系z轴(厚度)方向上单位宽度的剪力。

Vyy：作用在与局部坐标系或用户坐标系y轴垂直平面内，沿单元局部坐标系或用户坐标系z轴(厚度)方向上单位宽度的剪力。

VMax：单位宽度的绝对值最大的弯矩(Vxx和Vyy中的较大值)。

Fvector：在板单元中心处表示最大和最小主轴力的方向(向量)及最大最小值。

Mvector：在板单元中心处表示最大和最小主弯矩的方向(向量)及最大最小值。

系数：当选择Fvector或Mvector时，向量的显示比例。 显示类型

指定显示形式如下：

等值线： 用等值线显示模型位移。

点击等值线右侧的 [image] ，弹出如下对话框。

范围：定义等值线的范围。

：指定等值线的颜色分布范围。使用该功能可为特定的区域赋以特定的颜色。点击该键，将显示如下对话框。

等值线值：列表中将显示各颜色等级代表的等值线值。颜色等级的数量为下面选择的颜色数量。

颜色数量：输入要包含在等值线中的颜色的数量(在6、12、18、24种颜色中选择)。

颜色：指定或控制等值线的颜色。

颜色表：输入颜色的变化顺序。

V->R->G->B：青紫色->红->绿->蓝。

R->G->B：红->绿->蓝。

R->B->G：红->蓝->绿。

Gray Scaled：渐变灰色。

：调整颜色变化的顺序。在此设定颜色的变化后，颜色表中的顺序将不起作用。

反转等值线图：反转等值线中颜色变化的次序。

等值线：指定等值线的边界线颜色。该项设定仅在右侧选择?画等值线?或?单色线?时才有效。

单元边界：指定单元的边界颜色。

等值线选项：选择表示等值线的方法。

填充涂色

颜色按梯度扩散：颜色渐变(模糊边界)。

画等值线：在等值线中显示彩色边界。

只显示等值线：仅用彩色等值线表现等值线图。

单色线：仅用单色线表现等值线图。

标注等值线注释：显示表示等值线范围和边界的注释。

标注间距：注释的标注间距。

快速显示等值线(用于较大的板或实体单元模型)：板或实体单元的模型较大时，使用简化的等值线，以减少显示等值线需要的时间。

扩展：表现板单元或实体单元的等值线图时，将单元局部坐标系的z轴方向为分析结果的正方向，生成三维等值线图。

注：该选项不能在变形形状中使用。也不能与消隐命令同时使用。当需要同时显示顶板束和底板束地内力(应力)时，也不能使用该选项。

放大系数：将沿单元局部坐标系的z轴方向表现的分析结果放大显示。

变形： 显示模型变形后的形状。点击?变形?右侧的 [image] ，弹出如下对话框。

变形图的比例：放大或缩小变形的显示比例。

变形的表现方式：选择显示变形的方式。

节点位移：只显示节点位移的变形形状。

实际变形：显示详细的变形形状，包括沿两端节点之间任意截面的变形以及梁单元的节点变形。在施工阶段分析中，为了加快速度及节省时间，只提供节点位移。

实际位移(关闭自动调整)：按实际比例显示图变形。选择该项则输入的变形图的比例将不起作用。

相对位移：将最小位移设置为?0?，其他节点显示相对位移。

数值： 显示位移分量的数值。数字的字型和颜色可在 [image] 显示选项中控制。

点击数值右侧的 [image] ，弹出如下对话框。

小数点以下位数：指定小数形式的数值的精确度。

指数型：数值按指数形式显示。

最大和最小值：显示最小值和最大值。

最大绝对值：显示绝对值的最大值。

最大值：仅显示最大值。

最小值：仅显示最小值。

显示范围(%)：当某需要显示的值与选定的最大值或最小值的差在规定的范围以内时，在屏幕上显示该值。

显示角度：数值的显示方向。

注：默认的小数点可在?参数设置?中输入。当显示方向为0时，在节点或单元右侧，水平显示数值。角度的正方向为逆时针方向，正确选择显示方向，能更清晰地看到数值。

图例：在工作窗口的右边或左边显示与分析结果有关的各种图例。

点击图例右侧的 [image] ，弹出设定图例对话框。

图例的位置：选择图例在模型空间的位置。

图例数值类型：选择图例中的数值类型和小数点位数。

动画：动态显示变形过程。单击 [image] ，然后单击工作窗口底部动画控制板右边的 [image] 记录。

点击动画右侧的 [image] ，弹出如下对话框。

动画模式：选择表现分析结果的动画类型。

动画显示(颜色变化)等值线：选择该项，则随着变形量的改变，变形等值线的颜色也将发生变化。

重复半个周期：按半个周期重复放映动画，即从0到最大值。一般用于表现结构的一般变形。

重复整个周期：按整个周期重复放映动画，即从?0?到最大值，再到?0?。一般用于表现结构的振动变形和屈曲变形。

制作AVI选项：输入制作AVI动画的各控制数据。

颜色：选择动画的分辨率大小。可供选择的有56色(8位)、增强色(16位)、真彩色(24位)。

：选择压缩动画文件的程序。

半周期帧数(3～300)：模拟半周期的帧数。

每秒帧数：每秒帧数。

施工阶段选项：做施工阶段分析时，选择制作成动画的施工阶段。

施工阶段：选择该项时，在下面选择将制作成动画的施工阶段范围。

当前阶段内子步骤：选择该项时，表示将当前施工阶段各子步骤制作成动画。

变形前： 将模型的变形前形状和变形后的形状重叠显示。

模型变形前形状的显示类型可在 [image] 显示选项中控制。

镜像：通过反射面将1/2或1/4模型的分析结果展开成整个模型的结果。

点击镜像右侧的 [image] ，弹出如左图的对话框。

1/2模型的镜像：通过对称面将1/2模型的分析结果展开成整个模型的结果。

1/4模型的镜像：通过对称面将1/4模型的分析结果展开成整个模型的结果。

对称面：指定一个整体坐标系平面为对称面。

剖断面 ：剖断线或剖断面上板单元的位移。

点击剖断面右侧的

设定剖断方式

剖断线：沿剖断线生成位移(或内力、应力)图形。

剖断面：生成沿与剖断面相交的面的位移(或内力、应力)图形。

选择剖断线时

已定义的剖断线

已定义的剖断线列表。

：在已定义的剖断线列表中添加新的剖断线。

：在已定义的剖断线列表中删除已定义的剖断线。

：修改已定义的剖断线。

定义剖断线

定义一条剖断线。

名称：剖断线的名称。

Pnt1：剖断线的起点。

Pnt2：剖断线的终点。

选项

指定显示结果的平面和颜色，在该平面上生成图形。

法向：在板单元的法线方向生成图形。

平面内：在板单元的平面内方向显示图形

放大系数：指定输出结果显示的比例。

反转：反转图形显示的方向。

数值：在切断面图内显示结果数值。

仅输出最大/最小值：仅输出最大最小值。

图形：按图形形式显示剖断线上的分析结果。点击右侧 [image] ，设定剖断线图形文件的显示方式并定义图形横轴。

设定剖断线图形对话框

图形显示方式：选择是将各切割线(或切割面)图分别布置在不同表单内，还是布置在一张图内。

图形横轴：定义图形横轴。可以按距离始点Pnt1的距离，也可以按整体坐标系X、或Y、或Z轴的顺序显示结果。

当选择该项后，在前面的?位移等值线?表单中点击?适用?键时，将以图形文件的方式显示结果。

以图形形式显示的剖断面图

选择剖断面时

已定义的平面

在已定义的平面中选择某一平面或用户坐标系的x-y、x-z和y-z平面。

定义剖断面

板单元的法线方向：假设剖断面平行于板单元的局部坐标系z轴。

已定义的平面：按照已定义的平面。

对折板连续输出结果：对不同平面上的板单元，用连续线连续显示各板单元的分析结果。

反转：反转图形显示的方向。

数值：在切断面图内显示结果数值。

仅输出最大/最小值：仅输出最大最小值。

当前步骤位移：显示当前步骤内发生的位移。

批量输出结果( 、 )

选择荷载工况、荷载组合以及各施工阶段的步骤，然后选择输出的内容。连续定义输出的内容后，将其保存为图形文件。

点击 [image] ，定义批量输出信息。

在定义输出信息名称时，应事先在前面的荷载工况/荷载组合中选择相应的荷载工况和荷载组合。

选择的荷载工况和荷载组合、施工阶段步骤都将保存在该信息中。

当输出的图形要包含图例时，应该在设置批量输出信息之前选择显示图例。

点击 [image] ，选择批量输出内容。

批量输出对话框

保存的菜单信息：列有在设置批量输出信息对话框中定义的输出信息。在列表中选择某信息后，点击 [image] ，可以删除该信息。

阶段：选择将输出的施工阶段。选择该项时，下面的列表中将显示各施工阶段(不显示每个阶段内的子步骤)。

PostCS荷载：选择将输出的最终施工阶段的荷载组合。选择该项时，下面的列表中将显示最终施工阶段的荷载组合。

注：当没有定义施工阶段时，下面的列表中将列出各荷载工况。

使用保存的结果：选择此项时，在上面列表中选择的荷载工况将不起作用，程序将输出保存在保存的菜单信息中的荷载工况和荷载组合信息。

阶段荷载工况/荷载组合：当定义了施工阶段时，下面的列表中将显示各施工阶段的荷载工况和荷载组合。没有定义施工阶段时，下面的列表为空白。

步骤选项

保存的步骤：选择此项时，将输出保存在保存的菜单信息中的施工阶段(在左侧列表中选择的施工阶段)的子步骤信息。

所有步骤：选择此项时，将输出在左侧列表中选择的施工阶段的所有子步骤信息。

输出选项：选择将要输出的文件的格式(BMP或EMF文件)。

输出路径：指定输出的文件保存地址的目录。

文件前缀：指定要生成的图形文件名称的前缀。文件名称的后缀则根据输出选项决定(*.bmp或*.emf)。

自动描述：在生成的图形左上端显示输出的信息内容、施工阶段、子步骤、荷载工况和荷载组合等信息。

点击 [image] ，将按设定的内容输出图形文件。点击 [image] ，可以将输出的设定内容保存成二进制文件(*.bog)。点击 [image] 可以导入该文件，按同样的格式输出其他内容的文件。


05_板剖断面内力图

Home > midas Gen 2017 > 09_结果 > 02_结果 > 03_内力 > 05_板单元切断线内力图

板剖断面内力图

  • 功 能

可以查看任意剖断面上的内力。

  • 命 令

从主菜单中选择结果 > 内力 > 板剖断面内力图

在树形菜单的菜单表单中选择分析结果 > 内力 > 板剖断面内力图

在图标菜单中单击 [image] 板剖断面内力图

  • 输 入

荷载工况/荷载组合

选择荷载工况或荷载组合。

单击右边的 [image] 输入新的或修改现有的荷载工况。(参见"荷载工况 /荷载组合")

步骤：选择输出的步骤。可以选择非线性分析的荷载步骤、施工阶段分析的各步骤、水化热分析的各步骤。

剖断面

定义剖断面。

名称：输入剖断面的名称。

P0、P1、P2 ：参照提示图形输入三点坐标，可以使用鼠标编辑功能输入坐标。

：将定义的剖断面的坐标系添加到目录中。

：编辑目录中的坐标系。

：删除目录中已经定义的坐标系。

板单元内力选项

单元：输出各单元在节点处的内力的等值线图。

节点平均值：输出具有共享节点的各单元在共享节点处的内力平均值的等值线图。

取被激活单元的节点的平均值：只输出处于被激活状态的具有共享节点的各单元在共享节点处的内力平均值的等值线图。该功能一般适用于折板，观察折板的内力时，一般需只激活在同一平面内板单元。

内力

在下列各项中选择输出的内力分量：

注:
Fij：i-力作用平面。

j-力作用方向。

(+)符号约定：力作用平面的法线方向与某单元坐标轴方向一致，且力作用方向j与单元坐标轴方向一致时为正(+)；力作用平面的法线方向与某单元坐标轴方向相反，且力作用方向j与单元坐标轴方向相反时为正(+)。

Mij：i-力作用平面。

j-与弯矩旋转方向平行的轴。

(+)符号约定：当i≠j时，按右手法则，大拇指方向与力作用平面的法线方向一致为正(+)；当i=j时，弯矩作用时板的正面(法线方向作用面)受压时为正(+)。

(a) 内力(单位板宽)输出位置

(b) 轴力和剪力(单位板宽)

(c) 弯矩和扭矩(单位板宽)

<图1> 板单元的内力作用位置及符号约定

Fxx：作用在与局部坐标系或用户坐标系x轴垂直平面内，单元局部坐标系或用户坐标系x轴方向上单位宽度轴力。

Fyy：作用在与局部坐标系或用户坐标系y轴垂直平面内，单元局部坐标系或用户坐标系y轴方向上单位宽度轴力。

Fxy：单元局部坐标系或用户坐标系的x-y平面内(平面内受剪)单位宽度剪力(Fxy=Fyx)。

Mxx：作用在与局部坐标系或用户坐标系x轴垂直平面内，绕y轴旋转的单位宽度弯矩(绕局部坐标系y轴的平面外弯矩)。

Myy：作用在与局部坐标系或用户坐标系y轴垂直平面内，绕x轴旋转的单位宽度弯矩(绕局部坐标系x轴的平面外弯矩)。

Mxy：作用在与局部坐标系或用户坐标系x轴垂直平面内，绕x轴旋转的单位宽度扭矩(Mxy=Myx)。

Vxx：作用在与局部坐标系或用户坐标系x轴垂直平面内，沿单元局部坐标系或用户坐标系z轴(厚度)方向上单位宽度的剪力。

Vyy：作用在与局部坐标系或用户坐标系y轴垂直平面内，沿单元局部坐标系或用户坐标系z轴(厚度)方向上单位宽度的剪力。

输出选项

选择内力图形输出的方向。

法向：内力图形按板的法向输出。

平面内：内力图形在板的平面内输出。

显示系数：在模型窗口中显示的内力大小比例。

反转：反向显示内力图形。

图形：按图形形式显示剖断面上的分析结果。点击右侧 [image] ，设定剖断面图形文件的显示方式并定义图形横轴。

设定剖断面图形对话框

图形显示方式：选择是将各切割线(或切割面)图分别布置在不同表单内，还是布置在一张图内。

图形横轴：定义图形横轴。可以按距离始点Pnt1的距离，也可以按整体坐标系X、或Y、或Z轴的顺序显示结果。

以图形形式显示的剖断面图

数值：在剖断面图内显示结果数值。

最小/最大值：仅输出最大最小值。

注:在板单元内力的剖断面图中的?剖断面?和 [image] 板剖断面内力图命令的差异

1) 在板单元内力对话框中将坐标系选择为单元后，在剖断面图中选择剖断线时，在与定义的剖断线相交的点(A、B、C、D)上输出单元坐标系x、y轴方向的内力，并同时输出等值线图。但是只能输出1个内力的等值线图和相交点上的内力图。

2) 在板单元内力对话框中将坐标系选择为用户后，在剖断面图中选择剖断线时，在与定义的剖断线相交的点(A、B、C、D)上输出用户坐标系x、y轴方向的内力，并同时输出等值线图。但是只能输出1个内力的等值线图和相交点上的内力图。

3) 板剖断面内力图

与上面2)中方法接近，用户可以任意设定坐标系，查看坐标系方向的内力。该功能与上述两种情况不同的是可以同时查看不同的内力，且不必事先设定用户坐标系，但不提供等值线图。


06_墙单元内力

Home > midas Gen 2017 > 09_结果 > 02_结果 > 03_内力 > 06_墙内力

墙单元内力

  • 功 能

使用等值线查看墙单元内力。

  • 命 令

    从主菜单中选择结果 > 内力 > 墙单元内力

    在树形菜单的菜单表单中选择 分析结果 > 内力 > 墙单元内力

在图标菜单中点击 [image] 墙单元内力

  • 输 入

荷载工况/荷载组合

选择准备查看的内力结果。 当需要新建或编辑荷载组合时，可点击右侧的 [image] 。(参照 荷载工况 /荷载组合)

步骤：选择输出的步骤。可以选择非线性分析的荷载步骤、施工阶段分析的各步骤、水化热分析的各步骤。

注：可在荷载>施工阶段分析数据>选择显示施工阶段或施工阶段工具条中选择将显示的施工阶段。

内力： 选择准备查看的内力分量。

Fx：单元局部坐标系x轴方向的轴力。

Fy：单元局部坐标系y轴方向的剪力。

Fz：单元局部坐标系z轴方向的剪力。

Mx：绕单元局部坐标系x轴方向的扭矩。

My：绕单元局部坐标系y轴方向的弯矩。

Mz：绕单元局部坐标系z轴方向的弯矩。

显示类型

指定显示形式如下：

等值线： 用等值线显示模型位移。

点击等值线右侧的 [image] ，弹出如下对话框。

范围：定义等值线的范围。

：指定等值线的颜色分布范围。使用该功能可为特定的区域赋以特定的颜色。点击该键，将显示如下对话框。

等值线值：列表中将显示各颜色等级代表的等值线值。颜色等级的数量为下面选择的颜色数量。

颜色数量：输入要包含在等值线中的颜色的数量(在6、12、18、24种颜色中选择)。

颜色：指定或控制等值线的颜色。

颜色表：输入颜色的变化顺序。

V->R->G->B：青紫色->红->绿->蓝。

R->G->B：红->绿->蓝。

R->B->G：红->蓝->绿。

Gray Scaled：渐变灰色。

：调整颜色变化的顺序。在此设定颜色的变化后，颜色表中的顺序将不起作用。

反转等值线图：反转等值线中颜色变化的次序。

等值线：指定等值线的边界线颜色。该项设定仅在右侧选择画等值线或单色线时才有效。

单元边界：指定单元的边界颜色。

等值线选项：选择表示等值线的方法。

填充涂色

颜色按梯度扩散：颜色渐变(模糊边界)。

画等值线：在等值线中显示彩色边界。

只显示等值线：仅用彩色等值线表现等值线图。

单色线：仅用单色线表现等值线图。

标注等值线注释：显示表示等值线范围和边界的注释。

标注间距：注释的标注间距。

快速显示等值线(用于较大的板或实体单元模型)：板或实体单元的模型较大时，使用简化的等值线，以减少显示等值线需要的时间。

扩展：表现板单元或实体单元的等值线图时，将单元局部坐标系的z轴方向为分析结果的正方向，生成三维等值线图。

注：该选项不能在变形形状中使用。也不能与消隐命令同时使用。当需要同时显示顶板束和底板束地内力(应力)时，也不能使用该选项。

放大系数：将沿单元局部坐标系的z轴方向表现的分析结果放大显示。

变形： 显示模型变形后的形状。点击变形右侧的 [image] ，弹出如下对话框。

变形图的比例：放大或缩小变形的显示比例。

变形的表现方式：选择显示变形的方式。

节点位移：只显示节点位移的变形形状。

实际变形：显示详细的变形形状，包括沿两端节点之间任意截面的变形以及梁单元的节点变形。在施工阶段分析中，为了加快速度及节省时间，只提供节点位移。

实际位移(关闭自动调整)：按实际比例显示图变形。选择该项则输入的变形图的比例将不起作用。

相对位移：将最小位移设置为0，其他节点显示相对位移。

数值： 显示位移分量的数值。数字的字型和颜色可在 [image] 显示选项中控制。

点击数值右侧的 [image] ，弹出如下对话框。

小数点以下位数：指定小数形式的数值的精确度。

指数型：数值按指数形式显示。

最大和最小值：显示最小值和最大值。

最大绝对值：显示绝对值的最大值。

最大值：仅显示最大值。

最小值：仅显示最小值。

显示范围(%)：当某需要显示的值与选定的最大值或最小值的差在规定的范围以内时，在屏幕上显示该值。

显示角度：数值的显示方向。

注：默认的小数点可在参数设置中输入。当显示方向为0时，在节点或单元右侧，水平显示数值。角度的正方向为逆时针方向，正确选择显示方向，能更清晰地看到数值。

图例：在工作窗口的右边或左边显示与分析结果有关的各种图例。

点击图例右侧的 [image] ，弹出?设定图例?对话框。

图例的位置：选择图例在模型空间的位置。

图例数值类型：选择图例中的数值类型和小数点位数。

动画：动态显示变形过程。单击 [image] ，然后单击工作窗口底部动画控制板右边的 [image] 记录。

点击动画右侧的 [image] ，弹出如下对话框。

动画模式：选择表现分析结果的动画类型。

动画显示(颜色变化)等值线：选择该项，则随着变形量的改变，变形等值线的颜色也将发生变化。

重复半个周期：按半个周期重复放映动画，即从0到最大值。一般用于表现结构的一般变形。

重复整个周期：按整个周期重复放映动画，即从0到最大值，再到0。一般用于表现结构的振动变形和屈曲变形。

制作AVI选项：输入制作AVI动画的各控制数据。

颜色：选择动画的分辨率大小。可供选择的有256色(8位)、增强色(16位)、真彩色(24位)。

：选择压缩动画文件的程序。

半周期帧数(3～300)：模拟半周期?的帧数。

每秒帧数：每秒帧数。

施工阶段选项：做施工阶段分析时，选择制作成动画的施工阶段。

施工阶段：选择该项时，在下面选择将制作成动画的施工阶段范围。

当前阶段内子步骤：选择该项时，表示将当前施工阶段各子步骤制作成动画。

变形前： 将模型的变形前形状和变形后的形状重叠显示。

模型变形前形状的显示类型可在 [image] 显示选项中控制。

镜像：通过反射面将1/2或1/4模型的分析结果展开成整个模型的结果。

点击镜像右侧的 [image] ，弹出如左图的对话框。

1/2模型的镜像：通过对称面将1/2模型的分析结果展开成整个模型的结果。

1/4模型的镜像：通过对称面将1/4模型的分析结果展开成整个模型的结果。

对称面：指定一个整体坐标系平面为对称面。

输出位置

指定墙单元内力值的输出位置。仅在选择输出数值?时，该项才会被激活。

i端：显示墙单元起始节点(N1)处的内力值。

中心：显示墙单元中点处的内力值。

j端：显示墙单元结束节点(N2)处的内力值。

最大值：将墙单元的四等分点中最大内力值，作为墙单元中心的内力输出。

全部：同时显示起始节点i、结束节点j以及中心点的内力。

墙单元局部坐标系中内力(或应力)正负号的约定

批量输出结果( 、 )

选择荷载工况、荷载组合以及各施工阶段的步骤，然后选择输出的内容。连续定义输出的内容后，将其保存为图形文件。

点击 [image] ，定义批量输出信息。

在定义?输出信息名称?时，应事先在前面的?荷载工况/荷载组合?中选择相应的荷载工况和荷载组合。

选择的荷载工况和荷载组合、施工阶段步骤都将保存在该信息中。

当输出的图形要包含图例时，应该在设置批量输出信息之前选择显示图例。

点击 [image] ，选择批量输出内容。

批量输出对话框

保存的菜单信息：列有在设置批量输出信息对话框中定义的输出信息。在列表中选择某信息后，点击 [image] ，可以删除该信息。

阶段：选择将输出的施工阶段。选择该项时，下面的列表中将显示各施工阶段(不显示每个阶段内的子步骤)。

PostCS荷载：选择将输出的最终施工阶段的荷载组合。选择该项时，下面的列表中将显示最终施工阶段的荷载组合。

注：当没有定义施工阶段时，下面的列表中将列出各荷载工况。

使用保存的结果：选择此项时，在上面列表中选择的荷载工况将不起作用，程序将输出保存在保存的菜单信息中的荷载工况和荷载组合信息。

阶段荷载工况/荷载组合：当定义了施工阶段时，下面的列表中将显示各施工阶段的荷载工况和荷载组合。没有定义施工阶段时，下面的列表为空白。

步骤选项

保存的步骤：选择此项时，将输出保存在保存的菜单信息中的施工阶段(在左侧列表中选择的施工阶段)的子步骤信息。

所有步骤：选择此项时，将输出在左侧列表中选择的施工阶段的所有子步骤信息。

输出选项：选择将要输出的文件的格式(BMP或EMF文件)。

输出路径：指定输出的文件保存地址的目录。

文件前缀：指定要生成的图形文件名称的前缀。文件名称的后缀则根据?输出选项?决定(*.bmp或*.emf)。

自动描述：在生成的图形左上端显示输出的信息内容、施工阶段、子步骤、荷载工况和荷载组合等信息。

点击 ，将按设定的内容输出图形文件。点击 ，可以将输出的设定内容保存成二进制文件(*.bog)。点击 可以导入该文件，按同样的格式输出其他内容的文件。


07_墙单元内力图

Home > midas Gen 2017 > 09_结果 > 02_结果 > 03_内力 > 07_墙图形

墙单元内力图

  • 功 能

查看墙单元的剪力图和弯矩图。

  • 命 令

从主菜单中选择结果 > 内力 > 墙单元内力图

在树形菜单的菜单表单中选择 分析结果 > 内力 > 墙单元内力图

在图标菜单中点击 [image] 墙单元内力图

  • 输 入

荷载工况/荷载组合

选择准备查看的内力结果。

当需要新建或编辑荷载组合时，可点击右侧的 [image] 。(参照荷载工况 /荷载组合)

步骤

选择输出的步骤。可以选择非线性分析的荷载步骤、施工阶段分析的各步骤、水化热分析的各步骤。

注:可在荷载>施工阶段分析数据>选择显示施工阶段或施工阶段工具条中选择将显示的施工阶段。

内力

选择准备查看的内力分量。

Fx：单元局部坐标系x轴方向的轴力。

Fy：单元局部坐标系y轴方向的剪力。

Fz：单元局部坐标系z轴方向的剪力。

Fyz：同时输出单元局部坐标系y、z轴方向的剪力。

Mx：绕单元局部坐标系x轴方向的扭矩。

My：绕单元局部坐标系y轴方向的弯矩。

Mz：绕单元局部坐标系z轴方向的弯矩。

Myz：同时输出绕单元局部坐标系y、z轴方向的弯矩

显示类型

指定显示形式如下：

等值线： 用等值线显示模型位移。

点击等值线右侧的 [image] ，弹出如下对话框。

范围：定义等值线的范围。

：指定等值线的颜色分布范围。使用该功能可为特定的区域赋以特定的颜色。点击该键，将显示如下对话框。

等值线值：列表中将显示各颜色等级代表的等值线值。颜色等级的数量为下面选择的颜色数量。

颜色数量：输入要包含在等值线中的颜色的数量(在6、12、18、24种颜色中选择)。

颜色：指定或控制等值线的颜色。

颜色表：输入颜色的变化顺序。

V->R->G->B：青紫色->红->绿->蓝。

R->G->B：红->绿->蓝。

R->B->G：红->蓝->绿。

Gray Scaled：渐变灰色。

：调整颜色变化的顺序。在此设定颜色的变化后，颜色表中的顺序将不起作用。

反转等值线图：反转等值线中颜色变化的次序。

等值线：指定等值线的边界线颜色。该项设定仅在右侧选择?画等值线?或?单色线?时才有效。

单元边界：指定单元的边界颜色。

等值线选项：选择表示等值线的方法。

填充涂色

颜色按梯度扩散：颜色渐变(模糊边界)。

画等值线：在等值线中显示彩色边界。

只显示等值线：仅用彩色等值线表现等值线图。

单色线：仅用单色线表现等值线图。

标注等值线注释：显示表示等值线范围和边界的注释。

标注间距：注释的标注间距。

快速显示等值线(用于较大的板或实体单元模型)：板或实体单元的模型较大时，使用简化的等值线，以减少显示等值线需要的时间。

扩展：表现板单元或实体单元的等值线图时，将单元局部坐标系的z轴方向为分析结果的正方向，生成三维等值线图。

注：该选项不能在变形形状中使用。也不能与消隐命令同时使用。当需要同时显示顶板束和底板束地内力(应力)时，也不能使用该选项。

放大系数：将沿单元局部坐标系的z轴方向表现的分析结果放大显示。

变形： 显示模型变形后的形状。点击?变形?右侧的 [image] ，弹出如下对话框。

变形图的比例：放大或缩小变形的显示比例。

变形的表现方式：选择显示变形的方式。

节点位移：只显示节点位移的变形形状。

实际变形：显示详细的变形形状，包括沿两端节点之间任意截面的变形以及梁单元的节点变形。在施工阶段分析中，为了加快速度及节省时间，只提供节点位移。

实际位移(关闭自动调整)：按实际比例显示图变形。选择该项则输入的变形图的比例将不起作用。

相对位移：将最小位移设置为0，其他节点显示相对位移。

数值： 显示位移分量的数值。数字的字型和颜色可在 [image] 显示选项中控制。

点击数值右侧的 [image] ，弹出如下对话框。

小数点以下位数：指定小数形式的数值的精确度。

指数型：数值按指数形式显示。

最大和最小值：显示最小值和最大值。

最大绝对值：显示绝对值的最大值。

最大值：仅显示最大值。

最小值：仅显示最小值。

显示范围(%)：当某需要显示的值与选定的最大值或最小值的差在规定的范围以内时，在屏幕上显示该值。

显示角度：数值的显示方向。

注：默认的小数点可在?参数设置?中输入。当显示方向为0时，在节点或单元右侧，水平显示数值。角度的正方向为逆时针方向，正确选择显示方向，能更清晰地看到数值。

图例：在工作窗口的右边或左边显示与分析结果有关的各种图例。

点击?图例?右侧的 [image] ，弹出?设定图例?对话框。

图例的位置：选择图例在模型空间的位置。

图例数值类型：选择图例中的数值类型和小数点位数。

动画：动态显示变形过程。单击 [image] ，然后单击工作窗口底部动画控制板右边的 [image] 记录。

点击动画右侧的 [image] ，弹出如下对话框。

动画模式：选择表现分析结果的动画类型。

动画显示(颜色变化)等值线：选择该项，则随着变形量的改变，变形等值线的颜色也将发生变化。

重复半个周期：按半个周期重复放映动画，即从0到最大值。一般用于表现结构的一般变形。

重复整个周期：按整个周期重复放映动画，即从0到最大值，再到0。一般用于表现结构的振动变形和屈曲变形。

制作AVI选项：输入制作AVI动画的各控制数据。

颜色：选择动画的分辨率大小。可供选择的有256色(8位)、增强色(16位)、真彩色(24位)。

：选择压缩动画文件的程序。

半周期帧数(3～300)：模拟?半周期?的帧数。

每秒帧数：每秒帧数。

施工阶段选项：做施工阶段分析时，选择制作成动画的施工阶段。

施工阶段：选择该项时，在下面选择将制作成动画的施工阶段范围。

当前阶段内子步骤：选择该项时，表示将当前施工阶段各子步骤制作成动画。

变形前： 将模型的变形前形状和变形后的形状重叠显示。

模型变形前形状的显示类型可在 [image] 显示选项中控制。

镜像：通过反射面将1/2或1/4模型的分析结果展开成整个模型的结果。

点击?镜像?右侧的 [image] ，弹出如左图的对话框。

1/2模型的镜像：通过对称面将1/2模型的分析结果展开成整个模型的结果。

1/4模型的镜像：通过对称面将1/4模型的分析结果展开成整个模型的结果。

对称面：指定一个整体坐标系平面为对称面。

输出位置

指定墙单元内力值的输出位置。仅在选择输出?数值?时，该项才会被激活。

i端：显示墙单元起始节点(N1)处的内力值。

中心：显示墙单元中点处的内力值。

j端：显示墙单元结束节点(N2)处的内力值。

最大值：将墙单元的四等分点中最大内力值，作为墙单元中心的内力输出。

全部：同时显示起始节点i、结束节点j以及中心点的内力。

墙单元局部坐标系中内力(或应力)正负号的约定

批量输出结果( 、 )

选择荷载工况、荷载组合以及各施工阶段的步骤，然后选择输出的内容。连续定义输出的内容后，将其保存为图形文件。

点击 [image] ，定义批量输出信息。

在定义?输出信息名称?时，应事先在前面的?荷载工况/荷载组合?中选择相应的荷载工况和荷载组合。

选择的荷载工况和荷载组合、施工阶段步骤都将保存在该信息中。

当输出的图形要包含图例时，应该在设置批量输出信息之前选择显示图例。

点击 [image] ，选择批量输出内容。

批量输出对话框

保存的菜单信息：列有在设置批量输出信息对话框中定义的输出信息。在列表中选择某信息后，点击 [image] ，可以删除该信息。

阶段：选择将输出的施工阶段。选择该项时，下面的列表中将显示各施工阶段(不显示每个阶段内的子步骤)。

PostCS荷载：选择将输出的最终施工阶段的荷载组合。选择该项时，下面的列表中将显示最终施工阶段的荷载组合。

注：当没有定义施工阶段时，下面的列表中将列出各荷载工况。

使用保存的结果：选择此项时，在上面列表中选择的荷载工况将不起作用，程序将输出保存在保存的菜单信息中的荷载工况和荷载组合信息。

阶段荷载工况/荷载组合：当定义了施工阶段时，下面的列表中将显示各施工阶段的荷载工况和荷载组合。没有定义施工阶段时，下面的列表为空白。

步骤选项

保存的步骤：选择此项时，将输出保存在保存的菜单信息中的施工阶段(在左侧列表中选择的施工阶段)的子步骤信息。

所有步骤：选择此项时，将输出在左侧列表中选择的施工阶段的所有子步骤信息。

输出选项：选择将要输出的文件的格式(BMP或EMF文件)。

输出路径：指定输出的文件保存地址的目录。

文件前缀：指定要生成的图形文件名称的前缀。文件名称的后缀则根据输出选项决定(*.bmp或*.emf)。

自动描述：在生成的图形左上端显示输出的信息内容、施工阶段、子步骤、荷载工况和荷载组合等信息。

点击 ，将按设定的内容输出图形文件。点击 ，可以将输出的设定内容保存成二进制文件(*.bog)。点击 可以导入该文件，按同样的格式输出其他内容的文件。


08_构件内力图

Home > midas Gen 2017 > 09_结果 > 02_结果 > 03_内力 > 08_构件图形

构件内力图

  • 功 能

查看在各荷载工况下的构件(柱,梁,支撑,剪力墙)的轴力，剪力，弯矩。

  • 命 令

从主菜单中选择结果 > 内力 > 构件内力图

在树形菜单的菜单表单中选择 分析结果 > 内力 > 构件内力图

  • 输 入

荷载工况/荷载组合

选择准备查看的荷载工况和荷载组合。

当需要新建或编辑荷载组合时，可点击右侧的 [image] 。(参照荷载工况 /荷载组合)

步骤

选择输出分析结果的步骤。可以选择非线性分析的荷载步骤、施工阶段分析的各步骤、水化热分析的各步骤。

注:可在荷载>施工阶段分析数据>选择显示施工阶段或施工阶段工具条中选择将显示的施工阶段。

选择平面：选择需要输出构件内力图的平面或层

已命名的平面：选择指定平面

层：选择指定层

新输入平面名称或修改时，可点击右侧的 [image] 。（参照已命名的平面）

构件类型：选择要输出构件内力图的构件，如梁（柱以外的梁单元），柱（与整体坐标系Ｚ轴平行的梁单元），支撑（与整体坐标系Ｚ轴斜交的单元），墙（墙单元）。

显示类型

指定显示形式如下：

构件：按构件输出荷载

单元：按单元输出荷载

数值：

轴力： 轴力的输出与否以及制指定轴力的颜色

剪力： 剪力的输出与否以及指定剪力的颜色

弯矩： 弯矩的输出与否以及指定弯矩的颜色

小数点位数：要显示的小数点位数

指数型：是否要显示成指数形式

图例：在工作窗口的右边或左边显示与分析结果有关的各种图例。

显示图形

指定构件的构件内力图类型

成分：

轴力：轴力图显示为构件内力图

剪力：剪力图显示为构件内力图

弯矩：弯矩图显示为构件内力图

不涂色：构件内力图只是用外轮廓线表示

线涂色：构件内力图按线填充

实体涂色：构件内力图按面填充

系数： 指定构件内力图的画图比例

批量输出结果( 、 )

选择荷载工况、荷载组合以及各施工阶段的步骤，然后选择输出的内容。连续定义输出的内容后，将其保存为图形文件。

点击 [image] ，定义批量输出信息。

在定义输出信息名称时，应事先在前面的荷载工况/荷载组合中选择相应的荷载工况和荷载组合。

选择的荷载工况和荷载组合、施工阶段步骤都将保存在该信息中。

当输出的图形要包含图例时，应该在设置批量输出信息之前选择显示图例。

点击 [image] ，选择批量输出内容。

批量输出对话框

保存的菜单信息：列有在设置批量输出信息对话框中定义的输出信息。在列表中选择某信息后，点击 [image] ，可以删除该信息。

阶段：选择将输出的施工阶段。选择该项时，下面的列表中将显示各施工阶段(不显示每个阶段内的子步骤)。

PostCS荷载：选择将输出的最终施工阶段的荷载组合。选择该项时，下面的列表中将显示最终施工阶段的荷载组合。

注：当没有定义施工阶段时，下面的列表中将列出各荷载工况。

使用保存的结果：选择此项时，在上面列表中选择的荷载工况将不起作用，程序将输出保存在保存的菜单信息中的荷载工况和荷载组合信息。

阶段荷载工况/荷载组合：当定义了施工阶段时，下面的列表中将显示各施工阶段的荷载工况和荷载组合。没有定义施工阶段时，下面的列表为空白。

步骤选项

保存的步骤：选择此项时，将输出保存在保存的菜单信息中的施工阶段(在左侧列表中选择的施工阶段)的子步骤信息。

所有步骤：选择此项时，将输出在左侧列表中选择的施工阶段的所有子步骤信息。

输出选项：选择将要输出的文件的格式(BMP或EMF文件)。

输出路径：指定输出的文件保存地址的目录。

文件前缀：指定要生成的图形文件名称的前缀。文件名称的后缀则根据输出选项决定(*.bmp或*.emf)。

自动描述：在生成的图形左上端显示输出的信息内容、施工阶段、子步骤、荷载工况和荷载组合等信息。

点击 [image] ，将按设定的内容输出图形文件。点击 [image] ，可以将输出的设定内容保存成二进制文件(*.bog)。点击 [image] 可以导入该文件，按同样的格式输出其他内容的文件。


01_桁架单元应力

Home > midas Gen 2017 > 09_结果 > 02_结果 > 04_应力 > 01_桁架应力

桁架单元应力

  • 功 能

用等值线查看桁架单元、只受拉单元、索单元、钩单元、只受压单元、间隙单元的轴向应力。

  • 命 令

从主菜单中选择结果 > 应力 >桁架单元应力

在树形菜单的菜单表单中选择分析结果 > 应力 >桁架单元应力

在图标菜单中单击 [image] 桁架单元应力

  • 用 法

荷载工况/荷载组合

选择荷载工况或荷载组合。

单击右边的 [image] 输入新的或修改现有的荷载工况。(参见?荷载工况 /荷载组合?)

步骤：选择输出的步骤。可以选择非线性分析的荷载步骤、施工阶段分析的各步骤、水化热分析的各步骤。

选择内力

选择输出的应力形式。

全部：显示所有桁架单元的应力。

受拉：只显示受拉构件的应力。

受压：只显示受压构件的应力。

显示类型

指定显示形式如下：

等值线： 用等值线显示模型位移。

点击等值线右侧的 [image] ，弹出如下对话框。

范围：定义等值线的范围。

：指定等值线的颜色分布范围。使用该功能可为特定的区域赋以特定的颜色。点击该键，将显示如下对话框。

等值线值：列表中将显示各颜色等级代表的等值线值。颜色等级的数量为下面选择的颜色数量。

颜色数量：输入要包含在等值线中的颜色的数量(在6、12、18、24种颜色中选择)。

颜色：指定或控制等值线的颜色。

颜色表：输入颜色的变化顺序。

V->R->G->B：青紫色->红->绿->蓝。

R->G->B：红->绿->蓝。

R->B->G：红->蓝->绿。

Gray Scaled：渐变灰色。

：调整颜色变化的顺序。在此设定颜色的变化后，颜色表中的顺序将不起作用。

反转等值线图：反转等值线中颜色变化的次序。

等值线：指定等值线的边界线颜色。该项设定仅在右侧选择?画等值线?或?单色线?时才有效。

单元边界：指定单元的边界颜色。

等值线选项：选择表示等值线的方法。

填充涂色

颜色按梯度扩散：颜色渐变(模糊边界)。

画等值线：在等值线中显示彩色边界。

只显示等值线：仅用彩色等值线表现等值线图。

单色线：仅用单色线表现等值线图。

标注等值线注释：显示表示等值线范围和边界的注释。

标注间距：注释的标注间距。

快速显示等值线(用于较大的板或实体单元模型)：板或实体单元的模型较大时，使用简化的等值线，以减少显示等值线需要的时间。

扩展：表现板单元或实体单元的等值线图时，将单元局部坐标系的z轴方向为分析结果的正方向，生成三维等值线图。

注：该选项不能在变形形状中使用。也不能与消隐命令同时使用。当需要同时显示顶板束和底板束地内力(应力)时，也不能使用该选项。

放大系数：将沿单元局部坐标系的z轴方向表现的分析结果放大显示。

变形： 显示模型变形后的形状。点击?变形?右侧的 [image] ，弹出如下对话框。

变形图的比例：放大或缩小变形的显示比例。

变形的表现方式：选择显示变形的方式。

节点位移：只显示节点位移的变形形状。

实际变形：显示详细的变形形状，包括沿两端节点之间任意截面的变形以及梁单元的节点变形。在施工阶段分析中，为了加快速度及节省时间，只提供节点位移。

实际位移(关闭自动调整)：按实际比例显示图变形。选择该项则输入的变形图的比例将不起作用。

相对位移：将最小位移设置为0，其他节点显示相对位移。

数值： 显示位移分量的数值。数字的字型和颜色可在 [image] 显示选项中控制。

点击数值右侧的 [image] ，弹出如下对话框。

小数点以下位数：指定小数形式的数值的精确度。

指数型：数值按指数形式显示。

最大和最小值：显示最小值和最大值。

最大绝对值：显示绝对值的最大值。

最大值：仅显示最大值。

最小值：仅显示最小值。

显示范围(%)：当某需要显示的值与选定的最大值或最小值的差在规定的范围以内时，在屏幕上显示该值。

显示角度：数值的显示方向。

注：默认的小数点可在?参数设置?中输入。当显示方向为0时，在节点或单元右侧，水平显示数值。角度的正方向为逆时针方向，正确选择显示方向，能更清晰地看到数值。

图例：在工作窗口的右边或左边显示与分析结果有关的各种图例。

点击图例右侧的 [image] ，弹出设定图例对话框。

图例的位置：选择图例在模型空间的位置。

图例数值类型：选择图例中的数值类型和小数点位数。

动画：动态显示变形过程。单击 [image] ，然后单击工作窗口底部动画控制板右边的 [image] 记录。

点击动画右侧的 [image] ，弹出如下对话框。

动画模式：选择表现分析结果的动画类型。

动画显示(颜色变化)等值线：选择该项，则随着变形量的改变，变形等值线的颜色也将发生变化。

重复半个周期：按半个周期重复放映动画，即从0到最大值。一般用于表现结构的一般变形。

重复整个周期：按整个周期重复放映动画，即从0到最大值，再到0。一般用于表现结构的振动变形和屈曲变形。

制作AVI选项：输入制作AVI动画的各控制数据。

颜色：选择动画的分辨率大小。可供选择的有256色(8位)、增强色(16位)、真彩色(24位)。

：选择压缩动画文件的程序。

半周期帧数(3～300)：模拟半周期的帧数。

每秒帧数：每秒帧数。

施工阶段选项：做施工阶段分析时，选择制作成动画的施工阶段。

施工阶段：选择该项时，在下面选择将制作成动画的施工阶段范围。

当前阶段内子步骤：选择该项时，表示将当前施工阶段各子步骤制作成动画。

变形前： 将模型的变形前形状和变形后的形状重叠显示。

模型变形前形状的显示类型可在 [image] 显示选项中控制。

镜像：通过反射面将1/2或1/4模型的分析结果展开成整个模型的结果。

点击?镜像?右侧的 [image] ，弹出如左图的对话框。

1/2模型的镜像：通过对称面将1/2模型的分析结果展开成整个模型的结果。

1/4模型的镜像：通过对称面将1/4模型的分析结果展开成整个模型的结果。

对称面：指定一个整体坐标系平面为对称面。

屈服点：显示屈服点。

数值的输出位置

指定输出桁架单元内力值的截面的位置。仅在选择输出?数值?时，该项才会被激活。

i：显示桁架单元起始节点(N1)处的内力值。

j：显示桁架单元结束节点(N2)处的内力值。

最大值：将桁架单元的四等分点中最大轴力值，作为桁架单元中心的轴力输出。

全部：同时显示起始节点i、结束节点j以及最大轴力。

桁架单元局部坐标系中内力(或应力)正负号的约定

批量输出结果( 、 )

选择荷载工况、荷载组合以及各施工阶段的步骤，然后选择输出的内容。连续定义输出的内容后，将其保存为图形文件。

点击 [image] ，定义批量输出信息。

在定义输出信息名称时，应事先在前面的荷载工况/荷载组合中选择相应的荷载工况和荷载组合。

选择的荷载工况和荷载组合、施工阶段步骤都将保存在该信息中。

当输出的图形要包含图例时，应该在设置批量输出信息之前选择显示图例。

点击 [image] ，选择批量输出内容。

批量输出对话框

保存的菜单信息：列有在设置批量输出信息对话框中定义的输出信息。在列表中选择某信息后，点击 [image] ，可以删除该信息。

阶段：选择将输出的施工阶段。选择该项时，下面的列表中将显示各施工阶段(不显示每个阶段内的子步骤)。

PostCS荷载：选择将输出的最终施工阶段的荷载组合。选择该项时，下面的列表中将显示最终施工阶段的荷载组合。

注：当没有定义施工阶段时，下面的列表中将列出各荷载工况。

使用保存的结果：选择此项时，在上面列表中选择的荷载工况将不起作用，程序将输出保存在保存的菜单信息中的荷载工况和荷载组合信息。

阶段荷载工况/荷载组合：当定义了施工阶段时，下面的列表中将显示各施工阶段的荷载工况和荷载组合。没有定义施工阶段时，下面的列表为空白。

步骤选项

保存的步骤：选择此项时，将输出保存在保存的菜单信息中的施工阶段(在左侧列表中选择的施工阶段)的子步骤信息。

所有步骤：选择此项时，将输出在左侧列表中选择的施工阶段的所有子步骤信息。

输出选项：选择将要输出的文件的格式(BMP或EMF文件)。

输出路径：指定输出的文件保存地址的目录。

文件前缀：指定要生成的图形文件名称的前缀。文件名称的后缀则根据输出选项决定(*.bmp或*.emf)。

自动描述：在生成的图形左上端显示输出的信息内容、施工阶段、子步骤、荷载工况和荷载组合等信息。

点击 [image] ，将按设定的内容输出图形文件。点击 [image] ，可以将输出的设定内容保存成二进制文件(*.bog)。点击 [image] 可以导入该文件，按同样的格式输出其他内容的文件。


02_梁单元应力

Home > midas Gen 2017 > 09_结果 > 02_结果 > 04_应力 > 02_梁单元应力

梁单元应力

  • 功 能

用等值线查看梁单元(一般梁、变截面梁等)的应力。

  • 命 令

从主菜单中选择结果 > 应力 > 梁单元应力

在树形菜单的菜单表单中选择分析结果 > 应力 > 梁单元应力

在图标菜单中单击 [image] 梁单元应力

  • 输 入

荷载工况/荷载组合

选择荷载工况或荷载组合。单击右边的 [image] 输入新的或修改现有的荷载工况。(参见? 荷载工况 /荷载组合?)

步骤：选择输出的步骤。可以选择非线性分析的荷载步骤、施工阶段分析的各步骤、水化热分析的各步骤。

应力

在下列各项中选择输出应力分量。

Sax：单元局部坐标系x轴方向的轴向应力。

Ssy：单元局部坐标系y轴方向的剪应力。

Ssz：单元局部坐标系z轴方向的剪应力。

Sby：在单元局部坐标系下由绕z轴的弯曲引起的沿y方向变化的弯曲应力。

Sbz：在单元局部坐标系下由绕y轴的弯曲引起的沿z方向变化的弯曲应力。

组合应力：轴力产生的应力加上两个方向弯矩产生的应力(Sax+Sby+Sbz)。

最大值：在1、2、3、4位置中组合应力的最大值。

1、2、3、4：( )内y和z表示所处的位置，如1(-y, z)表示1号点位置在-y、+z位置。

注：只有在定义截面时，输入有计算梁单元的应力所需的数据(或程序可以自动计算出相应数据)时，程序才提供梁单元的计算结果，反之不提供应力计算结果(为0值)。例如：当在截面中按用户定义输入刚度时，只输入有面积、惯性矩时，程序不能获得相应应力计算信息(如截面高度y值)，所以不能提供应力值。

显示类型

指定显示形式如下：

等值线： 用等值线显示模型位移。

点击等值线右侧的 [image] ，弹出如下对话框。

范围：定义等值线的范围。

：指定等值线的颜色分布范围。使用该功能可为特定的区域赋以特定的颜色。点击该键，将显示如下对话框。

等值线值：列表中将显示各颜色等级代表的等值线值。颜色等级的数量为下面选择的颜色数量。

颜色数量：输入要包含在等值线中的颜色的数量(在6、12、18、24种颜色中选择)。

颜色：指定或控制等值线的颜色。

颜色表：输入颜色的变化顺序。

V->R->G->B：青紫色->红->绿->蓝。

R->G->B：红->绿->蓝。

R->B->G：红->蓝->绿。

Gray Scaled：渐变灰色。

：调整颜色变化的顺序。在此设定颜色的变化后，颜色表中的顺序将不起作用。

反转等值线图：反转等值线中颜色变化的次序。

等值线：指定等值线的边界线颜色。该项设定仅在右侧选择画等值线或单色线时才有效。

单元边界：指定单元的边界颜色。

等值线选项：选择表示等值线的方法。

填充涂色

颜色按梯度扩散：颜色渐变(模糊边界)。

画等值线：在等值线中显示彩色边界。

只显示等值线：仅用彩色等值线表现等值线图。

单色线：仅用单色线表现等值线图。

标注等值线注释：显示表示等值线范围和边界的注释。

标注间距：注释的标注间距。

快速显示等值线(用于较大的板或实体单元模型)：板或实体单元的模型较大时，使用简化的等值线，以减少显示等值线需要的时间。

扩展：表现板单元或实体单元的等值线图时，将单元局部坐标系的z轴方向为分析结果的正方向，生成三维等值线图。

注：该选项不能在变形形状中使用。也不能与消隐命令同时使用。当需要同时显示顶板束和底板束地内力(应力)时，也不能使用该选项。

放大系数：将沿单元局部坐标系的z轴方向表现的分析结果放大显示。

变形： 显示模型变形后的形状。点击变形右侧的 [image] ，弹出如下对话框。

变形图的比例：放大或缩小变形的显示比例。

变形的表现方式：选择显示变形的方式。

节点位移：只显示节点位移的变形形状。

实际变形：显示详细的变形形状，包括沿两端节点之间任意截面的变形以及梁单元的节点变形。在施工阶段分析中，为了加快速度及节省时间，只提供节点位移。

实际位移(关闭自动调整)：按实际比例显示图变形。选择该项则输入的变形图的比例将不起作用。

相对位移：将最小位移设置为0，其他节点显示相对位移。

数值： 显示位移分量的数值。数字的字型和颜色可在 [image] 显示选项中控制。

点击数值右侧的 [image] ，弹出如下对话框。

小数点以下位数：指定小数形式的数值的精确度。

指数型：数值按指数形式显示。

最大和最小值：显示最小值和最大值。

最大绝对值：显示绝对值的最大值。

最大值：仅显示最大值。

最小值：仅显示最小值。

显示范围(%)：当某需要显示的值与选定的最大值或最小值的差在规定的范围以内时，在屏幕上显示该值。

显示角度：数值的显示方向。

注：默认的小数点可在参数设置中输入。当显示方向为0时，在节点或单元右侧，水平显示数值。角度的正方向为逆时针方向，正确选择显示方向，能更清晰地看到数值。

图例：在工作窗口的右边或左边显示与分析结果有关的各种图例。

点击图例右侧的 [image] ，弹出设定图例对话框。

图例的位置：选择图例在模型空间的位置。

图例数值类型：选择图例中的数值类型和小数点位数。

动画：动态显示变形过程。单击 [image] ，然后单击工作窗口底部动画控制板右边的 [image] 记录。

点击动画右侧的 [image] ，弹出如下对话框。

动画模式：选择表现分析结果的动画类型。

动画显示(颜色变化)等值线：选择该项，则随着变形量的改变，变形等值线的颜色也将发生变化。

重复半个周期：按半个周期重复放映动画，即从0到最大值。一般用于表现结构的一般变形。

重复整个周期：按整个周期重复放映动画，即从0到最大值，再到0。一般用于表现结构的振动变形和屈曲变形。

制作AVI选项：输入制作AVI动画的各控制数据。

颜色：选择动画的分辨率大小。可供选择的有256色(8位)、增强色(16位)、真彩色(24位)。

：选择压缩动画文件的程序。

半周期帧数(3～300)：模拟半周期的帧数。

每秒帧数：每秒帧数。

施工阶段选项：做施工阶段分析时，选择制作成动画的施工阶段。

施工阶段：选择该项时，在下面选择将制作成动画的施工阶段范围。

当前阶段内子步骤：选择该项时，表示将当前施工阶段各子步骤制作成动画。

变形前： 将模型的变形前形状和变形后的形状重叠显示。

模型变形前形状的显示类型可在 [image] 显示选项中控制。

镜像：通过反射面将1/2或1/4模型的分析结果展开成整个模型的结果。

点击?镜像?右侧的 [image] ，弹出如左图的对话框。

1/2模型的镜像：通过对称面将1/2模型的分析结果展开成整个模型的结果。

1/4模型的镜像：通过对称面将1/4模型的分析结果展开成整个模型的结果。

对称面：指定一个整体坐标系平面为对称面。

输出位置

指定梁单元内力值的输出位置。仅在选择输出"数值"时，该项才会被激活。

i端：显示梁单元起始节点(N1)处的内力值。

中心：显示梁单元中点处的内力值。

j端：显示梁单元结束节点(N2)处的内力值。

最大值：将梁单元的四等分点中最大内力值，作为梁单元中心的内力输出。

全部：同时显示起始节点i、结束节点j以及中心点的内力。

梁单元局部坐标系中内力(或应力)正负号的约定

批量输出结果( 、 )

选择荷载工况、荷载组合以及各施工阶段的步骤，然后选择输出的内容。连续定义输出的内容后，将其保存为图形文件。

点击 [image] ，定义批量输出信息。

在定义输出信息名称时，应事先在前面的?荷载工况/荷载组合?中选择相应的荷载工况和荷载组合。

选择的荷载工况和荷载组合、施工阶段步骤都将保存在该信息中。

当输出的图形要包含图例时，应该在设置批量输出信息之前选择显示图例。

点击 [image] ，选择批量输出内容。

批量输出对话框

保存的菜单信息：列有在?设置批量输出信息?对话框中定义的输出信息。在列表中选择某信息后，点击 [image] ，可以删除该信息。

阶段：选择将输出的施工阶段。选择该项时，下面的列表中将显示各施工阶段(不显示每个阶段内的子步骤)。

PostCS荷载：选择将输出的最终施工阶段的荷载组合。选择该项时，下面的列表中将显示最终施工阶段的荷载组合。

注：当没有定义施工阶段时，下面的列表中将列出各荷载工况。

使用保存的结果：选择此项时，在上面列表中选择的荷载工况将不起作用，程序将输出保存在保存的菜单信息中的荷载工况和荷载组合信息。

阶段荷载工况/荷载组合：当定义了施工阶段时，下面的列表中将显示各施工阶段的荷载工况和荷载组合。没有定义施工阶段时，下面的列表为空白。

步骤选项

保存的步骤：选择此项时，将输出保存在保存的菜单信息中的施工阶段(在左侧列表中选择的施工阶段)的子步骤信息。

所有步骤：选择此项时，将输出在左侧列表中选择的施工阶段的所有子步骤信息。

输出选项：选择将要输出的文件的格式(BMP或EMF文件)。

输出路径：指定输出的文件保存地址的目录。

文件前缀：指定要生成的图形文件名称的前缀。文件名称的后缀则根据输出选项决定(*.bmp或*.emf)。

自动描述：在生成的图形左上端显示输出的信息内容、施工阶段、子步骤、荷载工况和荷载组合等信息。

点击 [image] ，将按设定的内容输出图形文件。点击 [image] ，可以将输出的设定内容保存成二进制文件(*.bog)。点击 [image] 可以导入该文件，按同样的格式输出其他内容的文件。


03_梁单元应力图

Home > midas Gen 2017 > 09_结果 > 02_结果 > 04_应力 > 03_梁单元应力图

梁单元应力图

  • 功 能

查看梁单元(一般梁、变截面梁等)的应力图。

  • 命 令

从主菜单中选择结果 > 应力 > 梁单元应力图

在树形菜单的菜单表单中选择分析结果 > 应力 > 梁单元应力图

  • 输 入

荷载工况/荷载组合

选择荷载工况或荷载组合。单击右边的 [image] 输入新的或修改现有的荷载工况。(参见" 荷载工况 /荷载组合")

步骤：选择输出的步骤。可以选择非线性分析的荷载步骤、施工阶段分析的各步骤、水化热分析的各步骤。

应力

在下列各项中选择输出应力分量。

Sax：单元局部坐标系x轴方向的轴向应力。

Ssy：单元局部坐标系y轴方向的剪应力。

Ssz：单元局部坐标系z轴方向的剪应力。

Sby：在单元局部坐标系下由绕z轴的弯曲引起的沿y方向变化的弯曲应力。

Sbz：在单元局部坐标系下由绕y轴的弯曲引起的沿z方向变化的弯曲应力。

组合应力：轴力产生的应力加上两个方向弯矩产生的应力(Sax+Sby+Sbz)。

最大值：在1、2、3、4位置中组合应力的最大值。

1、2、3、4：( )内y和z表示所处的位置，如1(-y, z)表示1号点位置在-y、+z位置。

注：只有在定义截面时，输入有计算梁单元的应力所需的数据(或程序可以自动计算出相应数据)时，程序才提供梁单元的计算结果，反之不提供应力计算结果(为0值)。例如：当在截面中按用户定义输入刚度时，只输入有面积、惯性矩时，程序不能获得相应应力计算信息(如截面高度y值)，所以不能提供应力值。

显示选项

比例系数：显示时的比例系数。

填充方式

不填充：无填充颜色。

线涂色：对线单元以填充颜色显示。

实涂色：对实体单元以填充颜色显示。

注：其余的可参见结果>应力>梁单元应力。


04_平面应力单元/板单元应力

Home > midas Gen 2017 > 09_结果 > 02_结果 > 04_应力 > 04_平面应力/板单元应力

平面应力单元/板单元应力

  • 功 能

用等值线查看平面应力单元或板单元的应力。

  • 命 令

从主菜单中选择结果 > 应力 > 平面应力单元/板单元应力

在树形菜单的菜单表单中选择分析结果 > 应力 > 平面应力单元/板应力单元

在图标菜单中单击 [image] 平面应力单元/板单元的应力

  • 输 入

荷载工况/荷载组合

选择荷载工况或荷载组合。

单击右边的 [image] 输入新的或修改现有的荷载工况。(参见"荷载工况 /荷载组合")

步骤：选择输出的步骤。可以选择非线性分析的荷载步骤、施工阶段分析的各步骤、水化热分析的各步骤。

应力选项

单元坐标系：

显示单元坐标系方向的应力。

UCS：

显示用户坐标系方向的应力。用户坐标系可以是整体坐标系，也可以是用户定义的坐标系。

单元

用单元各节点的应力显示等值线。

节点的平均值

用共享节点的各单元在共享节点位置的平均节点应力显示等值线。

取被激活单元的节点的平均值

取当前被激活单元在共享节点的应力平均值显示等高线。

板顶

显示板单元顶面处的应力。顶面指单元局部坐标系z方向最上边缘处。

板底

显示板单元底面处的应力。底面指单元局部坐标系z方向最下边缘处。

板顶、板底

同时显示顶面和底面处的应力。板单元厚度方向的应力按线性内插取得。

绝对最大值

仅显示顶面和底面处的应力的最大绝对值。

应力

在下列各项中选择应力分量。

在整体坐标系中

Sig-XX：整体坐标系X轴方向的轴向应力。

Sig-YY：整体坐标系Y轴方向的轴向应力。

Sig-ZZ：整体坐标系Z轴方向的轴向应力。

Sig-XY：整体坐标系X-Y平面内的剪应力。

Sig-YZ：整体坐标系Y-Z平面内的剪应力。

Sig-XZ：整体坐标系X-Z平面内的剪应力。

Sig-Max：最大主应力。

Sig-Min：最小主应力。

Sig-EFF：有效应力(von-Mises 应力)。

在单元坐标系中

Sig-xx：在单元局部坐标系x方向的轴向应力(垂直于局部坐标系y-z平面)

Sig - yy：在单元局部坐标系y方向的轴向应力(垂直于局部坐标系x-z平面)

Sig - xy：单元局部坐标系x-y平面内的剪应力(平面内剪应力)

Vector：用矢量显示最大和最小主应力。

系数：矢量图的绘制比例。

显示类型

指定显示形式如下：

等值线： 用等值线显示模型位移。

点击等值线右侧的 [image] ，弹出如下对话框。

范围：定义等值线的范围。

：指定等值线的颜色分布范围。使用该功能可为特定的区域赋以特定的颜色。点击该键，将显示如下对话框。

等值线值：列表中将显示各颜色等级代表的等值线值。颜色等级的数量为下面选择的颜色数量。

颜色数量：输入要包含在等值线中的颜色的数量(在6、12、18、24种颜色中选择)。

颜色：指定或控制等值线的颜色。

颜色表：输入颜色的变化顺序。

V->R->G->B：青紫色->红->绿->蓝。

R->G->B：红->绿->蓝。

R->B->G：红->蓝->绿。

Gray Scaled：渐变灰色。

：调整颜色变化的顺序。在此设定颜色的变化后，颜色表中的顺序将不起作用。

反转等值线图：反转等值线中颜色变化的次序。

等值线：指定等值线的边界线颜色。该项设定仅在右侧选择画等值线或单色线时才有效。

单元边界：指定单元的边界颜色。

等值线选项：选择表示等值线的方法。

填充涂色

颜色按梯度扩散：颜色渐变(模糊边界)。

画等值线：在等值线中显示彩色边界。

只显示等值线：仅用彩色等值线表现等值线图。

单色线：仅用单色线表现等值线图。

标注等值线注释：显示表示等值线范围和边界的注释。

标注间距：注释的标注间距。

快速显示等值线(用于较大的板或实体单元模型)：板或实体单元的模型较大时，使用简化的等值线，以减少显示等值线需要的时间。

扩展：表现板单元或实体单元的等值线图时，将单元局部坐标系的z轴方向为分析结果的正方向，生成三维等值线图。

注：该选项不能在变形形状中使用。也不能与消隐命令同时使用。当需要同时显示顶板束和底板束地内力(应力)时，也不能使用该选项。

放大系数：将沿单元局部坐标系的z轴方向表现的分析结果放大显示。

变形： 显示模型变形后的形状。点击变形右侧的 [image] ，弹出如下对话框。

变形图的比例：放大或缩小变形的显示比例。

变形的表现方式：选择显示变形的方式。

节点位移：只显示节点位移的变形形状。

实际变形：显示详细的变形形状，包括沿两端节点之间任意截面的变形以及梁单元的节点变形。在施工阶段分析中，为了加快速度及节省时间，只提供节点位移。

实际位移(关闭自动调整)：按实际比例显示图变形。选择该项则输入的变形图的比例将不起作用。

相对位移：将最小位移设置为0，其他节点显示相对位移。

数值： 显示位移分量的数值。数字的字型和颜色可在 [image] 显示选项中控制。

点击数值右侧的 [image] ，弹出如下对话框。

小数点以下位数：指定小数形式的数值的精确度。

指数型：数值按指数形式显示。

最大和最小值：显示最小值和最大值。

最大绝对值：显示绝对值的最大值。

最大值：仅显示最大值。

最小值：仅显示最小值。

显示范围(%)：当某需要显示的值与选定的最大值或最小值的差在规定的范围以内时，在屏幕上显示该值。

显示角度：数值的显示方向。

注：默认的小数点可在参数设置中输入。当显示方向为0时，在节点或单元右侧，水平显示数值。角度的正方向为逆时针方向，正确选择显示方向，能更清晰地看到数值。

图例：在工作窗口的右边或左边显示与分析结果有关的各种图例。

点击图例右侧的 [image] ，弹出?设定图例?对话框。

图例的位置：选择图例在模型空间的位置。

图例数值类型：选择图例中的数值类型和小数点位数。

动画：动态显示变形过程。单击 [image] ，然后单击工作窗口底部动画控制板右边的 [image] 记录。

点击动画右侧的 [image] ，弹出如下对话框。

动画模式：选择表现分析结果的动画类型。

动画显示(颜色变化)等值线：选择该项，则随着变形量的改变，变形等值线的颜色也将发生变化。

重复半个周期：按半个周期重复放映动画，即从0到最大值。一般用于表现结构的一般变形。

重复整个周期：按整个周期重复放映动画，即从0到最大值，再到0。一般用于表现结构的振动变形和屈曲变形。

制作AVI选项：输入制作AVI动画的各控制数据。

颜色：选择动画的分辨率大小。可供选择的有256色(8位)、增强色(16位)、真彩色(24位)。

：选择压缩动画文件的程序。

半周期帧数(3～300)：模拟半周期的帧数。

每秒帧数：每秒帧数。

施工阶段选项：做施工阶段分析时，选择制作成动画的施工阶段。

施工阶段：选择该项时，在下面选择将制作成动画的施工阶段范围。

当前阶段内子步骤：选择该项时，表示将当前施工阶段各子步骤制作成动画。

变形前： 将模型的变形前形状和变形后的形状重叠显示。

模型变形前形状的显示类型可在 [image] 显示选项中控制。

镜像：通过反射面将1/2或1/4模型的分析结果展开成整个模型的结果。

点击镜像右侧的 [image] ，弹出如左图的对话框。

1/2模型的镜像：通过对称面将1/2模型的分析结果展开成整个模型的结果。

1/4模型的镜像：通过对称面将1/4模型的分析结果展开成整个模型的结果。

对称面：指定一个整体坐标系平面为对称面。

剖断面 ：剖断线或剖断面上板单元的位移。

点击剖断面右侧的

设定剖断方式

剖断线：沿剖断线生成位移(或内力、应力)图形。

剖断面：生成沿与剖断面相交的面的位移(或内力、应力)图形。

选择剖断线时

已定义的剖断线

已定义的剖断线列表。

：在已定义的剖断线列表中添加新的剖断线。

：在已定义的剖断线列表中删除已定义的剖断线。

：修改已定义的剖断线。

定义剖断线

定义一条剖断线。

名称：剖断线的名称。

Pnt1：剖断线的起点。

Pnt2：剖断线的终点。

选项

指定显示结果的平面和颜色，在该平面上生成图形。

法向：在板单元的法线方向生成图形。

平面内：在板单元的平面内方向显示图形

放大系数：指定输出结果显示的比例。

反转：反转图形显示的方向。

数值：在切断面图内显示结果数值。

仅输出最大/最小值：仅输出最大最小值。

图形：按图形形式显示剖断线上的分析结果。点击右侧 [image] ，设定剖断线图形文件的显示方式并定义图形横轴。

设定剖断线图形对话框

图形显示方式：选择是将各切割线(或切割面)图分别布置在不同表单内，还是布置在一张图内。

图形横轴：定义图形横轴。可以按距离始点Pnt1的距离，也可以按整体坐标系X、或Y、或Z轴的顺序显示结果。

当选择该项后，在前面的位移等值线表单中点击适用键时，将以图形文件的方式显示结果。

以图形形式显示的剖断面图

选择剖断面时

已定义的平面

在已定义的平面中选择某一平面或用户坐标系的x-y、x-z和y-z平面。

定义剖断面

板单元的法线方向：假设剖断面平行于板单元的局部坐标系z轴。

已定义的平面：按照已定义的平面。

对折板连续输出结果：对不同平面上的板单元，用连续线连续显示各板单元的分析结果。

反转：反转图形显示的方向。

数值：在切断面图内显示结果数值。

仅输出最大/最小值：仅输出最大最小值。

数值选项

最大值：显示单元的各角点值的最大值。

单元中心值：显示单元中心的。

批量输出结果( 、 )

选择荷载工况、荷载组合以及各施工阶段的步骤，然后选择输出的内容。连续定义输出的内容后，将其保存为图形文件。

点击 [image] ，定义批量输出信息。

在定义输出信息名称时，应事先在前面的荷载工况/荷载组合中选择相应的荷载工况和荷载组合。

选择的荷载工况和荷载组合、施工阶段步骤都将保存在该信息中。

当输出的图形要包含图例时，应该在设置批量输出信息之前选择显示图例。

点击 [image] ，选择批量输出内容。

批量输出对话框

保存的菜单信息：列有在设置批量输出信息对话框中定义的输出信息。在列表中选择某信息后，点击 [image] ，可以删除该信息。

阶段：选择将输出的施工阶段。选择该项时，下面的列表中将显示各施工阶段(不显示每个阶段内的子步骤)。

PostCS荷载：选择将输出的最终施工阶段的荷载组合。选择该项时，下面的列表中将显示最终施工阶段的荷载组合。

注：当没有定义施工阶段时，下面的列表中将列出各荷载工况。

使用保存的结果：选择此项时，在上面列表中选择的荷载工况将不起作用，程序将输出保存在保存的菜单信息中的荷载工况和荷载组合信息。

阶段荷载工况/荷载组合：当定义了施工阶段时，下面的列表中将显示各施工阶段的荷载工况和荷载组合。没有定义施工阶段时，下面的列表为空白。

步骤选项

保存的步骤：选择此项时，将输出保存在保存的菜单信息中的施工阶段(在左侧列表中选择的施工阶段)的子步骤信息。

所有步骤：选择此项时，将输出在左侧列表中选择的施工阶段的所有子步骤信息。

输出选项：选择将要输出的文件的格式(BMP或EMF文件)。

输出路径：指定输出的文件保存地址的目录。

文件前缀：指定要生成的图形文件名称的前缀。文件名称的后缀则根据输出选项决定(*.bmp或*.emf)。

自动描述：在生成的图形左上端显示输出的信息内容、施工阶段、子步骤、荷载工况和荷载组合等信息。

点击 [image] ，将按设定的内容输出图形文件。点击 [image] ，可以将输出的设定内容保存成二进制文件(*.bog)。点击 [image] 可以导入该文件，按同样的格式输出其他内容的文件。


05_平面应变单元应力

Home > midas Gen 2017 > 09_结果 > 02_结果 > 04_应力 > 05_平面应变单元应力

平面应变单元应力

  • 功 能

用等值线查看平面应变单元的应力。

  • 命 令

从主菜单中选择结果 > 应力 > 平面应变单元应力

在树形菜单的菜单表单中选择分析结果 > 应力 > 平面应变单元应力

在图标菜单中单击 [image] 平面应变单元应力

  • 输 入

荷载工况/荷载组合

选择荷载工况或荷载组合。

单击右边的 [image] 输入新的或修改现有的荷载工况。(参见"荷载工况/荷载组合")

步骤：选择输出的步骤。可以选择非线性分析的荷载步骤、施工阶段分析的各步骤、水化热分析的各步骤。

应力选项

单元坐标系：

显示单元坐标系方向的应力。

UCS：

显示用户坐标系方向的应力。用户坐标系可以是整体坐标系，也可以是用户定义的坐标系。

单元:用单元各节点的应力显示等值线。

节点的平均值:用共享节点的各单元在共享节点位置的平均节点应力显示等值线。

只取激活节点的平均值:取当前被激活单元在共享节点的应力平均值显示等高线。

应力

在下列各项中选择应力分量。

在整体坐标系中

Sig-XX：整体坐标系X轴方向的轴向应力。

Sig-YY：整体坐标系Y轴方向的轴向应力。

Sig-ZZ：整体坐标系Z轴方向的轴向应力。

Sig-XY：整体坐标系X-Y平面内的剪应力。

Sig-YZ：整体坐标系Y-Z平面内的剪应力。

Sig-XZ：整体坐标系X-Z平面内的剪应力。

Sig-P1：第一主轴方向的主应力。

Sig-P2：第二主轴方向的主应力。

Sig-P3：第三主轴方向的主应力。

Tresca：Tresca 应力。

Sig-EFF：有效应力(von-Mises 应力)。

Sig-Pmax：显示Sig-P1，Sig-P2和Sig-P3三者绝对值中的最大值。

在单元坐标系中

Sig-xx：单元局部坐标系x方向的轴向应力(垂直于局部坐标系y-z平面)。

Sig-yy：单元局部坐标系y方向的轴向应力(垂直于局部坐标系x-z平面)。

Sig-zz：单元局部坐标系z方向的轴向应力(垂直于局部坐标系x-y平面)。

Sig-xy：单元局部坐标系x-y平面内的剪应力(平面内剪应力)。

Vector：用矢量显示三个主应力方向。

系数：矢量图的绘制比例。

显示单元的各角点值的最大值。

显示类型

指定显示形式如下：

等值线： 用等值线显示模型位移。

点击等值线右侧的 [image] ，弹出如下对话框。

范围：定义等值线的范围。

：指定等值线的颜色分布范围。使用该功能可为特定的区域赋以特定的颜色。点击该键，将显示如下对话框。

等值线值：列表中将显示各颜色等级代表的等值线值。颜色等级的数量为下面选择的颜色数量。

颜色数量：输入要包含在等值线中的颜色的数量(在6、12、18、24种颜色中选择)。

颜色：指定或控制等值线的颜色。

颜色表：输入颜色的变化顺序。

V->R->G->B：青紫色->红->绿->蓝。

R->G->B：红->绿->蓝。

R->B->G：红->蓝->绿。

Gray Scaled：渐变灰色。

：调整颜色变化的顺序。在此设定颜色的变化后，颜色表中的顺序将不起作用。

反转等值线图：反转等值线中颜色变化的次序。

等值线：指定等值线的边界线颜色。该项设定仅在右侧选择画等值线或单色线时才有效。

单元边界：指定单元的边界颜色。

等值线选项：选择表示等值线的方法。

填充涂色

颜色按梯度扩散：颜色渐变(模糊边界)。

画等值线：在等值线中显示彩色边界。

只显示等值线：仅用彩色等值线表现等值线图。

单色线：仅用单色线表现等值线图。

标注等值线注释：显示表示等值线范围和边界的注释。

标注间距：注释的标注间距。

快速显示等值线(用于较大的板或实体单元模型)：板或实体单元的模型较大时，使用简化的等值线，以减少显示等值线需要的时间。

扩展：表现板单元或实体单元的等值线图时，将单元局部坐标系的z轴方向为分析结果的正方向，生成三维等值线图。

注：该选项不能在变形形状中使用。也不能与消隐命令同时使用。当需要同时显示顶板束和底板束地内力(应力)时，也不能使用该选项。

放大系数：将沿单元局部坐标系的z轴方向表现的分析结果放大显示。

变形： 显示模型变形后的形状。点击?变形?右侧的 [image] ，弹出如下对话框。

变形图的比例：放大或缩小变形的显示比例。

变形的表现方式：选择显示变形的方式。

节点位移：只显示节点位移的变形形状。

实际变形：显示详细的变形形状，包括沿两端节点之间任意截面的变形以及梁单元的节点变形。在施工阶段分析中，为了加快速度及节省时间，只提供节点位移。

实际位移(关闭自动调整)：按实际比例显示图变形。选择该项则输入的变形图的比例将不起作用。

相对位移：将最小位移设置为0，其他节点显示相对位移。

数值： 显示位移分量的数值。数字的字型和颜色可在 [image] 显示选项中控制。

点击数值右侧的 [image] ，弹出如下对话框。

小数点以下位数：指定小数形式的数值的精确度。

指数型：数值按指数形式显示。

最大和最小值：显示最小值和最大值。

最大绝对值：显示绝对值的最大值。

最大值：仅显示最大值。

最小值：仅显示最小值。

显示范围(%)：当某需要显示的值与选定的最大值或最小值的差在规定的范围以内时，在屏幕上显示该值。

显示角度：数值的显示方向。

注：默认的小数点可在参数设置中输入。当显示方向为0时，在节点或单元右侧，水平显示数值。角度的正方向为逆时针方向，正确选择显示方向，能更清晰地看到数值。

图例：在工作窗口的右边或左边显示与分析结果有关的各种图例。

点击图例右侧的 [image] ，弹出设定图例对话框。

图例的位置：选择图例在模型空间的位置。

图例数值类型：选择图例中的数值类型和小数点位数。

动画：动态显示变形过程。单击 [image] ，然后单击工作窗口底部动画控制板右边的 [image] 记录。

点击动画右侧的 [image] ，弹出如下对话框。

动画模式：选择表现分析结果的动画类型。

动画显示(颜色变化)等值线：选择该项，则随着变形量的改变，变形等值线的颜色也将发生变化。

重复半个周期：按半个周期重复放映动画，即从0到最大值。一般用于表现结构的一般变形。

重复整个周期：按整个周期重复放映动画，即从0到最大值，再到0。一般用于表现结构的振动变形和屈曲变形。

制作AVI选项：输入制作AVI动画的各控制数据。

颜色：选择动画的分辨率大小。可供选择的有256色(8位)、增强色(16位)、真彩色(24位)。

：选择压缩动画文件的程序。

半周期帧数(3～300)：模拟半周期的帧数。

每秒帧数：每秒帧数。

施工阶段选项：做施工阶段分析时，选择制作成动画的施工阶段。

施工阶段：选择该项时，在下面选择将制作成动画的施工阶段范围。

当前阶段内子步骤：选择该项时，表示将当前施工阶段各子步骤制作成动画。

变形前： 将模型的变形前形状和变形后的形状重叠显示。

模型变形前形状的显示类型可在 [image] 显示选项中控制。

镜像：通过反射面将1/2或1/4模型的分析结果展开成整个模型的结果。

点击镜像右侧的 [image] ，弹出如左图的对话框。

1/2模型的镜像：通过对称面将1/2模型的分析结果展开成整个模型的结果。

1/4模型的镜像：通过对称面将1/4模型的分析结果展开成整个模型的结果。

对称面：指定一个整体坐标系平面为对称面。

屈服点 ：显示屈服点的值。

批量输出结果( 、 )

选择荷载工况、荷载组合以及各施工阶段的步骤，然后选择输出的内容。连续定义输出的内容后，将其保存为图形文件。

点击 [image] ，定义批量输出信息。

在定义输出信息名称时，应事先在前面的荷载工况/荷载组合中选择相应的荷载工况和荷载组合。

选择的荷载工况和荷载组合、施工阶段步骤都将保存在该信息中。

当输出的图形要包含图例时，应该在设置批量输出信息之前选择显示图例。

点击 [image] ，选择批量输出内容。

批量输出对话框

保存的菜单信息：列有在设置批量输出信息对话框中定义的输出信息。在列表中选择某信息后，点击 [image] ，可以删除该信息。

阶段：选择将输出的施工阶段。选择该项时，下面的列表中将显示各施工阶段(不显示每个阶段内的子步骤)。

PostCS荷载：选择将输出的最终施工阶段的荷载组合。选择该项时，下面的列表中将显示最终施工阶段的荷载组合。

注：当没有定义施工阶段时，下面的列表中将列出各荷载工况。

使用保存的结果：选择此项时，在上面列表中选择的荷载工况将不起作用，程序将输出保存在保存的菜单信息中的荷载工况和荷载组合信息。

阶段荷载工况/荷载组合：当定义了施工阶段时，下面的列表中将显示各施工阶段的荷载工况和荷载组合。没有定义施工阶段时，下面的列表为空白。

步骤选项

保存的步骤：选择此项时，将输出保存在保存的菜单信息中的施工阶段(在左侧列表中选择的施工阶段)的子步骤信息。

所有步骤：选择此项时，将输出在左侧列表中选择的施工阶段的所有子步骤信息。

输出选项：选择将要输出的文件的格式(BMP或EMF文件)。

输出路径：指定输出的文件保存地址的目录。

文件前缀：指定要生成的图形文件名称的前缀。文件名称的后缀则根据输出选项决定(*.bmp或*.emf)。

自动描述：在生成的图形左上端显示输出的信息内容、施工阶段、子步骤、荷载工况和荷载组合等信息。

点击 [image] ，将按设定的内容输出图形文件。点击 [image] ，可以将输出的设定内容保存成二进制文件(*.bog)。点击 [image] 可以导入该文件，按同样的格式输出其他内容的文件。


06_轴对称单元应力

Home > midas Gen 2017 > 09_结果 > 02_结果 > 04_应力 > 06_轴对称单元应力

轴对称单元应力

  • 功 能

用等值线查看轴对称单元的应力。

  • 命 令

从主菜单中选择结果 > 应力 > 轴对称单元应力

在树形菜单的菜单表单中选择分析结果 > 应力 > 轴对称单元应力

在图标菜单中单击 [image] 轴对称单元应力

  • 输 入
    荷载工况/荷载组合

选择荷载工况或荷载组合。

单击右边的 [image] 输入新的或修改现有的荷载工况。(参见"荷载工况 /荷载组合")

步骤：选择输出的步骤。可以选择非线性分析的荷载步骤、施工阶段分析的各步骤、水化热分析的各步骤。

应力选项

定义应力的方向。

单元坐标系：

显示单元坐标系方向的应力。

UCS：

显示用户坐标系方向的应力。用户坐标系可以是整体坐标系，也可以是用户定义的坐标系。

单元

用单元各节点的应力显示等值线。

节点的平均值

用共享节点的各单元在共享节点位置的平均节点应力显示等值线。

只取激活节点的平均值

取当前被激活单元在共享节点的应力平均值显示等高线。

应力

在下列各项中选择应力分量。

在整体坐标系中

Sig-XX：整体坐标系X轴方向的轴向应力。

Sig-YY：整体坐标系Y轴方向的轴向应力。

Sig-ZZ：整体坐标系Z轴方向的轴向应力。

Sig-XY：整体坐标系X-Y平面内的剪应力。

Sig-YZ：整体坐标系Y-Z平面内的剪应力。

Sig-XZ：整体坐标系X-Z平面内的剪应力。

Sig-P1：第一主轴方向的主应力。

Sig-P2：第二主轴方向的主应力。

Sig-P3：第三主轴方向的主应力。

Tresca：Tresca应力。

Sig-EFF：有效应力(von-Mises 应力)。

Sig-Pmax：显示Sig-P1，Sig-P2和Sig-P3三者绝对值中的最大值

在局部坐标系中

Sig-xx：在单元局部坐标系x轴方向的轴向应力(垂直于局部坐标系y-z平面)。

Sig-yy：在单元局部坐标系y轴方向的轴向应力(垂直于局部坐标系x-z平面)。

Sig-zz：在单元局部坐标系z轴方向的轴向应力(垂直于局部坐标系x-y平面)。

Sig-xy：单元局部坐标系x-y平面内的剪应力(平面内剪应力)。

Vector：用矢量显示三个主轴方向的主应力。

系数：矢量图的绘制比例。

显示类型

参见平面应变单元应力。


07_实体单元应力

Home > midas Gen 2017 > 09_结果 > 02_结果 > 04_应力 > 07_实体单元应力

实体单元应力

  • 功 能

用等值线查看实体单元的应力。

  • 命 令

从主菜单中选择结果 > 应力 > 实体单元应力

在树形菜单的菜单表单中选择分析结果 > 应力 > 实体单元应力

在图标菜单中单击 [image] 实体单元的应力

  • 输 入

荷载工况/荷载组合

选择荷载工况或荷载组合。

单击右边的 [image] 输入新的或修改现有的荷载工况。(参见"荷载工况 /荷载组合")

步骤：选择输出的步骤。可以选择非线性分析的荷载步骤、施工阶段分析的各步骤、水化热分析的各步骤。

应力选项

单元坐标系：

显示单元坐标系方向的应力。

UCS：

显示用户坐标系方向的应力。用户坐标系可以是整体坐标系，也可以是用户定义的坐标系。

单元

用单元各节点的应力显示等值线。

节点的平均值

用共享节点的各单元在共享节点位置的平均节点应力显示等值线。

只取激活节点的平均值

取当前被激活单元在共享节点的应力平均值显示等高线。

应力

在下列各项中选择应力分量。

在整体坐标系中

Sig-XX：整体坐标系X轴方向的轴向应力。

Sig-YY：整体坐标系Y轴方向的轴向应力。

Sig-ZZ：整体坐标系Z轴方向的轴向应力。

Sig-XY：整体坐标系X-Y平面内的剪应力。

Sig-YZ：整体坐标系Y-Z平面内的剪应力。

Sig-XZ：整体坐标系X-Z平面内的剪应力。

Sig-P1：第一主轴方向的主应力。

Sig-P2：第二主轴方向的主应力。

Sig-P3：第三主轴方向的主应力。

Tresca：Tresca应力。

Sig-EFF：有效应力(von-Mises 应力)。

Sig-Pmax：显示Sig-P1、Sig-P2和Sig-P3三者绝对值中的最大值。

在单元坐标系中

Sig-xx：在单元局部坐标系x轴方向的轴向应力(垂直于局部坐标系y-z平面)。

Sig-yy：在单元局部坐标系y轴方向的轴向应力(垂直于局部坐标系x-z平面)。

Sig-zz：在单元局部坐标系z轴方向的轴向应力(垂直于局部坐标系x-y平面)。

Sig-xy：单元局部坐标系x-y平面内的剪应力(平面内剪应力)。

Sig-yz：单元局部坐标系y-z平面内的剪应力(平面内剪应力)。

Sig-xz：单元局部坐标系x-z平面内的剪应力(平面内剪应力)。

Vector：用矢量显示最大和最小主应力。

显示类型

指定显示形式如下：

等值线： 用等值线显示模型位移。

点击等值线右侧的 [image] ，弹出如下对话框。

范围：定义等值线的范围。

：指定等值线的颜色分布范围。使用该功能可为特定的区域赋以特定的颜色。点击该键，将显示如下对话框。

等值线值：列表中将显示各颜色等级代表的等值线值。颜色等级的数量为下面选择的颜色数量。

颜色数量：输入要包含在等值线中的颜色的数量(在6、12、18、24种颜色中选择)。

颜色：指定或控制等值线的颜色。

颜色表：输入颜色的变化顺序。

V->R->G->B：青紫色->红->绿->蓝。

R->G->B：红->绿->蓝。

R->B->G：红->蓝->绿。

Gray Scaled：渐变灰色。

：调整颜色变化的顺序。在此设定颜色的变化后，颜色表中的顺序将不起作用。

反转等值线图：反转等值线中颜色变化的次序。

等值线：指定等值线的边界线颜色。该项设定仅在右侧选择画等值线或单色线时才有效。

单元边界：指定单元的边界颜色。

等值线选项：选择表示等值线的方法。

填充涂色

颜色按梯度扩散：颜色渐变(模糊边界)。

画等值线：在等值线中显示彩色边界。

只显示等值线：仅用彩色等值线表现等值线图。

单色线：仅用单色线表现等值线图。

标注等值线注释：显示表示等值线范围和边界的注释。

标注间距：注释的标注间距。

快速显示等值线(用于较大的板或实体单元模型)：板或实体单元的模型较大时，使用简化的等值线，以减少显示等值线需要的时间。

扩展：表现板单元或实体单元的等值线图时，将单元局部坐标系的z轴方向为分析结果的正方向，生成三维等值线图。

注：该选项不能在变形形状中使用。也不能与消隐命令同时使用。当需要同时显示顶板束和底板束地内力(应力)时，也不能使用该选项。

放大系数：将沿单元局部坐标系的z轴方向表现的分析结果放大显示。

变形： 显示模型变形后的形状。点击变形右侧的 [image] ，弹出如下对话框。

变形图的比例：放大或缩小变形的显示比例。

变形的表现方式：选择显示变形的方式。

节点位移：只显示节点位移的变形形状。

实际变形：显示详细的变形形状，包括沿两端节点之间任意截面的变形以及梁单元的节点变形。在施工阶段分析中，为了加快速度及节省时间，只提供节点位移。

实际位移(关闭自动调整)：按实际比例显示图变形。选择该项则输入的变形图的比例将不起作用。

相对位移：将最小位移设置为0，其他节点显示相对位移。

数值： 显示位移分量的数值。数字的字型和颜色可在 [image] 显示选项中控制。

点击数值右侧的 [image] ，弹出如下对话框。

小数点以下位数：指定小数形式的数值的精确度。

指数型：数值按指数形式显示。

最大和最小值：显示最小值和最大值。

最大绝对值：显示绝对值的最大值。

最大值：仅显示最大值。

最小值：仅显示最小值。

显示范围(%)：当某需要显示的值与选定的最大值或最小值的差在规定的范围以内时，在屏幕上显示该值。

显示角度：数值的显示方向。

注：默认的小数点可在参数设置中输入。当显示方向为0时，在节点或单元右侧，水平显示数值。角度的正方向为逆时针方向，正确选择显示方向，能更清晰地看到数值。

图例：在工作窗口的右边或左边显示与分析结果有关的各种图例。

点击图例右侧的 [image] ，弹出设定图例对话框。

图例的位置：选择图例在模型空间的位置。

图例数值类型：选择图例中的数值类型和小数点位数。

动画：动态显示变形过程。单击 [image] ，然后单击工作窗口底部动画控制板右边的 [image] 记录。

点击动画右侧的 [image] ，弹出如下对话框。

动画模式：选择表现分析结果的动画类型。

动画显示(颜色变化)等值线：选择该项，则随着变形量的改变，变形等值线的颜色也将发生变化。

重复半个周期：按半个周期重复放映动画，即从0到最大值。一般用于表现结构的一般变形。

重复整个周期：按整个周期重复放映动画，即从0到最大值，再到0。一般用于表现结构的振动变形和屈曲变形。

制作AVI选项：输入制作AVI动画的各控制数据。

颜色：选择动画的分辨率大小。可供选择的有256色(8位)、增强色(16位)、真彩色(24位)。

：选择压缩动画文件的程序。

半周期帧数(3～300)：模拟半周期的帧数。

每秒帧数：每秒帧数。

施工阶段选项：做施工阶段分析时，选择制作成动画的施工阶段。

施工阶段：选择该项时，在下面选择将制作成动画的施工阶段范围。

当前阶段内子步骤：选择该项时，表示将当前施工阶段各子步骤制作成动画。

变形前： 将模型的变形前形状和变形后的形状重叠显示。

模型变形前形状的显示类型可在 [image] 显示选项中控制。

镜像：通过反射面将1/2或1/4模型的分析结果展开成整个模型的结果。

点击?镜像?右侧的 [image] ，弹出如左图的对话框。

1/2模型的镜像：通过对称面将1/2模型的分析结果展开成整个模型的结果。

1/4模型的镜像：通过对称面将1/4模型的分析结果展开成整个模型的结果。

对称面：指定一个整体坐标系平面为对称面。

屈服点：显示屈服点。

等值面：查看并显示实体单元内的等应力面。

点击等值面右侧的 [image] ，弹出对话框。

等值面值的形式

选择查看应力的方法。

相对值(0～1)

应力相对值，最大值和最小值分别为1和0。

数值：实际应力值。

等值面值

：单击此按钮输入等值面数值，允许多重输入。

：单击此按钮删除数据记录。

显示多边形外轮廓线

绘制等应力面的多边形边界。边界线的颜色在上面介绍的等值线详细对话框中单元边缘中定义颜色。

透明(只在画面上)

指定等值面的透明程度，仅用与屏幕显示。

模型轮廓线

用下列选项描绘(亮显)实体单元模型的轮廓，以清楚地查看等应力面上的应力分布。轮廓线的颜色根据 [image] 显示选项中的颜色或打印颜色表单中自由边/面的颜色确定。

自由面：绘制不与其它实体单元相邻的所有表面的轮廓。

自由边：绘制不与其它实体单元相邻的所有边的轮廓。

注：等值面可以与动画选项一起使用。输入等值面的值后，等应力面在输入应力和最大应力之间的范围内动画显示。如果输入两个或两个以上的等值面应力值，动画范围则从所有值中最小的应力处开始。

批量输出结果( [image] 、 [image])

选择荷载工况、荷载组合以及各施工阶段的步骤，然后选择输出的内容。连续定义输出的内容后，将其保存为图形文件。

点击 [image] ，定义批量输出信息。

在定义?输出信息名称?时，应事先在前面的荷载工况/荷载组合中选择相应的荷载工况和荷载组合。

选择的荷载工况和荷载组合、施工阶段步骤都将保存在该信息中。

当输出的图形要包含图例时，应该在设置批量输出信息之前选择显示图例。

点击 [image] ，选择批量输出内容。

批量输出对话框

保存的菜单信息：列有在?设置批量输出信息?对话框中定义的输出信息。在列表中选择某信息后，点击 [image] ，可以删除该信息。

阶段：选择将输出的施工阶段。选择该项时，下面的列表中将显示各施工阶段(不显示每个阶段内的子步骤)。

PostCS荷载：选择将输出的最终施工阶段的荷载组合。选择该项时，下面的列表中将显示最终施工阶段的荷载组合。

注：当没有定义施工阶段时，下面的列表中将列出各荷载工况。

使用保存的结果：选择此项时，在上面列表中选择的荷载工况将不起作用，程序将输出保存在保存的菜单信息中的荷载工况和荷载组合信息。

阶段荷载工况/荷载组合：当定义了施工阶段时，下面的列表中将显示各施工阶段的荷载工况和荷载组合。没有定义施工阶段时，下面的列表为空白。

步骤选项

保存的步骤：选择此项时，将输出保存在保存的菜单信息中的施工阶段(在左侧列表中选择的施工阶段)的子步骤信息。

所有步骤：选择此项时，将输出在左侧列表中选择的施工阶段的所有子步骤信息。

输出选项：选择将要输出的文件的格式(BMP或EMF文件)。

输出路径：指定输出的文件保存地址的目录。

文件前缀：指定要生成的图形文件名称的前缀。文件名称的后缀则根据输出选项决定(*.bmp或*.emf)。

自动描述：在生成的图形左上端显示输出的信息内容、施工阶段、子步骤、荷载工况和荷载组合等信息。

点击 [image] ，将按设定的内容输出图形文件。点击 [image] ，可以将输出的设定内容保存成二进制文件(*.bog)。点击 [image] 可以导入该文件，按同样的格式输出其他内容的文件。


01_定义图形组

Home > midas Gen 2017 > 09_结果 > 02_结果 > 05_内力图 > 01_定义图形

定义图形组

  • 功 能

定义需要查看的图形组。

用户定义图形中可以输出的分析结果包括：位移；桁架单元的内力和应力；梁单元的内力和应力。

  • 命 令

从主菜单中选择结果 >用户定义图形> 定义图形组

在树形菜单的菜单表单中选择分析结果 > 定义图形组

  • 输 入

单元

选择要查看的单元。

结果类型

选择要查看的结果类型。

成分

在下列各项中选择位移分量：

DX：整体坐标系X轴方向的位移分量。

DY：整体坐标系Y轴方向的位移分量。

DZ：整体坐标系Z轴方向的位移分量。

DXY =

DYZ =

DXZ =

DXYZ =

显示选项

点击该按钮设置显示的选项。

组名称

添加、编辑及删除组的名称。


02_显示图形组

Home > midas Gen 2017 > 09_结果 > 02_结果 > 05_内力图 > 02_显示图形

显示图形组

  • 功 能

显示需要查看的图形组。

用户定义图形中可以输出的分析结果包括：位移；桁架单元的内力和应力；梁单元的内力和应力。

  • 命 令

从主菜单中选择结果 >用户定义图形> 显示图形组

在树形菜单的菜单表单中选择分析结果 > 显示图形组

  • 输 入

荷载工况/荷载组合

选择要查看荷载工况或者荷载组合。

图形组

选择要查看的已经定义好的图形组。

编辑显示选项

点击该按钮可以设置显示的选项。

系数

设置显示的系数。

自动：输入相应的数字，程序自动显示。

参考值：给出相应的参考值，程序按定义的系数进行显示。

批量输出

进行结果的批量输出。


01_应力

Home > midas Gen 2017 > 09_结果 > 02_结果 > 06_水化热分析结果 > 01_应力

应力

  • 功 能

使用等值线查看水化热分析过程中的应力。

  • 命 令

从主菜单中选择结果 > 水化热分析 > 应力

在树形菜单的菜单表单中选择分析结果 > 水化热分析 > 应力

  • 输 入

步骤

选择水化热分析的步骤。

选择应力坐标系

定义应力的方向。

整体坐标系：显示整体坐标系方向的应力。

单元坐标系：显示单元坐标系方向的应力。

单元

用单元各节点的应力显示等值线。

节点的平均值

用共享节点的各单元在共享节点位置的平均节点应力显示等值线。

只取激活节点的平均值

取当前被激活单元在共享节点的应力平均值显示等高线。

应力

在下列各项中选择应力分量。

在整体坐标系中

Sig-XX：整体坐标系X轴方向的轴向应力。

Sig-YY：整体坐标系Y轴方向的轴向应力。

Sig-ZZ：整体坐标系Z轴方向的轴向应力。

Sig-XY：整体坐标系X-Y平面内的剪应力。

Sig-YZ：整体坐标系Y-Z平面内的剪应力。

Sig-XZ：整体坐标系X-Z平面内的剪应力。

Sig-P1：第一主轴方向的主应力。

Sig-P2：第二主轴方向的主应力。

Sig-P3：第三主轴方向的主应力。

Tresca：Tresca应力。

Sig-EFF：有效应力(von-Mises 应力)。

Sig-Pmax：显示Sig-P1、Sig-P2和Sig-P3三者绝对值中的最大值。

在局部坐标系中

Sig-xx：在单元局部坐标系x轴方向的轴向应力(垂直于局部坐标系y-z平面)。

Sig-yy：在单元局部坐标系y轴方向的轴向应力(垂直于局部坐标系x-z平面)。

Sig-zz：在单元局部坐标系y轴方向的轴向应力(垂直于局部坐标系x-y平面)。

Sig-xy：单元局部坐标系x-y平面内的剪应力(平面内剪应力)。

Sig-yz：单元局部坐标系y-z平面内的剪应力(平面内剪应力)。

Sig-xz：单元局部坐标系x-z平面内的剪应力(平面内剪应力)。

张量：用矢量显示最大和最小主应力。

比例：矢量图的绘制比例。

显示类型

指定显示形式如下：

等值线： 用等值线显示模型位移。

点击等值线右侧的 [image] ，弹出如下对话框。

范围：定义等值线的范围。

：指定等值线的颜色分布范围。使用该功能可为特定的区域赋以特定的颜色。点击该键，将显示如下对话框。

等值线值：列表中将显示各颜色等级代表的等值线值。颜色等级的数量为下面选择的颜色数量。

颜色数量：输入要包含在等值线中的颜色的数量(在6、12、18、24种颜色中选择)。

颜色：指定或控制等值线的颜色。

颜色表：输入颜色的变化顺序。

V->R->G->B：青紫色->红->绿->蓝。

R->G->B：红->绿->蓝。

R->B->G：红->蓝->绿。

Gray Scaled：渐变灰色。

：调整颜色变化的顺序。在此设定颜色的变化后，颜色表中的顺序将不起作用。

反转等值线图：反转等值线中颜色变化的次序。

等值线：指定等值线的边界线颜色。该项设定仅在右侧选择画等值线或单色线时才有效。

单元边界：指定单元的边界颜色。

等值线选项：选择表示等值线的方法。

填充涂色

颜色按梯度扩散：颜色渐变(模糊边界)。

画等值线：在等值线中显示彩色边界。

只显示等值线：仅用彩色等值线表现等值线图。

单色线：仅用单色线表现等值线图。

标注等值线注释：显示表示等值线范围和边界的注释。

标注间距：注释的标注间距。

快速显示等值线(用于较大的板或实体单元模型)：板或实体单元的模型较大时，使用简化的等值线，以减少显示等值线需要的时间。

扩展：表现板单元或实体单元的等值线图时，将单元局部坐标系的z轴方向为分析结果的正方向，生成三维等值线图。

注：该选项不能在变形形状中使用。也不能与消隐命令同时使用。当需要同时显示顶板束和底板束地内力(应力)时，也不能使用该选项。

放大系数：将沿单元局部坐标系的z轴方向表现的分析结果放大显示。

变形： 显示模型变形后的形状。点击?变形?右侧的 [image] ，弹出如下对话框。

变形图的比例：放大或缩小变形的显示比例。

变形的表现方式：选择显示变形的方式。

节点位移：只显示节点位移的变形形状。

实际变形：显示详细的变形形状，包括沿两端节点之间任意截面的变形以及梁单元的节点变形。在施工阶段分析中，为了加快速度及节省时间，只提供节点位移。

实际位移(关闭自动调整)：按实际比例显示图变形。选择该项则输入的变形图的比例将不起作用。

相对位移：将最小位移设置为0，其他节点显示相对位移。

数值： 显示位移分量的数值。数字的字型和颜色可在 [image] 显示选项中控制。

点击数值右侧的 [image] ，弹出如下对话框。

小数点以下位数：指定小数形式的数值的精确度。

指数型：数值按指数形式显示。

最大和最小值：显示最小值和最大值。

最大绝对值：显示绝对值的最大值。

最大值：仅显示最大值。

最小值：仅显示最小值。

显示范围(%)：当某需要显示的值与选定的最大值或最小值的差在规定的范围以内时，在屏幕上显示该值。

显示角度：数值的显示方向。

注：默认的小数点可在?参数设置?中输入。当显示方向为0时，在节点或单元右侧，水平显示数值。角度的正方向为逆时针方向，正确选择显示方向，能更清晰地看到数值。

图例：在工作窗口的右边或左边显示与分析结果有关的各种图例。

点击图例右侧的 [image] ，弹出设定图例对话框。

图例的位置：选择图例在模型空间的位置。

图例数值类型：选择图例中的数值类型和小数点位数。

动画：动态显示变形过程。单击 [image] ，然后单击工作窗口底部动画控制板右边的 [image] 记录。

点击动画右侧的 [image] ，弹出如下对话框。

动画模式：选择表现分析结果的动画类型。

动画显示(颜色变化)等值线：选择该项，则随着变形量的改变，变形等值线的颜色也将发生变化。

重复半个周期：按半个周期重复放映动画，即从0到最大值。一般用于表现结构的一般变形。

重复整个周期：按整个周期重复放映动画，即从?0?到最大值，再到?0?。一般用于表现结构的振动变形和屈曲变形。

制作AVI选项：输入制作AVI动画的各控制数据。

颜色：选择动画的分辨率大小。可供选择的有256色(8位)、增强色(16位)、真彩色(24位)。

：选择压缩动画文件的程序。

半周期帧数(3～300)：模拟半周期的帧数。

每秒帧数：每秒帧数。

施工阶段选项：做施工阶段分析时，选择制作成动画的施工阶段。

施工阶段：选择该项时，在下面选择将制作成动画的施工阶段范围。

当前阶段内子步骤：选择该项时，表示将当前施工阶段各子步骤制作成动画。

变形前： 将模型的变形前形状和变形后的形状重叠显示。

模型变形前形状的显示类型可在 [image] 显示选项中控制。

镜像：通过反射面将1/2或1/4模型的分析结果展开成整个模型的结果。

点击?镜像?右侧的 [image] ，弹出如左图的对话框。

1/2模型的镜像：通过对称面将1/2模型的分析结果展开成整个模型的结果。

1/4模型的镜像：通过对称面将1/4模型的分析结果展开成整个模型的结果。

对称面：指定一个整体坐标系平面为对称面。

等值面：查看并显示实体单元内的等应力面。

点击等值面右侧的 [image] ，弹出对话框。

等值面值的形式

选择查看应力的方法。

相对值(0～1)

应力相对值，最大值和最小值分别为1和0。

数值：实际应力值。

等值面值

：单击此按钮输入等值面数值，允许多重输入。

：单击此按钮删除数据记录。

显示多边形外轮廓线

绘制等应力面的多边形边界。边界线的颜色在上面介绍的等值线详细对话框中单元边缘中定义颜色。

透明(只在画面上)

指定等值面的透明程度，仅用与屏幕显示。

模型轮廓线

用下列选项描绘(亮显)实体单元模型的轮廓，以清楚地查看等应力面上的应力分布。轮廓线的颜色根据 [image] 显示选项中的颜色或打印颜色表单中自由边/面的颜色确定。

自由面：绘制不与其它实体单元相邻的所有表面的轮廓。

自由边：绘制不与其它实体单元相邻的所有边的轮廓。

注：等值面可以与动画选项一起使用。输入等值面的值后，等应力面在输入应力和最大应力之间的范围内动画显示。如果输入两个或两个以上的等值面应力值，动画范围则从所有值中最小的应力处开始。

批量输出结果( [image] 、 [image])

选择荷载工况、荷载组合以及各施工阶段的步骤，然后选择输出的内容。连续定义输出的内容后，将其保存为图形文件。

点击 [image] ，定义批量输出信息。

在定义输出信息名称时，应事先在前面的荷载工况/荷载组合中选择相应的荷载工况和荷载组合。

选择的荷载工况和荷载组合、施工阶段步骤都将保存在该信息中。

当输出的图形要包含图例时，应该在设置批量输出信息之前选择显示图例。

点击 [image] ，选择批量输出内容。

批量输出对话框

保存的菜单信息：列有在设置批量输出信息对话框中定义的输出信息。在列表中选择某信息后，点击 [image] ，可以删除该信息。

阶段：选择将输出的施工阶段。选择该项时，下面的列表中将显示各施工阶段(不显示每个阶段内的子步骤)。

PostCS荷载：选择将输出的最终施工阶段的荷载组合。选择该项时，下面的列表中将显示最终施工阶段的荷载组合。

注：当没有定义施工阶段时，下面的列表中将列出各荷载工况。

使用保存的结果：选择此项时，在上面列表中选择的荷载工况将不起作用，程序将输出保存在保存的菜单信息中的荷载工况和荷载组合信息。

阶段荷载工况/荷载组合：当定义了施工阶段时，下面的列表中将显示各施工阶段的荷载工况和荷载组合。没有定义施工阶段时，下面的列表为空白。

步骤选项

保存的步骤：选择此项时，将输出保存在保存的菜单信息中的施工阶段(在左侧列表中选择的施工阶段)的子步骤信息。

所有步骤：选择此项时，将输出在左侧列表中选择的施工阶段的所有子步骤信息。

输出选项：选择将要输出的文件的格式(BMP或EMF文件)。

输出路径：指定输出的文件保存地址的目录。

文件前缀：指定要生成的图形文件名称的前缀。文件名称的后缀则根据输出选项决定(*.bmp或*.emf)。

自动描述：在生成的图形左上端显示输出的信息内容、施工阶段、子步骤、荷载工况和荷载组合等信息。

点击 [image] ，将按设定的内容输出图形文件。点击 [image] ，可以将输出的设定内容保存成二进制文件(*.bog)。点击 [image] 可以导入该文件，按同样的格式输出其他内容的文件。


02_温度

Home > midas Gen 2017 > 09_结果 > 02_结果 > 06_水化热分析结果 > 02_温度

温 度

  • 功 能

查看水化热分析过程中的温度分布。

  • 命 令

从主菜单中选择结果 > 水化热分析 > 温度

在树形菜单的菜单表单中选择分析结果 > 水化热分析 > 温度

  • 输 入

步骤

选择水化热分析的步骤。

显示类型

参见 结果>水化热分析>应力。


03_位移

Home > midas Gen 2017 > 09_结果 > 02_结果 > 06_水化热分析结果 > 03_位移

位移

  • 功 能

查看水化热分析过程中的位移。

  • 命 令

从主菜单中选择结果 > 水化热分析 > 位移

在树形菜单的菜单表单中选择分析结果 > 水化热分析 > 位移

  • 输 入

步骤

选择位移分析的步骤。

位移

在下列各项中选择位移分量。

DX：整体坐标系X轴方向的位移。

DY：整体坐标系Y轴方向的位移。

DZ：整体坐标系Z轴方向的位移。

RX：绕整体坐标系X轴的旋转位移。

RY：绕整体坐标系Y轴的旋转位移。

RZ：绕整体坐标系Z轴的旋转位移。

DXY：

DYZ：

DXZ：

DXYZ：

显示类型

参见结果>水化热分析>应力。


04_容许抗拉强度

Home > midas Gen 2017 > 09_结果 > 02_结果 > 06_水化热分析结果 > 04_容许抗拉应力

容许抗拉强度

  • 功 能

查看水化热分析过程中各节点的容许抗拉强度。

容许抗拉强度由已定义的材料强度发展函数获得。因为在材料强度发展函数中定义的强度为抗压强度，所以程序内部根据选择的规范将其转换为抗拉强度。

中国有关规范中没有给出强度发展函数的公式，用户可以自定义弹性模量的变化曲线，程序将根据ACI的标准将弹性模量反算推导出抗拉强度。

  • 命 令

从主菜单中选择结果 > 水化热分析 > 容许抗拉强度

在树形菜单的菜单表单中选择分析结果 > 水化热分析 > 容许抗拉强度

  • 输 入

步骤

选择水化热分析的步骤。

显示类型

参见结果>水化热分析>应力。


05_拉应力比

Home > midas Gen 2017 > 09_结果 > 02_结果 > 06_水化热分析结果 > 05_拉应力比

拉应力比

  • 功 能

查看水化热分析过程中各节点发生的应力与容许张拉应力的比值。

  • 命 令

从主菜单中选择结果 > 水化热分析 > 拉应力比

在树形菜单的菜单表单中选择分析结果 > 水化热分析 > 拉应力比

  • 输 入

步骤

选择水化热分析的步骤。

显示类型

参见 结果>水化热分析>应力。


06_图表

Home > midas Gen 2017 > 09_结果 > 02_结果 > 06_水化热分析结果 > 06_图表

图表

  • 功 能

用图表显示水化热分析过程中各节点的时程分析分析结果。

  • 命 令

从主菜单中选择结果 > 水化热分析 > 图表

在树形菜单的菜单表单中选择分析结果 > 水化热分析 > 图表

  • 输 入

定义的节点

选择图表中将输出的节点号及节点上的应力方向。

当点击"添加"键时，将显示定义输出节点的对话框。

选择节点号和应力分量。

Sig-XX：整体坐标系X轴方向的应力。

Sig-YY：整体坐标系Y轴方向的应力。

Sig-ZZ：整体坐标系Z轴方向的应力。

Max(X,Y,Z)：整体坐标系X、Y、Z轴方向的应力中的最大值。

图表内容

选择输出的时程结果内容。

应力 + 容许张拉应力：输出相应节点产生的应力和容许张拉应力的时程图形。

例如 A:N1-X 表示节点1在X轴方向的容许张拉应力；

S:N1-X 表示节点1在X轴方向的应力；

A:N1-Max 表示节点1在X、Y、Z轴方向的应力中的最大值。

应力：相应节点的应力。

容许张拉应力：相应节点的容许张拉应力。

拉应力比：相应节点的拉应力比。

温度：相应节点的温度。

X-轴类型

选择图形的X轴刻度的内容。

时间：输出随时间变化的图表。

阶段/步骤：输出随施工阶段和步骤变化的图表。


08_梁单元细部分析

Home > midas Gen 2017 > 09_结果 > 03_详细 > 01_梁单元 > 01_梁单元详细分析

梁单元细部分析

  • 功 能

通过梁的细部分析，生成梁的变形形状、剪力图(SFD)、弯矩图(BMD)，并给出截面的应力分布图。

  • 命 令

从主菜单中选择结果 > 梁单元细部分析

在树形菜单的菜单表单中选择结果 > 梁单元细部分析

  • 用 法

荷载工况/荷载组合

选择荷载工况或荷载组合。

单击右边的 [image] 输入新的或修改现有的荷载工况。(参见"荷载工况 /荷载组合")

步骤：选择输出的步骤。可以选择非线性分析的荷载步骤、施工阶段分析的各步骤、水化热分析的各步骤。

单元号

输入要进行细部分析的单元编号，或单击单元编号输入区后在模型窗口中选择相应的梁单元。

注:梁单元细部分析不支持移动荷载工况、包含移动荷载的荷载组合、荷载组合包络图。

选择单元后，点击"适用"键将显示如下结果窗口。

单元局部坐标系z轴方向的位移/剪力图(SFD)/弯矩图(SFD)

位移/剪力/弯矩图z-轴方向表单

显示梁单元强轴方向的位移变形形状、剪力图(SFD)、弯矩图(BMD)

位移：Dz 单元局部坐标系z轴方向的变形形状和相应的数值。

Di(abs)：节点i(N1)端的绝对位移。

Dj(abs)：节点j(N2)端的绝对位移。

Di(rel)：节点i(N1)端的相对位移。

Dj(rel)：节点j(N2)端的相对位移。

注:将节点i和j的较小位移设为0，计算另一端的相对位移，即得相对位移。

Dmax(abs)：最大绝对位移及相应位置。

Dmax(rel)：最大相对位移。

Dmin(abs)：最小绝对位移及相应位置。

Dmin(rel)：最小相对位移。

Duser(abs)：用户指定位置处的绝对位移及相应位置。

Duser(rel)：用户指定位置处的相对位移。

注:指定相应的位置的方法：在位移图中向左或向右移动鼠标指针或用结果窗口底部的滑动按钮。

剪力图：Fz 单元局部坐标系z轴方向的剪力及相应的数值。

Fi：节点i处的剪力。

Fj：节点j处的剪力。

Fmax：最大剪力及相应位置。

Fmin：最小剪力及相应位置。

Fuser：用户指定位置处的剪力及相应位置。

弯矩图：My 绕单元局部坐标系y轴的弯矩及相应的数值。

Mi：节点i处的弯矩。

Mj：节点j处的弯矩。

Mmax：最大弯矩及相应位置

Mmin：最小弯矩及相应位置

Muser：用户指定位置处的弯矩及相应位置

单元局部坐标系y轴方向的位移/剪力图(SFD)/弯矩图(SFD)

位移/剪力/弯矩图y-轴方向表单

显示梁单元弱轴方向的位移变形形状、剪力图(SFD)、弯矩图(BMD)

位移：Dy 单元局部坐标系z轴方向的变形形状和相应的数值。

Di(abs)：节点i(N1)端的绝对位移。

Dj(abs)：节点j(N2)端的绝对位移。

Di(rel)：节点i(N1)端的相对位移。

Dj(rel)：节点j(N2)端的相对位移。

注：将节点i和j的较小位移设为0，计算另一端的相对位移，即得相对位移。

Dmax(abs)：最大绝对位移及相应位置。

Dmax(rel)：最大相对位移。

Dmin(abs)：最小绝对位移及相应位置。

Dmin(rel)：最小相对位移。

Duser(abs)：用户指定位置处的绝对位移及相应位置。

Duser(rel)：用户指定位置处的相对位移。

注：指定相应的位置的方法：在位移图中向左或向右移动鼠标指针或用结果窗口底部的滑动按钮。

剪力图：Fy 单元局部坐标系y轴方向的剪力及相应的数值。

Fi：节点i处的剪力。

Fj：节点j处的剪力。

Fmax：最大剪力及相应位置。

Fmin：最小剪力及相应位置。

Fuser：用户指定位置处的剪力及相应位置。

弯矩图：Mz 绕单元局部坐标系z轴的弯矩及相应的数值。

Mi：节点i处的弯矩。

Mj：节点j处的弯矩。

Mmax：最大弯矩及相应位置。

Mmin：最小弯矩及相应位置。

Muser：用户指定位置处的弯矩及相应位置。

截面应力

截面表单

在梁单元细部分析中选择输出内容

截面应力

在梁单元细部分析对话栏内选择某一应力分量及相应的构件内力分量并单击 [image] ，则在截面表单中显示相应应力分量。

应力分量

：单元局部坐标系x轴方向的应力 (=轴向应力+ My和Mz产生的弯曲应力)。

：单元局部坐标系y轴方向的剪应力。

：单元局部坐标系z轴方向的剪应力。

von-Mises

von-Mises 应力 =

其中， [image] ：最大主应力。

：最小主应力。

Tresca

Tresca 应力 =

Princ(max):最大主应力。

Princ(min):最小主应力。

构件内力分量

Fx：单元局部坐标系x轴方向的轴力。

Fy：单元局部坐标系y轴方向的剪力。

Fz：单元局部坐标系z轴方向的剪力。

Mx：绕单元局部坐标系x轴的扭矩。

My：绕单元局部坐标系y轴的弯矩。

Mz：绕单元局部坐标系z轴的弯矩。

在对话框中输出相应结果

最大应力：提供指定应力分量沿梁长度方向的最大及最小分布图及相应数值。

：节点i(N1)端截面最大应力。

：节点j(N2)端截面最大应力。

：构件最大应力及相应位置。

：构件最小应力及相应位置。

：用户指定位置处的最大应力。

注：在最大应力图中向左或向右移动鼠标指针指定要查看的应力的位置。

横截面应力：显示指定位置的截面上的应力分布和相应值。

：截面最大应力及位置。

：截面最小应力及位置。

：用户指定位置处的应力

在截面应力分布图中上下左右移动鼠标指针指定截面上任意位置(在单元局部坐标系y-z平面上)。另外，在最大应力图中沿长度方向(在单元局部坐标系x轴上)向左或向右移动鼠标指针指定截面。

位置

绝对值：用户指定的位置到i节点的距离。

相对值(x/L)：用户指定的位置距离i节点的距离相对于梁总长度的距离比。

选择的内力：沿长度方向用户指定位置处的构件内力，将显示在梁单元细部分析对话栏内选择的构件内力分量，这些内力用于计算显示的应力。所有的内力分量显示在下面。


09_单元详细分析结果

Home > midas Gen 2017 > 09_结果 > 03_详细 > 01_梁单元 > 02_单元详细分析结果

单元详细分析结果

  • 功 能

检查单元属性及不同荷载工况和组合下的内力和应力。

  • 命 令

从主菜单中选择 结果 > 单元详细分析结果

在树形菜单的菜单表单中选择 分析结果 > 单元分析详细结果

  • 用 法

单元详细分析结果

单元号

输入要查看的单元编号。

注:直接输入单元编号，或单击输入区后在模型窗口中点击相应单元。

荷载工况

选择荷载工况、荷载组合。

步骤

选择要输出的荷载步骤或施工阶段步骤。

信息表单

输出单元编号、类型、材料特性、截面数据等信息。

内力表单

当为杆系单元时，将输出单元坐标系的内力分量。红色数字为最大值，蓝色数字为最小值。

当为平面单元时，将输出单元坐标系、整体坐标系、用户坐标系方向的内力分量。

当为实体单元时，将输出单元坐标系、整体坐标系方向的内力分量。

内力(L)：单元局部坐标系下的单元内力。

内力(G)：整体坐标系下的单元内力。

内力(U)：板单元用户坐标系方向单位宽度内的单元内力。

应力表单

当为杆系单元时，将输出单元坐标系的应力分量。

当为平面单元时，将输出单元坐标系、整体坐标系方向的应力分量。可选择查看顶面和底面应力。节点号和中心后面的(T)表示板顶面应力，(B)表示底面应力。

当为实体单元时，将输出单元坐标系、整体坐标系方向的应力分量。

内力(L)：单元局部坐标系下的单元应力。

内力(G)：整体坐标系下的单元应力。


10_局部方向内力的合力

Home > midas Gen 2017 > 09_结果 > 03_详细 > 02_局部方向内力的合力

局部方向内力的合力

  • 功 能

选择一些板单元的边缘(或一些实体单元的平面)，将这些边缘上的节点(或实体单元平面上的节点)的各内力相加，然后将相加的内力输出，输出位置为选择的板单元边缘的中心(或选择的实体单元平面的中心)。当做细部精密分析时，有时会将梁单元模拟成板单元或实体单元(或将板单元模拟成实体单元)，此时可用该功能，计算出设计时所需的构件内力，即重新计算出按梁单元(或板单元)设计时所需的内力。

  • 命 令

从主菜单中选择结果 > 局部方向内力的合力

在树形菜单的菜单表单中选择分析结果 > 局部方向内力的合力

  • 用 法

局部方向内力的合力

形式：指定将要进行内力相加的节点所属的平面单元(或实体单元)的方法。

交叉线选择

用线选择单元内的边缘。选择的边缘必须在该线上。

多边形选择

用多边形选择单元的边缘。定义多边形时，按选择节点的顺序及右手法则，决定输出合力的局部坐标系的x轴。并且只有当定义的x轴的相反方向(负方向)有单元时，定义的多边形才有效。

单元类型：选择要输出局部方向内力合力的单元类型

如果采用交叉线选择时，可以选择梁单元和板单元；

如果采用多边形选择，可以选择梁单元、板单元和实体单元。

梁单元和板单元可同时选择，以输出二者在该方向的合力。

荷载工况：选择相应的荷载工况或荷载组合。

容许误差：定义直线或多边形的公差。

输入坐标

位置：输入指定直线或多边形的点的整体坐标系坐标。

注：输入点的坐标，或单击输入区后在模型窗口中点击目标点。

当选择了用线选择板边缘时，输入定义一条直线的两点坐标后，需要另外输入定义方向的第三点，以确定考虑哪一侧的单元。

z 向量：输入一个矢量定义局部坐标系的z轴，作为输出结果的基准。(参见下面注解)

用线选择板边缘

注:
各单元内力的总和作用在选择的平面中心上，各内力的方向以局部坐标系为准。

用多边形选择边缘时，定义输出内力的局部坐标系的方法如下：

首先，根据点坐标的输入次序按右手法则确定局部坐标轴的x轴(大拇指方向)。其次，按前面输入的z轴矢量方向定义z轴。当未定义z向矢量时，程序默认输入的第一节点到第二节点的方向为局部坐标系的z轴。(参见下图)

当未定义z方向矢量时，在局部方向内力的合力对话框中单击 [image] ，将能观察到在单元中心点处显示的局部坐标轴。

定义内力输出的局部坐标系(未定义z向矢量时)

合力作用位置：

自动计算: 默认设置，在形心位置计算合力。如果为板单元，在重心位置自动计算合力。

用户输入: 用户输入整体坐标系中的坐标，用于计算合力。如果要计算两种以上类型的单元时，可选择此项。

输出结果：输出定义的线中心(或平面中心)的位置坐标和各局部坐标系方向(前面定义的)内力的合力。

名称：输入计算结果在文本文件中的名称。

输出文本：将计算结果输出到文本文件中。


11_位移参与系数

Home > midas Gen 2017 > 09_结果 > 03_详细 > 03_位移参与系数

位移参与系数

  • 功 能

每个单元基于横向荷载工况作用下的内力（轴力，扭矩，弯矩，剪力）而解出的位移参与系数可以用等值线和数值表示。为了校核位移参与系数，需要在发生最大位移的位置输入沿横向荷载工况作用方向的单位荷载。

  • 命 令

从主菜单选择结果> 位移参与系数

  • 用 法

位移荷载工况

选择进行单元/截面位移参与系数计算的横向荷载工况

点击 [image] 添加新的荷载工况或编辑及删除已定义的荷载工况。 (参阅荷载工况)

单位荷载工况

选择作用于最大位移处的单位荷载工况。单元/截面的位移参与系数是相对于单位荷载的作用位置及方向而言的。

点击 [image] 添加新的荷载工况或编辑、删除已定义的荷载工况。(参阅荷载工况.)

结果类型

单元: 单元位移参与系数

注:单元位移参与系数计算如下：

式中, [image]: 每个单元的位移参与系数

: 每个单元的各种位移成分

: 每个单元的重量

特性值: 截面特性值位移参与系数

注:简单的讲, 截面特性值位移参与系数计算如下：

式中, [image]: 每种截面特性值位移参与系数

m : 同样截面特性值的单元数量

让我们用一个简支梁的例子来说明，如图(Fig. 1a)所示它表示此梁在外荷载L作用下的挠度Δ，我们在此梁的挠度Δ方向及挠度最大点Δ处施加单位荷载，见图(Fig. 1b)。

(a) (b)

Fig. 1 单位荷载法

在 Fig. 1b中外力作用的虚功( [image] )表示如下

在Fig. 1a图中在外荷载L作用下的挠度Δ可以分解成轴向挠度 [image] ，弯曲挠度 [image] ，剪切挠度 [image] 和扭曲挠度 [image] ,且简支梁由单位荷载作用下产生的内力为 [image] ，单位荷载产生的内力所做的虚功而产生的挠度Δ表示为

如果梁的变形是线性的，且我们定义由外荷载L产生的内力为 [image] ，梁单元的挠度为

我们应用虚功原理， ( [image] ), 得到单位荷载法的方程式。

这里, [image] : 剪切形状系数

由单位荷载法引申到如一个建筑物受风荷载作用，如图Fig. 2b,在建筑物的顶部作用一单位荷载以此计算最大横向位移，如图Fig. 2a所示。如果我们把风荷载引起的位移当做虚位移 [image] 时，则此位移是各单元所贡献的位移之和。

式中, m : 单元的数量

是每个单元的位移参与系数, 表示如下

有横向支撑系统的位移参与系数可以计算且也可以做优化。

(a) (b)

Fig. 2 单位荷载法计算横向位移

成分

选择单元及截面特性值的各种内力成分的位移参与系数。

所有: 所有内力成分的位移参与系数总和

轴力: 在单元坐标系x轴方向上轴力成分的位移参与系数

扭矩: 在单元坐标系x轴上扭矩成分的位移参与系数

弯矩-y: 在单元坐标系y轴上弯矩成分的位移参与系数

弯矩-z: 在单元坐标系z轴上弯矩成分的位移参与系数

剪力-y: 在单元坐标系y轴剪力成分的位移参与系数

剪力-z: 在单元坐标系z轴剪力成分的位移参与系数

显示类型

指定显示形式如下：

等值线： 用等值线显示模型位移。

数值：显示位移参与系数分量的数值。数字的字型和颜色可在 [image] 显示选项中控制。

图例：在工作窗口的右边或左边显示与分析结果有关的各种图例。

位移参与系数

点击位移参与系数右侧的按钮 [image] ，弹出一个对话框，此对话框可以显示改变截面后的位移参与系数及截面重量的变化。

C

设计截面对话框

: 在截面列表中选择改变的截面

: 重新设置在列表中选择的初始模型的截面

: 重新设置初始模型中的所有截面

计算位移： 横向位移

增加位移： 位移增加值

减少重量

  钢材： 减少的结构钢材重量

混凝土： 减少的混凝土重量

: 将改变的截面更新模型中的原有截面


12_周期与振型

Home > midas Gen 2017 > 09_结果 > 04_模态 > 01_振型 > 01_周期与振型

周期与振型

  • 功 能

查看模型的特征值分析得到的振型形状和自振周期。

  • 命 令

从主菜单中选择结果 > 周期与振型

在树形菜单的菜单表单中选择结果 > 周期与振型

在图标菜单中单击 [image] 周期与振型

  • 用 法

荷载工况(模态号)

选择要求查看的振型。

按 [image] ，可以选择多个振型。

模态

在下列各项中选择要求的振型分量：

Md-X：振型分量X轴方向振型分量。

Md-Y：振型分量Y轴方向振型分量。

Md-Z：振型分量Z轴方向振型分量。

Md-XY：

Md-YZ：

Md-XZ：

Md-XYZ：

显示类型

指定显示类型如下：

模态：显示模态形状。

点击"模态"右侧的 [image] ，将显示如下对话框

振型形状放大系数：输入显示模态形状的系数。

三次插值方程：将每个节点的模态(包括转角模态)模拟成三次曲线。

三次插值系数：三次插值所用的系数，它影响单元曲线的形状(曲率)。

变形前： 将模型的变形前形状和变形后的形状重叠显示。

模型变形前形状的显示类型可在 [image] 显示选项中控制。

数值： 显示位移分量的数值。数字的字型和颜色可在 [image] 显示选项中控制。

点击数值右侧的 [image] ，弹出如下对话框。

小数点以下位数：指定小数形式的数值的精确度。

指数型：数值按指数形式显示。

最大和最小值：显示最小值和最大值。

最大绝对值：显示绝对值的最大值。

最大值：仅显示最大值。

最小值：仅显示最小值。

显示范围(%)：当某需要显示的值与选定的最大值或最小值的差在规定的范围以内时，在屏幕上显示该值。

显示角度：数值的显示方向。

注：默认的小数点可在参数设置中输入。当显示方向为0时，在节点或单元右侧，水平显示数值。角度的正方向为逆时针方向，正确选择显示方向，能更清晰地看到数值。

图例：在工作窗口的右边或左边显示与分析结果有关的各种图例。

点击图例右侧的 [image] ，弹出设定图例对话框。

图例的位置：选择图例在模型空间的位置。

图例数值类型：选择图例中的数值类型和小数点位数。

动画：动态显示变形过程。单击 [image] ，然后单击工作窗口底部动画控制板右边的 [image] 记录。

点击动画右侧的 [image] ，弹出如下对话框。

动画模式：选择表现分析结果的动画类型。

动画显示(颜色变化)等值线：选择该项，则随着变形量的改变，变形等值线的颜色也将发生变化。

重复半个周期：按半个周期重复放映动画，即从0到最大值。一般用于表现结构的一般变形。

重复整个周期：按整个周期重复放映动画，即从0到最大值，再到0。一般用于表现结构的振动变形和屈曲变形。

制作AVI选项：输入制作AVI动画的各控制数据。

颜色：选择动画的分辨率大小。可供选择的有256色(8位)、增强色(16位)、真彩色(24位)。

：选择压缩动画文件的程序。

半周期帧数(3～300)：模拟半周期的帧数。

每秒帧数：每秒帧数。

施工阶段选项：做施工阶段分析时，选择制作成动画的施工阶段。

施工阶段：选择该项时，在下面选择将制作成动画的施工阶段范围。

当前阶段内子步骤：选择该项时，表示将当前施工阶段各子步骤制作成动画。

等值线： 用等值线显示模型位移。

点击等值线右侧的 [image] ，弹出如下对话框。

范围：定义等值线的范围。

：指定等值线的颜色分布范围。使用该功能可为特定的区域赋以特定的颜色。点击该键，将显示如下对话框。

等值线值：列表中将显示各颜色等级代表的等值线值。颜色等级的数量为下面选择的颜色数量。

颜色数量：输入要包含在等值线中的颜色的数量(在6、12、18、24种颜色中选择)。

颜色：指定或控制等值线的颜色。

颜色表：输入颜色的变化顺序。

V->R->G->B：青紫色->红->绿->蓝。

R->G->B：红->绿->蓝。

R->B->G：红->蓝->绿。

Gray Scaled：渐变灰色。

：调整颜色变化的顺序。在此设定颜色的变化后，颜色表中的顺序将不起作用。

反转等值线图：反转等值线中颜色变化的次序。

等值线：指定等值线的边界线颜色。该项设定仅在右侧选择画等值线或单色线时才有效。

单元边界：指定单元的边界颜色。

等值线选项：选择表示等值线的方法。

填充涂色

颜色按梯度扩散：颜色渐变(模糊边界)。

画等值线：在等值线中显示彩色边界。

只显示等值线：仅用彩色等值线表现等值线图。

单色线：仅用单色线表现等值线图。

标注等值线注释：显示表示等值线范围和边界的注释。

标注间距：注释的标注间距。

快速显示等值线(用于较大的板或实体单元模型)：板或实体单元的模型较大时，使用简化的等值线，以减少显示等值线需要的时间。

扩展：表现板单元或实体单元的等值线图时，将单元局部坐标系的z轴方向为分析结果的正方向，生成三维等值线图。

注：该选项不能在变形形状中使用。也不能与消隐命令同时使用。当需要同时显示顶板束和底板束地内力(应力)时，也不能使用该选项。

放大系数：将沿单元局部坐标系的z轴方向表现的分析结果放大显示。


14_屈曲模态

Home > midas Gen 2017 > 09_结果 > 04_模态 > 01_振型 > 02_屈曲模态

屈曲模态

  • 功 能

查看模型的屈曲模态和临界荷载。

  • 命 令

从主菜单中选择结果 > 屈曲模态

在树形菜单的菜单表单中选择分析结果 > 屈曲模态

在图标菜单中单击 [image] 屈曲模态

  • 用 法

荷载工况(模态号)

选择要求查看的屈曲模态。

点击按钮 [image] ，可以选择多个屈曲模态。

模态成分

在下列各项中选择要求的屈曲模态分量：

Md-X：振型分量X轴方向屈曲模态分量。

Md-Y：振型分量Y轴方向屈曲模态分量。

Md-Z：振型分量Z轴方向屈曲模态分量。

Md-XY：

Md-YZ：

Md-XZ：

Md-XYZ：

显示类型

指定显示类型如下：

模态：显示模态形状。

点击"模态"右侧的 [image] ，将显示如下对话框

振型形状放大系数：输入显示模态形状的系数。

三次插值方程：将每个节点的模态(包括转角模态)模拟成三次曲线。

三次插值系数：三次插值所用的系数，它影响单元曲线的形状(曲率)。

变形前： 将模型的变形前形状和变形后的形状重叠显示。

模型变形前形状的显示类型可在 [image] 显示选项中控制。

数值： 显示位移分量的数值。数字的字型和颜色可在 [image] 显示选项中控制。

点击数值右侧的 [image] ，弹出如下对话框。

小数点以下位数：指定小数形式的数值的精确度。

指数型：数值按指数形式显示。

最大和最小值：显示最小值和最大值。

最大绝对值：显示绝对值的最大值。

最大值：仅显示最大值。

最小值：仅显示最小值。

显示范围(%)：当某需要显示的值与选定的最大值或最小值的差在规定的范围以内时，在屏幕上显示该值。

显示角度：数值的显示方向。

注：默认的小数点可在?参数设置?中输入。当显示方向为0时，在节点或单元右侧，水平显示数值。角度的正方向为逆时针方向，正确选择显示方向，能更清晰地看到数值。

图例：在工作窗口的右边或左边显示与分析结果有关的各种图例。

点击图例右侧的 [image] ，弹出设定图例对话框。

图例的位置：选择图例在模型空间的位置。

图例数值类型：选择图例中的数值类型和小数点位数。

动画：动态显示变形过程。单击 [image] ，然后单击工作窗口底部动画控制板右边的 [image] 记录。

点击动画右侧的 [image] ，弹出如下对话框。

动画模式：选择表现分析结果的动画类型。

动画显示(颜色变化)等值线：选择该项，则随着变形量的改变，变形等值线的颜色也将发生变化。

重复半个周期：按半个周期重复放映动画，即从0到最大值。一般用于表现结构的一般变形。

重复整个周期：按整个周期重复放映动画，即从0到最大值，再到0。一般用于表现结构的振动变形和屈曲变形。

制作AVI选项：输入制作AVI动画的各控制数据。

颜色：选择动画的分辨率大小。可供选择的有256色(8位)、增强色(16位)、真彩色(24位)。

：选择压缩动画文件的程序。

半周期帧数(3～300)：模拟半周期的帧数。

每秒帧数：每秒帧数。

施工阶段选项：做施工阶段分析时，选择制作成动画的施工阶段。

施工阶段：选择该项时，在下面选择将制作成动画的施工阶段范围。

当前阶段内子步骤：选择该项时，表示将当前施工阶段各子步骤制作成动画。

等值线： 用等值线显示模型位移。

点击等值线右侧的 [image] ，弹出如下对话框。

范围：定义等值线的范围。

：指定等值线的颜色分布范围。使用该功能可为特定的区域赋以特定的颜色。点击该键，将显示如下对话框。

等值线值：列表中将显示各颜色等级代表的等值线值。颜色等级的数量为下面选择的颜色数量。

颜色数量：输入要包含在等值线中的颜色的数量(在6、12、18、24种颜色中选择)。

颜色：指定或控制等值线的颜色。

颜色表：输入颜色的变化顺序。

V->R->G->B：青紫色->红->绿->蓝。

R->G->B：红->绿->蓝。

R->B->G：红->蓝->绿。

Gray Scaled：渐变灰色。

：调整颜色变化的顺序。在此设定颜色的变化后，颜色表中的顺序将不起作用。

反转等值线图：反转等值线中颜色变化的次序。

等值线：指定等值线的边界线颜色。该项设定仅在右侧选择画等值线或单色线时才有效。

单元边界：指定单元的边界颜色。

等值线选项：选择表示等值线的方法。

填充涂色

颜色按梯度扩散：颜色渐变(模糊边界)。

画等值线：在等值线中显示彩色边界。

只显示等值线：仅用彩色等值线表现等值线图。

单色线：仅用单色线表现等值线图。

标注等值线注释：显示表示等值线范围和边界的注释。

标注间距：注释的标注间距。

快速显示等值线(用于较大的板或实体单元模型)：板或实体单元的模型较大时，使用简化的等值线，以减少显示等值线需要的时间。

扩展：表现板单元或实体单元的等值线图时，将单元局部坐标系的z轴方向为分析结果的正方向，生成三维等值线图。

注：该选项不能在变形形状中使用。也不能与消隐命令同时使用。当需要同时显示顶板束和底板束地内力(应力)时，也不能使用该选项。

放大系数：将沿单元局部坐标系的z轴方向表现的分析结果放大显示。


13_组阻尼计算的各振型阻尼比

Home > midas Gen 2017 > 09_结果 > 04_模态 > 02_振型阻尼比

组阻尼计算的各振型阻尼比

  • 功 能

在设定了多个不同的组阻尼后，利用组阻尼中输入的值，以图形和表格的形式输出各振型阻尼比。

  • 命 令

从主菜单中选择结果 >组阻尼计算的各振型阻尼比

在树形菜单的菜单表单中选择结果 >组阻尼计算的各振型阻尼比

  • 用 法

图中上方是以图形显示的各个振型的频率和阻尼比，中间是以表格显示的各个振型的阻尼比，

质量和刚度系数的计算

能够计算与质量或刚度成比例的阻尼矩阵。可选择质量因子型阻尼、刚度因子型阻尼、质量和刚度因子型（Rayleigh Damping）阻尼。

振型1、振型2：为计算质量系数和刚度系数，选择2个振型。

阻尼选项：

质量因子：以质量因子方式计算阻尼比。

刚度因子：以刚度因子方式计算阻尼比。

振型1：选择计算阻尼比用的第一个振型。

振型2：选择计算阻尼比用的第二个振型。

：根据输入的振型为基础，计算质量系数（Alpha）和刚度系数（Beta）。点击该按钮则在右边显示计算出的Alpha和Beta值。

：调整X、Y轴的最大/最小值，修改图形输出区域。点击该按钮，则弹出如下对话框，可以对坐标轴参数进行设置。

X-轴最小：指定X轴最小值

X-轴最大：指定X轴最大值

Y-轴最小：指定Y轴最小值

Y-轴最大：指定Y轴最大值

：利用计算得出的Alpha、Beta值，输出Rayleigh Damping图形。点击后在最上方的图形中显示计算出的阻尼比。

：关闭对话框。


15_反应谱分析节点结果

Home > midas Gen 2017 > 09_结果 > 04_模态 > 03_反应谱节点结果

反应谱分析节点结果

  • 功 能

查看模型反应谱分析后得到的各个节点的结果。

  • 命 令

从主菜单中选择结果 > 反应谱分析节点结果

在树形菜单的菜单表单中选择结果 > 反应谱分析节点结果

  • 用 法

节点结果荷载工况

选择要求查看的反应谱荷载工况。

输出

惯性力：输出节点的惯性力；

加速度：输出节点的加速度；

模态：选择模态的名称。

成分

在下列各项中选择要求的分量：

FX：整体坐标系X轴方向的惯性力。

FY：整体坐标系Y轴方向的惯性力。

FZ：整体坐标系Z轴方向的惯性力。

MX：绕整体坐标系X轴方向的弯矩。

MY：绕整体坐标系Y轴方向的弯矩。

MZ：绕整体坐标系Z轴方向的弯矩。

FXY:整体坐标系XY平面内的惯性力。

FYZ:整体坐标系YZ平面内的惯性力。

FXZ:整体坐标系XZ平面内的惯性力。

FXYZ: 整体坐标系XYZ的惯性力。

显示类型

指定显示类型如下：

变形： 显示模型变形后的形状。点击变形右侧的 [image] ，弹出如下对话框。

变形图的比例：放大或缩小变形的显示比例。

变形的表现方式：选择显示变形的方式。

节点位移：只显示节点位移的变形形状。

实际变形：显示详细的变形形状，包括沿两端节点之间任意截面的变形以及梁单元的节点变形。在施工阶段分析中，为了加快速度及节省时间，只提供节点位移。

实际位移(关闭自动调整)：按实际比例显示图变形。选择该项则输入的变形图的比例将不起作用。

相对位移：将最小位移设置为0，其他节点显示相对位移。

无变形： 不显示模型变形后的形状。

数值： 显示位移分量的数值。数字的字型和颜色可在 [image] 显示选项中控制。

点击数值右侧的 [image] ，弹出如下对话框。

小数点以下位数：指定小数形式的数值的精确度。

指数型：数值按指数形式显示。

最大和最小值：显示最小值和最大值。

最大绝对值：显示绝对值的最大值。

最大值：仅显示最大值。

最小值：仅显示最小值。

显示范围(%)：当某需要显示的值与选定的最大值或最小值的差在规定的范围以内时，在屏幕上显示该值。

显示角度：数值的显示方向。

注：默认的小数点可在?参数设置?中输入。当显示方向为0时，在节点或单元右侧，水平显示数值。角度的正方向为逆时针方向，正确选择显示方向，能更清晰地看到数值。

图例：在工作窗口的右边或左边显示与分析结果有关的各种图例。

点击图例右侧的 [image] ，弹出?设定图例?对话框。

图例的位置：选择图例在模型空间的位置。

图例数值类型：选择图例中的数值类型和小数点位数。

动画：动态显示变形过程。单击 [image] ，然后单击工作窗口底部动画控制板右边的 [image] 记录。

点击动画右侧的 [image] ，弹出如下对话框。

动画模式：选择表现分析结果的动画类型。

动画显示(颜色变化)等值线：选择该项，则随着变形量的改变，变形等值线的颜色也将发生变化。

重复半个周期：按半个周期重复放映动画，即从0到最大值。一般用于表现结构的一般变形。

重复整个周期：按整个周期重复放映动画，即从0到最大值，再到0。一般用于表现结构的振动变形和屈曲变形。

制作AVI选项：输入制作AVI动画的各控制数据。

颜色：选择动画的分辨率大小。可供选择的有256色(8位)、增强色(16位)、真彩色(24位)。

：选择压缩动画文件的程序。

半周期帧数(3～300)：模拟半周期的帧数。

每秒帧数：每秒帧数。

施工阶段选项：做施工阶段分析时，选择制作成动画的施工阶段。

施工阶段：选择该项时，在下面选择将制作成动画的施工阶段范围。

当前阶段内子步骤：选择该项时，表示将当前施工阶段各子步骤制作成动画。

镜像：通过反射面将1/2或1/4模型的分析结果展开成整个模型的结果。

点击?镜像?右侧的 [image] ，弹出如左图的对话框。

1/2模型的镜像：通过对称面将1/2模型的分析结果展开成整个模型的结果。

1/4模型的镜像：通过对称面将1/4模型的分析结果展开成整个模型的结果。

对称面：指定一个整体坐标系平面为对称面。


01_位移/速度/加速度

Home > midas Gen 2017 > 09_结果 > 05_时程 > 01_时程分析结果 > 01_位移/速度/加速度

位移/速度/加速度

  • 功 能

查看时程分析后模型的位移、速度和加速度的结果。

  • 命 令

从主菜单中选择结果 > 时程分析结果 > 位移/速度/加速度

在树形菜单的菜单表单中选择结果 > 时程分析结果 > 位移/速度/加速度

  • 输 入

时程荷载工况名称

选择时程荷载工况。

单击右边的 [image] 输入新的或修改现有的荷载工况。(参见?荷载工况?)

步骤：选择输出的步骤。

时间函数

选择时间函数。

位移：输出位移结果

速度：输出速度结果

加速度：输出加速度结果

成分

在下列各项中选择分量：

DX：整体坐标系X轴方向的分量。

DY：整体坐标系Y轴方向的分量。

DZ：整体坐标系Z轴方向的分量。

DXY =

DYZ =

DXZ =

DXYZ =

   显示类型

指定显示形式如下：

变形： 显示模型变形后的形状。点击?变形?右侧的 [image] ，弹出如下对话框。

变形图的比例：放大或缩小变形的显示比例。

变形的表现方式：选择显示变形的方式。

节点位移：只显示节点位移的变形形状。

实际变形：显示详细的变形形状，包括沿两端节点之间任意截面的变形以及梁单元的节点变形。在施工阶段分析中，为了加快速度及节省时间，只提供节点位移。

实际位移(关闭自动调整)：按实际比例显示图变形。选择该项则输入的变形图的比例将不起作用。

相对位移：将最小位移设置为0，其他节点显示相对位移。

变形前： 将模型的变形前形状和变形后的形状重叠显示。

模型变形前形状的显示类型可在 [image] 显示选项中控制。

数值： 显示位移分量的数值。数字的字型和颜色可在 [image] 显示选项中控制。

点击数值右侧的 [image] ，弹出如下对话框。

小数点以下位数：指定小数形式的数值的精确度。

指数型：数值按指数形式显示。

最大和最小值：显示最小值和最大值。

最大绝对值：显示绝对值的最大值。

最大值：仅显示最大值。

最小值：仅显示最小值。

显示范围(%)：当某需要显示的值与选定的最大值或最小值的差在规定的范围以内时，在屏幕上显示该值。

显示角度：数值的显示方向。

注：默认的小数点可在参数设置中输入。当显示方向为0时，在节点或单元右侧，水平显示数值。角度的正方向为逆时针方向，正确选择显示方向，能更清晰地看到数值。

图例：在工作窗口的右边或左边显示与分析结果有关的各种图例。

点击?图例?右侧的 [image] ，弹出?设定图例?对话框。

图例的位置：选择图例在模型空间的位置。

图例数值类型：选择图例中的数值类型和小数点位数。

动画

开始时间：设置动画开始的时间。

结束时间：设置动画结束的时间。

增幅：设置动画的增幅。

设置默认时间：点击该按钮设置默认的动画时间。


02_内力(梁/桁架/一般连接)

Home > midas Gen 2017 > 09_结果 > 05_时程 > 01_时程分析结果 > 02_内力(梁/桁架/一般连接)

内力(梁/桁架/一般连接)

  • 功 能

查看梁、桁架、一般连接单元的时程分析后的结构内力。

  • 命 令

从主菜单中选择结果 > 时程分析结果 > 内力(梁/桁架/一般连接)

在树形菜单的菜单表单中选择结果 > 时程分析结果 > 内力(梁/桁架/一般连接)

  • 输 入

函数

选择时程结果函数。

时程荷载工况名称

选择已定义的时程荷载工况。

单击右边的 [image] 输入新的或修改现有的时程荷载工况。(参见"时程荷载工况")

步骤：选择输出的步骤。可以选择非线性分析的荷载步骤、施工阶段分析的各步骤、水化热分析的各步骤。

时间函数

选择已定义的时程荷载函数。

成分

Fx：单元坐标系x方向的轴力。

Fy：单元坐标系y方向的剪力。

Fz：单元坐标系z方向的剪力。

Mx：绕单元坐标系x轴的扭矩。

My：绕单元坐标系y轴的弯矩。

Mz：绕单元坐标系z轴的弯矩。

显示类型

指定显示形式如下：

等值线： 用等值线显示模型位移。

点击等值线右侧的 [image] ，弹出如下对话框。

范围：定义等值线的范围。

：指定等值线的颜色分布范围。使用该功能可为特定的区域赋以特定的颜色。点击该键，将显示如下对话框。

等值线值：列表中将显示各颜色等级代表的等值线值。颜色等级的数量为下面选择的颜色数量。

颜色数量：输入要包含在等值线中的颜色的数量(在6、12、18、24种颜色中选择)。

颜色：指定或控制等值线的颜色。

颜色表：输入颜色的变化顺序。

V->R->G->B：青紫色->红->绿->蓝。

R->G->B：红->绿->蓝。

R->B->G：红->蓝->绿。

Gray Scaled：渐变灰色。

：调整颜色变化的顺序。在此设定颜色的变化后，颜色表中的顺序将不起作用。

反转等值线图：反转等值线中颜色变化的次序。

等值线：指定等值线的边界线颜色。该项设定仅在右侧选择画等值线或单色线时才有效。

单元边界：指定单元的边界颜色。

等值线选项：选择表示等值线的方法。

填充涂色

颜色按梯度扩散：颜色渐变(模糊边界)。

画等值线：在等值线中显示彩色边界。

只显示等值线：仅用彩色等值线表现等值线图。

单色线：仅用单色线表现等值线图。

标注等值线注释：显示表示等值线范围和边界的注释。

标注间距：注释的标注间距。

快速显示等值线(用于较大的板或实体单元模型)：板或实体单元的模型较大时，使用简化的等值线，以减少显示等值线需要的时间。

扩展：表现板单元或实体单元的等值线图时，将单元局部坐标系的z轴方向为分析结果的正方向，生成三维等值线图。

注：该选项不能在变形形状中使用。也不能与消隐命令同时使用。当需要同时显示顶板束和底板束地内力(应力)时，也不能使用该选项。

放大系数：将沿单元局部坐标系的z轴方向表现的分析结果放大显示。

变形： 显示模型变形后的形状。点击变形右侧的 [image] ，弹出如下对话框。

变形图的比例：放大或缩小变形的显示比例。

变形的表现方式：选择显示变形的方式。

节点位移：只显示节点位移的变形形状。

实际变形：显示详细的变形形状，包括沿两端节点之间任意截面的变形以及梁单元的节点变形。在施工阶段分析中，为了加快速度及节省时间，只提供节点位移。

实际位移(关闭自动调整)：按实际比例显示图变形。选择该项则输入的变形图的比例将不起作用。

相对位移：将最小位移设置为0，其他节点显示相对位移。

数值： 显示位移分量的数值。数字的字型和颜色可在 [image] 显示选项中控制。

点击数值右侧的 [image] ，弹出如下对话框。

小数点以下位数：指定小数形式的数值的精确度。

指数型：数值按指数形式显示。

最大和最小值：显示最小值和最大值。

最大绝对值：显示绝对值的最大值。

最大值：仅显示最大值。

最小值：仅显示最小值。

显示范围(%)：当某需要显示的值与选定的最大值或最小值的差在规定的范围以内时，在屏幕上显示该值。

显示角度：数值的显示方向。

注：默认的小数点可在参数设置中输入。当显示方向为0时，在节点或单元右侧，水平显示数值。角度的正方向为逆时针方向，正确选择显示方向，能更清晰地看到数值。

图例：在工作窗口的右边或左边显示与分析结果有关的各种图例。

点击图例右侧的 [image] ，弹出设定图例对话框。

图例的位置：选择图例在模型空间的位置。

图例数值类型：选择图例中的数值类型和小数点位数。

变形前： 将模型的变形前形状和变形后的形状重叠显示。

模型变形前形状的显示类型可在 [image] 显示选项中控制。

动画

开始时间：输入分析结果动态分析开始时间。

结束时间：输入分析结果动态分析结束时间。

增幅：输入分析分析结果动态分析时间增量。

：点击该按钮设置分析结果动态分析时间为默认时间。

输出截面位置

指定梁单元内力值的输出位置。仅在选择输出"数值"时，该项才会被激活。

i端：显示梁单元起始节点(N1)处的内力值。

中心：显示梁单元中点处的内力值。

j端：显示梁单元结束节点(N2)处的内力值。

绝对最大：将梁单元的四等分点中绝对最大内力值，作为梁单元中心的内力输出。

Min/Max：将梁单元的四等分点中绝对最大最小内力值，显示在适当位置。

全部：同时显示起始节点i、结束节点j以及中心点的内力。


03_内力图(梁/桁架/一般连接)

Home > midas Gen 2017 > 09_结果 > 05_时程 > 01_时程分析结果 > 03_内力图(梁/桁架/一般连接)

内力图(梁/桁架/一般连接)

  • 功 能

以内力图的形式查看梁、桁架、一般连接单元的时程分析后的结构内力。

  • 命 令

从主菜单中选择结果 > 时程分析结果 > 内力图(梁/桁架/一般连接)

在树形菜单的菜单表单中选择结果 > 时程分析结果 > 内力图(梁/桁架/一般连接)

  • 输 入

函数

选择时程结果函数。

时程荷载工况名称

选择已定义的时程荷载工况。

单击右边的 [image] 输入新的或修改现有的时程荷载工况。(参见时程荷载工况)

步骤：选择输出的步骤。可以选择非线性分析的荷载步骤、施工阶段分析的各步骤、水化热分析的各步骤。

时间函数

选择已定义的时程荷载函数。

成分

Fx：单元坐标系x方向的轴力。

Fy：单元坐标系y方向的剪力。

Fz：单元坐标系z方向的剪力。

Mx：绕单元坐标系x轴的扭矩。

My：绕单元坐标系y轴的弯矩。

Mz：绕单元坐标系z轴的弯矩。

显示类型

参见 结果>时程分析结果>内力（梁/桁架/一般连接）。


04_应力(梁/桁架)

Home > midas Gen 2017 > 09_结果 > 05_时程 > 01_时程分析结果 > 04_应力(梁/桁架)

应力(梁/桁架)

  • 功 能

查看梁、桁架单元的时程分析后的结构应力。

  • 命 令

从主菜单中选择结果 > 时程分析结果 > 应力(梁/桁架)

在树形菜单的菜单表单中选择结果 > 时程分析结果 > 应力(梁/桁架)

  • 输 入

函数:选择时程结果函数。

时程荷载工况名称

选择已定义的时程荷载工况。

单击右边的 [image] 输入新的或修改现有的时程荷载工况。(参见时程荷载工况)

步骤：选择输出的步骤。可以选择非线性分析的荷载步骤、施工阶段分析的各步骤、水化热分析的各步骤。

时间函数:选择已定义的时程荷载函数。

成分

Sax：在单元局部坐标系x轴方向,轴力产生的轴向应力。

Ssy：在单元局部坐标系y轴方向,剪力Qy产生的剪应力。

Ssz：在单元局部坐标系y轴方向,剪力Qy产生的剪应力。

Sby：在单元坐标系y轴方向,弯矩Mz产生的截面应力。

Sbz：在单元坐标系z轴方向,弯矩My产生的截面应力。

组合：轴力产生的应力加上两个方向弯矩产生的应力(Sax+Sby+Sbz)。

最大值：在1、2、3、4位置中组合应力的最大值。

1、2、3、4：( )内y和z表示所处的位置，如1(-y, z)表示1号点位置在-y、+z位置。

注:只有在定义截面时，输入有计算梁单元的应力所需的数据(或程序可以自动计算出相应数据)时，程序才提供梁单元的计算结果，反之不提供应力计算结果(为0值)。例如：当在截面中按用户定义输入刚度时，只输入有面积、惯性矩时，程序不能获得相应应力计算信息(如截面高度y值)，所以不能提供应力值。

显示类型

参见结果》时程分析结果》内力（梁/桁架/一般连接）。


05_非弹性铰状态

Home > midas Gen 2017 > 09_结果 > 05_时程 > 01_时程分析结果 > 05_非弹性铰状态

非弹性铰状态

  • 功 能

查看非弹性铰的结果。

非弹性铰仅适用于非弹性时程分析。

  • 命 令

从主菜单中选择结果 > 时程分析结果 > 非弹性铰状态

在树形菜单的菜单表单中选择分析结果 > 时程分析结果 > 非弹性铰状态

  • 输 入

荷载工况/荷载组合

选择荷载工况或荷载组合。单击右边的 [image] 输入新的或修改现有的荷载工况。(参见? 荷载工况 /荷载组合?)

步骤：选择输出的步骤。可以选择非线性分析的荷载步骤、施工阶段分析的各步骤、水化热分析的各步骤。

时间函数

从列表中选择时间函数。

结果类型

选择查看的结果类型。

铰状态：以铰状态方式显示。

延性系数（D/D1）：以延性系数D/D1方式显示（当前变形和第一阶段屈服变形的比值）。

延性系数（D/D2）：以延性系数D/D2方式显示（当前变形和第二阶段屈服变形的比值）。

注：第一阶段屈服变形和第二阶段屈服变形分别为材料达到了第一阶段屈服强度和第二阶段屈服强度时的变形。有关第一阶段屈服强度和第二阶段屈服强度的定义参见在线帮助?模型 > 材料和截面特性 > 非弹性铰特性值?中的解释。

变形：以变形方式显示。

内力：以内力方式显示。

屈服状态：以屈服状态方式显示。

成分

在下列各项中选择位移分量：

DX：整体坐标系X轴方向的位移分量。

DY：整体坐标系Y轴方向的位移分量。

DZ：整体坐标系Z轴方向的位移分量。

RX：绕整体坐标系X轴的转角分量。

RY：绕整体坐标系Y轴的转角分量。

RZ：绕整体坐标系Z轴的转角分量。

数值类型

正：在正方向的最大值。

负：在负方向的最大值。

绝对值最大值：绝对值最大的位移值。

显示类型

指定显示形式如下：

等值线： 用等值线显示模型位移。

点击等值线右侧的 [image] ，弹出如下对话框。

范围：定义等值线的范围。

：指定等值线的颜色分布范围。使用该功能可为特定的区域赋以特定的颜色。点击该键，将显示如下对话框。

等值线值：列表中将显示各颜色等级代表的等值线值。颜色等级的数量为下面选择的颜色数量。

颜色数量：输入要包含在等值线中的颜色的数量(在6、12、18、24种颜色中选择)。

颜色：指定或控制等值线的颜色。

颜色表：输入颜色的变化顺序。

V->R->G->B：青紫色->红->绿->蓝。

R->G->B：红->绿->蓝。

R->B->G：红->蓝->绿。

Gray Scaled：渐变灰色。

：调整颜色变化的顺序。在此设定颜色的变化后，颜色表中的顺序将不起作用。

反转等值线图：反转等值线中颜色变化的次序。

等值线：指定等值线的边界线颜色。该项设定仅在右侧选择画等值线或单色线时才有效。

单元边界：指定单元的边界颜色。

等值线选项：选择表示等值线的方法。

填充涂色

颜色按梯度扩散：颜色渐变(模糊边界)。

画等值线：在等值线中显示彩色边界。

只显示等值线：仅用彩色等值线表现等值线图。

单色线：仅用单色线表现等值线图。

标注等值线注释：显示表示等值线范围和边界的注释。

标注间距：注释的标注间距。

快速显示等值线(用于较大的板或实体单元模型)：板或实体单元的模型较大时，使用简化的等值线，以减少显示等值线需要的时间。

扩展：表现板单元或实体单元的等值线图时，将单元局部坐标系的z轴方向为分析结果的正方向，生成三维等值线图。

注：该选项不能在变形形状中使用。也不能与消隐命令同时使用。当需要同时显示顶板束和底板束地内力(应力)时，也不能使用该选项。

放大系数：将沿单元局部坐标系的z轴方向表现的分析结果放大显示。

变形： 显示模型变形后的形状。点击变形右侧的 [image] ，弹出如下对话框。

变形图的比例：放大或缩小变形的显示比例。

变形的表现方式：选择显示变形的方式。

节点位移：只显示节点位移的变形形状。

实际变形：显示详细的变形形状，包括沿两端节点之间任意截面的变形以及梁单元的节点变形。在施工阶段分析中，为了加快速度及节省时间，只提供节点位移。

实际位移(关闭自动调整)：按实际比例显示图变形。选择该项则输入的变形图的比例将不起作用。

相对位移：将最小位移设置为0，其他节点显示相对位移。

数值： 显示位移分量的数值。数字的字型和颜色可在 [image] 显示选项中控制。

点击数值右侧的 [image] ，弹出如下对话框。

小数点以下位数：指定小数形式的数值的精确度。

指数型：数值按指数形式显示。

最大和最小值：显示最小值和最大值。

最大绝对值：显示绝对值的最大值。

最大值：仅显示最大值。

最小值：仅显示最小值。

显示范围(%)：当某需要显示的值与选定的最大值或最小值的差在规定的范围以内时，在屏幕上显示该值。

显示角度：数值的显示方向。

注：默认的小数点可在?参数设置?中输入。当显示方向为0时，在节点或单元右侧，水平显示数值。角度的正方向为逆时针方向，正确选择显示方向，能更清晰地看到数值。

图例：在工作窗口的右边或左边显示与分析结果有关的各种图例。

点击图例右侧的 [image] ，弹出设定图例对话框。

图例的位置：选择图例在模型空间的位置。

图例数值类型：选择图例中的数值类型和小数点位数。

变形前： 将模型的变形前形状和变形后的形状重叠显示。

模型变形前形状的显示类型可在 [image] 显示选项中控制。

动画

开始时间：设置动画开始的时间。

结束时间：设置动画结束的时间。

增幅：设置动画的增幅。

设置默认时间：点击该按钮设置默认的动画时间。


06_纤维截面分析结果

Home > midas Gen 2017 > 09_结果 > 05_时程 > 01_时程分析结果 > 06_纤维截面分析结果

纤维截面分析结果

  • 功 能

查看利用纤维单元的时程分析结果。可查看利用纤维单元的非弹性梁的多样的内力和纤维截面各块的应力-应变结果和破坏程度。

  • 命 令

从主菜单中选择结果 > 时程分析结果 > 纤维截面分析结果

在树形菜单的菜单表单中选择结果 > 时程分析结果 > 纤维截面分析结果

  • 输 入

单元

输入利用纤维单元的单元号。

荷载工况

选择已输入的时程荷载工况。

输出对象

截面：输出被选单元全截面分析结果。

纤维：输出纤维截面各块的分析结果。

位置：在单元长度方向选择输出结果位置。位置可在如下图所示位置中选择。

图形类型

指定输出结果坐标轴的表示成分。

输出对象选择了截面时：

X轴和Y轴可以任意选择输出成分。X轴可选则Dx、Ry、Rz、Fx、My、Mz、Time，Y轴可选择Dx、Ry、Rz、Fx、My、Mz。对常用的6种组合可以直接点击按钮即可。

Dx-Fx：单元坐标系x轴方向位移-轴力

My-Fx：绕单元坐标系y轴弯矩-x方向轴力

Ry-My：绕单元坐标系y轴的旋转角度-绕y轴弯矩

Mz-Fx：绕单元坐标系z轴弯矩-x方向轴力

Rz-Mz：绕单元坐标系z轴的旋转角度-绕z轴弯矩

My-Mz：绕单元坐标系y轴弯矩-绕z轴弯矩

输出对象选择了纤维时：

SN：应变（Strain）

SS：应力（Stress）

输出表格：以表格的形式输出时程分析结果。

：根据设定的坐标轴输出图形。

：选择纤维截面的块。

：取消所有选择。

：画面对齐。

：放大被选区域。

：放大整体画面。

：缩小整体画面。

：显示或不显示坐标轴。

纤维状态

受拉：输出受拉端的分析结果。

受压：输出受压端的分析结果。

弹性、裂缝、屈服、破碎：可修改相应的输出颜色。

混合：调整输出颜色的浓度。

：分析结果的图形数据，以BMP文件的格式输出。

MIDAS/Gen提供的纤维材料的滞回模型如下，钢材有4种，混凝土有5种。

  • 钢材的纤维材料特性

受拉区：弹性、屈服

受压区：弹性、屈服

  • 混凝土的纤维材料特性

受拉区：弹性、裂缝

受压区：弹性、破坏

Menegotto-Pinto 模型

四边形区域内为弹性阶段，区域外为屈服阶段。

双折线模型

四边形区域内为弹性阶段，区域外为屈服阶段。

非对称双折线模型

四边形区域内为弹性阶段，区域外为屈服阶段。

三折线模型

四边形区域内为弹性阶段，区域外为屈服阶段。

Kent & Park 模型

日本混凝土标准规范

日本公路标准模型

名古屋高速公路社团模型

三折线混凝土模型

动画

步骤：定义在图表中要查看的时程分析结果步骤。

增幅：输出图表特定步骤增幅。

时间：输出当前步骤荷载的实际时间。

：生成时程分析结果的动画。间隔为上面输入的增幅间隔。

：暂停。

：停止。

：转到动画开始的步骤。

：转到一倍增幅数量前的步骤。

：转到一倍增幅数量后的步骤。

：转到动画结束的步骤。


07_时程分析图形

Home > midas Gen 2017 > 09_结果 > 05_时程 > 02_时程图表/文本 > 01_时程分析图形

时程分析图形

  • 功 能

用图表查看随时间变化的时程分析的结果，包括桁架单元和梁单元的位移、单元内力、应力，非线性连接单元的单元力和变形。

  • 命 令

从主菜单中选择结果 > 时程分析结果 > 时程分析图形

在树形菜单的菜单表单中选择结果 > 时程分析结果 > 时程分析图形

  • 输 入

定义/编辑函数

目前可以提供桁架单元、梁单元、板单元、实体单元的位移、速度、加速度时程分析图形。以及桁架单元、梁单元、非线性连接单元、板单元、实体单元的内力和应力时程分析图形。点击 [image] ，定义输出的时程结果函数。点击 [image] ，定义输出的内容。

函数列表

在函数列表中选择将输出的函数，也可删除已经定义的函数。

在定义的函数列表中选择相应函数后，点击按钮从列表中添加可以添加该函数。

在定义的函数列表中选择相应函数后，点击 [image] 可以删除该函数。

横轴

选择图形的横轴的刻度基准。

显示类型

输入时程图形的标题和坐标轴输出结果的形式。

图形标题：输入图形标题。

X轴刻度小数点位数(指数型)：十进制的位数并选择是否表示为指数型。

Y轴刻度小数点位数(指数型)：十进制的位数并选择是否表示为指数型。

类型

选择输出的图表内容。

时程图表：时程分析结果的时程图表。

各模型最大值图表：输出各振型(频率)的最大值，既FFT分析结果。

使用性能评价图表：将使用性能分析结果与日本居住性能评价规范(1991)进行比较的图表。有关居住性能评价的方法，请参考有关规范和书籍。

点击 [image] ，将选择的函数生成图表后输出。

注：定义输出函数的方法如下:

点击 [image] 时，定义输出的时程结果函数。

定义函数：选择输出的结果类型。

图形函数：图形结果。

步骤函数：步骤结果。

点击 [image] ，定义输出的内容。

函数列表：

显示已经定义好的函数名称及类型。

点击退回：退回到上一级对话框中。

点击编辑：编辑选择的函数。

点击删除：删除选择的函数。

点击关闭：关闭对话框。

当选择位移时

位移

名称：输入函数名称。

节点号：输入将要输出位移的节点号。

结果类型：选择输出的结果类型。

位移：位移结果。

速度：速度结果。

加速度:加速度结果。

参考点：选择位移的参考点。

地面：选择地面为参考点。

添加地面作用：选择运动前的地面为参考点。

另一节点：选择另一节点为参考点。

输出分量：选择位移的输出方向。可以选择DX、DY、DZ、RX、RY、RZ。

时程荷载工况：选择荷载工况。

包括模态数量：选择输出的模态数量，可以选择全部或者一个。

点击 [image] ，生成函数并将其添加到输出目录中。

点击 [image] ，取消输入的数据并退回到上一级对话框中。

当选择桁架单元内力/应力时

名称：输入桁架单元的内力/应力的函数名称。

单元号：输入将要输出内力/应力的桁架单元号。

结果类型：选择是输出内力还是输出应力。

点：选择内力或应力的输出位置可选择I-节点或J-节点。

时程荷载工况：选择荷载工况。

包括模态数量：选择输出的模态数量，可以选择全部或者一个。

点击 [image] ，生成函数并将其添加到输出目录中。

点击 [image] ，取消输入的数据并退回到上一级对话框中。

当选择梁单元内力/应力时

名称：输入梁单元的内力/应力的函数名称。

单元号：输入将要输出内力/应力的梁单元号。

结果类型：选择输出的是内力还是应力。

内力：可选择的内力组成有轴向、剪切-y、剪切-z、扭矩、弯矩-y、弯矩-z。

应力：可选择的应力组成有轴向、剪切-y、剪切-z、弯曲应力(+y)、弯曲应力(-y)、弯曲应力(+z)、弯曲应力(-z)。

点：选择内力或应力的输出位置可选择I-节点或J-节点。

输出分量：选择输出的内力或应力成分。

包含轴向应力：选择此项时，输出弯曲应力=弯矩引起的应力+轴力引起的应力。

时程荷载工况：选择荷载工况。

包括模态数量：选择输出的模态数量，可以选择全部或者一个。

点击 [image] ，生成函数并将其添加到输出目录中。

点击 [image] ，取消输入的数据并退回到上一级对话框中。

当选择平面应力单元的内力/应力时

名称：输入平面应力单元的内力/应力的函数名称。

单元号：输入将要输出内力/应力的桁架单元号。

内力、应力：选择是输出内力还是输出应力。

点：选择内力或应力的输出位置可选择I-节点或J-节点。

输出分量：选择输出的内力或应力成分。

时程荷载工况：选择荷载工况。

包括模态数量：选择输出的模态数量，可以选择全部或者一个。

点击 [image] ，生成函数并将其添加到输出目录中。

点击 [image] ，取消输入的数据并退回到上一级对话框中。

当选择平面应变单元内力/应力时

名称：输入平面应变单元内力/应力的函数名称。

单元号：输入将要输出内力/应力的桁架单元号。

结果类型：选择是输出内力还是输出应力。

点：选择内力或应力的输出位置可选择I-节点或J-节点。

成分：选择输出的内力或应力成分。

时程荷载工况：选择荷载工况。

包括模态数量：选择输出的模态数量，可以选择全部或者一个。

点击 [image] ，生成函数并将其添加到输出目录中。

点击 [image] ，取消输入的数据并退回到上一级对话框中。

当选择板单元内力/应力时

名称：输入板单元内力/应力的函数名称。

单元号：输入将要输出内力/应力的桁架单元号。

内力、应力、单元内力：选择是输出内力还是输出应力或者单元内力。

点：选择内力或应力的输出位置可选择I-节点或J-节点。

输出分量：选择输出的内力或应力成分。

时程荷载工况：选择荷载工况。

包括模态数量：选择输出的模态数量，可以选择全部或者一个。

点击 [image] ，生成函数并将其添加到输出目录中。

点击 [image] ，取消输入的数据并退回到上一级对话框中。

当选择实体单元内力/应力时

名称：输入实体单元的内力/应力的函数名称。

单元号：输入将要输出内力/应力的桁架单元号。

内力、应力：选择是输出内力还是输出应力。

点：选择内力或应力的输出位置可选择I-节点或J-节点。

输出分量：选择输出的内力或应力成分。

时程荷载工况：选择荷载工况。

包括模态数量：选择输出的模态数量，可以选择全部或者一个。

点击 [image] ，生成函数并将其添加到输出目录中。

点击 [image] ，取消输入的数据并退回到上一级对话框中。

当选择非线性连接单元的变形/内力时

名称：输入非线性连接单元的变形/内力的函数名称。

非线性连接号：选择非线性连接号。

类型：选择是输出变形、I-节点内力还是J-节点内力。

内力成分：选择变形或内力的输出成分。

时程荷载工况：选择荷载工况。

点击 [image] ，生成函数并将其添加到输出目录中。

点击 [image] ，取消输入的数据并退回到上一级对话框中。

当选择非弹性铰变形/内力时

名称：输入非弹性铰变形/内力的函数名称。

单元号：输入将要输出内力/应力的桁架单元号。

结果类型：选择是输出变形还是内力。

成分：选择变形或内力输出的成分。

位置：根据非弹性铰类型的不同而变化。

时程荷载工况：选择荷载工况。

点击 [image] ，生成函数并将其添加到输出目录中。

点击 [image] ，取消输入的数据并退回到上一级对话框中。

在上面时程分析图表中点击右键，将出现下列关联菜单。

修改标题和标签

可以修改图形的标题和图形的x、y轴的名称。(参见下图)

缩小：在图形上用鼠标滑动，被滑过的区域将被放大。使用?缩小?功能可以恢复到缩小前状态。

恢复到初始画面：恢复到初始画面状态。

时间 <-> 频率：使用快速傅立叶变换(Fast Fourier Transform method)FFT分析功能，将时间(或频率)为变量的图形转换为频率(或时间)为变量的图形。

X轴-对数刻度：将X轴的刻度变为对数刻度。重新点击该命令，可恢复到原来刻度。

Y轴-对数刻度：将X轴的刻度变为对数刻度。重新点击该命令，可恢复到原来刻度。

修改图形范围：可以确定输出图形的范围。

自动确定：输出初始画面。该项被选择时，在下面输入的X、Y轴的最大最小值将不起作用。

以图形保存图表：可以将图表保存为BMP、JPG、EMF格式的图形。

以文本格式保存图表：可以将图表内容保存为文本格式。


09_时程分析文本

Home > midas Gen 2017 > 09_结果 > 05_时程 > 02_时程图表/文本 > 02_时程分析文本

时程分析文本

  • 功 能

按文本形式输出时程分析结果。也可只输出最大值和最小值。

  • 命 令

从主菜单中选择结果 > 时程分析结果 > 时程分析文本

在树形菜单的菜单表单中选择分析结果 > 时程分析结果 > 时程分析文本

  • 输 入

当选择节点分析结果时

选择结果类型：选择输出位移、速度、加速度。适用于所有单元类型。

选择输出形式

时间间隔：按时间间隔(步长)输出结果。步长在时程分析荷载工况中定义。

最大值和最小值：仅输出最大值和最小值。

输出的时间间隔

从t1到t2：从所有分析时间中，仅输出从t1到t2时间长度内的分析结果。

每n个步骤：在t1到t2时间长度内，每n个步骤(步长)输出一次结果。

选择节点

用户输入：由用户输入节点号。

在画面上选择的节点：在画面上事先选择节点后，点击"适用"键。

参考点：选择位移的参考点。

地面：选择地面为参考点。

添加地面作用：选择运动前的地面为参考点。

另一节点：选择另一节点为参考点。

时程分析荷载工况

选择输出的时程分析荷载工况。

当选择?单元分析结果(桁架单元、梁单元、平面应力/应变单元、实体单元)?时

结果类型：选择输出内力或应力。

输出方式

时间步骤：按时间步骤输出结果。步长在时程分析荷载工况中定义。

最大值和最小值：仅输出最大值和最小值。

输出的时间步骤

从t1到t2：从所有分析时间中，仅输出从t1到t2时间长度内的分析结果。

每n个步骤：在t1到t2时间长度内，每n个步骤(步长)输出一次结果。

选择单元

用户输入：由用户输入单元号。

选择单元：在画面上事先选择单元后，点击适用键。

时程分析荷载工况：选择输出的时程分析荷载工况。

当选择单元分析结果(板单元)时

结果类型：选择输出内力、单元内力或应力。

输出方式

时间步骤：按时间步骤输出结果。步长在时程分析荷载工况中定义。

最大值和最小值：仅输出最大值和最小值。

输出时间步骤

从t1到t2：从所有分析时间中，仅输出从t1到t2时间长度内的分析结果。

每n个步骤：在t1到t2时间长度内，每n个步骤(步长)输出一次结果。

选择单元

用户输入：由用户输入单元号。

选择单元：在画面上事先选择单元后，点击"适用"键。

时程分析荷载工况：选择输出的时程分析荷载工况。

当选择非线性连接结果时

选择结果类型：选择输出变形或内力。仅适用于非线性连接单元。

选择输出方式

时间步骤：按时间步骤输出结果。步长在时程分析荷载工况中定义。

最大值和最小值：仅输出最大值和最小值。

输出时间步骤

从t1到t2：从所有分析时间中，仅输出从t1到t2时间长度内的分析结果。

每n个步骤：在t1到t2时间长度内，每n个步骤(步长)输出一次结果。

选择非线性连接：选择非线性连接单元。

时程分析荷载工况：选择输出的时程分析荷载工况。


08_层数据图形

Home > midas Gen 2017 > 09_结果 > 05_时程 > 02_时程图表/文本 > 03_层数据图形

层数据图形

  • 功 能

进行时程分析后生成各层的数据图形，包括层剪力（按步骤(by step)查看和按最大值查看）、层倾覆弯矩、层剪力/底部剪力系数。

  • 命 令

从主菜单选择结果>时程分析结果>层数据图形

或从树形菜单的菜单项中结果>时程分析结果>层数据图形

  • 用 法

层剪力/倾覆弯矩by step(按步骤)

生成时程分析每一分析步骤产生的层剪力及各层的最大层剪力.

方向

指定层剪力方向，选择X-方向或Y-方向。

层

选择要生成层剪力的层

: 选择所有层

:解除选择所选定的层

结果类型

剪力：查看层的剪力

倾覆弯矩：查看层的倾覆弯矩

显示类型

输入时程图形的标题及各轴的输出格式.

图形标题: 时程剪力图形的标题

X轴小数点位数:剪力图在X轴向输出的十进制数值的小数点后位数，也可以勾选按指数方式输出.

Y轴小数点位数:剪力图在Y轴向输出的十进制数值的小数点后位数，也可以勾选按指数方式输出.

时程工况：选择要生成时程图形的工况.

当选择层剪力(最大值)

方向：指定层剪力方向，选择X-方向或者Y-方向。

结果类型

剪力：查看层的剪力

倾覆弯矩：查看层的倾覆弯矩

最小值/最大值

最小值: 显示每一层的最小层剪力.

最大值: 显示每一层的最大层剪力.

绝对最大值: 显示每一层的绝对最大层剪力.

显示类型：输入时程图形的标题及各轴的输出格式.

图形标题: 时程图形的标题

时程工况：选择要生成时程图形的工况.

当选择剪切系数（层剪力/底部剪力系数)

方向：指定层剪力方向，选择X-方向或者Y-方向。

选择底层：选择哪一层为底层

最大/最小

最小: 显示每一层的最小层剪力.

最大: 显示每一层的最大层剪力.

绝对最大: 显示每一层的绝对最大层剪力.

显示类型：输入时程图形的标题及各轴的输出格式.

图形标题: 时程图形的标题

时程工况：选择要生成时程图形的工况.


17_阶段/步骤时程图表

Home > midas Gen 2017 > 09_结果 > 05_时程 > 03_阶段/步骤时程图表

阶段/步骤时程图形

  • 功 能

对几何非线性分析、施工阶段分析等具有加载阶段或施工阶段的模型，可以按阶段或步骤输出位移结果，对梁单元和桁架单元还可以按阶段或步骤输出内力和应力结果。

  • 命 令

从主菜单中选择结果 > 阶段/步骤时程图表

在树形菜单的菜单表单中选择分析结果 > 阶段/步骤时程图表

  • 用 法

定义函数

定义将要输出的函数内容。点击 [image] ，添加新的函数。

目前可以输出所有单元类型的位移，梁单元、桁架单元的内力和应力结果。

输出模式

多函数：将多个函数输出在同一图表里。

多荷载工况：将某输出函数在各荷载工况、荷载组合的分析结果输出在同一图表里。

选择步骤

所有步骤：输出所有施工阶段及阶段内所有步骤的分析结果。

最终步骤：输出各施工阶段中的最后一个步骤的分析结果。(注：阶段和步骤的概念不同)

X-轴

阶段/步骤：输出相对于施工阶段步骤的图形。

时间：输出相对于时间的图形。

当选择了?多函数?时

选择输出的函数：在输出函数列表中可以重复选择输出的函数。当需要编辑已经定义的函数时，可以选择该函数后点击 ；当需要删除某函数时，选择该函数后点击 。

荷载工况/荷载组合：选择要输出的荷载工况或荷载组合。

注：可以输出各荷载工况或荷载组合作用下的施工阶段分析结果。荷载组合的定义参照?荷载组合?。

图形标题：输入图形的标题。

当选择多荷载工况时

选择输出的荷载工况

在荷载工况列表中选择荷载工况，可以多重选择。

定义的函数

在已经定义的函数列表中选择将输出的函数。

图形标题

输入图形的标题。

：点击此键，将显示图表结果。

：点击此键，将关闭窗口。

注：定义输出函数的方法如下：

在定义函数中选择位移时

名称：输入函数名称。

节点号：输入将要输出位移的节点号。

方向：输入位移的方向(DX、DY、DZ、RX、RY、RZ)。

点击 [image] ，生成函数并将其添加到输出目录中。

点击 [image] ，取消输入的数据并退回到上一级对话框。

在定义函数中选择桁架单元内力/应力时

名称：输入桁架单元的内力/应力的函数名称。

单元号：输入将要输出内力/应力的桁架单元号。

内力、应力：选择是输出内力还是输出应力。

点：选择内力或应力的输出位置可选择I-节点或J-节点。

点击 [image] ，生成函数并将其添加到输出目录中。

点击 [image] ，取消输入的数据并退回到上一级对话框中。

在定义函数中选择梁单元内力/应力时

名称：输入梁单元的内力/应力的函数名称。

单元号：输入将要输出内力/应力的梁单元号。

内力：可选择的内力组成有轴向、剪切-y、剪切-z、扭矩、弯矩-y、弯矩-z。

应力：可选择的应力组成有轴向、剪切-y、剪切-z、弯曲应力(+y)、弯曲应力(-y)、弯曲应力(+z)、弯曲应力(-z)。

点：选择内力或应力的输出位置可选择I-节点或J-节点。

输出分量：选择输出的内力或应力成分。

包含轴向应力：选择此项时，输出弯曲应力=弯矩引起的应力+轴力引起的应力。

点击 [image] ，生成函数并将其添加到输出目录中。

点击 [image] ，取消输入的数据并退回到上一级对话框中。

在上面时程分析图表中点击右键，将出现下列关联菜单。

修改标题和标签：可以修改图形的标题和图形的x、y轴的名称。(参见下图)

缩小：在图形上用鼠标滑动，被滑过的区域将被放大。使用"缩小"功能可以恢复到缩小前状态。

恢复到初始画面：恢复到初始画面状态。

时间 <-> 频率：使用FFT(Fast Fourier Transform method)分析功能，将时间(或频率)为变量的图形转换为频率(或时间)为变量的图形。

X轴-对数刻度：将X轴的刻度变为对数刻度。重新点击该命令，可恢复到原来刻度。

Y轴-对数刻度：将X轴的刻度变为对数刻度。重新点击该命令，可恢复到原来刻度。

修改图形范围：可以确定输出图形的范围。

自动确定：输出初始画面。该项被选择时，在下面输入的X、Y轴的最大最小值将不起作用。

以图形保存图表：可以将图表保存为BMP、JPG、EMF格式的图形。

以文本格式保存图表：可以将图表内容保存为文本格式。


18_施工阶段柱弹性收缩图形

Home > midas Gen 2017 > 09_结果 > 06_其它 > 01_施工阶段柱弹性收缩图形

施工阶段柱弹性收缩图形

  • 功 能

使用图形查看高层建筑施工过程中的柱的轴向弹性收缩量。

  • 命 令

从主菜单中选择结果 > 柱施工阶段弹性收缩

在树形菜单的菜单表单中选择结果 > 柱施工阶段弹性收缩

  • 用 法

柱弹性收缩图表

点击 [image] ，选择将输出的柱的位置和将输出的内容。

选择将输出的柱位置和输出内容

名称：输入图形的名称。

坐标信息：输入柱子的坐标位置(整体坐标系)以及容许误差。

：点击该键，下面列表中的所有项目都将被选择。

：点击该键，解除下面列表中的所有已选项目。

注：列表中提供如下结果。

弹性收缩: 用后缀Elst表示。

徐变: 因为徐变引起的收缩。用后缀Creep表示。

收缩: 因为收缩引起的收缩。用后缀Shrnk表示。

全部: 因为弹性收缩、徐变、收缩引起的收缩之和。用后缀Ttl表示。

浇筑该层楼板前的位移: 用后缀Up表示。

浇筑该层楼板后的位移: 用后缀Sub表示。

全部: 楼板浇筑前、后的位移的和。用后缀Ttl表示。

例: 柱1_Shrnk_Ttl表示柱1的温度收缩量(楼板浇筑前和浇筑后)。

点击 [image] 键，则选择输出的图形名称将显示在目录中。

在目录中选择将要最终输出的图形，然后点击 [image] ，则将在模型空间中将输出相应的图表。当需要修改图形内容时，可以点击 [image] ，当要删除该图形时可点击 [image] 。将鼠标放置在图形上面按右键，将弹出如下菜单。

修改标题和标签：修改图形的题目和纵横轴的名称。

彩色图形/黑白图形：选择图形的色彩表现方式。

缩小：将鼠标放置到图形上，按住鼠标然后向右拖动，则被鼠标划过的区域将被放大。缩小功能将被放大的图形恢复到前次状态。

恢复到初始画面：将图形恢复到初始画面状态。

以图形格式保存图表：将图表保存为BMP、JPG或EMF格式的图形文件。

以文本格式保存图表：以文本格式保存图表。


19_各层构件剪力

Home > midas Gen 2017 > 09_结果 > 06_其它 > 02_层构件剪力比

各层构件剪力

  • 功 能

查看各层构件的剪力比。

  • 命 令

从主菜单中选择结果> 层构件剪力比

在树形菜单的菜单表单中选择结果 > 层构件剪力比

  • 用 法

荷载工况

选择荷载工况

输出类型

内力：选择按内力输出

比例：选择按比例输出

施加荷载方向

角度：指定荷载作用角度

显示类型

等值线：用等值线显示模型位移。

点击等值线右侧的 [image] ，弹出如下对话框。

范围：定义等值线的范围。

：指定等值线的颜色分布范围。使用该功能可为特定的区域赋以特定的颜色。点击该键，将显示如下对话框。

等值线值：列表中将显示各颜色等级代表的等值线值。颜色等级的数量为下面选择的颜色数量。

颜色数量：输入要包含在等值线中的颜色的数量(在6、12、18、24种颜色中选择)。

颜色：指定或控制等值线的颜色。

颜色表：输入颜色的变化顺序。

V->R->G->B：青紫色->红->绿->蓝。

R->G->B：红->绿->蓝。

R->B->G：红->蓝->绿。

Gray Scaled：渐变灰色。

：调整颜色变化的顺序。在此设定颜色的变化后，颜色表中的顺序将不起作用。

反转等值线图：反转等值线中颜色变化的次序。

等值线：指定等值线的边界线颜色。该项设定仅在右侧选择?画等值线?或?单色线?时才有效。

单元边界：指定单元的边界颜色。

等值线选项：选择表示等值线的方法。

填充涂色

颜色按梯度扩散：颜色渐变(模糊边界)。

画等值线：在等值线中显示彩色边界。

只显示等值线：仅用彩色等值线表现等值线图。

单色线：仅用单色线表现等值线图。

标注等值线注释：显示表示等值线范围和边界的注释。

标注间距：注释的标注间距。

快速显示等值线(用于较大的板或实体单元模型)：板或实体单元的模型较大时，使用简化的等值线，以减少显示等值线需要的时间。

扩展：表现板单元或实体单元的等值线图时，将单元局部坐标系的z轴方向为分析结果的正方向，生成三维等值线图。

注：该选项不能在变形形状中使用。也不能与消隐命令同时使用。当需要同时显示顶板束和底板束地内力(应力)时，也不能使用该选项。

放大系数：将沿单元局部坐标系的z轴方向表现的分析结果放大显示。

变形： 显示模型变形后的形状。点击?变形?右侧的 [image] ，弹出如下对话框。

变形图的比例：放大或缩小变形的显示比例。

变形的表现方式：选择显示变形的方式。

节点位移：只显示节点位移的变形形状。

实际变形：显示详细的变形形状，包括沿两端节点之间任意截面的变形以及梁单元的节点变形。在施工阶段分析中，为了加快速度及节省时间，只提供节点位移。

实际位移(关闭自动调整)：按实际比例显示图变形。选择该项则输入的变形图的比例将不起作用。

相对位移：将最小位移设置为?0?，其他节点显示相对位移。

数值： 显示位移分量的数值。数字的字型和颜色可在 [image] 显示选项中控制。

点击数值右侧的 [image] ，弹出如下对话框。

小数点以下位数：指定小数形式的数值的精确度。

指数型：数值按指数形式显示。

最大和最小值：显示最小值和最大值。

最大绝对值：显示绝对值的最大值。

最大值：仅显示最大值。

最小值：仅显示最小值。

显示范围(%)：当某需要显示的值与选定的最大值或最小值的差在规定的范围以内时，在屏幕上显示该值。

显示角度：数值的显示方向。

注：默认的小数点可在参数设置中输入。当显示方向为0时，在节点或单元右侧，水平显示数值。角度的正方向为逆时针方向，正确选择显示方向，能更清晰地看到数值。


20_未知荷载系数

Home > midas Gen 2017 > 09_结果 > 06_其它 > 03_未知荷载系数

未知荷载系数

  • 功 能

用优化技术确定满足结构指定约束的未知荷载系数。

  • 命 令

从主菜单中选择结果 > 未知荷载系数

在树形菜单的菜单表单中选择分析结果 > 未知荷载系数

  • 用 法

为了用优化技术计算未知荷载系数，需要首先对与未知荷载系数有关的荷载工况进行荷载组合，然后指定约束条件和目标函数。所有这些数据收集在一个唯一的且未知的荷载系数组内进行分析。

：指定要得到未知荷载系数的条件，单击 [image] 形成新的未知荷载系数组。

：修改先前输入的未知荷载系数组。

：删除先前输入的未知荷载系数组。

单击 [image] 生成新的未知荷载系数组时，或单击 [image] 修改某组时，在下面给出的未知荷载系数项目明细中输入或修改数据。

   名称

输入未知荷载系数组的名称。

荷载组合

从先前在"结果> 荷载组合"中输入的荷载组合中选择某一荷载组合计算未知荷载系数。用于计算未知荷载系数的荷载组合必须包括构成荷载系数的基础的荷载工况。

目标函数类型

选择形成目标函数的方法，该函数由未知荷载系数组成。

线性：(荷载系数绝对值×权重)的总和

平方：(荷载系数×权重)的平方的线性总和

最大绝对值：(荷载系数×权重)的绝对值的最大值

未知荷载数的符号

指定要计算的未知荷载系数的正负号

负：将计算值的范围限制在负数区内

正负：不限制计算值的范围

正：将计算值的范围限制在正数区内

未知：选中要得到未知荷载系数的荷载工况。将荷载工况激活为未知荷载系数时，字符串"未知"即出现在相应荷载工况的系数区内。

荷载工况：作为未知荷载系数使用的荷载工况的名称。

系数：控制荷载工况在在目标函数中的相对重要性。

自重的系数：自重的调整系数。

约束条件

输入荷载组合结果要满足的约束，其中包括未知荷载系数。指定约束时，生成约束列表。可以有选择性地使用约束。对桁架或梁单元而言，约束类型是位移，反力及构件内力。

：选择生成新的约束。

：选择修改先前输入的约束。

：选择删除先前输入的约束。

选择 [image] 或 [image] 时。

约束名称：指定约束名称

约束类型：指定约束类型

  • 约束类型是位移时

   节点号：输入被约束的节点编号。

位移：从6个自由度中选择一个位移分量。

约束条件

相等：在包含未知荷载系数的荷载组合中的位移值(或另一节点相应分量的位移值)等于输入的值。

数值：输入包含未知荷载系数的荷载组合必须满足的位移分量值

其它节点：输入其他节点号，即将前面输入的节点与此节点的位移相互关系做为约束条件。

不等：在包含未知荷载系数的荷载组合中的位移值(或另一节点相应分量的位移值)大于等于或小于等于输入的值。

上限值：输入包含未知荷载系数的荷载组合必须满足的位移上限值。

下限值：输入包含未知荷载系数的荷载组合必须满足的位移下限值。

  • 约束类型是反力时

节点号：输入被约束的节点编号。

反力：从6个反力中选择一个反力分量。

约束条件

相等：在包含未知荷载系数的荷载组合中的反力值(或另一节点相应分量的反力值)等于输入的值。

数值：输入包含未知荷载系数的荷载组合必须满足的反力分量值

其它节点：输入其他节点号，即将前面输入的节点与此节点的反力相互关系做为约束条件。

不等：在包含未知荷载系数的荷载组合中的反力值(或另一节点相应分量的反力值)大于等于或小于等于输入的值。

上限值：输入包含未知荷载系数的荷载组合必须满足的反力上限值。

下限值：输入包含未知荷载系数的荷载组合必须满足的反力下限值。

  • 约束类型是桁架单元内力时

   单元号：输入被约束的桁架单元编号。

位置：输入施加强制约束的位置是在I端还是J端。

约束条件

相等：在包含未知荷载系数的荷载组合中的桁架单元的构件内力值(或另一桁架单元的构件内力值)等于输入的值。

数值：输入包含未知荷载系数的荷载组合必须满足的内力分量值

其它桁架单元：输入其他桁架单元号，即将前面输入的单元与此单元的内力相互关系做为约束条件。

不等：在包含未知荷载系数的荷载组合中的桁架单元的构件内力值(或另一桁架单元的构件内力值)大于等于或小于等于输入的值。

上限值：输入包含未知荷载系数的荷载组合必须满足的内力上限值。

下限值：输入包含未知荷载系数的荷载组合必须满足的内力下限值。

  • 约束类型是梁单元内力时

单元号：输入被约束的梁单元编号

位置：输入施加强制约束在梁单元上的位置，有I-端、1/4、1/2、3/4、J-端五项可供选择。

内力：选择梁单元内力的一个分量。

约束条件

相等：在包含未知荷载系数的荷载组合中的桁架单元的构件内力值(或另一梁单元的构件内力值)等于输入的值。

数值：输入包含未知荷载系数的荷载组合必须满足的内力分量值

其它梁单元：输入其他梁单元号，即将前面输入的单元与此单元的内力相互关系做为约束条件。

不等：在包含未知荷载系数的荷载组合中的梁单元的构件内力值(或另一梁单元的构件内力值)大于等于或小于等于输入的值。

上限值：输入包含未知荷载系数的荷载组合必须满足的内力上限值。

下限值：输入包含未知荷载系数的荷载组合必须满足的内力下限值。

：计算并生成未知荷载系数的结果，该结果用选定的未知荷载系数组中的约束将目标函数最小化。


23_钢束预应力损失图表

Home > midas Gen 2017 > 09_结果 > 06_其它 > 04_钢束预应力损失图表

钢束预应力损失图表

  • 功 能

按施工阶段以及施工步骤输出钢束的张力。可以使用图表确认预应力的各损失量。

  • 命 令

从主菜单中选择结果 > 钢束预应力损失图表

在树形菜单的菜单表单中选择分析结果 > 钢束预应力损失图表

  • 用 法

预应力钢束: 选择要查看的钢束名称。

施工信息: 选择施工阶段。

步骤: 选择施工阶段中的子步骤。

：使用动画连续查看所选钢束在各施工阶段的预应力的变化。

注：预应力的即时(瞬间)损失是张拉力和最初施工阶段中钢束实际应力之间的差异。

在图表上按鼠标右键，将弹出下列关联菜单。

保存为图形格式：可以将图表保存为BMP、JPG、EMF格式的图形文件。

保存为文本格式：可以将图表保存为文本格式的文件。

打印图形 ：可以将图形打印出来。


25_输出文本结果

Home > midas Gen 2017 > 09_结果 > 07_文本结果

输出文本结果

  • 功 能

由用户选定格式排列结构静力和动力分析结果并以文本文件形式输出结果。

文本输出支持的功能如下：

    • 按荷载集合输出(每种输出形式中可指定不同的荷载集合)。

    • 按材料特性，截面属性，单元编号等输出选定构件的内力和应力。

    • 输出节点位移和支座反力。

    • 输出包络线和每个单元摘要。

    • 在单元局部坐标系和整体坐标系中均可输出每个单元的结果。

  • 命 令

从主菜单中选择结果 > 输出文本结果

  • 用 法

文本输出的步骤是，逐步输入要求的信息直至得到最后结果。

    1. 选择文本输出后，出现下图所示的文本打印助手对话框，在其中选择输出荷载集合。

一个荷载集合是一种荷载集合合的集成。每个荷载集合用于输出成果的不同用途，如构件内力，节点位移，支座反力等。

单击 [image] 显示下面的荷载集合输入对话框：

输入荷载集合名称。选中要求的荷载工况/荷载集合合，封包并单击 [image] 注册荷载集合。如果需要，单击 [image] 或 [image] 修改或删除注册的荷载集合。

要注册所有需要的荷载集合时，单击 [image] 进入下一步输入对话框。

  2. 在单元输出选择对话框中，选择要输出的单元类型和输出模式。首先，从注册的荷载集合中选择某一荷载集合及要输出的单元类型。在对话框中只激活模型中使用的相关单元。单击单元类型右边的 [image] 设定单元输出的详细资料。

  3. 单元类型设置输出的详细资料

单元选择详细资料对话框包括两部分：左边是输出单元选择的筛选设置部分，右边是输出类型和其他项部分。筛选可用于号码，截面，材料，层，已命名的平面和组。最后只输出满足筛选中选定的全部属性的单元。满足筛选条件的单元排列在[筛选]域中。文本输出开始前在窗口中已选择的单元排列在[已选]域中。最后输出这两部分的集合。

  4. 单元输出设置完成后，单击 [image] 进入位移和反力输出设置。其步骤与单元输出类似。

独立的荷载集合可用于不同的项目。同样，按输出目的，也可使用独立的荷载集合合。

  5. 按输出次序的结果输出列表对话框和文件名显示如下。

输出次序可按默认分类，也可按类型分类。可以用鼠标选择并拖放进行个别修改。选中[在每类输出末端插入换页]，在每类输出末端的文档中插入页码。在文件名区内写入输出文件路径和文件名并单击 [image] ， 生成文档并在文本编辑器中察看生成的文件。参见用文本编辑器生成输出结果的输出部分。


01_反力

Home > midas Gen 2017 > 09_结果 > 08_结果表格 > 01_反力

反力

  • 功 能

在电子数据表格的分析结果中检查支承反力。

MIDAS/Gen的表格工具提供各种强大的内置功能。详细说明参见下列各项：

表格工具的使用

术语

熟悉用法

基本用法（单元移动、选择、大小的控制等）

数据处理（增加、删除、修改数据等）

使用粘贴板拷贝/粘贴数据

表格辅助功能

表格排序

表格格式设定

自动适应列宽

图表打印

表格类型的辅助功能

节点/单元表格

结果表格

  • 命 令

从主菜单中选择结果 > 分析结果表格 > 反力

从树形菜单的表格选项中选择分析结果表格 > 反力

  • 用 法 (参见反力和弯矩)

在被激活的对话框中选择要校核的荷载工况和荷载组合。

参考表格工具的使用校核如下数据：

节点：节点编号

荷载：荷载工况/组合

阶段：施工阶段

步骤：施工阶段中的子步骤

FX：整体坐标系下X方向的反力分量

FY：整体坐标系下Y方向的反力分量

FZ：整体坐标系下Z方向的反力分量

MX：整体坐标系下绕X轴的力矩分量

MY：整体坐标系下绕Y轴的力矩分量

MZ：整体坐标系下绕Z轴的力矩分量

Fx：局部坐标系下x方向的反力分量

Fy：局部坐标系下y方向的反力分量

Fz：局部坐标系下z方向的反力分量

Mx：局部坐标系下绕x轴的力矩分量

My：局部坐标系下绕y轴的力矩分量

Mz：局部坐标系下绕z轴的力矩分量


02_位移

Home > midas Gen 2017 > 09_结果 > 08_结果表格 > 02_位移

位移

  • 功 能

在电子数据表格的分析结果中中检查节点位移。

MIDAS/Gen的表格工具提供了各种强大的内置功能。详细说明参见下列各项：

表格工具的使用

术语

熟悉用法

基本用法（单元移动、选择、大小的控制等）

数据处理（增加、删除、修改数据等）

使用粘贴板拷贝/粘贴数据

表格辅助功能

表格排序

表格格式设定

自动适应列宽

图表打印

表格类型的辅助功能

节点/单元表格

结果表格

  • 命 令

从主菜单中选择结果 > 分析结果表格 > 位移

从树形菜单的表格选项中选择分析结果表格 > 位移

  • 用 法 (参见位移等值线)

在被激活的对话框中选择要校核的荷载工况和荷载组合。

参考表格工具的使用校核如下数据：

节点：节点编号

荷载：荷载工况/组合

阶段：施工阶段

步骤：施工阶段中的子步骤

DX：整体坐标系下X方向的位移分量

DY：整体坐标系下Y方向的位移分量

DZ：整体坐标系下Z方向的位移分量

RX：整体坐标系下绕X轴的转动分量

RY：整体坐标系下绕Y轴的转动分量

RZ：整体坐标系下绕Z轴的转动分量


01_内力和应力

Home > midas Gen 2017 > 09_结果 > 08_结果表格 > 03_桁架单元 > 内力和应力

桁架单元内力和应力表格

  • 功 能

在电子数据表格中检查分析结果中桁架单元的内力和应力。

MIDAS/Gen的表格工具提供了各种强大的内置功能，详细说明参见下列各项：

表格工具的使用

术语

熟悉用法

基本用法（单元移动、选择、大小的控制等）

数据处理（增加、删除、修改数据等）

使用粘贴板拷贝/粘贴数据

表格辅助功能

表格排序

表格格式设定

自动适应列宽

图表打印

表格类型的辅助功能

节点/单元表格

结果表格

  • 命 令

从主菜单中选择结果 > 分析结果表格 > 桁架 > 内力和应力

从主菜单中选择结果 > 分析结果表格 > 桁架 > 内力

从主菜单中选择结果 > 分析结果表格 > 桁架 > 应力

从树形菜单的表格表单中选择结果表格 > 桁架 > 内力和应力

从树形菜单的表格表单中选择结果表格 > 桁架 > 内力

从树形菜单的表格表单中选择结果表格 > 桁架 > 应力

  • 用 法 (参见桁架单元内力，桁架单元应力)

在被激活的对话框中选择荷载工况和荷载组合。

参考表格工具的使用校核如下数据：

单元：单元编号

荷载：荷载工况/组合

内力-I：桁架单元节点i (N1) 的轴力

内力-J：桁架单元节点j (N2) 的轴力

单元：单元编号

荷载：荷载工况/组合

应力-I：桁架单元节点i (N1) 的轴向应力

应力-J：桁架单元节点j (N2) 的轴向应力


01_内力

Home > midas Gen 2017 > 09_结果 > 08_结果表格 > 04_索单元 > 01_内力

索单元内力表格

  • 功 能

以表格的形式查看索单元产生的内力。

MIDAS/Gen的表格工具提供了各种强大的内置功能，详细说明参见下列各项：
表格工具的使用

  • 命 令

从主菜单中选择结果 > 分析结果表格 > 索单元 > 内力

从树形菜单的表格表单中选择结果表格 > 索单元 > 内力

  • 用 法

在被激活的对话框选择要输出的节点、单元、荷载工况。

参考 表格工具的使用 查看如下数据：

索单元内力

单元：单元号

荷载：单位荷载工况

步骤：阶段

节点I：i端的节点符号

节点J：j端的节点符号

张力：i端索的张力

FX：i端整体坐标系X轴方向的索张力

FY：i端整体坐标系Y轴方向的索张力

FZ：i端整体坐标系Z轴方向的索张力

张力：j端索的张力

FX：j端整体坐标系X轴方向的索张力

FY：j端整体坐标系Y轴方向的索张力

FZ：j端整体坐标系Z轴方向的索张力


02_信息

Home > midas Gen 2017 > 09_结果 > 08_结果表格 > 04_索单元 > 02_布置

索单元信息表格

  • 功 能

用表格的形式查看索单元的信息。

MIDAS/Gen的表格工具提供了各种强大的内置功能，详细说明参见下列各项：
表格工具的使用

  • 命 令

从主菜单中选择结果 > 分析结果表格 > 索单元 > 信息

从树形菜单的表格表单中选择结果表格 > 索单元 > 信息

  • 用 法

在被激活的对话框中选择节点、单元、荷载工况和施工阶段后点击 [image] 。

参考表格工具的使用查看如下数据：

索单元信息

单元: 单元号

荷载：荷载

阶段：施工阶段

节点i：i端节点号码

节点J：J端节点号码

总长：变形后索长度(无应力场长度 + 伸长量)

长量：伸长量

无应力长度：无应力场长度

垂度: 索的垂度

水平距离：i端至J端的水平距离

垂直距离：i端至J端的竖向距离

梯度：水平距离 / 垂直距离

倾斜角

i 端: i端的索切线与水平线夹角

J 端: J端的索切线与水平线夹角


01_内力和应力

Home > midas Gen 2017 > 09_结果 > 08_结果表格 > 05_梁单元 > 内力和应力

梁单元内力和应力表格

  • 功 能

在电子数据表格中检查分析结果中梁单元的内力和应力。

MIDAS/Gen的表格工具提供了各种强大的内置功能，详细说明参见下列各项：
表格工具的使用

术语

熟悉用法

基本用法（单元移动、选择、大小的控制等）

数据处理（增加、删除、修改数据等）

使用粘贴板拷贝/粘贴数据

表格辅助功能

表格排序

表格格式设定

自动适应列宽

图表打印

表格类型的辅助功能

节点/单元表格

结果表格

  • 命 令

从主菜单中选择结果 > 分析结果表格 > 梁 > 内力和应力

从主菜单中选择结果 > 分析结果表格 > 梁 > 内力

从主菜单中选择结果 > 分析结果表格 > 梁 > 应力

从树形菜单的表格表单中选择结果表格 > 梁 > 内力和应力

从树形菜单的表格表单中选择结果表格 > 梁 > 内力

从树形菜单的表格表单中选择结果表格 > 梁 > 应力

  • 用 法 (参见梁单元内力，梁单元应力)

在被激活的对话框中选择荷载工况和荷载组合。

参考表格工具的使用校核如下数据：

梁单元内力

单元：单元编号

荷载：荷载工况/组合

位置：每个单元沿长度方向的输出位置

轴向：轴力

剪力- y：单元局部坐标系y方向的剪力

剪力- z：单元局部坐标系z方向的剪力

扭矩：关于单元局部坐标系x轴的扭矩

弯矩- y：关于单元局部坐标系y轴的弯矩

弯矩- z：关于单元局部坐标系z轴的弯矩

梁单元应力

单元：单元编号

荷载：荷载工况/组合

位置：每个单元沿长度方向的输出位置

轴向：轴向应力

剪应力- y：单元局部坐标系y方向的剪应力

剪应力- z：单元局部坐标系z方向的剪应力

弯矩(+y)：关于单元局部坐标系y轴的弯曲应力

弯矩(-y)：关于单元局部坐标系y轴的弯曲应力

弯矩(+z)：关于单元局部坐标系z轴的弯曲应力

弯矩(-z)：关于单元局部坐标系z轴的弯曲应力

Cb(min/max): 组合应力中绝对值最大的应力值。

Cb1(-y+z)～Cb4(-y-z): 各组合应力值，某截面左上、右上、右下、左下端点位置的组合应力。


01_内力和应力

Home > midas Gen 2017 > 09_结果 > 08_结果表格 > 06_板单元 > 内力和应力

板单元内力和应力表格

  • 功 能

在电子数据表格中检查分析结果中板单元的内力和应力。

MIDAS/Gen的表格工具提供了各种强大的内置功能，详细说明参见下列各项：
表格工具的使用

术语

熟悉用法

基本用法（单元移动、选择、大小的控制等）

数据处理（增加、删除、修改数据等）

使用粘贴板拷贝/粘贴数据

表格辅助功能

表格排序

表格格式设定

自动适应列宽

图表打印

表格类型的辅助功能

节点/单元表格

结果表格

  • 命 令

从主菜单中选择结果 > 分析结果表格 > 板 > 内力和应力

从主菜单中选择结果 > 分析结果表格 > 板 > 内力(局部)

从主菜单中选择结果 > 分析结果表格 > 板 > 内力(全局)

从主菜单中选择结果 > 分析结果表格 > 板 > 内力(单位长度)

从主菜单中选择结果 > 分析结果表格 > 板 > 应力(局部)

从主菜单中选择结果 > 分析结果表格 > 板 > 应力(全局)

从树形菜单的表格表单中选择结果表格 > 板 > 内力和应力

从树形菜单的表格表单中选择结果表格 > 板 > 内力(局部)

从树形菜单的表格表单中选择结果表格 > 板 > 内力(全局)

从树形菜单的表格表单中选择结果表格 > 板 > 内力(单位长度)

从树形菜单的表格表单中选择结果表格 > 板 > 应力(局部)

从树形菜单的表格表单中选择结果表格 > 板 > 应力(全局)

  • 用 法 (参见?板单元内力?)

参考表格工具的使用校核如下数据：

  板内力（局部坐标系）

单元：单元编号

荷载：荷载工况/组合

节点：节点编号

Fx：单元局部坐标系x方向的轴力

Fy：单元局部坐标系y方向的轴力

Fz：单元局部坐标系z方向的轴力

Mx：绕单元局部坐标系x轴的弯矩

My：绕单元局部坐标系y轴的弯矩

Mz：绕单元局部坐标系z轴的弯矩

  板单元内力（整体坐标系）

单元：单元编号

荷载：荷载工况/组合

节点：节点编号

FX：单元整体坐标系X方向的轴力

FY：单元整体坐标系Y方向的轴力

FZ：单元整体坐标系Z方向的轴力

MX：绕单元整体坐标系X轴的弯矩

MY：绕单元整体坐标系Y轴的弯矩

MZ：绕单元整体坐标系Z轴的弯矩

板单元内力（单位长度）

单元：单元编号

荷载：荷载工况/组合

节点：节点编号

Fxx：单元局部坐标系x方向单位宽度的轴力

Fyy：单元局部坐标系y方向单位宽度的轴力

Fxy：单元局部坐标系x-y平面单位宽度的剪力

Fmax：单位宽度的最大主轴力

Fmin：单位宽度的最小主轴力

角度：单元局部坐标系x轴和最大主轴力的夹角

Mxx：相对于单元局部坐标系y轴单位宽度的弯矩

Myy：相对于单元局部坐标系x轴单位宽度的弯矩

Mxy：局部坐标系x-y平面单位宽度的扭矩

Mmax：单位宽度的最大主弯矩

Mmin：单位宽度的最小主弯矩

角度：单元局部坐标系x轴和最大主弯矩轴的夹角

Vxx：单元局部坐标系y-z 平面厚度(z) 方向单位宽度的剪力

Vyy：单元局部坐标系x-z 平面厚度(z) 方向单位宽度的剪力

板单元应力（局部坐标系）

单元：单元编号

荷载：荷载工况/组合

节点：节点编号

位置：单元局部坐标系下板单元顶部或底部的纤维

Sig-xx：单元局部坐标系x方向轴向应力

Sig-yy：单元局部坐标系y方向轴向应力

Sig-xy：单元局部坐标系x-y 平面的剪应力

Sig-Max：最大主应力

Sig-Min：最小主应力

角度：单元局部坐标系x轴和最大主应力向量的夹角

Sig-EFF：有效应力（von-Mises 应力）

板单元应力（整体坐标系）

单元：单元编号

荷载：荷载情况/组合

节点：节点编号

位置：单元整体坐标系下板单元顶部或底部的纤维

Sig-XX：单元整体坐标系X方向轴向应力

Sig-YY：单元整体坐标系Y方向轴向应力

Sig-ZZ：单元整体坐标系Z方向轴向应力

Sig-XY：单元整体坐标系X-Y平面的剪应力

Sig-YZ：单元整体坐标系Y-Z平面的剪应力

Sig-XZ：单元整体坐标系X-Z平面的剪应力

Sig-Max：最大主应力

Sig-Min：最小主应力

角度：单元整体坐标系X轴和最大主应力向量的夹角

Sig-EFF：有效应力（von-Mises 应力）


01_内力和应力

Home > midas Gen 2017 > 09_结果 > 08_结果表格 > 07_平面应力单元 > 内力和应力

平面应力单元内力和应力表格

  • 功 能

在电子数据表格中检查分析结果中平面应力单元的内力和应力。

MIDAS/Gen的表格工具提供了各种强大的内置功能，详细说明参见下列各项：
 表格工具的使用

术语

熟悉用法

基本用法（单元移动、选择、大小的控制等）

数据处理（增加、删除、修改数据等）

使用粘贴平面应力单元拷贝/粘贴数据

表格辅助功能

表格排序

表格格式设定

自动适应列宽

图表打印

表格类型的辅助功能

节点/单元表格

结果表格

  • 命 令

从主菜单中选择结果 > 分析结果表格 > 平面应力单元 > 内力和应力

从主菜单中选择结果 > 分析结果表格 > 平面应力单元 > 内力(局部)

从主菜单中选择结果 > 分析结果表格 > 平面应力单元 > 内力(全局)

从主菜单中选择结果 > 分析结果表格 > 平面应力单元 > 应力(局部)

从主菜单中选择结果 > 分析结果表格 > 平面应力单元 > 应力(全局)

从树形菜单的表格表单中选择结果表格 > 平面应力单元 > 内力和应力

从树形菜单的表格表单中选择结果表格 > 平面应力单元 > 内力(局部)

从树形菜单的表格表单中选择结果表格 > 平面应力单元 > 内力(全局)

从树形菜单的表格表单中选择结果表格 > 平面应力单元 > 应力(局部)

从树形菜单的表格表单中选择结果表格 > 平面应力单元 > 应力(全局)

  • 用 法 (参见 平面应力单元应力 )

在被激活的对话框中选择荷载工况和荷载组合。

参考表格工具的使用校核如下数据：

平面应力单元内力（局部坐标系/整体坐标系）

单元：单元编号

荷载：荷载工况/组合

节点：节点编号

Fx：单元局部坐标系x方向的单元内力

Fy：单元局部坐标系y方向的单元内力

FX：单元整体坐标系X方向的单元内力

FY：单元整体坐标系Y方向的单元内力

FZ：单元整体坐标系Z方向的单元内力

平面应力单元应力（局部坐标系）

单元：单元编号

荷载：荷载工况/组合

节点：节点编号

Sig-xx：单元局部坐标系x方向轴向应力

Sig-yy：单元局部坐标系y方向轴向应力

Sig-xy：单元局部坐标系x-y 平面的剪应力

Sig-Max：最大主应力

Sig-Min：最小主应力

角度：单元局部坐标系x轴和最大主应力向量的夹角

Sig-EFF：有效应力（von-Mises 应力）

平面应力单元应力（整体坐标系）

单元：单元编号

荷载：荷载工况/组合

节点：节点编号

Sig-XX：单元整体坐标系X方向轴向应力

Sig-YY：单元整体坐标系Y方向轴向应力

Sig-ZZ：单元整体坐标系Z方向轴向应力

Sig-XY：单元整体坐标系X-Y 平面的剪应力

Sig-YZ：单元整体坐标系Y-Z 平面的剪应力

Sig-XZ：单元整体坐标系X-Z 平面的剪应力

Sig-Max：最大主应力

Sig-Min：最小主应力

角度：单元整体坐标系X轴和最大主应力向量的夹角

Sig-EFF：有效应力（von-Mises 应力）


01_内力和应力

Home > midas Gen 2017 > 09_结果 > 08_结果表格 > 08_平面应变单元 > 01_内力和应力

平面应变单元内力和应力表格

  • 功 能

在电子数据表格中检查分析结果中平面应变单元的内力和应力。

MIDAS/Gen的表格工具提供了各种强大的内置功能，详细说明参见下列各项：

表格工具的使用

术语

熟悉用法

基本用法（单元移动、选择、大小的控制等）

数据处理（增加、删除、修改数据等）

使用粘贴板拷贝/粘贴数据

表格辅助功能

表格排序

表格格式设定

自动适应列宽

图表打印

表格类型的辅助功能

节点/单元表格

结果表格

  • 命 令

从主菜单中选择结果 > 分析结果表格 > 平面应变单元 > 内力和应力

从主菜单中选择结果 > 分析结果表格 > 平面应变单元 > 内力(局部)

从主菜单中选择结果 > 分析结果表格 > 平面应变单元 > 内力(全局)

从主菜单中选择结果 > 分析结果表格 > 平面应变单元 > 应力(局部)

从主菜单中选择结果 > 分析结果表格 > 平面应变单元 > 应力(全局)

从树形菜单的表格表单中选择结果表格 > 平面应变单元 > 内力和应力

从树形菜单的表格表单中选择结果表格 > 平面应变单元 > 内力(局部)

从树形菜单的表格表单中选择结果表格 > 平面应变单元 > 内力(全局)

从树形菜单的表格表单中选择结果表格 > 平面应变单元 > 应力(局部)

从树形菜单的表格表单中选择结果表格 > 平面应变单元 > 应力(全局)

  • 用 法 (参见平面应变单元应力)

在被激活的对话框中选择要查看的荷载工况和荷载组合。

参考表格工具的使用查看如下数据：

平面应变单元内力（局部/整体）

单元：单元编号

荷载：荷载工况/荷载组合

节点：节点编号或位置

Fx ：单元局部坐标系x方向的单元内力

Fy ：单元局部坐标系y方向的单元内力

Fz ：单元局部坐标系z方向的单元内力

FX ：单元整体坐标系X方向的单元内力

FY ：单元整体坐标系Y方向的单元内力

FZ ：单元整体坐标系Z方向的单元内力

平面应变单元应力（局部）

单元：单元编号

荷载：荷载工况/荷载组合

节点：节点编号或位置

Sig-xx：单元局部坐标系x方向轴向应力

Sig-yy：单元局部坐标系y方向轴向应力

Sig-zz：单元局部坐标系z方向轴向应力

Sig-xy：单元局部坐标系x-y平面的剪应力

Sig-P1：第一主轴方向的主应力。

Sig-P2：第二主轴方向的主应力。

Sig-P3：第三主轴方向的主应力。

Max-Shear：最大剪应力

Sig-EFF：有效应力（von-Mises 应力）

Sig-OCT：八面体应力（Octahedral Shear Stress 应力）

平面应变单元应力（整体）

单元：单元编号

荷载：荷载工况/荷载组合

节点：节点编号或位置

Sig-XX：单元局部坐标系X方向轴向应力

Sig-YY：单元局部坐标系Y方向轴向应力

Sig-ZZ：单元局部坐标系Z方向轴向应力

Sig-XZ：单元局部坐标系X-Z平面的剪应力

Sig-P1：第一主轴方向的主应力。

Sig-P2：第二主轴方向的主应力。

Sig-P3：第三主轴方向的主应力。

Max-Shear：最大剪应力

Sig-EFF：有效应力（von-Mises 应力）

Sig-OCT：八面体应力（Octahedral Shear Stress 应力）

注:因为平面应变单元只能建立在整体坐标系的X-Z平面内，所以局部坐标系下的Sig-xy对应的是整体坐标系下的Sig-XZ。


01_内力和应力

Home > midas Gen 2017 > 09_结果 > 08_结果表格 > 09_轴对称单元 > 内力和应力

轴对称单元内力和应力表格

  • 功 能

在电子数据表格中检查分析结果中轴对称单元的内力和应力。

MIDAS/Gen的表格工具提供了各种强大的内置功能，详细说明参见下列各项：
表格工具的使用

术语

熟悉用法

基本用法（单元移动、选择、大小的控制等）

数据处理（增加、删除、修改数据等）

使用粘贴板拷贝/粘贴数据

表格辅助功能

表格排序

表格格式设定

自动适应列宽

图表打印

表格类型的辅助功能

节点/单元表格

结果表格

  • 命 令

从主菜单中选择结果 > 分析结果表格 > 轴对称单元 > 内力和应力

从主菜单中选择结果 > 分析结果表格 > 轴对称单元 > 内力(局部)

从主菜单中选择结果 > 分析结果表格 > 轴对称单元 > 内力(全局)

从主菜单中选择结果 > 分析结果表格 > 轴对称单元 > 应力(局部)

从主菜单中选择结果 > 分析结果表格 > 轴对称单元 > 应力(全局)

从树形菜单的表格表单中选择结果表格 > 轴对称单元 > 内力和应力

从树形菜单的表格表单中选择结果表格 > 轴对称单元 > 内力(局部)

从树形菜单的表格表单中选择结果表格 > 轴对称单元 > 内力(全局)

从树形菜单的表格表单中选择结果表格 > 轴对称单元 > 应力(局部)

从树形菜单的表格表单中选择结果表格 > 轴对称单元 > 应力(全局)

  • 用 法 (参见轴对称单元应力)

参考表格工具的使用校核如下数据：

轴对称单元内力（局部坐标系/整体坐标系）

单元：单元编号

荷载：荷载工况/荷载组合

节点：节点编号

Fx：单元局部坐标系x方向的单元内力

Fy：单元局部坐标系y方向的单元内力

Fz：单元局部坐标系z方向的单元内力

FX：单元整体坐标系X方向的单元内力

FY：单元整体坐标系Y方向的单元内力

FZ：单元整体坐标系Z方向的单元内力

轴对称单元应力（局部坐标系）

单元：单元编号

荷载：荷载工况/荷载组合

节点：节点编号或位置

Sig-xx：单元局部坐标系x方向轴向应力

Sig-yy：单元局部坐标系y方向轴向应力

Sig-zz：单元局部坐标系z方向轴向应力

Sig-xy：单元局部坐标系x-y平面的剪应力

Sig-P1：第一主轴方向主应力

Sig-P2：第二主轴方向主应力

Sig-P3：第三主轴方向主应力

Max-Shear：最大剪应力

Sig-EFF：有效应力（von-Mises 应力）

Sig-OCT：八面体剪应力

轴对称单元应力（整体坐标系）

单元：单元编号

荷载：荷载工况/荷载组合

节点：节点编号或位置

Sig-XX：单元整体坐标系X方向轴向应力

Sig-YY：单元整体坐标系Y方向轴向应力

Sig-ZZ：单元整体坐标系Z方向轴向应力

Sig-XZ：单元整体坐标系X-Z 平面的剪应力

Sig-P1：第一主轴方向主应力

Sig-P2：第二主轴方向主应力

Sig-P3：第三主轴方向主应力

Max-Shear：最大剪应力

Sig-EFF：有效应力（von-Mises 应力）

Sig-OCT：八面体剪应力


01_内力和应力

Home > midas Gen 2017 > 09_结果 > 08_结果表格 > 10_实体单元 > 内力和应力

实体单元内力和应力表格

  • 功 能

在电子数据表格中检查分析结果中实体单元的内力和应力。

MIDAS/Gen的表格工具提供了各种强大的内置功能，详细说明参见下列各项：

表格工具的使用

术语

熟悉用法

基本用法（单元移动、选择、大小的控制等）

数据处理（增加、删除、修改数据等）

使用粘贴板拷贝/粘贴数据

表格辅助功能

表格排序

表格格式设定

自动适应列宽

图表打印

表格类型的辅助功能

节点/单元表格

结果表格

  • 命 令

从主菜单中选择结果 > 分析结果表格 > 实体单元 > 内力和应力

从主菜单中选择结果 > 分析结果表格 > 实体单元 > 内力(局部)

从主菜单中选择结果 > 分析结果表格 > 实体单元 > 内力(全局)

从主菜单中选择结果 > 分析结果表格 > 实体单元 > 应力(局部)

从主菜单中选择结果 > 分析结果表格 > 实体单元 > 应力(全局)

从树形菜单的表格表单中选择结果表格 > 实体单元 > 内力和应力

从树形菜单的表格表单中选择结果表格 > 实体单元 > 内力(局部)

从树形菜单的表格表单中选择结果表格 > 实体单元 > 内力(全局)

从树形菜单的表格表单中选择结果表格 > 实体单元 > 应力(局部)

从树形菜单的表格表单中选择结果表格 > 实体单元 > 应力(全局)

  • 用 法 (参见实体单元应力)

在被激活的对话框中选择荷载工况和荷载组合。

参考表格工具的使用校核如下数据：

实体单元内力（局部坐标系/整体坐标系）

单元：单元编号

荷载：荷载工况/组合

节点：节点编号

Fx：单元局部坐标系x方向的单元内力

Fy：单元局部坐标系y方向的单元内力

Fz：单元局部坐标系y方向的单元内力

FX：单元整体坐标系X方向的单元内力

FY：单元整体坐标系Y方向的单元内力

FZ：单元整体坐标系Z方向的单元内力

实体单元应力（局部坐标系）

单元：单元编号

荷载：荷载工况/组合

节点：节点编号

Sig-xx：单元局部坐标系x方向轴向应力

Sig-yy：单元局部坐标系y方向轴向应力

Sig-zz：单元局部坐标系z方向轴向应力

Sig-xy：单元局部坐标系x-y 平面的剪应力

Sig-yz：单元局部坐标系y-z 平面的剪应力

Sig-xz：单元局部坐标系x-z 平面的剪应力

Sig-P1：第一主轴方向主应力

Sig-P2：第二主轴方向主应力

Sig-P3：第三主轴方向主应力

Max-Shear：最大剪应力

Sig-EFF：有效应力（von-Mises 应力）

Sig-OCT：八面体剪应力

实体单元应力（整体坐标系）

单元：单元编号

荷载：荷载工况/组合

节点：节点编号

Sig-XX：单元整体坐标系X方向轴向应力

Sig-YY：单元整体坐标系Y方向轴向应力

Sig-ZZ：单元整体坐标系Z方向轴向应力

Sig-XY：单元整体坐标系X-Y 平面的剪应力

Sig-YZ：单元整体坐标系Y-Z 平面的剪应力

Sig-XZ：单元整体坐标系X-Z 平面的剪应力

Sig-P1：第一主轴方向主应力

Sig-P2：第二主轴方向主应力

Sig-P3：第三主轴方向主应力

Max-Shear：最大剪应力

Sig-EFF：有效应力（von-Mises 应力）

Sig-OCT：八面体剪应力


墙单元内力表格

  • 功 能

使用电子表格形式查看墙单元的内力。

Gen 的表格工具提供各种强大的内置功能。详细说明参见下列各项：

表格工具的使用

术语

熟悉用法

基本用法（单元移动、选择、大小的控制等）

数据处理（增加、删除、修改数据等）

使用粘贴板拷贝/粘贴数据

表格辅助功能

表格排序

表格格式设定

自动适应列宽

图表打印

表格类型的辅助功能

节点/单元表格

结果表格

  • 命 令

从主菜单中选择结果 > 分析结果表格 > 墙单元 > 内力

从树形菜单的表格表单中选择分析结果表格 > 墙单元 > 内力/弯矩

  • 用 法 (参照"墙单元内力")

在被激活的对话框中选择要查看的荷载工况和荷载组合。

参考表格工具的使用查看如下数据：

层: 层名称。

标高: 层的标高。

墙单元: 墙单元号。

荷载: 荷载工况。

阶段: 施工阶段名称。

步骤: 施工阶段内的次步骤名称。

位置: 墙单元的内力输出位置(上部或下部)。

轴向: 沿单元坐标系x轴方向的轴力。

剪力-y: 沿单元坐标系y轴的剪力。

剪力-z: 沿单元坐标系z轴的剪力。

扭矩: 绕单元坐标系x轴的扭矩。

弯矩-y: 绕单元坐标系y轴的弯矩。

弯矩-z: 绕单元坐标系z轴的弯矩。


12_弹性连接

Home > midas Gen 2017 > 09_结果 > 08_结果表格 > 12_弹性连接

弹性连接

  • 功 能

用数据表格的形式查看弹性连接分析结果。

MIDAS/Gen的表格工具提供了各种强大的内置功能。详细说明参见下列各项：

表格工具的使用

术语

熟悉用法

基本用法（单元移动、选择、大小的控制等）

数据处理（增加、删除、修改数据等）

使用粘贴板拷贝/粘贴数据

表格辅助功能

表格排序

表格格式设定

自动适应列宽

图表打印

表格类型的辅助功能

节点/单元表格

结果表格

  • 命 令

从主菜单中选择结果 > 分析结果表格 > 弹性连接

从树形菜单的表格选项中选择分析结果表格 > 弹性连接

  • 用 法

在被激活的对话框中选择要校核的荷载工况和荷载组合。

参考表格工具的使用校核如下数据：

号: 弹性连接单元号。

阶段：施工阶段

步骤：施工阶段中的子步骤

荷载：荷载工况/组合

节点：节点号

轴向: 轴力。

剪力-y: 沿单元坐标系y轴方向的剪力。

剪力-z: 沿单元坐标系z轴方向的剪力。

扭矩: 绕单元坐标系x轴的扭矩。

弯矩-y: 绕单元坐标系y轴的弯矩。

弯矩-z: 绕单元坐标系z轴的弯矩。

注：弹性连接中内力的正负号约定，可以参见在线帮助中结果>内力>梁单元内力里面的梁单元局部坐标系中内力(或应力)正负号的约定图示。


13_一般连接

Home > midas Gen 2017 > 09_结果 > 08_结果表格 > 13_一般连接

一般连接结果表格

  • 功 能

使用电子表格查看非线性连接的分析结果。

MIDAS/Gen的表格工具提供了各种强大的内置功能。详细说明参见下列各项：

表格工具的使用

术语

熟悉用法

基本用法（单元移动、选择、大小的控制等）

数据处理（增加、删除、修改数据等）

使用粘贴板拷贝/粘贴数据

表格辅助功能

表格排序

表格格式设定

自动适应列宽

图表打印

表格类型的辅助功能

节点/单元表格

结果表格

  • 命 令

从主菜单中选择结果 > 分析结果表格 > 一般连接

从树形菜单的表格选项中选择分析结果表格 > 一般连接

  • 用 法

在被激活的对话框中选择要校核的荷载工况和荷载组合。

参考表格工具的使用校核如下数据：

号: 弹性连接单元号。

荷载: 荷载工况/荷载组合。

节点: 分别为弹性连接单元的起始、结束节点号。

轴向: 轴力。

剪力-y: 沿单元坐标系y轴方向的剪力。

剪力-z: 沿单元坐标系z轴方向的剪力。

扭矩: 绕单元坐标系x轴的扭矩。

弯矩-y: 绕单元坐标系y轴的弯矩。

弯矩-z: 绕单元坐标系z轴的弯矩。


14_周期与振型

Home > midas Gen 2017 > 09_结果 > 08_结果表格 > 14_周期与振型

周期与振型表格

  • 功 能

使用电子表格形式查看模型的特征值分析结果(振型、自振周期、各振性参与质量等)。

MIDAS/Gen的表格工具提供了各种强大的内置功能，详细说明参见下列各项：

表格工具的使用

术语

熟悉用法

基本用法（单元移动、选择、大小的控制等）

数据处理（增加、删除、修改数据等）

使用粘贴板拷贝/粘贴数据

表格辅助功能

表格排序

表格格式设定

自动适应列宽

图表打印

表格类型的辅助功能

节点/单元表格

结果表格

  • 命 令

从主菜单中选择结果 > 分析结果表格 > 周期与振型

从树形菜单的表格选项中选择分析结果表格 > 周期与振型

  • 用 法 (参见周期与振型)

在被激活的对话框中选择振动模式，按照此模式列出固有振动向量。如果不需要则点击 [image] 。

参考表格工具的使用校核如下数据：

特征值分析结果表格

在图示特征值分析结果汇总表对话框中，按振动模式检查临界自振周期和振动模式参与的质量。

在关联菜单中重新选择激活纪录，指定模式检查自振模式向量。

注:

1、在各方向上，振型参与质量之和不足90%时，应该增加分析的振型数量；当无限增加振型数量也无法使振型参与质量之和达到90%时，应查看建立的模型是否正确，或有一些不必要的附属构件。

2、判断结构的某一模态是平动还是扭转，可以从设计>计算书的周期、地震作用及振型输出文件里面查看平动因子和扭转因子来进行判断。

3、从表格提供的数据来判断结构的某一模态是平动还是扭转的方法：对于比较规则的结构，使用结果/周期与振型的动画功能就可以很清楚地看出结构是平动还是扭转。对于不太规则的结构，如果上述方法无法判断时，就要结合上表中的振型参与质量和振型方向因子来判定。


15_屈曲模态

Home > midas Gen 2017 > 09_结果 > 08_结果表格 > 15_屈曲模态

屈曲模态

  • 功 能

用电子表格形式查看屈曲分析结果(屈曲模态和临界荷载)。

MIDAS/Gen的表格工具提供了各种强大的内置功能，详细说明参见下列各项：

表格工具的使用

术语

熟悉用法

基本用法（单元移动、选择、大小的控制等）

数据处理（增加、删除、修改数据等）

使用粘贴板拷贝/粘贴数据

表格辅助功能

表格排序

表格格式设定

自动适应列宽

图表打印

表格类型的辅助功能

节点/单元表格

结果表格

  • 命 令

从主菜单中选择结果 > 分析结果表格 > 屈曲模态

从树形菜单的表格选项中选择分析结果表格 > 屈曲模态

  • 用 法 (参见屈曲模态)

在被激活的对话框中选择屈曲模态，按照此模态列出屈曲向量。

参考表格工具的使用校核如下数据：

节点: 节点号。

模态: 屈曲模态号。

UX: 沿整体坐标系X轴方向的结果。

UY: 沿整体坐标系Y轴方向的结果。

UZ: 沿整体坐标系Z轴方向的结果。

RX: 绕整体坐标系X轴旋转方向的结果。

RY: 绕整体坐标系Y轴旋转方向的结果。

RZ: 绕整体坐标系Z轴旋转方向的结果。


16_反应谱分析节点结果

Home > midas Gen 2017 > 09_结果 > 08_结果表格 > 16_反应谱分析节点结果

反应谱分析节点结果

  • 功 能

使用电子表格形式查看模型的反应谱分析结果(振型、自振周期、各振性参与质量等)。

MIDAS/Gen的表格工具提供了各种强大的内置功能，详细说明参见下列各项：

表格工具的使用

术语

熟悉用法

基本用法（单元移动、选择、大小的控制等）

数据处理（增加、删除、修改数据等）

使用粘贴板拷贝/粘贴数据

表格辅助功能

表格排序

表格格式设定

自动适应列宽

图表打印

表格类型的辅助功能

节点/单元表格

结果表格

  • 命 令

从主菜单中选择结果 > 分析结果表格 > 反应谱分析节点结果

从树形菜单的表格选项中选择分析结果表格 > 反应谱分析节点结果

  • 用 法

在被激活的对话框中选择反应谱分析工况及模态。

参考表格工具的使用校核如下数据：

节点惯性力

选择的荷载工况和模态下，相应节点的X、Y、Z方向的平动和转动惯性力结果。

节点加速度

选择的荷载工况和模态下，相应节点的X、Y、Z方向的平动和转动加速度结果。


02_层间位移角验算

Home > midas Gen 2017 > 09_结果 > 08_结果表格 > 17_层 > 01_层间位移

层间位移角验算

  • 功 能

使用电子表格形式查看层间位移角的验算结果。

Gen 的表格工具提供各种强大的内置功能。详细说明参见下列各项：

表格工具的 使用

术语

熟悉用法

1.基本用法

2.数据处理

3.用剪贴板复制/粘贴数据

表格辅助功能

1.表格排序

2.表格格式设定

3.自动适应列宽

4.图表打印

表格类型的辅助功能

1.节点/单元表格

2.结果表格

  • 命 令

从主菜单中选择结果 > 分析结果表格 > 层 > 层间位移角验算

从树形菜单的表格表单中选择分析结果表格 > 层 > 层间位移角验算

  • 用 法

参考表格工具的使用查看如下数据：

层间位移(X)表单: 沿整体坐标系X轴方向的层间位移。

层间位移(Y)表单: 沿整体坐标系Y轴方向的层间位移。

层间位移(组合): X、Y两方向层间位移的组合( [image])

荷载工况: 荷载工况名称

节点: 节点号。

层: 层名称。

标高: 各层的标高。

层高度: 层高。

层间位移角限值：设定的层间位移角限值

楼层竖向构件的最大层间位移：

节点：节点编号。

层间位移：节点的层间位移。

编辑层间位移：

层间位移角：

验算：验算的结果（通过显示为ok）。

质心计算的层间位移

层间位移：节点的层间位移。

编辑层间位移：

层间位移比（最大/当前方法）：分析层间最大位移/平均层间位移

层间位移角：

验算：验算的结果（通过显示为ok）。

注： 点击该菜单时，会弹出层间位移参数设定的对话框。在图表中按右键，也会弹出该对话框，可以设定层间位移角容许值。下图层间位移对话框中的反应谱修正系数和稳定系数可选默认值'1'。


03_层间位移(时程分析）

Home > midas Gen 2017 > 09_结果 > 08_结果表格 > 17_层 > 02_层间位移(时程分析）

层间位移（时程分析）

  • 功 能

用电子表格形式查看时程分析的层间位移及层间位移角验算结果。

Gen 的表格工具提供各种强大的内置功能。详细说明参见下列各项：

表格工具的用法

术语

熟悉用法

1.基本用法

2.数据处理

3.用剪贴板复制/粘贴数据

表格辅助功能

1.表格排序

2.表格格式设定

3.自动适应列宽

4.图表打印

表格类型的辅助功能

1.节点/单元表格

2.结果表格

  • 命 令

从主菜单中选择结果 > 分析结果表格 > 层 > 层间位移（时程分析）

从树形菜单的表格表单中选择分析结果表格 > 层 > 层间位移（时程分析）

  • 用 法

参考表格工具的使用查看如下数据：

层间位移(X)表单: 沿整体坐标系X轴方向的层间位移。

层间位移(Y)表单: 沿整体坐标系Y轴方向的层间位移。

荷载工况: 荷载工况。

层: 层名称。

层间位移角限值: 层间位移角的限值。

时间/步骤: 出现的时间或步骤。

层间位移: 各层的层间位移。

编辑层间位移: 编辑后的层间位移。

层间位移角: 各层的层间位移角。

验算: 各层的层间位移角验算结果。（OK表示通过）


04_层位移

Home > midas Gen 2017 > 09_结果 > 08_结果表格 > 17_层 > 03_层位移

层位移

  • 功 能

用电子表格形式查看层位移。

Gen 的表格工具提供各种强大的内置功能。详细说明参见下列各项：

表格工具的用法

术语

熟悉用法

1.基本用法

2.数据处理

3.用剪贴板复制/粘贴数据

表格辅助功能

1.表格排序

2.表格格式设定

3.自动适应列宽

4.图表打印

表格类型的辅助功能

1.节点/单元表格

2.结果表格

  • 命 令

从主菜单中选择结果 > 分析结果表格 > 层 > 层位移

从树形菜单的表格表单中选择分析结果表格 > 层 > 层位移

  • 用 法

参考表格工具的使用查看如下数据：

层间位移(X)表单: 沿整体坐标系X轴方向的层间位移。

层间位移(Y)表单: 沿整体坐标系Y轴方向的层间位移。

层间位移(组合): X、Y两方向层间位移的组合( [image])

荷载工况: 荷载工况。

节点: 节点号。

层: 层名称。

标高: 各层的标高。

层高度: 层高。

楼层最大位移: 各层的层间最大位移。

楼层平均位移: 各层的平均层间位移。

最大/平均: 分析层间最大位移/平均层间位移。


05_层剪重比(反应谱分析)

Home > midas Gen 2017 > 09_结果 > 08_结果表格 > 17_层 > 04_层剪力(反应谱分析)

层剪重比(反应谱分析)

  • 功 能

使用电子表格形式查看反应谱分析的层剪重比计算结果。

MIDAS Gen 的表格工具提供各种强大的内置功能。详细说明参见下列各项：

表格工具的用法

术语

熟悉用法

1.基本用法

2.数据处理

3.用剪贴板复制/粘贴数据

表格辅助功能

1.表格排序

2.表格格式设定

3.自动适应列宽

4.图表打印

表格类型的辅助功能

1.节点/单元表格

2.结果表格

  • 命 令

从主菜单中选择结果 > 分析结果表格 > 层 > 层剪重比(反应谱分析)

从树形菜单的表格表单中选择分析结果表格 > 层 > 层剪重比(反应谱分析)

  • 用 法

在激活纪录对话框中选择要查看的模态。

参考表格工具的使用查看如下数据：

层: 层名称。

标高: 层的高度。

反应谱: 反应谱荷载名称。

地震反应力: 沿整体坐标系下X、Y方向的地震反应力。

楼层剪力: 层间剪力。

弹性支承反力: 按边界条件输入的弹性支承的反力。

除弹性支承外: 除弹性支承外的层间剪力。

包含弹性支承: 包含弹性支承反力的层间剪力。

注: 层地震反应力由相应层上下层间剪力的差值计算而得。

层: 层名称。

标高 : 层的高度。

反应谱 : 反应谱荷载名称。

楼层剪力: 沿整体坐标系X、Y方向的层间剪力。

重量合计: 沿整体坐标系X、Y方向的重量。

层剪重比: 沿整体坐标系X、Y方向的层剪重比。


06_层剪重比(时程分析)

Home > midas Gen 2017 > 09_结果 > 08_结果表格 > 17_层 > 05_层剪力(时程分析)

层剪重比(时程分析)

  • 功能

使用电子表格形式查看时程分析的层剪重比计算结果。

在MIDAS/Gen中表格工具是一种内置的强大功能，要详细了解请参考以下条目.
表格工具的用法

术语

熟悉用法

1.基本用法

2.数据处理

3.用剪贴板复制/粘贴数据

表格辅助功能

1.表格排序

2.表格格式设定

3.自动适应列宽

4.图表打印

表格类型的辅助功能

1.节点/单元表格

2.结果表格

  • 命令

从主菜单中选择结果>结果表格>层>层剪力(时程分析)

或在树形工作菜单的表格选项选择结果表格>层>层剪力(时程分析)

  • 用法

从记录激活的对话框中选择要查看层剪力的时程分析工况

注：要了解记录激活对话框参考"表格工具" 中的结果表格

参考表格工具用法并检查以下数据:

层: 层号

标高: 层标高

时程: 时程工况

剪力: 层剪力

Max-X:整体坐标系下X向的最大层剪力

Max-Y:整体坐标系下Y向的最大层剪力

Min-X: 整体坐标系下X向的最小层剪力

Min-Y:整体坐标系下Y向的最小层剪力

时间: 发生的时间

Max-X: X向产生最大层剪力的时间

Max-Y: Y向产生最大层剪力的时间

Min-X: X向产生最小层剪力的时间

Min-Y: Y向产生最小层剪力的时间


07_层模态

Home > midas Gen 2017 > 09_结果 > 08_结果表格 > 17_层 > 06_层模态

层模态

  • 功 能

用电子表格形式查看横向荷载作用下的层间位移。

MIDAS Gen 的表格工具提供各种强大的内置功能。详细说明参见下列各项：

表格工具的用法

术语

熟悉用法

1.基本用法

2.数据处理

3.用剪贴板复制/粘贴数据

表格辅助功能

1.表格排序

2.表格格式设定

3.自动适应列宽

4.图表打印

表格类型的辅助功能

1.节点/单元表格

2.结果表格

  • 命 令

从主菜单中选择结果 > 分析结果表格 > 层 > 层模态

从树形菜单的表格表单中选择分析结果表格 > 层 > 层模态

  • 用 法

在激活纪录对话框中选择要查看的模态。

参考表格工具的使用查看如下数据：

层: 层名称。

标高: 层的高度。

X: 层质心的整体坐标系X轴的坐标。

Y: 层质心的整体坐标系Y轴的坐标。

模态: 振动模态号。

UX: 沿整体坐标系X轴方向的模态值。

UY: 沿整体坐标系Y轴方向的模态值。

UZ: 沿整体坐标系Z轴方向的模态值。

RX: 绕整体坐标系X轴旋转的模态值。

RY: 绕整体坐标系Y轴旋转的模态值。

RZ: 绕整体坐标系Z轴旋转的模态值。


08_层偏心

Home > midas Gen 2017 > 09_结果 > 08_结果表格 > 17_层 > 07_层偏心

层偏心

  • 功 能

使用电子表格形式查看层偏心。计算偏心率应事先在?模型>建筑物数据>控制数据?中定义各层的中心位置。

Gen 的表格工具提供各种强大的内置功能。详细说明参见下列各项：

表格工具的用法

术语

熟悉用法

1.基本用法

2.数据处理

3.用剪贴板复制/粘贴数据

表格辅助功能

1.表格排序

2.表格格式设定

3.自动适应列宽

4.图表打印

表格类型的辅助功能

1.节点/单元表格

2.结果表格

  • 命 令

从主菜单中选择结果 > 分析结果表格 > 层 > 层偏心

从树形菜单的表格表单中选择分析结果表格 > 层 > 层偏心

  • 用 法

在激活对话框中选择要查看的荷载工况或荷载组合。

参考表格工具的使用查看如下数据：

注意：本功能只有在模型/建筑物数据/控制数据的选项中勾选了偏心率时才有用。

层名称: 层名称。

标高: 层标高。

重心: 重心的位置坐标。

刚心: 刚心的位置坐标。

偏心距离: 偏心距离。

扭转刚度: 绕刚度中心位置的层扭转刚度。

回转半径: 层回转半径。

偏心率:

(1) 偏心率的概念

我们一般认为地震作用在如图1所示的重心上，所以结构除了沿地震作用方向平动以外，还会绕刚心发生扭转。当重心与刚心的偏心距离较大时，部分构件会发生较大的位移。因为这些发生较大位移构件的破坏，造成该层结构的抵抗能力的降低，地震作用将集中作用在其他构件上。偏心率是指重心与刚心的偏心距离与该层抗扭刚度的比值，偏心率越大表明抗水平侧移构件的平面布置不规则。

图1. 偏心较大的建筑物

(2) 计算偏心率的方法

计算偏心率Re的方法如下。各方向的偏心距离和坐标设定如图2所示。

图2. 扭转约定符号

① 重心

一般使用在长期荷载作用下垂直构件(柱、剪力墙等)的轴力N以及该构件的坐标X、Y来计算重心位置gx, gy 。

在此∑是指所有竖向构件之和。当恒荷载和活荷载分布均匀没有偏心时，可以将几何中心视为重心。

② 刚心

假设柱、剪力墙等单元各方向的水平刚度为KX、KY, 坐标为X、Y，刚心的坐标为lX、lY，则各层的刚心坐标如下:

在此∑是X方向或或Y方向的有效的抗震单元的和，各抗震单元的X、Y坐标可以取该单元的几何形心的坐标。

③ 偏心距离(e)

偏心距离为重心与刚心的距离。

④ 抗扭刚度

下面将坐标系原点移动到刚心上。则各抗震单元的坐标为

结构的抗扭刚度为KR

∑表示 X方向或Y方向的抗震单元之和。

⑤ 回转半径 re

假设re为结构的回转半径，reX 、reY 为X、Y方向的回转半径，

⑥ 偏心率 Re

使用回转半径分别计算X、Y方向的偏心率ReX 、ReY 。

注意: 各验算方向使用的偏心距离ex 、ey 的下标与验算方向不一致。

(3) 计算例题

结构的地震剪力分布如图3所示时，计算该建筑物的偏心程度。

图 3. 有偏心的建筑物

将建筑的左下端设定为坐标原点，则刚心为

假设平面的几何中心为重心(也可参照前面所述求实际重心位置)，各方向的偏心如图3所示。

抗扭刚度的X、Y方向成分为

所以结构的抗扭刚度为

X、Y方向的回转半径为

因此各方向的偏心率为


09_层构件剪力比

Home > midas Gen 2017 > 09_结果 > 08_结果表格 > 17_层 > 08_层构件剪力比

层构件剪力比

  • 功 能

使用电子表格形式查看抵抗横向荷载的构件的层剪力比。

MIDAS/Gen中表格工具是一种内置的强大功能，要详细了解请参考以下条目.
表格工具的用法

术语

熟悉用法

1.基本用法

2.数据处理

3.用剪贴板复制/粘贴数据

表格辅助功能

1.表格排序

2.表格格式设定

3.自动适应列宽

4.图表打印

表格类型的辅助功能

1.节点/单元表格

2.结果表格

  • 命 令

从主菜单中选择结果>结果表格>层>层剪力比

或在树形工作菜单的表格选项选择结果表格>层>层剪力比

  • 用 法

从激活记录对话框中选择工况,然后点击确认键.

层 : 层名称

标高 : 层标高

荷载 : 侧向静力荷载(静力地震荷载,风荷载)

类型 :构件类型

号 :单元号

角度1:剪力的角度

内力1: 角度1方向上作用的剪力

比率1: 角度1方向上作用的剪力的贡献比率

角度2 :与角度一垂直的方向

内力2 : 角度2方向上作用的剪力

比率2 : 角度2方向上作用的剪力的贡献比率

注：输入角度后并按'适用'键:输入剪力作用角度(角度1),并按适用键,你就能看到这个角度的剪力值以及这个方向上作用剪力的贡献比率.


12_相邻层质量比

Home > midas Gen 2017 > 09_结果 > 08_结果表格 > 17_层 > 09_相邻层质量比

相邻层质量比

  • 功 能

使用电子表格形式查看相邻层质量比的验算结果。

Gen 的表格工具提供各种强大的内置功能。详细说明参见下列各项：

表格工具的 使用

术语

熟悉用法

1.基本用法

2.数据处理

3.用剪贴板复制/粘贴数据

表格辅助功能

1.表格排序

2.表格格式设定

3.自动适应列宽

4.图表打印

表格类型的辅助功能

1.节点/单元表格

2.结果表格

  • 命 令

从主菜单中选择结果 > 分析结果表格 > 层 > 相邻层质量比

从树形菜单的表格表单中选择分析结果表格 > 层 > 相邻层质量比

  • 用 法

参考表格工具的使用查看如下数据：

层: 层名称。

标高: 各层的标高。

层质量:各层的质量。

层质量比：该层与相邻下层质量之比。

验算： 验算结果是否满足《高规》3.5.6条的要求。

OK: 层质量比&le;1.5

NG: 层质量比>1.5


10_倾覆弯矩

Home > midas Gen 2017 > 09_结果 > 08_结果表格 > 17_层 > 10_倾覆弯矩

倾覆弯矩

  • 功 能

使用电子表格形式查看竖向构件的倾覆弯矩。

MIDAS/Gen中表格工具是一种内置的强大功能，要详细了解请参考以下条目.
表格工具的用法

术语

熟悉用法

1.基本用法

2.数据处理

3.用剪贴板复制/粘贴数据

表格辅助功能

1.表格排序

2.表格格式设定

3.自动适应列宽

4.图表打印

表格类型的辅助功能

1.节点/单元表格

2.结果表格

  • 命 令

从主菜单中选择结果>结果表格>层>倾覆弯矩

或在树形工作菜单的表格选项选择结果表格>层>倾覆弯矩

  • 用 法

从激活记录对话框中选择工况,然后点击确认键。

荷载工况 : 荷载工况名称

层 : 层名称

标高 : 层标高

层高度：层高。

角度1:剪力的角度

竖向构件的倾覆弯矩:

框架:

数值：倾覆弯矩的值。

比值：倾覆弯矩的比值。

剪力墙:

数值：倾覆弯矩的值。

比值：倾覆弯矩的比值。

角度2 :与角度一垂直的方向

竖向构件的倾覆弯矩:

框架:

数值：倾覆弯矩的值。

比值：倾覆弯矩的比值。

剪力墙:

数值：倾覆弯矩的值。

比值：倾覆弯矩的比值。

注：输入角度后并按'适用'键:输入作用角度(角度1),并按适用键,你就能看到这个角度的倾覆弯矩值以及这个方向上倾覆弯矩值的比值.


11_层轴向内力之和

Home > midas Gen 2017 > 09_结果 > 08_结果表格 > 17_层 > 11_层轴力统计

层轴向内力之和

  • 功 能

使用电子表格形式查看竖向单元的层轴向内力之和。

MIDAS/Gen中表格工具是一种内置的强大功能，要详细了解请参考以下条目。
表格工具的用法

术语

熟悉用法

1.基本用法

2.数据处理

3.用剪贴板复制/粘贴数据

表格辅助功能

1.表格排序

2.表格格式设定

3.自动适应列宽

4.图表打印

表格类型的辅助功能

1.节点/单元表格

2.结果表格

  • 命 令

从主菜单中选择结果>结果表格>层>层轴向内力之和

或在树形工作菜单的表格选项选择结果表格>层>层轴向内力之和

  • 用 法

从激活记录对话框中选择工况,然后点击确认键。

荷载工况 : 荷载工况名称。

层 : 层名称。

标高 : 层标高。

层高度：层高。

竖向单元的轴向内力之和:各个竖向单元的层轴向内力之和。

轴力中心:

X坐标:轴力中心的X轴坐标。

Y坐标:轴力中心的Y轴坐标。


12_扭转不规则验算

Home > midas Gen 2017 > 09_结果 > 08_结果表格 > 17_层 > 12_扭转不规则验算

扭转不规则验算

  • 功 能

使用电子表格形式查看扭转不规则验算的结果。

MIDAS/Gen中表格工具是一种内置的强大功能，要详细了解请参考以下条目.
表格工具的用法

术语

熟悉用法

1.基本用法

2.数据处理

3.用剪贴板复制/粘贴数据

表格辅助功能

1.表格排序

2.表格格式设定

3.自动适应列宽

4.图表打印

表格类型的辅助功能

1.节点/单元表格

2.结果表格

  • 命 令

从主菜单中选择结果>结果表格>层>扭转不规则验算

或在树形工作菜单的表格选项选择结果表格>层>扭转不规则验算

  • 用 法

从激活记录对话框中选择工况,然后点击确认键。

荷载工况：荷载工况的名称

层 : 层名称

标高 : 层标高

层高度：层高

楼层两端层间位移平均值:

层间位移: 层间位移的平均值

1.2*层间位移: 1.2倍的层间位移的平均值

楼层最大层间位移:

节点 :楼层最大层间位移的节点号

层间位移: 楼层最大层间位移的值

验算：验算结果（是否规则）


13_侧向刚度不规则验算

Home > midas Gen 2017 > 09_结果 > 08_结果表格 > 17_层 > 13_侧向刚度不规则验算

侧向刚度不规则验算

  • 功 能

使用电子表格形式查看侧向刚度不规则验算的结果。

MIDAS Gen 的表格工具提供各种强大的内置功能。详细说明参见下列各项：

表格工具的用法

术语

熟悉用法

1.基本用法

2.数据处理

3.用剪贴板复制/粘贴数据

表格辅助功能

1.表格排序

2.表格格式设定

3.自动适应列宽

4.图表打印

表格类型的辅助功能

1.节点/单元表格

2.结果表格

  • 命 令

从主菜单中选择结果 > 分析结果表格 > 层 > 侧向刚度不规则验算

从树形菜单的表格表单中选择分析结果表格 > 层 > 侧向刚度不规则验算

  • 用 法

在激活纪录对话框中选择要查看的荷载工况和荷载组合。

参考表格工具的使用查看如下数据：

如果结构类型为框架结构（设计->一般设计参数->定义结构控制参数中进行定义）：

荷载工况: 荷载工况名称。

层: 层名称。

标高: 层高度。

层高度: 层高。

层间位移: 该方向层间位移。

层剪力: 该方向层剪力。

层刚度: 该方向层刚度。

上部层刚度：

0.7Ku1:上层刚度的0.7倍。

0.8Ku123:上部三层刚度的0.8倍。

层刚度比: 本层刚度与上部层刚度之比。

验算：验算结果（规则或不规则）。

注: 层刚度 K=V/&delta;

V: 层剪力

δ: 层间位移

如果结构类型为框架-剪力墙结构或剪力墙结构（设计->一般设计参数->定义结构控制参数中进行定义）：

荷载工况: 荷载工况名称。

层: 层名称。

标高: 层高度。

层高度: 层高。

层间位移: 该方向层间位移。

层剪力: 该方向层剪力。

层刚度: 该方向层刚度。

上部层刚度Ku1：上层刚度

层刚度比: 本层刚度与上部层刚度之比。

验算：验算结果（规则或不规则）。

注: 层刚度 K=V/&delta;x h

V: 层剪力

&delta;: 层间位移

h: 层高


14_楼层承载力突变验算

Home > midas Gen 2017 > 09_结果 > 08_结果表格 > 17_层 > 14_承载力不规则验算

楼层承载力突变验算

  • 功 能

使用电子表格形式查看楼层承载力突变验算的结果。

MIDAS/Gen中表格工具是一种内置的强大功能，要详细了解请参考以下条目.
表格工具的用法

术语

熟悉用法

1.基本用法

2.数据处理

3.用剪贴板复制/粘贴数据

表格辅助功能

1.表格排序

2.表格格式设定

3.自动适应列宽

4.图表打印

表格类型的辅助功能

1.节点/单元表格

2.结果表格

  • 命 令

从主菜单中选择结果>结果表格>层>楼层承载力突变验算

或在树形工作菜单的表格选项选择结果表格>层>楼层承载力突变验算

  • 用 法

从激活记录对话框中选择工况,然后点击确认键。

层 : 层名称

标高 : 层标高

层高度：层高。

角度1:剪力的角度

楼层抗剪承载力1: 角度1的楼层抗剪承载力值。

上一层抗剪承载力1: 角度1的上一层层抗剪承载力值。

本层与上一层的承载力之比1: 角度1的本层与上一层的抗剪承载力值比值。

注释：验算结果（是否规则）。

角度2 :与角度一垂直的方向

楼层抗剪承载力2: 角度2的楼层抗剪承载力值。

上一层抗剪承载力2: 角度2的上一层层抗剪承载力值。

本层与上一层的承载力之比2: 角度2的本层与上一层的抗剪承载力值比值。

注释：验算结果（是否规则）。

注：输入角度后并按'适用'键:输入作用角度(角度1),并按适用键,你就能看到这个角度的楼层抗剪承载力。


14_0.2Q0验算

Home > midas Gen 2017 > 09_结果 > 08_结果表格 > 17_层 > 15_楼层抗剪承载力验算

0.2Q0验算

  • 功 能

使用电子表格形式查看侧向刚度不规则验算的结果。

MIDAS Gen 的表格工具提供各种强大的内置功能。详细说明参见下列各项：

表格工具的用法

术语

熟悉用法

1.基本用法

2.数据处理

3.用剪贴板复制/粘贴数据

表格辅助功能

1.表格排序

2.表格格式设定

3.自动适应列宽

4.图表打印

表格类型的辅助功能

1.节点/单元表格

2.结果表格

  • 命 令

从主菜单中选择结果 > 分析结果表格 > 层 > 0.2Q0验算

从树形菜单的表格表单中选择分析结果表格 > 层 > 0.2Q0验算

  • 用 法

在激活纪录对话框中选择要查看的荷载工况和荷载组合。

参考表格工具的使用查看如下数据：

荷载工况: 荷载工况名称。

层: 层名称。

标高: 层高度。

层高度: 层高。

框架剪力: 该层框架部分承担的剪力值。

0.2Q0: 结构底部总地震剪力的20%。

1.5Vfmax: 框架部分各楼层地震剪力中最大值的1.5倍。

最小（0.2Q0，1.5Vfmax）/框架剪力：

0.2Q0与1.5Vfmax中较小者与框架剪力的比值。

验算：验算结果（调整或不调整）。

如果最小（0.2Q0，1.5Vfmax）/框架剪力>1.0,则需调整，否则不调整。


01_作用时间

Home > midas Gen 2017 > 09_结果 > 08_结果表格 > 18_非弹性铰 > 01_时刻

非弹性铰作用时间

  • 功 能

以表格的形式输出定义非弹性铰的构件产生屈服的时间。

MIDAS/Gen的表格工具提供各种强大的内置功能。详细说明参见下列各项：

表格工具的使用

  • 命 令

从主菜单中选择结果 > 分析结果表格 > 非弹性铰 > 时间

从树形菜单的表格选项中选择分析结果表格 > 分配非弹性铰 > 作用时间

  • 用 法

在被激活的对话框中选择要查看的荷载工况。

参考表格工具的使用查看如下数据：

单元 : 单元号

铰位置 : 非弹性铰生成位置。在集中表单，显示为I，J，I与J，FX。在分布表单，按铰的数量来显示。

荷载 : 时程荷载

自由度：自由度

第一屈服

Dx : Dx方向产生开裂的时间

Dy : Dy方向产生开裂的时间

Dz : Dz方向产生开裂的时间

Rx : Rx方向产生开裂的时间

Ry : Ry方向产生开裂的时间

Rz : Rz方向产生开裂的时间

第二屈服

Dx : Dx方向产生屈服的时间

Dy : Dy方向产生屈服的时间

Dz : Dz方向产生屈服的时间

Rx : Rx方向产生屈服的时间

Ry : Ry方向产生屈服的时间

Rz : Rz方向产生屈服的时间

第三屈服

Dx : Dx方向达到最终状态的时间

Dy : Dy方向达到最终状态的时间

Dz : Dz方向达到最终状态的时间

Rx : Rx方向达到最终状态的时间

Ry : Ry方向达到最终状态的时间

Rz : Rz方向达到最终状态的时间

注:滞回模型为4折线时，显示第3屈服的时间。

注:各个方向的时间为?0?时，表示没有达到屈服状态。


02_梁单元统计

Home > midas Gen 2017 > 09_结果 > 08_结果表格 > 18_非弹性铰 > 02_梁单元统计

梁单元统计

  • 功 能

用表格的形式查看梁单元形成集中、分布型非弹性铰的结果。

MIDAS/Gen的表格工具提供各种强大的内置功能。详细说明参见下列各项：

表格工具的使用

  • 命 令

从主菜单中选择结果 > 分析结果表格 > 非弹性铰 > 梁单元统计

从树形菜单的表格表单中选择分析结果表格 > 分配非弹性铰 > 梁单元统计

  • 用 法

在被激活的对话框中选择要输出的节点、单元、荷载工况、模态等。

参考表格工具的使用查看如下数据：

类型：非弹性铰类型

单元：单元号

铰位置：形成非弹性铰的位置

非弹性铰特性值：定义的非弹性铰名称

荷载：时程荷载

时间/步骤：时间/步骤

变形：现阶段产生的变形

内力：现阶段产生的内力

D/D1：延性系数(变形/第一屈服变形)

D/D2：延性系数(变形/第二屈服变形)

状态：铰的状态。（弹性、第一屈服、第二屈服、第三屈服）

P1：第一屈服强度

P2：第二屈服强度。滞回模型为三折线、四折线时输出该项。

P3：第三屈服强度。滞回模型为四折线时输出该项。

D1：第一屈服变形

D2：第二屈服变形。滞回模型为三折线、四折线时输出该项。

D3：第三屈服变形。滞回模型为四折线时输出该项。


03_桁架单元统计

Home > midas Gen 2017 > 09_结果 > 08_结果表格 > 18_非弹性铰 > 03_桁架单元统计

桁架单元统计

  • 功 能

用表格的形式查看桁架单元形成集中、分布型非弹性铰的结果。

MIDAS/Gen的表格工具提供各种强大的内置功能。详细说明参见下列各项：

表格工具的使用

  • 命 令

从主菜单中选择结果 > 分析结果表格 > 非弹性铰 > 桁架单元统计

从树形菜单的表格表单中选择分析结果表格 > 分配非弹性铰 > 桁架单元统计

  • 用 法

参考表格工具的使用查看如下数据：

单元：单元号

节点1：桁架i端的节点号

节点2：桁架j端的节点号

非弹性铰特性值：定义的非弹性铰名称

荷载：时程荷载

时间/步骤：时间/步骤

变形：现阶段产生的变形

内力：现阶段产生的内力

D/D1：延性系数(变形/第一屈服变形)

D/D2：延性系数(变形/第二屈服变形)

状态：铰的状态。（弹性、第一屈服、第二屈服、第三屈服）

P1：第一屈服强度

P2：第二屈服强度。滞回模型为三折线、四折线时输出该项。

P3：第三屈服强度。滞回模型为四折线时输出该项。

D1：第一屈服变形

D2：第二屈服变形。滞回模型为三折线、四折线时输出该项。

D3：第三屈服变形。滞回模型为四折线时输出该项。


04_弹簧统计

Home > midas Gen 2017 > 09_结果 > 08_结果表格 > 18_非弹性铰 > 05_弹簧统计

弹簧统计

  • 功 能

以表格的形式输出弹簧类型的非弹性铰的生成结果。

MIDAS/Gen的表格工具提供各种强大的内置功能。详细说明参见下列各项：

表格工具的使用

  • 命 令

从主菜单中选择结果 > 分析结果表格 > 非弹性铰 > 弹簧统计

从树形菜单的表格表单中选择分析结果表格 > 分配非弹性铰 > 弹簧统计

  • 用 法

在被激活的对话框中选择要输出的节点、单元、荷载工况、模态等。

参考表格工具的使用查看如下数据：

特性：一般连接特性名称

节点1，2：一般连接的节点号

非弹性铰特性值: 非弹性特性值名称

荷载：时程荷载

时间/步骤：时间/阶段

变形：现阶段发生的位移

内力：现阶段发生的内力

D/D1：延性 (变形/第一屈服变形)

D/D2：延性 (变形/第二屈服变形)

状态：铰的状态（弹性、第一屈服、第二屈服、第三屈服）

P1：第一屈服强度

P2：第二屈服强度，滞回模型为三折线或四折线时输出此项。

P3：第三屈服强度，滞回模型为四折线时输出此项。

D1：第一屈服变形

D2：第二屈服变形，滞回模型为三折线或四折线时输出此项。

D3：第三屈服变形，滞回模型为四折线时输出此项。

注:设置减震装置时，不输出延性（D/D1, D/D2）、屈服强度、屈服位移。


05_内力

Home > midas Gen 2017 > 09_结果 > 08_结果表格 > 18_非弹性铰 > 06_内力

内力

  • 功 能

以表格的形式输出非弹性铰内力结果。

MIDAS/Gen的表格工具提供各种强大的内置功能。详细说明参见下列各项：

表格工具的使用

  • 命 令

从主菜单中选择结果 > 分析结果表格 > 非弹性铰 > 内力

从树形菜单的表格表单中选择分析结果表格 > 分配非弹性铰 > 内力

  • 用 法

在被激活的对话框中选择要输出的时程荷载工况名称。

参考表格工具的使用查看如下数据：

单元：单元号

铰位置：非弹性铰分配的位置，集中类型时以i、j、i&j、FX表示，分布类型时根据铰的数量来显示。

非弹性铰特性值：铰特性值名称

荷载：时程荷载工况

内力：分析时间内的最大内力

时间：最大内力产生时的时刻


06_变形

Home > midas Gen 2017 > 09_结果 > 08_结果表格 > 18_非弹性铰 > 07_变形

变形

  • 功 能

以表格的形式输出非弹性铰变形结果。

MIDAS/Gen的表格工具提供各种强大的内置功能。详细说明参见下列各项：

表格工具的使用

  • 命 令

从主菜单中选择结果 > 分析结果表格 > 非弹性铰 > 变形

从树形菜单的表格表单中选择分析结果表格 > 分配非弹性铰 > 变形

  • 用 法

在被激活的对话框中选择要输出时程荷载工况名称。

参考表格工具的使用查看如下数据：

单元：单元号

铰位置：非弹性铰分配的位置，集中类型时以i、j、i&j、FX表示，分布类型时根据铰的数量来显示。

非弹性铰特性值：铰特性值名称

荷载：时程荷载工况

变形：分析时间内的最大变形

时间：最大变形产生时的时刻


07_延性系数(D/D1)

Home > midas Gen 2017 > 09_结果 > 08_结果表格 > 18_非弹性铰 > 08_延性系数(D/D1)

延性系数(D/D1)

  • 功 能

以表格的形式输出非弹性铰延性系数（D/D1）结果。

MIDAS/Gen的表格工具提供各种强大的内置功能。详细说明参见下列各项：

表格工具的使用

  • 命 令

从主菜单中选择结果 > 分析结果表格 > 非弹性铰 > 延性系数（D/D1)

从树形菜单的表格表单中选择分析结果表格 > 非弹性铰 > 延性系数（D/D1)

  • 用 法

在被激活的对话框中选择要输出时程荷载工况名称。

参考表格工具的使用查看如下数据：

单元：单元号

铰位置：非弹性铰分配的位置，集中类型时以i、j、i&j、FX表示，分布类型时根据铰的数量来显示。

非弹性铰特性值：铰特性值名称

荷载：时程荷载工况

D/D1：以分析时间内的最大变形除以第一阶段屈服变形来表示的延性系数

时间：最大变形产生时的时刻

注：第一阶段屈服变形和第二阶段屈服变形分别为材料达到了第一阶段屈服强度和第二阶段屈服强度时的变形。有关第一阶段屈服强度和第二阶段屈服强度的定义参见在线帮助?模型 > 材料和截面特性 > 非弹性铰特性值?中的解释。


08_延性系数(D/D2)

Home > midas Gen 2017 > 09_结果 > 08_结果表格 > 18_非弹性铰 > 09_延性系数(D/D2)

变形延性系数(D/D2)

  • 功 能

以表格的形式输出非弹性铰变延性形系数（D/D2）结果。

MIDAS/Gen的表格工具提供各种强大的内置功能。详细说明参见下列各项：

表格工具的使用

  • 命 令

从主菜单中选择结果 > 分析结果表格 > 非弹性铰 > 延性系数（D/D2)

从树形菜单的表格表单中选择分析结果表格 > 非弹性铰 > 延性系数（D/D2)

  • 用 法

在被激活的对话框中选择要输出时程荷载工况名称。

参考表格工具的使用查看如下数据：

单元：单元号

铰位置：非弹性铰分配的位置，集中类型时以i、j、i&j、FX表示，分布类型时根据铰的数量来显示。

非弹性铰特性值：铰特性值名称

荷载：时程荷载工况

D/D2：分析时间内的最大变形除以第二阶段屈服变形的延性系数

时间：最大变形产生时的时刻

单元：单元号

非弹性铰特性值：铰特性值名称

荷载：时程荷载工况

D/D2：以分析时间内的最大变形除以第二阶段屈服变形来表示的延性系数

时间：最大变形产生时的时刻

注：第一阶段屈服变形和第二阶段屈服变形分别为材料达到了第一阶段屈服强度和第二阶段屈服强度时的变形。有关第一阶段屈服强度和第二阶段屈服强度的定义参见在线帮助?模型 > 材料和截面特性 > 非弹性铰特性值?中的解释。


01_位移/速度/加速度

Home > midas Gen 2017 > 09_结果 > 08_结果表格 > 19_时程分析 > 01_位移/速度/加速度

位移/速度/加速度

  • 功 能

以表格的形式输出时程分析的位移、速度和加速度结果。

MIDAS/Gen的表格工具提供各种强大的内置功能。详细说明参见下列各项：

表格工具的使用

  • 命 令

从主菜单中选择结果 > 分析结果表格 > 时程分析 > 位移/速度/加速度

从树形菜单的表格选项中选择分析结果表格 > 时程分析 > 位移/速度/加速度

  • 用 法

在被激活的对话框中选择要查看的荷载工况。

参考表格工具的使用查看如下数据：

节点 : 节点号

荷载 : 时程荷载

Dx : Dx方向产生的位移

Dy : Dy方向产生的位移

Dz : Dz方向产生的位移

Rx : Rx方向产生的位移

Ry : Ry方向产生的位移

Rz : Rz方向产生的位移


02_梁单元内力

Home > midas Gen 2017 > 09_结果 > 08_结果表格 > 19_时程分析 > 02_梁单元内力

梁单元内力

  • 功 能

用表格的形式查看梁单元的时程分析的内力。

MIDAS/Gen的表格工具提供各种强大的内置功能。详细说明参见下列各项：

表格工具的使用

  • 命 令

从主菜单中选择结果 > 分析结果表格 > 时程分析 > 梁单元内力

从树形菜单的表格表单中选择分析结果表格 > 时程分析 > 梁单元内力

  • 用 法

在被激活的对话框中选择要输出的节点、单元、荷载工况、模态等。

参考表格工具的使用查看如下数据：

单元：单元号

荷载：时程荷载

位置：输出梁单元内力的位置

轴向：轴向的内力

剪力-y：y向发生的剪力

剪力-z：z向发生的剪力

扭矩：扭矩

弯矩-y：y向发生的弯矩

弯矩-z：z向发生的弯矩

内力：现阶段发生的内力

时间/步骤：时间/步骤


03_墙单元内力

Home > midas Gen 2017 > 09_结果 > 08_结果表格 > 19_时程分析 > 03_墙单元内力

墙单元内力

  • 功 能

用表格的形式查看墙单元的时程分析的内力。

MIDAS/Gen的表格工具提供各种强大的内置功能。详细说明参见下列各项：

表格工具的使用

  • 命 令

从主菜单中选择结果 > 分析结果表格 > 时程分析 > 墙单元内力

从树形菜单的表格表单中选择分析结果表格 > 时程分析 > 墙单元内力

  • 用 法

在被激活的对话框中选择要输出的节点、单元、荷载工况、模态等。

参考表格工具的使用查看如下数据：


03_桁架单元内力

Home > midas Gen 2017 > 09_结果 > 08_结果表格 > 19_时程分析 > 04_桁架内力

桁架单元内力

  • 功 能

以表格的形式输出桁架单元时程分析的结果。

MIDAS/Gen的表格工具提供各种强大的内置功能。详细说明参见下列各项：

表格工具的使用

  • 命 令

从主菜单中选择结果 > 分析结果表格 > 时程分析 > 桁架单元内力

从树形菜单的表格表单中选择分析结果表格 > 时程分析 > 桁架单元内力

  • 用 法

在被激活的对话框中选择要输出的节点、单元、荷载工况、模态等。

参考表格工具的使用查看如下数据：

单元：单元号

荷载：时程荷载

内力-I：I端发生的内力

内力-J：J端发生的内力

内力：现阶段发生的内力

时间/步骤：时间/步骤


04_一般连接

Home > midas Gen 2017 > 09_结果 > 08_结果表格 > 19_时程分析 > 05_一般连接

一般连接

  • 功 能

以表格的形式输出一般连接的时程分析结果。

MIDAS/Gen的表格工具提供各种强大的内置功能。详细说明参见下列各项：

表格工具的使用

  • 命 令

从主菜单中选择结果 > 分析结果表格 > 时程分析 > 一般连接

从树形菜单的表格表单中选择分析结果表格 > 时程分析 > 一般连接

  • 用 法

在被激活的对话框中选择要输出的时程荷载工况名称。

参考表格工具的使用查看如下数据：

号：一般连接的号

荷载：时程荷载

节点：一般连接的节点位置

轴向：轴向的内力

剪力-y：y向发生的剪力

剪力-z：z向发生的剪力

扭矩：扭矩

弯矩-y：y向发生的弯矩

弯矩-z：z向发生的弯矩

内力：现阶段发生的内力

时间/步骤：时间/步骤


01_应力

Home > midas Gen 2017 > 09_结果 > 08_结果表格 > 20_水化热分析 > 01_应力

应力表格

  • 功 能

使用表格形式查看水化热分析得到的实体单元的应力。

MIDAS/Gen的表格工具提供了各种强大的内置功能，详细说明参见下列各项：

表格工具的使用

术语

熟悉用法

基本用法（单元移动、选择、大小的控制等）

数据处理（增加、删除、修改数据等）

使用粘贴板拷贝/粘贴数据

表格辅助功能

表格排序

表格格式设定

自动适应列宽

图表打印

表格类型的辅助功能

节点/单元表格

结果表格

  • 命 令

从主菜单中选择结果 > 分析结果表格 > 水化热分析 > 应力

从树形菜单的表格表单中选择结果表格 > 水化热分析 > 应力

  • 用 法 ("参见应力" )

在激活对话框中选择要查看的分析步骤。

参考表格工具的使用校核如下数据：

水化热应力(局部)

单元: 单元号。

阶段: 施工阶段名称。

步骤: 施工阶段内子步骤。

时间: 施工持续时间。

节点: 单元的节点号或位置。

Sig-xx: 沿单元坐标系x轴方向的轴向应力。

Sig-yy: 沿单元坐标系y轴方向的轴向应力。

Sig-zz: 沿单元坐标系z轴方向的轴向应力。

Sig-xy: 单元坐标系x-y平面的剪应力。

Sig-yz: 单元坐标系y-z平面的剪应力。

Sig-xz: 单元坐标系x-z平面的剪应力。

Sig-P1: 主轴1方向的主应力。

Sig-P2: 主轴2方向的主应力。

Sig-P3: 主轴3方向的主应力。

Max-Shear: 最大剪应力。

Sig-EFF: 有效应力(von-Mises Stress)。

Sig-OCT: 八面体应力(Octahedral Shear Stress)。

水化热应力(整体)

单元 : 单元号。

阶段 : 施工阶段名称。

步骤 : 施工阶段内子步骤。

时间 : 施工持续时间。

节点 : 单元的节点号或位置。

Sig-xx: 沿整体坐标系X轴方向的轴向应力。

Sig-yy: 沿整体坐标系Y轴方向的轴向应力。

Sig-zz: 沿整体坐标系Z轴方向的轴向应力。

Sig-xy: 整体坐标系X-Y平面的剪应力。

Sig-yz: 整体坐标系Y-Z平面的剪应力。

Sig-xz: 整体坐标系X-Z平面的剪应力。

Sig-P1: 主轴1方向的主应力。

Sig-P2: 主轴2方向的主应力。

Sig-P3: 主轴3方向的主应力。

Max-Shear: 最大剪应力。

Sig-EFF: 有效应力(von-Mises Stress)。

Sig-OCT: 八面体应力(Octahedral Shear Stress)。


02_温度

Home > midas Gen 2017 > 09_结果 > 08_结果表格 > 20_水化热分析 > 02_温度

温度表格

  • 功 能

使用表格形式查看水化热分析得到的节点温度分析结果。

MIDAS/Gen的表格工具提供了各种强大的内置功能，详细说明参见下列各项：

表格工具的使用

术语

熟悉用法

基本用法（单元移动、选择、大小的控制等）

数据处理（增加、删除、修改数据等）

使用粘贴板拷贝/粘贴数据

表格辅助功能

表格排序

表格格式设定

自动适应列宽

图表打印

表格类型的辅助功能

节点/单元表格

结果表格

  • 命 令

从主菜单中选择结果 > 分析结果表格 > 水化热分析 > 温度

从树形菜单的表格表单中选择结果表格 > 水化热分析 > 温度

  • 用 法

在激活对话框中选择要查看的分析步骤。

参考表格工具的使用校核如下数据：

节点: 节点号。

阶段: 施工阶段名称。

步骤: 施工阶段内子步骤。

时间: 施工持续时间。

温度: 节点温度。


03_位移

Home > midas Gen 2017 > 09_结果 > 08_结果表格 > 20_水化热分析 > 03_位移

位移表格

  • 功 能

使用表格形式查看水化热分析得到的节点位移分析结果。

MIDAS/Gen的表格工具提供了各种强大的内置功能，详细说明参见下列各项：

表格工具的使用

术语

熟悉用法

基本用法（单元移动、选择、大小的控制等）

数据处理（增加、删除、修改数据等）

使用粘贴板拷贝/粘贴数据

表格辅助功能

表格排序

表格格式设定

自动适应列宽

图表打印

表格类型的辅助功能

节点/单元表格

结果表格

  • 命 令

从主菜单中选择结果 > 分析结果表格 > 水化热分析 > 位移

从树形菜单的表格表单中选择结果表格 > 水化热分析 > 位移

  • 用 法

在激活对话框中选择要查看的分析步骤。

参考表格工具的使用校核如下数据：

节点: 节点号。

阶段: 施工阶段名称。

步骤: 水化热分析各阶段内的子步骤。

时间: 时间。

DX: 整体坐标系X轴方向的位移。

DY: 整体坐标系Y轴方向的位移。

DZ: 整体坐标系Z轴方向的位移。

RX: 绕整体坐标系X轴的旋转位移。

RY: 绕整体坐标系Y轴的旋转位移。

RZ: 绕整体坐标系Z轴的旋转位移。

注:当有施工阶段时，表格中将输出阶段和步骤。当有非线性分析时，也将输出步骤项。


04_容许抗拉强度

Home > midas Gen 2017 > 09_结果 > 08_结果表格 > 20_水化热分析 > 04_容许拉应力

容许抗拉强度表格

  • 功 能

使用电子表格形式查看水化热分析时各节点的容许抗拉强度值。

MIDAS/Gen 的表格工具提供了各种强大的内置功能，详细说明参见下列各项：

表格工具的使用

术语

熟悉用法

基本用法（单元移动、选择、大小的控制等）

数据处理（增加、删除、修改数据等）

使用粘贴板拷贝/粘贴数据

表格辅助功能

表格排序

表格格式设定

自动适应列宽

图表打印

表格类型的辅助功能

节点/单元表格

结果表格

  • 命 令

从主菜单中选择结果 > 分析结果表格 > 水化热分析 > 容许抗拉强度

从树形菜单的表格表单中选择结果表格 > 水化热分析 > 容许抗拉强度

  • 用 法 (参见"容许抗拉强度")

在激活对话框中选择要查看的分析步骤。

参考表格工具的使用校核如下数据：

节点: 节点号。

阶段: 施工阶段名称。

步骤: 水化热分析各阶段内的子步骤。

时间: 时间。

应力: 容许抗拉强度。

注：当有施工阶段时，表格中将输出阶段和步骤。当有非线性分析时，也将输出步骤项。


05_管冷节点温度

Home > midas Gen 2017 > 09_结果 > 08_结果表格 > 20_水化热分析 > 05_管冷节点温度

管冷节点温度表格

  • 功 能

使用表格形式查看冷却管中水经过节点的温度。

MIDAS/Gen 的表格工具提供了各种强大的内置功能，详细说明参见下列各项：

表格工具的使用

术语

熟悉用法

基本用法（单元移动、选择、大小的控制等）

数据处理（增加、删除、修改数据等）

使用粘贴板拷贝/粘贴数据

表格辅助功能

表格排序

表格格式设定

自动适应列宽

图表打印

表格类型的辅助功能

节点/单元表格

结果表格

  • 命 令

从主菜单中选择结果 > 分析结果表格 > 水化热分析 > 管冷节点温度

从树形菜单的表格表单中选择结果表格 > 水化热分析 > 管冷节点温度

  • 用 法

在激活对话框中选择要查看的分析步骤。

参考表格工具的使用校核如下数据：

管冷: 管冷组名称。

阶段: 施工阶段名称。

步骤: 施工阶段内子步骤。

时间: 子步骤时间。

节点: 节点号。

温度: 水的节点温度。


01_预应力钢束坐标

Home > midas Gen 2017 > 09_结果 > 08_结果表格 > 21_预应力钢束 > 01_钢束坐标

预应力钢束坐标

  • 功 能

使用电子表格形式查看预应力钢束的坐标。

MIDAS/GEN 的表格工具提供各种强大的内置功能。详细说明参见下列各项：

表格工具的使用

术语

熟悉用法

基本用法（单元移动、选择、大小的控制等）

数据处理（增加、删除、修改数据等）

使用粘贴板拷贝/粘贴数据

表格辅助功能

表格排序

表格格式设定

自动适应列宽

图表打印

表格类型的辅助功能

节点/单元表格

结果表格

  • 命 令

从主菜单中选择结果 > 分析结果表格 > 预应力钢束 > 预应力钢束坐标

从树形菜单的表格选项中选择分析结果表格 > 预应力钢束 > 预应力钢束坐标

  • 用 法

参考表格工具的使用校核如下数据：

预应力钢束名称: 用户定义的预应力钢束的名称。

号: 钢束节点号。

x、y、z : 钢束的单元坐标系坐标。即以截面基准线(在定义截面时用修改偏心设定)。

注：1. 钢束节点号为?0?的钢束的坐标为整体坐标系坐标。该钢束的其余节点坐标为单元坐标(以截面基准线为单元坐标系的x轴，基准线位置在模型>材料和截面特性>截面中，添加截面时，在截面数据>修改偏心中确定)。

2. 每个钢束均有一个编号为0钢束节点号。


02_预应力钢束伸长量

Home > midas Gen 2017 > 09_结果 > 08_结果表格 > 21_预应力钢束 > 02_钢束伸长量

预应力钢束伸长量

  • 功 能

使用电子表格形式查看预应力钢束的伸长量。

MIDAS/Gen的表格工具提供各种强大的内置功能。详细说明参见下列各项：

表格工具的使用

术语

熟悉用法

基本用法（单元移动、选择、大小的控制等）

数据处理（增加、删除、修改数据等）

使用粘贴板拷贝/粘贴数据

表格辅助功能

表格排序

表格格式设定

自动适应列宽

图表打印

表格类型的辅助功能

节点/单元表格

结果表格

  • 命 令

从主菜单中选择结果 > 分析结果表格 > 预应力钢束 > 预应力钢束伸长量

从树形菜单的表格选项中选择分析结果表格 > 预应力钢束 > 预应力钢束伸长量

  • 用 法

参考表格工具的使用校核如下数据：

预应力钢束名称: 钢束的名称。

阶段: 加载该钢束的施工阶段。

步骤: 加载该钢束的施工步骤。

预应力钢束延伸长度

开始: 在钢束始点位置钢束的伸长量。

结束: 在钢束结束位置钢束的伸长量。

混凝土压缩长度

开始: 在钢束始点位置混凝土的压缩长度。

结束: 在钢束结束位置混凝土的压缩长度。

合计

开始: 在钢束始点位置钢束的伸长量与混凝土的压缩长度之和。

结束: 在钢束结束位置钢束的伸长量与混凝土的压缩长度之和。


03_钢束重量

Home > midas Gen 2017 > 09_结果 > 08_结果表格 > 21_预应力钢束 > 03_钢束重量

钢束重量

  • 功 能

使用电子表格形式查看预应力钢束的重量。

  • 命 令

从主菜单中选择结果 > 分析结果表格 > 预应力钢束 > 钢束重量

从树形菜单的表格选项中选择分析结果表格 > 预应力钢束 > 钢束重量

  • 用 法

参考表格工具的使用校核如下数据：

钢束名称: 预应力钢束的名称。

钢束号: 预应力钢束的号。

面积: 预应力钢束的面积。

长度：预应力钢束的长度。

重量：预应力钢束的重量。

总重量：预应力钢束的总重量。


01_梁单元内力和应力

Home > midas Gen 2017 > 09_结果 > 08_结果表格 > 22_施工阶段联合截面 > 01_梁单元内力和应力

梁单元内力和应力表格

  • 功 能

在电子数据表格中检查分析结果中施工阶段联合截面梁单元的内力和应力。

MIDAS/Gen的表格工具提供了各种强大的内置功能，详细说明参见下列各项：

表格工具的使用

术语

熟悉用法

基本用法（单元移动、选择、大小的控制等）

数据处理（增加、删除、修改数据等）

使用粘贴板拷贝/粘贴数据

表格辅助功能

表格排序

表格格式设定

自动适应列宽

图表打印

表格类型的辅助功能

节点/单元表格

结果表格

  • 命 令

从主菜单中选择结果 > 分析结果表格 > 施工阶段联合截面 > 梁单元内力和应力

从主菜单中选择结果 > 分析结果表格 > 施工阶段联合截面 > 梁单元内力

从主菜单中选择结果 > 分析结果表格 > 施工阶段联合截面 > 梁单元应力

从树形菜单的表格表单中选择结果表格 > 施工阶段联合截面 > 梁单元内力和应力

从树形菜单的表格表单中选择结果表格 > 施工阶段联合截面 > 梁单元内力

从树形菜单的表格表单中选择结果表格 > 施工阶段联合截面 > 梁单元应力

  • 用 法 (参见?梁单元内力?，?梁单元应力?)

在被激活的对话框中选择荷载工况和荷载组合。

参考表格工具的使用校核如下数据：

梁单元内力

单元：单元编号

荷载：荷载工况/荷载组合

阶段：施工阶段

步骤：施工阶段的子步骤

截面位置：联合截面中相应截面的位置编号

位置：每个单元沿长度方向的输出位置

轴向：轴力

弯矩- y：关于单元局部坐标系y轴的弯矩

弯矩- z：关于单元局部坐标系z轴的弯矩

梁单元应力

单元：单元编号

荷载：荷载工况/荷载组合

阶段：施工阶段

步骤：施工阶段的子步骤

截面位置：联合截面中相应截面的位置编号

位置：每个单元沿长度方向的输出位置

轴向：轴力

弯矩(+y)：关于单元局部坐标系y轴的弯曲应力

弯矩(-y)：关于单元局部坐标系y轴的弯曲应力

弯矩(+z)：关于单元局部坐标系z轴的弯曲应力

弯矩(-z)：关于单元局部坐标系z轴的弯曲应力

Cb(min/max): 组合应力中绝对值最大的应力值。

Cb1(-y+z)～Cb4(-y-z): 各组合应力值，某截面左上、右上、右下、左下端点位置的组合应力。


01_单元

Home > midas Gen 2017 > 09_结果 > 08_结果表格 > 23_位移参与系数 > 01_单元

单元的位移参与系数表格

  • 功 能

以表格形式输出单元的位移参与系数。

  • 命 令

从主菜单中选择结果 > 分析结果表格 > 位移参与系数>单元

从树形菜单的表格选项中选择分析结果表格 > 位移参与系数>单元

  • 用 法

单元号：单元号

Dspl LC：位移荷载工况

Unit LC：单位荷载工况

Delta：单元的位移

Delta/WT：单元位移与单元重量的比值

Fx/WT：基于力Fx求出的单元位移分量与单元重量的比值

Fy/WT：基于力Fy求出的单元位移分量与单元重量的比值

Fz/WT：基于力Fz求出的单元位移分量与单元重量的比值

Mx/WT：基于弯矩Mx求出的单元位移分量与单元重量的比值

My/WT：基于弯矩My求出的单元位移分量与单元重量的比值

Mz/WT：基于弯矩Mz求出的单元位移分量与单元重量的比值


02_截面/厚度

Home > midas Gen 2017 > 09_结果 > 08_结果表格 > 23_位移参与系数 > 02_截面/厚度

截面/厚度的位移参与系数表格

  • 功 能

以表格形式输出截面/厚度的位移参与系数。

  • 命 令

从主菜单中选择结果 > 分析结果表格 > 位移参与系数>截面/厚度

从树形菜单的表格选项中选择分析结果表格 > 位移参与系数>截面/厚度

  • 用 法

号：截面/厚度号

名称：截面/厚度名称

Dspl LC：位移荷载工况

Unit LC：单位荷载工况

Delta：截面/厚度的位移

Delta/WT：截面/厚度位移与截面/厚度重量的比值

Fx/WT：基于力Fx求出的截面/厚度位移分量与截面/厚度重量的比值

Fy/WT：基于力Fy求出的截面/厚度位移分量与截面/厚度重量的比值

Fz/WT：基于力Fz求出的截面/厚度位移分量与截面/厚度重量的比值

Mx/WT：基于弯矩Mx求出的截面/厚度位移分量与截面/厚度重量的比值

My/WT：基于弯矩My求出的截面/厚度位移分量与截面/厚度重量的比值

Mz/WT：基于弯矩Mz求出的截面/厚度位移分量与截面/厚度重量的比值


24_初始单元内力

Home > midas Gen 2017 > 09_结果 > 08_结果表格 > 24_初始单元内力

初始单元内力

  • 功 能

以表格形式输出利用初始荷载控制数据计算得出的外部荷载引起的单元内力。

  • 命 令

从主菜单中选择结果 > 分析结果表格 > 初始单元内力

从树形菜单的表格选项中选择分析结果表格 > 初始单元内力

  • 用 法

类型：单元类型

号：单元号

构件内力-i：单元i端的构件内力

构件内力-j：单元j端的构件内力

轴力：轴力

剪力(y)：单元坐标系y方向的剪力

剪力(z)：单元坐标系z方向的剪力

扭矩：扭矩

弯矩(y)：绕单元坐标系y轴的弯矩

弯矩(z)：绕单元坐标系z轴的弯矩


01_整体控制

Home > midas Gen 2017 > 10_Pushover > 01_整体控制 > 01_整体控制

整体控制

  • 功 能

    输入Pushover分析必要的控制条件，有以下几方面。

    1.初始荷载：输入初始荷载（一般情况下为重力荷载代表值）

    2.收敛标准：确定迭代最大子步骤数（每步最大迭代步骤数）和容许误差

    3.刚度折减系数：确定第1屈服后和第2屈服后相对于弹性刚度的折减系数（双折线型只有第1屈服点，三折线型需设定第1、第2屈服点）

    4.分布铰参考位置：确定计算梁单元屈服强度的参考位置（仅适用于分布铰）

  • 命 令

从主菜单中选择 Pushover > 整体控制 > 整体控制...

  • 输 入

Pushover主控数据对话框

初始荷载

定义、修改或删除初始荷载工况。

方法1：考虑初始荷载的非线性分析：默认方法，选择工况、系数，点击“添加”

方法2：导入静力分析/施工阶段分析结果

注1：若使用方法2，则会导入施工阶段分析的单元内力，并且不再以初始荷载进行非线性分析。

荷载工况

选择定义初始荷载的静力荷载工况。

系数

输入初始荷载中每个荷载工况的比例系数。

注1：含下列温度荷载的情况，则不能进行Pushover分析。 1）梁截面温度；2）温度梯度；3）系统温度；4）节点温度；5）单元温度。

注2：初始荷载产生的构件内力会累加到Pushover分析中，但不考虑由初始荷载产生的位移结果。

注3：如果在铰特性值中考虑P-M相关，则需要设置初始荷载。

停止分析

剪切成分屈服：梁/柱--若任一梁或柱构件若发生剪切破坏，则自动终止Pushover分析；墙--同梁柱

注：若因剪切破坏而终止分析，则可在Pushover最后一步中查看结果。

非线性分析选项

容许不收敛：通过增加迭代步骤数，可改善非线性分析的收敛性。但如果迭代步骤数设置太大，则会更加耗时。勾选该选项，则当迭代不收敛时，midas Gen会在不收敛处自动细分再次迭代计算，因此能在不增加步骤数的前提下实现收敛。如果不勾选该项，当分析不收敛时，Pushover分析会终止。

最大子步骤数：设置最大子步骤数，即分割每一步长的数量。

最大迭代次数：设置每一步骤内最大迭代计算次数，以满足结构的平衡条件。

注：最大迭代次数适用于所有的Pushover分析荷载工况

收敛标准

确定收敛的极限容许值。当某一步骤迭代的增量误差在达到最大迭代次数之前满足该容许值，则该步骤停止并进入下一步骤的迭代计算。

注1：一般情况下，采用位移标准即可。只有当非常特殊的情况下，才会额外考虑其他的标准（内力标准和能量标准）。例如：虽然满足位移标准，但由于存在不平衡力（又叫残余力：塑性铰的出现造成了单元刚度的变化，进而引起单元内力的变化，从而使外力和单元内力之间产生不平衡力）且不可忽略而导致无法正确求解时。

注2：当采用多个收敛标准时，每一步骤的迭代次数会增加。

注3：当不满足收敛标准时，残余不平衡力将累计到下一个增量步骤中的外力中。因此，如果当前步骤的计算能够收敛，则无论上一步的是否收敛，都不会影响分析结果。

Pushover铰数据选项

定义默认骨架曲线的刚度折减系数；设置计算梁截面屈服强度的参考位置（分布铰适用）。

定义默认骨架曲线的刚度折减系数

三折线/滑动三折线类型：α1--达到第1屈服点后的刚度折减系数（α1≤1.0）；α2--达到第2屈服点后的刚度折减系数（α2<α1≤1.0）

双折线/滑动双折线类型：α1--达到屈服点后的刚度折减系数（α1≤1.0）

注：如果用户改变了默认刚度折减系数后，则在塑性铰对话框中的刚度折减系数采用用户定义的数值。

点弹簧支承：非线性类型

在Pushover分析中，考虑点弹簧支承的非线性类型（只受压、只受拉、多折线类型）。

：删除主控数据。这个开关只有在静力弹塑性分析控制数据存在时才能被激活。 在这种情况下，静力弹塑性分析将不能进行。


01_Pushover荷载工况

Home > midas Gen 2017 > 10_Pushover > 02_荷载工况 > 01_Pushover荷载工况

Pushover荷载工况

  • 功 能

输入、编辑或删除静力弹塑性分析的荷载工况和分析条件。

  • 命 令

    从主菜单中选择 Pushover > 荷载工况 > Pushover荷载工况...

  • 输 入

点击 [image] 产生新的荷载工况。点击 [image] 确认或编辑输入的数据，点击 [image] 删除输入的数据。

Pushover荷载工况对话框

如果选择荷载控制

Pushover荷载工况对话框(荷载控制)

一般控制

计算步骤数（nstep）：达到预估坍塌荷载（Qud）的步骤数。需填入大于1的整数，默认推荐值为20。

考虑P-Delta效应：是否考虑P-Delta几何非线性效应

注1：P-Delta效应非常重要。横向荷载产生的横向位移在重力作用下会被放大，且这种效应会降低结构的侧向刚度。尤其当塑性铰发生在柱构件下端时，在较大的轴力作用下，侧向刚度的降低能引起整个结构的垮塌。

注2：FEMA或Eurocode规范型的塑性铰，在达到强度峰值后，结构刚度会迅速降低，达到极限强度后，其几何刚度可以忽略。如：Collapse Prevention（CP）和Near Collapse（NC）阶段等。

初始荷载

使用初始荷载产生的累加反力/层剪力/位移

注1：如果在铰特性值中考虑P-M相关，则需要设置初始荷载

注2：如果采用导入静力分析结果（ST）或施工阶段分析结果（CS），则反力和位移不会累加。

步骤控制选项

设置荷载增量的控制数据

自动控制步骤：预估坍塌荷载（Qud）按照荷载计算参数设置被自动分割。第一步会加载到结构弹性极限值的90%，其后的步骤按照的比例 [image] 自动分割。

注：弹性极限值指的是发生第一次屈服时的预估荷载。

相同步骤（1/nstep）：预估坍塌荷载（Qud）被输入的计算步骤数均分。

增量控制函数：预估坍塌荷载（Qud）被用户自定义函数分割。

终止分析条件

当前刚度比（Cs）：如果当前增量步骤的结构刚度与初始刚度的比值达到设定值，则分析终止。例如：设定该参数为5%，则当前的结构刚度与初始刚度的比值达到0.05时，分析终止。

注：除了以上设置的终止分析条件外，当计算步骤数达到最大值、刚度矩阵为负时，分析同样会终止。

弹塑性层间位移角限值：默认为1/10。

荷载工况（Qud）

设定Pushover分析的荷载加载模式的类型（放大比率）。

荷载类型

静力荷载工况：使用已定义的静力荷载工况的加载模式。通过比例系数实现荷载组合的加载形式。

加速度常量：荷载模式按照结构的惯性力分布。如果加速度值为一常量时，则荷载加载形式取决于每一楼层的质量。

模态：推覆力加载模式为某一模态形式（需进行特征值分析）。

归一化模态*质量：通过归一化模态*质量的形式加载。

如果选择位移控制

Pushover荷载工况对话框(位移控制)

一般控制

计算步骤数（nstep）：达到既定位移的步骤数。需填入大于1的整数，默认推荐值为20。

考虑P-Delta效应：是否考虑P-Delta几何非线性效应

注1：P-Delta效应非常重要。横向荷载产生的横向位移在重力作用下会被放大，且这种效应会降低结构的侧向刚度。尤其当塑性铰发生在柱构件下端时，在较大的轴力作用下，侧向刚度的降低能引起整个结构的垮塌。

注2：FEMA或Eurocode规范型的塑性铰，在达到强度峰值后，结构刚度会迅速降低，达到极限强度后，其几何刚度可以忽略。如：Collapse Prevention（CP）和Near Collapse（NC）阶段等。

初始荷载

使用初始荷载产生的累加反力/层剪力/位移

注1：如果在铰特性值中考虑P-M相关，则需要设置初始荷载

注2：如果采用导入静力分析结果（ST）或施工阶段分析结果（CS），则反力和位移不会累加。

控制选项

设置Pushover分析的位移目标

整体控制：目标位移可以根据发生最大平动位移的节点设置。

注：对于平面不规则结构，每一步发生的最大位移的节点和方向都会变化。

主节点控制

指定相对于主节点的目标位移。

主节点：主节点号

主方向：在整体坐标系下，在三个平动位移方向中选择其一作为目标位移方向。

最大位移：最大目标位移


02_Pushover函数增量

Home > midas Gen 2017 > 10_Pushover > 02_荷载工况 > 02_Pushover函数增量

Pushover增量函数

  • 功 能

    添加、修改或删除Pushover工况的步骤控制选项中的增量函数。

  • 命 令

    从主菜单中选择 Pushover > 荷载工况 > Pushover增量函数...

  • 输 入

点击 [image] 产生新的荷载工况。点击 [image] 确认或编辑输入的数据，点击 [image] 删除输入的数据。

导入CSV文件

可导入扩展名为“.CSV”的数据，形成增量函数。

用户输入

用户可直接在表格中输入步骤号和函数值


03_定义铰特性值

Home > midas Gen 2017 > 10_Pushover > 03_分配铰特性 > 01_定义Pushover铰特性值

定义铰特性值

  • 功 能

定义塑性铰数据用于Pushover分析。

  • 命 令

从主菜单中选择 设计 > 静力弹塑性(Pushover)分析 > 定义Pushover铰特性值...

  • 输 入

定义Pushover铰数据对话框

点击 [image] 按钮在下面的对话框中定义塑性铰信息。

点击 [image] 按钮进行查看和修改。

点击 [image] 按钮删除已输入的数据。

点击 [image] 按钮复制已经定义的铰数据。

定义了塑性铰类型并把其分配给所选定的构件后，在定义Pushover铰数据对话框勾选显示生成的铰，可以根据截面数据自动计算铰数据。选择被检查的铰数据且点击 [image] 按钮可以打开添加/编辑铰数据对话框，在对话框中点击 [image] 按钮可以检查铰数据。但是已分配的铰的数据在这里不允许修改。

注1
当塑性铰特性值分配给构件后，将自动生成塑性铰数据名称。例如，B358-beam表示如下：

B: 分配给梁单元的铰

358: 梁单元编号

beam: Pushover铰名称

注2

每个单元的塑性铰特性值将根据截面数据自动产生。对于钢筋混凝土构件，首先需要利用设计功能确定钢筋数据。和截面相关的钢筋数据可以在钢筋混凝土构件设计参数->编辑梁/柱/支撑/墙钢筋数据提供。如果利用钢筋混凝土构件自动配筋功能，在设计结果对话框中，需要使用 [image] 按钮将钢筋数据读到每个单元中。

注3

数值型钢材截面的承载力计算方法

1. 如果为自动计算，则截面信息（如Area，Asy，Asz,Cym,Cyp,Czm,Czp）不能为0；

2. 可以计算轴力P，弯矩My-Mz，剪力Vy-Vz以及PMM特性值；

3. 对于P-M型塑性铰，根据Pc(抗压承载力)，Pt（抗拉承载力），M0（轴力为0时的抗弯承载力）得到P-M曲线；

添加/编辑塑性铰数据类型对话框

名称

定义塑性铰特性值名称。

描述

对于塑性铰特性值的简单描述。

单元类型

选择单元类型

梁/柱：梁单元或柱单元；

墙：墙单元；

桁架：桁架单元；

墙类型

单元类型中选择墙时该选项被激活。

膜：仅考虑面内塑性；

板：同时考虑面内和面外塑性；

注：塑性铰类型应与墙单元定义时所选类型相同。

材料类型

选择相应单元的材料类型。

混凝土/SRC(包含)：混凝土或型钢混凝土；

钢结构/SRC(填充)：钢材或钢管混凝土；

砌体：砌体类型

定义

选择抗弯构件的荷载-变形关系；

弯矩-旋转角（M-&theta;）：

弯矩-曲率（M-&phi;集中）：

考虑塑性铰长度：勾选时，可以指定塑性铰的长度

积分点：选择积分点的位置，可以选择端部或中心。

积分点位置

选择端部时 [image] 选择中心时

弯矩-曲率（M-&phi;分布）：

墙柱：对于砌体材料类型的竖向构件，根据弯矩-转角关系计算截面的塑性铰特性值。

墙梁：对于砌体材料类型的水平构件，根据弯矩-转角关系计算截面的塑性铰特性值。

相关类型

无: 轴力与弯矩互不关联。

P-M相关: 轴力与单轴弯矩耦合，计算抗弯屈服特性值时考虑轴力的影响。

P-M-M相关: 轴力与两个方向的弯矩耦合，计算抗弯屈服特性值时考虑轴力的影响。

P-My-Mz: 自动生成轴力、My & Mz铰特性值

相关类型

无: 轴力与弯矩互不关联。

P-M相关: 轴力与单轴弯矩耦合，计算抗弯屈服特性值时考虑轴力的影响。

P-M-M相关: 轴力与两个方向的弯矩耦合，计算抗弯屈服特性值时考虑轴力的影响。

P-My-Mz: 自动生成轴力、My & Mz铰特性值

成分

Fx,Fy,Fz,Mx,My,Mz: 勾选自由度，定义塑性铰；

铰位置：选择塑性铰的位置。可选择I端，J端或I端和J端。

截面数量：选择“弯矩-曲率（M-Phi分布）”类型时，指定积分点的个数。

骨架曲线：选择骨架曲线的类型

注1：可以使用的骨架曲线类型如下：

1.双折线（或滑移双折线类型）

2.三折线（或滑移三折线类型）

3. FEMA类型

4. Eurocode8:2004

只有当单元类型中选择“桁架”或“一般连接”时，才能激活滑移双折线和滑移三折线类型。

注2：多折线类型适用于荷载控制法和位移控制法，但FEMA和Eurocode8仅适用于位移控制法。

铰特性：在下列对话框中输入相应的铰特性值。

如果相关类型选择“无”同时骨架曲线为双折线或三折线类型

铰特性值数据对话框(多折线型)

输出方法

自动计算：根据规范自动计算铰特性值；

注：自动计算时需要如下数据：

1. 设计规范；

2. 材料和截面特性值；

3. 钢筋混凝土构件的钢筋数据；

用户输入：用户自定义铰特性值

输出类型

刚度折减系数：根据屈服承载力和刚度折减系数定义骨架曲线；

刚度-屈服旋转角：根据屈服承载力和屈服变形定义骨架曲线；

注：

1. 刚度-屈服旋转角选项只有当输入方法选择用户输入时才能被激活。

2. 对于不同的成分，屈服变形有所不同。对于Fx为屈服变形，对于Fy和Fz为屈服应变，对于Mx，My，Mz为屈服旋转角。

I端和J端的数值类型

对称：如果I端和J端的配筋数据相同，选择该项

不对称：如果I端和J端的配筋数据不相同，可选择该项

注：只有当铰类型选择“弯矩-旋转角（M-thita）”或“弯矩-曲率（M-phi集中）”时才能激活“I端和J端的数值类型”。当输入方法选择“自动计算”时，会自动考虑I端和J端的不对称性。

特性值

类型

对称：如果顶部和底部配筋相同，选择该项

不对称：如果顶部和底部配筋相同，选择该项

屈服强度

如果输入方法选择“自动计算”，程序会自动计算屈服强度。当输入方法选择“用户输入”时，可直接输入屈服弯矩和转角数值。

P1: 第一屈服强度

对于混凝土，该值为开裂强度。对钢构件，该值为截面顶部和底部边缘开始屈服时的构件内力。

P2: 第二屈服强度

对于混凝土，该值表示混凝土开始压碎或钢筋开始屈服的起始点。对于钢结构，它代表整个构件开始屈服的构件内力。

注： P2数值一定比P1大。

刚度折减系数

主控数据使用数据：Pushover主控数据中定义的刚度折减系数；

用户定义：用户自定义刚度折减系数；

初始刚度

6EI/L,3EI/L,2EI/L:只有当塑性铰定义为“弯矩-旋转角”类型时，该项才被激活；

用户：用户直接输入

弹性刚度：将弹性刚度作为初始刚度。

初始间距

如果单元类型为桁架或一般连接，骨架曲线类型为滑移双折线或滑移三折线时，在此输入受拉或受压的初始间距。

如果相关类型选择“无”同时骨架曲线为“FEMA”类型

铰特性值数据对话框(FEMA型)

输出方法

自动计算：根据规范自动计算铰特性值；

注：自动计算时需要如下数据：

1. 设计规范；

2. 材料和截面特性值；

3. 钢筋混凝土构件的钢筋数据；

用户输入：用户自定义铰特性值

特性值

类型

对称：如果顶部和底部配筋相同，选择该项

不对称：如果顶部和底部配筋相同，选择该项

屈服强度（My）

如果输入方法选择“自动计算”，程序会自动计算屈服强度。当输入方法选择“用户输入”时，可直接输入屈服弯矩数值。坐标系与单元局部坐标系相同

屈服转角（Dy）

如果输入方法选择“自动计算”，程序会自动计算屈服转角。当输入方法选择“用户输入”时，可直接输入屈服转角数值。坐标系与单元局部坐标系相同

接受准则（当前变形/屈服变形）

根据延性系数（整体变形/屈服变形），直接输入结构的目标性能指标。程序以FEMA-273中的主要数据作为参考值。如果对称仅需输入正值。

注： Pushover分析结束后，图例中的铰状态信息可以反映接受准则。在变形形状对话框中，显示类型中选择铰状态，可以按步查看铰的状态。

初始刚度

6EI/L,3EI/L,2EI/L:只有当塑性铰定义为“弯矩-旋转角”类型时，该项才被激活；

用户：用户直接输入

弹性刚度：将弹性刚度作为初始刚度。

如果相关类型选择“无”同时骨架曲线为“Eurocode 8:2004”类型

铰特性值数据对话框(Eurocode 8:2004)

输入方法

自动计算：根据规范自动计算铰特性值；

注：自动计算时需要如下数据：

1. 设计规范；

2. 材料和截面特性值；

3. 钢筋混凝土构件的钢筋数据；

用户输入：用户自定义铰特性值

特性值

类型

对称：如果顶部和底部配筋相同，选择该项

不对称：如果顶部和底部配筋相同，选择该项

屈服强度（My）

如果输入方法选择“自动计算”，程序会自动计算屈服强度。当输入方法选择“用户输入”时，可直接输入屈服弯矩数值。坐标系与单元局部坐标系相同

屈服转角（Dy）

如果输入方法选择“自动计算”，程序会自动计算屈服转角。当输入方法选择“用户输入”时，可直接输入屈服转角数值。坐标系与单元局部坐标系相同

横截面等级

型钢梁或型钢柱端部的旋转能力取决于横截面的等级。如果想要由程序自动判别横截面等级，需要首先进行钢构件验算，而后选择“自动”即可。

接受准则

根据变形直接输入结构的目标性能指标。程序以Eurocode 8-3中的主要数据作为基本值。如果对称仅需输入正值。

注： Pushover分析结束后，图例中的铰状态信息可以反映接受准则。在变形形状对话框中，显示类型中选择铰状态，可以按步查看铰的状态。

初始刚度

弯矩铰的初始刚度默认值为屈服强度除以屈服转角，其中屈服强度和屈服转角按照Eurocode 8 1&3自动计算。包括分项系数在内的各种安全系数，在计算时不考虑。

6EI/L,3EI/L,2EI/L:只有当塑性铰定义为“弯矩-旋转角”类型时，该项才被激活；

用户：用户直接输入

弹性刚度：将弹性刚度作为初始刚度。

如果相关类型选择“P-M-M相关”

屈服面特性值对话框

输出方法

自动：根据规范自动计算铰特性值；

用户：用户自定义铰特性值

特性

类型（y轴，z轴）

对称：如果y轴和z轴的铰特性值相同，选择该项

不对称：如果y轴和z轴的铰特性值不相同，可选择该项

组成成分

y轴：定义绕y轴方向的骨架曲线和初始刚度等

z轴：定义绕z轴方向的骨架曲线和初始刚度等

类型（正，负）

对称：如果I端和J端的配筋数据相同，选择该项

不对称：如果I端和J端的配筋数据不相同，可选择该项

注：只有当铰类型选择“弯矩-旋转角（M-&theta;）”或“弯矩-曲率（M-&phi;集中）”时才能激活“I端和J端的数值类型”。当输入方法选择“自动计算”时，会自动考虑I端和J端的不对称性。

屈服强度

如果输入方法选择“自动”，程序会根据截面信息自动计算y轴和z轴方向的屈服强度。

当输入方法选择“用户”时，可直接输入屈服弯矩。

内插方法：My-Mz

P-M相关曲线是根据Bresler加载轮廓线进行内插得到的。曲线可以为椭圆，线性或用户定义的形状。alpha等于1和2分别代表线性和椭圆形状。

注：
如果由用户定义内插方法，则两个轴向的弯矩可以由Bresler加载轮廓线法公式计算。在三维相关图形中，对于给定的轴力，其 Mx-My平面的曲线可以通过下列公式得到。

如果假定 [image] ，则公式如下：

一般情况下，对矩形截面 [image] 值在1.0-2.0范围之间。如果 [image] 值为1.0，则曲线变为一条直线，其为最保守的设计， [image] 值为1.5时为比较合理结果。

第一和第二相关曲线的形状

可以通过图形或表格查看强轴或弱轴方向的屈服面。
显示数据：点击该按钮，显示分析中应用的轴力和弯矩。

注：各种骨架曲线类型的屈服强度和屈服面的定义

1. 混凝土三折线

屈服强度
屈服面
图形

第一屈服强度

PC0（t）:受拉屈服轴力

Mc0: 无轴力时开裂弯矩

第二屈服强度

Pmax(c):受压屈服轴力

MY0：无轴力时极限弯矩

MY.max:最大极限弯矩

第一屈服面（开裂）

程序根据PC0（t）和MC0自动计算开裂面

第二屈服面（极限）

受拉（-）,受压（+）

由于膜型剪力墙不具有面外刚度，因而仅定义绕y轴方向的弯矩。

2. 混凝土双折线，FEMA，EC8

屈服强度
屈服面
图形

屈服（极限）强度

Pmax(c):受压屈服轴力

MY0：无轴力时极限弯矩

MY.max:最大极限弯矩

屈服面（极限）

受拉（-）,受压（+）

由于膜型剪力墙不具有面外刚度，因而仅定义绕y轴方向的弯矩。

3. 钢构件三折线

屈服强度
屈服面
图形

第一屈服强度

PC（t）:受拉屈服轴力

Mcy,z: 最大开裂弯矩

第二屈服强度

Pmax(c):受压屈服轴力

MYy,z，max：最大极限弯矩

第一和第二屈服面（极限）

受拉（-）,受压（+）

2. 钢结构双折线，FEMA，EC8

屈服强度
屈服面
图形

屈服（极限）强度

Pmax(c):受压屈服轴力

MYy,z.max:最大极限弯矩

屈服面（极限）

受拉（-）,受压（+）

如果相关类型选择“无”或“P-M”类型，同时骨架曲线为“GSD导入”类型

输出方法

自动计算：根据规范自动计算铰特性值；

注：自动计算时需要如下数据：

1. 设计规范；

2. 材料和截面特性值；

3. 钢筋混凝土构件的钢筋数据；

用户输入：用户自定义铰特性值

I端和J端的数值类型

对称：如果I端和J端的配筋数据相同，选择该项

不对称：如果I端和J端的配筋数据不相同，可选择该项

注：只有当铰类型选择“弯矩-旋转角（M-&theta;）”或“弯矩-曲率（M-&phi;集中）”时才能激活“I端和J端的数值类型”。当输入方法选择“自动计算”时，会自动考虑I端和J端的不对称性。

特性值

类型

对称：如果顶部和底部配筋相同，选择该项

不对称：如果顶部和底部配筋相同，选择该项

屈服强度（My）

如果输入方法选择“自动计算”，程序会自动计算屈服强度。当输入方法选择“用户输入”时，可直接输入屈服弯矩数值。坐标系与单元局部坐标系相同

屈服转角（Dy）

如果输入方法选择“自动计算”，程序会自动计算屈服转角。当输入方法选择“用户输入”时，可直接输入屈服转角数值。坐标系与单元局部坐标系相同

接受准则（当前变形/屈服变形）

根据延性系数（整体变形/屈服变形），直接输入结构的目标性能指标。程序以FEMA-273中的主要数据作为参考值。如果对称仅需输入正值。

注： Pushover分析结束后，图例中的铰状态信息可以反映接受准则。在变形形状对话框中，显示类型中选择铰状态，可以按步查看铰的状态。

初始刚度

6EI/L,3EI/L,2EI/L:只有当塑性铰定义为“弯矩-旋转角”类型时，该项才被激活；

用户：用户直接输入

弹性刚度：将弹性刚度作为初始刚度。

注：各单元类型的铰特性值

1. 当定义为弯矩-转角（M-&theta;）

成分
铰特性值定义
初始刚度
铰位置
Fx(轴力)
轴力-应变（相对位移）
EA/L
中心
Fy，Fz（剪力）
剪力-剪应变
GAs/L
中心
Mx(扭矩)
扭矩-转角
GJ/L
I端、J端
My，Mz(弯矩)
弯矩-转角
6EI/L,3EI/L,2EI/L
I端，J端

2. 当定义为弯矩-曲率（M-&phi;集中，分布）

成分
铰特性值定义
初始刚度
铰位置
Fx(轴力)
轴力-应变（相对位移）
EA
积分点
Fy，Fz（剪力）
剪力-剪应变
GAs
积分点
Mx(扭矩)
扭矩-转角
GJ/L
积分点
My，Mz(弯矩)
弯矩-转角
EI
积分点

3. 桁架单元（轴力成分）

成分
铰特性值定义
初始刚度
铰位置
Fx(轴力)
轴力-应变（相对位移）
EA
积分点

4. 一般连接单元

成分
铰特性值定义
初始刚度
铰位置
Fx(轴力)
轴力-应变（相对位移）
用户定义EA/L
中间
Fy，Fz（剪力）
剪力-剪应变（相对位移）
用户定义GAs/L
中间
Mx(扭矩)
扭矩-转角
用户定义GJ/L
中间
My，Mz(弯矩)
弯矩-转角
用户定义EI/L
中间

砌体特性值

砌体结构的墙梁一般考虑为两个墙单元之间的叠合梁。其用于连接两个墙单元，同时连接板和梁。如果构件被考虑为叠合梁，可以通过框架分析来确定竖向和水平构件的力学特性。

当选择墙柱时

砌体特性值对话框（墙柱类型）

建筑物类型：砌体结构墙柱抗弯承载力及抗剪承载力与结构类型的关系如下表所示

抗弯承载力（D/H） | 抗剪承载力
新建建筑 | 8/1000
已有建筑 | 6/1000

计算墙柱承载力时，还需要如下数据：

抗压强度（fm）

抗剪强度（f0）

竖向应力分布系数（k）

注1： 如何计算承载力

轴向承载力

受压承载力：

受拉承载力：

这里，fc:抗压强度（用户定义数值）

L：墙柱长度

T：墙柱厚度

抗剪承载力

新建建筑物

L：墙柱长度

L':各荷载步的中和轴高度；

H：墙柱高度

T：墙柱厚度

&tau;0：抗剪强度（用户定义）

p:竖向应力

抗剪承载力计算假定

已有建筑物

这里

L：墙柱长度

H：墙柱高度

T：墙柱厚度

&tau;0：抗剪强度（用户定义）

p:竖向应力

抗弯承载力

受压

受拉

这里

fc: 抗压强度

k:竖向应力分布系数（默认值为0.85）

p:竖向应力

P：轴力

注2：所计算的承载力可以通过“设计->Pushover分析->Pushover铰结果表格->梁统计表格”中进行查看

注3：砌体墙柱的局部坐标轴

墙柱的水平方向和竖直方向分别为单元局部坐标系的z轴和y轴。如下图所示，将直接影响墙柱的承载力。程序根据上述假定自动计算铰特性值。

当选择墙梁类型时

砌体特性值（墙梁）

计算墙梁承载力时需要如下数据：

水平抗压强度（fhd）

无竖向荷载时剪切强度（fvk0）

Hp

注1：如何计算承载力

轴向承载力

抗压

抗拉

这里，

fkd:水平抗压强度（用户定义数值）

抗剪承载力

这里

fvk0: 无竖向荷载时抗剪强度（用户定义数值）

抗弯承载力

注2

所计算的承载力可以通过“设计->Pushover分析->Pushover铰结果表格->梁统计表格”中进行查看


04_分配铰特性值

Home > midas Gen 2017 > 10_Pushover > 03_分配铰特性 > 02_分配Pushover铰特性值

分配铰特性值

  • 功 能

  • 对所有的构件分配/替换在定义铰特性值对话框中定义的铰

  • 命 令

    从主菜单中选择 设计 > 静力弹塑性(Pushover)分析 > 分配铰特性值...

  • 输 入

选项

添加/替换：对于所选构件添加新的或替换已有的铰。

删除： 对于所选的构件删除已存在的铰。

单元类型

选择分配Pushover铰的单元类型。

铰特性值类型

选择铰的特性值类型分配给所选的构件。

列出在铰特性值类型中定义的铰类型。

点击右边的按钮调用定义Pushover铰对话框添加、编辑或删除铰类型。


07_运行静力弹塑性（Pushover）分析

Home > midas Gen 2017 > 10_Pushover > 04_运行分析

运行静力弹塑性（Pushover）分析

  • 功 能

执行Pushover分析。

  • 命 令

从主菜单中选择 设计>静力弹塑性(Pushover)分析>运行静力弹塑性（Pushover）分析...

注：完成弹性分析后，在后处理模式可以执行Pushover分析。


01_反力1

Home > midas Gen 2017 > 10_Pushover > 05_Pushover结果 > 01_反力 > 01_反力

反力

  • 功 能

输出Pushover分析每一步骤的反力结果。

  • 命 令

从主菜单中选择 Pushover > Pushover结果 > 反力 > 反力...

查看方式请参考 结果 > 反力 > 反力

注：只能选择Pushover分析工况。

注2：其余结果（应力、变形、内力）查看方式均与之类似，这里不再赘述。


05_铰状态结果

Home > midas Gen 2017 > 10_Pushover > 05_Pushover结果 > 05_铰状态结果

铰状态结果

  • 功 能

    图形方式查看Pushover分析的塑性铰状态（延性比、变形、屈服状态等）

  • 命 令

    从主菜单中选择 Pushover > Pushover结果 > 铰状态结果...

  • 输 入

Pushover荷载工况名称

选择已有的Pushover分析工况名称

步骤： 确定查看的分析步骤数

结果类型

延性比：

D/D1--实际发生的变形值与第1屈服变形值的比值；

D/D2--实际发生的变形值与第2屈服变形值的比值

塑性变形：发生屈服前，塑性变形均显示为0

屈服状态：双折线或三折线型塑性铰状态

注：根据分配的屈服强度，铰状态可以分为以下几种情况：

-双折线型：弹性、1st屈服强度、2nd屈服强度

-三折线型：弹性、1st屈服强度、2nd屈服强度、3rd屈服强度

如果为分布铰，则铰状态以颜色显示（弹性：蓝色，1st屈服：绿色，2nd屈服：红色）

屈服状态（FEMA）：FEMA型塑性铰状态

注：FEMA铰状态分为下列3种：弹性、IO（Immediate Occupancy），LS（Life Safety），CP（Collapse Prevention），Collapse

屈服状态（EC8:2004）：EC8:2004型铰状态，分为弹性，DL（Damage Limitation），SD（Significant Damage），NC（Near Collapse），Collapse

成分

Dx : 单元坐标轴x轴方向的轴力成分

Dy : 单元坐标轴y轴方向的剪力成分

Dz : 单元坐标轴z轴方向的剪力成分

Rx : 单元坐标轴x轴方向的扭矩成分

Ry : 单元坐标轴y轴方向的弯矩成分

Rz : 单元坐标轴z轴方向的剪力成分


06_静力弹塑性（Pushover）曲线

Home > midas Gen 2017 > 10_Pushover > 05_Pushover结果 > 06_Pushover曲线

静力弹塑性（Pushover）曲线

  • 功 能

利用从Pushover分析结果中计算的基底剪力与位移的相互作用得到结构的能力反应曲线和能力谱，同时也生成由使用设计反映谱的地震荷载产生的需求谱。

代表结构的最大塑性变形能力状态的性能控制点，在给定的阻尼比的情况下，可以通过能力谱和需求谱的相交点得到。

  • 命 令

从主菜单中选择 设计 > 静力弹塑性(Pushover)分析 > 静力弹塑性（Pushover）曲线...

  • 用 法

Pushover曲线对话框

Pushover荷载工况

选择一种荷载工况用于Pushover分析。

显示类型

选择产生的Pushover结果曲线类型。

基底剪力－位移

切变系数－位移: 切变系数(横向荷载/总重) vs 位移

切变系数－层间位移: 切变系数 vs 层间位移

其它节点的附加曲线: 产生附加曲线的节点号

能力谱:　Pushover分析得到的荷载(基底剪力)与位移曲线转换成加速度谱(Sa)与位移谱(Sd)曲线。

需求谱

为了使用设计反映谱生成需求谱，在指定的设计标准中定义一个设计反映谱。

各阻尼(％)比需求谱
使用指定的阻尼比产生的需求谱。

各周期（秒）的周期直线
对于给定的周期产生相应的周期直线。

性能评价点

使用ATC-40中建议的等效阻尼法，评估塑性需求谱并和能力谱相比，从而得到性能控制点。

Procedure-A: 首先评估处于塑性状态下结构的等效阻尼，并且产生相应的需求谱，性能控制点通过反复计算得到。

Procedure-B: 通过假定了延性需求曲线并且使用相应的等效周期和等效阻尼比，来评估性能控制点和得到与能力谱相交点的方法。

阻尼参数

输入确定等效阻尼比的参数。

固有 + 附加阻尼(%)
通过安装在结构上的机械装置来指定总阻尼比，以此反映固有阻尼和附加阻尼的效果。

结构反应类型
选择A,B,C类型得到用于计算等效阻尼的换算系数。

注：
结构反应类型的分类在下面的表中。

振动持续时间 | 新建建筑物 | 已建成的一般建筑物 | 已建成的破损建筑物
短 | Type A | Type B | Type C
长 | Type B | Type C | Type C

例如，如果指定结构的阻尼比为5%，则等效阻尼计算如下：

以上是根据ATC-40的变量定义方法。

性能点

曲线还可以提供在谱上的性能控制点及其转换成多自由体系的一些信息。

V, D

在性能控制点处的最大的基底剪力及处于塑性状态下结构的最大位移。

Sa, Sd

性能控制点处谱的加速度及谱的位移。

Teff, Deff

性能控制点处的塑性等效周期与等效阻尼。

除在静力弹塑性（Pushover)分析控制中定义的步骤外，用户可以指定一些子步骤查看附加的分析结果。这些Pushover分析结果输出在层间位移表格中。这个功能只有在曲线类型为能力谱时才能激活。

附加Pushover步骤对话框

定义子步骤

选择定义一个子步骤的方法

性能控制点

定义一个作为子步骤的性能控制点。

位移控制

指定一个子步骤的相对位移。

基底剪力

指定一个子步骤的相对总横向荷载。

注：
当定义子步骤由性能控制点、控制位移或基底剪力控制时，点击 [image] 按钮计算生成相应的数值。 生成子步骤数据时，程序计算相应位置和自动决定相对于下一步的参照步骤和距离比。

用户输入

用户直接输入参照的步骤和距离比。

自动计算子步骤的位置。

添加子步骤数据

子步骤位置数据

参照步骤: 指定子步骤数据的参照步骤。

距离比: 相对于参照步骤与下一步骤间距离的距离比。

: 添加子步骤到列表。

: 编辑子步骤数据。

: 删除子步骤。

自动生成性能控制点荷载步。


08_Pushover图形

Home > midas Gen 2017 > 10_Pushover > 05_Pushover结果 > 07_Pushover图形

Pushover图形

  • 功 能

    图形方式查看Pushover分析的静力弹塑性分析结果。

1.梁、桁架、墙、一般连接的位移/内力

2.节点位移

3.荷载增量

  • 命 令

从主菜单中选择 设计>静力弹塑性(Pushover)分析>Pushover图形...

  • 用 法

Pushover分析完成后，可以输出层剪力vs层间位移或构件剪力vs层间位移曲线以便校核。

定义/编辑函数

定义或修改函数

Pushover结果函数

定义过程不再赘述

函数列表

显示已定义的函数

竖向轴

选择函数列表中的项目，点击“全部列表”按钮加入

水平轴

选择函数列表中的项目，点击“全部列表”按钮加入


New Topic5

Home > midas Gen 2017 > 10_Pushover > 05_Pushover结果 > 08_Pushover层图形 > 01_层剪力图形

层剪力图形

  • 功 能

    图形显示层剪力－层间位移和层剪力-层间位移角的Pushover分析结果。

注意：使用此功能，必须在主菜单 结构 > 建筑 > 控制数据 > 控制数据 中须勾选层剪力比。

  • 命 令

从主菜单中选择 Pushover > Pushover结果 > Pushover层图形 > 层剪力图形...

  • 用 法

Pushover分析完成后，可以输出层剪力-层间位移或层剪力-层间位移角曲线以便校核。

Pushover荷载工况名称

选择已有的Pushover分析工况名称

结果的方向：确定要显示的方向分量

结果类型

层剪力-层间位移 和 层剪力-层间位移角。

层

选择校核的一个或多个楼层

注：通过塑性层剪力和层间位移的关系曲线可以评估结构抵抗塑性变形的能力，特别是可以明确计算楼层的塑性变形角以便评价结构局部抵抗塑性变形的能力

楼层剪力图(层剪力-层间位移)


02_构件剪力图形

Home > midas Gen 2017 > 10_Pushover > 05_Pushover结果 > 08_Pushover层图形 > 02_构件剪力图形

构件剪力图形

  • 功 能

    图形显示构件剪力－位移和构件剪力-位移角的Pushover分析结果。

注意：使用此功能，必须在主菜单 结构 > 建筑 > 控制数据 > 控制数据 中须勾选层剪力比。

  • 命 令

从主菜单中选择 Pushover > Pushover结果 > Pushover层图形 > 构件剪力图形...

  • 用 法

Pushover分析完成后，可以输出构件剪力-位移和构件剪力-位移角曲线以便校核。

构件剪力图形

图形表示构件剪力-位移或构件剪力-位移角

Pushover荷载工况

选择一种已用于分析的Pushover荷载工况。

结果的方向：确定要显示的方向分量

结果类型

构件剪力-位移和构件剪力-位移角。

单元

手动选择用模型中的单元或手动输入单元号。

注：通过利用构件剪力与位移的关系曲线可以评价构件的塑性变形能力。

构件剪力图形(构件剪力-位移)


03_层剪力/层间位移/层间位移角图形

Home > midas Gen 2017 > 10_Pushover > 05_Pushover结果 > 08_Pushover层图形 > 03_层剪力/层间位移/层间位移角图形

层剪力/层间位移/层间位移角图形

  • 功 能

    图形显示楼层-层剪力，楼层－层间位移和楼层-层间位移角的Pushover分析结果。

注意：使用此功能，必须在主菜单 结构 > 建筑 > 控制数据 > 控制数据 中须勾选层剪力比。

  • 命 令

从主菜单中选择 Pushover > Pushover结果 > Pushover层图形 > 层剪力/层间位移/层间位移角图形...

  • 用 法

Pushover分析完成后，可以输出楼层-层剪力，楼层－层间位移和楼层-层间位移角曲线以便校核。

Pushover荷载工况名称

选择已有的Pushover分析工况名称

结果的方向：确定要显示的方向分量

结果类型

层-层剪力，层-层间位移 和 层-层间位移角。

步骤

选择推覆过程中的一个或多个步骤

注：从老版本导入的模型中“添加层间位移输出的Pushover步骤”的结果，会转化“User”形式的Pushover工况。详细情况，请参考“Pushover曲线”。

层-层剪力

层-层间位移


01_Pushover铰特性

Home > midas Gen 2017 > 10_Pushover > 06_Pushover表格 > 01_Pushover铰特性

Pushover铰特性

  • 功 能

用表格形式查看已分配铰的构件，以及这些构件上的铰类型和铰特性值。

  • 命 令

从主菜单中选择 Pushover > Pushover表格 > Pushover铰特性 ...

  • 用 法

Pushover分析完成后，可以


05_Pushover铰表格

Home > midas Gen 2017 > 10_Pushover > 06_Pushover表格 > 02_Pushover铰

Pushover铰表格

  • 功 能

在表格中按照单元编号的顺序显示单元的铰的类型及铰的位置。

在检查输入数据的时候，可以修改/删除或者增加新数据。

  • 命 令

从主菜单中选择设计 > 静力弹塑性（Pushover）分析 > Pushover铰表格。

  • 输 入

显示如下表格时，用户可以选择相关项目来修改/删除或者增加新数据。


01_Pushover文本

Home > midas Gen 2017 > 10_Pushover > 07_文本 > 01_Pushover文本

Pushover文本

  • 功 能

    生成文本形式的Pushover结果，用来输出节点的位移结果，梁/桁架/墙的内力、应力结果，一般连接的内力、变形结果。

  • 命 令

从主菜单中选择 Pushover > 文本 >Pushover文本...

  • 用 法

选择输出选项

步骤：按照步骤数输出结果

最大/最小：只输出最大/最小结果

输出类型

确定输出步骤的范围及输出步长，默认为整个Push步骤数、一步一输出。

选择节点

用户输入节点号或在模型中选择节点

参考点

选择大地为参考或以其他节点为参考

注：单元内力/应力结果、一般连接结果与之类似，不在赘述。


01_定义结构控制参数

Home > midas Gen 2017 > 11_设计 > 01_一般设计参数 > 01_定义结构控制参数

定义结构控制参数

  • 功 能

选择全局坐标系下X方向和Y方向的框架类型(有支撑/无支撑)，对于钢结构用户可以选择由程序自动计算柱计算此长度长度系数，计算方法参见《钢结构设计规范》GB50017-2003　附录D内容；对于钢筋混凝土结构可以定义结构体系。

  • 命 令

从主菜单中选择 设计>一般设计参数 >定义结构控制参数...

从树形菜单的表格中选择 设计表格>一般设计参数>定义结构控制参数

  • 输 入

在下图所示对话框中输入数据：

定义结构控制参数对话框

定义框架侧移特性

X轴方向的侧移

在全局坐标系下X方向选择有约束无侧移或者无约束有侧移框架（默认=无约束有侧移）。

Y轴方向的侧移

在全局坐标系下Y方向选择有约束无侧移或者无约束有侧移框架（默认=无约束有侧移）。

设计类型

三维: 三维结构分析。

X-Z平面: 在全局坐标系X-Z平面内的二维分析。

Y-Z平面: 在全局坐标系Y-Z平面内的二维分析。

X-Y平面: 在全局坐标系X-Y平面内的二维分析。

由程序自动计算"计算长度系数"(仅用于钢结构)

对于钢结构建议用户选择由程序自动计算柱的计算长度系数。

结构类型

结构材料类型：

结构类型：

由用户选择钢筋混凝土结构的类型。（需要先定义钢筋混凝土设计参数：设计 >钢筋混凝土构件设计参数）

0.2Q调整上限值

勾选该项目，即可设定框剪结构进行0.2Q调整时的上限值。


02_活荷载折减系数

Home > midas Gen 2017 > 11_设计 > 01_一般设计参数 > 02_活荷载折减系数

活荷载折减系数

  • 功 能

设计墙、柱和基础时的活荷载的折减系数，输入用来计算活荷载折减系数的基本数据。

注：可以按照《建筑结构荷载规范》定义的活荷载折减系数,对于其他设计标准，可以利用 编辑活荷载折减系数 的功能，指定单个构件的折减系数。

  • 命 令

从主菜单中选择 设计>一般设计参数>活荷载折减系数...

从树形菜单的表格中选择 设计表格>一般设计>编辑活荷载折减系数

  • 输 入

下面对话框用来输入折减系数：

活荷载折减系数对话框

活荷载工况名称

在建立分析模型时，点击 [image] 可以显示活荷载工况，在该对话框内选择要折减的活荷载工况。

折减系数范围

活荷载在这个范围内折减（参阅注1）

层：活荷载折减系数应用的相关楼层。

下面的方法用来输入活荷载折减系数适用的平面区域。

<方法1> （参阅注2）

直接输入全局坐标系下X、Y方向的坐标，来选择活荷载折减系数适用的区域。

Xmin：全局坐标系下X方向的坐标的最小值

Xmax：全局坐标系下X方向的坐标的最大值

Ymin：全局坐标系下Y方向的坐标的最小值

Ymax：全局坐标系下Y方向的坐标的最大值

范围：标注活荷载折减系数范围

<方法2>

用鼠标选择两个对角线上的节点来定义活荷载折减系数适用区域的最大及最小值。

点取节点编号：在模型范围内选择两个对角线上的节点。

：增加计算活荷载折减系数的基本数据。

：修正以前定义的确定活荷载折减系数的基本数据。

：删除计算活荷载折减系数的基本数据。

：应用输入的数据或者选项，关闭对话框。

：不应用输入的数据或者选项，关闭对话框。

注1：活荷载折减系数根据柱、剪力墙、基础所支承的楼层数确定，可参见《建筑结构荷载规范》中的具体内容。单个构件活荷载折减系数由修改活荷载折减系数确定。

注2：使用坐标来确定活荷载折减系数时，一定要选择竖向构件的位置坐标。

活荷载工况对话框

活荷载工况

显示建模时输入的活荷载工况。

从活荷载工况选区点击 [image] ，显示活荷载工况，从中选择要折减活荷载工况。

选择的活荷载工况

列出计算活荷载折减系数的活荷载工况。

：使用鼠标从活荷载工况中删除荷载工况。

：输入选择的荷载工况和数值，关闭对话框。

：不进行选择，关闭对话框。


03_短期/长期荷载工况

Home > midas Gen 2017 > 11_设计 > 01_一般设计参数 > 03_短期/长期荷载工况

短期/长期荷载工况

该功能目前不支持中国规范。


04_使用性荷载组合类型

Home > midas Gen 2017 > 11_设计 > 01_一般设计参数 > 04_使用性荷载组合类型

使用性荷载组合类型

  • 功 能

荷载工况将分类为：准永久、频遇、标准三种类型。

注1：该功能只有在规范为 Eurocode 2 或 3 时才被激活。

注2：需要只有在主菜单 结果 > 荷载组合 中选择规范Eurocode 2或3，才能根据该功能标准进行设计。

注3：如果荷载组合为自动生成，则可对其进行自动分类；如果荷载组合为手动定义，则需手动进行分类。

  • 命 令

从主菜单中选择 设计 >一般设计参数 > 使用性荷载组合类型...

从树形菜单的表格中选择 设计表格 > 一般设计参数 > 使用性荷载组合类型

  • 输 入

在下图所示对话框中输入数据：

定义使用性能荷载组合类型对话框 关于分类方法的详细信息，请参考 [EN 1990 Basic of Structural Design]

›


04_非线性荷载工况荷载参与度

Home > midas Gen 2017 > 11_设计 > 01_一般设计参数 > 05_非线性荷载工况荷载参与度

非线性荷载工况荷载参与度

  • 功 能

当由荷载组合建立的荷载工况做非线性分析时，查看各荷载工况的组合值系数。


05_指定构件

Home > midas Gen 2017 > 11_设计 > 01_一般设计参数 > 06_指定构件

指定构件

  • 功能

设计是按构件来进行的，分析是按单元来进行的；对于梁单元或桁架单元，当一个构件由几个线单元组成时，可以将这些单元指定为一个构件进行设计。

注：对于钢结构需要将单元指定为构件进行设计验算，否则构件的计算长度容易取错；对于钢筋混凝土结构可以不用指定构件，但对于类似越层柱的情况需要指定构件。

  • 命令

从主菜单中选择 设计>一般设计参数>指定构件

  • 输入

按如下操作，选择相应的单元指定为一个构件

选项

添加/替换: 定义新的构件或替换已存在的构件。

删除: 删除选定的构件。你可以在模型窗口选择构件或从构件列表窗口中选择构件删除。

构件

容许单一单元构件: 勾选容许单一单元被指定为构件。

分配类型

手动: 用户直接定义构件。

自动: 程序自动定义构件。

选择类型

全部: 模型中所有的单元都将被指定为构件，这个功能在分配类型选择为自动时将非常方便。

根据选择: 被选择的单元将被指定一个构件。

对于曲梁或各单元间平面夹角超过15度的需要根据选择指定。

: 选择的单元被指定为一个构件。

: 关闭对话框。

注1

当多个单元被指定为一个构件时，将用单元号最少的单元表示构件，这个单元就是构件的代表单元，构件所有的设计参数将被赋给这个代表单元。

注2

对于不同的材料、不同的截面或单元坐标轴方向不同的单元不能被指定为一个构件。

注3
设计参数、计算长度系数(K)、等效弯距系数(Cm)、弯距放大系数和极限长细比都将取自构件的代表单元，但自由长度(L,Lb)将取自整个构件中的所有单元。


06_反转构件方向

Home > midas Gen 2017 > 11_设计 > 01_一般设计参数 > 07_反转构件局部方向

反转构件方向

  • 功能

当一个构件有几个单元组成时，应用此功能可以反转构件两端单元的局部方向，使之这两个单元的I、J端对称，便于查看设计结果。

注意:不执行此项操作对设计没有什么影响，对于应用这个功能的构件在窗口列表中将被以 * 显示。

  • 命令

从主菜单中选择 设计>一般设计参数>反转构件方向

  • 输入

从模型中选择构件按如下操作

选择构件

全部: 选择所有构件反转构件方向。

根据选择: 选择部分构件反转构件方向。

: 反转已选择的构件的方向。

: 关闭对话框。

注意:此功能仅适用于构件，应用此功能前必须首先指定构件。


07_定义加腋梁

Home > midas Gen 2017 > 11_设计 > 01_一般设计参数 > 08_定义加腋梁

定义加腋梁

  • 功能

利用此功能可以对钢筋混凝土加腋梁进行截面配筋设计，设计过程分为定义加腋构件和设计两部分。

  • 命令

从主菜单中选择 设计>一般设计参数>定义加腋梁

  • 输入

从模型中选择构件按如下操作

名称

输入定义加腋梁的名称。

加腋梁的定义分为三部分，A、B、C三部分，每一部分都可以由几个单元组成，参见图示。

单元列表

定义A部分、B部分、C部分所包含的单元。

定义设计位置

定义变截面的设计截面位置，程序默认为A、C部分的1/2位置，或由用户指定L1和L2，但不能分别超过A、C部分的长度。

最后按添加按钮完成定义加腋梁。

注意:

1、B部分中与A、C两部分相连的单元端部截面形状必须与A、C两部分端部截面形状相同；且加腋部分的变化必须是光滑的曲线或直线。

2、加腋梁的设计材料采用分析时采用的材料。


08_自由长度(L,Lb)

Home > midas Gen 2017 > 11_设计 > 01_一般设计参数 > 09_无支撑长度(L,Lb)

自由长度(L,Lb)

  • 功 能

输入选定构件绕强轴（单元坐标系y轴)和绕弱轴(单元坐标系z轴)弯曲的自由长度,对于绕弱轴弯曲的构件输入受压翼缘的侧向自由长度。

注意：当构件为指定的构件时，程序将根据构件的连接和支撑条件自动计算强轴（单元坐标系y轴)和弱轴(单元坐标系z轴)的自由长度。

  • 命 令

从主菜单中选择 设计>一般设计参数>自由长度（L,Lb）...。

从树形菜单的表格中选择 设计表格>一般设计>自由长度（L,Lb）。

  • 输 入

首先选择模型中的构件，输入如下：

选项

选择增加/替换或者删除。

增加/替换：增加新数据或者修改以前的数据。

删除：删除数据，当执行删除时，不需要输入数据。

计算长度

输入指定构件强轴和弱轴的自由长度。（见注1)

Ly：绕强轴弯曲的自由长度（由z方向的支撑确定）。

Lz：绕弱轴弯曲的自由长度（由y方向的支撑确定）。

受压翼缘的支承点间距（侧向自由长度）

输入侧向自由长度。

Lb：侧向自由长度[默认值 = Lz]（见注2）。

不考虑：如果绕构件强轴的容许弯曲应力计算要忽略侧向自由长度时，选择此项（见注3）。

：将输入的数据应用到选定的构件上。

：关闭对话框。

有两种输入方法：

方法1：在输入框中直接输入Ly，Lz的值。

方法2：点击Ly，Lz或者Lb的区域，选择模型中的两个节点，根据两个节点之间的直线距离自动计算后输入。

注1:如果没有输入构件的Ly和Lz值，程序会根据相应梁（桁架）单元的节点坐标计算构件长度，然后作为Ly和 Lz的值。

注2:如果没有输入构件的Lb值，取Lb=Lz。

注3:如果在钢构件设计参数对话框中勾选?所有梁都不考虑横向屈曲?选项，此项功能自动选择，并且自动设置默认值Lb=0，参阅《钢结构设计规范》。

注4:如果对于同一个构件重复输入Ly，Lz和Lb，系数按照最后输入的数值更新。

注5:在数据表格中按照单元编号的顺序校核自由长度，侧向自由长度，用户可以修改/填加和删除数据表中的项目。


09_计算长度系数(K)

Home > midas Gen 2017 > 11_设计 > 01_一般设计参数 > 10_计算长度系数(K)

计算长度系数(K)

  • 功 能

对于选定的构件直接输入绕强轴(单元坐标轴y轴)和绕弱轴(单元坐标轴z轴)屈曲时自由长度的有效计算长度系数。

  • 命 令

从主菜单中选择 设计>一般设计参数>计算长度系数（K）...。

从树形菜单的表格中选择 设计表格>一般设计>计算长度系数（K）。

  • 输 入

首先在模型中选择构件，输入如下：

选项

选择增加/替换或删除。

增加/替换：增加新数据或者修改以前的数据。

删除：删除数据，当执行删除时，不需要输入数据。

计算长度系数（见注1）

输入有效计算长度系数。

Ky：绕强轴(单元坐标轴y轴)的有效计算长度系数（默认值=1.0）

Kz：绕弱轴(单元坐标轴 z轴)有效计算长度系数（默认值=1.0）

：应用输入值于选定构件。

：关闭对话框。

使用下列两种方法之一输入数据：

方法1：直接输入Ky和Kz数值。

方法2：点击 [image] 使用K系数输入对话框输入数据，如下图所示。

K系数输入对话框

在K系数输入对话框中选择构件强轴或弱轴有效屈曲长度系数，然后点击 [image] 。

注1：如果没有输入Ky和Kz的值，则取Ky=1.0，Kz = 1.0。

注2：对于钢柱，可以选择由程序自动计算有效计算长度系数。

在计算长度系数对话框中选择?由程序自动计算计算长度系数?选项，可以自动计算有效长度系数。

注3：当执行设计功能时，同时计算有效计算长度系数，计算数值应用于相应的柱构件（单元）。

如果用户通过对话框定义该值，则应用用户定义的数值。

由程序自动计算的有效计算长度系数，在钢构件强度验算结果和钢筋混凝土柱构件设计结果中加注记号显示。

如果自动计算的有效计算长度系数不能代表构件真实计算长度，并且得到异常大的值，那么推荐由用户直接输入恰当的数值。

注4：如果对于同一个构件重复输入有效屈曲计算长度系数，使用下列过程设置适用值：

  1. 用户最后输入的有效屈曲计算长度系数

  2. 由程序自动计算选项得到的有效屈曲计算长度系数

注5：在数据表格中按照单元编号的顺序校核有效屈曲计算长度系数,用户可以修改/增加和删除数据表中的项目。


10_极限长细比

Home > midas Gen 2017 > 11_设计 > 01_一般设计参数 > 11_极限长细比

极限长细比

  • 功能

使用此功能可以设定受压及受拉构件的极限长细比。

注：不定义此项时程序自动按设计规范取用相应的长细比限值。

  • 命令

从主菜单中选择 设计>一般设计参数>极限长细比。

从树形菜单的表格中选择 设计表格>一般设计> 极限长细比。

  • 输入

在模型窗口中选择构件并按如下操作：

选项

选择添加/替换或删除。

添加/替换: 添加新值或替换原先输入的数值。

删除: 删除已经输入的不需要的数值。

极限长细比

输入极限长细比。

受压构件:
轴向受压构件极限长细比 [默认=200] (见注 1)

CF为不同钢号的换算系数。

受拉构件:
轴向受拉构件极限长细比 [默认=300] (见注 1)

不验算
如果不需要计算长细比(KL/r)选择此项，那么设计结果中将不输出长细比。

: 将数值赋给所选择的构件。

: 关闭对话框。

注1：对于在单元坐标轴X方向有轴力（拉力，压力）作用的构件适用此功能，当没有输入极限长细比时，程序默认数值如下：受压构件 = 200；受拉构件 = 300。

注2：当对于同一个构件重复输入极限长细比时，数值将按照最后输入的值更新。

注3：在数据表格中按照单元的序号可以显示构件的极限长细比， 用户可以修改/添加和删除在表格中的项目。


11_等效弯矩系数(Beta_m)

Home > midas Gen 2017 > 11_设计 > 01_一般设计参数 > 12_等效弯矩系数(Cm)

等效弯矩系数(Beta_m)

  • 功 能

等效弯矩系数是在检验弯矩作用在对称轴平面内（外）的实腹式受弯构件稳定性时，所需用到的对弯矩进行?修正?的系数，所以分为平面内等效弯矩系数（Beta_my)和平面外等效弯矩系数(Beta_mz)。这些系数可由程序自动计算，也可由用户输入。

在梁柱构件同时出现轴向力和弯矩时，计算弯曲强度或者组合强度比时需要使用等效弯矩系数,等效弯矩系数是实际弯矩图和等效弯矩图的相关系数。

注：当为混凝土结构时此数显示为弯矩系数（Cm）。

  • 命 令

从主菜单中选择　设计>一般设计参数>等效弯矩系数（Beta_m）...。

从树形菜单的表格中选择　设计表格>一般设计>等效弯矩系数（Beta_m）。

  • 输 入

首先，选择模型中的构件，输入如下：

选项

选择添加/替换或者删除。

添加/替换：增加新数据或者修改以前的数据。

删除：删除数据，当执行删除时，不需要输入数据。

等效弯矩系数

输入等效弯矩系数。

Beta_my：

绕强轴（单元坐标轴y轴）弯曲的（平面内）弯矩系数。（参阅注1）

Beta_mz：

绕弱轴（单元坐标轴z轴）弯曲的（平面外）弯矩系数。（参阅注1）

由程序自动计算

选中该项，由程序自动计算等效弯矩系数。

：将输入的数据应用到选定的构件上。

：关闭对话框。

注1：等效弯矩系数的计算按《钢结构设计规范》GB50017-03第5.2.2条的规定执行。

注2：如果对于同一个构件重复输入弯矩系数（Cm），按照最后输入的数值更新。

注3:在数据表格中按照单元编号可以校核等效弯矩系数，用户可以修改/增加和删除数据表中的项目。


12_设计弯矩放大系数

Home > midas Gen 2017 > 11_设计 > 01_一般设计参数 > 13_设计弯矩放大系数

设计弯矩放大系数

  • 功 能

在承受轴向力和弯矩同时作用的钢构件、细长的钢筋混凝土构件和剪力墙中，输入计算考虑力矩放大影响的抗弯强度所需的力矩放大系数。

  • 命 令

从主菜单中选择　设计 > 一般设计参数 > 设计弯矩放大系数(B1/δb,B2/δs)...。

从树形菜单的表格中选择设计表格>一般设计>设计弯矩放大系数(B1/δb,B2/δs)

  • 输 入

首先，选择模型中的构件，输入如下：

选项

选择增加/替换或者删除。

增加/替换：增加新数据或者修改以前的数据。

删除：删除数据，当执行删除时，不需要输入数据。

弯矩放大系数

输入力矩放大系数。（参阅 注1）

B1y/δby：

有防侧倾支撑的结构中，承受垂直荷载的构件沿强轴方向弯曲的力矩的放大系数。

B1z/δbz：

有防侧倾支撑的结构中，承受垂直荷载的构件沿弱轴方向弯曲的力矩的放大系数。

B2y/δsy：

无防侧倾支撑的结构中，承受水平荷载的构件沿强轴方向弯曲的力矩的放大系数。[默认值 = 1.0]

B2z/δsz：

无防侧倾支撑的结构中，承受水平荷载的构件沿弱轴方向弯曲的力矩的放大系数。[默认值 = 1.0]

：将输入的数据应用到选定的构件上。

：关闭对话框。

注 1

应用AISC-LRFD93或AIK-LSD97规定的力矩放大系数B1和B2。在设计和验算细长钢筋混凝土柱和剪力墙强度时，使用δb 和δs

注 2

如果没有输入B1y/δby和B1z/δbz时，程序自动计算该数值。

注 3

如果没有输入B2y/δsy和B2z/sz时，B2y/δsy=1.0，B2z/sz=1.0。通常，水平荷载的力矩放大系数可以通过P-Delta分析得到，因此，可以进行P-Delta分析来得到更加准确的结果。

注 4

如果对于同一个构件重复输入弯矩系数 B1/δ，系数按照最后输入的数值更新。

注 5

在数据表格中按照单元编号的顺序校核力矩放大系数。用户可以修改/增加核删除数据表中的项目 按如下过程可以进入数据表格。


13_编辑活荷载折减系数

Home > midas Gen 2017 > 11_设计 > 01_一般设计参数 > 14_编辑活荷载折减系数

编辑活荷载折减系数

  • 功 能

当计算轴向强度时，使用此功能来折减作用在柱、剪力墙和基础的活荷载。

  • 命 令

从主菜单中选择　设计>一般设计参数>编辑活荷载折减系数...。

从树型菜单的表格中选择　设计表格>一般设计>编辑活荷载折减系数。

  • 输 入

首先，选择模型中的构件，输入如下：

选项

选择增加/替换或者删除。

增加/替换：增加新数据或者修改以前的数据。

删除：删除数据，当执行删除时，不需要输入数据。

折减系数

输入活荷载折减系数。[默认值=1.0]

：应用输入的数据于选定构件。

：关闭对话框。

注1:参见《建筑结构荷载规范》GB50009-01第4.1.2条规定执行。

注2:如果用户希望自动对柱、剪力墙、基础按照自定义范围应用活荷载折减系数，请使用命令“活荷载折减系数”。

从主菜单中选择 设计>一般设计参数>活荷载折减系数...

从树形菜单的表格中选择 设计表格>一般设计参数>活荷载折减系数

注3：如果对于同一个构件重复输入活荷载折减系数，系数按照最后输入的数值更新。

注4：在数据表格中按照单元编号可以校核活荷载折减系数，用户可以修改/增加和删除数据表中的项目。


14_编辑地震作用放大系数

Home > midas Gen 2017 > 11_设计 > 01_一般设计参数 > 15_地震放大系数

地震作用放大系数

  • 功 能

此功能适用于需要调整地震作用的构件，根据《建筑抗震设计规范》及《高层建筑混凝土结构技术规程》的有关规定，对于结构的薄弱层及剪重比不满足要求楼层的构件需要调整地震作用。

  • 命 令

从主菜单中选择 设计>一般设计参数>地震作用放大系数...。

从树形菜单的表格中选择 设计表格>一般设计>地震作用放大系数。

  • 输 入

首先，在模型窗口中选择构件并按如下操作：

选项

选择添加/替换或删除。

添加/替换: 添加新值或替换原先输入的数值。

删除: 删除已经输入的不需要的数值。

地震作用调整系数

仅用于地震作用荷载工况的内力调整系数

轴力：输入轴力调整系数[默认=1.0]

弯矩：输入弯矩调整系数[默认=1.0]

剪力：输入剪力调整系数[默认=1.0]

输入用于荷载组合中的地震作用内力调整系数

轴力：输入轴力调整系数[默认=1.0]

弯矩：输入弯矩调整系数[默认=1.0]

剪力：输入剪力调整系数[默认=1.0]

：将数值赋给所选择的构件。

: 关闭对话框。


15_抗震等级

Home > midas Gen 2017 > 11_设计 > 01_一般设计参数 > 16_定义抗震等级

抗震等级

  • 功 能

此功能可以对构件分别指定不同的抗震等级。

  • 命 令

从主菜单中选择 设计>一般设计参数>抗震等级...。

从树形菜单的表格中选择 设计表格>一般设计>抗震等级。

  • 输 入

首先，在模型窗口中选择构件并按如下操作：

选项

选择添加/替换或删除。

添加/替换: 添加新值或替换原先输入的数值。

删除: 删除已经输入的不需要的数值。

构件抗震等级

混凝土：输入混凝土构件抗震等级。

钢材：输入钢构件设防烈度。

SRC:　输入SRC构件设防烈度。

: 将数值赋给所选择的构件。

: 关闭对话框。


16_编辑构件类型

Home > midas Gen 2017 > 11_设计 > 01_一般设计参数 > 17_编辑构件类型

编辑构件类型

  • 功 能

在特殊部位及特殊构件需要指定构件设计类型，因为此类构件按规范做设计时区别其它构件的设计规定。

  • 命 令

从主菜单中选择　设计>一般设计参数>编辑构件类型...。

从树型菜单的表格中选择　设计表格>一般设计>编辑构件类型...。

  • 输 入

首先，在模型中选择构件，输入如下：

选项

选择增加/替换或删除。

增加/替换：增加新类型或者修改以前的类型。

删除：删除类型，当执行删除时，不需要输入数据。

构件类型（参阅注 1）

输入设计中使用的构件类型。

梁：框架梁、连梁及框支梁〔默认＝框架梁〕

柱：框架柱、底层柱、角柱、底层角柱及框支柱〔默认＝框架柱〕

支撑：支撑构件

剪力墙：

加强位置：剪力墙底部加强区范围

一般位置：除剪力墙加强区以外的部位

一般建筑：除特殊高层以外的建筑

特殊高层：《高规》中定义的复杂高层建筑结构

：将输入类型应用到选定的构件上。

：关闭对话框。

注1:

若用户没有定义构件类型，那么程序根据对比两个节点之间的坐标定义构件类型。

柱：单元坐标系下的x轴平行于整体坐标系下的Z轴构件，程序默认为柱。

梁：单元坐标系下的x轴平行于整体坐标系下的X-Y平面的构件，程序默认为梁，与框架柱相连的梁默认为框架梁。

支撑：不属于梁、柱、墙构件的其他构件，需要由用户指定。

剪力墙：由于剪力墙设计时，加强位置与一般位置的设计规定不同，所以需要区分。另外由于复杂高层建筑与一般建筑的剪力墙加强位置的设计规定有所不同，所以也需要区分。特殊高层是指《高规》JGJ3-2002中第10.1.1条规定的复杂高层建筑结构。

注2：模型中的斜向构件建议由用户指定构件设计类型。

注3：如果对于同一个构件重复输入构件类型，类型按照最后输入的类型更新。

注3：在数据表格中可以按照单元编号的顺序校核构件类型，用户可以修改/增加和删除数据表中的项目。


18_地震荷载组合类型

Home > midas Gen 2017 > 11_设计 > 01_一般设计参数 > 18_地震荷载组合类型

地震荷载组合类型

该功能目前不支持中国规范。


01_设计标准

Home > midas Gen 2017 > 11_设计 > 02_设计 > 01_钢构件设计 > 01_设计规范

设计标准

  • 功 能

使用此项功能选择设计规范，用于钢结构构件强度验算；并确定结构水平构件（梁和桁架）的侧向支撑条件。

  • 命 令

从主菜单中选择 设计>钢构件设计参数>设计标准... 。

  • 输 入

如下对话框用于数据输入：

设计规范对话框

设计标准

钢结构设计规范[默认=GB50017-03]

注：如果用户没有输入设计规范，程序默认应用《钢结构设计规范》GB50017-03。

如下钢结构设计规范可供选择：

- 容许钢结构设计，韩国建筑学会（AIK-ASD83）

- 荷载和抗力系数设计，美国钢结构学会（AISC-LRFD93）

- 冷轧型钢钢结构设计，美国钢铁学会（AISI-CFSD86）

- 钢结构设计，欧洲规范3 ENV 1993-1-1 （Eurocode3）

- 建筑中结构使用钢铁架，英国标准（BS5950-90）

- 容许应力设计，美国钢结构学会（AISC-ASD89）

- 极限状态设计，韩国建筑学会（AIK-LSD97）

                - 容许应力设计，韩国土木工程师协会（KSCE-ASD96）

所有梁都不考虑横向屈曲

勾选此项将不对梁（或桁架）做整体稳定性计算。

注：如果满足《钢结构设计规范》GB50017-03中第4.2.1条时，可以勾选此项不做梁的整体稳定性验算。如果选择此项，在?自由长度（L，Lb）?对话框中?受压翼缘的支撑点间距?无效，且Lb = 0适用于所有构件。

考虑抗震

输入抗震设防烈度。

：输入选项，关闭对话框。

：不输入数据或者选项，关闭对话框。


02_材料分项系数

Home > midas Gen 2017 > 11_设计 > 02_设计 > 01_钢构件设计 > 02_材料分项系数

材料分项系数

  • 功 能

使用材料分项系数可以由材料的屈服强度转换为设计强度。

  • 命 令

从主菜单中选择 设计>钢筋混凝土构件设计参数>材料分项系数... 。

  • 输 入

下列对话框用于数据输入：

材料分项系数对话框

当前设计标准

之前定义的钢结构设计规范

材料分项系数

输入各种材料的分项系数。

：输入选项，关闭对话框。

：不输入数据或者选项，关闭对话框。


03_编辑钢材

Home > midas Gen 2017 > 11_设计 > 02_设计 > 01_钢构件设计 > 03_编辑钢材

编辑钢材

  • 功 能

使用此项功能可以修改在建立分析模型时输入的部分钢结构材料特性数据，或者根据特殊设计要求，改变材料特性数据。即在做构件强度验算时可以采用新的材料，不用修改模型重新分析。

  • 命 令

从主菜单中选择 设计>钢构件设计参数>编辑钢材... 。

  • 输 入

用如下对话框输入数据（参阅 注1）：

编辑钢结构材料对话框

材料列表

显示建立分析模型时输入的钢结构材料特性，用鼠标选择要修改的材料。

选择钢材

显示选择的设计标准及材料的强度等级，以便可以修改材料特性数据。

使用程序提供的材料特性数据库或者直接输入修改后的数据。

使用材料特性数据库方法

用鼠标选择材料名称和相应的设计规范。

用户直接输入

在规范区选择?None?，在名称区输入材料名称。执行此项操作后，将激活所有 材料特性数据区数据以便输入。（参阅注2）。

弹性模量（Es）：钢材弹性模量

泊松比（Ps）：钢材泊松比

抗拉强度（Fu）：钢材极限抗拉强度

屈服强度（Fy1～4）：钢材不同厚度的屈服强度

：按用户输入的数值修改相应的材料特性。

：不输入数据或者进行选择，直接关闭对话框。

注1：

钢结构材料标准分为： None,　ASTM(S)，CSA(S),BS(S),DIN(S),EN(S),JIS(S),GB(S),JGJ(S),KS(S),KS-Civil(S)。

注2：

不同国家标准钢材屈服强度参考值：

        (1) 中国GB(S)
            - Es = 206000 N/mm2
            - Fy (N/mm2)

牌号 | Fy1 | Fy2 | Fy3 | Fy4
Q235 | 235 | 225 | 215 | 205
Q345 | 345 | 325 | 295 | 275
Q390 | 390 | 370 | 350 | 330
Q420 | 420 | 400 | 380 | 360

- 钢材屈服强度按钢材厚度分类如下：（mm）

牌号 | Fy1 | Fy2 | Fy3 | Fy4
Q235 | < 16 | 16～40 | 40～60 | 60～100
Q345 | < 16 | 16～35 | 35～50 | 50～100
Q390 | < 16 | 16～35 | 35～50 | 50～100
Q420 | < 16 | 16～35 | 35～50 | 50～100

(2)中国JGJ(S)
- Es = 206000 N/mm2
- Fy (N/mm2)

牌号 | Fy1 | Fy2 | Fy3 | Fy4
Q235 | 235. | 225. | 215. | 205.
Q345 | 345. | 325. | 295. | 275.

- 钢材屈服强度按钢材厚度分类如下：（mm）

牌号 | Fy1 | Fy2 | Fy3 | Fy4
Q235 | 16 | 16～40 | 40～60 | 60～100
Q345 | 16 | 16～35 | 35～50 | 50～100

          (3) ASTM(S)
              - Es = 29000 kips/in2
             - Fy (kips/in2)

Material type | Fy-a
A36 | 36.
A53 | 35.
A242-40 | 40.
A242-42 | 42.
A242-46 | 46.
A242-50 | 50.
A441-40 | 40.
A441-42 | 42.
A441-46 | 46.
A441-50 | 50.
A500-33 | 33.
A500-39 | 39.
A500-42 | 42.
A500-46 | 46.
A500-50 | 50.
A501 | 36.
A514-90 | 90.
A514-100 | 100.
A529-42 | 42.
A529-50 | 50.
A570-40 | 40.
A570-42 | 42.
A572-42 | 42.
A572-50 | 50.
A572-60 | 60.
A572-65 | 65.
A588-40 | 40.
A588-42 | 42.
A588-46 | 46.
A588-50 | 50.
A606-45 | 45.
A606-50 | 50.
A607-45 | 45.
A607-50 | 50.
A607-55 | 55.
A607-60 | 60.
A607-65 | 65.
A607-70 | 70.
A618-50 | 50.
A852 | 70.

(4) CSA(S)
- Es = 200000 N/mm2
- Fy (N/mm2)

Material type | Fy-1 | Fy-2 | Fy-3
230G(H) | 230. | 230. | 230.
350G(H) | 350. | 350. | 350.
400G(H) | 400. | 400. | 400.
260W(H) | 260. | 260. | 260.
300W(H) | 300. | 290. | 280.
350W(H) | 350. | 330. | 320.
380W(H) | 380. | 380. | 380.
400W(H) | 400. | 400. | 400.
480W(H) | 480. | 480. | 480.
260WT(H) | 260. | 260. | 260.
300WT(H) | 300. | 290. | 290.
350WT(H) | 350. | 330. | 330.
380WT(H) | 380. | 380. | 380.
400WT(H) | 400. | 400. | 400.
480WT(H) | 480. | 480. | 480.
350R(H) | 350. | 350. | 350.
350A(H) | 350. | 350. | 350.
400A(H) | 400. | 400. | 400.
480A(H) | 480. | 480. | 480.
350AT(H) | 350. | 350. | 350.
400AT(H) | 400. | 400. | 400.
480AT(H) | 480. | 480. | 480.
700Q(H) | 700. | 700. | 700.
700QT(H) | 700. | 700. | 700.
230G(C) | 230. | 230. | 230.
350G(C) | 350. | 350. | 350.
400G(C) | 400. | 400. | 400.
260W(C) | 260. | 260. | 260.
300W(C) | 300. | 290. | 280.
350W(C) | 350. | 330. | 320.
380W(C) | 380. | 380. | 380.
400W(C) | 400. | 400. | 400.
480W(C) | 480. | 480. | 480.
260WT(C) | 260. | 260. | 260.
300WT(C) | 300. | 290. | 290.
350WT(C) | 350. | 330. | 330.
380WT(C) | 380. | 380. | 380.
400WT(C) | 400. | 400. | 400.
480WT(C) | 480. | 480. | 480.
350R(C) | 350. | 350. | 350.
350A(C) | 350. | 350. | 350.
400A(C) | 400. | 400. | 400.
480A(C) | 480. | 480. | 480.
350AT(C) | 350. | 350. | 350.
400AT(C) | 400. | 400. | 400.
480AT(C) | 480. | 480. | 480.
700Q(C) | 700. | 700. | 700.
700QT(C) | 700. | 700. | 700.

- Max. thickness for applying Fy (mm)

Hollow Structural Sections

Material type | Fy-1 | Fy-2 | Fy-3
300W | 16.0 |  |
350W, 350WT | 16.0 |  |
380W, 380WT | 16.0 |  |
350A, 350AT | 16.0 |  |

Plates, Bars and Welded Shapes

Material type | Fy-1 | Fy-2 | Fy-3
350R | 14.0 |  |
400W, 400WT | 20.0 |  |
480W, 480WT | 20.0 |  |
480A, 480AT | 20.0 |  |
350G, 400G | 30.0 |  |
400A, 400AT | 40.0 |  |
700Q, 700QT | 50.0 |  |
350WT | 40.0 | 60.0 | 100.0
260W, 260WT | 40.0 | 65.0 | 100.0
300W, 300WT | 40.0 | 65.0 | 100.0
350W, 350WT | 40.0 | 65.0 | 100.0
350A, 350AT | 40.0 | 65.0 | 100.0
230G | 40.0 | 65.0 | 300.0

Rolled Shapes and Sheet Piling (G=Group)

Material type | Fy-1 | Fy-2 | Fy-3
350R | G1 |  |
400W | G1 |  |
480W, 480WT | G1 |  |
400WT | G1,2 |  |
400A, 400AT | G1,2 |  |
300W | G1,2 | G3 |
350G, 400G | G1,2 | G3 |
350WT | G1,2 | G3,4 |
260W | G1,2 | G3,4 |
230G | G1,2 | G3,4 | G5
260WT, 300WT | G1,2 | G3,4 | G5
350A, 350AT | G1,2 | G3,4 | G5

(5) BS(S)
- Es = 205000 N/mm2
- Fy (N/mm2)

Material type | Fy-a | Fy-b | Fy-c | Fy-d
43A | 275. | 265. | 255. | 245.
43B | 275. | 265. | 255. | 245.
43B(T) | 275. | 265. | 255. | 245.
43C | 275. | 265. | 255. | 245.
43D | 275. | 265. | 255. | 245.
43DD | 275. | 265. | 255. | 245.
43E | 275. | 265. | 255. | 245.
43EE | 275. | 265. | 255. | 245.
50A | 355. | 345. | 340. | 325.
50B | 355. | 345. | 340. | 325.
50B(T) | 355. | 345. | 340. | 325.
50C | 355. | 345. | 340. | 325.
50D | 355. | 345. | 340. | 325.
50DD | 355. | 345. | 340. | 325.
50E | 355. | 345. | 340. | 325.
50EE | 355. | 345. | 340. | 325.
50F | 355. | 345. | 340. | 325.
55C | 450. | 430. | 415. | 400.
55EE | 450. | 430. | 415. | 400.
55F | 450. | 430. | 415. | 400.
WR50A | 355. | 355. | 355. | 355.
WR50B | 355. | 355. | 355. | 355.
WR50C | 355. | 355. | 355. | 355.

- Max. thickness for applying Fy (mm)

Material type | Fy-a | Fy-b | Fy-c | Fy-d
43,50 Series | 16.0 | 40.0 | 63.0 | 100.0
55 Series | 16.0 | 25.0 | 40.0 | 63.0

(6) DIN(S)
- Es = 210000 N/mm2
- Fy (N/mm2)

Material type | Fy-a | Fy-b
St37-2 | 240. | 215.
USt37-2 | 240. | 215.
RSt37-2 | 240. | 215.
St52-3 | 360. | 325.
StE355 | 360. | 325.
WStE355 | 360. | 325.
TStE355 | 360. | 325.
EStE355 | 360. | 325.
GS-52 | 260. | 260.
GS-20Mn5 | 260. | 260.
C35N | 300. | 270.

- Max. thickness for applying Fy (mm)

Material type | Fy-a | Fy-b
GS Series | 100.0 | -
C35N | 16.0 | 80.0
Others | 40.0 | 80.0

(7) EN(S)
- Es = 210000 N/mm2
- Fy (N/mm2)

Material type | Fy-a | Fy-b
S235 | 235. | 215.
S275 | 275. | 255.
S355 | 355. | 335.
S420 | 420. | 390.
S460 | 460. | 430.
Fe360 | 235. | 215.
Fe430 | 275. | 255.
Fe510 | 355. | 335.
FeE275 | 275. | 255.
FeE355 | 355. | 355.
S420M | 420. | 390.
S460M | 460. | 430.

- Max. thickness for applying Fy (mm)

Material type | Fy-a | Fy-b
All other Series | 40.0 | 100.0

(8) JIS(S)
- Es = 205000 N/mm2
- Fy (N/mm2)

Material type | Fy-a | Fy-b
SN400A | 235. | 215.
SN400B | 235. | 215.
SN400C | 235. | 215.
SN490B | 325. | 295.
SN490C | 325. | 295.
SS400 | 235. | 215.
STK400 | 235. | 215.
STKR400 | 235. | 215.
SSC400 | 235. | 215.
SS490 | 275. | 255.
SS540 | 370. | 370.
SM400 | 235. | 215.
SMA400 | 235. | 215.
SM490 | 325. | 295.
SM490Y | 325. | 295.
SMA490 | 325. | 295.
STK490 | 325. | 295.
STKR490 | 325. | 295.
SM520 | 355. | 355.
SCW410-CF | 235. | 235.
SCW480-CF | 275. | 275.
SCW490-CF | 315. | 315.
SCW520-CF | 355. | 355.

- Max. thickness for applying Fy (mm)

Material type | Fy-a | Fy-b
All other Series | 40.0 | 100.0

(9)JTJ(S)
- Es = 210000 N/mm2
- Fy (N/mm2)

Material type | Fy1 | Fy2 | Fy3 | Fy4
A3 | 240. | 240. | 240. | 240.
16Mn | 345. | 325. | 315. | 295.

- Max. thickness for applying Fy (mm)

Material type | Fy-1 | Fy-2 | Fy-3 | Fy-4
16Mn | 16.0 | 25.0 | 36.0 | 50.0

(10) KS(S)
- Es = 2100 tonf/cm2
- Fy (tonf/cm2)

Material type | Fy-a | Fy-b
SS41 | 2.4 | 2.2
SPS41 | 2.4 | 2.2
SPSR41 | 2.4 | 2.2
SS50 | 2.8 | 2.6
SS55 | 3.8 | 3.8
SS400 | 2.4 | 2.2.
SPS400 | 2.4 | 2.2
SPSR400 | 2.4 | 2.2
SS490 | 2.8 | 2.6
SS540 | 3.8 | 3.8
SWS41 | 2.4 | 2.2
SWS50 | 3.3 | 3.0
SWS50Y | 3.3 | 3.0
SPS50 | 3.3 | 3.0
SPSR50 | 3.3 | 3.0
SWS53 | 3.6 | 3.4
SWS58 | 4.1 | 4.1
SWS400 | 2.4 | 2.2
SWS490 | 3.3 | 3.0
SWS490Y | 3.3 | 3.0
SWS490TMC | 3.3 | 3.3
SWS520 | 3.6 | 3.4
SWS520TMC | 3.6 | 3.6
SWS570 | 4.1 | 4.1
SWS520(LSD) | 3.6 | 3.3
SWS570(LSD) | 4.3 | 4.3
SM400 | 2.4 | 2.2
SM490Y | 3.3 | 3.0
SMA490 | 3.3 | 3.0
SCW490-CF | 3.3 | 3.0
SPS490 | 3.3 | 3.0
SPSR490 | 3.3 | 3.3
SM490TMC | 3.3 | 3.3
SM520 | 3.6 | 3.4
SM520TMC | 3.6 | 3.6
SM570 | 4.1 | 4.1
SM520(LSD) | 3.6 | 3.3
SM570(LSD) | 4.3 | 4.3
SMA41 | 2.4 | 2.2
SMA50 | 3.3 | 3.0
SMA58 | 4.1 | 4.1
SSC400 | 2.4 | 2.4
ZSS400 | 3.0 | 3.0

- Max. thickness for applying Fy (mm)

Material type | Fy-a | Fy-b
490-CF | 8.0 | 60.0
490TMC | 40.0 | 80.0
Others | 40.0 | 100.0

(11) KS-Civil(S)
- Es = 2100 tonf/cm2
- Fy (tonf/cm2)

Material type | Fy-a | Fy-b | Fy-c
SS41 | 2.4 | 2.2 | 2.2
SPS41 | 2.4 | 2.2 | 2.2
SPS50 | 3.2 | 3.0 | 3.0
SS400 | 2.4 | 2.2 | 2.2
SPS400 | 2.4 | 2.2 | 2.2
SPS490 | 3.2 | 3.0 | 3.0
SWS41 | 2.5 | 2.4 | 2.2
SWS50 | 3.3 | 3.2 | 3.0
SWS50Y | 3.7 | 3.6 | 3.4
SWS53 | 3.7 | 3.6 | 3.4
SWS58 | 4.7 | 4.6 | 4.4
SWS400 | 2.5 | 2.4 | 2.2
SWS490 | 3.3 | 3.2 | 3.0
SWS490Y | 3.7 | 3.6 | 3.4
SWS520 | 3.7 | 3.6 | 3.4
SWS570 | 4.7 | 4.6 | 4.4
SM400 | 2.4 | 2.2 | 2.2
SM490 | 3.2 | 3.0 | 3.0
SM490Y | 3.6 | 3.4 | 3.3
SM520 | 3.6 | 3.4 | 3.3
SM570 | 4.6 | 4.4 | 4.3
SMA41 | 2.4 | 2.2 | 2.2
SMA50 | 3.6 | 3.4 | 3.3
SMA58 | 4.6 | 4.4 | 4.3
SMA400 | 2.4 | 2.2 | 2.2
SMA490 | 3.6 | 3.4 | 3.3
SMA570 | 4.6 | 4.4 | 4.3

- Max. thickness for applying Fy (mm)

Material type | Fy-a | Fy-b | Fy-c
SS, SM | 40.0 | 75.0 | 100.0
Others | 16.0 | 40.0 | 40.0


04_正常使用极限状态参数

Home > midas Gen 2017 > 11_设计 > 02_设计 > 01_钢构件设计 > 04_正常使用极限状态参数

正常使用极限状态参数

  • 功 能

此项功能暂不支持中国规范。


04_编辑梁的等效弯矩系数(Beta_b)

Home > midas Gen 2017 > 11_设计 > 02_设计 > 01_钢构件设计 > 05_等效弯矩系数(Cb)

编辑梁的等效弯矩系数(Beta_b)

  • 功 能

在计算梁的整体稳定系数时需要用到这个系数，此系数的定义方法可参见《钢规》GB50017-03附录B的内容。

  • 命 令

从主菜单中选择 设计>钢构件设计参数>编辑梁的等效弯矩系数（Beta_b）... 。

从树形菜单中表格选择 设计表格>钢构件设计参数>编辑梁的等效弯矩系数（Beta_b）。

  • 输 入

首先，选择模型中的构件，输入如下：

选项

选择增加/替换或者删除。

增加/替换：增加新数据或者修改以前的数据。

删除：删除数据，当执行删除时，不需要输入数据。

编辑梁的等效弯矩系数

Beta_b：由用户输入梁的等效弯矩系数　[默认值=1.0]

由程序计算：选择此项，由程序自动按《钢规GB50017-03附录B的方法计算。一般用户应该选择由程序自动计算。

：将输入的数据应用到选定的构件上。

：关闭对话框。

注1：
如果对于同一个构件重复输入该系数（Beta_b），系数按照最后一次输入的数值进行更新。

注２：
在数据表格中按照单元编号的顺序查看等效弯矩系数（Beta_b），用户可以修改，增加和删除数据表中的项目。

可通过如下途径进入数据表格。

主菜单：设计->钢构件设计参数->钢构件设计表格->编辑梁的等效弯矩系数（Beta_b）

工作目录树表格分页：设计表格->钢构件设计->编辑梁的等效弯矩系数（Beta_b）


05_容许剪切应力折减系数(Cv)

Home > midas Gen 2017 > 11_设计 > 02_设计 > 01_钢构件设计 > 06_剪切系数(Cv)

容许剪切应力折减系数(Cv)

  • 功 能

使用此项功能输入剪切应力折减系数（Cv），用来计算I型和C型截面主轴方向（z方向）的设计剪切强度或容许剪应力。

  • 命 令

从主菜单中选择 设计 > 钢构件设计参数 > 容许剪切应力折减系数（Cv）... 。

从树形菜单的表格中选择 设计表格> 钢构件设计参数 > 容许剪切应力折减系数（Cv）。

  • 输 入

首先，选择模型中的构件，输入如下：

选项

选择增加/替换或者删除。

增加/替换：增加新数据或者修改以前的数据。

删除：删除数据，当执行删除时，不需要输入数据。

剪切应力折减系数

输入剪切系数。

Cv：剪切系数

程序计算:选择此项，由程序自动计算。

：将输入的数据应用到选定的构件上。

：关闭对话框。

注1：
如果对于同一个构件重复输入剪切系数(Cv)，系数按照最后输入的数值更新。

注2：
在数据表格中按照单元编号的顺序校核剪切系数(Cv)。用户可以修改/增加核删除数据表中的项目。


06_定义容许应力

Home > midas Gen 2017 > 11_设计 > 02_设计 > 01_钢构件设计 > 07_定义容许应力

定义容许应力

  • 功 能

使用此项功能输入容许应力系数。通常，对钢结构构件进行强度校核时，与使用设计规范提供的计算数值相比，用户更希望确定容许应力。输入的系数是容许应力与钢结构材料屈服强度(Fy)的比值。

  • 命 令

从主菜单中选择 设计 > 钢构件设计参数 > 定义容许应力...。

从树菜单的表格中选择 设计表格> 钢构件设计> 定义容许应力。

  • 输 入

首先，选择模型中的构件，输入如下：

选项

选择增加/替换或者删除。

增加/取代：增加新数据或者修改以前的数据。

删除：删除数据，当执行删除时，不需要输入数据。

设定容许应力

输入容许应力系数 (参阅注1)。

压力(Fa) ：构件轴向受压的容许压应力系数 (参阅 注2)。

张力(Ft) ：构件轴向受拉的容许拉应力系数 (参阅 注3)。

强轴弯矩(Fby) ：绕构件强轴弯矩的的容许弯曲应力系数 (参阅 注4)。

弱轴弯矩(Fby) ：绕构件弱轴弯矩的的容许弯曲应力系数 (参阅 注4)。

剪力(Fv) ：剪力的容许剪应力系数 (参阅 注5）。

：将输入的数据应用到选定的构件上。

：关闭对话框。

注1：
仅适用于AISC-ASD89 和 AIK-ASD83设计规范。不适用于钢-钢筋混凝土组合柱构件的强度校核。

注2:
Fa 代表构件轴向压力的容许压应力。

注3:
Ft 代表构件轴向拉力的容许拉应力。

注4:
Fby 和 Fbz代表绕构件强轴、弱轴弯矩的容许弯曲应力。不考虑弯曲方向，同样的数值应用于所有受拉受压纤维。

注5:
Fv 代表沿强轴、弱轴方向的容许剪应力，主轴、弱轴数值相同。

注6:
如果对于同一个构件重复输入容许应力系数，系数按照最后输入的数值更新。

注7:
在数据表格中按照单元编号的顺序校核容许应力系数。用户可以修改/增加核删除数据表中的项目。


08_按构件指定抗震体系

Home > midas Gen 2017 > 11_设计 > 02_设计 > 01_钢构件设计 > 08_按构件指定抗震体系

按构件指定抗震体系

  • 功 能

此项功能暂不支持中国规范。


07_箱形截面纵向加劲肋

Home > midas Gen 2017 > 11_设计 > 02_设计 > 01_钢构件设计 > 09_箱形截面纵向加劲肋

箱形截面纵向加劲肋

  • 功 能

使用此项功能输入箱形截面横向/纵向加劲肋的间距和尺寸。（参阅 注 1）

  • 命 令

从主菜单中选择 设计 > 钢构件设计参数 > 箱形截面纵向加劲肋... 。

从树形菜单的表格中选择 设计表格> 钢构件设计> 箱形截面纵向加劲肋。

  • 输 入

首先，选择模型中的构件，输入如下：

选项

选择添加/替换或者删除。

添加/替换：增加新数据或者修改以前的数据。

删除：删除数据，当执行删除时，不需要输入数据。

截面号

强度已校核的箱形构件截面特性编号。

：使用这个按钮修改构件的截面形状和尺寸。在设计对话框中显示截面，详细参阅?截面设计...?。

箱形截面

显示箱形构件截面数据。

H：钢结构截面高度。

B：钢结构截面宽度。

tw：腹板厚度。

tf1：第一翼缘厚度。

Cw：组合腹板板中心距离（B-tw）。

tf2：第二翼缘厚度。

纵向加劲肋

输入纵向加劲肋数据。

宽度(Bstf)：加劲肋宽度

厚度(Tstf)：加劲肋厚度

横向加劲肋

输入横向加劲肋数据。

间距(Astf)：横向加劲肋间距

箱形截面

由纵向加劲肋分隔的板块数目。

翼缘处(Noy)：在翼缘处由纵向加劲肋分隔的板块数目。

腹板处(Noz)：在腹板处由纵向加劲肋分隔的板块数目

：将输入的数据应用到选定的构件上。

：关闭对话框。

注 1
仅在设计规范是KSCE-ASD96（韩国土木工程师协会公路桥梁-钢桥规范的容许应力设计）时适用。

注 2
如果对于同一个构件重复输入纵向/横向加劲肋，系数按照最后输入的数值更新。

注 3
在数据表格中按照截面属性编号的顺序校核纵向加劲肋。用户可以修改/增加核删除数据表中的项目。


01_定义抗震等级

Home > midas Gen 2017 > 11_设计 > 02_设计 > 02_RC设计 > 01_设计规范

定义抗震等级

  • 功 能

使用此项功能可以选择设计规范；定义构件的抗震等级；定义建筑物的安全等级；框架柱的计算长度及梁端负弯矩调幅系数。

  • 命 令

从主菜单中选择 设计>钢筋混凝土构件设计参数>定义抗震等级... 。

  • 输 入

下列对话框用于数据输入：

混凝土设计规范对话框

设计标准

选择钢筋混凝土设计规范

使用抗震设计的特别规定

使用抗震设计的特别规定对话框

用于定义构件的抗震等级。

板类型

定义框架柱的计算长度，参见《混规》GB50010-2010中第6.2.20条。

扭矩设计

如勾选，则按照《混规》（GB50010-2010）6.4节进行钢筋混凝土梁抗扭设计。

梁扭矩折减系数：

梁的计算扭矩可通过该折减系数进行折减。扭矩折减系数可根据周围楼盖情况确定。

梁端负弯矩调幅系数

输入考虑在竖向荷载作用下，梁端负弯矩的调幅系数。

：输入选项，关闭对话框。

：不输入数据或者选项，关闭对话框。


02_材料分项系数

Home > midas Gen 2017 > 11_设计 > 02_设计 > 02_RC设计 > 02_材料分项系数

扭矩折减系数

  • 功 能

定义钢筋混凝土梁抗扭设计时的扭矩折减系数。

  • 命 令

从主菜单中选择 设计>钢筋混凝土构件设计参数>扭矩折减系数... 。

  • 输 入

下列对话框用于数据输入：

扭矩折减系数对话框

选项

添加/替换：对所选钢筋混凝土梁构件定义扭矩折减系数；

删除：删除所选钢筋混凝土梁构件构件已经定义的扭矩折减系数。


03_编辑钢筋混凝土材料特性

Home > midas Gen 2017 > 11_设计 > 02_设计 > 02_RC设计 > 03_编辑混凝土材料

编辑钢筋混凝土材料特性

  • 功 能

应用此项功能可以定义设计用钢筋强度级别，还可以修改建立分析模型时输入的部分钢筋和混凝土材料的特性数据。

  • 命 令

从主菜单中选择 设计>钢筋混凝土构件设计参数>编辑钢筋混凝土材料特性...。

  • 输 入

下列对话框用于数据输入：

定义设计用钢筋级别对话框

材料列表

显示建立分析模型时输入的混凝土材料特性，选择要修改的材料。

混凝土材料

显示选择的材料特性，修改/改变材料特性数据。

可以使用程序中内置的材料特性数据库或者直接输入改变的数据。

使用程序中内置的材料属性数据库：

用鼠标选择相应规范和材料名称。

如果需要，用户可以改变钢筋标准和混凝土标准,也就是说钢筋和混凝土标准不必相同。

用户直接输入数据：

在规范区选择?None?，在名称区输入材料名称，然后激活数据区填写材料特性。

抗压强度(fc/fck)：混凝土抗压强度标准植。

钢筋

规范：选择钢筋标准

主筋：纵向受力主筋强度等级

箍筋：横向箍筋强度等级（包括拉筋）

Fy：主筋屈服强度

Fys：箍筋屈服强度

：按用户定义修改材料特性。

：不输入数据或者选项，关闭对话框。

注1：在规范中指定?None?时，程序使用用户定义的材料特性进行设计。


04_编辑最大配筋率

Home > midas Gen 2017 > 11_设计 > 02_设计 > 02_RC设计 > 04_编辑最大配筋率

编辑最大配筋率

  • 功 能

输入钢筋混凝土构件最大容许配筋率。

  • 命 令

从主菜单中选择 设计>混凝土构件设计参数>编辑最大配筋率... 。

  • 输 入

使用如下对话框输入数据：

最大配筋率对话框

当前设计标准

显示选定的设计规范。

最大配筋率

根据钢筋混凝土构件类型输入最大配筋率。

剪力墙设计(Rhow)：剪力墙构件最大配筋率 [默认=0.04](参阅 注1)

柱设计(Rhoc)：柱构件最大配筋率 [默认=0.03](参阅 注2)

支撑设计(Rhor)：支撑构件最大配筋率 [默认=0.03](参阅 注3)

：输入数值或选项，关闭对话框。

：不输入数值或选项，关闭对话框。

注1：钢筋混凝土剪力墙、框架柱的最大配筋率可以参见相应的设计规范规定。

注2：设定钢筋混凝土支撑构件轴向的主筋配筋率可以参见钢筋混凝土柱构件。


05_定义设计用钢筋直径

Home > midas Gen 2017 > 11_设计 > 02_设计 > 02_RC设计 > 05_定义设计用钢筋直径

定义设计用钢筋直径

  • 功 能

设计梁、柱和支撑构件时，输入主筋、箍筋的标准规格及混凝土的保护层厚度，另外在设计剪力墙构件时，输入水平和竖向钢筋的标准规格及间距。

程序对于梁可以根据用户定义的钢筋直径进行实际配筋；对于柱程序可以根据用户定义的钢筋直径自动布筋，然后进行双偏压验算，直至满足设计要求，程序最后输出的配筋面积是实配的结果；对于剪力墙目前版本没有考虑边缘构件的设计要求。

  • 命 令

  从主菜单中选择 设计>混凝土构件设计参数>定义设计用钢筋直径...。

  • 输 入

如下对话框用于数据输入：

钢筋设计标准对话框

用于梁设计

设计梁构件时，输入主筋和箍筋的标准规格以及混凝土的保护层厚度。

主筋：设计用主筋标准规格

点击 [image] 显示钢筋规格对话框，用鼠标选择输入主筋标准规格。

最多可以输入5种钢筋规格。

钢筋规格对话框

：应用选项，关闭对话框。

：不应用选项，关闭对话框。

箍筋：设计用箍筋的标准规格

腹筋：设计用腹筋的标准规格，属于构造钢筋，不影响梁的强度。

dT：截面上部上排主筋中心到截面边缘的距离（保护层厚度）

dB：截面下部下排主筋中心到截面边缘的距离（保护层厚度）

用于柱设计

设计柱构件时，输入主筋和箍筋的标准规格以及混凝土的保护层厚度。

主筋：设计用主筋的标准规格。

箍筋：设计用箍筋的标准规格。

do：主筋中心到截面边缘的距离（保护层厚度）

用于支撑设计

设计支撑构件时，输入主筋和箍筋的标准规格。

主筋：设计用主筋的标准规格。

箍筋：设计用箍筋的标准规格

do：主筋中心到截面边缘的距离（保护层厚度）

用于剪力墙设计

设计剪力墙构件时，输入竖向钢筋和水平钢筋的标准规格以及竖向钢筋的保护层厚度。

竖筋：设计用竖向钢筋的标准规格

横筋：设计用水平向钢筋的标准规格

端部加强筋：设计用端部加强钢筋的最小标准规格

de：第一排竖向钢筋（或端部钢筋）中心到剪力墙端部的距离（保护层厚度）

dw：端部竖向钢筋中心到剪力墙边缘的距离（保护层厚度），用于剪力墙的平面外抗弯设计。

点击 [image] 显示如下对话框。

输入墙附加数据对话框

平面外抗弯设计

是否考虑剪力墙平面外受弯设计，即进行剪力墙弱轴方向的抗弯设计，特别对于受面外水平荷载作用的剪力墙，如地下室外墙（受侧土及水压力作用）等，需要考虑平面外受弯设计。

墙钢筋间距

设计剪力墙时，输入水平及竖向钢筋配筋间距。

竖向钢筋间距：输入剪力墙竖向钢筋可供选择的配筋间距

水平钢筋间距：输入剪力墙最小水平向配筋间距

端部钢筋设计方法

选择考虑端部加强钢筋的设计方法。

方法1：沿墙长等间距放置竖向钢筋（没有端部加强钢筋）

方法2：假定先沿墙长等间距放置竖向钢筋，然后再确定端部附加钢筋数量，把这些附加钢筋放置在端部和中间部分。

方法3：假定墙体两端的竖向钢筋承担所有的轴向力(Pu)和弯矩(Mu)，剩余部位配置的钢筋用来抵抗剪力。

方法4：同方法2，但把附加钢筋放置在剪力墙的两端。

端部钢筋间距

Dist1：4根端部钢筋时的间距

Dist2：6根端部钢筋时的间距

Dist3：大于等于8根端部钢筋时的间距

注1：如果没有输入支撑构件的主筋和箍筋标准规格，则使用的标准规格同柱构件。

注2：剪力墙设计时如果没有输入dw值(de=0情况)，自动使用2英寸（5.08cm）。


06_各构件类型钢筋设置

Home > midas Gen 2017 > 11_设计 > 02_设计 > 02_RC设计 > 06_按构件定义配筋

各构件类型钢筋设置

  • 功 能

用户可以通过该功能对不同的构件类型（梁，柱，墙，支撑）进行不同的钢筋设置。

  • 命 令

  从主菜单中选择 设计>混凝土构件设计参数>各构件类型钢筋设置...。

  • 输 入

如下对话框用于数据输入：

各构件类型钢筋设置对话框

选项

添加/替换：为所选构件添加或替换钢筋设置；

删除：删除所选构件的钢筋设置；

主筋：设计用主筋标准规格

箍筋：设计用箍筋的标准规格

数量：箍筋肢数

腰筋：设计用腰筋的标准规格，属于构造钢筋，不影响梁的强度。

dT：截面上部上排主筋中心到截面边缘的距离（保护层厚度）

dB：截面下部下排主筋中心到截面边缘的距离（保护层厚度）

考虑最大间距

如果勾选该项，则应用规范规定的间距要求。

搭接钢筋：选择钢筋混凝土设计时候的钢筋搭接选项

无：不考虑钢筋搭接；

50%：纵向钢筋搭接接头面积百分率为50%；

100%：纵向钢筋搭接接头面积百分率为100%。


07_编辑梁端负弯矩调幅系数

Home > midas Gen 2017 > 11_设计 > 02_设计 > 02_RC设计 > 07_梁端负弯矩调幅系数

编辑梁端负弯矩调幅系数

  • 功 能

在竖向荷载作用下，可考虑框架梁端塑性变形内力重分布对梁端负弯矩乘以调幅系数进行调幅。使用此功能可以对模型中选择的构件输入梁端负弯矩调幅系数。

  • 命 令

从主菜单中选择 设计>钢筋混凝土构件设计参数>编辑梁端负弯矩调幅系数... 。

  • 输 入

首先，选择模型中的构件，输入如下：

选项

选择增加/替换或者删除。

添加/替换：增加新数据或者修改以前的数据。

删除：删除数据，当执行删除时，不需要输入数据。

梁端负弯矩调幅系数

输入梁端负弯矩调幅系数。

：将输入的数据应用到选定的构件上。

：关闭对话框。

注1：如果对于同一个构件重复输入梁端负弯矩调幅系数，系数按照最后输入的数值更新。

注2：在数据表格中按照单元编号的顺序校核梁端负弯矩调幅系数，用户可以修改/增加和删除数据表中的项目；


08_扭矩折减系数

Home > midas Gen 2017 > 11_设计 > 02_设计 > 02_RC设计 > 08_扭矩折减系数

扭矩折减系数

  • 功 能

定义钢筋混凝土梁抗扭设计时的扭矩折减系数。

  • 命 令

从主菜单中选择 设计>钢筋混凝土构件设计参数>扭矩折减系数... 。

  • 输 入

下列对话框用于数据输入：

扭矩折减系数对话框

选项

添加/替换：对所选钢筋混凝土梁构件定义扭矩折减系数；

删除：删除所选钢筋混凝土梁构件构件已经定义的扭矩折减系数。


16_使用性能参数

Home > midas Gen 2017 > 11_设计 > 02_设计 > 02_RC设计 > 09_使用性能参数

使用性能参数

  • 功 能

定义性能验算中应力参数，挠度、裂缝的控制参数。

注：该参数只能应用于梁构件。（适用于 Eurocode ）

  • 命 令

从主菜单中选择 设计>钢筋混凝土构件设计参数>使用性能参数... 。

从树形菜单中表格选择 设计表格>钢筋混凝土构件设计参数>使用性能参数。

  • 输 入

首先，选择模型中的梁或柱构件，输入如下：

选项

选择增加/替换或者删除。

增加/替换：增加新数据或者修改以前的数据。

删除：删除数据，当执行删除时，不需要输入数据。

截面类别

全部：针对所有构件。

选择：针对选中的构件。

环境等级

选择环境等级（具体参数请参看Table 4.1 of EN 1992-1-1:2004(E)）。

应力参数

输入强度折减系数。

裂缝控制

选择环境等级（具体参数请参看Table 4.1 of EN 1992-1-1:2004(E)）。

准永久挠度控制

选择或输入准永久挠度系数。

特征挠度控制

选择或输入特征挠度系数。

挠度调整控制

选择或输入准永久挠度系数。

：将输入的数据应用到选定的构件上。

：关闭对话框。


09_抗力模型不定性系数

Home > midas Gen 2017 > 11_设计 > 02_设计 > 02_RC设计 > 10_抗力模型不定性系数

抗力模型不定性系数

  • 功 能

使用此项功能用于输入结构构件的抗力模型不定性系数。

  • 命 令

从主菜单中选择 设计>钢筋混凝土构件设计参数>抗力模型不定性系数... 。

  • 输 入

下列对话框用于数据输入：

抗力模型不定性系数对话框

不定性系数

结构构件的抗力模型不定性系数：静力设计取1.0，对不确定性较大的结构构件根据具体情况取大于1.0的数值；抗震设计应用承载力抗震调整系数代替该系数；


08_编辑验算用梁截面数据

Home > midas Gen 2017 > 11_设计 > 02_设计 > 02_RC设计 > 11_编辑梁截面数据

编辑验算用梁截面数据

  • 功 能

输入钢筋混凝土梁构件的截面尺寸和钢筋数据，用来进行强度验算。

  • 命 令

从主菜单中选择 设计>钢筋混凝土构件设计参数>编辑验算用梁截面数据... 。

从树菜单的表格中选择 设计表格>钢筋混凝土设计>编辑梁截面数据。

  • 输 入

首先，选择模型中的构件，输入如下：

选项

选择添加/替换或者删除。

添加/替换：增加新数据或者修改以前的数据。

删除：删除数据，当执行删除时，不需要输入数据。

截面

选择验算强度的截面。

号: 截面编号

SEL: 勾选需要截面数据编辑和验算的构件。

名称: 截面名称

钢筋: 钢筋配置情况(In: 钢筋已配置, - : 钢筋没有配置)

: 选择所有截面数据

: 解除选择的所有截面数据

点击 [image] : 编辑截面形状和尺寸。显示设计截面对话框(指向"设计截面")。

截面数据 (参阅 注 1)

显示梁构件截面数据。

形状：构件截面形状

Hc：截面高度

Bc：截面宽度

bf：T型截面翼缘宽度

hf：T型截面翼缘厚度

配筋

输入梁构件每个位置钢筋数据，进行强度校核。

：输入/修改梁端部（节点i）钢筋数据，显示如下梁钢筋定义对话框：

梁钢筋定义对话框

上部钢筋

输入上部钢筋数据。

单层配筋：一层钢筋布置

双层配筋：二层钢筋布置

：上部钢筋上排数量

：上部钢筋下排数量

：钢筋规格

下部钢筋

输入下部钢筋数据。

单层配筋：一层钢筋布置

双层配筋：二层钢筋布置

：下部钢筋上排数量

：下部钢筋下排数量

：钢筋规格

箍筋间距：箍筋间距

肢数：箍筋肢数

：输入数值或选项，关闭对话框。

：不输入数值或选项，关闭对话框。

：输入梁构件(1/4)L、(1/2)L 和(3/4)L位置处的钢筋数据。

：输入/修改梁构件端部（节点j）钢筋数据。

箍筋：箍筋直径

dT：截面上部上层主筋中心到截面边缘的距离(保护层厚度)

dB：截面下部下层主筋中心到截面边缘的距离(保护层厚度)

       ：将输入的数据应用到选定的构件上。

：关闭对话框。

注1：T形截面钢筋数据对话框如下：

梁钢筋定义对话框

注2：如果没有定义梁构件外层主筋保护层厚度(dT=0、dB=0)时，则不进行强度验算。

注3：如果仅在i节点、中央、j节点中的一个截面输入钢筋数据，则程序内部做法如下：

只在i节点、中央、j节点之一输入钢筋数据：钢筋数据应用于所有位置，进行强度验算。

在i节点、j节点输入钢筋数据：i节点钢筋数据应用于中央节点，进行强度验算。

在i节点、中央输入钢筋数据：i节点钢筋数据应用于j节点，进行强度验算。

在中央、j节点输入钢筋数据：j节点钢筋数据应用于i节点，进行强度验算。

注4：如果对于同一个截面重复输入钢筋数据，数据按照最后输入的数值更新。

注5：在数据表格中按照截面编号的可以校核钢筋数据，用户可以修改/增加和删除表中数据。


08_编辑验算用柱截面数据

Home > midas Gen 2017 > 11_设计 > 02_设计 > 02_RC设计 > 12_编辑柱截面数据

编辑验算用柱截面数据

  • 功 能

输入钢筋混凝土柱构件的截面尺寸和钢筋数据，用来进行强度验算。

  • 命 令

从主菜单中选择 设计 > 钢筋混凝土构件设计参数 > 编辑验算用柱截面数据...。

从树菜单的表格中选择 设计表格> 钢筋混凝土设计> 编辑柱截面数据。

  • 输 入

首先，选择模型中的构件，输入如下

选项

选择添加/替换或者删除。

添加/替换：增加新数据或者修改以前的数据。

删除：删除数据，当执行删除时，不需要输入数据。

截面

选择进行强度验算的截面。

号 : 截面编号

SEL: 勾选需要编辑的构件。

名称: 截面名称

钢筋: 钢筋配置情况(In: 钢筋已配置, - : 钢筋没有配置)

: 选择所有截面数据

: 解除选择的所有截面数据

点击 [image] : 编辑截面形状和尺寸。显示设计截面对话框(指向"设计截面")。

截面数据

显示柱构件截面数据。

形状：构件截面形状

Hc：截面高度(圆截面为直径)

Bc：截面宽度

配筋

输入柱构件截面钢筋数据，进行强度验算。

箍筋类型

定义箍筋类型。

环筋：环型箍筋

螺旋筋：螺旋型箍筋

直径：箍筋标准规格

：显示如下对话框，输入/修改柱截面的钢筋数据：

定义柱/支撑钢筋对话框

主筋直径 (Norb)：主筋规格

主筋数 (Nqrb)：柱截面配置的竖向钢筋数量

单面根数(Nrow)：柱截面配置的竖向钢筋单面根数

箍筋间距：箍筋间距

肢数：箍筋肢数

：输入数值或选项，关闭对话框。

：不输入数值或选项，关闭对话框。

主筋的中心位置(do)

    截面主筋中心到截面边缘的距离（保护层厚度）

：应用输入的数据于选定构件。

：关闭对话框。

注1：如果没有定义柱构件外层主筋保护层厚度(do=0)，则不进行强度验算。

注2：圆形截面柱数据对话框如下：

注3：主筋数量必须是一偶数，对于矩形截面数值应大于4，对于圆形截面，数值应大于6。

注4：如果对于同一个截面重复输入钢筋数据，数据按照最后输入的数值更新。

注5：在数据表格中按照截面编号可以校核钢筋数据，用户可以修改/增加和删除表中数据。


09_编辑验算用支撑截面数据

Home > midas Gen 2017 > 11_设计 > 02_设计 > 02_RC设计 > 13_编辑支撑截面数据

编辑验算用支撑截面数据

  • 功 能

输入钢筋混凝土支撑构件的截面尺寸和钢筋数据，用来进行强度验算。

  • 命 令

从主菜单中选择 设计>钢筋混凝土构件设计参数>编辑验算用支撑截面数据。

从树菜单的表格中选择 设计表格>钢筋混凝土设计>编辑支撑截面数据。

  • 输 入

首先，选择模型中的构件，输入如下：

选项

选择添加/替换或者删除。

添加/替换：增加新数据或者修改以前的数据。

删除：删除数据，当执行删除时，不需要输入数据。

截面

选择进行强度验算的截面。

号:　截面编号

SEL: 勾选需要截面数据编辑的构件。

名称: 截面名称

钢筋: 钢筋配置情况(In: 钢筋已配置, - : 钢筋没有配置)

: 选择所有截面数据

: 解除选择的所有截面数据

点击 [image] : 编辑截面形状和尺寸。显示设计截面对话框(指向"设计截面")。

截面数据

显示支撑构件截面数据。

形状：构件截面形状

Hc：截面高度(圆截面为直径)

Bc：截面宽度

钢筋数据

输入支撑构件截面钢筋数据，进行强度校核。

箍筋类型

定义箍筋类型。

环筋：环型箍筋

螺旋筋：螺旋型箍筋

环筋/螺旋筋：箍筋标准规格

：显示如下对话框，输入/修改支撑截面的钢筋数据：

定义柱/支撑钢筋对话框

主筋直径(Norb)：主筋标准规格

主筋数(Nqrb)：配置的纵向钢筋数量

单面根数(Nrow)：配置的纵向钢筋单面根数

箍筋间距：箍筋间距

肢数：箍筋肢数

：输入数值或选项，关闭对话框。

：不输入数值或选项，关闭对话框。

主筋的中心位置(do)

截面主筋中心到截面边缘的距离(保护层厚度)

：应用输入的数据于选定构件。

：关闭对话框。

注1：如果没有输入支撑构件外层主筋保护层厚度(do=0)，则不进行强度验算。

注2：圆形截面支撑钢筋数据对话框如下：

注3：主筋数量必须是一偶数，对于矩形截面数值应大于4，对于圆形截面，数值应大于6。

注4：如果对于同一个截面重复输入钢筋数据，数据按照最后输入的数值更新。

注5：在数据表格中按照截面编号的可以编辑钢筋数据，用户可以修改/增加和删除表中的数据。


10_编辑验算用墙截面数据

Home > midas Gen 2017 > 11_设计 > 02_设计 > 02_RC设计 > 14_编辑墙截面数据

编辑验算用墙截面数据

  • 功 能

用户输入各层的剪力墙构件设计标准--钢筋标准规格，钢筋布置，钢筋数量，剪力墙截面厚度等，进行强度验算。

  • 命 令

从主菜单中选择 设计>钢筋混凝土构件设计参数>编辑验算用墙截面数据...。

从树菜单的表格中选择 设计表格>钢筋混凝土设计>编辑墙截面数据。

  • 输 入

墙

输入楼层数据和剪力墙的标志，剪力墙设计标准和钢筋数据提供给这个标志的剪力墙。

墙号：剪力墙编号

剪力墙编号可以在输入区由用户直接输入，或者用鼠标在分析模型中点取。

开始层：应用设计数据的起始楼层。

结束层：应用设计数据的终止楼层。

墙的截面

输入剪力墙构件墙体厚度。

使用模型厚度：使用建立分析模型时的墙体厚度。

厚度：剪力墙构件的厚度。

验算钢筋

输入验算用钢筋数据。

竖向钢筋：输入剪力墙竖向钢筋的标准规格和间距。

水平钢筋：输入剪力墙水平向钢筋的标准规格和间距。

使用端部钢筋：决定是否使用端部钢筋，如果选择使用端部钢筋，需要输入端部钢筋的数量、直径和间距。

主筋的中心位置

输入剪力墙竖向钢筋中心到构件边缘的距离（保护层厚度）。

dw：端部竖向钢筋中心到剪力墙边缘的距离。

de：剪力墙端部到第一排竖向钢筋中心的距离。

操作

增加、修改或者删除用户指定楼层的剪力墙设计标准和钢筋数据。

：输入设计标准和钢筋数据。

：修改以前定义的设计标准和钢筋数据。

：删除选定的设计标准和钢筋数据。

注1：剪力墙构件中必须设置两排竖向钢筋。

注2：端部钢筋数据应用于剪力墙构件两端，并且沿构件的主轴对称分布。

注3：如果对同一个剪力墙截面重复输入钢筋数据或设计标准，数据按照最后输入的数值更新。


11_编辑墙标志数据

Home > midas Gen 2017 > 11_设计 > 02_设计 > 02_RC设计 > 15_编辑墙标签数据

编辑墙标志数据

  • 功 能

在进行自动设计和强度验算时，输入剪力墙组名称或单个名称用来区分剪力墙。

  • 命 令

从主菜单中选择 设计>钢筋混凝土构件设计参数>编辑墙标志数据。

  • 输 入

墙的标志

输入组名称或者单个名称，对剪力墙构件进行分类。

名称：剪力墙构件组或单片剪力墙名称

墙号列表：剪力墙构件编号列表

剪力墙编号由用户在输入区输入或者在分析模型中选择。

操作

增加、修改或删除剪力墙的编号。

：添加剪力墙构件名称。

：修改以前定义的剪力墙构件名称。

：删除选定的剪力墙构件名称。

：关闭输入对话框。

注1：如果用户没有定义墙体标志，程序自动生成如下名称，名称最长为12个字符。

名称 = "wM" + 剪力墙ID

注2：如果对同一个剪力墙构件重复输入墙体标志名称，墙体标志名称按最后输入的名称更新。


17_按墙号采用边界元法

Home > midas Gen 2017 > 11_设计 > 02_设计 > 02_RC设计 > 16_按墙号采用边界元法

按墙号采用边界元法

  • 功 能

此项功能暂不支持中国规范。


01_设计标准

Home > midas Gen 2017 > 11_设计 > 02_设计 > 03_SRC构件 > 01_设计标准

设计标准

  • 功 能

输入适用于钢-钢筋混凝土组合构件(SRC)强度验算的设计规范。

  • 命 令

从主菜单中选择　设计>SRC组合构件设计参数>设计标准...。

从树菜单的表格中选择 设计>SRC设计参数>设计标准。

  • 输 入

下列对话框用于数据输入：

      SRC设计标准对话框

设计标准

选择设计规范

考虑抗震

输入抗震设防烈度

：输入选项，关闭对话框。

：不输入数据选项，关闭对话框。

    注1：下列SRC设计规范可供选择：

- 中国《型钢混凝土组合结构技术规程》JGJ138-2001

中国《钢管混凝土结构设计与施工规程》CECS28:90

- 美国SSRC的容许应力设计(结构稳定研究委员会)(SSRC79)

- 日本建筑学会的SRC结构设计规范(AIJ-SRC01)

- 韩国建筑学会的SRC结构设计规范(AIK-SRC2K)

注2：美国SSRC(SSRC79)的容许应力设计和韩国建筑学会的SRC结构设计规范(AIK-SRC2k)适用于SRC组合柱构件的设计。


02_编辑SRC材料

Home > midas Gen 2017 > 11_设计 > 02_设计 > 03_SRC构件 > 02_编辑SRC材料

编辑SRC材料

  • 功 能

可以修改建立分析模型时输入的部分钢、混凝土、钢筋材料的特性数据，主要用于设计验算。

  • 命 令

从主菜单中选择 设计>SRC组合构件设计参数>编辑SRC材料...。

  • 输 入

下列对话框用于数据输入：

材料列表

显示建模时输入的钢、混凝土和钢筋材料特性，用鼠标选择要修改的材料。

选择SRC材料

按照钢材、混凝土材料和钢筋的分类分别显示选择的材料特性。

选择钢材：修改选定的钢材数据，使用程序中内置的材料特性数据库或者直接输入数据可以改变材料特性数据。

用户直接输入

在规范区选择?无?，在名称区输入材料名称，然后激活各输入区输入的材料特性数据。

Es：钢材的弹性模量

Fu：钢材的极限抗拉强度

Fy1～4：钢材不同厚度的屈服强度

选择混凝土材料：显示选择的混凝土材料特性，修改材料特性数据。

用户直接输入

在规范区选择?无?，在名称区输入材料名称，然后激活各输入区输入的材料特性数据。

Fck：混凝土圆柱体抗压强度标准值

选择钢筋：显示选择的钢筋材料特性，修改材料特性数据。

规范：选择钢筋标准

主筋等级：主筋强度等级

辅筋等级：箍筋强度等级

Fyr：主筋抗拉强度标准值

Fys：箍筋抗拉强度标准值

：修改先前输入的材料特性。

：不输入数据选项，关闭对话框。


03_编辑SRC梁截面数据

Home > midas Gen 2017 > 11_设计 > 02_设计 > 03_SRC构件 > 03_编辑SRC梁截面数据

编辑SRC梁截面数据

  • 功 能

编辑SRC梁截面数据和钢筋数据，用于对SRC梁进行强度验算。

  • 命 令

从主菜单中选择　设计>SRC组合构件设计参数>编辑SRC梁截面数据。

从树菜单的表格中选择　设计表格>SRC设计>编辑SRC梁截面数据。

  • 输 入

首先，选择模型中的构件，输入如下：

选项

增加/替换：增加新数据或者修改以前的数据。

删除：删除数据，当执行删除时，不需要输入数据。

截面

显示截面设计对话框，修改SRC构件截面形状和尺寸

点击 按钮显示编辑设计截面对话框，可以修改SRC构件截面形状和尺寸，修改后的截面可以直接用于设计验算。

钢材截面

显示SRC构件钢材截面数据。

H：钢材截面高度(圆管为截面直径)

B(tw)：钢材截面宽度(圆管为截面厚度)

tw：钢材截面腹板厚度

tf1：钢材截面上翼缘厚度

Cw：箱形截面组合腹板中心间距 (默认：Cw=B-tw)

tf2：钢材截面下翼缘厚度

混凝土截面

显示构件混凝土截面数据。

Hc：外包钢截面的混凝土截面高度(圆截面为外直径)

Bc：外包钢截面的混凝土截面宽度

材料

标准材料：换算成等效截面计算截面刚度时，将SRC材料转换成同一材料的类型。

主筋

输入SRC梁的钢筋数据，用于验算截面强度。

自动计算钢筋间距：选择是否由程序自动计算主筋间距或者直接输入

钢筋：输入钢筋数量和规格。

层数：SRC截面中主筋的层数。

主筋的中心位置(do)：主筋中心到混凝土截面边缘的距离(保护层厚度)。

：输入选定的截面数据。

：关闭对话框。

注1：SRC截面仅适用混凝土包钢材构件，不适用于钢材内浇混凝土的SRC截面，钢管混凝土除外。

注2：可以在混凝土包钢材构件时输入钢筋数据，不适用于钢材内浇混凝土的SRC截面。

注3：必须输入对SRC截面进行强度校核的钢筋数据，钢筋数量必须是4的倍数。

注4：如果对同一个SRC构件截面重复输入钢筋数据，数据按照最后输入的数值更新。

注5：在数据表格中按照截面特性编号可以校核钢筋数据，用户可以修改数据表中的项目。


04_编辑SRC柱截面数据

Home > midas Gen 2017 > 11_设计 > 02_设计 > 03_SRC构件 > 04_编辑SRC柱截面数据

编辑SRC柱截面数据

  • 功 能

输入SRC截面数据和钢筋数据，对钢-钢筋混凝土组合柱进行强度校核。

  • 命 令

从主菜单中选择　设计>SRC组合构件设计参数>编辑SRC柱截面数据。

从树菜单的表格表中选择　设计表格>SRC设计>编辑SRC柱截面数据。

  • 输 入

首先，选择模型中的构件，输入如下：

选项

增加/替换：增加新数据或者修改以前的数据。

删除：删除数据，当执行删除时，不需要输入数据。

截面

显示截面设计对话框，修改SRC构件截面形状和尺寸。

点击 按钮显示编辑设计截面对话框，可以修改SRC构件截面形状和尺寸，修改后的截面可以直接用于设计验算。

钢材截面(参阅 注 1)

显示建模时输入的SRC构件钢材截面数据。

H：钢材截面高度(圆管为截面直径)

B(tw)：钢材截面宽度(圆管为截面厚度)

tw：钢材截面腹板厚度

tf1：钢材截面上翼缘厚度

Cw：箱形截面组合腹板中心间距 (默认：Cw=B-tw)

tf2：钢材截面下翼缘厚度

混凝土截面

显示建模时输入的混凝土截面数据。

Hc：外包钢截面的混凝土截面高度(圆截面为外直径)

Bc：外包钢截面的混凝土截面宽度

材料

标准材料：换算成等效截面计算截面刚度时，将SRC材料转换成同一材料的类型。

主筋

输入SRC构件钢筋数据，用于验算截面强度。

自动计算钢筋间距：选择是否由程序自动计算主筋间距或者直接输入。

钢筋：输入钢筋数量和规格。

层数：SRC截面中主筋的层数。

主筋的中心位置(do)：主筋中心到混凝土构件边缘的距离(保护层厚度)。

箍筋

输入箍筋的直径及间距

：输入选定的截面数据。

：关闭对话框。

注1：SRC截面仅适用混凝土包钢材构件，不适用于钢材内浇混凝土的SRC截面，钢管混凝土除外。

注2：可以在混凝土包钢材构件时输入钢筋数据，不适用于钢材内浇混凝土的SRC截面。

注3：必须输入对SRC截面进行强度校核的钢筋数据，钢筋数量必须是4的倍数。

注4：如果对同一个SRC构件截面重复输入钢筋数据，数据按照最后输入的数值更新。

注5：在数据表格中按照截面特性编号可以校核钢筋数据，用户可以修改数据表中的项目。


05_钢构件截面验算

Home > midas Gen 2017 > 11_设计 > 03_钢构件设计 > 01_钢构件验算

钢构件截面验算

AISC-ASD89，AISC-LRFD93，AISC-CFSD86，Eurocode 3，BS5950-90，AIK-ASD83，KSCE-ASD96，AIK-LSD97，AIK-CFSD98

  • 功 能

用分析结果和强度校核数据，根据下列钢结构设计标准检查钢结构构件的承载力：

中国《钢结构设计规范》（GB50017-2003)

美国钢结构学会的容许应力设计(AISC-ASD89，容许应力设计)，

美国钢结构学会的荷载和抗力系数设计(AISC-LRFD93，荷载和抗力系数设计)，

美国钢铁学会的冷轧型钢设计(AISI-CFSD86，冷轧型钢设计)，

ENV 1993-1-1欧洲规范3 (钢结构设计，1.1节 通则和建筑准则)，

英国标准协会的BS 5950(BS 5950：第1部分，简支和连续结构的实用设计规范：热轧型钢截面），

韩国建筑学会(AIK-ASD83，容许应力设计)，

韩国土木工程师协会的公路桥梁和钢桥规范(KSCE-ASD96，容许应力设计)，

韩国建筑学会的钢结构极限状态设计标准(AIK-LSD97，极限状态设计)，

韩国建筑学会的冷轧型钢设计(AIK-CFSD98，冷轧型钢设计)。

该模块校核全部钢结构构件的强度，并反映活荷载折减系数、地震荷载和移动荷载的修正系数。还可以对由于改变设计特性和标准的选定构件进行重新分析和校核。，还提供断面最优化设计功能。

  • 命 令

从主菜单中选择　设计>钢构件截面验算...。

  • 生成结果

按照单元或者截面特性以及最大应力比(组合强度比)和相应的荷载组合，生成强度校核结果。

由用户选择生成强度校核结果的单位体系。

1. GB50017-2003

CHK：按构件显示构件强度校核结果

= "OK"：构件中的应力在容许应力范围内

= "OK*"：构件中的应力在容许应力范围内，但是超过容许长细比

= "NG"：构件中的应力超过容许应力范围

= "NG*"：构件中的应力超过容许应力范围和容许长细比

MEMB：单元编号

SECT：截面特性编号

COM：最大组合应力比

SHR：剪力的应力比(构件剪应力/容许剪应力)

选择：选择构件，进行截面修改，再校核，输出结果

截面名称：用户指定截面或者程序内部储存的截面

材料：用户指定材料或者程序内部储存的材料

Fy：屈服强度

LCB：生成最大组合应力比的荷载组合编号

Len：根据分析模型中的节点局部坐标计算的构件长度

Ly, Lz：分别为构件绕强轴(单元坐标系y轴)、弱轴(单元坐标系z轴)弯曲的无支撑长度

Lb：构件受压翼缘横向无支撑长度

Ky, Kz：分别为构件绕强轴(单元坐标系y轴)、弱轴(单元坐标系z轴)弯曲的有效弯曲长度系数

Bmy,Bmz：分别为构件绕强轴(单元坐标系y轴)、弱轴(单元坐标系z轴)的等效弯矩系数

N：构件轴向压力

Nr:构件轴向容许压力

Mb：屈曲抵抗力矩(横侧扭转)

Mrb：容许屈曲抵抗力矩(横侧扭转)

My, Mz：分别为构件绕强轴、弱轴的弯矩

Mry, Mrz：分别为构件绕强轴、弱轴的容许弯矩

2. AISC-ASD89

AISC-ASD89 规范校核结果对话框

Cb：绕构件强轴的弯矩的弯矩放大系数

Cmy, Cmz：分别为绕关于构件强轴、弱轴的力矩系数

3. AISC-LRFD93

AISC-LRFD93 规范校核结果对话框

4. AISI-CFSD86

AISI-CFSD86规范校核结果对话框

Ap_y, Ap_z：分别为由阻止侧倾的钢框架中的垂直荷载产生的绕构件强轴、弱轴的弯矩的力矩放大系数

其他符号定义同 AISC-LRFD93.

5. Eurocode 3

Eurocode 3 规范校核结果对话框

B_y, B_z：Bmy和Bmz是等效均布弯矩系数

Nsd：作用的设计轴力

N_Rd：设计轴向抗力

Mbsd：作用的设计弯矩

Mb_Rd：横向侧无约束的梁的设计屈曲抵抗力矩

Mysd：绕构件强轴作用的设计弯矩

My_Rd：绕构件强轴作用的设计屈曲抵抗力矩

Mzsd：绕构件弱轴作用的设计弯矩

Mz_Rd：绕构件弱轴作用的设计屈曲抵抗力矩

其他符号定义同 AISC-LRFD93。

6. BS5950-90

BS5950-90 规范校核结果对话框

n：长细比修正系数(AISC-ASD89中相当于1/Cb)

m_y, m_z：分别为绕构件强轴、弱轴的弯矩的力矩放大系数

Fa：作用的设计轴力

Pa：轴向设计强度承载力

Mb：屈曲抵抗力矩(横侧扭转)

My：临界区域绕构件强轴作用的力矩

Mcy：无轴向荷载时，截面对构件强轴力矩承载力

Mz：临界区域绕构件弱轴作用的力矩

Mcz：无轴向荷载时，截面对构件强轴力矩承载力

其他符号定义同AISC-LRFD93。

7. AIK-ASD83

AIK-ASD83规范校核结果对话框

CHK：按构件显示构件强度校核结果

= "OK"：构件中的应力在容许应力范围内

= "OK*"：构件中的应力在容许应力范围内，但是超过容许长细比

= "NG"：构件中的应力超过容许应力范围

= "NG*"：构件中的应力超过容许应力范围和容许长细比

NOEL：单元编号

NPRO：截面特性编号

COM：最大组合应力比

SHR：剪力的应力比(构件剪应力/容许剪应力)

SEL：选择构件，进行截面修改，再校核，输出结果

构件名称：用户指定截面或者程序内部储存的截面

材料：用户指定材料或者程序内部储存的材料

Fy：屈服强度

LCB：生成最大组合应力比的荷载组合编号

Len：根据分析模型中的节点局部坐标计算的构件长度

Ly, Lz：分别为构件绕强轴(局部坐标系y轴)、弱轴(局部坐标系z轴)弯曲的无支撑长度

Lb：构件受压翼缘横向无支撑长度

Ky, Kz：分别为构件绕强轴(局部坐标系y轴)、弱轴(局部坐标系z轴)弯曲的有效弯曲长度系数

fa：构件轴向压应力

fby, fbz：分别为构件绕强轴、弱轴弯曲的弯曲应力

Pa：构件轴力(Pa > 0：拉力，Pa < 0：压力)

My, Mz：分别为构件绕强轴、弱轴的弯矩

Cm：绕构件强轴的弯矩的弯曲系数

Fa：构件轴向的容许压应力(容许拉应力)

FBy, FBz：分别为构件绕强轴、弱轴弯曲的容许弯曲应力

8. KSCE-ASD96

KSCE-ASD96 规范校核结果对话框

内容与AIK-ASD83类似。

9. AIK-LSD97

AIK-LSD97 规范校核结果对话框

Cb：绕构件强轴弯矩的弯曲系数

B1y, B1z：钢框架中阻止侧倾的垂直荷载产生的弯矩的力矩放大系数

B2y, B2z：钢框架中无法阻止侧倾的水平荷载产生的弯矩的力矩放大系数

Pu：构件轴力

Muy, Muz：分别为绕构件强轴、弱轴的弯矩

phiPn：构件额定轴向强度

phiMny, phiMnz：分别为绕构件强轴、弱轴的额定抗弯强度

COM：最大组合强度比

SHR：抗剪强度比(所需抗剪强度/额定抗剪强度）

LCB：生成最大组合强度系比的荷载组合编号

其他符号定义同AIK-ASD83。

10. AIK-CFSD98

AIK-CFSD98 规范校核结果对话框

参见AISI-CFSD86。

普通控制

：显示强度校核使用的规范

按照单元或特性显示最大组合应力比(组合强度比)的强度校核结果。

按特性分类显示同一属性的构件中生成最大组合应力比(组合强度比)的单元的强度校核结果。

一旦确定属性，选择控制具有相同特性的所有单元。

：显示用户选择的单位系统。

按构件生成最大组合应力(强度)的强度校核结果时，依特性值编号或者构件编号按升序排列结果。

：选择所有构件

：取消选择所有构件

重新设计选定的构件。

根据按截面特性显示的结果重新设计时，包括所有具有相同截面的单元。

选中此项，在模型视窗中选择并亮显选定的构件。

：显示强度校核详细结果

：显示强度校核简化结果

：对于选定构件，显示强度校核的图形结果。

：对于选定构件，显示强度校核的详细计算结果。

：对于选定构件，显示强度校核简要结果表格。

当结果按截面分类时，生成具有最大组合应力(强度)的构件的设计结果。

：在校核结果对话框中显示所有强度校核结果。

：在校核结果对话框中只显示从校核结果中选择的满足设计要求(OK)的强度校核结果。

：在校核结果对话框中只显示从校核结果中选择的不满足设计要求(NG)的强度校核结果。

对选定构件，生成所有荷载组合工况下的强度校核结果。

：关闭对话框。

截面改变

：提供满足选定单元条件的截面。(截面改变)

构件名称：程序内部存储的截面名称

CHK：按截面显示强度校核结果

= "OK"：截面中的应力(必需的强度)在容许应力(设计强度)范围内

= "NG"：截面中的应力(必需的强度)超过容许应力(设计强度)范围

选择：选择要改变的截面

LCB：生成最大组合应力比(组合强度比)的荷载组合编号

COM：最大组合应力比(组合强度比)

SHR：剪力的应力比(强度比)=构件剪应力/容许剪应力(必需的抗剪强度/设计抗剪强度)

H：截面高度

B：截面宽度

Area：截面面积

：选择要改变的特性编号

：打开一个用作截面数据库的MGB文件

(可使用包含用户创建的截面数据的MGB文件，在建立数据库时只包括数据库/用户截面)。

：选择要改变的数据库截面

：选择要改变的截面形状

选择要改变的截面尺寸范围。

如果截面尺寸范围要和当前使用的截面尺寸的一部分相一致，选中校核框。要指定范围，在从输入区和到输入区中输入与所用单位系统一致的尺寸。

如果预先指定新截面为已知尺寸，那么只在从输入区中输入尺寸。

：对要改变的截面，指定组合应力比(组合强度比)的范围。

：对满足设计条件的截面进行强度校核并生成结果。

：对截面强度校核选择排序优先权。

：校核选定截面的强度，在钢结构强度校核文件(.GD1)中保存改变的结果，然后关闭对话框。

：校核选定截面的强度，在钢结构强度校核文件(.GD1)中保存改变的结果。

：关闭对话框。

修改特性

：完成强度校核之后，用改变后的截面修正模型特性。(修改特性)

修改前截面特性值代表在最初分析模型中使用的截面特性。

修改后截面特性值代表完成最终强度校核以后的改变的截面特性。

：仅自动选择已改变的特性。

：取消所有选择

：用选定的截面修改模型中的属性

：关闭对话框。

绘制强度校核结果图

按材料、单元、特性值绘制强度校核结果图（绘制强度校核结果图）。

：全选

：取消全选

选择图形输出分类选项(对于特性选择，定义表格输出格式）。

选择图形输出选项(选择横线或竖线)。

指定图形输出所用的荷载组合(全部表示在所有荷载组合中生成最大比率的荷载组合)。

：选择输出比率的类型

：选择输出比率的范围

在模型视窗中选择满足分类选项、钢结构规范校核的荷载组合、比率和比率界限的单元。

选中方框，在已有视窗里生成图形(若未选中，则在新的视窗中生成图形)。

对满足选定条件的构件，在图形中生成强度校核结果比。

：关闭对话框。


06_钢结构优化设计

Home > midas Gen 2017 > 11_设计 > 03_钢构件设计 > 02_钢结构优化设计

钢结构优化设计

  • 功 能

目前构件优化是通过迭代分析和最优设计（截面优化）得到最优截面。根据结构分析结果，钢结构设计模块，SRC设计模块为基础进行强度校核。

SRC构件截面最优化设计通过改变钢构件的截面尺寸得到。混凝土截面尺寸、钢构件形状和钢筋数量不能改变，设计也必须满足容许长细比的要求。

  • 命 令

只能在后处理模式下执行此功能，当运行钢结构设计模块时，不能执行钢结构最优化设计模块。如果执行SRC设计模块时，同样也不能执行SRC最优设计模块。

从主菜单中选择　设计 > 钢结构优化设计...。

从主菜单中选择　设计 > SRC结构优化设计...。

  • 输 入

SEL：

选择进行最优化处理的截面。

截面名称：

用户输入的构件名称。

修改前截面：

显示用户输入的构件尺寸和强度校核结果，这部分内容不能修改。

尺寸：构件尺寸，?B?放在截面名称之前，表示焊接组合截面。

面积：构件横截面的面积。

验算：强度校核结果产生的组合应力比(组合强度比)。

设计标准：

提供截面最优化设计标准。

容许

输入选定构件组合应力比(组合强度比)的上限，选择在界限比值内的具有最小截面面积的构件。

把修改后的构件并入分析模型以后，对模型进行再分析，由于构件刚度系数的改变，会生成和选定组合应力比(组合强度比)不同的结果。

截面数据库

选择设计使用的数据库。

用在 [image] 中输入的板厚度和构件尺寸输入在D1-D6中创建的焊接组合截面。

当选择 [image] 时，用户可以使用在 [image] 中输入的构件（焊接截面）。

                   形状

选择构件类型（形状）。符号如下：

L：L-型钢截面

C：C-型钢截面

I：I-型钢截面

T：T-型钢截面

B：箱形钢截面

P：圆钢管截面

SR：圆钢

SB：方钢

2L：双L-型钢截面

2C：双C-型钢截面

当使用钢结构截面最优化设计功能时，才可以改变构件类型（形状）。使用SRC截面最优化设计功能时，不允许改变钢构件类型（形状）。

D1-D6

输入构件截面的尺寸范围。

若输入值为?0?，搜寻所有尺寸，当前项目之后的所有输入项将被忽略。

当 [image] 是 [image] ，并且构件尺寸输入值为?0?时，用下列数据创建截面：

Section shape | H1 | H2 | H inc | Remarks
L-Steel section | 50 | 300 | 10 |
C-Steel section | 100 | 800 | 50 |
I-Steel section | 100 | 1500 | 100 |
T-Steel section | 50 | 500 | 50 |
Box-Steel section | 100 | 1500 | 100 |
Circular-Steel pipe section | 100 | 1500 | 100 |
Round Steel bar | 10 | 200 | 10 |
Rectangular Steel bar | 10 | 300 | 10 |
Double L-Steel section | 50 | 300 | 10 |
Double C-Steel section | 100 | 800 | 50 |

截面高度数据：单位为?mm?、?cm?、?m? [单位：mm]

Section shape | H1 | H2 | H inc | Remarks
L-Steel section | 2.0 | 12.0 | 0.5 |
C-Steel section | 4.0 | 32.0 | 2.0 |
I-Steel section | 4.0 | 60.0 | 4.0 |
T-Steel section | 2.0 | 20.0 | 2.0 |
Box-Steel section | 4.0 | 60.0 | 4.0 |
Circular-Steel pipe section | 4.0 | 60.0 | 4.0 |
Round Steel bar | 0.5 | 8.0 | 0.5 |
Rectangular Steel bar | 0.5 | 12.0 | 0.5 |
Double L-Steel section | 2.0 | 12.0 | 0.5 |
Double C-Steel section | 4.0 | 32.0 | 2.0 |

截面高度数据：单位为?in?、?ft'? [单位：in]

Section shape | W1 | W2 | W inc | Remarks
L-Steel section | 50 | 300 | 10 |
C-Steel section | 40 | 400 | 20 |
I-Steel section | 100 | 900 | 100 |
T-Steel section | 50 | 500 | 50 |
Box-Steel section | 100 | 900 | 100 |
Circular-Steel pipe section | - | - | - |
Round Steel bar | - | - | - |
Rectangular Steel bar | 10 | 200 | 10 |
Double L-Steel section | 50 | 300 | 10 |
Double C-Steel section | 40 | 400 | 20 |

截面宽度数据：单位为?mm?、?cm?、?m? [单位：mm]

Section shape | W1 | W2 | W inc | Remarks
L-Steel section | 2.0 | 12.0 | 0.5 |
C-Steel section | 2.0 | 16.0 | 1.0 |
I-Steel section | 4.0 | 36.0 | 4.0 |
T-Steel section | 2.0 | 20.0 | 2.0 |
Box-Steel section | 4.0 | 36.0 | 4.0 |
Circular-Steel pipe section | - | - | - |
Round Steel bar | - | - | - |
Rectangular Steel bar | 0.5 | 8.0 | 0.5 |
Double L-Steel section | 2.0 | 12.0 | 0.5 |
Double C-Steel section | 2.0 | 16.0 | 1.0 |

截面宽度数据：单位为?in?、?ft'? [单位：in]

当 [image] 是轧制钢截面(AISC，BS，DIN，JIS和KS)时，强度校核时检查输入尺寸的5%。当截面是焊接钢截面（USER，BUILT），仅对完全符合输入尺寸的截面进行强度校核。

当所有项目均为?0?时，因为要校核很大数量的构件，所以运行时间很长。输入合理范围可以提高构件强度校核的效率。

各截面形状的数据输入如下：

Section | Symbol | D1 | D2 | D3 | D4 | D5 | D6
L-Steel section | ' L ' | H | B | tw | tf | Rop |
C-Steel section | ' C ' | H | B1 | tw | tf1 | B2 | tf2
I-Steel section | ' I ' | H | B1 | tw | tf1 | B2 | tf2
T-Steel section | ' T ' | H | B | tw | tf |  |
Box-Steel section | ' B ' | H | B | tw | tf1 | Cw | tf2
Circular-Steel pipe section | ' P ' | D | tw |  |  |  |
Round Steel bar | ' SR' | D |  |  |  |  |
Rectangular Steel bar | ' SB ' | H | B |  |  |  |
Double L-Steel section | ' 2L ' | H | B | tw | tf | C | Rop
Double C-Steel section | ' 2C ' | H | B | tw | tf | C |

  参见截面获得详细帮助。

输入柱构件最优设计所需数据。

当 [image] 是 [image] 时，指定板厚。

当 [image] 是 [image] 时，提供截面尺寸。

指定强度校核和再分析的循环次数。

通过再分析执行强度校核。按照 [image] 指定的次数改变构件，对构件进行重复分析之后，取代原始模型，再次分析修正后的模型。

柱设计

  • 功 能

输入柱构件最优化设计所需数据。

  • 输 入

柱设计对话框

作用力和弯矩

轴力和弯矩

选择满足指定条件的构件，指定条件指轴力（必需的轴向强度）和弯矩（必需的抗弯强度）产生的组合应力（强度）在容许应力比范围内（在允许中设置的容许强度比）。

仅有轴力

选择满足指定条件的构件，指定条件指轴力（必需的轴向强度）在容许应力比范围内。

组合柱拼接的连接方法

对于l 形和箱形钢截面，当 [image] 设置成 [image] 时，就可以按照柱外部及内部尺寸确定构件尺寸。

内部不变 (内部连接模式)

构件内部尺寸按照不同深度/宽度固定，可以改变钢板厚度。

外部不变 (外部连接模式)

构件的外部尺寸保持不变。

钢板厚度数据

  • 功 能

输入最优化设计中使用的翼缘和腹板厚度。

  • 输 入

板厚度数据对话框

厚度

设置成 [image] ，输入构件的板厚，最多可以使用50种类型。

按照升序对输入的板厚排序。

在当前单位系统下程序内置数据库中自动获得厚度数据。

1) 单位?mm?、?cm?、?m?

6 mm，8 mm， 9 mm，10 mm，12 mm，15 mm，16 mm，18 mm，20 mm，22 mm，24 mm， 25 mm，26 mm，28 mm，30 mm，32 mm，34 mm，35 mm，36 mm，38 mm，40 mm， 42 mm，45 mm，46 mm，48 mm，50 mm，55 mm，60 mm，65 mm，70 mm，75 mm，80 mm (共 32 种)

2) 单位?in?、?ft?

0.250 in(4/16 in), 0.3125 in(5/16 in), 0.375 in(6/16 in), 0.4375 in(7/16), 0.500 in(8/16 in), 0.5625 in(9/16 in), 0.625 in(10/16 in), 0.750 in(12/16 in), 0.875 in(14/16 in), 1.000 in, 1.125 in, 1.250 in, 1.375 in, 1.500 in, 1.625 in, 1.750 in, 1.875 in, 2.000 in, 2.125 in, 2.250 in, 2.375 in, 2.500 in, 2.625 in, 2.750 in, 2.875 in, 3.000 in, 3.250 in, 3.500 in, 3.750 in, 4.000 in (共 30种)

用户定义截面

  • 功 能

预先定义最优化设计使用的截面，输入全部截面数据创建截面数据库。

  • 输 入

用户定义截面对话框

形状

对于输入的数据定义截面形状符号。

当使用SRC最优设计时，构件不能改变原始定义的形状。从数据库截面中选择构件的钢截面维持原始定义的形状。

D1-D6

输入构成相应截面的主要尺寸，参阅D1-D6的输入内容。

从文件中获得截面数据。

        • 数据文件格式

  1. 仅允许使用焊接钢截面，不允许使用轧制型钢截面。

  2. 数据文件用?*数据库-截面?开头。

  3. 用空格或者逗号分隔数据。

  4. 第一条?ID?作为简单标识符，自由输入。

  5. 参阅从窗口中输入的截面?形状?主要数据。

  6. 使用当前单位输入D1-D6，参阅主要数据输入窗口的D1-D6。

输入格式举例：

*DB-Section

**ID, SHP, D1, D2, D3, D4, D5, D6

1, I, 12.38, 12.08, 0.47, 0.735,

2, I, 14.02, 14.52, 0.44, 0.71,

3, I, 16.33, 10.235, 0.395, 0.665,

4, I, 4.16, 4.06, 0.28, 0.345,

5, T, 10.715, 8.355, 0.515, 0.835,

6, T, 4.07, 5.25, 0.23, 0.33,

7, L, 4, 4, 0.3125, 0.3125

注：在编辑数据格式文件时上面的标题头*DB-Section也是需要的

分析选项

  • 功 能

定义最优化设计时改变构件重分析的循环次数。

  • 输 入

分析选项对话框

循环次数

输入重分析循环次数。

  • 最大循环次数为10。

  • 仅选择构件不做再分析时输入?0?。

  • 完成对改变构件的再分析以后，可以观察。模型可以再次修改和分析。

  • 如果对满足设计约束条件的构件进行分析，因为截面的刚度系数发生了变化，所以结果不再与约束条件相吻合。如果重分析的次数足够，可以得到和设计约束条件相接近的结果。

最优化设计结果

  • 功 能

按照不同格式显示并对最优设计结果分类，反映模型中构件的改变情况。

  • 应 用

最优设计结果对话框

用?SEL?把选中的构件并入原始模型，校核后，对新构件进行再分析，再分析结果显示在主输入窗口中。

在屏幕上或者文件中生成文本格式的结果。

以不同格式的图表显示结果，输出图表格式如下：

系数

显示每个截面的最大组合应力比（组合强度比）。

重量

按截面显示总重量的变化结果。

总重量

每个截面的总重单独汇编，最右端的截面重量是总重

重量比

显示由组合应力比（组合强度比）概括的重量结果。组合应力比（组合强度比）以增量0.1（10%）显示。

平均系数

按截面显示平均安全系数，所有构件系数总和除以构件总数得到该值。

注：当选定截面不满足容许长细比的要求时，最优设计结果应力比为?999.0?。


01_梁配筋设计

Home > midas Gen 2017 > 11_设计 > 04_混凝土设计 > 01_混凝土构件设计 > 01_梁设计

梁配筋设计

  • 功 能

根据整个结构的分析结果和定义的设计参数，自动设计钢筋混凝土梁构件。

  • 命 令

从主菜单中选择　设计>钢筋混凝土构件配筋设计>梁配筋设计...。

  • 生成结果

根据混凝土设计荷载组合，计算每个单元在I,1/4,1/2,3/4及J位置处的最大正负弯矩和剪力，自动计算截面配筋量，按照构件排序输出每个单元的设计结果；若按截面特性值排序输出设计结果，程序是考虑每个截面特性值的所有单元和截面位置，得到计算的最大配筋量，在此基础上按照截面特性值输出设计结果。

在结果表格中如果自动设计结果满足给定的设计要求，则结果显示为蓝色，否则显示为红色。

在结果表格中位置M表示截面1/4,1/2,3/4位置之一，在这些位置处考虑最不利的正负弯矩和剪力。

设计结果是按用户定义的主筋规格(最多5种类型)和箍筋规格(1种类型)，设计配置最优化的钢筋规格和数量，满足间距和配筋率的要求。

目前版本程序内定构件截面配筋最多为2层。

按用户选择的单位系统自动生成设计结果。

MEMB：单元编号

SECT：截面属性编号

Span：梁构件长度

Bc,Hc：梁构件宽度和高度

bf,hf：T形截面翼缘宽度和厚度

fcu：混凝土极限抗压强度

fyk：主筋强度标准值

fvk：抗剪钢筋强度标准值

Pos：截面设计位置（I,M,J)

设计位置M的结果是指截面位置1/4,1/2和3/4处的最大正负弯矩和剪力。

CHK：设计结果的判断

"OK"：设计结果满足设计正负弯矩和剪力的设计强度要求。

"N**"：设计结果不满足设计负弯矩的设计强度要求。

"*P*"：设计结果不满足设计正弯矩的设计强度要求。

"**V"：设计结果不满足设计剪力的设计强度要求。

"NP*"：设计结果不满足设计正、负弯矩的设计强度要求。

"*PV"：设计结果不满足设计正弯矩和剪力的设计强度要求。

"N*V"：设计结果不满足设计负弯矩和剪力的设计强度要求。

"NPV"：设计结果不满足设计正、负弯矩和剪力的设计强度要求。

N(-)M：截面的最大设计负弯矩。

LCB：对应截面最大设计负弯矩的荷载组合号。

AsTop：程序计算的截面上部钢筋所需面积，程序取用规范要求的最小配筋量和计算配筋量两者的较大者。

Rebar：根据用户定义的钢筋规格，程序自动选配的钢筋。

如果配置的钢筋多于2排，程序会把其余的钢筋布置在第二排，然后在CHK下显示"N**"。

1排钢筋("xx-Dyy")

xx 是上部钢筋数量，Dyy是指钢筋的规格。

2排钢筋("xx-yy-Dzz")

xx是上部钢筋上排数量，yy是上部钢筋下排数量，Dzz是指钢筋的规格。

P(+)M:截面的最大设计正弯矩。

LCB：对应截面最大设计正弯矩的荷载组合号。

AsBot：程序计算的截面下部钢筋所需面积，程序给出的是规范要求的最小配筋量和计算配筋量两者的较大者。

Rebar：根据用户定义的钢筋规格，程序自动选配的钢筋。

如果配置的钢筋多于2排，程序会把其余的钢筋布置在第二排，然后在CHK下显示"P**"。

1排钢筋("xx-Dyy")

xx是下部钢筋数量，Dyy是钢筋的规格。

2排钢筋("xx-yy-Dzz")

xx是下部钢筋下排数量，yy是下部钢筋上排数量，Dzz是钢筋的规格。

V：截面的最大设计剪力

LCB：对应截面最大设计剪力的荷载组合号。

AsV：程序计算的截面抗剪钢筋面积(长度单位2/米)，列出规范要求的最小配筋量和计算配筋量两者的较大者。

stirrup:箍筋间距，按用户输入的箍筋标准规格，根据AsV求得的箍筋间距。

下面显示箍筋自动设计结果：

"D-xx@yyy"

其中：D是箍筋肢数，xx是箍筋直径，yyy是钢筋间距。

普通控制

设计标准GB50010-02：显示自动设计使用的规范。

："按单元分类"显示设计结果，其中包括由所有荷载组合在3个截面(I,M 和 J)位置处产生的设计最大正负弯矩和剪力。

"按特性分类"显示设计最大正负弯矩和剪力的设计结果，截面位置代表相关截面特性的所有单元。既然结果不属于某个单元， MEMB(单元编号)为"0"。

选定特性后，SECT控制具有同一截面特性的所有单元。

：显示用户选择的单位体系。

：自动设计中选择主筋的搭接方式选项，该选项用于确定钢筋间距。

自动设计默认选择50% (50%搭接)。

= 无：不考虑搭接计算主筋数量

= 50%：考虑50%搭接计算主筋数量

= 100%：考虑100%搭接计算主筋数量

：按单元生成设计结果时，选择是否按截面编号或单元编号升序排列结果。

：将配筋结果赋予构件，在?编辑验算用梁截面数据?中可以看到构件配筋结果，在验算截面及做PUSHOVER分析时需要用到截面实配钢筋结果。

：选择所有构件

：取消选定的所有构件

重新设计选定的构件。

：显示自动设计详细结果

：显示自动设计简单结果

：选择输出数据中的截面位置。

：对于选定构件，以文本文件的方式显示简要的计算结果。文件名：Untitled.rcs

：对于选定构件，以文本文件方式显示详细计算结果。文件名：Untitled.rcs

"按单元分类"的设计结果支持详细计算。

：对于选定构件，用简图的形式显示设计结果。

选择"按特性分类"时，生成在每个截面位置((I,M 和 J)处求得的最大内力，代表具有同一特性的所有单元。

全部：在设计结果对话框显示所有设计结果。

满足：在校核结果对话框中，只显示强度校核结果中满足设计要求(OK)的结果。

不满足：在校核结果对话框中，只显示强度校核结果中不满足设计要求(NG)的结果。

：选中此项，在模型视窗中选择并亮显选定的构件。

：关闭对话框。


02_柱配筋设计

Home > midas Gen 2017 > 11_设计 > 04_混凝土设计 > 01_混凝土构件设计 > 02_柱设计

柱配筋设计

  • 功 能

根据整个结构分析结果和定义的设计参数，自动进行钢筋混凝土柱构件配筋设计。

  • 命 令

从主菜单中选择　设计>钢筋混凝土构件配筋设计>柱配筋设计...。

  • 生成结果

按照混凝土设计荷载组合，计算每个单元在(I端,跨中和J端)位置处的最大轴力，双向弯矩和剪力，按双偏压的计算方法进行配筋设计，并根据P-M关系图表求出有关的设计强度比。按照混凝土设计荷载组合，考虑每个截面特性的所有单元和截面位置，得到P-M图表中的最大强度比，在此基础上按照截面特性整理自动设计结果。

按照截面特性号得到的自动设计结果是根据混凝土设计用荷载组合下同种截面特性的所有构件得到的最大配筋结果进行输出。

如果自动设计结果满足给定的特性，则结果显示蓝色，否则显示为红色。

按用户输入的主筋(最多5种类型)和箍筋(1种类型)，设计最优化的钢筋规格和数量，满足间距和配筋率的要求。

按用户选择的单位体系生成设计结果。

构件：构件编号

截面：截面特性编号

Bc,Hc：柱构件的宽度和高度

fcu：混凝土极限抗压强度

fyk：主筋强度标准值

fvk ：抗剪钢筋强度标准值

CHK：设计结果的判断

"OK"：自动设计结果满足设计轴力、弯矩和剪力的设计强度要求

"P**"：自动设计结果不满足轴力的设计强度要求

"*M*"：自动设计结果不满足弯矩的设计强度要求

"**V"：自动设计结果不满足剪力的设计强度要求

"PM*"：自动设计结果不满足轴力、弯矩的设计强度要求

"*MV"：自动设计结果不满足弯矩、剪力的设计强度要求

"P*V"：自动设计结果不满足轴力、剪力的设计强度要求

"PMV"：自动设计结果不满足轴力、弯矩和剪力的设计强度要求

LCB：得到由P-M图表确定的最大强度比的荷载组合号，程序检查所有荷载组合和相应单元或截面特性，确定最大强度比。

Uc：最大轴压比；

Rat-Uc：最大轴压比与规范限值的比值；

N：对应LCB荷载组合，作用在柱构件上的设计轴力。

N>0：作用在构件上的轴向压力

N<0：作用在构件上的轴向拉力

Rat-N：设计轴力(N)和截面轴向设计强度(Nr)的比值，比值大于1.0表示设计强度不满足，即使增加钢筋数量至最大配筋率，或采用最小钢筋间距也不能满足要求。

M：对应LCB荷载组合，作用在构件上的设计弯矩。

Rat-M：设计弯矩（M)和截面抗弯设计强度(Mr)的比值，比值大于1.0表示设计强度不满足，即使增加钢筋数量至最大配筋率，或采用最小钢筋间距也不能满足要求。

Ast：程序自动计算的主筋面积，应大于规范指定的最小配筋面积。

V-Rebar：程序按照规范的设计构造要求，配置的钢筋规格和钢筋数量。

符号：n1 - n2 - Dxx

n1：主筋总数；n2：主筋层数，Dxx：主筋标准规格

V：对应LCB荷载组合，构件的最大设计剪力。

Rat-V：设计剪力(V)和截面抗剪设计强度(Vcs)的比值，比值大于1.0表示设计强度不满足，即使增加钢筋数量至最大配筋率，或采用最小钢筋间距也不能满足要求。

As-H：程序计算的所需的抗剪箍筋截面面积(长度单位2/m)，不小于规范规定的最小体积配箍率。

H-Rebar：按用户输入的箍筋标准规格，根据As-H配置的抗剪箍筋。

普通控制

GB50010-02：显示自动设计使用的规范。

："按单元分类"显示设计结果，其中包括根据P-M关系图表得到的最大强度比以及在截面(I,1/4,1/2,3/4 和 J)位置所有荷载组合产生的设计剪力。

"按特性分类"显示设计结果，其中包括根据P-M关系图表得到的最大强度比以及代表同一属性所有单元的设计剪力。既然结果不属于某个单元，NOEL(单元编号)为"0"。

选定特性后，SEL控制控制具有同一截面特性的所有单元。

：显示用户选择的单位体系。

：自动设计中选择主筋的搭接方式选项，该选项用于确定钢筋间距。

自动设计默认选择50% (50%搭接)。

= 无：不考虑搭接计算主筋数量

= 50%：考虑50%搭接计算主筋数量

= 100%：考虑100%搭接计算主筋数量

：按单元生成设计结果时，选择是否按截面编号或单元编号升序排列结果。

：将配筋结果赋予构件，在?编辑验算用柱截面数据?中可以看到构件配筋结果，在验算截面及做PUSHOVER分析时需要用到截面实配钢筋结果。

：选择所有构件

：取消选定的所有构件

重新设计选定的构件。

：显示自动设计详细结果

：显示自动设计简单结果

：对于选定构件，以文本文件的方式显示简要的计算结果。文件名：Untitled.rcs

：对于选定构件，以文本文件方式显示详细计算结果。文件名：Untitled.rcs

"按单元分类"的设计结果支持详细计算。

：对于选定构件，用简图的形式显示设计结果。

选择按?特性值?分类时，生成与最大配筋相应的内力，代表具有同一特性的所有构件。

用轴力和双向弯矩绘制结果和相应的P-M图表。

全部：在设计结果对话框显示所有设计结果。

满足：在校核结果对话框中，只显示强度校核结果中满足设计要求(OK)的结果。

不满足：在校核结果对话框中，只显示强度校核结果中不满足设计要求(NG)的结果。

：选中此项，在模型视窗中选择并亮显选定的构件。

：关闭对话框。


03_支撑配筋设计

Home > midas Gen 2017 > 11_设计 > 04_混凝土设计 > 01_混凝土构件设计 > 03_支撑设计

支撑配筋设计

  • 功 能

根据整个结构分析结果和定义的设计参数，按照选定的规范自动设计混凝土支撑构件。

  • 命 令

从主菜单中选择　设计>钢筋混凝土构件配筋设计>支撑配筋设计...。

  • 生成结果

按照混凝土设计荷载组合，计算每个单元在I,1/4,1/2,3/4 及J位置处的最大轴力，双向弯矩和剪力，在此基础上按照单元整理设计结果。根据P-M关系图表求与设计强度有关的设计强度比。

按照混凝土设计荷载组合，考虑每个截面特性的所有单元和截面位置，得到P-M图表中的最大强度比，在此基础上按照截面特性整理设计结果。

如果自动设计结果满足给定的特性，则结果显示蓝色，否则显示为红色。

按用户输入主筋(最多5种类型)和箍筋(1种类型)，设计最优化的钢筋规格和数量，满足间距和配筋率的要求。

按用户选择的单位体系生成设计结果。

MEMB：单元编号

SECT：截面特性编号

Bc, Hc：支撑构件的宽度和高度

fcu：混凝土极限抗压强度

fyk：主筋强度标准值

fvk：抗剪钢筋强度标准值

CHK：自动设计结果

"OK"：设计结果满足设计轴力、弯矩和剪力的设计强度要求

"P**"：设计结果不满足设计轴力的设计强度要求

"*M*"：设计结果不满足设计弯矩的设计强度要求

"**V"：设计结果不满足设计剪力的设计强度要求

"PM*"：设计结果不满足设计轴力、弯矩的设计强度要求

"*MV"：设计结果不满足设计弯矩、剪力的设计强度要求

"P*V"：设计结果不满足设计轴力、剪力的设计强度要求

"PMV"：设计结果不满足设计轴力、弯矩和剪力的设计强度要求

LCB：得到由P-M图表确定的最大强度比的荷载组合，程序检查所有荷载组合和相应单元或截面特性，确定最大强度比。

N：对应LCB荷载组合，作用在支撑构件上的设计轴力。

N>0：作用在构件上的轴向压力

N<0：作用在构件上的轴向拉力

Rat-N：设计轴力(N)和轴向设计强度(Nr)的比值，比值大于1.0表示设计强度不满足，即使增加钢筋数量至最大配筋率，或采用最小钢筋间距也不能满足要求。

M：对应LCB荷载组合，作用在支撑构件上的设计弯矩，其值计算如下：

Rat-M：设计弯矩(M)和抗弯设计强度(Mr)的比值，比值大于1.0表示设计强度不满足，即使增加钢筋数量至最大配筋率，或采用最小钢筋间距也不能满足要求。

Ast：程序自动计算的主筋面积，应大于规范规定的最小配筋面积。

V-Rebar：程序按优化原则配置的钢筋规格和钢筋数量。

符号：n1- n2-(Dxx)

(n1：主筋数量；n2：主筋层数， Dxx：主筋的标准规格)

Vu：对应LCB荷载组合，构件的最大设计剪力。

Rat-V：设计剪力(V)和抗剪设计强度(Vcs)的比值，比值大于1.0表示设计强度不满足，即使增加钢筋数量至最大配筋率，或采用最小钢筋间距也不能满足相应支撑截面的要求。

As-H：程序计算的所需的抗剪箍筋截面面积(长度单位2/m)，以及规范规定的最小配箍量。

H-Rebar：按用户输入的箍筋标准规格，根据As-H配置的抗剪钢筋。

普通控制

GB50010-02：显示自动设计使用的规范。

："按单元分类"显示设计结果，其中包括根据P-M关系图表得到的最大强度比以及在截面(I,1/4,1/2,3/4 & J)位置所有荷载组合产生的设计剪力。

"按属性分类"显示设计结果，其中包括根据P-M关系图表得到的最大强度比以及代表同一属性所有单元的设计剪力。既然结果不属于某个单元，NOEL(单元编号)为"0"。

选定特性后，SEL控制具有同一截面特性的所有单元。

：显示用户选择的单位体系。

：自动设计中选择主筋的搭接方式选项，该选项用于确定钢筋间距。

自动设计默认选择 50% (50%搭接)。

None：不考虑搭接计算主筋数量

50%：考虑50%搭接计算主筋数量

100%：考虑100%搭接计算主筋数量

：按单元生成设计结果时，选择是否按截面编号或单元编号升序排列结果。

：将配筋结果赋予构件，在?编辑验算用支撑截面数据?中可以看到构件配筋结果，在验算截面及做PUSHOVER分析时需要用到截面实配钢筋结果。

：选择所有构件

：取消选定的所有构件

：重新设计选定的构件。

：显示自动设计详细结果

：显示自动设计简单结果

：对于选定构件，以文本文件的方式显示简要的计算结果。文件名：Untitled.rcs

：对于选定构件，以文本文件方式显示详细计算结果。文件名：Untitled.rcs

"按单元分类"的设计结果支持详细计算。

：对于选定构件，以简图的形式显示设计结果。

选择"按特性分类"时，生成与最大配筋相应的内力，代表具有同一特性的所有构件。

用轴力和双向弯矩绘制结果和相应的P-M图表。

全部：在设计结果对话框显示所有设计结果。

满足：在校核结果对话框中，只显示强度校核结果中满足设计要求(OK)的结果。

不满足：在校核结果对话框中，只显示强度校核结果中不满足设计要求(NG)的结果。

：选中此项，在模型视窗中选择并亮显选定的构件。

：关闭对话框。


04_墙配筋设计

Home > midas Gen 2017 > 11_设计 > 04_混凝土设计 > 01_混凝土构件设计 > 04_墙设计

墙配筋设计

  • 功 能

根据整个结构分析结果和定义的设计参数，根据选定的规范设计混凝土剪力墙构件。

  • 命 令

从主菜单中选择　设计>钢筋混凝土构件配筋设计>墙配筋设计...。

  • 生成结果

按照混凝土设计荷载组合，计算每个单元在I和J位置处的最大轴力，双向弯矩和剪力，按照偏心受压构件进行配筋，按照?剪力墙ID+楼层?整理自动设计结果，并根据P-M关系图表求出与设计强度有关的强度比。

按照混凝土设计荷载组合，考虑每个单元、截面位置的墙体ID+楼层，计算由P-M图表导出的最大竖向配筋率，并按照?剪力墙ID?整理设计结果。

如果设计结果满足设计要求，则结果显示蓝色，否则显示为红色。

按用户选择的单位体系生成设计结果。

按用户输入钢筋信息(竖向钢筋－最多5种类型，端部钢筋，水平钢筋规格)，程序按优化原则自动设计钢筋规格和钢筋间距(竖向和水平)，满足最小间距和最小配筋率的要求。

墙号+层：墙体编号和楼层

墙号(WID)：用户输入的墙体编号

层：结构分析模型中定义的楼层名称

墙标志：剪力墙标志

Lw：剪力墙构件的长度

HTw：剪力墙构件的高度

hw：剪力墙构件的厚度

fcu：混凝土极限抗压强度

fyk：竖向钢筋强度标准值

fvk：水平向钢筋强度标准值

CHK：自动设计结果

"OK"：设计结果满足设计轴力、弯矩和剪力的设计强度要求

"P**"：设计结果不满足设计轴力的轴向设计强度要求

"*M*"：设计结果不满足设计弯矩的设计强度要求

"**V"：设计结果不满足设计剪力的设计强度要求

"PM*"：设计结果不满足设计轴力、弯矩的设计强度要求

"*MV"：设计结果不满足设计弯矩、剪力的设计强度要求

"P*V"：设计结果不满足设计轴力、剪力的设计强度要求

"PMV"：设计结果不满足设计轴力、弯矩和剪力的设计强度要求

Uc: 剪力墙肢轴压比

Rat-Uc：剪力墙肢轴压比与轴压比限值的比值

q:作用于墙顶组合的等效竖向均布荷载设计值

Rat-q:等效竖向均布荷载设计值与限值的比值

N：对应LCB荷载组合，作用在剪力墙构件上的轴力

N > 0：作用在构件上的轴向压力

N < 0：作用在构件上的轴向拉力

M,LCB：构件的设计弯矩以及相应的荷载组合。

AsV：程序计算的竖向配筋量(长度单位2/长度单位x100)，列出计算配筋面积和规范要求的最小配筋面积两者之间的较大者。端部钢筋的配筋量单独给出，不包括在AsV中。

V-rebar：按用户输入的钢筋规格，根据AsV求得的实配竖向钢筋。

V,LCB：构件的设计剪力及相应的荷载组合。

AsH：程序计算的水平抗剪配筋面积(长度单位2/长度单位x100)，列出计算配筋面积和规范要求的最小配筋面积两者之间的较大者。

H-rebar：按用户输入的钢筋规格，根据AsH求得的实配的水平钢筋。

端部钢筋：根据用户输入的钢筋规格，程序自动计算和配置的端部钢筋。

自动设计结果的端部钢筋显示如下：

"nn-Dxx@yyy"

其中nn是端部钢筋数量， xx是指定标准钢筋规格，yyy是钢筋间距（单位：毫米）。

"不使用"

不满足规范指定的最小钢筋间距，或者墙体厚度不满足配筋要求。

钢筋层：竖向钢筋放置的层数。

普通控制

GB50010-02(方法1）

显示可供自动设计使用的规范及设计方法(在方法1、方法2、方法3、方法4中选择)。

?按墙体ID+楼层分类?显示设计结果，其中包括根据P-M关系图表得到的最大竖向钢筋配筋率和在位置(I 和J)处所有荷载组合产生的设计剪力。

?按墙体ID分类?显示设计结果，其中包括根据P-M关系图表得到的最大强度比以及检查同一长度和厚度的所有剪力墙构件的设计剪力。既然结果不属于某一个单元，?墙体ID+楼层?为?0?。

选定墙体ID后，SEL控制属于同一?墙体ID?的各个?墙体ID+楼层?。

：按墙体ID+楼层生成自动设计结果时，选择是否按墙体ID编号或者楼层编号升序排列结果。

：按墙体ID编号生成自动设计结果时，选择按墙体ID编号或者墙体标志升序排列结果。

：显示用户选择的单位体系。

：将配筋结果赋予构件，在?编辑验算用墙截面数据?中可以看到构件配筋结果，在验算截面及做PUSHOVER分析时需要用到截面实配钢筋结果。

：选择所有构件

：取消选定的所有构件

重新设计选定的构件，按照?墙体ID+楼层分类?重新设计时，包括用墙体ID定义的所有墙体。

：显示设计详细结果

：显示设计简单结果

：对于选定构件，以文本文件的方式显示简要的计算结果。

：对于选定构件，以文本文件的方式显示详细的计算结果。

按?墙体ID+楼层分类?的设计结果支持详细计算。

：对于选定构件，以简图形式显示设计结果。

用轴力和双向弯矩绘制结果和相应的P-M图表

   ：选中此项，在模型视窗中选择并亮显选定的构件。

：关闭对话框。

：按照墙体标志和楼层墙体ID排列自动设计结果。

选择分类类别。

选择列表

选择墙体构件的名称列表。

打印列表

选定墙体构件的名称列表。

选择楼层排序方式(升序或降序）。

选择：选择生成结果的楼层

楼层：指定楼层

：从选择列表选择墙体ID或者墙体标志，然后发送到打印列表中去。

：从打印列表中删除墙体ID或者墙体标志。

：选择所有楼层

：取消选择所有楼层

对于选定构件，生成设计结果汇总表，在选定层生成每个墙体ID或者墙体标志的最大值。

生成选定层的每个墙体ID或者墙体标志所需的钢筋数量。

：关闭对话框。


05_加腋梁设计

Home > midas Gen 2017 > 11_设计 > 04_混凝土设计 > 01_混凝土构件设计 > 05_加腋梁设计

加腋梁设计

  • 功 能

根据整个结构的分析结果和定义的设计参数，自动设计钢筋混凝土加腋梁。

  • 命 令

从主菜单中选择　设计>钢筋混凝土构件配筋设计>加腋梁设计...。

  • 生成结果

根据混凝土设计荷载组合，计算每个单元在I,1/4,1/2,3/4及J位置处的最大正负弯矩和剪力，自动计算截面配筋量，按照构件排序输出每个单元的设计结果；若按截面特性值排序输出设计结果，程序是考虑每个截面特性值的所有单元和截面位置，得到计算的最大配筋量，在此基础上按照截面特性值输出设计结果。


01_梁截面验算

Home > midas Gen 2017 > 11_设计 > 04_混凝土设计 > 02_混凝土构件验算 > 01_梁截面验算

梁截面验算

  • 功 能

根据整个结构分析结果和补充设计参数，根据如下规范校核混凝土梁构件的强度：中国混凝土结构设计规范（GB50010-02)、美国混凝土学会(ACI318-89、 ACI318-95 和ACI 318-99)，韩国建筑学会(AIK-USD94)，韩国混凝土学会(KCI-USD99)，韩国土木工程师协会(KSCE-USD96)。

  • 命 令

从主菜单中选择 设计>钢筋混凝土截面验算>梁截面验算...

  • 生成结果

按照混凝土设计荷载组合，计算每个单元在I端,中央及J端的正负最大弯矩和剪力，在此基础上按照单元整理强度校核结果。

按照混凝土设计荷载组合，考虑每个截面特性的所有单元和截面位置，得到计算的最大配筋量，在此基础上按照截面特性整理强度校核结果。

如果自动设计结果满足给定的特性，则结果显示蓝色，否则显示为红色。

根据用户输入的主筋(直径、数量)，箍筋(直径、数量)，设计参数等信息或者自动设计结果来进行强度校核。

没有钢筋数据，不能校核强度。

      MEMB：单元号

SECT：截面特性编号

      Span：梁构件长度

      Bc, Hc：梁构件宽度，高度（深度）

      bf, hf：T形截面翼缘宽度，厚度

      fcu：混凝土极限抗压设计强度

      fyk：主筋强度标准值

      fvk：抗剪箍筋强度标准值

      Pos：强度校核位置(I,M,J)

设计结果M表示关于1/4, 1/2 及 3/4 这些点处的正负最大弯矩和剪力的强度校核结果。

  CHK：强度校核结果

  = "OK"：强度校核结果满足设计正负弯矩和剪力的设计强度要求。

  = "N**"：强度校核结果不满足设计负弯矩的设计强度要求。

  = "*P*"：强度校核结果不满足设计正弯矩的设计强度要求。

  = "**V"：强度校核结果不满足设计剪力的设计强度要求。

  = "NP*"：强度校核结果不满足设计正负弯矩的设计强度要求。

  = "*PV"：强度校核结果不满足设计正弯矩和剪力的设计强度要求。

  = "N*V"：强度校核结果不满足设计负弯矩和剪力的设计强度要求。

  = "NPV"：强度校核结果不满足设计正负弯矩和剪力的设计强度要求。

  AsTop：用户输入截面上部主筋面积或者由程序自动设计。

  AsBot:：用户输入截面下部主筋面积或者由程序自动设计。

  N（-）M, LCB：在相应的单元或截面及荷载组合下出现的设计最大负弯矩。

  N（-）Mr：根据梁构件给定截面的尺寸和钢筋布置位置计算的设计最大负抗弯强度。

  RatN：如果设计负弯矩/设计负抗弯强度超过1.0，则用红色显示。

  P(+)M, LCB：在相应的单元或截面及荷载组合下出现的设计最大正弯矩。

  P(+)Mr：根据梁构件给定截面的尺寸和钢筋布置位置计算的最大设计正抗弯强度。

  RatP：如果设计正弯矩/设计正抗弯强度超过1.0，则用红色显示。

  V, LCB：在相应的单元或截面及荷载组合下出现的设计最大剪力。

  Vc：梁构件混凝土设计抗剪强度。

  ACI318-89, ACI318-95 & ACI318-99, Vc =

  KCI-USD99, Vc =

  KSCE-USD96, Vc =

  AIK-USD94, Vc =

  RatV：如果设计剪力/设计抗剪强度超过1.0，则用红色显示。

普通控制

设计标准GB50010-02：显示强度校核使用的规范。

"按构件分类"显示强度校核结果，包括由所有荷载组合中挑选出的在截面 (I,M和J)位置处的正负最大弯矩和最大剪力。

"按特性值分类"显示强度校核结果，在截面位置(I, M和J)处显示正负最大弯矩和最大剪力，截面位置代表相同截面特性的所有单元。既然结果不属于某一个单元，NOEL(单元编号)为"0"。

选定特性后，SEL控制具有同一截面特性的所有单元。

：显示用户选择的单位体系。

：选择所有构件

：取消选定的所有构件

重新对选定的构件进行强度校核。按照截面特性显示重新校核结果时，具有同一截面特性的所有单元均包括在内。

：显示强度校核详细结果

：显示强度校核简单结果

：选择输出数据中包括的截面位置。

：对于选定构件，用简要计算结果显示强度校核结果。

：对于选定构件，用详细计算结果显示强度校核结果。

"按单元分类"的校核结果支持详细计算。

：对于选定构件，生成自动设计结果汇总表。

当选定"按特性分类"时，生成同一特性的所有构件的最大配筋量结果。

当RatN，RatP和RatV超过1.0时，输出数据的右方显示"*"。

= 全部：在校核结果对话框中显示所有强度校核结果。

= 满足：在校核结果对话框中，只显示强度校核结果中满足设计要求(OK)的结果。

= 不满足：在校核结果对话框中，只显示强度校核结果中不满足设计要求(NG)的结果。

：选中此项，在模型视窗中选择并亮显选定构件。

：关闭对话框。


02_柱截面验算

Home > midas Gen 2017 > 11_设计 > 04_混凝土设计 > 02_混凝土构件验算 > 02_柱截面验算

柱截面验算

  • 功 能

根据整个结构分析结果和补充的设计参数，根据如下规范校核混凝土柱构件的强度：中国混凝土结构设计规范（GB50010-02)、美国混凝土学会(ACI318-89、 ACI318-95 和ACI 318-99)，韩国建筑学会(AIK-USD94)，韩国混凝土学会(KCI-USD99)，韩国土木工程师协会(KSCE-USD96)。

  • 命 令

从主菜单中选择　设计>钢筋混凝土截面验算>柱截面验算...

  • 生成结果

按照混凝土设计荷载组合，计算每个单元在I,中央 和 J位置处的最大轴力，弯矩和剪力产生的强度比，在此基础上按照单元整理强度校核结果。根据P-M关系图表求出与设计强度相应的最大强度比。

按照混凝土设计荷载组合，考虑每个截面特性的所有单元，计算P-M图表中的最大强度比，在此基础上按照截面特性整理强度校核结果。

如果自动设计结果满足给定的特性，则结果显示蓝色，否则显示为红色。

根据用户输入的主筋(直径、数量)，辅筋(直径、数量)，设计参数等信息或者自动设计结果来进行强度校核。

没有钢筋数据，不能校核强度。

在用户选择的单位系统中生成强度校核结果。

MEMB：单元编号

SECT：截面属性编号

Bc,Hc：柱构件的宽度、高度（深度）

fcu：混凝土极限抗压强度

fyk：主筋强度标准值

fvk：抗剪箍筋强度标准值

CHK：强度校核结果

= "OK"：强度校核结果满足设计轴力、弯矩和剪力的设计强度要求

= "P**"：强度校核结果不满足设计轴力的设计强度要求

= "*M*"：强度校核结果不满足设计弯矩的设计强度要求

= "**V"：强度校核结果不满足设计剪力的设计强度要求

= "PM*"：强度校核结果不满足设计轴力、弯矩的设计强度要求

= "*MV"：强度校核结果不满足设计弯矩、剪力的设计强度要求

= "P*V"：强度校核结果不满足设计轴力、剪力的设计强度要求

= "PMV"：强度校核结果不满足设计轴力、弯矩和剪力的设计强度要求

LCB：由P-M图表确定最不利的荷载组合，程序检查所有荷载组合和相应单元截面特性，确定最大比率。

V-Rebar：用户输入主筋标准规格和数量或者在自动设计时由程序修改。

符号： n1 - n2 - #xx(Dxx)

(n1：主筋数量，n2：主筋排数， #xx(Dxx)：主筋标准尺寸)

N：在LCB中显示的荷载组合下作用在柱构件上的设计轴力。

= N > 0：作用在构件上的轴向压力

= N < 0：作用在构件上的轴向拉力

Rat-N：设计轴力和设计轴向强度的比值，比值大于1.0表示柱构件现有的钢筋和截面不能满足设计强度要求。

M：在LCB中显示的荷载组合下作用在柱构件上的设计弯矩。

Rat-N：设计弯矩和设计抗弯强度的比值，比值大于1.0表示柱构件现有的钢筋和截面不能满足设计强度要求。

V：在5个截面位置处，所有荷载组合情况下相应单元和截面的最大剪力。

Rat-V：设计剪力和设计抗剪强度的比值，比值大于1.0表示柱构件现有的钢筋和截面不能满足设计强度要求。

As-H:每延米的箍筋配筋面积。

H-Rebar：实配箍筋。

以下是美国规范验算内容：

D_nsy：用户直接输入或者程序计算的两端固定的柱的弯矩放大系数，反映柱构件端部之间的曲率，支撑绕局部y轴的弯矩乘以这个系数。注：此部分属于美国规范验算的内容。

D_nsz：用户直接输入或者程序计算的两端固定的柱的弯矩放大系数，反映柱构件端部之间的曲率，支撑绕局部z轴的弯矩乘以这个系数。注：此部分属于美国规范验算的内容。

Mcy：放大后的绕局部y轴的弯矩。

Mcz：放大后的绕局部z轴的弯矩。

RatMy：绕强轴的设计弯矩和设计抗弯强度的比值，比值大于1.0表示柱构件现有的钢筋和截面不能满足设计强度要求。

RatMz：绕弱轴的设计弯矩和设计抗弯强度的比值，比值大于1.0表示柱构件现有的钢筋和截面不能满足设计强度要求。

Vu：在5个截面位置处，所有荷载组合情况下相应单元和截面的最大剪力。

Rat-V：设计剪力和设计抗剪强度的比值。

普通控制

GB50010-02：显示强度校核使用的规范

"按单元分类"显示强度校核结果，其中包括根据P-M关系图表得到的最大强度比以及在截面I,1/4,1/2,3/4 & J位置处所有荷载组合产生的剪力。

"属性分类"显示强度校核结果，其中包括根据P-M关系图表得到的最大强度比以及同一特性所有单元的设计剪力。既然结果不属于某一个单元，NOEL(单元编号)为"0"。

选定特性后，SEL控制具有同一截面特性的所有单元。

：显示用户选择的单位系统。

：选择所有构件

：取消选定的所有构件

重新对选定的构件进行强度校核。按照截面特性显示重新校核结果时，具有同一截面特性的所有单元均包括在内。

：显示强度校核详细结果

：显示强度校核简单结果

：对于选定构件，用简要计算结果显示强度校核结果。

：对于选定构件，用详细计算结果显示强度校核结果。

"按单元分类"的校核结果支持详细计算。

：对于选定构件，生成自动设计结果汇总表。

当选定"按截面分类"时，生成同一截面属性的所有构件的最大钢筋数量。

用轴力和双向弯矩绘制结果和相应的P-M图表。

= 全部：在校核结果对话框显示所有强度校核结果。

= 满足：在校核结果对话框中，只显示强度校核结果中满足设计要求(OK)的结果。

= 不满足：在校核结果对话框中，只显示强度校核结果中不满足设计要求(NG)的结果。

：选中此项，在模型视窗中选择并亮显选定构件。

：关闭对话框。


03_支撑截面验算

Home > midas Gen 2017 > 11_设计 > 04_混凝土设计 > 02_混凝土构件验算 > 03_支撑截面验算

支撑截面验算

  • 功 能

根据整个结构分析结果和补充的设计参数，根据如下规范校核混凝土支撑构件的强度：中国混凝土结构设计规范（GB50010-02)、美国混凝土学会(ACI318-89、ACI318-95 和ACI 318-99)，韩国建筑学会(AIK-USD94)，韩国混凝土学会(KCI-USD99)，韩国土木工程师协会(KSCE-USD96)。

  • 命 令

从主菜单中选择　设计>钢筋混凝土截面演算>支撑截面验算...

  • 生成结果

按照混凝土设计荷载组合，计算每个单元在I,1/4,1/2,3/4 和 J位置处的最大轴力，弯矩和剪力产生的强度比，在此基础上按照单元整理强度校核结果。根据在P-M关系图表求出与设计强度相应的最大强度比

按照混凝土设计荷载组合，考虑每个截面特性的所有单元，计算P-M图表中的最大强度比，在此基础上按照截面特性生成强度校核结果。

如果自动设计结果满足给定的特性，则结果显示蓝色，否则显示为红色。

根据用户输入的主筋(直径、数量)，箍筋(直径、数量)，设计参数等信息或者自动设计结果来进行强度校核。

没有钢筋数据，不能校核强度。

在用户选择的单位系统中生成强度校核结果。

MEMB：单元编号

SECT：截面特性编号

Bc, Hc：支撑构件的宽度、高度（深度）

fcu：混凝土极限抗压强度

fyk：主筋强度标准值

fvk：抗剪箍筋强度标准值

CHK：强度校核结果

= "OK"：强度校核结果满足设计轴力、弯矩和剪力的设计强度要求

= "P**"：强度校核结果不满足设计轴力的设计强度要求

= "*M*"：强度校核结果不满足设计弯矩的设计强度要求

= "**V"：强度校核结果不满足设计剪力的设计强度要求

= "PM*"：强度校核结果不满足设计轴力、弯矩的设计强度要求

= "*MV"：强度校核结果不满足设计弯矩、剪力的设计强度要求

= "P*V"：强度校核结果不满足设计轴力、剪力的设计强度要求

= "PMV"：强度校核结果不满足设计轴力、弯矩和剪力的设计强度要求

LCB：由P-M图表确定最不利的荷载组合，程序检查所有荷载组合和相应单元和截面特性，确定最大比率。

V-Rebar：用户输入主筋标准规格和数量或者在自动设计时由修改。

    符号： n1 - n2 - #xx(Dxx)

  (n1：主筋数量，n2：主筋排数， #xx(Dxx)：主筋标准规格)

N：在LCB中显示的荷载组合下作用在支撑构件上的设计压(拉)力。

    = N> 0：作用在构件上的轴向压力

    = N< 0：作用在构件上的轴向拉力

Rat-N：设计轴力和设计轴向强度的比值，比值大于1.0表示支撑构件现有的钢筋和截面不能满足设计强度要求。

My：绕强轴（y轴）的弯矩。

Mz：绕弱轴（z轴）的弯矩。

RatMy：绕强轴的设计弯矩和设计抗弯强度的比值，比值大于1.0表示支撑构件现有的钢筋和截面不能满足设计强度要求。

RatMz：绕弱轴的设计弯矩和设计抗弯强度的比值，比值大于1.0表示支撑构件现有的钢筋和截面不能满足设计强度要求。

V：在5个截面位置处，所有荷载组合情况下相应单元和截面的最大剪力。

Rat-V：设计剪力和设计抗剪强度的比值。

普通控制

设计标准GB50010-02：显示强度校核使用的规范

"按单元分类"显示强度校核结果，其中包括根据P-M关系图表得到的最大强度比以及在截面(I,1/4,1/2,3/4 及 J)位置处所有荷载组合产生的剪力。

"按特性分类"显示强度校核结果，其中包括根据P-M关系图表得到的最大强度比以及同一特性所有单元的设计剪力。既然结果不属于某一个单元，NOEL(单元编号)为"0"。

选定特性后，SEL控制具有同一截面特性的所有单元。

：显示用户选择的单位体系。

：选择所有构件

：取消选定的所有构件

重新对选定的构件进行强度校核。按照截面特性显示重新校核结果时，具有同一截面特性的所有单元均包括在内。

：显示强度校核详细结果

：显示强度校核简单结果

：对于选定构件，用简要计算结果显示强度校核结果。

：对于选定构件，用详细计算结果显示强度校核结果。

"按单元分类"的校核结果支持详细计算。

：对于选定构件，生成自动设计结果汇总表。

当选定"按特性分类"时，生成同一特性的所有构件的最大配筋量结果

用轴力和双向弯矩绘制结果和相应的P-M图表。

= 全部：在校核结果对话框显示所有强度校核结果。

= 满足：在校核结果对话框中，只显示强度校核结果中满足设计要求(OK)的结果。

= 不满足：在校核结果对话框中，只显示强度校核结果中不满足设计要求(NG)的结果。

：选中此项，在模型视窗中选择并亮显选定构件

：关闭对话框。


04_墙截面验算

Home > midas Gen 2017 > 11_设计 > 04_混凝土设计 > 02_混凝土构件验算 > 04_墙截面验算

墙截面验算

  • 功 能

根据整个结构分析结果和补充的设计参数，根据如下规范校核混凝土墙构件的强度：中国混凝土结构设计规范（GB50010-02)、美国混凝土学会(ACI318-89、 ACI318-95 和ACI 318-99)，韩国建筑学会(AIK-USD94)，韩国混凝土学会(KCI-USD99)，韩国土木工程师协会(KSCE-USD96)。

  • 命 令

从主菜单中选择设计 > 钢筋混凝土截面验算>墙截面验算...

  • 生成结果

按照混凝土设计荷载组合，计算每个单元在I,1/4,1/2,3/4 和 J位置处的最大轴力，弯矩和剪力产生的强度比，在此基础上按照单元整理强度校核结果。根据P-M关系图表求出与设计强度相应的最大强度比。

按照混凝土设计荷载组合，考虑每个截面特性的所有单元，计算P-M图表中的最大强度比，在此基础上按照截面特性整理强度校核结果。

如果自动设计结果满足给定的特性，则结果显示蓝色，否则显示为红色。

根据用户输入的主筋(直径、数量)，辅筋(直径、数量)，设计参数等信息或者自动设计结果来进行强度校核。

没有钢筋数据，不能校核强度。

在用户选择的单位系统中生成强度校核结果。

WID：墙号

Wall Mark：墙标志

Lw:剪力墙宽度

HTw:剪力墙高度

fcu：混凝土极限抗压强度

hw:墙厚

fyk：主筋强度标准值

fvk：抗剪钢筋强度标准值

CHK：强度校核结果

= "OK"：强度校核结果满足设计轴力、弯矩和剪力的设计强度要求

= "P**"：强度校核结果不满足设计轴力的设计强度要求

= "*M*"：强度校核结果不满足设计弯矩的设计强度要求

= "**V"：强度校核结果不满足设计剪力的设计强度要求

= "PM*"：强度校核结果不满足设计轴力、弯矩的设计强度要求

= "*MV"：强度校核结果不满足设计弯矩、剪力的设计强度要求

= "P*V"：强度校核结果不满足设计轴力、剪力的设计强度要求

= "PMV"：强度校核结果不满足设计轴力、弯矩和剪力的设计强度要求

LCB：由P-M图表确定最不利荷载组合，程序检查所有荷载组合和相应单元截面特性，确定最大比率

N：作用在墙构件上的最大设计轴力。

Ratio：设计弯矩和设计抗弯强度的比值，比值大于1.0表示柱构件现有的钢筋和截面不能满足设计强度要求。

Rat-V：设计剪力和设计抗剪强度的比值，比值大于1.0表示柱构件现有的钢筋和截面不能满足设计强度要求。

M：墙的设计弯矩。

V：墙的设计剪力。

As-V:墙截面每延米竖向钢筋配筋面积。

As-H:墙截面每延米水平向钢筋配筋面积。

V-Rebar:墙截面竖向实配钢筋。

H-Rebar:墙截面水平向实配钢筋。

普通控制

GB-50010-02：显示强度校核使用的规范

"按单元分类"显示强度校核结果，其中包括根据P-M关系图表得到的最大强度比以及在截面I,1/4,1/2,3/4 & J位置处所有荷载组合产生的剪力。

"属性分类"显示强度校核结果，其中包括根据P-M关系图表得到的最大强度比以及同一特性所有单元的设计剪力。既然结果不属于某一个单元，NOEL(单元编号)为"0"。

选定特性后，SEL控制具有同一截面特性的所有单元。

：显示用户选择的单位系统。

：选择所有构件

：取消选定的所有构件

重新对选定的构件进行强度校核。按照截面特性显示重新校核结果时，具有同一截面特性的所有单元均包括在内。

：显示强度校核详细结果

：显示强度校核简单结果

：对于选定构件，用简要计算结果显示强度校核结果。

：对于选定构件，用详细计算结果显示强度校核结果。

"按单元分类"的校核结果支持详细计算。

：对于选定构件，生成自动设计结果汇总表。

当选定"按截面分类"时，生成同一截面属性的所有构件的最大钢筋数量。

用轴力和双向弯矩绘制结果和相应的P-M图表。

= 全部：在校核结果对话框显示所有强度校核结果。

= 满足：在校核结果对话框中，只显示强度校核结果中满足设计要求(OK)的结果。

= 不满足：在校核结果对话框中，只显示强度校核结果中不满足设计要求(NG)的结果。

：选中此项，在模型视窗中选择并亮显选定构件。

：关闭对话框。


01_板设计控制

Home > midas Gen 2017 > 11_设计 > 04_混凝土设计 > 03_板单元设计 > 01_板设计控制

板设计控制

  • 功 能

定义用于设计的板单元内力（Mxx和Myy）的取值规则。

（注意：该菜单对于中国规范（GB50010-10）不适用。）

  • 命 令

从主菜单中选择 设计> 设计 > 板单元设计 > 板设计控制

  • 输 入

在下图所示对话框中输入数据：

当不勾选“考虑Mxy（x-y plane扭矩）”时，板设计弯矩Mxx以及Myy按照相应的分析结果Mxx和Myy得到；

当勾选了“考虑Mxy（x-y plane扭矩）”时，板设计弯矩Mxx以及Myy按照相应的分析结果Mxx和Myy分别叠加上各自方向上的扭矩Mxy得到。


正常使用状态荷载组合类型1

Home > midas Gen 2017 > 11_设计 > 04_混凝土设计 > 03_板单元设计 > 02_正常使用状态荷载组合类型

正常使用状态荷载组合类型

  • 功 能

定义正常使用状态下荷载组合（基本组合）的类型。

  • 命 令

从主菜单中选择 设计> 设计 > 板单元设计 > 正常使用状态荷载组合类型

  • 输 入

在下图所示对话框中输入数据：

通过菜单： 结果 > 组合 > 荷载组合 定义的正常使用状态荷载组合（标准组合），在该对话框中进行选择分类，分别将其定义为“准永久”、“多遇”和“特征”三种子类型。

注意：在此定义的“准永久组合”为用于计算板挠度用的荷载组合，“多遇”和“特征”组合应用于欧洲规范。


03_板荷载组合

Home > midas Gen 2017 > 11_设计 > 04_混凝土设计 > 03_板单元设计 > 03_板荷载组合

板荷载组合

  • 功 能

定义用于板设计和验算所使用的荷载组合。

  • 命 令

从主菜单中选择 设计> 设计 > 板单元设计 > 板荷载组合

  • 输 入

在下图所示对话框中输入数据：

对话框中“强度验算”栏为通过菜单： 结果 > 组合 > 荷载组合 定义的基本组合；“使用性验算”和“挠度（开裂）”对应的栏中为通过菜单： 结果 > 组合 > 荷载组合 定义的标准组合。

注意：

1. 在“强度验算”栏中选择参与板配筋设计、配筋验算和冲切验算所起作用的荷载组合；

2. 在“使用性验算”栏中选择板的裂缝计算中所起作用的荷载组合，同时在在菜单 设计> 设计 > 板单元设计 > 正常使用状态荷载组合类型 的“准永久”及该菜单中的“使用性验算”中选中的荷载组合在挠度计算中起作用。

3. “挠度（开裂）”栏中的选项对应国外规范中计算挠度的荷载组合，而中国规范中挠度和裂缝的计算均为同一组荷载组合，即在“使用性能验算”中勾选。


04_设计用钢筋参数

Home > midas Gen 2017 > 11_设计 > 04_混凝土设计 > 03_板单元设计 > 04_设计用钢筋参数

设计用钢筋参数

  • 功 能

对于通过菜单 节点/单元 > 网格 > 定义子区域 中所定义的各子区域，通过此对话框定义子区域板的设计选筋参数。

在对各板进行设计配筋计算之后，通过该对话框设置的选筋参数，进行钢筋的自动优化配置。

  • 命 令

从主菜单中选择设计 > 板单元设计 > 设计用钢筋参数

  • 输 入

板基本构造筋

定义板的基本构造筋。

当通过菜单：节点/单元 > 网格 > 定义子区域 的对话框中已经定义了板的基本构造筋时，以定义子区域对话框中定义的基本构造为主。

1. 此处的基本构造筋为选筋配置时必须的配置钢筋；

2. 板的实际选筋结果中的钢筋配置由两部分组成，即此处的“板基本构造筋”的配筋结果和对话框中根据选筋参数（钢筋直径和间距）自动计算的配筋结果。

3. 当计算配筋结果大于“板基本构造筋”的配筋结果时，多余的配筋面积应按照选筋参数（钢筋直径和间距）进行自动配筋。

3. 当计算配筋结果小于“板基本构造筋”的配筋结果时，则不再另外进行选筋。

板设计

在 菜单：节点/单元 > 网格 > 定义子区域 中定义的子区域类型为“板”时，在此处设置其选筋参数。

筏板设计

在 菜单：节点/单元 > 网格 > 定义子区域 中定义的子区域类型为“筏板”时，在此处设置其选筋参数。

板带设计

在 菜单：节点/单元 > 平板结构 > 柱上板带 中定义并指定了柱上板带区域时，在此处设置其选筋参数

注：对话框中的 方向1 和 方向2 为钢筋的布置方向，在菜单“节点/单元 > 网格 > 定义子区域”中定义。


04_设计用钢筋参数

Home > midas Gen 2017 > 11_设计 > 04_混凝土设计 > 03_板单元设计 > 05_验算用板钢筋

验算用板钢筋

  • 功 能

按照名称组定义验算用的子区域板/筏板和柱上板带的实配钢筋。

通过在菜单 设计 > 板单元设计 > 板抗弯设计 的对话框中进行配筋设计之后，点击“更新钢筋”之后，所有参与设计的子区域板/筏板的设计选筋数据都更新到该对话框中。

通过在菜单 设计 > 板单元设计 > 柱上板带设计 的对话框中进行配筋设计之后，点击“更新钢筋”之后，所有参与设计的柱上板带的设计选筋数据都更新到该对话框中。

  • 命 令

从主菜单中选择设计 > 板单元设计 > 验算用板钢筋

  • 输 入

构件类型

选择定义验算用板钢筋的类型，类型分为前处理定义为子区域的“板/筏板”和定义为柱上板带的“柱上板带”。

类型名称：对于相同钢筋配置的“板/筏板”或者“柱上板带”定义一个类型名称

单元列表：输入一个类型名称中对应的所有的板单元的单元号，这些单元号的对应的钢筋配置相同。

板/筏板

构件类型选择“板/筏板”时，该区域亮显。用户设置某一类型名称对应的所有“板/筏板”单元的顶底面和两个方向上的钢筋配置情况。

柱顶

构件类型选择“柱上板带”时，该区域亮显。用户设置某一类型名称对应的所有“柱上板带”的顶底面和两个方向上的钢筋配置情况。

添加/替换：添加定义新的名称组至列表中，或者选中列表中的某名称组进行钢筋修改。

删除：选中列表中的某名称，对该名称以及其相应的钢筋配置进行删除。


04_设计用钢筋参数

Home > midas Gen 2017 > 11_设计 > 04_混凝土设计 > 03_板单元设计 > 06_板抗剪钢筋

板抗剪钢筋

  • 功 能

设柱区域板的抗剪钢筋，用于冲切验算。

注：该对话框不适用于中国规范。

  • 命 令

从主菜单中选择设计 > 板单元设计 > 板抗剪钢筋

  • 输 入

选项

添加/替换： 在模型中选择板单元，输入抗剪钢筋面积后，对板单元的抗剪钢筋值进行定义或修改；

删除： 在模型中选择已经定义抗剪钢筋的板单元，对定义的抗剪钢筋数据进行删除。

区域

Av（y-dir）：该板区域中柱的单元坐标y向的抗剪钢筋面积值；

Av（z-dir）：该板区域中柱的单元坐标z向的抗剪钢筋面积值；

间距

s：抗剪钢筋的间距。

屈服强度

fyt：抗剪钢筋的屈服受拉强度。


04_设计用钢筋参数

Home > midas Gen 2017 > 11_设计 > 04_混凝土设计 > 03_板单元设计 > 07_修改柱位置

修改柱位置

  • 功 能

修改板柱结构中柱的位置。柱位置的修改数据用于进行板柱结构的冲切验算。

  • 命 令

从主菜单中选择设计 > 板单元设计 > 修改柱位置

  • 输 入

选项

添加/替换： 在模型中选择需要修改位置的柱，输入修改数据后，对柱的位置进行定义或修改；

删除： 在模型中选择已经修改位置的柱，对定义的柱位置数据进行删除。

柱位置

内部：柱冲切的关键截面相对于单元坐标系无偏移；

边缘：柱冲切的关键截面相对于单元坐标系y或者z轴有单侧偏移；

中心：柱冲切的关键截面相对于单元坐标系y和z轴有两侧偏移。

危险截面

离外表面距离：设置危险截面离柱单元坐标系y和z向的距离。

注意：+y（+z）和-y（-z）分别代表距离柱单元坐标系正向和负向的距离。其单元坐标系方向可通过菜单 视图 > 显示 > 显示 中进行查看。


04_设计用钢筋参数

Home > midas Gen 2017 > 11_设计 > 04_混凝土设计 > 03_板单元设计 > 08_使用可靠性参数

使用可靠性参数

  • 功 能

该菜单用于定义板挠度的限值。

注：该菜单不适用于中国规范。

  • 命 令

从主菜单中选择设计 > 板单元设计 > 使用性能参数

  • 输 入

选项

添加/替换： 在模型中选择定义挠度限值的板单元；

删除： 在模型中选择已经定义挠度限值的板单元，对定义的挠度限值进行删除。

截面类型

全部：定义模型中所有梁/板单元的挠度限值；

选择：在模型中选择需要定义挠度限值的单元。

挠度限值

设置挠度的限值。

挠度调整系数：设置单元挠度值的放大系数。


04_设计用钢筋参数

Home > midas Gen 2017 > 11_设计 > 04_混凝土设计 > 03_板单元设计 > 09_板抗弯设计

板抗弯设计

  • 功 能

对于通过菜单 节点/单元 > 网格 > 定义子区域 中所定义的各子区域单元，通过此菜单进行配筋设计的相关计算以及自动选筋。

  • 命 令

从主菜单中选择设计 > 板单元设计 > 板抗弯设计

  • 输 入

荷载工况/荷载组合

选择参与设计的荷载组合，所供选择的组合为在菜单： 设计 > 板单元设计 > 板荷载组合中所勾选的强度验算组合。

注：当需要查看所选的所有基本组合下的最不利设计结果时，应选择“ALL COMINATION”。

抗弯设计

对于板单元的设计配筋结果的查看，应选择“单元”。

板顶、板底、顶底：选择显示设计结果的钢筋配置位置，沿板的单元坐标轴z方向上的面顶面，相反方向上的面为底面。

方向-1、方向-2： 选择显示设计结果的钢筋的布置方向，“方向-1”和“方向-2”在菜单“节点/单元 > 网格 > 定义子区域”中定义。

显示类型

云图：显示表示设计结果大小的等值线色彩图；

图例：显示云图色彩代表的数值范围的说明；

数值：在三维图形中显示设计结果的数值。

单向抗弯设计：输出板的剖断面的设计配筋结果。

输出结果内容

输出的结果内容包括三维图形结果、文本结果和表格结果三种。

1. 三维图形结果

钢筋配置： 根据板单元的钢筋设计结果，以及设计用钢筋参数菜单中设置的相应的选筋参数，得到的最终选筋结果；

计算配筋： 板单元的钢筋计算结果（单位长度上的钢筋面积值）；

计算配筋率：由钢筋计算结果得到的配筋率；

相对受压区高度：板单元作为压弯或拉弯构件，在钢筋计算中，得到的相对受压区高度值；

超配系数：由选筋参数得到的最终的选筋结果，与计算配筋结果的比值；

设计内力：显示板单元相应位置相应荷载组合下的设计内力Mxx（或Myy）的设计值；

2. 文本结果

设计结果：板单元计算设计的文本结果。

3. 表格结果

设计内力：板单元设计内力计算表格。

更新钢筋：将板单元最终的选筋结果更新至板的验算用钢筋的数据库中，可以通过菜单： 设计 > 板单元设计 > 板抗弯验算 对更新的配筋数据进行编辑。

适用：显示板单元的三维图形结果。


04_设计用钢筋参数

Home > midas Gen 2017 > 11_设计 > 04_混凝土设计 > 03_板单元设计 > 10_板抗弯验算

板抗弯验算

  • 功 能

对于通过菜单 设计 > 板单元设计 > 验算用板钢筋 中按类型名称定义的“板/筏板”的钢筋配置，通过此菜单进行相关的配筋验算。

  • 命 令

从主菜单中选择设计 > 板单元设计 > 板配筋验算

  • 输 入

荷载工况/荷载组合

选择参与验算的荷载组合，所供选择的组合为在菜单： 设计 > 板单元设计 > 板荷载组合中所勾选的组合。

注：当需要查看所选的所有基本组合下的最不利验算结果时，应选择“ALL COMINATION”。

抗弯设计

对于板单元的验算配筋结果的查看，应选择“单元”。

板顶、板底、顶底：选择显示验算结果的钢筋配置位置，沿板的单元坐标轴z方向上的面顶面，相反方向上的面为底面。

方向-1、方向-2： 选择显示验算结果的钢筋的布置方向，“方向-1”和“方向-2”在菜单“节点/单元 > 网格 > 定义子区域”中定义。

显示类型

云图：显示表示验算结果大小的等值线色彩图；

图例：显示云图色彩代表的数值范围的说明；

数值：在三维图形中显示验算结果的数值。

单向抗弯设计：输出板的剖断面的验算结果。

输出结果内容

输出的结果内容包括三维图形结果、文本结果和表格结果三种。

1. 三维图形结果

钢筋配置： 显示菜单验算用板钢筋中定义的实配钢筋结果；

钢筋面积： 显示实配钢筋面积结果（每延米的面积值）；

计算配筋率：由实配钢筋结果得到的配筋率；

相对受压区高度：板单元作为压弯或拉弯构件，用实配钢筋结果计算得到的相对受压区高度值；

超配系数：由选筋参数得到的最终的选筋结果，与计算配筋结果的比值；

设计内力：显示板单元相应位置相应荷载组合下的设计内力Mxx（或Myy）的设计值；

2. 文本结果

设计结果：板单元验算的文本结果。

3. 表格结果

设计内力：板单元设计内力计算表格。

适用：显示板单元的三维图形结果。


11_板抗剪验算

Home > midas Gen 2017 > 11_设计 > 04_混凝土设计 > 03_板单元设计 > 11_板抗剪验算

板抗剪验算

  • 功 能

对柱上的板单元进行冲切验算

  • 命 令

从主菜单中选择设计 > 板单元设计 > 板抗剪验算

  • 输 入

荷载工况/荷载组合

选择参与验算的荷载组合，所供选择的组合为在菜单： 设计 > 板单元设计 > 板荷载组合中所勾选的强度验算组合。

注：当需要查看所选的所有基本组合下的最不利验算结果时，应选择“ALL COMINATION”。

冲切验算

选择“CODE”表示按照规范进行计算。

显示类型

云图：显示表示验算结果大小的等值线色彩图；

图例：显示云图色彩代表的数值范围的说明；

数值：在三维图形中显示验算结果的数值。

比值：板柱节点的冲切力与冲切抗力的比值；

Fl：每个板柱节点的冲切力；

Asvu：抗冲切箍筋值。

单向抗弯设计：输出板的剖断面的验算结果（剪力、冲切力与抗冲切力的比值）。

输出结果内容

设计结果：生成冲切验算的文本结果。

适用：显示板单元的三维图形结果。


12_板正常使用状态验算

Home > midas Gen 2017 > 11_设计 > 04_混凝土设计 > 03_板单元设计 > 12_板正常使用状态验算

板正常使用状态验算

  • 功 能

通过该菜单对板单元进行应力、裂缝和挠度验算。

  • 命 令

从主菜单中选择设计 > 板单元设计 > 板正常使用状态验算

  • 输 入

荷载组合

选择参与设计的荷载组合。

当查看“裂缝”结果时，所供选择的组合为在菜单： 设计 > 板单元设计 > 板荷载组合 的“使用性验算”中所勾选的组合；当查看“挠度”结果时，所供选择的组合为在菜单：设计 > 板单元设计 > 正常使用状态荷载组合类型 中的“准永久”栏中以及菜单设计 > 板单元设计 > 板荷载组合 的“使用性验算”中同时勾选的荷载组合。

注：当需要查看所选的所有基本组合下的最不利设计结果时，应选择“ALL COMINATION”。

抗弯设计

对于板单元的设计配筋结果的查看，应选择“单元”。

板顶、板底、顶底：选择显示设计结果的钢筋配置位置，沿板的单元坐标轴z方向上的面顶面，相反方向上的面为底面。

方向-1、方向-2： 选择显示设计结果的钢筋的布置方向，“方向-1”和“方向-2”在菜单“节点/单元 > 网格 > 定义子区域”中定义。

显示类型

云图：显示表示设计结果大小的等值线色彩图；

图例：显示云图色彩代表的数值范围的说明；

数值：在三维图形中显示设计结果的数值。

输出结果内容

裂缝：在三维图形中输出板的裂缝值结果；

挠度：在三维图形中输出板的长期挠度值的结果。

数值： 以数值的形式输出结果；

比值：当选择“挠度”时，该选项亮显，以比值的形式输出挠度结果，即长期挠度与弹性变形的比值。

适用：显示板单元的三维图形结果。


13_裂缝截面分析控制

Home > midas Gen 2017 > 11_设计 > 04_混凝土设计 > 03_板单元设计 > 13_裂缝截面分析控制

裂缝截面分析控制

  • 功 能

设置裂缝截面的分析控制参数。

（注意：该菜单对于中国规范（GB50010-10）不适用。）

  • 命 令

从主菜单中选择 设计> 设计 > 板单元设计 > 裂缝截面分析控制

  • 输 入

在下图所示对话框中输入数据：

迭代次数/荷载工况：设置在开裂截面分析中需要迭代的次数，默认值为20；

收敛误差：设置开裂截面分析中的收敛误差，默认值为0.001.


14_执行裂缝截面分析

Home > midas Gen 2017 > 11_设计 > 04_混凝土设计 > 03_板单元设计 > 14_执行裂缝截面分析

执行裂缝截面分析

  • 功 能

执行裂缝截面的分析，该分析为考虑板开裂的挠度计算。

（注意：该菜单对于中国规范（GB50010-10）不适用。）

  • 命 令

从主菜单中选择 设计> 设计 > 板单元设计 > 执行裂缝截面分析


15_柱上板带设计

Home > midas Gen 2017 > 11_设计 > 04_混凝土设计 > 03_板单元设计 > 15_柱上板带设计

柱上板带设计

  • 功 能

对于通过菜单 节点/单元 > 网格 > 柱上板带 中，定义并指定了柱上板带的区域单元，通过此菜单进行配筋设计的相关计算以及自动选筋。

  • 命 令

从主菜单中选择设计 > 板单元设计 > 柱上板带设计

  • 输 入

荷载工况/荷载组合

选择参与设计的荷载组合，所供选择的组合为在菜单： 设计 > 板单元设计 > 板荷载组合中所勾选的强度验算组合。

注：当需要查看所选的所有基本组合下的最不利设计结果时，应选择“ALL COMINATION”。

显示类型

等值线：显示表示设计结果大小的等值线；

数值：在三维图形中显示设计结果的数值。

输出结果内容

钢筋配置： 根据柱上板带的钢筋设计结果，以及设计用钢筋参数菜单中设置的相应的选筋参数，得到的最终选筋结果；

计算配筋： 柱上板带的钢筋计算结果；

承载比例：柱上板带的设计内力和承载力的比值；

弯矩图：显示柱上板带相应荷载组合下的弯矩图；

不平衡弯矩：显示柱节点处的不平衡弯矩的结果；

板设计结果：当勾选“钢筋配置”时亮显，在显示柱上板带的实际选筋配置的同时显示其设计弯矩值；

文本结果

设计结果：柱上板带的计算设计配筋的文本结果。

更新钢筋：将柱上板带的最终的选筋结果更新至其验算用钢筋的数据库中，可以通过菜单： 设计 > 板单元设计 > 板抗弯验算 对更新的配筋数据进行编辑。

适用：显示板单元的三维图形结果。


16_柱上板带验算

Home > midas Gen 2017 > 11_设计 > 04_混凝土设计 > 03_板单元设计 > 16_柱上板带验算

柱上板带验算

  • 功 能

对于通过菜单 设计 > 板单元设计 > 验算用板钢筋 中按类型名称定义的“柱顶”的钢筋配置，通过此菜单进行相关的配筋验算。

  • 命 令

从主菜单中选择设计 > 板单元设计 > 柱上板带验算

  • 输 入

荷载工况/荷载组合

选择参与验算的荷载组合，所供选择的组合为在菜单： 设计 > 板单元设计 > 板荷载组合中所勾选的强度验算组合。

注：当需要查看所选的所有基本组合下的最不利验算结果时，应选择“ALL COMINATION”。

显示类型

等值线：显示表示设计结果大小的等值线；

数值：在三维图形中显示设计结果的数值。

输出结果内容

钢筋配置：显示菜单验算用板钢筋中定义的实配钢筋结果；

钢筋配筋： 柱上板带的实配钢筋面积结果；

承载比例：柱上板带的设计内力和承载力的比值；

弯矩图：显示柱上板带相应荷载组合下的弯矩图；

不平衡弯矩：显示柱节点处的不平衡弯矩的结果；

板设计结果：当勾选“钢筋配置”时亮显，在显示柱上板带的验算用钢筋配置的同时显示其设计弯矩值；

验算结果：柱上板带的配筋验算的文本结果。

适用：显示板单元的三维图形结果。


01_SRC梁截面验算

Home > midas Gen 2017 > 11_设计 > 05_SRC构件设计 > 01_梁截面验算

SRC梁截面验算

  • 功 能

用分析整个结构的结果和另外的强度校核数据校核SRC构件的强度，强度校核数据根据如下规范得到：美国SSRC(结构稳定研究委员会)或者韩国建筑学会的结构设计规范(AIK-SRC2K，容许应力设计)。

SRC规范校核模块仅对柱构件进行强度校核。
它支持下列功能：

- 活荷载折减系数
- 地震力修正系数
- 移动荷载下所有构件的强度校核

  • 命 令

从主菜单中选择设计 > SRC截面验算 >梁截面验算...

快捷键： Ctrl+7

  • 生成结果

按照混凝土设计荷载组合，计算每个单元在I端,中央及J端的正负最大弯矩和剪力，在此基础上按照单元整理强度校核结果。

按照混凝土设计荷载组合，考虑每个截面特性的所有单元和截面位置，得到计算的最大配筋量，在此基础上按照截面特性整理强度校核结果。

如果自动设计结果满足给定的特性，则结果显示蓝色，否则显示为红色。

根据用户输入的主筋(直径、数量)，辅筋(直径、数量)，设计参数等信息或者自动设计结果来进行强度校核。

没有钢筋数据，不能校核强度。

在用户选择的单位系统中生成强度校核结果。

CHK：构件强度校核结果的情况

= "OK"：构件中的应力在容许应力范围内

= "OK*"：构件中的应力在容许应力范围内，但是超过容许长细比

= "NG"：构件中的应力超过容许应力范围

= "NG*"：构件中的应力超过容许应力范围和容许长细比

MEMB：单元编号

COM：最大相互作用组合系数

SECT：截面属性号

SHR：剪力的应力比(构件剪应力/容许剪应力)

Type：截面形状符号

= RBO：矩形混凝土截面包含未填充的箱形钢截面

= RBC：矩形混凝土截面包含填充混凝土的箱形钢截面

= RPO：矩形混凝土截面包含未填充的管状钢截面

= RPC：矩形混凝土截面包含填充混凝土的管状钢截面

= CBO：圆形混凝土截面包含未填充的箱形钢截面

= CBC：圆形混凝土截面包含填充混凝土的箱形钢截面

= CPO：圆形混凝土截面包含未填充的管状钢截面

= CPC：圆形混凝土截面包含填充混凝土的管状钢截面

= EBC：填充混凝土的箱形钢截面(内填充混凝土的筒形断面)

= EPC：填充混凝土的圆形钢截面(内填充混凝土的筒形断面)

= RIB：矩形混凝土截面包含I-形钢截面

= CIB：圆形混凝土截面包含I-形钢截面

Rebar：用户输入的主筋标准规格和数量。

符号： n1 - n2 - #xx(Dxx).

(n1：主筋数量，n2：主筋排数， #xx(Dxx)：主筋标准规格)。

构件名称：用户输入或者程序内部储存的钢截面名称

材料：用户输入或者程序内部储存的钢材名称

Fa：钢材屈服强度

fc：混凝土抗压设计强度

Fys：主筋设计屈服强度

Bc, Hc：混凝土截面宽度，高度（深度）

LCB：得到最大组合应力比的荷载组合

Len：分析模型中局部节点坐标下的构件长度

Ly, Lz：分别为构件绕强轴(y轴)弱轴(z轴)屈曲的自由长度

N：构件轴力(N > 0：拉力，N < 0：压力)

My, Mz：分别为构件绕强轴和弱轴的弯矩

Ky, Kz：分别为构件绕强轴和弱轴屈曲时的有效屈曲长度系数

Eta,Etz:分别为绕强轴和弱轴的弯矩放大系数

sN：构件轴向的压(拉)应力

sMy,sMz：分别为构件绕强轴和弱轴弯矩产生的弯曲应力

rN：构件轴向的容许压(拉)应力

rMy, rMz：分别构件强轴和弱轴的的容许弯曲应力

普通控制

JGJ138-01：显示强度校核使用的规范。

按照单元或属性显示最大组合应力比的强度校核结果。按?特性分类?显示相同截面特性的所有构件当中生成最大组合应力比的单元的强度校核结果。

一旦确定属性，SEL控制相同截面属性的所有单元。

：显示用户选择的单位系统。

：选择所有构件

：取消选择所有构件

：

重新对选定的构件进行强度校核。按照截面属性显示重新校核的结果，包括相同截面特性的所有单元。

：选中此项，在模型视窗中选择并亮显选定的构件。

：显示强度校核详细结果

：简单显示强度校核结果

：对于选定构件，生成简要计算的强度校核结果。

：对于选定构件，生成详细计算的强度校核计算结果。

：对于选定构件，简要显示强度校核列表。

当选定?按特性分类?时，生成具有相同属性的所有构件的最大组合应力比。

= 全部：在校核结果对话框显示所有强度校核结果。

=满足：从校核结果中选择，在设计结果对话框中只显示满足设计要求(OK)的强度校核结果。

= 不满足：从校核结果中选择，在设计结果对话框中只显示不满足设计要求(NG)的强度校核结果。

：基于钢结构荷载组合，生成所有选定构件的强度校核结果。

：关闭对话框。


02_SRC柱截面验算

Home > midas Gen 2017 > 11_设计 > 05_SRC构件设计 > 02_柱截面验算

SRC柱截面验算

  • 功 能

根据结构的分析结果和定义的设计参数，按下列规范验算SRC柱构件的强度：中国型钢混凝土组合结构技术规程（JGJ138-2001)、美国SSRC(结构稳定研究委员会)或者韩国建筑学会的结构设计规范(AIK-SRC2K，容许应力设计)。

SRC规范校核模块仅对柱构件进行强度校核。
它支持下列功能：

- 活荷载折减系数
- 地震力修正系数
- 移动荷载下所有构件的强度校核
- 按照不同设计参数设计的选定构件的强度再校核
- 截面最优化设计
- 对修改的截面进行再分析和强度再校核

  • 命 令

从主菜单中选择　设计>SRC截面验算>柱截面验算...

  • 输 入

按照单元或者属性对强度校核结果进行分类，其中包括控制荷载组合和相应的最大组合强度比。

在用户选择的单位体系中生成强度校核结果。

CHK：构件强度校核结果的情况

= "OK"：构件中的应力在容许应力范围内

= "OK*"：构件中的应力在容许应力范围内，但是超过容许长细比

= "NG"：构件中的应力超过容许应力范围

= "NG*"：构件中的应力超过容许应力范围和容许长细比

MEMB：单元编号

COM：最大相互作用组合系数

SECT：截面属性号

SHR：剪力的应力比(构件剪应力/容许剪应力)

Type：截面形状符号

= RBO：矩形混凝土截面包含未填充的箱形钢截面

= RBC：矩形混凝土截面包含填充混凝土的箱形钢截面

= RPO：矩形混凝土截面包含未填充的管状钢截面

= RPC：矩形混凝土截面包含填充混凝土的管状钢截面

= CBO：圆形混凝土截面包含未填充的箱形钢截面

= CBC：圆形混凝土截面包含填充混凝土的箱形钢截面

= CPO：圆形混凝土截面包含未填充的管状钢截面

= CPC：圆形混凝土截面包含填充混凝土的管状钢截面

= EBC：填充混凝土的箱形钢截面(内填充混凝土的筒形断面)

= EPC：填充混凝土的圆形钢截面(内填充混凝土的筒形断面)

= RIB：矩形混凝土截面包含I-形钢截面

= CIB：圆形混凝土截面包含I-形钢截面

Rebar：用户输入的主筋标准规格和数量。

符号： n1 - n2 - #xx(Dxx).

(n1：主筋数量，n2：主筋排数， #xx(Dxx)：主筋标准规格)。

构件名称：用户输入或者程序内部储存的钢截面名称

材料：用户输入或者程序内部储存的钢材名称

Fa：钢材屈服强度

fc：混凝土抗压设计强度

Fys：主筋设计屈服强度

Bc, Hc：混凝土截面宽度，高度（深度）

LCB：得到最大组合应力比的荷载组合

Len：分析模型中局部节点坐标下的构件长度

Ly, Lz：分别为构件绕强轴(y轴)弱轴(z轴)屈曲的自由长度

N：构件轴力(N > 0：拉力，N < 0：压力)

My, Mz：分别为构件绕强轴和弱轴的弯矩

Ky, Kz：分别为构件绕强轴和弱轴屈曲时的有效屈曲长度系数

Eta,Etz:分别为绕强轴和弱轴的弯矩放大系数

sN：构件轴向的压(拉)应力

sMy,sMz：分别为构件绕强轴和弱轴弯矩产生的弯曲应力

rN：构件轴向的容许压(拉)应力

rMy, rMz：分别构件强轴和弱轴的的容许弯曲应力

普通控制

JGJ138-01：显示强度校核使用的规范。

按照单元或属性显示最大组合应力比的强度校核结果。按?特性分类?显示相同截面特性的所有构件当中生成最大组合应力比的单元的强度校核结果。

一旦确定属性，SEL控制相同截面属性的所有单元。

：显示用户选择的单位系统。

：选择所有构件

：取消选择所有构件

：

重新对选定的构件进行强度校核。按照截面属性显示重新校核的结果，包括相同截面特性的所有单元。

：选中此项，在模型视窗中选择并亮显选定的构件。

：显示强度校核详细结果

：简单显示强度校核结果

：对于选定构件，生成简要计算的强度校核结果。

：对于选定构件，生成详细计算的强度校核计算结果。

：对于选定构件，简要显示强度校核列表。

当选定?按特性分类?时，生成具有相同属性的所有构件的最大组合应力比。

= 全部：在校核结果对话框显示所有强度校核结果。

=满足：从校核结果中选择，在设计结果对话框中只显示满足设计要求(OK)的强度校核结果。

= 不满足：从校核结果中选择，在设计结果对话框中只显示不满足设计要求(NG)的强度校核结果。

：基于钢结构荷载组合，生成所有选定构件的强度校核结果。

：关闭对话框。

改变截面

对于选定单元，提供满足条件的截面形式，如果在混凝土截面(RBO，RBC，RPO，RPC，CBO，CBC，CPO，CPC，RIB或CIB)中使用钢筋，那么仅列出不妨碍混凝土截面和钢的截面。

修改SRC 截面数据 中提供结构钢和钢筋的间距。

  构件名称：截面名称

CHK：强度校核结果

= "OK"：截面中的应力在容许应力范围内

= "NG"：截面中的应力不在容许应力范围内

LCB：影响最大组合应力比的荷载组合

COM：最大应力组合比

SHR：剪力的应力比(构件剪应力/容许剪应力)

H：钢截面高度（深度）

B：钢截面宽度

：选择要改变的属性编号

：打开一个用于截面数据库的MGB文件

(可以使用包含用户创建的截面数据的MGB文件，在建立数据库时只包括数据库/用户截面)。

：选择要改变截面的数据库

选择要改变的钢截面(在RBO，RBC，RPO，RPC，CBO，CBC，CPO，CPC，RIB和CIB中选择)。

I - RIB，CIB

B(开口) - RBO，CBO

B(闭合) - RBC，CBC

B(填充) - EBC

P(开口) - RPO，CPO

P(闭合) - RPC，CPC

P(填充) - EPC

注意，选择开口或是闭合时，混凝土截面保持不变，但是选择填充截面时，混凝土截面自动改变。

:

选择要改变的截面尺寸范围。

如果要求目标截面尺寸和当前使用的截面尺寸相一致，选中校核框。使用当前单位系统在从输入区和到输入区中指定尺寸范围。

如果要求新截面与给定截面尺寸相同，那么只在从输入区中填写尺寸。

：选择要改变截面的组合应力比范围。

：

对SRC截面进行强度校核，钢截面必须满足限制条件。

：选择强度校核截面分类选项。

完成选定截面的强度校核后，在SRC强度校核文件(GD4)中保存改变的结果，然后关闭对话框。

完成选定截面的强度校核后，在SRC强度校核文件(GD4)中保存改变的结果。

：关闭对话框。

更新改变的截面

：完成强度校核之后，用已改变的截面修正模型属性。

改变之前的属性代表在最初分析模型中使用的截面特性。

改变之后的属性代表完成最终强度校核以后的改变的截面特性。

：仅自动选择已改变的属性。

：取消所有选择

：用选定的截面修正模型属性。

执行修正时，分析和强度校核结果均被删除，修正后的模型需要重新分析和重新校核强度。

单击 [image] ，然后单击 [image] ，对修正后的模型进行重新分析和校核强度。

：关闭对话框。

按材料、截面、构件绘制强度校核结果图(绘制强度校核结果图)。

：全选

：取消全选

选择图形输出分类选项（对于SEL选择，定义表格输出格式）。

选择图形输出选项(选择横线或竖线)。

选择图形输出的荷载组合(全部荷载组合中生成最大比例的所有荷载组合)。

：选择输出分量比。

在模型视窗中选择满足分类选项、荷载组合、分量比和界限比例的构件。

选项，在新的视窗里生成图形。(若选中，则在已有视窗中生成图形)。

生成满足选定条件的构件的强度校核结果的对比图形。

：关闭对话框。


12_SRC结构优化设计

Home > midas Gen 2017 > 11_设计 > 05_SRC构件设计 > 03_SRC优化设计

SRC结构优化设计

  • 功 能

根据构件通过迭代分析和最优设计（截面最优化设计）提出最优截面形式。以结构分析结果，钢结构设计模块，SRC设计模块为基础进行强度校核。

SRC构件截面最优化设计通过改变钢构件的截面尺寸得到。混凝土截面尺寸、钢构件形状和钢筋数量不能改变，设计也必须满足容许长细比的要求。

  • 命 令

只能在前处理模式下执行此功能，当运行钢结构设计模块时，不能执行钢结构最优化设计模块。如果执

行SRC设计模块时，同样也不能执行SRC最优设计模块。

从主菜单中选择设计 > 钢结构最优化设计...

快捷键：[Ctrl]+[F8]

从主菜单中选择设计 > SRC最优化设计...。

快捷键：[Ctrl]+[F11]

  • 输 入

SRC截面优化设计对话框

SEL

选择进行最优化处理的截面。

截面名称

用户输入的构件名称。

原截面

显示用户输入的构件尺寸和强度校核结果，这部分内容不能修改。

尺寸：构件尺寸，?B?放在截面名称之前，表示焊接组合截面。

面积：构件横截面的面积。

COM：强度校核结果产生的组合应力比(组合强度比)。

设计标准

提供截面最优化设计标准。

容许

输入选定构件组合应力比(组合强度比)的上限，选择在界限比值内的具有最小截面面积的构件。

把修改后的构件并入分析模型以后，对模型进行再分析，由于构件刚度系数的改变，会生成和选定组合应力比(组合强度比)不同的结果。

截面数据库

选择设计使用的数据库。程序支持5种数据库： 、 [image] 、 [image] 、 [image] 和 [image] 。

用在中 [image] 输入的板厚度和构件尺寸D1-D6创建焊接组合截面。

当选择 [image] ，用户可以使用在 [image] 中输入的构件（焊接截面）。

形状

选择构件类型（形状）。符号如下：

L：L-型钢截面

C：C-型钢截面

I：I-型钢截面

T：T-型钢截面

B：箱形钢截面

P：圆钢管截面

SR：圆钢

SB：方钢

2L：双L-型钢截面

2C：双C-型钢截面

当使用钢结构截面最优化设计功能时，才可以改变构件类型（形状）。使用SRC截面最优化设计功能时，不允许改变钢构件类型（形状）。

D1-D6

输入构件截面的尺寸范围。

若输入值为?0?，搜寻所有尺寸，忽略当前项目之后的所有输入项。

当 [image] 是 [image] ，并且构件尺寸输入值为?0?时，用下列数据创建截面：

Section shape | H1 | H2 | H inc | Remarks
L-Steel section | 50 | 300 | 10 |
C-Steel section | 100 | 800 | 50 |
I-Steel section | 100 | 1500 | 100 |
T-Steel section | 50 | 500 | 50 |
Box-Steel section | 100 | 1500 | 100 |
Circular-Steel pipe section | 100 | 1500 | 100 |
Round Steel bar | 10 | 200 | 10 |
Rectangular Steel bar | 10 | 300 | 10 |
Double L-Steel section | 50 | 300 | 10 |
Double C-Steel section | 100 | 800 | 50 |

截面高度数据：单位为?mm?、?cm?、?m? [单位：mm]

Section shape | H1 | H2 | H inc | Remarks
L-Steel section | 2.0 | 12.0 | 0.5 |
C-Steel section | 4.0 | 32.0 | 2.0 |
I-Steel section | 4.0 | 60.0 | 4.0 |
T-Steel section | 2.0 | 20.0 | 2.0 |
Box-Steel section | 4.0 | 60.0 | 4.0 |
Circular-Steel pipe section | 4.0 | 60.0 | 4.0 |
Round Steel bar | 0.5 | 8.0 | 0.5 |
Rectangular Steel bar | 0.5 | 12.0 | 0.5 |
Double L-Steel section | 2.0 | 12.0 | 0.5 |
Double C-Steel section | 4.0 | 32.0 | 2.0 |

截面高度数据：单位为?in?、?ft'? [单位：in]

Section shape | W1 | W2 | W inc | Remarks
L-Steel section | 50 | 300 | 10 |
C-Steel section | 40 | 400 | 20 |
I-Steel section | 100 | 900 | 100 |
T-Steel section | 50 | 500 | 50 |
Box-Steel section | 100 | 900 | 100 |
Circular-Steel pipe section | - | - | - |
Round Steel bar | - | - | - |
Rectangular Steel bar | 10 | 200 | 10 |
Double L-Steel section | 50 | 300 | 10 |
Double C-Steel section | 40 | 400 | 20 |

截面宽度数据：单位为?mm?、?cm?、?m? [单位：mm]

Section shape | W1 | W2 | W inc | Remarks
L-Steel section | 2.0 | 12.0 | 0.5 |
C-Steel section | 2.0 | 16.0 | 1.0 |
I-Steel section | 4.0 | 36.0 | 4.0 |
T-Steel section | 2.0 | 20.0 | 2.0 |
Box-Steel section | 4.0 | 36.0 | 4.0 |
Circular-Steel pipe section | - | - | - |
Round Steel bar | - | - | - |
Rectangular Steel bar | 0.5 | 8.0 | 0.5 |
Double L-Steel section | 2.0 | 12.0 | 0.5 |
Double C-Steel section | 2.0 | 16.0 | 1.0 |

截面宽度数据：单位为?in?、?ft'? [单位：in]

当 [image] 是轧制钢截面(AISC，BS，DIN，JIS和KS)时，强度校核时检查输入尺寸的5%。当截面是焊接钢截面（USER，BUILT），仅对完全符合输入尺寸的截面进行强度校核。

当所有项目均为?0?时，因为要校核很大数量的构件，所以运行时间很长。输入合理范围可以提高构件强度校核的效率。

各截面形状的数据输入如下：

Section | Symbol | D1 | D2 | D3 | D4 | D5 | D6
L-Steel section | ' L ' | H | B | tw | tf | Rop |
C-Steel section | ' C ' | H | B1 | tw | tf1 | B2 | tf2
I-Steel section | ' I ' | H | B1 | tw | tf1 | B2 | tf2
T-Steel section | ' T ' | H | B | tw | tf |  |
Box-Steel section | ' B ' | H | B | tw | tf1 | Cw | tf2
Circular-Steel pipe section | ' P ' | D | tw |  |  |  |
Round Steel bar | ' SR' | D |  |  |  |  |
Rectangular Steel bar | ' SB ' | H | B |  |  |  |
Double L-Steel section | ' 2L ' | H | B | tw | tf | C | Rop
Double C-Steel section | ' 2C ' | H | B | tw | tf | C |

参见截面 获得详细帮助。

:

输入柱构件最优设计所需数据。

:

当 [image] 是 [image] 时，指定板厚。

:

当 [image] 是 [image] 时，提供截面尺寸。

:

指定强度校核和再分析的循环次数。

:

通过再分析执行强度校核。按照 [image] 指定的次数改变构件，对构件进行重复分析之后，取代原始模型，再次分析修正后的模型。

柱设计

  • 功 能

输入柱构件最优化设计所需数据。

  • 输 入

柱设计对话框

作用力和弯矩

轴力和弯矩

选择满足指定条件的构件，指定条件指轴力（必需的轴向强度）和弯矩（必需的抗弯强度）产生的组合应力（强度）在容许应力比范围内（在允许中设置的容许强度比）。

仅有轴力

选择满足指定条件的构件，指定条件指轴力（必需的轴向强度）在容许应力比范围内。

组合柱拼接的连接方法

对于l 形和箱形钢截面，当 [image] 设置成 [image] 时，就可以按照柱外部及内部尺寸确定构件尺寸。

内部不变 (内部连接模式)

构件内部尺寸按照不同深度/宽度固定，可以改变钢板厚度。

外部不变 (外部连接模式)

构件的外部尺寸保持不变。

钢板厚度数据

  • 功 能

输入最优化设计中使用的翼缘和腹板厚度。

  • 输 入

板厚度数据对话框

厚度

设置成 [image] ，输入构件的板厚，最多可以使用50种类型。

按照升序对输入的板厚排序。

在当前单位系统下程序内置数据库中自动获得厚度数据。

1) 单位?mm?、?cm?、?m?

6 mm，8 mm， 9 mm，10 mm，12 mm，15 mm，16 mm，18 mm，20 mm，22 mm，24 mm， 25 mm，26 mm，28 mm，30 mm，32 mm，34 mm，35 mm，36 mm，38 mm，40 mm， 42 mm，45 mm，46 mm，48 mm，50 mm，55 mm，60 mm，65 mm，70 mm，75 mm，80 mm (共 32 种)

2) 单位?in?、?ft?

0.250 in(4/16 in), 0.3125 in(5/16 in), 0.375 in(6/16 in), 0.4375 in(7/16), 0.500 in(8/16 in), 0.5625 in(9/16 in), 0.625 in(10/16 in), 0.750 in(12/16 in), 0.875 in(14/16 in), 1.000 in, 1.125 in, 1.250 in, 1.375 in, 1.500 in, 1.625 in, 1.750 in, 1.875 in, 2.000 in, 2.125 in, 2.250 in, 2.375 in, 2.500 in, 2.625 in, 2.750 in, 2.875 in, 3.000 in, 3.250 in, 3.500 in, 3.750 in, 4.000 in (共 30种)

用户定义截面

  • 功 能

预先定义最优化设计使用的截面，输入全部截面数据创建截面数据库。

  • 输 入

用户定义截面对话框

形状

对于输入的数据定义截面形状符号。

当使用SRC最优设计时，构件不能改变原始定义的形状。从数据库截面中选择构件的钢截面维持原始定义的形状。

D1-D6

输入构成相应截面的主要尺寸，参阅D1-D6的输入内容。

从文件中获得截面数据。

        • 数据文件格式

  1. 仅允许使用焊接钢截面，不允许使用轧制型钢截面。

  2. 数据文件用?*数据库-截面?开头。

  3. 用空格或者逗号分隔数据。

  4. 第一条?ID?作为简单标识符，自由输入。

  5. 参阅从窗口中输入的截面?形状?主要数据。

  6. 使用当前单位输入D1-D6，参阅主要数据输入窗口的D1-D6。

** 输入格式举例

*DB-SECTION

**ID, SHP, D1, D2, D3, D4, D5, D6

1, I, 12.38, 12.08, 0.47, 0.735,

2, I, 14.02, 14.52, 0.44, 0.71,

3, I, 16.33, 10.235, 0.395, 0.665,

4, I, 4.16, 4.06, 0.28, 0.345,

5, T, 10.715, 8.355, 0.515, 0.835,

6, T, 4.07, 5.25, 0.23, 0.33,

7, L, 4, 4, 0.3125, 0.3125

分析选项

  • 功 能

定义最优化设计时改变构件重分析的循环次数。

  • 输 入

分析选项对话框

循环次数

输入重分析循环次数。

  • 最大循环次数为10。

  • 仅选择构件不做再分析时输入?0?。

  • 完成对改变构件的再分析以后，可以观察。模型可以再次修改和分析。

  • 如果对满足设计约束条件的构件进行分析，因为截面的刚度系数发生了变化，所以

  • 结果不再与约束条件相吻合。如果重分析的次数足够，可以得到和设计约束条件相接近的结果。

最优化设计结果

  • 功 能

按照不同格式显示并对最优设计结果分类，反映模型中构件的改变情况。

  • 应 用

最优设计结果对话框

用?SEL?把选中的构件并入原始模型，校核后，对新构件进行再分析，再分析结果显示在主输入窗口中。

在屏幕上或者文件中生成文本格式的结果。

以不同格式的图表显示结果，输出图表格式如下：

系数:

显示每个截面的最大组合应力比（组合强度比）。

重量:

按截面显示总重量的变化结果。

总重量:

每个截面的总重单独汇编，最右端的截面重量是总重

重量比:

显示由组合应力比（组合强度比）概括的重量结果。组合应力比（组合强度比）以增量0.1（10%）显示。

平均系数:

按截面显示平均安全系数，所有构件系数总和除以构件总数得到该值。

注:当选定截面不满足容许长细比的要求时，最优设计结果应力比为?999.0?。


14_设计截面

Home > midas Gen 2017 > 11_设计 > 06_截面 > 01_设计用截面

设计截面

  • 功 能

按照用户定义的钢结构或者混凝土结构的截面数据进行构件设计和强度校核。

  • 命 令

从主菜单中选择设计 > 截面设计...

  • 输 入

用下面的对话框输入数据：

截面设计对话框

：从下表中选择编辑截面

截面对话框

截面号：截面编号

名称：截面名称

：下拉截面形状列表

用户：用户自定义的截面

数据库：截面数据库名称

注：
GEN内部数据库名称如下：

AISC：美国标准

JIS：日本标准

KS：韩国标准

截面名称：截面名称

组合截面：组成成分分类

注：

下列参数为组合截面的组成成分，组合截面容许应力折减系数反映了AISC-ASD89强度校核要求，如不激活此项，可使用轧制截面。

H：截面高度（深度）

B1：第一翼缘宽度

tw：腹板厚度

tf1：第一翼缘厚度

B2：第二翼缘宽度

tf2：第二翼缘厚度

：计算并显示选定截面的截面特性。

：应用输入数值或者选项并关闭对话框。

：取消命令。

：对选定截面输入数值。


15_钢结构设计结果简图

Home > midas Gen 2017 > 11_设计 > 07_设计结果 > 01_钢结构设计

钢结构设计结果简图

  • 功 能

用数字分量和轮廓检查钢结构构件的设计结果

  • 命 令

从主菜单中选择设计 > 钢结构设计结果简图...

  • 输 入

荷载工况/荷载组合

选择指定的荷载工况、荷载组合或者包络线。

点击右边的 [image] 输入、增加、修改荷载组合（参阅荷载工况/荷载组合）。

分量

从下列设计结果中指定分量：

轴向：轴向应力比(强度比)分量

剪切-y：强轴方向剪应力比(强度比)分量

剪切-z：弱轴方向剪应力比(强度比)分量

弯曲-y：绕主轴力矩的弯曲应力比(强度比)分量

弯曲-z：绕弱轴力矩的弯曲应力比(强度比)分量

组合：最大组合应力比(强度比)分量

显示类型

指定显示类型如下：

等值线 用等值线显示设计结果。

范围：指定等值线范围。

：指定等值线边线的颜色范围。用户可以用特殊颜色定义特殊范围。

颜色编号：定义等值线中使用的颜色编号(在6、12、18和24中选择)。

斜线填充：在等值线中显示带颜色的斜线(阴影)。

画等值线：用颜色显示等值线。

颜色：指定或者改变等值线中的颜色。

色表：定义颜色类型。

：控制等值线中每个范围的颜色。

等值线：指定等值线边界的颜色。

单元边界：指定在等值线中显示的单元边界颜色。

图例 在工作窗口的左侧或右侧组织并显示与分析结果有关的各种标记。

图例位置：在显示窗口中图例的位置。

值 用数值显示选定的设计结果分量。数字的字体和颜色可在 [image] 显示选项中控制。

小数点：将数值显示为小数形式。

指数：将数值表示为指数形式。

最小和最大值：显示最小值和最大值。

绝对最大值：显示绝对最大值。

最大值：仅显示最大值。

最小值：仅显示最小值。

界限比例（%）：按设计结果的最大值或最小值设置屏幕显示界限。

注
默认的小数点可在?参数选择?中控制。

验算

显示钢结构截面的强度验算结果 (见注释)

显示: 选择要显示构件类型。

柱截面尺寸: 柱截面显示比例系数。

数值选项: 设定小数点后位数。

注释：
下面图中显示的是钢结构构件的强度验算比：

上图中的（R1，R2 和R3）为梁和柱的强度验算结果:

钢梁：

R1: 表示钢梁正应力强度与抗拉、抗压强度设计值的比值

R2: 表示钢梁整体稳定应力与抗拉、抗压强度设计值的比值

R3: 表示钢梁剪应力强度与抗拉、抗压强度设计值的比值

钢柱：

R1: 表示钢柱正应力强度与抗拉、抗压强度设计值的比值

R2: 表示钢柱强轴方向稳定应力与抗拉、抗压强度设计值的比值

R3: 表示钢柱弱轴方向稳定应力与抗拉、抗压强度设计值的比值

：把输入的数值应用到选中构件上。

：关闭输入对话框。


16_钢筋砼结构设计结果简图

Home > midas Gen 2017 > 11_设计 > 07_设计结果 > 02_混凝土设计

钢筋砼结构设计结果简图

  • 功 能

通过数值分量和轮廓校核钢筋混凝土构件的设计结果。

  • 命 令

从主菜单中选择设计 > 钢筋砼结构设计结果简图...

  • 输 入

荷载工况/荷载组合

选择指定的荷载工况、荷载组合或者包络线。

点击右边的 [image] 输入、增加、修改荷载组合。(参见"荷载工况/荷载组合")。

分量

从下列各项中选择设计结果的目标分量：

轴向：轴向强度系数分量

剪切-y：强轴方向剪切强度系数分量

剪切-z：弱轴方向剪切强度系数分量

弯曲-y：绕强轴力矩的弯曲强度系数分量

弯曲-z：绕弱轴力矩的弯曲强度系数分量

组合：最大组合强度系数分量

注释:?组合?选项是用来验算设计结果的配筋

显示类型

指定显示类型如下：

等值线 用等值线显示设计结果。

范围：指定等值线范围。

：指定等值线边线的颜色范围。用户可以用特殊颜色定义特殊范围。

颜色编号：定义等值线中使用的颜色编号(在6、12、18和24中选择)。

斜线填充：在等值线中显示带颜色的斜线(阴影)。

画等值线：用颜色显示等值线。

颜色：指定或者改变等值线中的颜色。

色表：定义颜色类型。

：控制等值线中每个范围的颜色。

等值线：指定等值线边界的颜色。

单元边界：指定在等值线中显示的单元边界颜色。

图例 在工作窗口的左侧或右侧组织并显示与分析结果有关的各种标记。

图例位置：在显示窗口中图例的位置。

值 用数值显示选定的设计结果分量。数字的字体和颜色可在 [image] 显示选项中控制。

小数点：将数值显示为小数形式。

指数：将数值表示为指数形式。

最小和最大值：显示最小值和最大值。

绝对最大值：显示绝对最大值。

最大值：仅显示最大值。

最小值：仅显示最小值。

界限比例（%）：按设计结果的最大值或最小值设置屏幕显示界限。

注
默认的小数点可在?参数选择?中控制。

配筋

生成配筋结果。(参考注释)

实配钢筋: 配筋直径和数量

所需配筋面积:设计所需要的配筋面积

显示类型: 从等值线, 图例和数值中选择你所需的显示类型

显示: 选择在配筋图中要显示的构件类型。

柱截面尺寸: 输入柱截面显示的缩放比例.

数值选项: 设定显示数值的小数点后的位数及显示方式.

注. 配筋显示
从MIDAS/Gen V6.0.0版本开始，结构配筋情况如实配钢筋直径，实配钢筋面积及所需要的钢筋面积都能够在混凝土设计结果简图及组合结构设计结果简图中找到。

(1) 框架实配钢筋图

(2)框架所需配筋面积图

1. 梁配筋

图中的梁1的设计结果

(3) 梁设计结果简图

图(3）中的A窗口是如图(1）中显示的选择'实配钢筋'选项情况下的实配钢筋直径和间距。B窗口是在如图(2）中显示的选择'所需钢筋面积'选项情况下的配筋直径和面积.

2. 柱配筋图

(1）和(2）图中的柱2设计结果如下图：

(4) 柱设计结果简图

(5)柱实配钢筋图

(6)柱所需配筋面积图

配筋图表(5）和(6）说明：

a: （0.44）表示柱的轴压比Uc，(Uc＝N/(fc'×Ag)) ,（EQ：0.37）表示考虑抗震设计时的轴压比；

b: 角部实配钢筋面积总量为：

4d20 = 4 × 314.2 = 1256.8 mm2 ；

c & d : 单侧的实配钢筋数及钢筋大小；

e:柱箍筋配筋大小及间距(Asv)。

根据上面图中显示的b，c和d，总的实配钢筋数为：

b+ ((c - 2) + (d - 2))× 2 = 4 + ((4 - 2) + (4 - 2)) × 2 = 12

沿z向边的实配钢筋数为4（或称沿z向边的实配钢筋层数），因此有

12-4-d20 (见图（4）中的C)

3. 墙配筋图

(7）和(8）图中的墙1的设计结果

（7) 墙实配钢筋图

（8) 墙所需配筋面积图

下面是图（7）和（8）中配筋说明：

a: (0.05)表示墙的轴压比 Uc，( Uc＝N/(fc'×Ag))

b：图（7）中，(V)28-d12@200表示此片墙竖筋总的实际配筋数,实际配筋大小和配筋间距；(V为Vertical缩写)

图（8）中，（V）1131表示此片墙每单位长度（m）竖筋的配筋面积；

c：图（7）中，(E)40-d18@100表示此片墙两端端部加强筋总的实际配筋数，实配配筋大小和配筋间距；（E为End的缩写）

图（8）中，(E)10180表示此片墙两端端部加强筋总的配筋面积；

d: (H)d12@220，表示此片墙水平筋的实配钢筋大小和配筋间距；（H为Horizontal的缩写）

输出截面位置（梁）

按截面位置校核钢筋混凝土构件的设计结果。当选中?显示类型?中的?值?时，可以使用该功能。

I，中心，J：代表钢筋混凝土构件的截面位置，用户不能自己选择位置，它是根据?最大值?或者?全部?选项自动选择的。

最大值：每个钢筋混凝土构件中出现的最大值。

全部：钢筋混凝土构件各截面出现的所有值。

：把输入的数值应用到选中的构件上。

：关闭输入对话框。


17_SRC组合结构设计结果简图

Home > midas Gen 2017 > 11_设计 > 07_设计结果 > 03_SRC构件设计

SRC组合结构设计结果简图

  • 功 能

用数字分量和轮廓检查SRC构件的设计结果。

  • 命 令

从主菜单中选择设计 >SRC 设计结果...

  • 输 入

荷载工况/组合

选择指定的荷载工况、荷载组合或者包络线。

点击右边的 [image] 输入、增加、修改荷载组合(参阅荷载工况/组合)。

分量

从下列设计结果中选择目标分量：

轴向：轴向应力比分量

剪切-y：强轴方向剪应力比分量

剪切-z：弱轴方向剪应力比分量

弯曲-y：绕主轴力矩的弯曲应力比分量

弯曲-z：绕弱轴力矩的弯曲应力比分量

组合：最大组合应力比分量

显示类型

指定显示类型如下：

等值线 用等值线显示设计结果。

范围：指定等值线范围。

：指定等值线边线的颜色范围。用户可以用特殊颜色定义特殊范围。

颜色编号：定义等值线中使用的颜色编号(在6、12、18和24中选择)。

斜线填充：在等值线中显示带颜色的斜线(阴影)。

画等值线：用颜色显示等值线。

颜色：指定或者改变等值线中的颜色。

色表：定义颜色类型。

：控制等值线中每个范围的颜色。

等值线：指定等值线边界的颜色。

单元边界：指定在等值线中显示的单元边界颜色。

图例 在工作窗口的左侧或右侧组织并显示与分析结果有关的各种标记。

图例位置：在显示窗口中图例的位置。

值 用数值显示选定的设计结果分量。数字的字体和颜色可在 [image] 显示选项中控制。

小数点：将数值显示为小数形式。

指数：将数值表示为指数形式。

最小和最大值：显示最小值和最大值。

绝对最大值：显示绝对最大值。

最大值：仅显示最大值。

最小值：仅显示最小值。

界限比例（%）：按设计结果的最大值或最小值设置屏幕显示界限。

注
默认的小数点可在?参数选择?中控制。

配筋

生成配筋结果。(参考注释)

实配钢筋: 配筋直径和数量

所需配筋面积:设计所需要的配筋面筋

显示类型: 从等值线, 图例和数值中选择你所需的显示类型

显示: 选择在配筋图中要显示的构件类型。

柱截面尺寸: 输入柱截面显示的缩放比例.

数值: 设定显示数值的小数点后的位数及显示方式.

注：配筋显示
从MIDAS/Gen V6.0.0版本开始，结构配筋情况如实配钢筋直径，实配钢筋面积及所需要的钢筋面积都能够在钢筋混凝土设计结果简图及组合结构设计结果简图中找到。

注：

SRC配筋图形显示结果中，其数字含义参见上一节?钢筋砼结构设计结果简图?。


18_钢结构设计内力

Home > midas Gen 2017 > 11_设计 > 08_设计内力 > 01_钢构件设计

钢结构设计内力

  • 功 能

在电子数据表格中检查设计结果中钢构件的设计内力。

  • 命 令

从主菜单中选择设计 > 钢结构设计内力。

  • 输 入

显示钢构件的设计内力结果。


01_梁设计内力

Home > midas Gen 2017 > 11_设计 > 08_设计内力 > 02_混凝土设计 > 01_梁设计内力

梁设计内力

  • 功 能

在电子数据表格中检查设计结果中混凝土结构梁的设计内力。

  • 命 令

从主菜单中选择设计 > 混凝土结构设计内力>梁设计内力。


02_柱设计内力

Home > midas Gen 2017 > 11_设计 > 08_设计内力 > 02_混凝土设计 > 02_柱设计内力

柱设计内力

  • 功 能

在电子数据表格中检查设计结果中混凝土结构柱的设计内力。

  • 命 令

从主菜单中选择设计 > 混凝土结构设计内力>柱设计内力。


03_支撑设计内力

Home > midas Gen 2017 > 11_设计 > 08_设计内力 > 02_混凝土设计 > 03_支撑设计内力

支撑设计内力

  • 功 能

在电子数据表格中检查设计结果中混凝土结构支撑的设计内力。

  • 命 令

从主菜单中选择设计 > 混凝土结构设计内力>支撑设计内力。


04_墙设计内力

Home > midas Gen 2017 > 11_设计 > 08_设计内力 > 02_混凝土设计 > 04_墙设计内力

墙设计内力

  • 功 能

在电子数据表格中检查设计结果中混凝土结构墙的设计内力。

  • 命 令

从主菜单中选择设计 > 混凝土结构设计内力>墙设计内力。


01_SRC梁设计内力

Home > midas Gen 2017 > 11_设计 > 08_设计内力 > 03_SRC构件设计 > 01_SRC梁设计内力

SRC梁设计内力

  • 功 能

在电子数据表格中检查设计结果中SRC梁的设计内力。

注：该功能目前不支持中国规范。

  • 命 令

从主菜单中选择设计 > SRC设计内力>SRC梁设计内力。


02_SRC柱设计内力

Home > midas Gen 2017 > 11_设计 > 08_设计内力 > 03_SRC构件设计 > 02_SRC柱设计内力

SRC柱设计内力

  • 功 能

在电子数据表格中检查设计结果中SRC柱的设计内力。

  • 命 令

从主菜单中选择设计 > SRC设计内力>SRC柱设计内力。


21_运行批量设计

Home > midas Gen 2017 > 11_设计 > 09_批处理 > 01_运行批量设计

运行批量设计

  • 功 能

连续执行分析模型、钢结构/钢-混凝土组合结构强度校核、钢筋混凝土(梁、柱、支撑、墙体)设计等。

  • 命 令

从主菜单中选择设计 >运行批量设计...

  • 输 入

选择对话框中要执行的项并点击 [image].

批量分析对话框

: 连续运行所选择的项.

: 关闭对话框.


01_自由长度(L,Lb)

Home > midas Gen 2017 > 11_设计 > 10_表格 > 01_一般设计 > 01_自由长度(L,Lb)

自由长度(L,Lb)

  • 功 能

在表格中按照单元编号的顺序显示自由长度和横向自由长度。

在检查输入数据的时候，可以修改/删除或者增加新数据。

  • 命 令

从主菜单中选择设计 > 一般设计参数 > 一般设计表格 > 自由长度（L,Lb）...。

从树形菜单的表格表中选择一般设计表格 >一般设计>自由长度（L,Lb）...。

  • 输 入

显示如下表格时，用户可以选择相关项目来修改/删除或者增加新数据。

单元：单元编号

Ly：强轴（单元坐标轴y轴)弯曲自由长度

Lz：弱轴（单元坐标轴z轴)弯曲自由长度

不考虑：考虑自由长度选项

Lb：横向自由长度


02_计算长度系数（K）

Home > midas Gen 2017 > 11_设计 > 10_表格 > 01_一般设计 > 02_计算长度系数（K）

计算长度系数（K）

  • 功 能

在表格中按照单元编号的顺序显示有效屈曲长度系数。

在检查输入数据的时候，可以修改/删除或者增加新数据。

  • 命 令

从主菜单中选择设计 > 一般设计参数 > 一般设计表格> 计算长度系数（K）...。

从树形菜单的表格表单中选择设计表单 > 一般设计 > 计算长度系数（K）。

  • 输 入

显示如下表格时，用户可以选择相关项目来修改/删除或者增加新数据。

单元：单元编号

Ky：关于强轴（单元坐标轴y轴)的有效屈曲长度系数

Kz：关于弱轴（单元坐标轴z轴)的有效屈曲长度系数


03_极限长细比

Home > midas Gen 2017 > 11_设计 > 10_表格 > 01_一般设计 > 03_极限长细比

极限长细比

  • 功 能

在表格中按照单元编号的顺序显示极限长细比。

检查输入数据时，可以修改/删除或者增加新数据。

  • 命 令

从主菜单中选择设计 > 一般设计参数 > 一般设计表格 > 极限长细比... 。

从树形菜单的表格表中选择设计表格> 一般设计> 极限长细比。

  • 输 入

显示如下表格时，用户可以选择相关项目来修改/删除或者增加新数据。

单元：单元编号

没有验算：此项功能为不验算长细比（KL/r）

受压：受压构件最大长细比

受拉：受拉构件最大长细比


04_等效弯矩系数(Beta_m)

Home > midas Gen 2017 > 11_设计 > 10_表格 > 01_一般设计 > 04_等效弯矩系数Cm)

等效弯矩系数(Beta_m)

  • 功 能

在表格中按照单元编号的顺序显示等效弯矩系数。

在检查输入数据的时候，可以修改/删除或者增加新数据。

  • 命 令

从主菜单中选择设计 > 一般设计参数 > 一般设计表格 > 等效弯矩系数（Beta_m）...。

从树形菜单的表格表单中选择设计表单 > 一般设计 > 弯矩系数。

  • 输 入

显示如下表格时，用户可以选择相关项目来修改/删除或者增加新数据。

单元：单元编号

自动计算：激活该项可以自动计算等效弯矩系数（Beta_m）

Beta_my：绕构件强轴的等效弯矩系数

Beta_mz：绕构件弱轴的等效弯矩系数


05_设计弯矩放大系数

Home > midas Gen 2017 > 11_设计 > 10_表格 > 01_一般设计 > 05_弯矩放大系数

设计弯矩放大系数(B1/δb,B2/δs)

  • 功 能

在表格中按照单元编号的顺序显示设计弯矩放大系数。

在检查输入数据的时候，可以修改/删除或者增加新数据。

  • 命 令

从主菜单中选择设计>一般设计参数>一般设计表格>设计弯矩放大系数（B1/δb,B2/δs）...。

从树形菜单的表格表单中选择表格>设计表格>一般设计>设计弯矩放大系数（B1/δb,B2/δs）。

  • 输 入

显示如下表格时，用户可以选择相关项目来修改/删除或者增加新数据。

单元：单元编号

B1y/δby：有防侧倾支撑的框架中承受垂直荷载的构件沿强轴弯曲方向的设计弯矩放大系数。

B1z/δbz：有防侧倾支撑的框架中承受垂直荷载的构件沿弱轴弯曲方向的设计弯矩放大系数。

B2y/δsy：无防侧倾支撑的框架中承受水平荷载的构件沿强轴弯曲方向的设计弯矩放大系数。

B2z/δsz：无防侧倾支撑的框架中承受水平荷载的构件沿弱轴弯曲方向的设计弯矩放大系数。


06_编辑活荷载折减系数

Home > midas Gen 2017 > 11_设计 > 10_表格 > 01_一般设计 > 06_编辑活荷载折减系数

编辑活荷载折减系数

  • 功 能

在表格中按照单元编号的顺序显示活荷载折减系数。

在检查输入数据的时候，可以修改/删除或者增加新数据。

  • 命 令

从主菜单中选择设计 > 一般设计参数 > 一般设计表格 > 编辑活荷载折减系数...。

从树形菜单的表格表单中选择表格 > 设计表格 > 一般设计 > 编辑活荷载折减系数...

  • 输 入

显示如下表格时，用户可以选择相关项目来修改/删除或者增加新数据。

单元：单元编号

折减系数：活荷载折减系数


07_地震作用放大系数

Home > midas Gen 2017 > 11_设计 > 10_表格 > 01_一般设计 > 07_地震放大系数

地震作用放大系数

  • 功 能

将地震作用下的内力调整系数按构件顺序整理成的表格，表格中输入的数据可以修改/删除，还可以增加新的数据。

  • 命 令

从主菜单中选择 设计 > 一般设计参数 > 一般设计表格 > 地震作用放大系数...。

从树形菜单的表格中选择 设计表格 > 一般设计 > 地震作用放大系数。

  • 输 入

表格形式如下，可以选择相应的项目进行修改/删除，以及增加数据。

荷载工况?轴力：地震作用下的轴力调整系数

荷载工况?弯矩：地震作用下的弯矩调整系数

荷载工况?剪力：地震作用下的剪力调整系数

荷载组合?轴力：包括了地震作用的荷载组合下的轴力调整系数

荷载组合?弯矩：包括了地震作用的荷载组合下的弯矩调整系数

荷载组合?剪力：包括了地震作用的荷载组合下的剪力调整系数


08_抗震等级

Home > midas Gen 2017 > 11_设计 > 10_表格 > 01_一般设计 > 08_定义抗震等级

抗震等级

  • 功 能

可以对同一结构的不同部位采用不同的抗震等级，按构件顺序整理为表格

  • 命 令

从主菜单中选择 设计 > 一般设计参数 > 一般设计表格 > 抗震等级...。

从树形菜单的表格中选择 表格 > 设计表格 > 一般设计 > 抗震等级。

  • 输 入

表格形式如下，可以选择相应的项目进行修改/删除，以及增加数据。

单元号：构件序号

混凝土：混凝土构件的抗震等级

钢材：钢构件的抗震等级

SRC：SRC构件的抗震等级


09_编辑构件类型

Home > midas Gen 2017 > 11_设计 > 10_表格 > 01_一般设计 > 09_编辑构件类型

编辑构件类型

  • 功 能

在表格中按照单元编号的顺序显示构件类型。

在检查输入数据的时候，可以修改/删除或者增加新数据。

  • 命 令

从主菜单中选择设计 > 一般设计参数 > 一般设计表格 > 编辑构件类型...。

从树形菜单的表格表单中选择表格> 设计表格 >一般设计> 编辑构件类型。

  • 输 入

显示如下表格时，用户可以选择相关项目来修改/删除或者增加新数据。

单元：单元编号

构件类型：梁、柱、支撑


01_编辑梁的等效弯矩系数(Beta_b)

Home > midas Gen 2017 > 11_设计 > 10_表格 > 02_钢构件设计 > 01_等效弯矩系数(Cb)

编辑梁的等效弯矩系数(Beta_b)

  • 功 能

在表格中按照单元编号的顺序显示梁的等效弯矩系数。

检查输入数据时，可以修改/删除或者增加新数据。

  • 命 令

从主菜单中选择设计 > 钢结构设计参数 > 钢结构设计表 > 编辑梁的等效弯矩系数（Beta_b）...。

从树形菜单的表格表中选择设计表> 钢结构设计 > 梁的等效弯矩系数（Beta_b）。

  • 输 入

显示如下表格时，用户可以选择相关项目来修改/删除或者增加新数据。

单元：单元编号

自动计算：选择此项自动计算梁的等效弯矩系数（Beta_b）

Beta_b:等效弯矩系数


02_容许剪切应力折减系数(Cv)

Home > midas Gen 2017 > 11_设计 > 10_表格 > 02_钢构件设计 > 02_剪切系数(Cv)

容许剪切应力折减系数(Cv)

  • 功 能

在表格中按照单元编号的顺序显示剪切系数。

检查输入数据时，可以修改/删除或者增加新系数。

  • 命 令

从主菜单中选择设计 > 钢结构设计参数 > 钢结构设计表 > 容许剪切应力折减系数（Cv）...。

从树形菜单的表格表中选择设计表> 钢结构设计 > 容许剪切应力折减系数（Cv）。

  • 输 入

显示如下表格时，用户可以选择相关项目来修改/删除或者增加新数据。

单元：单元编号

自动计算：选择此项自动计算剪切系数（Cv）

Cv：剪切系数


03_定义容许应力

Home > midas Gen 2017 > 11_设计 > 10_表格 > 02_钢构件设计 > 03_定义容许应力

定义容许应力

  • 功 能

在表格中按照单元编号的顺序显示容许应力系数。

检查输入数据时，可以修改/删除或者增加新数据。

  • 命 令

从主菜单中选择设计 > 钢结构设计参数 > 钢结构设计表格 > 定义容许应力... 。

从树形菜单的表格表中选择设计表> 钢结构设计 > 定义容许应力。

  • 输 入

显示如下表格时，用户可以选择相关项目来修改/删除或者增加新数据。

单元：单元编号

Fa：容许压应力系数

Ft：容许拉应力系数

Fby：绕强轴弯曲的容许弯曲应力系数

Fbz：绕弱轴弯曲的容许弯曲应力系数

Fv：容许剪应力系数


04_按构件指定抗震体系

Home > midas Gen 2017 > 11_设计 > 10_表格 > 02_钢构件设计 > 04_按构件指定抗震体系

按构件指定抗震体系

  • 功 能

此项功能暂不支持中国规范。


04_箱形截面纵向加劲肋

Home > midas Gen 2017 > 11_设计 > 10_表格 > 02_钢构件设计 > 05_箱型截面纵向加劲肋

箱形截面纵向加劲肋

  • 功 能

在表格中按照截面编号的顺序显示箱形截面横向/纵向加劲肋。

检查输入数据时，可以修改/删除或者增加新数据。

  • 命 令

从主菜单中选择设计 > 钢结构设计参数 > 钢结构设计表格 > 箱形截面纵向加劲肋...。

从树形菜单的表格中选择设计表> 钢结构设计 > 箱形截面纵向加劲肋。

  • 输 入

显示如下表格时，用户可以选择相关项目来修改/删除或者增加新数据。

截面：截面属性编号

Astf：横向加劲肋的间距

Bstf：纵向加劲肋的宽度

Tstf：纵向加劲肋的厚度

Noy：在翼缘处由纵向加劲肋分隔的板块数目

Noz：在腹板处由纵向加劲肋分隔的板块数目


03_编辑抗力模型不定性系数

Home > midas Gen 2017 > 11_设计 > 10_表格 > 03_编辑抗力模型不定性系数

编辑抗力模型不定性系数

  • 功 能

在表格中按照单元号编辑抗力模型不定性系数。

检查输入数据时，可以修改/删除或者增加新数据。

  • 命 令

从主菜单中选择设计 > 钢筋混凝土构件设计参数 > 钢筋混凝土设计表格 > 抗力模型不定性系数。

  • 输 入

显示如下表格时，用户可以选择相关项目来修改/删除或者增加新数据。

单元：单元编号

抗力模型不定性系数：输入相应构件的抗力模型不定性系数（参见《混规》3.3.2）


01_编辑梁端负弯矩调幅系数

Home > midas Gen 2017 > 11_设计 > 10_表格 > 04_混凝土/SRC设计 > 01_梁端负弯矩调幅系数

编辑梁端负弯矩调幅系数

  • 功 能

在表格中按照单元编号显示钢筋混凝土梁构件的梁端负弯矩调幅系数。

检查输入数据时，可以修改/删除或者增加新数据。

  • 命 令

从主菜单中选择设计 > 钢筋混凝土构件设计参数 > 钢筋混凝土设计表格 > 梁端负弯矩调幅系数。

从树菜单的表格中选择设计表格> 钢筋混凝土设计 > 梁端负弯矩调幅系数。

  • 输 入

显示如下表格时，用户可以选择相关项目来修改/删除或者增加新数据。

单元：单元编号


02_编辑扭矩折减系数

Home > midas Gen 2017 > 11_设计 > 10_表格 > 04_混凝土/SRC设计 > 02_扭矩折减系数

编辑扭矩折减系数

  • 功 能

在表格中按照单元号编辑钢筋混凝土梁构件的扭矩折减系数。

检查输入数据时，可以修改/删除或者增加新数据。

  • 命 令

从主菜单中选择设计 > 钢筋混凝土构件设计参数 > 钢筋混凝土设计表格 > 扭矩折减系数。

  • 输 入

显示如下表格时，用户可以选择相关项目来修改/删除或者增加新数据。

单元：单元编号

扭矩折减系数：输入相应构件的扭矩折减系数


03_正常使用极限状态参数

Home > midas Gen 2017 > 11_设计 > 10_表格 > 04_混凝土/SRC设计 > 03_正常使用极限状态参数

正常使用极限状态参数

  • 功 能

此项功能暂不支持中国规范。


Home > midas Gen 2017 > 11_设计 > 10_表格 > 04_混凝土/SRC设计 > 04_钢筋暴露状态

04_钢筋暴露状态

Type topic text here.


04_构件钢筋设计标准

Home > midas Gen 2017 > 11_设计 > 10_表格 > 04_混凝土/SRC设计 > 05_按构件定义钢筋

钢筋的设计标准

  • 功 能

在表格中按照单元编号的顺序修改构件的钢筋设计标准。

检查输入数据时，可以修改/删除或者增加新数据。

  • 命 令

从主菜单中选择设计 > 钢筋混凝土构件设计参数 > 钢筋混凝土设计表格 > 钢筋设计标准...

从树菜单的表格中选择设计表格> 钢筋混凝土设计 > 钢筋设计标准

  • 输 入

显示如下表格时，用户可以选择相关项目来修改/删除或者增加梁、柱、支撑及剪力墙钢筋设计标准数据。

梁钢筋设计标准

单元：单元编号

主筋：主筋标准规格

箍筋：箍筋标准规格

排数：钢筋排数

侧筋：侧向钢筋标准规格

dT：截面上部主筋中心的距离

dB：截面下部主筋中心的距离

考虑主筋的间距限值：勾选是否考虑间距限值

搭接钢筋选项：按0，50％或100％考虑钢筋搭接

柱钢筋设计标准

单元：单元编号

主筋：主筋标准规格

抗拉钢筋/螺旋筋：抗拉钢筋/螺旋筋标准规格

排列Y/Z：Y/Z方向钢筋排数

d0：截面外部距主筋中心的距离

考虑主筋的间距限值：勾选是否考虑间距限值

搭接钢筋选项：按0，50％或100％考虑钢筋搭接

支撑钢筋设计标准

参考柱钢筋色基标准

墙钢筋设计标准

墙号：墙单元编号

层：楼层号

竖向钢筋：竖向钢筋标准规格

横向钢筋：横向钢筋标准规格

de：剪力墙端部到第一排竖向钢筋中心的距离（保护层厚度）

dw：剪力墙边缘到端部竖向钢筋中心的距离（保护层厚度）


05_编辑验算用梁截面数据

Home > midas Gen 2017 > 11_设计 > 10_表格 > 04_混凝土/SRC设计 > 06_编辑梁截面数据

编辑验算用梁截面数据

  • 功 能

在表格中按照截面特性编号的顺序显示钢筋混凝土梁构件的截面数据。

检查输入数据时，可以修改/删除或者增加新数据。

  • 命 令

从主菜单中选择设计 > 钢筋混凝土构件设计参数 > 钢筋混凝土设计表格 > 编辑验算用梁截面数据...。

从树菜单的表格中选择设计表格> 钢筋混凝土设计 > 编辑验算用梁截面数据。

  • 输 入

显示如下表格时，用户可以选择相关项目来修改/删除或者增加新数据。

截面：截面特性编号

箍筋：箍筋标准规格

dT：截面上部主筋中心的距离

dB：截面下部主筋中心的距离

i-Top Array：i节点上部钢筋的排数

i-Top RB1：i节点上部钢筋上排顶筋的根数（单排）

i-Top RB2：i节点上部钢筋下排顶筋的根数（双排）

i-Top Name：i节点上部钢筋的标准规格

i-Bot Array：i节点下部钢筋的排数

i-Bot RB1：i节点下部钢筋下排底筋的根数（单排）

i-Bot RB2：i节点下部钢筋上排底筋的根数（双排）

i-Bot Name：i节点下部钢筋的标准规格

i-SB Space：i节点架立筋间矩

m-Top Array：m节点上部钢筋的排数

m-Top RB1：m节点上部钢筋上排顶筋的根数（单排）

m-Top RB2：m节点上部钢筋下排顶筋的根数（双排）

m-Top Name：m节点上部钢筋的标准规格

m-Bot Array：m节点下部钢筋的排数

m-Bot RB1：m节点下部钢筋下排底筋的根数（单排）

m-Bot RB2： m节点下部钢上排底筋的根数（双排）

m-Bot Name：m节点下部钢筋的标准规格

m-SB Space：m节点架立筋间矩

j-Top Array：j节点上部钢筋的排数

j-Top RB1：j节点上部钢筋上排顶筋的根数（单排）

j-Top RB2：j节点上部钢筋下排顶筋的根数（双排）

j-Top Name：j节点上部钢筋的标准规格

j-Bot Array：j节点下部钢筋的排数

j-Bot RB1：j节点下部钢筋下排底筋的根数（单排）

j-Bot RB2：j节点下部钢筋上排底筋的根数（双排）

j-Bot Name：j节点下部钢筋的标准规格

j-SB Space：j节点架立筋间矩


06_编辑验算用柱截面数据

Home > midas Gen 2017 > 11_设计 > 10_表格 > 04_混凝土/SRC设计 > 07_编辑柱截面数据

编辑验算用柱截面数据

  • 功 能

在表格中按照截面特性编号的顺序显示钢筋混凝土柱构件的截面数据。

检查输入数据时，可以修改/删除或者增加新数据。

  • 命 令

从主菜单中选择设计 > 钢筋混凝土构件设计参数 > 钢筋混凝土设计表格 > 编辑验算用柱截面数据...。

从树菜单的表格中选择设计表格> 钢筋混凝土设计 > 编辑验算用柱截面数据。

  • 输 入

显示如下表格时，用户可以选择相关项目来修改/删除或者增加新数据。

截面：截面属性编号

箍筋形式：箍筋类型(普通/螺旋)

主筋：主筋的标准规格

Nqrb：柱截面垂直钢筋数目

Nrow：柱截面垂直钢筋排数

do：截面上部主筋中心和截面边缘的距离（保护层厚度）

Sub RB：箍筋标准尺寸

间距：箍筋间距


07_编辑验算用支撑截面数据

Home > midas Gen 2017 > 11_设计 > 10_表格 > 04_混凝土/SRC设计 > 08_编辑支撑截面数据

编辑验算用支撑截面数据

  • 功 能

在表格中按照截面特性编号的顺序显示钢筋混凝土支撑构件的截面数据。

检查输入数据时，可以修改/删除或者增加新数据。

  • 命 令

从主菜单中选择设计 > 钢筋混凝土构件设计参数 > 钢筋混凝土设计表格 > 编辑验算用支撑截面数据...。

从树菜单的表格中选择设计表格> 钢筋混凝土设计 > 编辑验算用支撑截面数据。

  • 输 入

显示如下表格时，用户可以选择相关项目来修改/删除或者增加新数据。

截面：截面属性编号

箍筋：箍筋类型(普通/螺旋)

主筋：主筋的标准规格

Nqrb：垂直钢筋数目

Nrow：垂直钢筋排数

do：截面上部主筋中心和截面边缘的距离（保护层厚度）

Sub RB：箍筋标准规格

间距：箍筋间距


08_编辑验算用墙截面数据

Home > midas Gen 2017 > 11_设计 > 10_表格 > 04_混凝土/SRC设计 > 09_编辑墙截面数据

编辑验算用墙截面数据

  • 功 能

在表格中按照截面特性编号的顺序显示钢筋混凝土剪力墙构件的截面数据。

检查输入数据时，可以修改/删除或者增加新数据。

  • 命 令

从主菜单中选择设计 > 钢筋混凝土构件设计参数 > 钢筋混凝土设计表格 > 编辑验算用墙截面数据...。

从树菜单的表格中选择设计表格> 钢筋混凝土设计 > 编辑验算用墙截面数据。

  • 输 入

显示如下表格时，用户可以选择相关项目来修改/删除或者增加新数据。

墙 ID：剪力墙ID编号

楼层：校核截面强度的楼层

标高：地面标高至校核层的底面的距离

模型厚度：校核建立分析模型时输入的厚度

厚度：剪力墙构件厚度，选择模型厚度时，不能输入此厚度

VRB 名称：垂直钢筋标准规格

VRB 间距：垂直钢筋间距

ERB 名称：端部钢筋标准规格

ERB 间距：端部钢筋间距

ERB 编号：端部钢筋编号

HRB 名称：水平钢筋标准规格

HRB 间距：水平钢筋间距

dw：端部垂直钢筋中心到剪力墙构件端部的距离

de：剪力墙构件端部到第一排垂直钢筋中心的距离


01_编辑SRC柱截面数据

Home > midas Gen 2017 > 11_设计 > 10_表格 > 04_混凝土/SRC设计 > 10_编辑SRC柱截面数据

编辑SRC柱截面数据

  • 功 能

在表格中按照截面特性编号的顺序显示SRC构件的截面数据。

检查输入数据时，可以修改/删除或者增加新数据。

  • 命 令

从主菜单中选择设计 > SRC组合构件设计参数 >SRC 设计表格> 编辑SRC柱截面数据...。

从树菜单的表格中选择设计表格> SRC设计 > 编辑SRC柱截面数据。

  • 输 入

显示如下表格时，用户可以选择相关项目来修改/删除或者增加新数据。

截面：截面特性编号

自动计算：确定由程序自动计算主筋间距或是用户直接输入。

间距：箍筋间距

钢筋名称：主筋标准规格

主筋位置（do）：主筋中心至截面表面的距离（保护层厚度）


23_计算书

Home > midas Gen 2017 > 11_设计 > 11_计算书 > 01_计算书

计算书

  • 功 能

生成结构分析与设计结果的计算书，为.TXT记事本格式。

  • 命 令

从主菜单中选择设计 > 计算书 。

  • 输 入

勾选需要输出的内容，

设定保存的路径 [image] ，

同时点 [image] (即生成计算书)，

最后点击 [image] 查看详细计算书。


01_项目输入状况

Home > midas Gen 2017 > 12_查询 > 01_项目输入状况

项目输入状况

  • 功 能

为快速查询，提供建模过程中的数据输入状态列表。

在评估建模进度并把当前模型数据和其他模型数据做对照的时候，使用这些列表很方便。

  • 命 令

从主菜单中选择查询 > 项目输入状况...

从树形菜单的菜单表单中选择查询 > 项目情况

快捷键： [Ctrl]+T

  • 输 入

显示每个项目的数据输入状态。在适用部位提供数据纪录编号。


02_查询节点

Home > midas Gen 2017 > 12_查询 > 02_查询 > 01_查询节点

查询节点

  • 功 能

查询节点坐标和节点的各类属性(荷载情况，边界条件等)。

  • 命 令

从主菜单中选择查询 > 查询节点...

从树形菜单的菜单表单中选择 查询 > 查询节点

在图标菜单中点击 [image] 查询节点

快捷键： [F4]

  • 输 入

查询

在列表中指定查询项目。

节点：节点坐标

注
如果连续查询节点坐标，还提供查询节点之间的距离。

结点局部坐标轴：节点局部坐标系

一般支承：节点一般支承条件

节点弹性支承：节点弹性支承条件

一般弹性支承：节点一般弹性支承条件

刚性连接：在主节点和从节点之间的约束条件

节点质量：节点集中质量

节点荷载：节点集中荷载

节点温度：节点温度

节点动力荷载：节点动力荷载

节点号

直接在输入框中输入要查询的节点编号，或者点击工作窗中的相应节点。查询的信息将在信息窗口中显示。

注
使用快速查询可以很容易地检查节点编号和坐标。快速查询可以显示在模型窗口捕捉的单元和节点属性。


03_查询单元

Home > midas Gen 2017 > 12_查询 > 02_查询 > 02_查询单元

查询单元

  • 功 能

查询单元信息，例如单元连接节点，单元的各类属性(荷载情况，边界条件)。

  • 命 令

从主菜单中选择查询 > 查询单元...

从树形菜单的菜单表单中选择 查询 > 查询单元

在图标菜单中点击 [image] 查询单元

快捷键： [Ctrl]+[F4]

  • 输 入

查询

在列表中指定查询项目。

单元：单元材料属性、截面或厚度编号，连结节点、长度或面积等。

释放梁端约束：梁端约束情况(简支，部分固定，全部固定)。

梁端刚域：梁柱连接偏移量

释放板端约束：板节点约束释放情况

梁单元荷载

压力荷载

预应力：预应力荷载

初拉力：初拉力荷载

温度梯度：温度梯度荷载

装饰材料荷载

单元号

直接在输入框中输入要查询的单元编号，或者点击工作窗中的相应单元。查询的信息将在信息窗口中显示。

注
使用快速查询可以很容易地检查单元基本属性。快速查询可以显示在模型窗口捕捉的单元和节点属性，快速查询可以列出如下特性：

单元：单元编号
类型：单元类型
材料号：材料编号
特性值号：截面特性值或者厚度编号
Beta-角度：单元方向
连接节点：单元连接的节点
单元长度
与整体坐标平面的夹角

单元面积
单元体积


04_节点详细表格

Home > midas Gen 2017 > 12_查询 > 03_详细表格 > 01_节点详细表格

节点详细表格

  • 功 能

通过表格查询节点坐标和节点属性。

首先"选择"目标单元，然后选取功能。

  • 命 令

从主菜单中选择查询 > 节点详细表格...

从树形菜单的表格表单中选择查询表格 > 节点详细

在图标菜单中点击 [image] 节点详细表格

  • 输 入

点击表格窗口底部按照种类划分的跳格，在表格中显示所需信息。

表格类型如下：

节点：节点坐标

局部坐标轴：节点的局部坐标系统

一般支承：节点的一般支承条件

节点弹性支承：节点弹性支承条件

一般弹性支承：节点一般弹性支承条件

刚性连接：在主节点和从节点之间的约束条件

节点质量：节点集中质量

节点荷载：节点集中荷载

支座强制位移：支点强制位移荷载

节点温度：节点温度

节点动力荷载：节点动力荷载

Thms：节点固定温度

注
用户可以通过右键对表格进行操作，其中全部复制功能指将包括表格的表头的全部数据同时复制。


05_单元详细表格

Home > midas Gen 2017 > 12_查询 > 03_详细表格 > 02_单元详细表格

单元详细表格

  • 功 能

通过表格查询单元连结的节点和单元属性。

首先"选择"目标单元，然后选取功能。

  • 命 令

从主菜单中选择查询 > 单元详细表格...

从树形菜单的表格表单中选择查询表格 > 单元详细

在图标菜单中点击 [image] 单元详细表格

  • 输 入

点击表格窗口底部按照种类划分的跳格，在表格中显示所需信息。

表格类型如下：

单元：单元材料属性、截面和厚度编号、连接节点、长度或面积等。

释放梁单元端部约束：梁端约束情况(简支，部分固定，全部固定)。

单元端部刚域：梁柱连接偏移量

释放板单元端部约束：板节点约束释放情况

梁单元荷载

Fmld

预应力荷载

初拉力

压力荷载

单元温度

温度梯度荷载

Btmp

构成几何刚度的初始荷载

分配热源

单元对流边界

时间荷载

徐变系数

注
用户可以通过右键对表格进行操作，其中全部复制功能指将包括表格的表头的全部数据同时复制。


07_设计参数详细表格(D)

Home > midas Gen 2017 > 12_查询 > 03_详细表格 > 03_设计参数详细表格

设计参数详细表格

  • 功能

查询单元的设计参数及设计类型。

首先"选择"目标单元，然后选取功能。

  • 命 令

从主菜单中选择查询 > 设计参数详细表格

从树形菜单的表格表单中选择查询表格 > 设计参数详细表格

在图标菜单中点击 [image] 设计参数详细表格

  • 用法

点击表格窗口底部按照种类划分的跳格，在表格中显示所需信息。

表格类型如下：

单元

长度

Sueq

K

弯矩增大系数

活荷载折减系数

Cb

Cm

Cv

容许应力

极限长细比

构件类型

编辑张拉应力

指定容许张拉应力

特殊荷载组合


08_层重量表格

Home > midas Gen 2017 > 12_查询 > 04_重量/质量/荷载表格 > 01_层重量表格

层重量表格

  • 功能

在扩展表格中查看作用在建筑结构上的层重量统计，应用这个功能前必须用定义层数据来生成层数据 。

在MIDAS/Gen中表格工具是一种内置的强大功能，要详细了解请参考以下条目。

表格工具的用法

术语

熟悉用法

1.基本用法

2.数据处理

3.用剪贴板复制/粘贴数据

表格辅助功能

1.表格排序

2.表格格式设定

3.自动适应列宽

4.图表打印

表格类型的辅助功能

1.节点/单元表格

2.结果表格

  • 命令

从主菜单中选择查询>层重量表格...

或在树形工作菜单的表格选项选择查询>层重量表格

  • 用法

参考表格的用法并输入或修改以下数据:

层 : 层名称

标高 : 层标高

单元重量:各种类型结构单元的重量

合计: 某一层的所有单元构件总重量

输出层重量合计:每一种类型构件的总重量

注
在这个统计表格中数据是不能更改的。


09_层荷载表格

Home > midas Gen 2017 > 12_查询 > 04_重量/质量/荷载表格 > 02_层荷载表格

层荷载表格

  • 功能

在扩展表格中查看作用在建筑结构上的荷载统计，应用这个功能前必须用定义层数据来生成层数据 。

在MIDAS/Gen中表格工具是一种内置的强大功能，要详细了解请参考以下条目。

表格工具的用法

术语

熟悉用法

1.基本用法

2.数据处理

3.用剪贴板复制/粘贴数据

表格辅助功能

1.表格排序

2.表格格式设定

3.自动适应列宽

4.图表打印

表格类型的辅助功能

1.节点/单元表格

2.结果表格

  • 命令

从主菜单中选择查询>层荷载表格

或在树形工作菜单的表格选项选择查询>层荷载表格

  • 用法

在激活的对话框中选择要查看荷载值的荷载工况.

参考表格的用法并输入或修改以下数据:

从上图中选择要查看的静力荷载工况。

荷载X: 整体坐标系下X向荷载

荷载Y: 整体坐标系下Y向荷载

荷载Z: 整体坐标系下Z向荷载

荷载 : 荷载工况

层 : 层名称

标高 : 层标高

集中: 集中荷载数值

梁单元 : 梁单元荷载数值

楼板 : 楼板荷载数值

压力 :压力荷载数值

自重 : 考虑的自重方向

合计 : 某一层的荷载值合计

层剪力: 层剪力

层弯矩:层弯矩

输出层荷载合计:把每一种类型的荷载单独汇总

注
自动计算的风载荷地震荷载是按集中荷载加在每一层的。
在这个统计表格中数据是不能更改的。


10_层质量表格

Home > midas Gen 2017 > 12_查询 > 04_重量/质量/荷载表格 > 03_层质量表格

层质量表格

  • 功能

在扩展表格中查看作用在建筑结构上的层质量统计，应用这个功能前必须用定义层数据来生成层数据 。

在MIDAS/Gen中表格工具是一种内置的强大功能，要详细了解请参考以下条目。

表格工具的用法

术语

熟悉用法

1.基本用法

2.数据处理

3.用剪贴板复制/粘贴数据

表格辅助功能

1.表格排序

2.表格格式设定

3.自动适应列宽

4.图表打印

表格类型的辅助功能

1.节点/单元表格

2.结果表格

  • 命令

从主菜单中选择查询>层质量表格

或在树形工作菜单的表格选项选择查询>层质量表格

  • 用法

参考表格的用法并输入或修改以下数据:

层质量

层 : 层名称

标高 : 层标高

移动质量

X-方向:整体坐标系下X向转换的质量总和

X-方向: 整体坐标系下Y向转换的质量总和

转动惯量:转动质量惯性矩

质心

X-坐标: X向质心坐标值

Y-坐标: Y向质心坐标值

X-方向
整体坐标系下X向的质量

层 : 层名称

标高 : 层标高

节点质量:集中在节点的质量值合计

荷载转化为质量: 由荷载转化的质量

刚性楼板质量:楼板的质量

结构质量: 自重转化的质量

合计: 指定层的质量合计值

Y-方向和 Z -方向同理类推.

注
在这个统计表格中数据是不能更改的.


06_单元重量表格

Home > midas Gen 2017 > 12_查询 > 04_重量/质量/荷载表格 > 04_单元重量表格

单元重量表格

  • 功 能

通过表格查询单元的重量

  • 命 令

从主菜单中选择查询 > 单元重量表格...

从树形菜单的表格表单中选择查询表格 > 重量表格

  • 输 入

可以根据各种选择类型进行选择，查看所选单元的特性及重量。

如：选择类型选择单元类型>梁单元,点击添加后确认。

将列出所有梁单元各单元的长度及重量。

注

L/A/V 分别为对应杆系单元的长度、面单元的面积、实体单元的体积。


11_质量统计表格

Home > midas Gen 2017 > 12_查询 > 04_重量/质量/荷载表格 > 05_质量统计表格

质量统计表格

  • 功 能

在电子数据表中校核分析模型中输入的节点质量数据。

MIDAS/Gen的表格工具提供了许多强大的内部功能，具体使用方法参阅以下内容：

表格工具的使用

术语

掌握使用方法

基本说明(单元移动、选择、大小控制等)

数据处理(增加、删除、修改数据)

用剪贴板复制/粘贴数据

表格功能补充

表格排序

表格格式设定

自动适应列宽

图表打印

各表格类型的补充功能

节点/单元表格

结果表格

  • 命 令

从主菜单中选择查询 > 质量统计表格...

从树形菜单的表格表单中选择查询表格 > 质量统计

  • 输 入

参考表格工具的使用, 输入或者修改表中所示数据：

节点质量(X方向)

节点：节点号

节点质量：节点集中质量

荷载转化为质量：由垂直静力荷载分量转化过来的节点质量

结构质量：由结构自重转化过来的节点质量

合计：每个节点上的节点质量总和

Y方向和Z方向同X方向。

注
此种功能下，不允许改变数据大小。


12_荷载统计表格

Home > midas Gen 2017 > 12_查询 > 04_重量/质量/荷载表格 > 06_荷载统计表格

荷载统计表格

  • 功 能

在电子数据表中校核分析模型中输入的荷载数据。

MIDAS/Gen的表格工具提供了许多强大的内部功能，具体使用方法参阅以下内容：

表格工具的使用

术语

掌握使用方法

基本说明(单元移动、选择、大小控制等)

数据处理(增加、删除、修改数据)

用剪贴板复制/粘贴数据

表格功能补充

表格排序

表格格式设定

自动适应列宽

图表打印

各表格类型的补充功能

节点/单元表格

结果表格

  • 命 令

从主菜单中选择查询 > 荷载统计表格...

从树形菜单的表格表单中选择查询表格 > 荷载统计

  • 输 入

参考表格工具的使用, 输入或者修改表中所示数据：

从上图中选择要查看的静力荷载工况。

节点质量(X方向)

荷载：静力荷载工况

集中：集中荷载的总和

梁单元：梁单元荷载的总和

楼板：楼面荷载的总和

压力：压力荷载的总和

自重：自重的总和

合计：静力荷载的合计

Y方向和Z方向同X方向

注
此种功能下，不允许改变数据大小。


13_激活施工阶段

Home > midas Gen 2017 > 12_查询 > 05_各施工阶段激活组

激活施工阶段

  • 功 能

以表格的形式显示每个施工阶段定义的组。分为结构、边界、荷载三个表格，组的激活、钝化状

态分别用O和X表示。

MIDAS/Gen的表格工具提供了许多强大的内部功能，具体使用方法参阅以下内容：

表格工具的使用

术语

掌握使用方法

基本说明(单元移动、选择、大小控制等)

数据处理(增加、删除、修改数据)

用剪贴板复制/粘贴数据

表格功能补充

表格排序

表格格式设定

自动适应列宽

图表打印

各表格类型的补充功能

节点/单元表格

结果表格

  • 命 令

从主菜单中选择查询 > 激活施工阶段...

从树形菜单的表格表单中选择查询表格 > 激活组总表

  • 输 入

参考表格工具的使用, 输入或者修改表中所示数据：

结构组

组名称：再每个施工阶段定义的组的名称。

A: 代表相应的组第一次激活，用?O?表示，当钝化时，用?X?表示。

T: 代表在相应的施工阶段全部激活的组，用?O?表示激活。表示相应施工阶段激活的组的累积情况。

边界、荷载组的表示同结构组。

注

此种功能下，不允许改变数据。

单击鼠标右键，选择"显示/隐藏AD列"可以显示或者隐藏激活列。


01_单位体系

Home > midas Gen 2017 > 13_工具 > 01_设置 > 01_单位体系

单位体系

  • 功 能

设置当前应用的单位体系。

  • 命 令

从主菜单中选择工具 > 单位体系...

  • 输 入

单位体系对话框显示如下图：

    1. 对话框中用 [image] 显示当前使用状态下的长度、力和热度的单位。

    2. 首先选择新的长度和力的单位，然后点击 [image] 或者 [image] 来改变单位体系。当前窗口显示的所有数值会按照新的单位体系改变。

    3. 热量值会按照所选单位体系改变，但温度值不随单位体系而改变。

    4. 点击 [image] 设置新的单位体系，然后关闭对话框。点击 [image] 保持对话框打开状态。

    5. 如果勾选了"设定为默认单位体系"，此时点击 [image] 或者 [image] ，那么参数设置下的设定默认值中的默认值改为新的单位体系。

注1 当前单位体系也可以通过单位变换窗口改变，单位变换窗口位于状态栏的底部。

注2 对于数据库材料，其参数值会按照所选温度单位而改变。对于用户自定义材料，其参数不随所选的单位体系而改变，保持为摄氏度。


02_参数设置

Home > midas Gen 2017 > 13_工具 > 01_设置 > 02_首选项

参数设置

  • 功 能

设置运行midas Gen时所有类型的初始参数。

根据下列命令设置参数。使用对话框左侧的菜单树查看或者修改参数。

使用环境

一般：提供用户公司名称、公司商标、临时文件路径和保存临时文件所需条件等设置。

视图：默认工作视图。

容许误差：指定合并节点和交叉单元的容许误差。

材料和截面：指定材料和截面默认的数据库。

楼面荷载数据库：在数据库中提前定义楼面荷载大小。

结果

设计: 指定适合不同材料类型和材料特性的结构设计标准。

注意

输出格式

格式-尺寸和其他：指定生成模型数据和结果分析的数值格式。

格式-内力

格式-荷载

  • 命 令

从主菜单中选择工具 > 参数设置...

  • 输 入

显示如下参数设置对话框：

参数设置对话框

在对话框左侧的菜单树中选择项目，右侧则出现相应的特性值。

选中"点击确认时保存修改事项"，然后点击 [image] ，当前设置会立即生效，并且将这些

变化保存在视图注册表中，供以后使用MIDAS/Gen时运用。

均使用默认值：以默认值设定所有的参数。

设定默认值：以默认值设定当前的参数。

具体设置

使用环境 > 一般

一般使用环境对话框

公司名称：用户的公司名称

公司商标：指定一个包含公司标识的BMP图形文件，在各种分析/设计结果中均打印此商标。

文件夹：指定一个在运行MIDAS/Gen时可以建立和删除临时文件的文件夹。

注
必须指定一个有足够硬盘空间的临时文件夹，如果硬盘空间不足，则运行会很慢或者会出现问题。

自动保存：给定自动保存文件的时间间隔。

建立备份文件：无论何时保存修改后的文件，均生成一个备份文件(.bak)

最近的项目列表：在文件菜单底部，设定最近的项目文件个数。

使用环境 > 视图

当建立一个新的文件或者打开已有文件，设置默认工作窗口。

视图环境对话框

初始模型边界尺寸：建立一个新文件时，指定窗口的默认尺寸。

初始点格

轴网间距 x：建立新文件时，指定用户坐标系下x方向轴网间距。

轴网间距 y：建立新文件时，指定用户坐标系下y方向轴网间距。

打开轴网：建立新文件或者打开已有文件时，激活该选项，在屏幕上显示轴网点。(参阅"轴网"）。

初始视点

设定建立新文件或者打开已有文件时的初始视点，可以选择标准视图和俯视。（参阅"视点"）。

捕捉

设定建立新文件或者打开已有文件时的捕捉功能，可以选择点格、轴线、节点和单元。（参阅"捕捉"）。

使用环境 > 容许误差

容许误差环境对话框

以下视为零

当小于某个定值时看作"0"。

合并重复节点时的容许误差

指定一个公差把小于该公差的若干节点合并成一个节点。这个公差也适用于复制节点。

交叉计算的容许误差

运行交叉计算命令时，指定合并相邻节点和单元的交叉线公差。

使用环境 > 材料和截面

指定材料和截面默认的数据库。

材料和截面数据库对话框

使用环境 > 楼面荷载数据库

数据库中定义的楼面荷载可以在荷载 > 定义楼面荷载类型 中调出。

使用环境 > 结果

设定是否考虑所有包络荷载组合类型的符号。

设定相应的国家规范。

使用环境 > 设计

指定适合不同材料类型和材料特性的结构设计标准。

设计对话框

使用环境 > 注意

指定是否显示注意图窗。

输出格式 > 格式－尺寸和其他

生成分析结果时，指定小数点位数。

格式（尺寸和其他）对话框

若激活"自动"，每个数值的小数位数根据以前由选定单位系统定义的格式由程序自动匹配。若不激活自动状态，用户可以自己指定每个选项的小数点位数。

若激活"指数形式"，忽略指定的小数点位数，所有数值均用指数表达。

输出格式 > 格式－内力

生成分析结果时，指定内力小数点位数。

格式（内力）对话框

输出格式 > 格式－荷载

生成分析结果时，指定荷载的数值形式和小数点位数。

格式（荷载）对话框


03_MGT命令窗口

Home > midas Gen 2017 > 13_工具 > 02_MGT命令窗口

MGT命令窗口

  • 功 能

执行MGT(Midas Gen Text) 格式命令输入模型数据。

通过MGT文件，用户可以更方便的输入模型数据，该数据可以和已有的建模数据整合在一起。用户使用单独建立的MGT文件可以随时输入模型数据，例如节点坐标，材料属性，截面数据，指定位移模式和设计参数等。

  • 命 令

从主菜单中选择工具 > MGT命令窗口...

快捷键： Ctrl+[F12]

  • 输 入

MGT命令窗口

命令或数据

选择要运行的命令。

在命令窗口根据输入格式选择命令，定义在命令中使用的参数。

上图显示了输入节点数据。选择节点之后点击 [image] 。按指定格式在命令窗口输入参数，点击底部 [image] ，可以把材料数据并入到已建模型数据中去。命令窗口中的命令和数据将执行并反应在模型数据中。

关于MGT命令详细参阅用户手册第一册。

在命令窗口中显示和当前指定MGT命令相关的数据，进行总体修正模型数据时点击 [image] 十分有效。对数据进行修改后，点击 [image] 用新的模型数据代替已经存在的数据。

注
如果数据类型不同，那么复制数据和输入多重数据的方法也不相同。
可以向已有数据中添加数据来反映荷载和支撑条件，模型的几何形状，与节点、单元、材料、截面相关的数据均被新数据取代。

根据选定命令删除当前模型数据的内容。

运行命令窗口中输入的内容，并输入模型数据。

在命令窗口中删除输入的内容。


06_截面特性计算器

Home > midas Gen 2017 > 13_工具 > 03_生成器 > 01_截面特性计算器

截面特性值计算器

  • 功 能

截面特性计算器是有效、快速计算复杂截面截面特性的工具。计算出的截面特性可以方便的通过截面输入功能导入到结构模型中。下面总结了SPC(Sectional Property Calculator)的主要方面：

使用输入(Import)功能可以导入AUTOCAD的DXF文件。

各种建模功能简化了数据的输入。

SPC可以对输入的截面进行完全自动的网格划分。

能够计算由不同材料组成的联合截面。

  • 命 令

从主菜单中选择工具 > 截面特性计算器...

  • 输 入

详细使用方法参见SPC 的使用说明。

通过导入Auto Cad DXF文件计算复杂截面的截面特性值

批量计算截面特性值


12_任意截面设计器

Home > midas Gen 2017 > 13_工具 > 03_生成器 > 02_任意截面设计器

任意截面设计器

  • 功 能

任意截面设计器是用于计算任意形状截面的截面特性，相关曲线，弯矩-曲率关系和应力分布的工具。

任意截面设计器可设计的范围：

定义各种不规则形状的截面；

计算截面特性；

生成P-M，P-My-Mz，M-M相关曲线；

计算截面承载力（抗弯），并根据构件内力计算安全系数；

生成弯矩-曲率曲线；

绘制各种截面的应力云图。

上述所有功能均支持钢筋混凝土截面，钢截面和组合截面。

  • 命 令

从主菜单中选择工具 > 任意截面设计器...

  • 输 入

任意截面设计器窗口

GSD窗口

GSD工作步骤

步骤1 ：GSD中定义截面；

步骤2：导出任意截面/截面特性到midas Gen/Civil；

步骤3：midas Gen/Civil中运行分析和设计；

步骤4：导入midas Gen/Civil中构件内力到GSD；

步骤5：任意截面设计（相关曲线，弯矩-曲率曲线，应力云图）

详细内容请参见任意截面设计器帮助文件。


04_材料统计

Home > midas Gen 2017 > 13_工具 > 03_生成器 > 03_材料表

材料统计

  • 功 能

根据所有单元的单元类型、材料类型和截面形状(直线、平面和实体单元)总结生成结构分析中的材料统计。

在预算或者设计阶段，材料统计用来计算材料数量，它还可以有效应用于最优设计阶段，一旦完成结构设计，就可以知道构件重量。

  • 主要功能

- 根据材料特性/截面特性的数量生成材料统计。

- 自动计算构件的长度，面积、重量和体积。

- 区分钢构件的轧制截面和组合截面。

- 根据钢板厚度自动计算组合截面的重量和面积。

- 计算混凝土构件的混凝土体积。

- 提供整个模型中每种材料特性的每种单元形状的重量总计。

- 提供整个模型的重量。

  • 材料统计(B.O.M)输出格式

梁 - 桁架单元材料统计类型1：根据特性编号、截面信息和材料特性划分线单元。

梁 - 桁架单元材料统计类型2：根据截面信息和材料特性划分线单元。

梁 - 桁架单元材料统计类型3：根据截面信息划分线单元。

叠合板单元材料统计类型1：按板厚和材料特性划分钢板叠合线单元。

组合板单元材料统计类型2：仅按板厚和材料特性划分钢板叠合线单元。

板单元材料统计：按板厚和材料特性划分平面单元。

实体单元材料统计：按材料特性划分实体单元。

按材料形成材料统计：按材料特性形成总数量

  • 命 令

从主菜单中选择工具 > 材料统计...

  • 输 入

  1. 选择材料统计对话框，如下图所示。

  2. 对话框中显示了材料统计输出格式列表，表中不显示没有使用的单元类型。

  3. 校核输出格式。

  4. 如果要在输出文件中插入页号，则在"输出选择"中，激活"在输出文件里插入页号"选项。

  5. 在"文件名称"中，用 [image] 键指定存储输出文件的文件名，或者直接输入"文件名"。

  6. 点击 [image] 保存文件，然后自动显示文本编辑器中的内容。

材料统计对话框


05_地震数据生成器

Home > midas Gen 2017 > 13_工具 > 03_生成器 > 04_地震数据生成器

地震数据生成器

  • 功 能

SGSw(视窗下地震数据生成系统)摘录和绘制地震历史记录曲线、地震反应谱曲线、设计反应谱曲线。其中设计反应谱曲线使用MIDAS系列程序内置的地震数据库。

  • 内置的地震历史记录 - 搜集了1940年到1990年北美50多条地震记录。

  • 设计反应谱有10余种，包括

- UBC 88-94建筑统一规范动力部分。

- UBC 1997建筑统一规范动力部分。

- ATC 3-06规定，应用技术理事会。

- Newmark & Hall设计反应谱

- 按韩国建筑学会的结构设计标准制定的设计反应谱(1986、2000)。

- 按韩国公路桥梁标准规范动力设计标准制定的设计反应谱。

  • 命 令

从主菜单中选择工具 > 地震数据生成器...

在MIDAS/Gen文件夹中运行 [image] SGSw.exe。

  • 输 入

  • 文件(File)

打印、保存由SGSw按不同格式生成的各种类型数据，打开以前生成的数据。

  • 生成(Generate)

摘录和绘制地震历史记录曲线、地震反应谱曲线、设计反应谱曲线。其中设计反应谱曲线使用SGSw内置的地震数据库。

  • 选项(Option)

包括曲线的所有选项。

  • 视图(View)

激活视窗选项中的工具条和状态栏，缩小被放大的视窗，在视窗中切换时程曲线和频响曲线。

文件

打开

打开以前生成的SGSw文件。

关闭

关闭当前工作窗口。

保存

在文件中保存当前数据，在[保存类型]中选择文件保存类型。文件允许的扩展名包括文本文件的SGS扩展名，图形文件.BMP、.JPG、.EMF的扩展名。

打印

外部打印图形。页面设置对话框如下图所示，由右面的预览可以控制打印格式，点击 [image] 打印。

打印设置

设置打印机、打印格式和打印方向。

页面设置对话框

生成

地震加速度记录

打开地震历史记录，绘制图形。

选择生成 > 地震记录显示下图所示的地震记录对话框。

选择地震地区地震分量，输入振幅比例和和时间比例，然后点击 [image] 。

把所有生成的数据统一化，加速度用g(重力加速度)表示，初始时间间隔0.02秒。使用振幅比例和时间比例可以改变时间步长和振幅的初始值，之后生成新的数据。当要生成不是程序内置的地震历史记录时，点击 [image] 以[.dbs]格式打开用户自建的数据文件。

地震记录对话框

生成地震反应谱

根据MIDAS/Gen程序自有的地震历史记录或者用户自建的地震数据生成绘制地震反应谱曲线。

生成地震反应谱对话框

    1. 选择地震地区地震分量，输入振幅比例和和时间比例，当要生成的不是程序内置的地震历史记录时，点击 [image] 以[.dbs]格式打开用户自建的数据文件。

    2. 输入阻尼比，如果同时绘制具有不同阻尼比的几条曲线，点击 [image] 来增加阻尼比。

    3. 在输出时间段内输入时间范围和时间步数量。

    4. 在谱类型中选择要生成的谱的类型。

注
激活x轴对数比例，生成沿x轴向的对数比例时间间隔。

设计反应谱

生成绘制设计反应谱曲线。详细菜单如下所示：

- IBC2000(ASCE7-98)

- UBC(1997)

- UBC 88-94

- ATC 3-06

- NBC(1995)

- Eurocode-8(1996) Design

- Eurocode-8(1996) Elastic

- Japan(Arch.2000)

- China(GB5001-2001)

- ChinaShanghai(DGJ08-9-2003)

- China(JTJ004-89)

- China(GB111-87)

- Korea(Arch.2000)

- Korea(Arch.1992)

- Korea(Bridge)

- Newmark & Hall

选择和生成设计反应谱相应的详细菜单，下图是输入设计反应谱数据对话框。输入生成反应谱的所需数据，点击 [image] 生成数据，绘制图形曲线。

设计反应谱数据对话框

选项

从主菜单中选择[选项]，出现如下详细菜单：

如果菜单不适用于当前数据类型，那么菜单不被激活。

X对数刻度：用对数刻度显示图形X轴。

Y对数刻度：用对数刻度显示图形Y轴。

X轴网格：显示图形X轴线网格。

Y轴网格：显示图形Y轴线网格。

对角线网格：沿图形对角线方向显示网格线。

线宽：调整图形曲线的宽度。在粗线和细线之间切换。

单位：改变生成数据的单位。

编辑图形标题：改变图形的标题名称。

视图

从主菜单中选择[视图]，出现如下详细菜单：

如果菜单不适用于当前数据类型，那么菜单不被激活。

恢复全图

当图形被放大的时候，恢复显示初始状态。左击鼠标窗选需放大的部分，右击鼠标恢复放大部分的初始尺寸。

时间<->频率

在图形中观察地震历史记录，图形可以在时程曲线和频响曲线之间切换。频响曲线由快速傅立叶变换计算得到。


07_转换EMF文件为DXF文件

Home > midas Gen 2017 > 13_工具 > 03_生成器 > 05_转换图元文件为DXF文件

转换EMF文件为DXF文件

  • 功 能

将EMF格式的文件转换为AUTOCAD的DXF格式的文件。

  • 命 令

从主菜单中选择工具 > 转换EMF文件为DXF文件...

  • 输 入

在右侧窗口选择相应的EMF文件，点击 [image] ，即将EMF文件转化为DXF文件，用相同的文件名保存。


08_文本编辑器

Home > midas Gen 2017 > 13_工具 > 04_编辑器 > 01_文本编辑器

文本编辑器

  • 功 能

MIDAS文本编辑器和普通文本编辑器类似，支持诸如"新建"、"保存"、"打印"这些在窗口环境下运行的基本功能。而且，它也是一个文件编辑器，可以打开和编辑MIDAS系列程序软件生成的各种类型的文本文件。

  • 命 令

从主菜单中选择工具 > 文本编辑器...

快捷键：[Ctrl]+[F5]

  • 输 入

新建文件

新建：创建一个新文件。

打开：打开一个文本文件。

关闭：关闭当前文件。

保存文件

保存：在使用状态下，按当前文件名保存。

另存为：在使用状态下，用新文件名保存文件。

编辑文件

选择字符

单词：双击相关单词。

点黑字符串：移动鼠标光标到左侧灰色边缘，点击。

点黑几行字符：移动鼠标光标到左侧灰色边缘，向下拖动鼠标。

全选：按[Ctrl]+A 。

垂直选择：按住[Alt]键，拖动鼠标矩形窗口选择。

复制、剪切、粘贴、删除

复制

选中文件指定范围，按[Ctrl]+C或者编辑菜单选"拷贝"把它保存在剪贴板上。

剪切

选中文件指定范围，按 [Ctrl]+X或者编辑菜单选"剪切"。

粘贴

粘贴剪贴板上保存的复制或剪切内容。移动光标至插入位置按按[Ctrl]+V或者编辑菜单选"粘贴"。

删除

选中要删除的部分按[Delete]。

查找和替换

查找文件中指定的字符(目标字符)，然后用新的字符取代目标字符。随意指定选项[全字匹配]、[区分大小写]。

查找

按[Ctrl]+F或者编辑菜单选"查找"，然后出现查找对话框，输入目标字符串，按[F3] 或者点击 [image] 。

替换

按 [Ctrl]+H或者编辑菜单选"替换"显示替换对话框。

移动

使用下列快捷键可以很容易地移动文件内容。
这些命令和视窗操作系统使用的文本编辑器一致。

命令 | 快捷键 | 功能
向上翻页 | PgUp | 前移一页
向下翻页 | PgDn | 后移一页
开头 | Ctrl + Home | 移动光标至起始部分
末尾 | Ctrl + End | 移动光标至末尾部分
前一字符 | Ctrl + ＄ | 光标移动至前一个字符处
下一字符 | Ctrl + ℃ | 光标移动至后一个字符处

书签

在文件特定行设置一个书签，使用"查找书签"可以很容易地发现该位置。

设置书签

移动光标到指定行，点击 [image] 。在左侧页边出现一个书签的蓝色标志。

查找书签

点击 [image] 或者按[F2]可以移动至下一个书签位置。

删除书签

移动光标至书签所在行，点击 [image] 删除该行书签。点击 [image] 删除所有书签。

撤消/恢复

撤消

编辑菜单选择"撤消"，按[Ctrl]+Z 或者点击 [image] 恢复最近所做的操作。

恢复

编辑菜单选择"恢复"，按[Ctrl]+Y 或者点击 [image] 恢复最近撤消命令所取消的操作。

分页符

点击图标插入分页符(♀)，打印时可以表示页面划分情况。分页符(♀)仅在编辑状态下出现，打印或者预览时，新的一页出现分页符。

文件打印

页眉页脚设置

点击图标或者文件菜单选择"页眉页脚设置"，出现页眉页脚设置对话框，在页眉页脚中可以增加文件的说明部分。

打印设置

设置打印机、文件类型和打印方向。

打印预览

打印之前预览文本文件。

当前屏幕可以预览两页内容，可以放大还原屏幕显示的页面大小。

打印

打印当前文件。

其他功能

分割屏幕

激活 [image] 情况下建立文件，将屏幕分割成滚动块，在垂直滚动条的顶部盒水平滚动条的左前方出现小的滚动块，移动这些滚动块，可以将屏幕分割成两部分或者四部分。

选择字体和颜色

选择视窗 > 配置菜单或者点击 [image] 出现"选择字体和颜色对话框"，在对话框中可以改变字体和颜色。

显示表格和制表符

点击 [image] 显示隐藏的表格[`]和制表符[^]。


09_图形编辑器

Home > midas Gen 2017 > 13_工具 > 04_编辑器 > 02_图形编辑器

图形编辑器

  • 功 能

MIDAS图形编辑器是和MIDAS系列程序相连接的矢量图形编辑器，用来编辑打印各种类型的图形文件。图形编辑器可以自由添加和编辑由MIDAS/Gen生成的各种*.BMP和*.EMF(增强图元文件)文件。它还可以为用户生成精确的报告文件，具有和 MS-PowerPoint、Word相类似的绘图功能。

绘图

和大多数图形编辑器类似，MIDAS图形编辑器支持各种绘图功能。

- 直线

- 多边形

- 矩形

- 曲线

- 闭合曲线

- 椭圆(圆)

- 字符

- 位图图形

- 视窗增强图元文件图形

编辑

MIDAS图形编辑器提供了各种编辑功能，用来进行图形处理。

- 选择

- 移动

- 旋转

- 改变尺寸

- 点编辑

- 对齐

- 剪切、复制、粘贴

- 形成组/取消组

- 堆叠命令、Z字形次序

  • 命 令

从主菜单中选择工具 > 图形编辑器...

快捷键：[Ctrl]+[F6]

  • 输 入

绘图

功能 | 说明
绘制直线 | 点击 [image] 绘制直线。左击起始点，拖动鼠标到指定位置。
绘制多义线 | 点击 [image] 绘制多义线。连续点击各点绘制相连线，双击最后一点完成绘制。如果沿途右击鼠标，则取消绘制。
绘制多边形 | 点击 [image] 绘制多边形。点击多边形的各个角点，双击最后一点完成绘制。如果沿途右击鼠标，则取消绘制。
绘制矩形 | 点击 [image] 绘制矩形。点击矩形的左上角，拖动鼠标至右下角。
绘制多义曲线 | 点击 [image] 绘制多义曲线。点击曲线上的控制点，双击最后一点绘制曲线。单根曲线由经过两个控制点的结束点形成。如果沿途右击鼠标，则取消绘制。
绘制闭合曲线 | 点击 [image] 绘制闭合曲线。点击闭合曲线上的控制点，双击最后一点绘制曲线。单根曲线由经过两个控制点的结束点形成。如果沿途右击鼠标，则取消绘制。闭合曲线的表面可以填充颜色。
绘制椭圆 | 点击 [image] 绘制椭圆。椭圆内接于矩形，点击矩形的左上角，拖动鼠标至右下角绘制椭圆
插入文字 | 点击 [image] 插入文字。用鼠标点击指定位置，出现"文字"字符，双击这个字符输入文字。右击鼠标从菜单中选择[属性...]，设置字体和边框。
插入图形 | 点击 [image] 插入图形。然后出现文件对话框，选择图形文件，点击插入位置。插入图形文件以后，可以调整图形文件的大小和位置。

注
当按同样尺寸或者正交方式绘制一个特殊单元时，按住[Shift] 键绘制该单元。

编辑

选择

图形编辑器基本处于一个选择模式下。若未处于该模式下，点击 [image] 切换至该模式。在选择模式下，点击需要选择的物体。如果要选择若干物体，左击并拖动鼠标选择，或者按住[Ctrl]键在点击各个物体，最后被选中的物体成为"参照物"，并且端点变成灰色，和其他选中的物体相区别。参照物也可以作为对齐功能的参照。如果要改变参照物，按住[Ctrl]键，点击新的参照物。如果在几个物体中没有选择合适的参照物，那么按住 [Shift] 键点击合适的物体作为参照物。

移动

在选择模式下，将光标移动到物体的中心，光标切换成移动模式。此时，左击拖动鼠标移动物体至指定位置。如果激活格栅捕捉选项，那么沿格栅捕捉点移动物体。

要准确移动物体，使用移动图标更为有效。点击一次与移动方向一致的图标，移动物体一个单位。按住 [Shift] 键点击鼠标，一次移动5个单位。

对齐

使用对齐功能可以很容易地排列物体。如果选中几个物体，以带灰色端点的参照物为对齐基准。

上述按钮依次代表：

顶部对齐

水平中心对齐

底部对齐

左对齐

垂直中心对齐右对齐

对齐间距图标可以按规定间距重排物体。

等水平间距

等垂直间距

尺寸对齐图标可以把选中的所有物体调整成同样大小。如果选中几个物体，那么带灰色端点的参照物成为尺寸基准。

调整水平尺寸

调整垂直尺寸

同时调整水平/垂直尺寸

旋转

点击旋转图标，旋转选中的物体。

旋转图标包括"自由旋转"、"左旋90° "、"右旋90° "、"水平对称旋转"、"垂直对称旋转"几个功能。当选择"自由旋转"的时候，移动光标至选中物体，光标变成一个图标，此时点住鼠标左键，移动鼠标自由旋转物体。

改变尺寸

如果想改变选中物体的尺寸，可以把光标移动到物体的端点处，光标变成一个双箭头符号，就可以改变物体的尺寸了。根据选择的端点，可以左/右、垂直、左/右/垂直改变尺寸。

形成组/取消组

选择几个物体，点击 [image] (形成组)，把选中的几个物体合并成一个物体。

要解除形成的组，点击 [image] (取消组)，根据形成组的顺序，按照逆序从最后一个组逐个取消组。

形成组/取消组也可以通过在选中物体上右击鼠标出现的鼠标右键菜单中选择。

叠放次序

按照特殊的叠放次序显示堆叠的物体，称为Z字形次序。具有最高次序的物体置于顶层，较低顺序的物体放置在较高顺序物体的下层。这种顺序依据物体建立的顺序，点击叠放次序图标可以改变这种顺序。

叠放次序的功能包括"置于顶层"、"置于低层"、"上移一层"、"下移一层"。叠放次序也可以通过在选中物体上右击鼠标出现的鼠标右键菜单中选择。

点编辑

点击 [image] 点编辑来切换点编辑命令。各个端点移动到物体的组成点上。

移动点

在点编辑模式下，把鼠标移动到端点处，光标形状变成允许移动的符号，左击拖动组成物体的点。

插入点

如果在两个端点之间按住[Ctrl]键，光标变成插入状态，左击鼠标插入点。这种情况仅适用于由无限点组成的物体，比如曲线和连续直线。

删除点

在一个点上按住[Ctrl]键，光标变成"X"形，表示处于删除状态，左击鼠标删除该点。这种情况仅适用于由无限点组成的物体，比如曲线和连续直线。

改变组成成分特性

选择要改变性质的物体点击 [image] (改变组成成分特性)，或者在物体上右击鼠标在鼠标右键菜单中选择[属性...] ，然后出现下图所示的改变组成成分特性对话框，设置与物体有关的详细属性。各种属性(线型颜色和宽度，外表颜色，等)均可以选择或者改变。

改变组成成分特性

其他功能

撤消/恢复

在图形编辑器中可以按照最近顺序恢复/再执行撤消/恢复命令。

格栅显示和格栅捕捉

点击格栅显示图标显示或者隐藏格栅点。点击格栅捕捉用来捕捉所有临近格栅点的节点。

缩放，窗口充满，选定范围充满

缩放

点击缩放来进行窗口放大。当光标变成一个放大镜时，左击可以按照特定比例放大。如果左击拖动鼠标选定范围，那么这个范围充满整个窗口。

窗口充满

放大/还原窗口中的所有物体，可以尽量大的显示所有物体。

选定范围充满

放大/还原当前所选物体，可以尽量大的显示所选物体。

文件功能

新建

建立一个空白图形文件。

打开

可以打开*.MGF(MIDAS图形格式)、*.BMP格式、*.EMF格式的图形文件。

保存

保存图形文件。可以保存*.MGF(MIDAS图形格式)、*.BMP格式、*.EMF格式的图形文件。

打印机设置

设置打印机、页边距、类型和文件打印方向等。

打印预览

在实际打印前预览打印形式。

打印

实际打印图形。


10_用户定制

Home > midas Gen 2017 > 13_工具 > 05_用户自定义 > 01_用户自定义

用户定制

  • 功 能

选择选项，在屏幕上显示树形菜单视窗、信息窗口和状态条，设置工具条的详细选项，为经常使用的功能设置快捷键，或者对设置进行修改或者删除。

  • 命 令

从主菜单中选择工具 > 用户定制 > 树形菜单

从主菜单中选择工具 > 用户定制 > 信息窗口

从主菜单中选择工具 > 用户定制 > 工作面板

从主菜单中选择工具 > 用户定制 > 状态条

从主菜单中选择工具 > 用户定制 > 工具条...

从主菜单中选择工具 > 用户定制 > 快捷键...

  • 输 入

    命令

可以采用拖放的方法将常用的命令拖到工具栏。同理也可以通过将相应工具按钮拖到工具栏之外的方法，将该工具按钮删除。

菜单对话框

Categories：选择需要修改命令所属的主菜单；

Commands:选择命令，将其拖放到工具栏指定位置。

Description：所选命令的简要描述

工具栏

对话框中罗列了可使用的工具条。检查工具条前面是否有? ?，有? ?表示该工具条在模型视窗里处于激活状态。

工具栏对话框

：恢复工具条为初始状态。

：恢复所有工具条为初始状态

键盘

用户可对各命令手动定义快捷键。

键盘对话框

类型

选择一个要添加或者修改快捷键的主菜单功能组。

命令

在"类型"中选择的主菜单功能组中的子菜单将显示在这里。从中选择一个快捷键要代表的功能。

当前快捷键

列出选择的功能已经分配的快捷键。

输入新的快捷键

通过键盘输入新的快捷键。如果该快捷键已经分配给其它功能，则该功能将显示在窗口下方。

: 分配快捷键。

: 删除分配的快捷键。

: 将全部快捷键重置为默认值。

注

指定快捷键时，单个字符或者仅与[Alt]组合，可能会由于工作环境的不同而无法正常使用。所以推荐用户使用类似[Ctrl], [Shift], [Ctrl]+[Alt], [Ctrl]+[Shift]的组合。数字小键盘上的数字与普通的数字是不同的，因此当用户使用这些数字定义快捷键时，可能会与操作系统相互冲突而无法正常使用。

菜单

菜单对话框

菜单：菜单下拉菜单的类型（可选类型：None=default，Unfold，Slide和Fade）

菜单阴影：为下拉菜单设置阴影效果。

选项

选项对话框

显示工具栏提示：当鼠标放在工具按钮上时，是否显示该图标的解释


11_全屏

Home > midas Gen 2017 > 13_工具 > 05_用户自定义 > 02_全屏

全屏

  • 功 能

模型窗口在整个屏幕上居中显示。

  • 命 令

从主菜单中选择工具 > 全屏...

快捷键: [Ctrl]+[U]


01_登记注册

Home > midas Gen 2017 > 14_登记注册

登记注册

  • 功 能

输入软件加密锁的注册密钥号。安装好的软件，只有输入注册密钥号才可以使用。

  • 命 令

从主菜单中选择帮助 > 登记注册...

  • 输 入

保护锁号：注册密钥号。向北京迈达斯技术有限公司索取，Tel: 010-51659908。

保护锁类型：分为网络版和单机版两种。

当选择"网络版"时：

网络协议：TCP/IP

服务器名称或服务IP地址：服务器IP为动态IP时，输入Localhost 或者 127.0.0.1；当服务器为固定IP时，输入真实IP地址。


03_目录

Home > midas Gen 2017 > 15_帮助 > 01_目录

目录

  • 功 能

通过目录在帮助文件中查找帮助信息。

  • 命 令

从主菜单中选择帮助 > 目录...


06_显示开始页

Home > midas Gen 2017 > 15_帮助 > 02_显示开始页

显示开始页

  • 功 能

显示打开软件时的初始界面。

  • 命 令

从主菜单中选择帮助 > 显示开始页...

  • 输 入


07_关于MIDAS/Gen

Home > midas Gen 2017 > 15_帮助 > 03_关于midas Gen

关于midas Gen

  • 功 能

显示机器上安装的midas Gen软件的相关信息。

  • 命 令

从主菜单中选择帮助 > 关于midas Gen...

  • 输 入


03_定义荷载组

Home > 03_定义荷载组

定义荷载组

  • 功 能

将一些荷载组成一个荷载组，以便于建模、修改和输出,也可以编辑和删除已建立的荷载组。

对复杂的模型，当分析和设计中需要反复使用某些荷载时，可以将其定义为一个荷载组，然后可以直接使用该荷载组名称进行选择(选择属性)，或只激活该荷载组(激活属性)。该功能可以用于定义桥梁各施工阶段的荷载。

在生成荷载组之前，需要先定义荷载组的名称。然后在树形菜单的组表单中使用拖放功能将节点和单元赋予相应的荷载组。

  • 命 令

从主菜单中选择模型 > 组 > 定义荷载组...

在树形菜单的菜单表单中选择模型 > 组 > 定义荷载组...

在树形菜单的组表单中利用荷载组的关联菜单

  • 输 入

定义荷载组名称对话框

名称:输入要建立的荷载组的名称。

后缀:当需要同时建立多个荷载组时，可以在荷载组名称后面加上数字后缀。

:建立新的荷载组名称。

:修改选中荷载组的名称。

:删除选中荷载组的名称。

:删除没有选中的荷载组名称。

:关闭该对话框。

:按升序重新排列荷载组名称。

:按降序重新排列荷载组名称。

:选中一个或多个荷载组名称向上移动。

:选中一个或多个荷载组名称向下移动。

注1
可以在树形菜单的组表单中，点击右键，在弹出的关联菜单选择相应的命令操作。

首先使用选择功能选择相应的节点和单元，然后用鼠标选择相应的荷载组，将其拖放到模型窗口内，则选择的节点和单元将被分配到相应的荷载组中。

在组表单中，在相应荷载组上点击右键，在弹出的关联菜单选择分配或再分配时，将弹出选择荷载类型对话框。选择相应的荷载工况，点击

，则相应的荷载工况将被赋予该荷载组。

该功能主要用于使用一般功能赋予荷载组内容时。使用建模助手时，各荷载组内的荷载工况内容均已被自动定义。

注2
使用荷载组重复定义某一节点或单元上的荷载时，在分析过程中，将按阶段适用不同的荷载。


13_渲染选项

Home > 13_渲染选项

渲染选项

  • 功 能

控制不同的光源选项，处理模型阴影。在渲染视图中，为漫游效果执行各种视图处理命令。

  • 命 令

从主菜单中选择视图 > 渲染选项

在图标菜单中单击 [image] 渲染选项

  • 用 法

模型窗口模式

光源：在对话框中单击图形区，并拖动鼠标，调整光源的位置。

打开光源: 确定是否使用阴影效果。

打开镜反射: 确定是否使用镜面反射效果。

注:
镜面灯光效果在后处理模式中会扭曲等值线颜色。

周边光：可以均匀控制模型各面的亮度，与光源的位置无关。

分散光：控制目标的亮度，使垂直于光源的表面更亮。

反射光：控制镜面反射效果，使与视线方向一致的反射光部分变亮。反射成分默认为白色，因此反射部分的颜色接近于白色。

反射强度：控制反射成分的亮度，较大数值时表示反射部分的范围较广。

渲染窗口模式

光源：在对话框中单击图形区，并拖动鼠标，控制光源的位置。

激活: 确定是否使用阴影效果。

周边光：可以均匀控制模型各面的亮度，与光源的位置无关。

分散光：控制目标的亮度，使垂直于光源的表面更亮。

反射光：控制镜面反射效果，使与视线方向一致的反射光部分变亮。反射成分默认为白色，因此反射部分的颜色接近于白色。

反射强度：控制反射成分的亮度，较大数值时表示反射部分的范围较广。

漫游

执行移动、旋转和缩放/漫游功能。


23_显示选项

Home > 23_显示选项

显示选项

  • 功 能

显示选项用于修改在模型窗口中显示的图形、字符串或符号的表现形式。

显示选项中的设定值会注册到Windows的注册表中，因此即使结束或重新启动程序，这些值也将保持不变。

主要功能如下：

字体表单 ：指定字体、大小、颜色和形状等。

颜色表单 ：指定屏幕上节点、单元、各种属性(材料特性、截面、荷载、边界条件等)和分析结果的显示颜色。

打印颜色表单 ：指定打印输出时的节点、单元、各种属性和分析结果的打印颜色。

尺寸表单 ：指定各属性标签的显示尺寸大小以及与视图操作相关的有关功能的显示状态。

绘图表单 ：选择各种模型表现形式。

  • 命 令

从主菜单中选择视图 > 显示选项...

在图标菜单中单击 [image] 显示选项

  • 用 法

<图1>显示选项对话框

字体

在左侧树形菜单中选择要修改表示形式的条目，在右侧设置表中指定字体、大小和颜色等。

  • 节点

节点号：节点编号。

节点输出值：节点位移、反力等数值。

节点局部坐标轴：表示节点局部坐标轴方向的文字。

  • 单元

号码/属性名称：单元编号、类型和名称，材料/截面/厚度的编号和名称。

单元输出值：单元内力、应力等数值。

设计标志：显示设计参数。

局部坐标轴：单元局部坐标轴。

等值线标注：等值线边界上的标注文字。

  • 荷载

荷载值：各种形式荷载的数值。

  • 边界条件

弹性，一般连接轴：表示弹性/非线性连接单元的单元局部坐标轴的文字。

尺寸：表示尺寸的文字。

信息条：在信息窗口显示的各种信息。

MGT命令窗口：在MGT命令窗口中表达的字符串。

打印：打印时使用的字体等。

节点

节点号：节点编号。

节点输出值：节点位移、反力等数值。

节点局部坐标轴：表示节点局部坐标轴方向的文字。

单元

号码/属性名称：单元编号、类型和名称，材料/截面/厚度的编号和名称。

单元输出值：单元内力、应力等数值。

设计标志：显示的设计参数。

局部坐标轴：单元局部坐标轴。

等值线标注：等值线边界上的标注文字。

荷载

荷载值：各种形式荷载的数值。

边界条件

弹性连接轴：表示弹性连接单元的单元局部坐标轴的文字。

水化热：与水化热分析相关的文字和数值。

尺寸：表示尺寸的文字。

字体：改变字体类型。

大小：改变字体大小。

文字颜色：改变字体颜色。

背景颜色：选择不透明选项后为字符串的背景颜色。

透明：将字符串背景设为透明，使标签与背景图像协调。

不透明：将字符串背景设为不透明，使标志亮显。

：改变字体、字形、大小、效果、颜色、语种等。

：对选择的项目使用MIDAS/Gen提供的默认值。

：对相应表单中的所有选择项目使用MIDAS/Gen提供的默认值。

颜色表单

在左侧树形菜单中选择要改变屏幕显示颜色的条目，然后在右侧设置表中指定显示颜色。

视图

上部背景：工作窗口的上部背景颜色。

下部背景：工作窗口的下部背景颜色。

点格：点栅格的颜色。

轴线：轴线的颜色。

光标：鼠标光标的颜色。

用户坐标系符号：用户坐标系UCS符号的颜色。

信息窗口

背景：信息窗口的背景颜色。

命令行：信息窗口命令行的颜色。

树形菜单

背景：树形菜单的背景颜色。

背景标题：树形菜单标题的颜色。

节点

标准：节点的颜色。

被选后：被选中的节点的颜色。

局部坐标系x轴：节点局部x轴的颜色。

局部坐标系y轴：节点局部y轴的颜色。

局部坐标系z轴：节点局部z轴的颜色。

钝化：被钝化的节点的颜色。

单元

单元可以用同一种颜色，也可以根据单元类型和使用材料特性着色。这种按类型分别着色的操作可通过绘图表单中的选择颜色来设定。

一般：指定全部单元为唯一的颜色。

线框架：在线框图中表示的单元颜色。

消隐：消隐处理后的表面的颜色。

消隐边界：消隐处理后的表面边界的颜色。

下列各种单元可以指定单独的颜色：

桁架单元

梁单元

平面应力单元

板单元

墙单元

平面应变单元

轴对称单元

实体单元

只受拉桁架单元

只受压桁架单元

注
当在绘图表单中的选择颜色中选择单元颜色时，以上不同单元类型的指定颜色方可应用到模型的颜色中。

符号：表示线单元横截面形状的颜色以及间隙，钩，索单元的颜色。

被选后：被选中的单元的颜色。

钝化：被钝化的单元的颜色。

变形前：当同时显示已变形的和未变形的模型形状时，未变形的模型形状的颜色。

单元坐标系x轴：单元坐标系x轴的颜色。

单元坐标系y轴：单元坐标系y轴的颜色。

单元坐标系z轴：单元坐标系z轴的颜色。

局部方向：显示建立单元时节点输入次序的颜色。

自由面/边：板单元或实体单元自由边或自由面的颜色。

铰特性值

非弹性铰-开：6个自由度中，表示设置了非弹性铰的自由度的符号颜色。

铰特性

非弹性铰-关：6个自由度中，表示没有设置非弹性铰的自由度的符号颜色。

非弹性铰-边：表示非弹性铰符号边的颜色。

质量

指定质量输入状态符号的颜色。

节点质量(开)：6个自由度中，表示输入了节点质量的自由度的符号颜色。

节点质量(关)：6个自由度中，表示没有输入节点质量的自由度的符号颜色。

节点质量符号轮廓：节点质量符号轮廓的颜色。

荷载变质量(开)：由荷载转变为节点质量的方向的颜色。

荷载变质量(关)：选择由荷载转变为节点质量的方向时，未被选中的方向的颜色。

荷载变质量符号轮廓：由荷载转变为节点质量的符号的轮廓的颜色。

刚性楼板质量(开)：6个自由度中，表示输入了刚性楼板质量的自由度的符号颜色。

刚性楼板质量(关)：6个自由度中，表示没有输入刚性楼板质量的自由度的符号颜色。

刚性楼板质量符号轮廓：刚性楼板质量符号轮廓的颜色。

层质量填充：层质量的颜色。

层质量轮廓：层质量轮廓的颜色。

荷载

根据荷载类型指定颜色。

节点体力填充：节点体力箭头的颜色。

节点体力边：节点体力轮廓的颜色。

节点荷载标志：节点荷载箭头的颜色。

节点荷载标志轮廓：节点荷载箭头轮廓的颜色。

强制位移(开)：6个自由度中，表示输入了强制位移的方向符号的颜色。

强制位移(关)：6个自由度中，表示未指定强制位移的方向符号的颜色。

强制位移符号轮廓：强制位移符号轮廓的颜色。

梁单元荷载标志：梁单元荷载箭头的颜色。

梁单元荷载标志轮廓：梁单元荷载箭头轮廓的颜色。

压力荷载标志：压力荷载箭头的颜色。

压力荷载标志轮廓：压力荷载箭头轮廓的颜色。

楼面荷载标志：楼板荷载箭头的颜色。

楼面荷载标志轮廓：楼板荷载箭头轮廓的颜色。

装饰材料荷载标志：装饰材料荷载箭头的颜色。

装饰材料荷载轮廓：装饰材料荷载箭头轮廓的颜色。

楼板荷载名称区域：楼板荷载作用范围的颜色。

楼板荷载名称轮廓：楼板荷载作用范围轮廓的颜色。

注
在楼板荷载名称区域中设定的颜色只有将绘图表单中的楼板荷载颜色选择颜色设定为全局颜色时方可显示在模型中。

平面荷载标志：平面荷载箭头的颜色。

平面荷载标志轮廓：平面荷载箭头轮廓的颜色。

平面荷载名称区域：平面荷载作用范围的颜色。

平面荷载标志轮廓：平面荷载作用范围轮廓的颜色。

预应力荷载标志：预应力荷载箭头的颜色。

预应力荷载标志轮廓：预应力荷载箭头轮廓的颜色。

初拉力标志：初拉力荷载箭头的颜色。

初始张拉标志轮廓：预拉荷载箭头轮廓的颜色。

节点温度荷载标志：节点温度荷载箭头的颜色。

节点温度荷载标志轮廓：节点温度荷载箭头轮廓的颜色。

单元温度荷载标志：单元温度荷载箭头的颜色。

单元温度荷载标志轮廓：单元温度荷载箭头轮廓的颜色。

温度梯度荷载：温度梯度荷载标志的颜色。

梁截面温度标志：梁截面温度标志的颜色。

风荷载标志：风荷载箭头的颜色。

风荷载标志轮廓：风荷载箭头轮廓的颜色。

地震荷载标志：地震作用箭头的颜色。

地震荷载标志轮廓：地震作用箭头轮廓的颜色。

节点动力荷载标志：时程分析时输入的节点动力荷载箭头的颜色。

节点动力荷载标志轮廓：时程分析时输入的节点动力荷载箭头轮廓的颜色。

多支座激振-开：6个自由度中，表示输入了多支座激振的方向符号的颜色。

多支座激振-关：6个自由度中，表示未输入多支座激振的方向符号的颜色。

多支座激振-边：多支座激振符号轮廓的颜色。

预应力钢束

指定钢束布置的颜色。

预应力钢束布置形状：显示钢束布置的线的颜色。

控制点：为了定义钢束布置形状而输入的控制点的颜色。

被选择的钢束布置形状：被选择的钢束布置形状的线的颜色。

尺寸

尺寸线：显示尺寸线的颜色。

边界条件

指定表示边界条件的符号的颜色。

约束(开)：6个自由度中，被约束的自由度的颜色。

约束(关)：6个自由度中，没有被约束的自由度的颜色。

约束标志轮廓：表示约束的符号轮廓的颜色。

支承方向边：各方向支承显示中支承符号边的颜色。

支承方向填充：各方向支承显示中支承符号的颜色。

弹性支撑(开)：6个弹性支承条件自由度中，输入了弹性支撑条件的符号的颜色。

弹性支撑(关)：6个弹性支承条件自由度中，未指定弹性支撑条件的符号的颜色。

弹性支撑标志轮廓：节点弹性支撑标志的轮廓的颜色。

非线性弹性支承打开：在一般弹性支撑中，在刚度矩阵的6个对角线成分中输入了支承刚度的标志的颜色。

非线性弹性支承关闭：在一般弹性支撑中，在刚度矩阵的6个对角线成分中未输入支承刚度的标志的颜色。

弹性支承面：弹性支承面标志符号的颜色。

节点多线性弹性支撑(开)：6个节点多线性弹性支承条件自由度中，输入了弹性支撑条件的符号的颜色。

节点多线性弹性支撑(关)：6个节点多线性弹性支承条件自由度中，未指定弹性支撑条件的符号的颜色。

节点多线性弹性支撑标志轮廓：节点多线性弹性支撑标志的轮廓的颜色。

点支承方向边：6个点支承条件自由度中，输入了点支承条件的符号边的颜色。

点支承方向填充：6个点支承条件自由度中，输入了点支承条件的符号的颜色。

点支承方向边（抗压/抗拉）：6个抗压/抗拉点支承条件自由度中，输入了点支承条件的符号边的颜色。

点支承方向填充（抗压/抗拉）：6个抗压/抗拉点支承条件自由度中，输入了点支承条件的符号的颜色。

点支承方向边（多折线）：6个多折线点支承条件自由度中，输入了点支承条件的符号边的颜色。

点支承方向填充（多折线）：6个多折线点支承条件自由度中，输入了点支承条件的符号的颜色。

面支承（框架）：面支承（框架）的符号颜色。

面支承（平面/线）：面支承（平面/线）的符号颜色。

面支承（平面/面）：面支承（平面/面）的符号颜色。

面支承（实体/面）：面支承（实体/面）的符号颜色。

一般弹性支承(开)：6个节点一般弹性支承条件自由度中，输入了弹性支承条件的符号的颜色。

一般弹性支承(关)：6个节点一般弹性支承条件自由度中，未指定弹性支承条件的符号的颜色。

一般弹性支承标志轮廓：一般弹性支承标志的轮廓的颜色。

梁端刚域：梁端刚域符号的颜色。

释放梁/板端约束标志：表示释放梁/板端约束的符号的颜色。

刚性连接：刚性连接(主节点和从属节点之间)符号的颜色。

线性约束：线性约束符号的颜色。

层刚性楼板：层刚性楼板符号的颜色。

车道：车道符号的颜色。

连续车道支座：连续车道支座符号的颜色。

车道面：车道面符号的颜色。

车道面中心线：车道面中心线的颜色。

主节点：在刚性楼层显示中主节点符号的颜色。

弹性连接：弹性连接单元的颜色。

弹性连接x轴：弹性连接单元的局部坐标系x轴的颜色。

弹性连接y轴：弹性连接单元的局部坐标系y轴的颜色。

弹性连接z轴：弹性连接单元的局部坐标系z轴的颜色。

一般连接：一般连接单元的颜色。

一般连接x轴：一般连接单元的局部坐标系x轴的颜色。

一般连接y轴：一般连接单元的局部坐标系y轴的颜色。

一般连接z轴：一般连接单元的局部坐标系z轴的颜色。

修改一般连接特性值：修改了的一般连接特性值的颜色。

水化热

指定与水化热有关的数据符号的颜色。

对流边界：表示对流边界的符号轮廓的颜色。

对流边界标志：对流边界的符号的颜色。

图例

指定显示有各种输出结果参照事项的图例的颜色。

绘图颜色：图例窗口中分割线的颜色。

文字颜色：图例窗口中文本的颜色。

分析结果

在显示分析结果的模型窗口中，指定下列各项的颜色：

板剖断线颜色：在查看板分析结果时，在显示形式中选择了剖断面时，在板单元上显示的剖断线的颜色。

板剖断面颜色：在查看板分析结果时，在显示形式中选择了剖断面时，在板单元上显示的剖断面的颜色。

梁单元/墙单元颜色：将梁/墙单元内力图按单一颜色表示时的颜色。

移动荷载轨迹节点荷载：使用移动荷载追踪器查出的节点集中荷载的符号(箭头)的颜色。

移动荷载轨迹分布荷载：使用移动荷载追踪器查出的分布荷载的符号(箭头)的颜色。

设计

构件：构件的颜色。

Pushover铰-开：6个自由度中，设定了Pushover铰的自由度的颜色。

Pushover铰-关：6个自由度中，未设定Pushover铰的自由度的颜色。

Pushover铰-边：Pushover铰符号边的颜色。

子区域布筋方向1：子区域布筋方向1的颜色。

子区域布筋方向2：子区域布筋方向2的颜色。

材料

该项只有在输入了材料特性时方在表单中显示。

按材料类型设定单元的颜色。

线框架：用线框架表示单元的颜色。

消隐：消隐面的颜色。

消隐轮廓：消隐面轮廓的颜色。

透明：调整被赋以颜色的单元的透明度。

注
1、当在绘图表单中的选择颜色中选择材料颜色时，在此项中指定的颜色才可显示到模型的颜色中。

2、截面、厚度、楼面荷载类型三项说明及应用条件同材料项。

选择值

颜色：改变颜色。

：指定用户定义的颜色。

基本选择

：将模型窗口背景设为黑色，其它部分使用MIDAS/Gen提供的默认颜色。

：将模型窗口背景设为白色，其它部分使用MIDAS/Gen提供的默认颜色。

：打开一个颜色文件：文件名.color，并将它作为当前颜色。

：将颜色文件保存为：文件名.color。

：选中的条目使用MIDAS/Gen提供的默认颜色。

：相关表单中所有被选中的条目均使用MIDAS/Gen提供的默认颜色。

打印颜色表单

在左侧树形菜单中选择要修改打印颜色的条目，然后在右侧设置表中指定打印颜色。

用法参见颜色表单。

尺寸表单

标志符号：控制符号和标志的大小。

缩放：控制放大或缩小的比例。

移动：控制移动距离。

旋转：控制旋转角度的比例。

收缩：控制单元收缩的比例。

透视：控制视点的位置。

绘图表单

在该项表单中将决定在颜色表单中指定的颜色的表现方法(基本颜色、单元颜色、材料颜色、截面颜色等)、消隐面的处理方法、显示厚度与否、被捕捉或被选择的目标的表现方式、打印时使用的颜色、节点和单元钝化时的表现方式、剪力和弯矩图的表现方式等。

单元颜色：指定在屏幕上显示单元时的颜色选择方法。

基本颜色：使用在颜色表单?单元?条目中的?一般?中定义的颜色。

单元颜色：使用在颜色表单?单元?条目中对不同单元类型(桁架、梁等)定义的颜色。

材料颜色：使用在颜色表单中?材料?条目中对不同材料定义的颜色。

截面颜色：使用在颜色表单中?截面?条目中对不同截面定义的颜色。

：随机采用单元、材料、截面/厚度项中定义的颜色。

：恢复使用随机颜色项前定义的颜色。

消隐选项(模型)

填充：对单元的消隐面使用在颜色表单中定义的颜色。

轮廓线：单元消隐时，只表示在颜色表单中定义的轮廓颜色，消隐面颜色取背景颜色。

外轮廓线+填充：给所有的消隐面和轮廓着色。

杆系的厚度：显示组成线单元截面的各成分的厚度(如工字钢腹板和翼缘的厚度)。

板单元厚度：显示板单元的厚度。

消隐选项(变形前)

线框架：显示变形形状时，将变形前的模型仅用线框架表示。

轮廓线：显示变形形状时，仅用单元轮廓表示变形前的模型。

杆系的厚度：显示变形的形状时，变形前的模型将显示组成线单元截面的各成分的厚度(如工字钢腹板和翼缘的厚度)。

板单元厚度：显示变形的形状时，变形前的模型将显示板单元的厚度。

线框选项

阴影处理实体和平面单元：勾选该项表示在线框图中以阴影形式显示实体和平面单元。

混色：选择是否混色。

系数：选择混色单元的透明比例系数。

捕捉/选择显示线：调整捕捉单元时单元局部坐标轴的显示线宽以及单元被选择时单元的线的宽度。

线框架模型线宽：用线框架图显示模型时，表示捕捉或选择的线的宽度。

隐藏线模型线宽：用消隐方式显示模型时，表示捕捉或选择的线的宽度。

显示单元坐标轴：指定是否显示被捕捉单元(或节点)的单元编号(或节点编号)以及被捕捉单元的单元局部坐标轴。

注
单元局部坐标轴按建立单元过程中输入节点的次序显示。

打印颜色选项

黑/白打印：以黑/白色打印。

彩色打印(视图)：使用在颜色表单中定义的颜色打印。

彩色打印(设定)：使用在打印颜色表单中定义的颜色打印。

被钝化的目标：指定被钝化的节点和单元的表示方法。

显示单元、节点：将被钝化的节点和单元按在颜色表单中?单元?条目中的钝化项中定义的颜色表示轮廓线。

考虑对齐缩放：对齐缩放时，考虑用轮廓表示的被钝化的节点和单元，即用轮廓表示的被钝化的节点和单元也将被对齐缩放。

梁/墙单元内力图：指定梁/墙单元的剪力/弯矩图的绘制方向。

反转弯矩图：颠倒弯矩图的绘制方向，使正值和负值颠倒。

反转剪力图：剪力图的绘制方向颠倒至单元局部坐标轴的反方向。

SRC中混凝土外轮廓线：指定SRC构件中混凝土部分的外轮廓线的宽度。

动态标签：输入模型数据时(如荷载、边界条件等)，即时显示所输入的数据的标志(如荷载箭头、边界符号等）的功能。

楼面荷载颜色：设定在颜色表单中?荷载?条目中的楼面荷载名称项中定义的颜色表现形式。

单元线宽：定义单元线宽度。

：选中的条目使用MIDAS/Gen提供的默认值。

：在当前表单中选中的所有条目使用MIDAS/Gen提供的默认值。

：所有显示选项均使用MIDAS/Gen提供的默认值。